精华内容
下载资源
问答
  • Windows上构建DHCP Server

    万次阅读 2018-06-09 15:51:43
    转载请注明出处~~~ 如果计算机不是安装的windows Server版操作系统,搭建DHCP可以... 下载地址: https://sourceforge.net/projects/dhcpserver/, 这个软件的优点是只有1MB左右大小,运行起来不占用CPU等系...

        转载请注明出处~~~

        如果计算机不是安装的windows Server版操作系统,搭建DHCP可以使用Open DHCP Server软件,这个软件有windows版本和Linux版本。这里介绍windows版本。

        下载地址: https://sourceforge.net/projects/dhcpserver/, 这个软件的优点是只有1MB左右大小,运行起来不占用CPU等系统资源。

        注意软件安装最好不要安装在C盘(默认),因为有可能找不到配置文件,这里安装在E盘,打开配置文件OpenDHCPServer.ini文件即为配置文件,在配置文件中可以设置DHCP服务相关参数。

        在修改配置文件前,先在windows服务下面使能Open DHCP Server服务。win+R -->services.msc

        配置文件中,[HTTP_INTERFACE]部分如果不被设置,那么在浏览器输入http://127.0.0.1:6789即可查看当前DHCP客户端信息,比如IP地址租约到期时间(一般DHCP Client的DHCP程序都会自动租约到期前1半时间向DHCP Server请求续租,续租成功后http://127.0.0.1:6789租约时间会更新),另外还显示DHCP可自动分配的IP地址范围等信息。

        配置文件中,如果使用简单配置,那么安装完这个软件后所有配置都不需要修改,把安装这个软件的计算机ip设为静态IP,一般为192.168.0.xx,然后连接到交换机上,其他计算机就可以DHCP了。

        如果修改配置,比如修改[RANGE_SET]部分为:

    DHCPRange=192.168.1.100-192.168.1.254

    1=255.255.255.0

    6=192.168.1.1,192.168.1.2

    3=192.168.1.1  //网关

    51=60    //租约时间

        然后再把PC机ip设置为192.168.1.xx网段后,连接PC机网络到交换机,交换机其他端口就可以获取192.168.1.xx网段的DHCP IP地址了。

        这个软件安装后,一般运行RunStandAlone.bat脚本。

        如果把一台嵌入式设备连接到具备DHCP server的上述网络中,在嵌入式设备上使能DHCP功能,在运行有DHCP Server的计算机上用网络抓包工具抓包,会发现DHCP client会依次每隔30秒、15秒向DHCP Server续租。

       如果想停止DHCP Server,只需要关闭windows端的(RunStandAlone.bat)cmd.exe即可。如果server退出,嵌入式设备上的DHCP client请求不到server的ack,那么客户端的dhcp进程会退出,以前的ip将不能使用。










    展开全文
  • window10上搭建open DHCP server

    千次阅读 2021-02-26 10:42:25
    个人电脑上正常是不自带DHCP server,晚上查找win10是可以通过自带的“管理可选功能”安装dhcp server。... 本文采用了open DHCP server软件搭建dhcp服务...官网下载地址:https://sourceforge.net/projects/dhcpserver/

    个人电脑上正常是不自带DHCP server,晚上查找win10是可以通过自带的“管理可选功能”安装dhcp server。https://jingyan.baidu.com/article/4f34706ef5432ea286b56d34.html(亲试后我的电脑上没有找到)

    本文采用了open DHCP server软件搭建dhcp服务,这个软件的优点是只有1MB左右大小,运行起来占用资源少。

    官网下载地址:https://sourceforge.net/projects/dhcpserver/

    备用下载地址:https://download.csdn.net/download/weixin_43777852/15479793

     

    安装

    根据网上的资料,open dhcp server 最好不要安装在C盘。这里我安装在了D盘

    安装后的目录:

    OpenDHCPServer.ini文件即为配置文件,后面我们会配置这个文件

    使能Open DHCP Server服务

    运行services.msc

    服务里面多了Open DHCP Server项,状态还未运行,手动启动下

    查看当前DHCP客户端信息

    如果使用简单配置,那么安装完这个软件后所有配置都不需要修改,把安装这个软件的计算机ip设为静态IP,一般为192.168.0.xx,启动后服务后客户端主机便可以动态获取ip地址了。(需要关闭防火墙,否则可能连不上

    在浏览器输入http://127.0.0.1:6789即可查看当前DHCP客户端信息,比如IP地址租约到期时间(一般DHCP Client的DHCP程序都会自动租约到期前1半时间向DHCP Server请求续租,续租成功后http://127.0.0.1:6789租约时间会更新),另外还显示DHCP可自动分配的IP地址范围等信息。

    OpenDHCPServer.ini文件简单的配置

    RANGE_SET

     

    DHCPRange默=192.168.0.1-192.168.0.254

    改为

    DHCPRange = 192.168.0.2-192.168.0.254

    执行RunStandAlone.bat脚本或重新启动dhcp服务修改便可以生效

     

    设置PC网口ip

    将PC机的网段设置为以上配置的网段,否则设备无法通过 udhcp连接上

     

    连接测试

    这里我的嵌入式设备使用的是usb口模拟以太网连接的,ifconfig查看usb0网口已经自动分配了id

     

    展开全文
  • DHCP如何分配ip地址不冲突

    千次阅读 2019-01-21 18:48:52
    原文地址 https://www.xzbu.com/8/view-7133510.htm
    展开全文
  • 原标题:一文了解如何使用DHCP自动分配IP地址?DHCP允许计算机动态地获取IP地址,而不是静态为每台主机指定地址。DHCP能够分配其他配置参数,例如客户端的启动配置文件,使客户端仅用一个消息就获取它所需要的所有...

    原标题:一文了解如何使用DHCP自动分配IP地址?

    DHCP允许计算机动态地获取IP地址,而不是静态为每台主机指定地址。

    DHCP能够分配其他配置参数,例如客户端的启动配置文件,使客户端仅用一个消息就获取它所需要的所有配置信息。

    动态分配机制:通过DHCP为主机分配一个有使用期限(这个使用期限通常叫做租期)的IP地址。这种分配机制适用于主机需要临时接入网络或者空闲地址数小于网络主机总数且主机不需要永久连接网络的场景。

    静态分配机制:网络管理员通过DHCP为指定的主机分配固定的IP地址。相比手工静态配置IP地址,通过DHCP方式静态分配机制避免人工配置发生错误,方便管理员统一维护管理。

    降低客户端的配置和维护成本。DHCP易配置部署,对于非技术用户,DHCP能够将客户端与配置相关的操作降至最低,并能够降低远程部署和维护成本。

    集中管理。DHCP服务器可以管理多个网段的配置信息,当某个网段的配置发生变化时,管理员只需要更新DHCP服务器上的相关配置即可。

    典型组网

    9768446097fb4137f7a59e5e5909c082.png

    DHCP组网中,包括以下三种角色:

    •DHCP服务器

    DHCP服务器负责从地址池中选择IP地址分配至DHCP客户端,还可以为DHCP客户端提供其他网络参数,如默认网关地址、DNS服务器地址和WINS服务器地址。DHCP服务器可以接收处理来自本网段或跨网段由DHCP中继转发的DHCP请求报文。

    •DHCP客户端

    DHCP客户端发送DHCP请求报文、通过BOOTP或DHCP协议请求获取IP地址等网络参数的设备。例如,IP电话、PC、手机、无盘工作站等。

    •DHCP中继

    DHCP中继负责转发DHCP服务器和DHCP客户端之间的DHCP报文,协助DHCP服务器向DHCP客户端动态分配网络参数的设备。

    DHCP客户端广播发送请求报文(即目的IP地址为255.255.255.255),位于同一网段内的DHCP服务器能够接收请求报文。如果DHCP客户端和DHCP服务器不在同一个网段,DHCP服务器无法接收来自客户端的请求报文,此时,需要通过DHCP中继来转发DHCP报文。不同于传统的IP报文转发,DHCP中继接收到DHCP请求或应答报文后,会重新修改报文格式并生成一个新的DHCP报文再进行转发。

    DHCP原理描述

    ◆DHCP服务器给首次接入网络的客户端分配IP

    1、无中继场景

    在没有部署DHCP中继的场景下,首次接入网络DHCP客户端与DHCP服务器的报文交互过程,该过程称为DHCP报文四步交互。

    9890d46e0f09679d1c961c0feeca7f05.png

    第一步:发现阶段

    首次接入网络的DHCP客户端不知道DHCP服务器的IP地址,为了学习到DHCP服务器的IP地址,DHCP客户端以广播方式发送DHCP DISCOVER报文(目的IP地址为255.255.255.255)给同一网段内的所有设备(包括DHCP服务器或中继)。

    第二步:提供阶段

    与DHCP客户端位于同一网段的DHCP服务器都会接收到DHCP DISCOVER报文,DHCP服务器选择跟接收DHCP DISCOVER报文接口的IP地址处于同一网段的地址池,并且从中选择一个可用的IP地址,然后通过DHCP OFFER报文发送给DHCP客户端。

    第三步:选择阶段

    如果有多个DHCP服务器向DHCP客户端回应DHCP OFFER报文,则DHCP客户端一般只接收第一个收到的DHCP OFFER报文,然后以广播方式发送DHCP REQUEST报文,它将选择某个DHCP服务器提供的IP地址,其他DHCP服务器可以重新将曾经分配给客户端的IP地址分配给其他客户端。

    第四步:确认阶段

    当DHCP服务器收到DHCP客户端发送的DHCP REQUEST报文后,DHCP服务器回应DHCP ACK报文,表示DHCP REQUEST报文中请求的IP地址分配给客户端使用。

    2、有中继场景

    有DHCP中继的场景中,首次接入网络的DHCP客户端和DHCP服务器的工作原理与无中继场景时DHCP客户端首次接入网络的工作原理相同。主要差异是DHCP中继在DHCP服务器和DHCP客户端之间转发DHCP报文,以保证DHCP服务器和DHCP客户端可以正常交互。如下图:

    8cb15cf1938cbe16189054e5a8f1a425.png

    ◆DHCP客户端重用曾经使用过的地址的工作原理

    DHCP客户端非首次接入网络时,可以重用曾经使用过的地址。如图所示,DHCP客户端与DHCP服务器交互DHCP报文,以重新获取之前使用的IP地址等网络参数,该过程称为两步交互。

    21248d2243a6f1f62be1dec2eda320da.png

    第一步:选择阶段

    客户端广播发送包含前一次分配的IP地址的DHCP REQUEST报文,请求的IP地址选项字段填入曾经使用过的IP地址。

    第二步:确认阶段

    DHCP服务器收到DHCP REQUEST报文后,根据DHCP REQUEST报文中携带的MAC地址来查找有没有相应的租约记录,如果有则返回DHCP ACK报文,通知DHCP客户端可以继续使用这个IP地址。否则,保持沉默,等待客户端重新发送DHCP DISCOVER报文请求新的IP地址。

    ◆DHCP客户端更新租期的工作原理

    DHCP服务器采用动态分配机制给客户端分配IP地址时,分配出去的IP地址有租期限制。

    DHCP客户端向服务器申请地址时可以携带期望租期,服务器在分配租期时把客户端期望租期和地址池中租期配置比较,分配其中一个较短的租期给客户端。租期到期或者客户端下线释放地址后,服务器会收回该IP地址,收回的IP地址可以继续分配给其他客户端使用。

    这种机制可以提高IP地址的利用率,避免客户端下线后IP地址继续被占用。如果DHCP客户端希望继续使用该地址,需要更新IP地址的租期(如延长IP地址租期)。

    ea690fb9cd6bd65802411dfc6d012c02.png

    1.当租期达到50%(T1)时,DHCP客户端会自动以单播的方式向DHCP服务器发送DHCP REQUEST报文,请求更新IP地址租期。如果收到DHCP服务器回应的DHCP ACK报文,则租期更新成功(即租期从0开始计算);如果收到DHCP NAK报文,则重新发送DHCP DISCOVER报文请求新的IP地址。

    2.当租期达到87.5%(T2)时,如果仍未收到DHCP服务器的应答,DHCP客户端会自动以广播的方式向DHCP服务器发送DHCP REQUEST报文,请求更新IP地址租期。如果收到DHCP服务器回应的DHCP ACK报文,则租期更新成功(即租期从0开始计算);如果收到DHCP NAK报文,则重新发送DHCP DISCOVER报文请求新的IP地址。

    3.如果租期时间到时都没有收到服务器的回应,客户端停止使用此IP地址,重新发送DHCP DISCOVER报文请求新的IP地址。

    DHCP配置举例

    ◆配置设备作为DHCP服务器示例(基于接口地址池)

    1、组网需求

    1a3a0694a89c12ac7b796a239054c000.png

    如图所示,某企业为办公终端规划了两个网段,网段10.1.1.0/24内PC为员工固定办公终端,网段10.1.2.0/24供企业出差人员临时接入网络。为方便管理员统一管理,希望企业终端能够自动获取IP地址和DNS服务器IP地址(当用户希望以域名方式访问时需要配置域名解析的DNS服务器)。其中,企业管理者的办公PC(Client_1)由于业务需要,希望使用固定IP地址为10.1.1.100/24。

    2、配置思路

    基于接口地址池的DHCP服务器的配置思路如下:

    通过在Router上配置DHCP服务器,实现为企业的两个网段内终端动态分配IP地址和DNS服务器地址。其中,网段10.1.1.0/24内PC为员工固定办公终端,IP地址租期配置为30天,并通过DHCP静态方式为DHCP Client_1分配固定IP地址(10.1.1.100/24);网段10.1.2.0/24供企业出差人员临时接入网络,IP地址租期配置为2天。

    3、操作步骤

    (1)使能DHCP服务

    system-view

    [Huawei] sysname Router

    [Router] dhcp enable

    (2)配置接口加入VLAN

    # 配置Eth2/0/0接口加入VLAN10。

    [Router] vlan batch 10 to 11

    [Router] interface ethernet 2/0/0

    [Router-Ethernet2/0/0] port link-type access

    [Router-Ethernet2/0/0] port default vlan 10

    [Router-Ethernet2/0/0] quit

    # 配置Eth2/0/1加接口入VLAN11。

    [Router] interface ethernet 2/0/1

    [Router-Ethernet2/0/1] port link-type access

    [Router-Ethernet2/0/1] port default vlan 11

    [Router-Ethernet2/0/1] quit

    (3)配置VLANIF接口IP地址

    # 配置VLANIF10接口地址。

    [Router] interface vlanif 10

    [Router-Vlanif10] ip address 10.1.1.1 24

    [Router-Vlanif10] quit

    # 配置VLANIF11接口地址。

    [Router] interface vlanif 11

    [Router-Vlanif11] ip address 10.1.2.1 24

    [Router-Vlanif11] quit

    (4)配置接口地址池

    # 配置VLANIF10接口下的客户端从接口地址池中获取IP地址和相关网络参数。

    [Router] interface vlanif 10

    [Router-Vlanif10] dhcp select interface

    [Router-Vlanif10] dhcp server lease day 30

    [Router-Vlanif10] dhcp server domain-name huawei.com

    [Router-Vlanif10] dhcp server dns-list 10.1.1.2

    [Router-Vlanif10] dhcp server excluded-ip-address 10.1.1.2

    [Router-Vlanif10] dhcp server static-bind ip-address 10.1.1.100 mac-address 286e-d488-b684

    [Router-Vlanif10] quit

    # 配置VLANIF11接口下的客户端从接口地址池中获取IP地址和相关网络参数。

    [Router] interface vlanif 11

    [Router-Vlanif11] dhcp select interface

    [Router-Vlanif11] dhcp server lease day 2

    [Router-Vlanif11] dhcp server domain-name huawei.com

    [Router-Vlanif11] dhcp server dns-list 10.1.1.2

    [Router-Vlanif11] quit返回搜狐,查看更多

    责任编辑:

    展开全文
  • 实现lwip的DHCP自动获取ip地址

    千次阅读 2012-03-04 15:25:49
    实现lwip的DHCP自动获取ip地址 [转载]  上个星期,在LM3S系列移植的lwip上,实现了自动获取ip的功能。  实现过程是:1)在opt.h上使能#define LWIP_ARP 1和#define LWIP_DHCP 1;2)在lwipopts.h上使能#define ...
  • DHCP,给我个IP !

    千次阅读 2013-08-26 10:45:56
    DHCP是一种使网络管理员能够集中管理和自动分配IP网络地址的通信协议。在IP网络中,每个连接Internet的设备都需要分配唯一的IP地址。DHCP使网络管理员能从中心结点监控和分配IP地址。当某台计算机移到网络中的其它...
  • Cisco网络中的因DHCP冲突无法获取IP

    千次阅读 2019-05-23 16:35:29
    设备:Cisco 3750 核心交换机最近一段时间,内网时常出客户端无法通过DHCP自动获取IP,但是在线在用的IP不多。 show ip dhcp binding...show ip dhcp conflict发现被吃掉的IP都在这被占用了 clear ip dhcp conflic...
  • 如果客户端发现分配的IP地址已经被使用,则客户端向DHCPServer发出客户端报文,通知DHCP Server禁用这个IP地址,然后客户端开始新的地址申请过程。 如果发送给DHCP客户端的地址已经被其他DHCP客户端使用,客户端会向...
  • 一:DHCP简介 DHCP:动态主机配置协议,是一个局域网的网络协议,使用UDP协议工作,用于内部网或者网络服务...DHCP客户端:在支持DHCP功能的网络设备上将指定的端口作为DHCP Client,通过DHCP协议从DHCP Server动态...
  • DHCP以及客户端是如何避免IP冲突

    千次阅读 2017-07-25 14:12:31
    摘 要: 无论是管理员手工分配IP地址,还是通过DHCP自动分配,非常重要的一个原则就是不能出现地址分配冲突的情况。...本文详细介绍在DHCP协议中,Server与Client之间是如何避免IP地址重点内容分配冲突的。
  • DHCP

    千次阅读 多人点赞 2018-05-22 13:23:14
    DHCP采用客户端/服务器通信模式,由客户端(DHCP Client)向服务器(DHCP Server)提出配置申请,服务器返回为客户端分配的配置信息(包括IP地址、缺省网关、DNS Server、WINS Server等参数)...
  • ISC DHCP 分配IP流程分析

    千次阅读 2015-05-11 09:13:24
    ISC DHCP 分配IP流程分析 2010-10-11 22:30:59 分类: 系统运维 本文的copyleft归gfree.wind@gmail.com所有,使用GPL发布,可以自由拷贝,转载。但转载请保持文档的完整性,注明原作者及原链接,严禁用于任何...
  • 1.应用场景 两台EC20开发板,通过以太网口进行连接...服务端使用dnsmasq这个工具来创建DHCP服务器。 2.DHCP客户端配置 开发板没有dhclient,差点 dhclient与udhcpc是同一个概念的东西,都是用来配置DHCP客户端。 ...
  • RAS占用DHCP地址池

    千次阅读 2014-03-31 17:55:44
    现象:DHCP服务器地址池中,有的机器租用了好几个IP地址,其中一个的唯一ID是MAC地址,其他几个的唯一ID都是是RAS。原因:RAS一次性会向DHCP服务器申请n个IP地址。解决办法:在域控操作客户端或直接到客户端禁用RAS...
  • DHCP 出现 电脑或手机需要 IP 地址才能上网。...于是就有了 DHCP 协议,会自动配置设备的网络参数,包括 IP 地址、子网掩码、网关地址、DNS 服务器等,替代手动配置。还能统一 IP 地址分配,方便网络管理.
  • DHCP故障无法获取ip如何分析解决

    千次阅读 2014-11-18 15:59:47
    对于DHCP故障,相信管理员们都遇到过,本文将介绍3招处理DHCP故障的技巧和步骤。第一:检查物理连接是否畅通。在客户端与服务器连接的网卡上配置IP地址,确保该IP地址与服务器端接口GigabitEthernet1/0/0的IP地址在...
  • ip dhcp snooping的设置

    2011-06-07 21:36:59
    对于DHCP我们这次主要讲解的是ip dhcp snooping的设置。通过文章的内容。大家能够对此有一个全面的掌握。 我们学习网络协议的内容已经不少了,对于DHCP来说,也接触了不少。那么接下来我们主要分析的是ip...
  • 公司通过cisco871代理上网,内部通过一个...今天又出现,再次查看地址池和客户端列表发现有几个ip没有被分配,然后通过 show ip dhcp ? 发现有一个conflict选择试了一下,发现有几个ip在里面从网上找到文章如下 ...
  • SQL Server 连接问题-TCP/IP

    万次阅读 2012-08-18 21:34:53
    出自:http://blogs.msdn.com/b/apgcdsd/archive/2012/02/24/ms-sql-server-tcp-ip.aspx TCP/IP的基本工作原理这里就不浪费口水了。现在这网络年代,谁不知道TCP/IP啊。不要跟我抬杠说你偏就没听说过TCP/IP阿,真是...
  • 它的主要作用是:对IP地址进行集中管理和分配,使网络环境中的主机动态的获得IP地址、网关地址、DNS服务器地址等信息,并提升IP地址的使用率。 1.2使用DHCP的原因 1.2.1、从用户角度看 IP地址是每个网络节点的标识,...
  • dhcp

    2009-12-31 07:46:37
    原理DHCPDISCOVER(DHCP发现) DHCPOFFER(DHCP提供) DHCPREQUEST(DHCP请求) DHCPACK(DHCP确认)(1)当DHCP客户机第一次登录网络时,如果客户机上没有任何IP信息设定,它会向网络发出DHCP DISCVER数据包,为...
  • 图片 上帝视角 DHCP 出现 电脑或手机需要 IP 地址才能上网。大刘有两台电脑和两台手机,...于是就有了 DHCP 协议,会自动配置设备的网络参数,包括 IP 地址、子网掩码、网关地址、DNS 服务器等,替代手动配置。还能统一

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 10,451
精华内容 4,180
关键字:

dhcpserver占用ip