精华内容
下载资源
问答
  • passive-interface :设置被动接口,只接收路由更新,不发送路由更新,这在RIP中很有用,但在EIGRP与OSPF中配置了被动接口将阻止路由器之间建立毗邻关系,因为它会阻止hello更新。 distribute-list 可以...
     
     
    在某些情况下,有些路由器不一定要接收到所有的路由更新,此时我们通过不同的方法来设置

     
    • passive-interface  :设置被动接口,只接收路由更新,不发送路由更新,这在RIP中很有用,但在EIGRP与OSPF中配置了被动接口将阻止路由器之间建立毗邻关系,因为它会阻止hello更新。

     
    • distribute-list 可以很好的解决这类问题,而且还不阻止毗邻关系的建立。

     
    下面我们做一个实验,在R1、R2、R3、R4上配置RIP协议,但阻止R4接收到10.4.4.0 的路由信息

     

     

     

    可以有两种方法配置:
    • 方法1:在R3上配置禁止在s0/0接口上外发10.4.4.0/24的路由
      • access-list 10 deny   10.1.1.0 0.0.0.255
      • access-list 10 permit any
      •  
      • router rip
      •  network 10.0.0.0
      •  distribute-list 10 out Serial0/0
    • 方法2:在R4上配置禁止接收10.4.4.0/24的路由
    • access-list 10 deny   10.1.1.0 0.0.0.255
    • access-list 10 permit any
    • router rip
    •  network 10.0.0.0
    •  distribute-list 10 in

     

     

    Distribute-list命令用法

    distribute-list有两种,一种是基于out方向的;一种是基于in方向的;

     
        out方向:
        distribute-list {access-list-number | name } out
     
        in方向:
        distribute-list [access-list-number | name ] | [route-map map-tag] in [interface-type interface-number]

     
    Distribute-list在距离矢量路由协议与链路状态协议的不同用法

     
    一. 距离矢量协议Rip Eigrp
    因为距离矢量协议直接传递路由信息,会在运行协议进程接口的in 和out方向控制相应协议路由信息
    Distribute-list in在协议接口的in方向控制路由信息,只改变自己,其它路由器不改变
    Distribute-list out在协议接口的out方向控制路由信息,自己不改变,其它路由器会改变。

     
    二. 链路状态协议Ospf Is-Is
    因为链路状态协议传递的是LSA(LSU)信息,在每台路由器同步LSA(LSU)后每台路由器根据database数据库信息运行SPF算法再得到路由表信息。在接口in 和out方向不直接传递路由信息.
    但5类LSA类似距离矢量协议会受影响所以5类的外部路由会被distribute-list发生改变.
    如果是一个纯的链路状态协议的网络(ospf)没有5类的LSA:
    Distribute-list out将不起任何作用(其它路由器不受改变),但会在不同进程之间起作用.
    如: R2(config-router)#distribute-list 1 out ospf 1(没做实验验证)
    Distribute-list in 不改变ospf database的信息,但会过滤相应的生成的路由信息

     



    本文转自zcm8483 51CTO博客,原文链接:http://blog.51cto.com/haolun/993176

    展开全文
  • Command "python setup.py egg_info" failed with error code 1 in /private/tmp/pip-build-pty_cqzi/distribute/ 请将安装命令由 sudo -H python -m pip install -U pip 更改为: sudo -H python2 -m ...

    如果出现如下提示:

    Command "python setup.py egg_info" failed with error code 1 in /private/tmp/pip-build-pty_cqzi/distribute/

    请将安装命令由

    sudo -H python -m pip install -U pip

    更改为:

    sudo -H python2 -m  pip install -U distribute

     

    转载于:https://my.oschina.net/u/63375/blog/913916

    展开全文
  • 1、分发列表distribute-list解析 2、实验拓扑 3、实验配置 R1配置 interface Serial0/0 ip address 12.1.1.1 255.255.255.0 interface Serial0/1 ip address 13.1.1.1 255.255.255.0 interface Serial0/2 ...

    1、分发列表distribute-list解析

    wKioL1ZhL_rAlZEhAAH9FgHVC5s708.png

    wKioL1ZhL__DUDF0AAIMXal1KiI405.png


    2、实验拓扑

    wKioL1ZhMEfRZOOAAABKhJ9TWLA136.png

    3、实验配置

    R1配置

    interface Serial0/0

     ip address 12.1.1.1 255.255.255.0

    interface Serial0/1

     ip address 13.1.1.1 255.255.255.0

    interface Serial0/2

     ip address 14.1.1.1 255.255.255.0

    router eigrp 90

     redistribute ospf 110 metric 1500 100 255 1 1500

     network 14.1.1.0 0.0.0.255

     no auto-summary

    router ospf 110

     router-id 1.1.1.1

     log-adjacency-changes

     redistribute rip subnets

     network 13.1.1.0 0.0.0.255 area 0

    router rip

     version 2

     network 12.0.0.0

     no auto-summary


    R2配置

    interface Loopback0

     ip address 2.2.2.2 255.255.255.0

    interface Serial0/0

     ip address 12.1.1.2 255.255.255.0

    router rip

     version 2

     network 2.0.0.0

     network 12.0.0.0

     no auto-summary


    R3配置

    interface Loopback0

     ip address 3.3.3.3 255.255.255.0

    interface Serial0/0

     ip address 13.1.1.3 255.255.255.0

    router ospf 110

     router-id 3.3.3.3

     log-adjacency-changes

     network 3.3.3.0 0.0.0.255 area 0

     network 13.1.1.0 0.0.0.255 area 0


    R4配置

    interface Loopback0

     ip address 4.4.4.4 255.255.255.0

    interface Serial0/0

     ip address 14.1.1.4 255.255.255.0

    router eigrp 90

     network 4.4.4.0 0.0.0.255

     network 14.1.1.0 0.0.0.255

     no auto-summary


    4、分发列表应用

    wKioL1ZhMRywaE-wAABFm7Ku_0s541.png此时我们可以看到R4可以学到3.3.3.3/32和13.1.1.0/24这两条路由,这里我们希望通过分发列表让R4只学到13.1.1.0/24这条路由。

    R1配置

    access-list 3 permit 3.3.3.3

    router eigrp 90

     distribute-list 3 out ospf 110

    wKiom1ZhMhDxhbjbAAA-9QeGMLc522.png此时R4只学到13.1.1.0/24这条路由。






          本文转自开源殿堂 51CTO博客,原文链接:http://blog.51cto.com/kaiyuandiantang/1719545,如需转载请自行联系原作者



    展开全文
  • 一、python-dev 包的安装 ...二、distribute包的安装(Distribute制作程序包,而用pip安装程序包) http://www.nowamagic.net/academy/detail/1330219 # wget https://pypi.python.org/packages/source/d/

    一、python-dev 包的安装

    sudo aptitude -y install python-dev

    二、distribute包的安装(Distribute制作程序包,而用pip安装程序包)

    http://www.nowamagic.net/academy/detail/1330219

    # wget https://pypi.python.org/packages/source/d/distribute/distribute-0.7.3.zip --no-check-certificate
    # unzip distribute-0.7.3.zip
    # cd distribute-0.7.3
    # python2.7 setup.py install

    三、pip命令的安装(用来从PyPI安装功能包,代替旧版本的easy_install)

    # wget https://raw.github.com/pypa/pip/master/contrib/get-pip.py

    #sudo python get-pip.py

    pip --version

    使用pip命令安装的包会存放在 /usr/local/lib/python2.7目录下。

    四、安装virtualenv

    作用是将python的实际运行环境进行虚拟的工具包。

    pip install virtualenv

    用virtualenv 创建一个供新开发的python应用程序运行的虚拟环境。

    (python2.7)zhchang@zhchang-All-Series:~$ export VIRTUALENV_SUE_DISTRIBUTE=true
    (python2.7)zhchang@zhchang-All-Series:~$ mkdir ~/work
    (python2.7)zhchang@zhchang-All-Series:~$ cd work
    (python2.7)zhchang@zhchang-All-Series:~/work$ virtualenv env
    虚拟环境激活:

    source env/bin/activate

    (env)zhchang@zhchang-All-Series:~/work$

    退出虚拟环境:

    (env)zhchang@zhchang-All-Series:~/work$ deactivate
    zhchang@zhchang-All-Series:~/work$




    展开全文
  • 分布式组件对象Distribute Component Object Model(DCOM)的配置 上海博达数据通信有限公司 VOIP项目部 龚超一. 进程内组件(DLL)的配置1) 组件端(Component)或服务器端(Server)的配置(远程)
  • distribute-list

    2018-12-24 21:35:34
    Distribute-list(分发列表)用来过滤路由信息Distribute-list使用方法:Out方向distribute分发列表 Route(config-router)#distribute-list {access-list-number|name} out [interface-name|routing-process[routing...
  • Distribute-list

    2018-10-18 14:15:06
    Distribute-list: 只能过滤路由信息。 对于距离矢量协议:传递的是纯路由信息,使用分发列表毫无影响。 对于链路状态协议: (1)in方向,分发列表只能在本地收到LSA后,生成路由的那一刹那进行路由的过滤,执行...
  • distribute_crawler

    千次阅读 2014-02-14 11:32:25
    distribute_crawler 使用scrapy,redis, mongodb,graphite实现的一个分布式网络爬虫,底层存储mongodb集群,分布式使用redis实现, 爬虫状态显示使用graphite实现。 这个工程是我对垂直搜索引擎中分布式网络爬虫...
  • distribute-list分发列表

    2019-07-24 20:35:16
    distribute-list分发列表是用来控制路由更新的一个工具,只能过滤路由信息,不能过滤LSA 如上图,R1、R2、R3运行RIP。R2在初始情况下,会将自己的路由表更新给R1,其中假设包含三条路由1.0、2.0及3.0。现在...
  • Python pip distribute

    千次阅读 2016-05-09 16:36:50
     脚本来安装Distribute,也可以通过easy_install, pip,源文件来安装,不过使用distribute_setup.py来安装是最简单和受欢迎的方式   $ curl -0 http://python-distribute.org/distribute_setup.py $ ...
  • XILINX FPGA 7系之 CLB/LUT可以知道 CLB 是基本的组成单元,SLICE 也是 CLB 的基本组成单元,为了更好的使用 XILINX FPGA ,有必要在深挖一下 Distribute RAM(分布式内存); XILINX 的 “ ug474_7Series_CLB.pdf...
  • Distribute Cached 使用

    2014-06-09 09:27:19
    DistributedCache: 一些比较小...查看代码了才知道其实它根本不是什么缓存,它只不过是在配置文件中的指定属性记录下相应的值,然后在mapreduce的时候,调用配置文件里面的属性值,然后取得需要的文件盒jar包。
  • clickhouse之分布式(distribute)

    万次阅读 2017-12-24 14:22:22
    Distribute  原文地址:https://clickhouse.yandex/docs/en/table_engines/distributed.html  clickhouse的分布式引擎本身不存储数据,但是允许查询分布式查询。读取数据自动就是并行化的。在读取数据的时候,...
  • distribute-list 分布列表

    2011-08-11 14:38:47
    标签:distribute-list 分配控制列表 distribute-list in (IP) To filter networks received in updates, use the distribute-list in command in address family or router configuration mode. To change .....
  • queue可作为distribute-webmagic的任务队列,也可作为独立的消息去重中间件 在distribute-webmagic中的架构图:   该组件通讯基于netty,缓存基于ehcache,介绍以下核心类 EhCache 封装后的缓存 QueueClient...
  • 利用distribute-list列表过滤路由 实验目的: 1:熟练配置路由重分发 2:利用distribute-list过滤相应的路由 图片: 1:具体配置 R1 ! Enable Conf t hostname London no ip domain-look line cons ...
  • 实验介绍:R2和R3通过配置达到互连,在R1上做分发列表控制路由更新。 配置: R1: interface Loopback0 ip address 11.1.1.1 255.255.255.255 interface Serial1/0 ip address 12.1.1.1 255.255.255.0 interface ...
  • 七、Order By、Sort By、Distribute By、Cluster By 的使用
  • Distribute Strategy--翻译学习

    千次阅读 2019-06-04 10:16:49
    tf.distribute.Strategy,是一个用于多GPU、多服务器或多TPU进行分布式模型训练的API接口。用户通过改动较少的代码就可以使用该接口进行分布式训练。该API除了可进行分布式训练外也可实现在不同的平台进行分布式评估...
  • 目录 Order By Sort By Sort By 和Order By 的不同 ...描述了 SELECT 子句 ORDER BY、SORT BY、CLUSTER BY 和 DISTRIBUTE BY 的语法。 Order By 与 SQL 中的 ORDER BY 类似(默认排序为升序) ...
  • 1.概述distribute-list分发列表是用于控制路由更新的一个工具,只能过滤路由信息,不能过滤LSA。如上图,R1、R2、R3运行RIP。R2在初始情况下,会将自己的路由表更新给R1,其中假设包含三条路由1.0、2.0及3.0。现在...
  • Hive中order by,sort by,distribute by,cluster by的区别
  • Hadoop + HBase distribute

    2012-05-08 17:20:11
    4 复制配置好的hbase文件以此到别的机器 scp –r /hbase-0.92.1 chunxiao@192.168.1.132:~/  配置结束。  到${HADOOP_HOME}/bin目录 ./start-dfs.sh 到${HADOOP_HOME}/bin目录 ./start-hbase.sh ...
  • 目标:测试 distribute by 的作用,希望针对user列,将不同的用户分配在不同的reduce中,方便后期计算。====================== 测试1:reduce 4个,按 length(user) 分配 测试2:reduce 4个,按 substr(user,0,2) ...
  • 文章目录1. 单机多卡 MirroredStrategy2. 多机训练 MultiWorkerMirroredStrategy 学习于:简单粗暴 TensorFlow 2 1. 单机多卡 MirroredStrategy ...strategy = tf.distribute.MirroredStrategy() # 指定设备
  • hive order by sort by distribute by总结

    万次阅读 2016-06-16 20:56:45
    不管如何配置,只能有一个reduce。那当数据量很大的时候,这个reduce就成为了单点,速度会很慢很慢。。。 3.distribute by sort by配合select top N distribute by,顾名思义,是起分散数据作用的。distribute by ...
  • distribute list可以用来控制路由更新,它需要用到access list。一般情况下,access list并不能控制由路由器自己生成的数据流,但是如果将access list应用到distribute list,则可以用来允许、拒绝路由选择更新。 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 24,036
精华内容 9,614
关键字:

distribute配置