精华内容
下载资源
问答
  • 3分钟带你明白交换机路由对未知数据帧的处理.doc
  • HUB、交换机路由

    2011-10-21 11:07:46
    HUB、交换机路由 首先说HUB,也就是 集线器 。它的作用可以简单的理解为将一些机器连接起来组成一个局域网。   而 交换机 (又名交换式集线器)作用与集线器大体相同。   但是两者在性能上有区别:集...

    HUB、交换机和路由

    首先说HUB,也就是 集线器 。它的作用可以简单的理解为将一些机器连接起来组成一个局域网。

     

    而 交换机 (又名交换式集线器)作用与集线器大体相同。

     

    但是两者在性能上有区别:集线器采用的是共享带宽的工作方式,而交换机是独享带宽。这样在机器很多或数据量很大时,两者将会有比较明显的。

     

    而 路由器 与以上两者有明显区别,它的作用在于连接不同的网段并且找到网络中数据传输最合适的路径 ,可以说一般情况下个人用户需求不大。

     

    路由器是产生于交换机之后,就像交换机产生于集线器之后,所以路由器与交换机也有一定联系,并不是完全独立的两种设备。路由器主要克服了交换机不能路由转发数据包的不足。 

     

     

    -----------------

     

    总的来说,路由器与交换机的主要区别体现在以下几个方面: 

    (1)工作层次不同 

    最初的的交换机是工作在OSI/RM开放体系结构的数据链路层,也就是第二层,而路由器一开始就设计工作在OSI模型的网络层。由于交换机工作在OSI的第二层(数据链路层),所以它的工作原理比较简单,而路由器工作在OSI的第三层(网络层),可以得到更多的协议信息,路由器可以做出更加智能的转发决策。 

    (2)数据转发所依据的对象不同 

    交换机是利用物理地址或者说MAC地址来确定转发数据的目的地址。(网卡硬件本身的地址 MAC)

    而路由器则是利用不同网络的ID号(即IP地址)来确定数据转发的地址。(软件实现,网络地址/协议地址/IP地址)

     

    IP地址是在软件中实现的,描述的是设备所在的网络,有时这些第三层的地址也称为协议地址或者网络地址。MAC地址通常是硬件自带的,由网卡生产商来分配的,而且已经固化到了网卡中去,一般来说是不可更改的。而IP地址则通常由网络管理员或系统自动分配。 

    (3)传统的交换机只能分割冲突域,不能分割广播域;而路由器可以分割广播域 

    由交换机连接的网段仍属于同一个广播域,广播数据包会在交换机连接的所有网段上传播,在某些情况下会导致通信拥挤和安全漏洞。连接到路由器上的网段会被分配成不同的广播域,广播数据不会穿过路由器。虽然第三层以上交换机具有VLAN功能,也可以分割广播域,但是各子广播域之间是不能通信交流的,它们之间的交流仍然需要路由器。 

    (4)路由器提供了防火墙的服务 

    路由器仅仅转发特定地址的数据包,不传送不支持路由协议的数据包传送和未知目标网络数据包的传送,从而可以防止广播风暴。 

    交换机一般用于LAN-WAN的连接,交换机归于网桥,是数据链路层的设备,有些交换机也可实现第三层的交换。 路由器用于WAN-WAN之间的连接,可以解决异性网络之间转发分组,作用于网络层。他们只是从一条线路上接受输入分组,然后向另一条线路转发。这两条线路可能分属于不同的网络,并采用不同协议。相比较而言,路由器的功能较交换机要强大,但速度相对也慢,价格昂贵,第三层交换机既有交换机线速转发报文能力,又有路由器良好的控制功能,因此得以广泛应用。 

    目前个人比较多宽带接入方式就是ADSL,因此笔者就ADSL的接入来简单的说明一下。现在购买的ADSL猫大多具有路由功能(很多的时候厂家在出厂时将路由功能屏蔽了,因为电信安装时大多是不启用路由功能的,启用DHCP。打开ADSL的路由功能),如果个人上网或少数几台通过ADSL本身就可以了,如果电脑比较多你只需要再购买一个或多个集线器或者交换机。考虑到如今集线器与交换机的 价格相差十分小,不是特殊的原因,请购买一个交换机。不必去追求高价,因为如今产品同质化十分严重,我最便宜的交换机现在没有任 何问题。给你一个参考报价,建议你购买一个8口的,以满足扩充需求,一般的价格100元左右。接上交换机,所有电脑再接到交换机上就行了。余下所要做的事情就只有把各个机器的网线插入交换机的接口,将猫的网线插入uplink接口。然后设置路由功能,DHCP等, 就可以共享上网了   


    展开全文
  • 华为交换机与路由器远程登录配置。authentication(认证)、authorization(授权)、accounting(计费)的简称,是网络安全的一种管理机制;Authentication是本地认证/授权,authorization和accounting是由远处...
  • H3C 交换机策略路由流量负载均衡

    千次阅读 2019-08-06 19:27:23
    外网出口交换机上有2条运营商线路,出外网的流量到达交换机后需要流量在2条线路上负载均衡,由于考虑到还会有其他运营商线路接入,且要求运营商流量来回路径一致,所以单纯通过静态路由迭代无法实现,此处可以使用...
    1.  

      组网环境

    1.  

      实现说明

    外网出口交换机上有2条运营商线路,出外网的流量到达交换机后需要流量在2条线路上负载均衡,由于考虑到还会有其他运营商线路接入,且要求运营商流量来回路径一致,所以单纯通过静态路由迭代无法实现,此处可以使用pbr+静态路由迭代的配置方式实现上述需求。

    1.  

      配置说明

    vlan 100

    description 流量路径-1

    #

    vlan 101

    description 流量路径-2

    #

    interface Vlan-interface100

    description 流量路径-1

     ip address 1.1.1.1 255.255.255.0

    #

    interface Vlan-interface101

    description 流量路径-2

     ip address 2.2.2.1 255.255.255.0

    #

    interface GigabitEthernet1/0/1

     port link-mode bridge

     port link-type trunk

     port trunk permit vlan 100

    #

    interface GigabitEthernet1/0/2

     port link-mode bridge

     port link-type trunk

     port trunk permit vlan 101

    #

    nqa entry admin 1

     type icmp-echo

      destination ip 1.1.1.2

      frequency 100

      next-hop ip 1.1.1.2

      reaction 1 checked-element probe-fail threshold-type consecutive 5 action-type trigger-only

    #

    nqa entry admin 2

     type icmp-echo

      destination ip 2.2.2.2

      frequency 100

      next-hop ip 2.2.2.2

      reaction 1 checked-element probe-fail threshold-type consecutive 5 action-type trigger-only

    #

    nqa schedule admin 1 start-time now lifetime forever

    nqa schedule admin 2 start-time now lifetime forever

    #

    track 1 nqa entry admin 1 reaction 1

    track 2 nqa entry admin 2 reaction 1

    #

    acl advanced 3000

     rule 0 permit ip source 10.0.0.0 0.0.0.8 

    #

    policy-based-route aaa permit node 1

     if-match acl 3000

     apply next-hop 111.111.111.111

    #

     ip route-static 111.111.111.111 32 1.1.1.1 track 1

     ip route-static 111.111.111.111 32 2.2.2.1 track 2

    #

     

    展开全文
  • 讲述三层交换机路由连接方法

    千次阅读 2014-03-14 16:21:28
    三层交换机确实具有一定的“路由”功能,它可以实现不同的子网连接功能,但是特别注意的问题是,它的路由功能相对路由器来说还是要弱许多的,而且三层交换机只能使用一个网络。 而且通常只是局域网子网之间的互联...

    三层交换机确实具有一定的“路由”功能,它可以实现不同的子网连接功能,但是特别注意的问题是,它的路由功能相对路由器来说还是要弱许多的,而且三层交换机只能使用一个网络。

    而且通常只是局域网子网之间的互联,并不能把局域网与广域网,或者互联网连接起来,因为三层交换机所支持的路由协议非常有限,毕竟这不是它的主要功能。我们知道,在局域网上,二层的交换机通过源MAC 地址来标识数据包的发送者,根据目的MAC 地址来转发数据包。

    对于一个目的地址不在本局域网上的数据包,二层交换机不可能直接把它送到目的地,需要通过路由设备(比如传统的路由器)来转发,这时就要把交换机连接到路由设备上。如果把交换机的缺省网关设置为路由设备的IP 地址,交换机会把需要经过路由转发的包送到路由设备上。

    路由设备检查数据包的目的地址和自己的路由表,如果在路由表中找到转发路径,路由设备把该数据包转发到其它的网段上,否则,丢弃该数据包。专用路由器昂贵、复杂、速度慢、易成为网络瓶颈,因为它要分析所有的广播包并转发其中的一部分,还要和其它的路由器交换路由信息,而且这些处理过程都是由CPU 来处理的(不是专用的ASIC )。

    第三层交换机既能像二层交换机那样通过MAC 地址来标识转发数据包,也能像传统路由器那样在两个网段之间进行路由转发。传统路由器采用软件来维护路由表,而三层交换机是通过专用的ASIC芯片来处理路由转发的。与传统路由器相比,第三层交换机的路由速度一般要快十倍或数十倍。

    大家都知道,路由器可以连接企业局域网和广域网(如因特网),但却忽略了一路由器的另一个应用,那就是它的局域网连接功能。路由器的广域网连接可参见拓扑图图和三层交换机的路由连接图。

    路由器的作用因不同的路由器类型而定,我们常说的路由器通常是指边界路由器,就是位于不同类型网络的边界,如拓扑图图和三层交换机的路由连接图所示。还有一种路由器。

    它设计的目的就不是用于不同类型网络的连接,而是用于同为局域网的不同局域网或不同子网之间的连接,这就是“中间节点路由器”。它的网络结构如下图所示。它与三层交换机的路由连接图相比,只是用中间节点路由器接替了原来的三层交换机。

    “边界路由器”处于网络边界的边缘或末端,用于不同网络路由器的连接,这也是目前大多数路由器的类型。如前面介绍的互联网接入路由器和后面要介绍的vpn路由器都属于边界路由器。这类路由器所支持的网络协议和路由协议比较广,背板带宽非常高,具有较高的吞吐能力,以满足各类不同类型网络(包括局域网和广域网)的互联。

    而“中间节点路由器”则处于局域网的内部,通常用于连接不同局域网,起到一个数据转发的桥梁作用。中间节点路由器更注重MAC地址的记忆能,要求较 大的缓存。因为所连接的网络基本上是局域网,所以所支持的网络协议比较单一,背板带宽也较小,这些都是为了获得最高的性价比,适应一般企业的随能力。

    它与三层交换机的路由功能相比,在路由功能上肯定比三层交换机的强,但在局域网这种数据交换频繁的网络中,采用中间节点路由器来进行局域网的连接,网络性能可能会受到一定影响。

    总的来说,如果所连接的局域网或子网较多、网络互访不是很频繁、路由较复杂的环境中,最好采用中间节点路由器连接方案。但在少数子网连接、网络间互访频繁的环境中,最好还是采用三层交换机连接方式。而且还可节省设备投资,因为三层交换机不仅具有满足应用需求的路由功能,还可当作交换机用,连接许多网络设备。

    展开全文
  • [转载]H3CS5500交换机策略路由配置

    千次阅读 2017-04-29 14:46:10
    原文地址:H3CS5500交换机策略路由配置作者:IT-CollectionPlatForm拓扑图: 网络情况如下: 用户1网络:172.16.1.0/24 用户2网络: 192.168.1.0/24 至出口1网络:172.16.100.0/24 至出口2网络:192.168.100.0/24 ...

    拓扑图:

    h3c55002

    网络情况如下:

    用户1网络:172.16.1.0/24
    用户2网络: 192.168.1.0/24
    至出口1网络:172.16.100.0/24
    至出口2网络:192.168.100.0/24

    实现功能:用户1通过互联网出口1,用户2通过互联网出口2。
    功能实现:在三层交换台机上配置默认路由,将数据包丢向192.168.100.253,再利用策略路由,凡是用户2网络IP192.168.1.0/24的地址都丢向172.16.100.253。

    配置步骤:

     

     

    1、首先建立默认路由,将所有的数据包都丢往出口2的下一节点192.168.100.253

    [H3C5500] ip route-static 0.0.0.0 0.0.0.0 192.168.100.253

    2、配置流分类1,对象为172.16.1.0/24的数据

    [H3C5500]acl number 3001

    [H3C5500-acl-adv-3001] rule 0 permit ip source 172.16.1.0 0.0.0.255

    [H3C5500] quit

    [H3C5500] traffic classifier 1

    [H3C5500-classifier-1] if-match acl 3001

    [H3C5500-classifier-1] quit

    3、配置刚才定义的流分类的行为,定义如果匹配就下一跳至出口1即172.16.100.253

    [H3C5500] traffic behavior 1

    [H3C5500-behavior-1] redirect next-hop 172.16.100.253

    [H3C5500-behavior-1] quit

    4、将刚才设置的应用至QOS策略中,定义policy 1

    [H3C5500] qos policy 1

    [H3C5500-qospolicy-1] classifier 1 behavior 1

    [H3C5500-qospolicy-1] quit

    5、在接口上应用定义的QOS策略policy 1

    [H3C5500] interface GigabitEthernet 1/0/15

    [H3C5500-GigabitEthernet1/0/15] qos apply policy 1 inbound

    [H3C5500-GigabitEthernet1/0/15] quit

    至此,配置已完成。

    配置文件(略过一些接口配置信息):

    version 5.20, Release 2102P02
    #
    sysname H3C5500
    #
    domain default enable system
    #
    telnet server enable
    #
    vlan 1
    #
    vlan 100 to 103
    #
    traffic classifier 1 operator and
    if-match acl 3001
    #
    traffic behavior 1
    redirect next-hop 172.16.100.253
    #
    qos policy 1
    classifier 1 behavior 1
    #
    dhcp server ip-pool 1
    network 192.168.1.0 mask 255.255.255.0
    gateway-list 192.168.1.254
    dns-list 221.228.255.1
    #
    dhcp server ip-pool 2
    network 172.16.1.0 mask 255.255.255.0
    gateway-list 172.16.1.254
    dns-list 221.228.255.1
    #
    local-user huawei
    password cipher .]@USE=B,53Q=^Q`M<1!!
    service-type telnet terminal
    level 3
    #
    acl number 3001
    rule 0 permit ip source 172.16.1.0 0.0.0.255
    #
    interface NULL0
    #
    interface Vlan-interface1
    ip address 192.168.0.254 255.255.255.0
    #
    interface Vlan-interface100
    ip address 192.168.100.254 255.255.255.0
    #
    interface Vlan-interface101
    ip address 192.168.1.254 255.255.255.0
    #
    interface Vlan-interface102
    ip address 172.16.100.254 255.255.255.0
    #
    interface Vlan-interface103
    ip address 172.16.1.254 255.255.255.0
    #
    interface GigabitEthernet1/0/1
    port link-type access
    port access vlan 100
    speed 1000
    duplex full
    #
    interface GigabitEthernet1/0/2
    port link-type access
    port access vlan 102
    speed 1000
    duplex full
    #
    interface GigabitEthernet1/0/15
    port link-type trunk
    port trunk permit vlan 1 101 103
    speed 1000
    duplex full
    qos apply policy 1 inbound
    #
    interface GigabitEthernet1/0/16
    port link-type trunk
    port trunk permit vlan 1 101 103
    speed 1000
    duplex full
    qos apply policy 1 inbound
    #
    ip route-static 0.0.0.0 0.0.0.0 192.168.100.253
    #
    dhcp enable
    #
    load xml-configuration
    #
    user-interface aux 0
    authentication-mode scheme
    user-interface vty 0 4
    authentication-mode scheme
    user privilege level 3
    #
    return

    展开全文
  • SDN路由交换机路由服务研究,张毅,侯海兵,SDN网络将传统网络中的数据转发层面与控制层面相分离,采用集中控制的方法对网络中的数据流进行统一调度管理。随着SDN网络规模扩大
  • 三层交换机实现路由器功能, 需要 主机, 三个交换机, 一个路由器 【效果图】 【配置代码】  注意!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 注意 端口 一定要对, ...
  •  三层交换机的端口, 仍然有24个, 还是表示fa0/1-24, 其三层路由功能不是通过fastethernet端口来实现的, 而是通过其vlan接口来实现的,因此在联通的两个二层交换机上, 要配置vlan才能实现互通. 那么相应的, 二层...
  • 同时就算使用了路由键2进行绑定,但还是能接收到路由键1发送的数据,说明faout交换机路由键其实是没什么关系的。这就是扇形交换机。 topic交换机-主题交换机 生产者: package rabbitmqDemo.demo2.direct; ...
  • 二层交换机vlan单臂路由的配置

    千次阅读 2019-11-26 09:46:01
    2、熟练掌握二层交换机vlan路由的定义。 3、熟练掌握二层交换机vlan单臂路由实验配置过程。 二、实验内容 1、绘制拓扑图,根据拓扑图进行试验: 2、配置路由器和二层交换机,并最终验证网络的连通性。 三、实验...
  • 2.网络核心为思科3560G三层交换机,划分4个VLAN,基本VLAN10/VLAN20属于Group1,VLAN30/VLAN40属于Group2。3.两台接入路由器LAN端IP分别为10.10.10.254(Group1使用),10.10.20.254(Group2使用)二...
  • HUT,交换机路由的区别

    千次阅读 2005-01-05 13:33:00
    您了解集线器(HUB),交换机(Switch),路由器(Route)之间的区别吗?这篇文章就向您做一个简单的介绍,让您在构建网络或者购买网络产品时,对上述三者有个更加清楚的认识。 路由器,集线器,交换机粗粗一看,...
  • 2、熟练掌握三层交换机vlan路由的定义。 3、熟练掌握三层交换机vlan单臂路由实验配置过程。 二、实验内容 1、绘制拓扑图,根据拓扑图进行试验: 2、配置路由器和三层交换机,并最终验证网络的连通性。 三、实验...
  • 交换机数据路由路由决定是否转发,比交换智能点 。这样能避免过多的广播造成网络堵塞。 现在路由多用在分内外网上 6、网关 好比是个门,对家庭来说门是门,对国家来说海关是门。 在局域网里来说集线器就是...
  • 配置交换机的静态路由

    万次阅读 多人点赞 2017-10-17 23:05:24
    sys  ip route-static 0.0.0.0 0.0.0.0 172.31.255.159 (静态路由吓一跳172.31.255.159) 删除静态路由在命令前加undo即可
  • 笔者制定了一个解决方案:利用MikroTikRouterOS,改造了几台办公淘汰下来的普通PC做成软路由,分担原来防火墙的流量来共同承担网络的出口任务,在三层交换机上做策略路由实现数据的不同流向,从而达到分流的目的。...
  • 再谈交换机数据劫持

    千次阅读 2008-06-18 11:32:00
    很多朋友对交换机数据劫持有不理解,我以前写的那鬼东西也太繁琐了,我自己都给看晕了。交换正常的转发流程,对外出去的数据包通过黄线正常的到了路由器,交换内部有MAC和端口的绑定关系,大家都知道网关的MAC在主干...
  • 交换机路由协议配置

    千次阅读 2005-10-09 19:32:00
    路由协议配置1 功能需求及组网说明路由协议配置『配置环境参数』1. 如图,交换机SwitchA、SwitchB、SwitchC实现互连。2. SwitchA中vlan10虚接口地址10.1.1.1/24,vlan20虚接口地址20.1.1.1/24,vlan20与SwitchB ...
  • X是direct类型的交换机,它负责接收生产者的消息,并根据路由键分发消息到指定的队列。 Q1和Q2是队列。Q1队列只会接收:消息路由键为orange的消息,Q2队列只会接收:消息路由键为black和green的消息。 C1和C2是...
  • 使用二层交换机+路由器(单臂路由) 1.1 PC1配置 手动配置pc1的IP地址:192.168.2.10 子网掩码:255.255.255.0 网关:192.168.2.1 1.2 PC2配置 手动配置pc2的IP地址:192.168.3.10 子网掩码:255.255.255.0 网关:...
  • 静态路由,动态路由,三层交换机

    千次阅读 2019-05-20 19:50:52
    案例1:配置静态路由 案例2:配置多路由环境网络 案例3:三层交换机基本配置 案例4:三层交换机实现VLAN互通 案例5:搭建小型办公网络 案例6:动态路由 1 案例1:配置静态路由 1.1 问题 按照图-1的拓扑结构...
  • 交换机一般使用重定向来实现策略路由。 配置步骤 配置ACL规则 acl 3001 rule permit ip source 192.168.10.0 0.0.0.255 quit acl 3002 rule permit ip source 192.168.20.0 0.0.0.255 quit 配置流分类 traffic ...
  • 交换机实现 VLAN 间路由 【实验目的】 利用三层交换机交换机实现 VLAN 间路由。 【背景描述】 为减小广播包对网络的影响,网络管理员在公司内部网络中进行了 VLAN 的划分,为了实现不同 VLAN 间的互相访问,网络...
  • cisco3560交换机的策略路由的设置

    千次阅读 2019-07-06 07:25:33
    因为数据包在离开的接口上是已经路由过的,不会再走策略路由 [-- Switch(config)#interface vlan 1 -- 或者绑定在VLAN1虚拟接口上也可以]  Switch(config-if)#ip policy route-map GaoXiong [--如果是绑定在...
  • 大多数企业都会配备三层交换机,通过划分VLAN更好的管理内部网络,三层交换机功能强大,本身带路由功能,可以控制VLAN之间的互相访问,这里要介绍的是三层交换机与防火墙连接上网。
  • 利用三层交换机实现 VLAN 间路由

    千次阅读 2019-12-16 10:42:34
    某企业有两个主要部门,技术部和销售部,分处于不同的办公室,为了安全和便于管理对两个部门的主机...三层交换机具备网络层的功能,实现 VLAN 相互访问的原理是:利用三层交换机路由功能,通过识别数据包的 IP ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 66,580
精华内容 26,632
关键字:

交换机数据路由