精华内容
下载资源
问答
  • 神州数码交换机配置基本命令

    千次阅读 2020-09-20 09:16:08
    神州数码交换机配置基本命令 交换机基本状态: hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switch>enable ;进入特权...

    神州数码交换机配置基本命令
    交换机基本状态:
    hostname> ;用户模式
    hostname# ;特权模式
    hostname(config)# ;全局配置模式
    hostname(config-if)# ;接口状态
    交换机口令设置:
    switch>enable ;进入特权模式
    switch#config terminal ;进入全局配置模式
    switch(config)#hostname ;设置交换机的主机名
    switch(config)#enable secret xxx ;设置特权加密口令
    switch(config)#enable password xxa ;设置特权非密口令
    switch(config)#line console 0 ;进入控制台口
    switch(config-line)#line vty 0 4 ;进入虚拟终端
    switch(config-line)#login ;允许登录
    switch(config-line)#password xx ;设置登录口令 xx
    switch#exit ;返回命令
    交换机 VLAN 设置:
    switch#vlan database ;进入 VLAN 设置
    switch(vlan)#vlan 2 ;建 VLAN 2
    switch(vlan)#no vlan 2 ;删 vlan 2
    switch(config)#int f0/1 ;进入端口 1
    switch(config-if)#switchport access vlan 2 ;当前端口加入 vlan 2
    switch(config-if)#switchport mode trunk ;设置为干线
    switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的 vlan
    switch(config-if)#switchport trunk encap dot1q ;设置 vlan 中继
    switch(config)#vtp domain ;设置发 vtp 域名
    switch(config)#vtp password ;设置发 vtp 密码
    switch(config)#vtp mode server ;设置发 vtp 模式
    switch(config)#vtp mode client ;设置发 vtp 模式
    交换机设置 IP 地址:
    switch(config)#interface vlan 1 ;进入 vlan 1
    switch(config-if)#ip address ;设置 IP 地址
    switch(config)#ip default-gateway ;设置默认网关
    switch#dir Flash: ;查看闪存
    交换机显示命令:
    switch#write ;保存配置信息
    switch#show vtp ;查看 vtp 配置信息
    switch#show run ;查看当前配置信息
    switch#show vlan ;查看 vlan 配置信息
    switch#show interface ;查看端口信息
    switch#show int f0/0 ;查看指定端口信息
    完了最最要的一步。要记得保存设置俄,
    保存命令:switch(config)#copy running-config startup-config
    VLAN 配置命令

    神州数码交换机配置基本命令

    9.2.2.1 vlan
    命令:vlan [vlan-id]
    no vlan [vlan-id]
    功能:创建 vlan 并且进入 vlan 配置模式,在 vlan 模式中,用户可以配置 vlan 名称和
    为该 vlan 分配交换机端口;本命令的 no 操作为删除指定的 vlan。
    参数:[vlan-id]为要创建/删除的 vlan 的 vid,取值范围为 1~4094。
    命令模式:全局配置模式
    缺省情况:交换机缺省只有 vlan1。
    使用指南:vlan1 为交换机的缺省 vlan,用户不能配置和删除 vlan1。允许配置 vlan 的 总共数量为 255 个。另需要提醒的是不能使用本命令删除通过 gvrp 学习到的动态 vlan。
    举例:创建 vlan100,并且进入 vlan100 的配置模式。
    switch(config)#vlan 100
    switch(config-vlan100)#
    9.2.2.2 name
    命令:name [vlan-name]
    no name
    功能:为 vlan 指定名称,vlan 的名称是对该 vlan 一个描述性字符串;本命令的 no 操 作为删除 vlan 的名称。
    参数:[vlan-name]为指定的 vlan 名称字符串。
    命令模式:vlan 配置模式
    缺省情况:vlan 缺省 vlan 名称为 vlanxxx,其中 xxx 为 vid。
    使用指南:交换机提供为不同的 vlan 指定名称的功能,有助于用户记忆 vlan,方便管
    理。
    举例:为 vlan100 指定名称为 testvlan。
    switch(config-vlan100)#name testvlan
    9.2.2.3 switchport access vlan
    命令:switchport access vlan [vlan-id]
    no switchport access vlan
    功能:将当前 access 端口加入到指定 vlan;本命令 no 操作为将当前端口从 vlan 里删 除。
    参数:[vlan-id]为当前端口要加入的 vlan vid,取值范围为 1~4094。
    命令模式:端口配置模式
    缺省情况:所有端口默认属于 vlan1。
    使用指南:只有属于 access mode 的端口才能加入到指定的 vlan 中,并且 access 端口
    同时只能加入到一个 vlan 里去。
    举例:设置某 access 端口加入 vlan100。
    switch(config)#interface ethernet 0/0/8
    switch(config-ethernet0/0/8)#switchport mode access
    switch(config-ethernet0/0/8)#switchport access vlan 100
    switch(config-ethernet0/0/8)#exit
    9.2.2.4 switchport interface
    命令:switchport interface [interface-list]
    no switchport interface [interface-list]
    功能:给 vlan 分配以太网端口的命令;本命令的 no 操作为删除指定 vlan 内的一个或
    一组端口。
    参数:[interface-list] 要添加或者删除的端口的列表,支持”;””-”,如:ethernet 0/0/1;2;5
    神州数码交换机配置基本命令
    或 ethernet 0/0/1-6;8。
    命令模式:vlan 配置模式
    缺省情况:新建立的 vlan 缺省不包含任何端口。
    使用指南:access 端口为普通端口,可以加入 vlan,但同时只允许加入一个 vlan。
    举例:为 vlan100 分配百兆以太网端口 1,3,4-7,8。
    switch(config-vlan100)#switchport interface ethernet 0/0/1;3;4-7;8

    9.2.2.5 switchport mode
    命令:switchport mode {trunk|access}
    功能:设置交换机的端口为 access 模式或者 trunk 模式。
    命令模式:端口配置模式
    参数:trunk 表示端口允许通过多个 vlan 的流量;access 为端口只能属于一个 vlan。
    命令模式:端口配置模式
    缺省情况:端口缺省为 access 模式。
    使用指南:工作在 trunk mode 下的端口称为 trunk 端口,trunk 端口可以通过多个 vlan
    的流量,通过 trunk 端口之间的互联,可以实现不同交换机上的相同 vlan 的互通;工作在
    access mode 下的端口称为 access 端口,access 端口可以分配给一个 vlan,并且同时只能分 配给一个 vlan。
    在 trunk 端口不允许 802.1x 认证。
    举例:将端口 5 设置为 trunk 模式,端口 8 设置为 access 模式。
    switch(config)#interface ethernet 0/0/5
    switch(config-ethernet0/0/5)#switchport mode trunk
    switch(config-ethernet0/0/5)#exit
    switch(config)#interface ethernet 0/0/8
    switch(config-ethernet0/0/8)#switchport mode access
    switch(config-ethernet0/0/8)#exit
    9.2.2.6 switchport trunk allowed vlan
    命令:switchport trunk allowed vlan {[vlan-list]|all}
    no switchport trunk allowed vlan
    功能:设置 trunk 端口允许通过 vlan;本命令的 no 操作为恢复缺省情况。
    参数:[vlan-list]为允许在该 trunk 端口上通过的 vlan 列表;all 示关键字表允许该 trunk
    端口通过所有 vlan 的流量。
    命令模式:端口配置模式
    缺省情况:trunk 端口缺省允许通过所有 vlan。
    使用指南:用户可以通过本命令设置哪些 vlan 的流量通过 trunk 端口,没有包含的 vlan
    流量则被禁止。
    举例:设置 trunk 端口允许通过 vlan1,3,5-20 的流量。
    switch(config)#interface ethernet 0/0/5
    switch(config-ethernet0/0/5)#switchport mode trunk
    switch(config-ethernet0/0/5)#switchport trunk allowed vlan 1;3;5-20
    switch(config-ethernet0/0/5)#exit
    9.2.2.7 switchport trunk native vlan
    命令:switchport trunk native vlan [vlan-id]
    no switchport trunk native vlan
    功能:设置 trunk 端口的 pvid;本命令的 no 操作为恢复缺省值。
    参数:[vlan-id]为 trunk 端口的 pvid。
    命令模式:端口配置模式

    神州数码交换机配置基本命令

    缺省情况:trunk 端口默认的 pvid 为 1。
    使用指南:在 802.1q 中定义了 pvid 这个概念。trunk 端口的 pvid 的作用是当一个
    untagged 的帧进入 trunk 端口,端口会对这个 untagged 帧打上带有本命令设置的 native pvid
    的 tag 标记,用于 vlan 的转发。
    举例:设置某 trunk 端口的 native vlan 为 100。
    switch(config)#interface ethernet 0/0/5
    switch(config-ethernet0/0/5)#switchport mode trunk
    switch(config-ethernet0/0/5)#switchport trunk native vlan 100
    switch(config-ethernet0/0/5)#exit
    9.2.2.8 vlan ingress enable
    命令:vlan ingress enable
    no vlan ingress enable
    命令模式:端口配置模式
    功能:打开端口的 vlan 入口规则;本命令的 no 操作为关闭入口准则。
    缺省情况:系统缺省关闭端口的 vlan 入口准则。
    使用指南:当打开端口的 vlan 入口规则,系统在接收数据时会检查源端口是否是该 vlan
    的成员端口,如果是则接受数据并转发到目的端口,否则丢弃该数据。
    举例:打开端口的 vlan 入口规则。
    switch(config-ethernet0/0/1)# vlan ingress enable
    9.2.2.9 private-vlan
    命令:private-vlan {primary|isolated|community}
    no private-vlan
    功能:将当前 vlan 设置为 private vlan,该命令的 no 操作为取消 private vlan 设置。
    参数:primary 将当前 vlan 设置为 primary vlan,isolated 将当前 vlan 设置为 isolated
    vlan,community 将当前 vlan 设置为 community vlan。
    命令模式:vlan 配置模式
    缺省情况:缺省没有 private vlan 配置。
    使用指南:private vlan 分为三种:primary vlan,在 primary vlan 内的端口可以和关 vlan, 在 isolated vlan 内的端口之间是隔绝的,它们只可以和其相关联的 primary vlan 内的端口通
    信;community vlan,在 community vlan 内的端口相互之间可以通信,也可以和其相关联的
    primary vlan 内的端口通信;在 isolated vlan 内的端口和在 community vlan 内的端口之间不
    能通信。只有不包含任何以太网端口的 vlan 才能被设置为 private vlan;只有设置了关联关 系的 private vlan 才能 access 类型的以太网端口设置为成员端口;普通 vlan 若被设置成
    privatevlan 后,会自动将所属以太网端口清空。
    gvrp 不传播 private vlan 的信息。
    举例:将 vlan100、200、300 设置为 privatevlan,类型分别为 primary、isolated、community。
    switch(config)#vlan 100
    switch(config-vlan100)#exit
    switch(config-vlan100)#private-vlan primary
    switch(config)#vlan 200
    switch(config-vlan200)#private-vlan isolated
    switch(config-vlan200)#exit
    switch(config)#vlan 300
    switch(config-vlan300)#private-vlan community
    switch(config-vlan300)#exit
    9.2.2.10 private-vlan association
    神州数码交换机配置基本命令

    命令:private-vlan association [secondary-vlan-list]
    no private-vlan association
    功能:设置 private vlan 的绑定操作,该命令的 no 操作为取消 private vlan 绑定。
    参数: [secondary-vlan-list] 为与指定 primary vlan 相关关联的 secondary vlan 列表, secondary vlan 包括 isolated vlan 和 community vlan 两种,支持“;”连接多个 secondary vlan。
    命令模式:vlan 配置模式
    缺省情况:缺省没有 private vlan 绑定。
    使用指南:只有primary类型的vlan才能设置private vlan关联关系;被关联到primary vlan
    上的 secondary vlans 内的各个端口可以和关联的 primary vlan 内的各个端口进行通信。
    在设置 private vlan 关联前,三种类型的 private vlan 都没有以太网端口的成员端口;存
    在 private vlan 关联关系的 primary vlan 不能被删除;被解除关联关系的 privatevlans 会自动
    将所属成员端口清空。
    举例:将 isolated vlan200、community vlan300 关联到 primary vlan100 上。
    switch(config-vlan100)#private-vlan association 200;300

    展开全文
  • 前面我们给大家汇总了华为、华三交换机配置命令,都是非常适合小项目的,当然碰到大型的网络工程,还是需要厂家的专业人才来做。今天再给大家分享一下锐捷交换机配置命令,这样国内三大家就全部都有了,学习一些...

    前面我们给大家汇总了华为、华三交换机的配置命令,都是非常适合小项目的,当然碰到大型的网络工程,还是需要厂家的专业人才来做。今天再给大家分享一下锐捷交换机的配置命令,这样国内三大家就全部都有了,学习一些基础网络知识还是不错的,尤其在视频监控系统中应用一下,还是可以的。

    正文:

    一、连接及远程登录

    用一台计算机作为控制台和网络设备相连接,通过计算机对网络设备进行配置。

    1、硬件连接

    把Console线一端连接在计算机的串口上,另一端连接在网络设备的Console口上。

    按照上面的线序制作一根双绞线,一端通过一个转换头连接在计算机的串口上,另一端连接在网络设备的Console口上。

    c030567fea29233e3ec654dac3aada66.png

    2、软件安装

    在计算机上安装一个终端仿真软件来登录网络设备。“超级终端”安装方法,通常是使用secureCRT较多。

    按照提示的步骤进行安装,其中连接的接口应选择"COM1",端口的速率选择“9600”,数据流控制应选择"无",其它都使用默认即可。

    0987142268d3bab8e26498b129cb583b.png

    二、基础命令

    连接上交换机后,需要进行命令配置,我们来看看配置的命令。

    1、准备命令

    db794f1fec05b9b7e9b78f2c3ce99132.png

    2、查看信息

    4036eb0513a0236f6694f9cc1b973fb8.png

    3、端口基本配置

    2d357926641809bd906dc07c88077ad1.png

    4、聚合端口创建

    cc9701c935e311f32b3b901ea255dbbe.png

    5、生成树

    4448686b42218e1208a0f3206ada28c5.png

    6、VLan的基本配置

    545bf37d3f8dc4f2cb1a9ce8086548e2.png

    7、端口安全

    c2fb9fcfff583bdf358995c98a804cb4.png

    A、配置最大连接数限制

    266731c7f1428807e3969664bf847236.png

    B、IP和MAC地址绑定

    8、三层路由功能(只针对三层交换机)

    85eed2ee4f7c7bb88aefc481373ed851.png

    9、三层交换机路由协议

    48bc0e6bc993e3734b6c535b6fe25acc.png

    三、锐捷交换机实现同VLAN不同交换通信

    我们都知道,同一个VLAN在同一个交换机中,是完全可以通信的。那么对于同一个VLAN在不同的交换机上,如果不做配置,是无法通信的,我们可以看一下下面的示例。

    示例1:

    a9892dcb8e9928f04eaf22c30a2a22d8.png

    (1)分析

    两台交换机S1和S2利用VLAN分割成几个虚拟局域网,S1中VLAN1、VLAN30与S2中的VLAN1、VLAN30虽然是同一个VLAN,但却不能直接通信。那么如何使VLAN1、VLAN30同VLAN之间可以通信呢,不同的VLAN之间不可以通信呢?

    (2)配置

    配置S1:

    S1>enable //进入特权配置模式

    S1#configure terminal //全局配置模

    ! 创建VLAN20

    S1(config)#vlan 20 //创建vlan20

    S1(config-vlan)#name VLAN20 //给这个vlan命名vlan为vlan

    ! 创建VLAN30

    S1(config-vlan)#vlan 30

    S1(config-vlan)#name VLAN30

    S1(config-vlan)#exit

    ! 把F0/4~F0/7指派给VLAN20

    S1(config)#interface f0/4 //进入端口f0/4

    S1(config-if)#switchport access vlan 20 //把这个端口划分给vlan20

    S1(config-if)#interface f0/5 //进入端口f0/5

    S1(config-if)#switchport access vlan 20

    S1(config-if)#interface f0/6

    S1(config-if)#switchport access vlan 20

    S1(config-if)#interface f0/7

    S1(config-if)#switchport access vlan 20

    ! 把F0/8~F0/11指派给VLAN30

    S1(config-if)#interface f0/8 //进入端口f0/8

    S1(config-if)#switchport access vlan 30 //把这个端口划分给vlan30

    S1(config-if)#interface f0/9

    S1(config-if)#switchport access vlan 30

    S1(config-if)#interface f0/10

    S1(config-if)#switchport access vlan 30

    S1(config-if)#interface f0/11

    S1(config-if)#switchport access vlan 30

    ! 把F0/12配置为Trunk模式

    S1(config-if)#interface f0/12 //进入端口f0/12

    S1(config-if)#switchport mode trunk // 将端口f0/12设为trunk,如果交换机只有一个vlan。就使用access接口。如果交换机有多个vlan就必须使用trunk端口,因为trunk端口可封装vlan标签。

    S1(config-if)#end //返回特权模式

    ! 查看配置结果

    S1#show vlan

    ! 保存配置

    S1#copy running-config startup-config

    配置S2:

    S2>enable

    S2#configure terminal

    ! 创建VLAN30

    S2(config)#vlan 30

    S2(config-vlan)#name VLAN30

    S2(config-vlan)#exit

    ! 把F0/1~F0/5指派给VLAN30

    S2(config)#interface range f0/1-5 //将s2中的1到5端口划分到vlan30,这个使用了端口简化配置方式,当然也可以在1中使用。

    S2(config-if)#switchport access vlan 30

    ! 把F0/12配置为Trunk模式

    S2(config-if)#interface f0/12

    S2(config-if)#switchport mode trunk // 将s2端口f0/12也设为trunk,如果交换机只有一个vlan。就使用access接口。如果交换机有多个vlan就必须使用trunk端口,因为trunk端口可封装vlan标签。

    S2(config-if)#end

    ! 查看配置结果

    S2#show vlan

    ! 保存配置

    S2#copy running-config startup-config

    如此,配置就完成了。S1中的VLAN1与S2中的VLAN1便可以通信了。

    VLAN1与VLAN20与VLAN30无法通信。

    仔细看我们不难发现,上面的配置实例看起来没有那么多代码,其实就是4行关键代码重复使用。

    四、功能配置命令示例

    交 换机密码

    (config)#enable secret level 1 0 100

    (config)#enable secret level 15 0 100

    远程登入密码

    (config)#line vty 0 4

    (config-line)#password 100

    (config-line)#end

    交换机管理IP

    (config)#interface vlan 1

    (config-if)#ip address 192.168.1.10 255.255.255.0

    (config-if)#no shutdown

    修改交换机老化时间

    (config)#mac-address-table aging-time 20

    (config)#end

    添删vlan

    (config)#vlan 888

    (config-vlan)#name a888

    (config)#no vlan 888

    添加access口

    (config)#interface gigabitEthernet 0/10

    (config-if)#switchport mode access

    (config-if)#switchport access vlan 10

    切换assess trunk

    (config-if)#switchport mode access

    (config-if)#switchport mode trunk

    指定特定一个native vlan

    (config-if)#switchport trunk native vlan 10

    配置网关:

    switch(config)#ip default-gateway 192.168.1.254

    显示接口详细信息的命令

    show interfaces gigabitEthernet 4/1 counters

    接口配置

    Switch(config)#interface gigabitethernet 0/1

    把接口工作模式改为光口。

    Switch(config-if)#medium-type fiber

    把接口工作模式改为电口。

    Switch(config-if)#medium-type copper

    VLAN配置

    建立VLAN 100

    Switch (config)#vlan 100

    该VLAN名称为ruijie

    Switch (config)#name ruijie

    将交换机接口划入VLAN 中:

    range表示选取了系列端口1-48,这个对多个端口进行相同配置时非常有用。

    Switch (config)#interface range f 0/1-48

    将接口划到VLAN 100中。

    Switch (config-if-range)#switchport access vlan 100

    将接口划回到默认VLAN 1中,即端口初始配置。

    Switch (config-if-range)#no switchport access vlan

    Switch(config)#interface fastEthernet 0/1

    该端口工作在access模式下

    Switch(config-if)#switchport mode access

    该端口工作在trunk模式下

    Switch(config-if)#switchport mode trunk

    Switch(config)#interface fastEthernet 0/2

    路由配置:添加一条路由。

    switch (config)#ip route 目的地址 掩码 下一跳

    switch (config)#ip route 210.10.10.0 255.255.255.0 218.8.8.

    展开全文
  • 交换机配置命令

    千次阅读 2020-01-21 21:19:08
    交换机配置命令 1)用户模式: switch> 可以查看交换机的基本简单信息,且不能做任何修改配置! 2)特权模式: switch> enable switch# 可以查看所有配置,且不能修改配置 但可以做测试、保存、...

    交换机的配置命令

    1)用户模式:

    switch>
    可以查看交换机的基本简单信息,且不能做任何修改配置!

    在这里插入图片描述



    2)特权模式:

    switch> enable
    switch#
    可以查看所有配置,且不能修改配置 但可以做测试、保存、初始化等操作

    在这里插入图片描述


    3)全局配置模式:

    switch# configure terminal
    switch(config)#
    默认不能查看配置! 可以修改配置,且全局生效!

    在这里插入图片描述


    4)接口配置模式:

    switch(config)# interface f0/1
    switch(config-if)# 默认不能查看配置!
    可以修改配置,且对该端口生效!

    在这里插入图片描述


    5)console口/线/控制台模式:

    默认不能查看配置!
    可以修改配置,且对console口生效!


    6)exit退出一级
    end直接退到特权模式


    7) 支持命令缩写


    8)?的用法


    9)历史命令


    上下键

    10.tab补全键


    11.配置主机名:
    conf t
    hostname 设备名
    

    在这里插入图片描述


    12.设置用户密码:

    line co 0
    password 密码
    login
    exit
    

    在这里插入图片描述在这里插入图片描述


    12.快捷键:

    ctrl+u :快速删除光标全所有字符
    ctrl+a :快速定位光标到行首
    ctrl+e :快速定位光标到行尾
    

    在内存中存在一个文件:
    running-config
    第一次开机,系统会在内存中自动
    创建一个新的干净的running-config


    14保存配置:

    en
    copy running-config startup-config
    或
    write
    

    在这里插入图片描述


    15.交换机开机动作:
    先去硬盘中查找startup-config是否存在,
    如果不存在,在内存中创建新的run
    若果存在,则复制到内存中并改名为running-config


    16.查看running-config配置

    en
    show running-config
    sh run
    

    在这里插入图片描述


    17.查看startup-config配置

    show startup-config
    

    在这里插入图片描述


    18.重启设备:

    en reload

    在这里插入图片描述


    19.配置特权密码:

    conf t
    enable password 密码  (明文)
    enable secret 密码   (密文)
    

    在这里插入图片描述
    在这里插入图片描述


    20.查看MAC地址表:

    show mac-address-table

    在这里插入图片描述


    21.查看接口状态列表:

    show ip int brief
    sh ip int b
    

    在这里插入图片描述


    22.手工关闭接口

    int f0/x
      shutdown
      exit
    

    在这里插入图片描述


    23.手工开启接口

    int f0/x
      no shutdown
      exit
    

    在这里插入图片描述


    24.do的用法
    其他模式加do空格可以强制使用特权模式的命令
    如:

    do sh run
    do sh ip int b
    do wr
    


    25.删除配置

    1)在哪配置的,就在哪删!
    2)命令前加no空格
    3)原命令中有参数,并且参数具有唯一性,则
       删除时不需要加参数
    如:
    conf t
    hostname sw1
    
    conf t
    no hostname
    

    在这里插入图片描述


    26.清空/擦除/初始化配置

    en
    erase startup-config
    

    小练习:
    1.开启一台交换机
    2.配置主机名为sw01-01
    3.配置用户密码为123.com
    4.配置特权密码为456.com
    5.通过show命令验证以上配置是否配置成功!
    6.重启验证配置是否存在
    7.重新做2-4步骤
    8.保存配置,并重启,验证是否保存成功
    9.连接2台PC,并观察MAC地址表是否形成。
    

    27.为3层端口配置IP:

    int f0/0
      ip add 10.1.1.254 255.255.255.0
      no shut
      exit
    

    28.开启远程控制:
    在这里插入图片描述

    conf t
    line vty 0 4
      transport input telnet
      password  密码
      login
      exit
    远程登录:
    telnet  + ip地址
    

    在这里插入图片描述
    在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述

    
      hostname r1
     ip domain-name r1.qf.com
      crypto key generate rsa  生成密钥对!
      line vty 0 4
      transport input telnet/ssh/none/all
      login local
      exit
    username xx password 456.com
    enable secret 123.com
    
    远程登录:
    ssh -l 用户名 地址
    
    现实中:
    ssh 用户名@IP地址
    

    在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述

    练习:
    1.成功实现在pc上telnet或ssh远程连接到路由器上,其中只做login验证
    2.成功实现在pc上telnet或ssh远程连接到路由器上,其中要求做login local验证
    

    29.为交换机配置管理IP:
    conf t
    int vlan 1
    ip add 10.1.1.253 255.255.255.0
    no shut
    在这里插入图片描述


    30.为交换机配置默认网关:
    目的:可被跨网段管理!

      conf t
      ip default-gateway 10.1.1.254
    

    31.关闭自动解析功能:

      conf t
       no ip domain-lookup
    

    展开全文
  • cisco2960交换机配置命令
  • 交换机的高级配置中,通常是利用以上配置菜单中的”[K] Command Line“项进行的,在交换机的高级配置中,通常是利用以上配置菜单中的”[K] Command Line“项进行的。Cisco交换机所使用的软件系统为Catalyst ...

    在交换机的高级配置中,通常是利用以上配置菜单中的”[K] Command Line“项进行的,

    在交换机的高级配置中,通常是利用以上配置菜单中的”[K] Command Line“项进行的。

    Cisco交换机所使用的软件系统为Catalyst IOS。CLI的全称为”Command-Line Interface“,中文名称就称之为”命令行界面“,它是一个基于DOS命令行的软件系统模式,对大小写不敏感(即不区分大小写)。有这种模式的不仅交换机有、路由器、防火墙都有,其实就是一系列相关命令,但它与DOS命令不同,CLI可以缩写命令与参数,只要它包含的字符足以与其他当前可用至的命令和参数区别开来即可。虽然对交换机的配置和管理也可以通过多种方式实现,既可以使用纯字符形式的命令行和菜单(Menu),也可以使用图形界面的Web浏览器或专门的网管软件(如CiscoWorks 2000)。相比较而言,命令行方式的功能更强大,但掌握起来难度也更大些。下面把交换机的一些常用的配置命令介绍如下。

    Cisco IOS共包括6种不同的命令模式:User EXEC模式、Privileged EXEC模式、VLAN dataBase模式、Global configuration模式、Interface configuration模式和Line configuration模式。当在不同的模式下,CLI界面中会出现不同的提示符。为了方便大家的查找和使用,表1列出了6种CLI命令模式的用途、提示符、访问及退出方法,交换机配置之交换机高级配置的常见命令网络知识》(https://www.unjs.com)。

    表1::CLI命令模式特征表        Cisco IOS命令需要在各自的命令模式下才能执行,因此,如果想执行某个命令,必须先进入相应的配置模式。例如”interface type_number“命令只能在”Global configuration“模式下执行,而”duplex full-flow-control“命令却只能在”Interface configuration“模式下执行。

    在交换机CLI命令中,有一个最基本的命令,那就是帮助命令”?“,在任何命令模式下,只需键入”?“,即显示该命令模式下所有可用到的命令及其用途,这就交换机的帮助命令。另外,还可以在一个命令和参数后面加”?“,以寻求相关的帮助。

    例如,我们想看一下在”Privileged Exec“模式下在哪些命令可用,那么,可以在”#“提示符下键入”?“,并回车。再如,如果想继续查看”Show“命令的用法,那么,只需键入”show ?“并回车即可。另外,”?“还具有局部关键字查找功能。也就是说,如果只记得某个命令的前几个字符,那么,可以使用”?“让系统列出所有以该字符或字符串开头的命令。但是,在最后一个字符和”?“之间不得有空格。例如,在”Privileged Exec“模式下键入”c?“,系统将显示以”c“开头的所有命令。

    还要说明的一点是:Cisco IOS命令均支持缩写命令,也就是说,除非您有打字的癖好,否则根本没有必要键入完整的命令和关键字,只要键入的命令所包含的字符长到足以与其他命令区别就足够了。例如,可将”show configure“命令缩写为”sh conf“,可将”show configure“命令缩写为”sh conf“然后回车执行即可。

    以上介绍了命令方式下的常见配置命令,由于配置过程比较复杂,在此不作详细介绍。

    原文转自:http://www.ltesting.net

    展开全文
  • 第6天:交换机配置命令实验01:交换机的工作模式实验目的:验证交换机常用的几个命令实验环境:实验步骤:点击主机PC0和PC1,给主机PC0和PC1配置IP地址测试PC0和PC1能否PING通点击交换机Switch0,选择命令行选项...
  • 锐捷交换机配置命令

    千次阅读 2019-09-24 16:41:37
    锐捷交换机配置命令 交换机基本操作 1.进入特权模式 Switch>enable Switch# 2.返回用户模式 Switch#exit Press RETURN to get started! Switch> 配置模式: 全局配置模式[主机名(config)#]:配置交换机的整体...
  • 交换机配置基本命令

    千次阅读 2012-01-08 20:19:43
    交换机基本状态: hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switch>enable ;进入特权模式 switch#config terminal ...
  • 华为3COM交换机配置命令讲解教程华为3COM交换机配置命令讲解教程华为3COM交换机配置命令讲解教程
  • Ruijie交换机配置telnet命令

    千次阅读 2018-04-17 10:50:46
    首先进入config模式line vty 0 4 只允许5个人同时间在线username admin password admin 配置用户名为admin 密码为adminenable password admin 配置enable密码为adminexit 退出到上一层service password-encryption ...
  • 一、交换机配置模式介绍 交换机配置模式主要有: ? 用户模式:此模式只可以简单... 特权模式:此模式可以查看一些交换机的配置,后面讲述的很多show命令便是在此模式下进行的,还可以对一些简单的设置配置,例如时间。
  • 中兴交换机配置命令

    千次阅读 2017-05-27 17:01:00
    中兴交换机配置命令 ZTE交换机配置常用命令汇总(摘自网络)个人心得:命令的使用要注意各种用户模式。配成普通交换机:把2-24端口归到VLAN1下,2-24端口如果互相隔离,可以用PVLAN删除隔离端口即可。2852s和2826s...
  • 思科交换机相关配置 ...特权用户模式可输入show命令查看相关设置,命令后输入?可查询帮助 可用no 命令撤销已经设置的配置 二、Telnet远程登录设置 1.交换机配置IP地址 进入vlan 1 //int vlan 1 启用 //
  • 锐捷交换机显示命令:显示交换机硬件及软件的信息 Switch#show version显示当前运行的配置参数 Switch#show running-config显示保存的配置参数 Switch#show configure常用锐捷交换机EXEC命令将当前运行的配置参数...
  • 思科交换机配置命令大全switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3:交换机命名hostname...
  • 常用交换机配置命令

    千次阅读 2019-06-26 14:30:52
    本文基于华为和思科各数通设备的常用命令来对比学习,这两个命令体系是网络项目中常见的,其他一些厂家也是基于类似的命令体系.下面也会根据公司业务需求列举部分网络...dis cur 显示所有配置命令 <Quidway>...
  • 如何进入交换机配置命令窗口

    万次阅读 2019-04-21 21:46:12
    网管型交换机一般都有“Console”端口,用于进行交换机配置。  物理连接完成后就要进行交换机软件配置,下面以思科“Catalyst 1900”为例来说明如何进行交换机软件配置: 第1步:单击“开始”按钮,在“程序”菜单...
  • 思科三层交换机配置命令

    千次阅读 2019-05-21 14:29:03
    1.交换机支持的命令 思科交换机基本状态: hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switch>enable ;进入特权模式 ...
  • 交换机配置命令分类总结电脑资料 交换机配置命令--VTP 为了将交换机配置成一个集群的命令交换机首先要给接口分配一个IP地址然后使用下列命令 switchconfig# cluster enable cluster-name 为了从一条中继链路上删除...
  • 博科交换机常用配置命令

    千次阅读 2020-10-30 15:48:45
    交换机基本配置命令 IP地址 ipaddrshow ipaddrset - 博科交换机的默认IP地址是10.77.77.77,在命令行模式下可以通过ipaddrset命令对交换机的IP地址进行设置和修改。 Switch Name / Hostname switchname ...
  • 交换机的基本配置命令一、实验目的通过实验掌握交换机的基本配置命令二、实验描述主要实验内容如下:1.配置主机名、密码、VLAN2.配置VLAN IP地址及默认网关三、实验拓扑四、实验设备1.S2960 1台2.PC 1台3.console线 ...
  • 锐捷交换机配置命令节选

    千次阅读 2019-05-20 15:10:18
    锐捷交换机配置命令节选 命令模式的切换 交换机和路由器的模式大体可分为四层:用户模式→特权模式→全局配置模式→其它配置模式。 进入某模式时,需要逐层进入。 进入特权模式 enable 进入全局配置模式 ...
  • 最近使用到的一些交换机配置命令,记录一下。 1. 通过mac地址查找所在交换机端口 show mac address-table address MAC地址 (MAC地址规则为**.**.**) 2. H3C交换机查看端口相邻的网络设备 Disp dnp例如...
  • cisco交换机常用配置命令

    千次阅读 2019-04-11 15:59:07
    前段时间我们发布了关于学校机房项目交换机的配置,理解这篇,交换机配置不再难,这篇是以思科交换机为配置基础,有部分朋友觉得有些难度,希望我们发些基础些的内容,本期我们就一起来看下思科的基础配置。...
  • 锐捷交换机配置命令大全

    千次阅读 多人点赞 2020-07-26 19:17:38
    一、基础配置命令 1、准备命令 >Enable 进入特权模式 #Exit 返回上一级操作模式 #End 返回到特权模式 #write memory 或copy running-config startup-config 保存配置文件 #del flash:config.text 删除配置文件...
  • Switch#hostname //配置主机名 Switch#show version //...Switch#show running-config //查看交换机当前配置信息 Switch#show startup-config //显示已保存的配置信息 Switch#copy running-config startup...
  • 中兴2826S系列交换机常用配置命令 发表于 2009-12-24 22:10:26 以下命令只包含一些常用的命令[//]后面的表示注解,即说明本条命令所产生的意义。 以下命令适用于中兴ZXR10 2609/2818S/2826S/2852S系列交换机 命令...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 15,843
精华内容 6,337
关键字:

交换机配置查看命令show