精华内容
下载资源
问答
  • 交换机Hybrid端口配置

    2019-04-24 10:22:00
    交换机Hybrid端口配置,通过Hybrid配置实现不同PC机之间访问及隔离。
  • H3C交换机开启关闭端口及限速

    千次阅读 2020-12-22 18:33:13
    如果要查看当前所有端口的配置,可以通过:dis cu这条命令进行查询,当然这条命令会显示所有当前生效的配置,不仅仅包含端口的配置,这条命令经常用来检查交换机的配置情况,用来排查故障,比较常用的;如果只想查看...

    登录

    telnet ip

    输入账号密码登录

    查看全部端口的配置

           display current-configuration   

           display current-configuration interface

    如果要查看当前所有端口的配置,可以通过:dis cu这条命令进行查询,当然这条命令会显示所有当前生效的配置,不仅仅包含端口的配置,这条命令经常用来检查交换机的配置情况,用来排查故障,比较常用的;如果只想查看所有端口的配置而不需要其他配置,可以使用更精确的命令:dis cu int来查看。

    dis cu int(空格键翻页查看交换机端口,q退出)

     

    sys (system-view的缩写,进入系统视图,表示方式为[H3C],在系统视图下可以进一步的查看交换机的配置信息和调试信息)

     

    在系统视图下输入interface命令可以进入以太网端口视图,如在[H3C]输入"interface g1/0/1"(或简写int g1/0/1),就进入了该交换机的第一个端口

     

    以上我是进入的2/0/10

    display this    查看当前端口生效配置

    dis th //缩写

     

    port link-mode bridge //端口开启状态

     

    关闭端口:shutdown

    开启:undo shutdown

     

    qos 流量限制

    inbound 上行

    outbound 下行

    qos apply policy 200M outbound \\限速下行200M,命令都可以tab补全,qos限速可能会略有浮动

    speed //强制限速,单位M,只能10,100,1000...(上下行)

     

    取消:undo

    undo speed

    undo qos apply policy 200M outbound

     

    如果Speed、Inbound、outbound都在同一个端口里,那个带宽低就是就会执行那条命令

     

    save //保存

     

    quit //退出

     

     

     

    展开全文
  • 交换机端口安全

    2020-03-26 17:57:23
    交换机端口安全 本篇讲一下交换机端口安全,虽然简单,但是在生活的运用极为常见,可以有效的保护我们的网络的安全。 端口安全 端口安全(Port Security),从基本原理上讲,Port Security特性会通过MAC地址表...

    交换机的端口安全

    本篇讲一下交换机的端口安全,虽然简单,但是在生活的运用极为常见,可以有效的保护我们的网络的安全。

    端口安全

    端口安全(Port Security),从基本原理上讲,Port Security特性会通过MAC地址表记录连接到交换机端口的以太网MAC地址(即网卡号),并只允许某个MAC地址通过本端口通信。其他MAC地址发送的数据包通过此端口时,端口安全特性会阻止它。使用端口安全特性可以防止未经允许的设备访问网络,并增强安全性。另外,端口安全特性也可用于防止MAC地址泛洪造成MAC地址表填满。
    常见的端口安全有绑定其MAC地址,只允许本台物理设备访问网络,一般安全性较高的公司不允许私人电脑连接公司内网,即使连接上也是无法访问网络的。也有的限制其最大的连接数,当超过一定数量的MAC地址时,自动关闭端口来保护网络,这两种方法都能有效的防止MAC欺骗和泛洪攻击。

    配置命令

    SW1(config)#interface f0/1 //进入端口模式
    SW1(config-if)#switch mode access //把端口改为访问模式
    SW1(config-if)#switch port-security //打开交换机的端口安全功能
    sw03(config-if)#switch port-security maximum 3 // 设置端口上的最大同时连接数为 3
    R10(config-if)#mac-address 3.3.3 //修改MAC地址
    SW1(config-if)#switchport port-security violation restrict //修改violation方式为restrict 默认shutdown,还有protect模式可选。
    SW1(config-if)#switchport port-security mac-address 7.7.7 //将路由器f0/0 的mac地址绑定,静态绑定MAC地址

    实例举例

    在这里插入图片描述
    环境:R9、R10模拟PC,保证R9与R10能够互相通信,SW1作为交换机。
    需求1:使用交换机端口安全技术,使得当R9的mac地址发生变化时,R9无法再次ping通R10。改回原来mac地址,恢复通信。
    需求2:设置交换机e0/1端口上的最大同时连接数为 3,当连接数超过3时,R9无法与10通信。
    需求3:修改violation方式,将SW1的e0/0修改成restrict,并且绑定mac地址7.7.7,将e0/1修改成protect,并且绑定mac地址8.8.8。

    配置:
    底层配置,配置IP地址,这里不再介绍。
    需求1:
    先来看没配置之前的情况,SW1正常学习到R9与R10的mac地址,可以正常通信。
    在这里插入图片描述
    配置端口保护:
    SW1(config)#interface f0/1 //进入端口模式
    SW1(config-if)#switch mode access //把端口改为访问模式
    SW1(config-if)#switch port-security //打开交换机的端口安全功能

    配置完成,我们修改R9的mac地址
    R11(config)#int e0/0
    R11(config-if)#mac-address 1.1.1
    这时候我们来查看访问情况和mac地址表
    在这里插入图片描述
    在这里插入图片描述
    可以看到,现在R9已经ping通不了R10了,SW1的mac地址也随之变化,新的mac地址也无法被交换机学到。
    现在,我们把mac地址重新改回来。
    R11(config)#int e0/0
    R11(config-if)#mac-address aabb.cc00.9000
    这时候我们会发现还是没有变化,理由是由于端口安全的配置,导致接口现在是err-disabled的双down情况,所以需要我们将接口shutdown,再 no shutdown 。
    在这里插入图片描述
    SW1(config)#int e0/1
    SW1(config-if)#shutdown
    SW1(config-if)#no shutdown

    这时后我们再来查看访问和mac地址表,
    在这里插入图片描述
    在这里插入图片描述
    成功恢复通信,到此,需求1满足需求。

    需求2:
    SW1(config)#int e0/0
    SW1(config-if)#switch mode access //把端口改为访问模式
    sw03(config-if)#switch port-security
    sw03(config-if)#switch port-security maximum 3 设置端口上的最大同时连接数为 3

    配置完成,我们在R10修改mac地址为2.2.2和3.3.3
    R10(config-if)#mac-address 2.2.2
    R10(config-if)#mac-address 3.3.3
    此时来查看交换机MAC地址表
    在这里插入图片描述

    此时有MAC地址表有只有3个连接数,还是可以实现访问通信。
    在这里插入图片描述

    再在R10修改mac地址为4.4.4
    R10(config-if)#mac-address 4.4.4
    此时来查看访问和MAC地址表,mac地址连接数已经超过了3个,所以触发端口安全,使得R9无法访问R10。
    在这里插入图片描述
    在这里插入图片描述

    到此,满足需求2的要求。

    需求3:
    SW1(config)#int e0/0
    SW1(config-if)#switchport port-security violation restrict //修改violation方式为restrict
    SW1(config-if)#switchport port-security mac-address 7.7.7 //然后将路由器f0/0 的mac地址绑定
    SW1(config)#int e0/0
    SW1(config-if)#switchport port-security violation protect //修改violation方式为protect
    SW1(config-if)#switchport port-security mac-address 8.8.8 //然后将路由器f0/0 的mac地址绑定

    到此,满足全部需求。
    补充:
    1、protect 模式,当违规时,只丢弃违规的数据流量,不违规的正常转发,而且不会通知有流量违规,也就是不会发送SNMP trap ;
    2、restrict , 当违规时,只丢弃违规的流量,不违规的正常转发,但它会产生流量违规通知,发送SNMP trap,并且会记录日志;
    3、shutdown,这个是默认模式,当违规时,将接口变成error-disabled并shut down,并且接口LED灯会关闭,也会发SNMP trap,并会记录syslog。

    展开全文
  • H3C交换机-端口绑定与端口安全
  • #interface 第一步查出来的端口名 (进入端口) #shutdown (关闭接口) #end (结束配置) #write (保存配置) 打开接口: #enable #configure terminal #interface FastEthernet 0/1 进入端口 #no s...

    设备的接口默认是打开状态
    配置之前建议使用

    #show interface status(查看接口名称)
    关闭接口:
    #enable 
    #configure terminal
    #interface 第一步查出来的端口名   (进入端口)
    #shutdown    (关闭接口)
    #end     (结束配置)
    #write      (保存配置)


    打开接口:
    #enable 
    #configure terminal
    #interface FastEthernet 0/1       进入端口
    #no shutdown     打开接口
    #end
    #write      保存配置

    展开全文
  • 交换机Trunk端口配置,功能需求及组网说明,配置环境参数,数据配置步骤,配置命令代码,利用将端口配置为Trunk端口来完成在不同交换机之间透传VLAN,达到属于相同VLAN的PC机,跨交换机进行二层访问;或者不同VLAN的...
  • 模拟器:eNSP 安全端口: 将设备端口学习到的MAC地址变为安全MAC地址(分为两类:安全动态MAC地址和Sticky安全地址,这两类地址是设备信任的地址),以阻止除了安全动态MAC...开启端口后,默认学习到的最大地址数为1,

    模拟器:eNSP

    安全端口:
    将设备端口学习到的MAC地址变为安全MAC地址(分为两类:安全动态MAC地址和Sticky安全地址,这两类地址是设备信任的地址),以阻止除了安全动态MAC和静态MAC之外的主机通过本接口和交换机通信。

    安全MAC地址类型:
    1.安全动态MAC地址:
    当接口上学习到了MAC地址,地址会转换为动态MAC地址,如果当接口上学习的最大MAC地址数量达到上限以后不会再学习新的安全动态MAC地址,并且只允许原来学习到的地址的设备进行入交换机进行通信。开启端口后,默认学习到的最大地址数为1,也就是说只允许学习的第一个MAC地址进行通信,就算原来接口上有多个MAC地址,也只允许现在存在的安全地址进行通信。

    当收到了其他MAC地址的报文,有三种动作:分别是保护,限制和关闭,三种方式有一个共同点都是不转发报文,保护是系统不会做出任何提示,限制是系统会做出警告,让管理员发现,关闭是直接将相应的端口进行关闭,并做出相应的提示,让这个接口无法接收任何数据帧。

    安全动态MAC地址不老化,但是可以设置老化时间。最后,安全动态MAC地址会在设备重启后消失。

    2.Sticky MAC地址:
    粘性MAC地址和安全动态MAC地址都是属于安全MAC地址,其实现的功能也是一样的,他们之间的不同主要体现在以下三个方面:

    1. 安全动态MAC地址可以设置老化的时间(默认为0表示永不老化),自己设置的时候不能设置为0,但是粘性MAC地址是不能够设置老化时间的。
    2. 安全动态MAC地址重启和会失效,而粘性MAC地址重启后仍然存在,只有undo掉命令才会失效。
    3. 安全动态MAC地址表项只能通过动态学习到,而粘性MAC地址表既可以通过安全动态MAC地址转换得到,也可以进行手工的配置。

    实验拓扑:
    在这里插入图片描述
    PC1:
    在这里插入图片描述
    PC2:
    在这里插入图片描述

    具体步骤:
    1.测试安全动态MAC地址的学习
    首先没有进行任何配置,让双方进行通信,然后在交换机上查看对应的MAC地址表:
    在这里插入图片描述
    然后在接口上开启安全动态MAC地址的功能,配置:
    interface GigabitEthernet0/0/1
    port-security enable
    重新进行PC1和PC2的通信:
    在这里插入图片描述
    发现原来的动态MAC地址被覆盖变为了动态安全MAC地址,如果在接口上原来配置的是普通静态MAC地址,如果开启了安全功能,静态地址不会进行类型的转换,但是却具有了相应安全接口的特性。

    然后检查安全端口的特性,我们将PC1的MAC地址进行修改:
    在这里插入图片描述
    然后用PC1pingPC2,发现ping不通,说明安全端口起作用了。
    在这里插入图片描述
    并且弹出了 警告(安全接口的模拟保护模式是限制):
    在这里插入图片描述
    然后修改其学习的最大的安全MAC地址数量:
    interface GigabitEthernet0/0/1
    port-security max-mac-num 2 //进入接口,设置最大学习的MAC地址为2
    用修改了MAC地址的PC1去pingPC2,观察结果:
    在这里插入图片描述
    已经可以通信了,在交换机上查看对应的MAC地址表,发现安全地址已经从原来的1个变为现在的两个了,说明修改最大的安全MAC地址学习数量成功。
    在这里插入图片描述
    2.测试Sticky MAC地址的学习,首先配置动态学习的Sticky MAC,配置:
    interface GigabitEthernet0/0/2 //进入接口
    port-security enable //开启粘性MAC地址之前需要开启安全接口的功能
    port-security mac-address sticky //然后将接口转换为粘性MAC地址的接口
    然后用PC2pingPC1:(发现在g0/0/2上有了粘性的MAC地址)
    在这里插入图片描述
    静态添加粘性MAC地址的配置:(首先需要进入绑定MAC地址的接口)
    port-security mac-address sticky 8888-9999-7777 vlan 1 //注意这个MAC地址条目需要绑定vlan,如果接口上已经有了对应的安全MAC地址,并且已经到达了最大数量,这条命令不成功

    其他配置:
    设置安全动态端口的条目的老化时间:(进入接口)
    port-security aging-time x //时间为分钟
    在这里插入图片描述
    设置安全端口的保护动作:(进行接口)
    port-security protect-action x //之后跟上自己选取的保护方式,模式是第二个限制
    在这里插入图片描述
    注意:安全地址开启后学习到了动态安全MAC地址,如果再在此接口上开启粘性功能,其动态安全MAC地址直接转换为粘性MAC地址,并且undo掉此功能后,粘性MAC地址自动消失(动态MAC地址也会自动消失)。

    展开全文
  • 这里需要拒绝PC1和PC2互相访问),可以在交换机SWA上配置端口隔离功能,具体配置如下: [SWA]port-isolate group 1 #创建端口隔离组 [SWA-Ethernet1/0/1]port-isolate enable group 1 #将端口1
  • 如何理解交换机混杂端口?

    千次阅读 2019-05-29 19:13:15
    有这样一种情况,我们需要在交换机的一台端口上接PC和其他交换机。那么,这个接口设置为access会不合适,设置为trunk也不合适,就出现了混杂端口。 知识补充 untag 设置untag的vlan在数据包发出时不打标记。可理解...
  • 实验目标 l掌握交换机基本信息的配置管理。 实验背景 l某公司新进一批交换机,在投入网络以后要进行初始配置与管理,...这种管理方式不占用交换机的网络端口,第一次配置交换机必须利用Console端口进行配置。 l...
  • 交换机端口聚合配置又是怎么回事呢,那么交换机端口聚合如何配置的呢?下面是学习啦小编收集整理的交换机端口聚合如何配置,希望对大家有帮助~~交换机端口聚合配置的方法工具/原料计算机网络工具软件方法/...
  • 前言:expect是一个自动化交互套件,主要应用于执行命令和程序时,...进入192.168.11.1交换机,输入密码,输入enable密码,进入0/11端口下,关闭端口,最后退出。 #!/usr/bin/expect set timeout 3 spawn telnet 19.
  • 路由器端口(Cisco Packet Tracer) 本次实验是5.实验的修改,虽然说是路由器,...Switch(config)#ip routing //三层交换机开启路由功能 Switch(config-if)#no switchport //该接口不再是交换接口了,成为路由接口 测试
  • 04. 交换机端口聚合配置

    万次阅读 多人点赞 2018-11-20 13:21:33
    交换机端口聚合配置 ...1)端口聚合(又称为链路聚合),将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽带的端口,可以实现负载分担,并提供冗余链路。 2)端口聚合使用的是E...
  • 定时关闭华为交换机端口

    千次阅读 2015-10-19 12:17:01
    关于因业务须求,定时关闭交换机端口的做法 通过对各种资料的查询与对比,我现在知道了两种可以实现在某一特定时间内关闭交换机端口,并在另一时间段打开端口的做法。现我将其做法与大家分享一下。希望大家提出好...
  • 华三V5、V7交换机POE开启 POE通过以太网电口,利用双绞线进行远程供电 开启GigabitEthernet 1/0/1的PoE。 开启GigabitEthernet 1/0/1的PoE。 [H3C] interface GigabitEthernet 1/0/1 [H3C-GigabitEthernet1/0/1]...
  • 端口聚合(又称为链路聚合),将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽口的端口,可以实现负载分担,并提供冗余链路。 技术原理: 端口聚合使用的是EtherChanne特性,在...
  • 一,路由器和交换机开启snmp 开启snmp ,可以通过 web 管理界面,也可以用命令 1.开启snmp 2.选择snmp 协议版本,我一般都选择v2版本,v3 我没用过,我看到还需要密码,所以没用过;v2 版本只需要...
  • STP根交换机、备份根交换机、根端口的配置修改 STP 运算第一步:通过比较每台交换机的ID(交换机优先级+MAC地址构成)选举根交换机交换机优先级低为根交换机,次之为备份根交换机(优先级相同比较交换机...
  • 交换机实现端口保护

    2008-02-14 11:20:00
    交换机实现端口保护现在网络安全要求也越来越高了,一个局域网有时候也希望能够做到互相不能访问。我主要是给大家介绍一下在cisco的交换机上面如何来实现大家的需求。 在cisco 低端交换机中的实现方法: 1.通过端口...
  • 首先我们要开启交换机的terminal monitor功能 在特权模式下输入 terminal monitor 然后我们手动的关闭某个端口,就会发现我们弹出了一个提示 (2)第二种方式就是我们选择一种工具这里是选用的我们日常运维所用的...
  • MAC端口安全 ...3.将S1交换机的E0/0/1端口开启安全检测功能,并配置Sticky MAC功能。 4.从PC1 PING PC2 ,查看S1、S2、S3的MAC地址表,分别截图记录,等待20秒之后再次查看3台交换机的MAC地址表,对比
  • 一、实验拓扑图: 二、实验要求: ...3.将S1交换机的E0/0/1端口开启安全检测功能,并配置StickyMAC功能。 4.从PC1PINGPC2,查看S1、S2、S3的MAC地址表,分别截图记录,等待20秒之后再次查看3台...
  • 端口环路检测的作用是检测交换机端口是否存在环路。如果端口存在环路,会导致mac 地址学习错误,且容易造成广播风暴,严重时会导致交换机及网络瘫痪。启用单端口的环路检测,关闭有环路的端口,可以有效的消除...
  • 一、实验名称 ...了解交换机端口配置命令行 1.新建Packet Tracer拓扑图 2.了解交换机端口配置命令行 2.交换机的Telnet远程登陆配置 1.新建Packet Tracer拓扑图 2.配置交换机管理IP地址 3.配置用...
  • 交换机网络端口禁用

    千次阅读 2016-10-17 17:03:24
    登陆后是用户模式Switch>,输入enter进入管理模式Switch#,输入config进入全局模式,进入端口(例如24号网口)Switch_config#interface fastEthernet 0/24,输入关闭命令shutdown。进入端口(例如G2网口)Switch_...
  • 2016计算机网络技术实验实训教程:实验五三层交换机端口配置计算机网络技术实验实训教程实验五 三层交换机端口配置实验名称...实现功能:开启三层交换机物理端口的路由功能。实验设备:S3750一台,直连线一根。...
  • 如何查看交换机端口下接什么设备?(以H3C为例,) step 1:  查看端口状态,看物理端口是否启用,未启用则端口未接设备或设备未开机。   step 2:  若端口开启状态,则查看接口下MAC-ADDRESS  dis ...
  • 转载——华为交换机镜像端口配置

    千次阅读 2019-03-25 22:49:15
    端口镜像华为交换机端口镜像配置 通过配置镜像功能,可以将报文复制到特定的目的地进行分析,以进行网络监控和故障定位。 镜像是指将经过指定端口(源端口或者镜像端口)的报文复制一份到另一个指定端口(目的端口...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 25,353
精华内容 10,141
关键字:

交换机如何开启端口