精华内容
下载资源
问答
  • eth-trunk链路聚合
    千次阅读
    2021-12-30 15:22:31

    概述

    以太网利纳鲁聚合Eth-Trunk简称链路聚合,它通过将多条以太网物理链路捆绑在一起成为一条路基链路,从而实现增加链路带宽的目的。同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效地提高链路的可靠性。

    采用链路聚合技术可以在不进行硬件升级的条件下,通过将多个物理接口捆绑为一个逻辑接口,达到增加链路带宽的目的。在实现增大带宽的同时,链路聚合采用备份链路的机制,可以有效的提高设备之间链路的可靠性。

    增加带宽

    链路聚合接口的最大带宽可以达到各成员接口之和。

    提高可靠性

    当某条活动链路出现故障时,流量可以切换到其他可用的成员链路上,从而提高链路聚合接口的可靠性。

    负载分担

    在一个链路聚合组内,可以实现在各成员活动链路上的负载分担。

    链路聚合组和链路聚合接口

    链路聚合组LAG(Link Aggregation Group)是指将若干条以太链路捆绑在一起所形成的逻辑链路。

    每个聚合组唯一对应着一个逻辑接口,这个逻辑接口称之为链路聚合接口或Eth-Trunk接口。

    成员接口和成员链路

    组成Eth-Trunk接口的各个物理接口称为成员接口。成员接口对应的链路称为成员链路。

    活动接口和非活动接口、活动链路和非活动链路

    链路聚合组的成员接口存在活动接口和非活动接口两种。转发数据的接口称为活动接口,不转发数据的接口称为非活动接口。

    活动接口数上限阈值

    设置活动接口数上限阈值的目的是在保证带宽的情况下提高网络的可靠性。当前活动链路数目达到上限阈值时,再向Eth-Trunk中添加成员接口,不会增加Eth-Trunk活动接口的数目,超过上限阈值的链路状态将被置为Down,作为备份链路。

    手工负载分担模式链路聚合不支持活动接口书上限阈值的配置

    链路聚合模式分为手工模式和LACP模式两种

    手工模式下,Eth-Trunk的建立、成员接口的加入由手工配置,没有链路聚合控制协议LACP的参与。当需要在两个直连设备之间提供一个较大的链路带宽而设备又不支持LACP协议时,可以使用手共模式。手工模式可以实现增加带宽,提高可靠性和负载分担的目的。

    LACP模式Eth-Trunk建立过程下:

    1、两段互相发送LACPDU报文。

    在DeviceA和DeviceB上创建Eth-Trunk并配置为LACP模式,然后想Eth-Trunk中手工加入成员接口。此时成员接口上便启用了LACP协议,两端互发LACPDU报文。

    2、确定主动端和活动端链路。

    两端设备均会收到对端发过来的LACPDU报文。以DeviceB为例,当DeviceB收到DeviceA发送的报文时,DeviceA的系统优先级高于本端的系统优先级,则确定DeiveA为LACP主动端。如果DeviceA和DeviceB的系统优先级相同,比较两端设备的MAC地址,去确定MAC地址小的一端为LACP主动端。

    选出主动端后,两端都会以主动端的接口优先级来选择活动接口,两端设备选择了一致的活动接口,活动链路组便可以建立起来,从这些活动链路中以负载分担的方式转发数据。

    3、LACP抢占:

    使能LACP抢占功能后,聚合组会始终保持高优先级的接口作为活动接口的状态。

    配置注意事项:

    链路聚合前:

    成员接口不能配置某些业务,例如成员接口不能修改接口类型,不能配置静态MAC地址。

    Eth-Trunk接口不能嵌套,即Eth-Trunk接口的成员接口不能是Eth-Trunk接口。
    一个Eth-Trunk接口中的成员接口必须是以太网类型和速率相同的接口。
    以太网类型和速率不同的接口不能加入同一个Eth-Trunk接口,如GE接口和FE接口不能加入同一个Eth-Trunk接口,GE电接口和GE光接口不能加入同一个Eth-Trunk接口。
    如果本端设备接口加入了Eth-Trunk,与该接口直连的对端接口也必须加入Eth-Trunk,两端才能正常通信。
    两台设备对接时需要保证两端设备上链路聚合的模式一致。
    链路聚合后:
    一个以太网接口只能加入到一个Eth-Trunk接口,如果需要加入其它Eth-Trunk接口,必须先退出原来的Eth-Trunk接口。
    当成员接口加入Eth-Trunk后,学习MAC地址或ARP地址时是按照Eth-Trunk来学习的,而不是按照成员接口来学习。
    删除聚合组时需要先删除聚合组中的成员接口。

    [SW1]dis current-configuration
    sysname SW1
    vlan batch 10 20
    
    interface Eth-Trunk1
    port link-type trunk
    port trunk allow-pass vlan 10 20
    
    interface GigabitEthernet0/0/1
    eth-trunk 1 //加入Eth-trunk接口
    
    interface GigabitEthernet0/0/2
    eth-trunk 1 //加入Eth-trunk接口
    
    interface GigabitEthernet0/0/3
    eth-trunk 1 //加入Eth-trunk接口

    执行:display eth-trunk 1,查看配置结果:
    配置LACP模式链路聚合:
    如下图,在两台设备上配置LACP模式链路聚合组,提高两设备之间的带宽与可靠性,具体要求如下:
    两条活动链路具有负载分担的能力。
    两设备间的链路具有一条冗余备份链路,当活动链路出现故障链路时,备份链路替代故障链路,保持数据传输的可靠性。

    [SW3]dis current-configuration
    sysname SW3
    lacp priority 100
    //配置系统LACP优先级
    
    interface Eth-Trunk1
    //创建eth-trunk接口
    mode lacp-static
    //配置链路聚合模式为LACP模式
    least active-linknumber 2
    //配置链路聚合活动接口数下限阈值
    max bandwidth-affected-linknumber 3
    //配置带宽计算的端口数量
    load-balance dst-ip
    //配置负载分担方式
    lacp timeout fast
    //配置当前接口接收LACP协议报文的超时时间
    lacp preempt enable
    //使能当前Eth-Trunk接口的LACP抢占功能
    max active-linknumber 2
    //配置链路聚合活动接口数上限阈值
    lacp preempt delay 20
    //配置当前Eth-Trunk接口的LACP抢占等待时间
    //配置为fast,对端发送LACP报文的周期为1秒。
    //配置为slow,对端发送LACP报文的周期为30秒。
    //LACP协议报文的超时时间为LACP报文发送周期的3倍
    lacp selected speed
    //更改LACP模式Eth-Trunk依据接口速率来选择活动接口
    
    interface GigabitEthernet0/0/1
    eth-trunk 1 //加入Eth-trunk接口
    lacp priority 100
    //配置当前接口的LACP优先级
    
    interface GigabitEthernet0/0/2
    eth-trunk 1
    
    interface GigabitEthernet0/0/3
    eth-trunk 1

    trunkport interface gi 0/0/1 to 0/0/3
    //将多个接口同时加上eth-turnk接口中
    
    display eth-trunk [ trunk-id [ interface interface-type interface-number | verbose ] ]
    //查看Eth-Trunk接口的配置信息
    
    display lacp statistics eth-trunk 1
    //查看LACP模式下LACP报文收发统计信息
    
    display interface eth-trunk 1
    //查看eth-trunk接口的状态信息
    
    display trunkmembership eth-trunk 1
    //查看eth-trunk的成员接口信息
    
    reset lacp statistics eth-trunk 1
    //清除LACP收发报文的统计信息
    
    reset lacp error packet statistics
    //清除LACP错误报文的统计信息

    可查看另一篇类似文章:链路聚合Eth-Trunk_曹世宏的博客-CSDN博客_eth-trunk

    更多相关内容
  • Eth-Trunk链路聚合

    千次阅读 2021-07-15 08:49:36
    一、链路聚合原理 1.1 原理简述 链路聚合能够提高链路带宽,增强网络可用性,支持负载分担。 链路聚合是把两台设备之间的多条物理链路聚合在一起,当做一条逻辑链路来使用。这两台设备可以是一对路由器,一对交换机...

    一、链路聚合原理

    1.1 原理简述

    链路聚合能够提高链路带宽,增强网络可用性,支持负载分担。

    在这里插入图片描述
    链路聚合是把两台设备之间的多条物理链路聚合在一起,当做一条逻辑链路来使用。这两台设备可以是一对路由器,一对交换机,或者是一台路由器和一台交换机。一条聚合链路可以包含多条成员链路,默认最多为8条。链路聚合能够提高链路带宽。理论上,通过聚合几条链路,一个聚合口的带宽可以扩展为所有成员口带宽的总和,这样就有效地增加了逻辑链路的带宽。链路聚合为网络提供了高可靠性。配置了链路聚合之后,如果一个成员接口发生故障,该成员口的物理链路会把流量切换到另一条成员链路上。链路聚合还可以在一个聚合口上实现负载均衡,一个聚合口可以把流量分散到多个不同的成员口上,通过成员链路把流量发送到同一个目的地,将网络产生拥塞的可能性降到最低。

    1.2 链路聚合模式

    链路聚合包含两种模式:手动负载均衡模式和静态LACP(Link Aggregation Control Protocol)模式。

    1.2.1 手工负载均衡模式

    • 手工负载分担模式下所有活动接口都参与数据的转发,分担负载流量。
      在这里插入图片描述
      手工负载分担模式下,Eth-Trunk的建立、成员接口的加入由手工配置,没有链路聚合控制协议的参与。该模式下所有活动链路都参与数据的转发,平均分担流量,因此称为负载分担模式。如果某条活动链路故障,链路聚合组自动在剩余的活动链路中平均分担流量。当需要在两个直连设备间提供一个较大的链路带宽而设备又不支持LACP协议时,可以使用手工负载分担模式。ARG3系列路由器和X7系列交换机可以基于目的MAC地址,源MAC地址,或者基于源MAC地址和目的MAC地址,源IP地址,目的IP地址,或者基于源IP地址和目的IP地址进行负载均衡。

    1.2.2 静态LACP(Link Aggregation Control Protocol)模式

    • LACP模式支持链路备份。

    在这里插入图片描述
    在静态LACP模式中,链路两端的设备相互发送LACP报文,协商聚合参数。协商完成后,两台设备确定活动接口和非活动接口。在静态LACP模式中,需要手动创建一个Eth-Trunk口,并添加成员口。LACP协商选举活动接口和非活动接口。静态LACP模式也叫M:N模式。M代表活动成员链路,用于在负载均衡模式中转发数据。N代表非活动链路,用于冗余备份。如果一条活动链路发生故障,该链路传输的数据被切换到一条优先级最高的备份链路上,这条备份链路转变为活动状态。

    在静态LACP模式的Eth-Trunk中加入成员端口后,这些端口将向对端通告自己的优先级、mac地址、接口优先级、接口ID等信息,对端接受到这些信息后,将这些信息与自身接口所保存的信息进行比较以选择出能够聚合的端口双方对那些端口能够达成一致,确定活动链路。
    在两端设备中选择优先级较高的一端作为主动端,如果系统LACP优先级相同则选择Mac地址较小的一端作为主动端(注:系统优先级的值越小,优先级越高,默认是32768)
    接口LACP的值越小优先级越高,如果接口LACP的值相同,接口ID小的优先级被选为活动接口(注:接口LACP优先级是为了区分同一个Eth-Trunk中不同接口被选为活动接口的有限程度,优先级越高的接口被选择为活动接口)

    静态LACP的抢占机制:
    LACP抢占延时设置:LACP抢占发生时,处于备份状态的链路将会等待一段时间后,再切换到转发状态,这就是抢占延时配置抢占延时是为了避免由于某些链路频繁变化而导致的Eth-trunk数据传输不稳定的情况发生,在链路恢复正常,若系统使能了LACP抢占延时,端口重新切换回活动端口的状态就需要经过抢占延时的时间。

    1.3 流量控制

    • Eth-Trunk链路两端相连的物理接口的数量、速率、双工方式、流控方式必须一致。
      在这里插入图片描述
      在一个聚合口中,聚合链路两端的物理口(即成员口)的所有参数必须一致,包括物理口的数量,传输速率,双工模式和流量控制模式。成员口可以是二层接口或三层接口。数据流在聚合链路上传输,数据顺序必须保持不变。一个数据流可以看做是一组MAC地址和IP地址相同的帧。例如,两台设备间的Telnet或FTP连接可以看做一个数据流。如果未配置链路聚合,只是用一条物理链路来传输数据,那么一个数据流中的帧总是能按正确的顺序到达目的地。配置了链路聚合后,多条物理链路被绑定成一条聚合链路,一个数据流中的帧通过不同的物理链路传输。如果第一个帧通过一条物理链路传输,第二个帧通过另外一条物理链路传输,这样一来同一数据流的第二个数据帧就有可能比第一个数据帧先到达对端设备,从而产生接收数据包乱序的情况。为了避免这种情况的发生,Eth-Trunk采用逐流负载分担的机制,这种机制把数据帧中的地址通过HASH算法生成HASH-KEY值,然后根据这个数值在Eth-Trunk转发表中寻找对应的出接口,不同的MAC或IP地址HASH得出的HASH-KEY值不同,从而出接口也就不同,这样既保证了同一数据流的帧在同一条物理链路转发,又实现了流量在聚合组内各物理链路上的负载分担,即逐流的负载分担。逐流负载分担能保证包的顺序,但不能保证带宽利用率。
      负载分担的类型主要包括以下几种,用户可以根据具体应用选择不同的负载分担类型。
    1. 根据报文的源MAC地址进行负载分担;
    2. 根据报文的目的MAC地址进行负载分担;
    3. 根据报文的源IP地址进行负载分担;
    4. 根据报文的目的IP地址进行负载分担;
    5. 根据报文的源MAC地址和目的MAC地址进行负载分担;
    6. 根据报文的源IP地址和目的IP地址进行负载分担;
    7. 根据报文的VLAN、源物理端口等对L2、IPv4、IPv6和MPLS报文进行增强型负载分担。

    二、链路聚合配置

    配置Eth-Trunk口和成员口,需要注意以下规则:

    1. 只能删除不包含任何成员口的Eth-Trunk口。
    2. 把接口加入Eth-Trunk口时,二层Eth-Trunk口的成员口必须是二层接口,三层Eth-Trunk口的成员口必须是三层接口。
    3. 一个Eth-Trunk口最多可以加入8个成员口。
    4. 加入Eth-Trunk口的接口必须是hybrid接口(默认的接口类型)。
    5. 一个Eth-Trunk口不能充当其他Eth-Trunk口的成员口。
    6. 一个以太接口只能加入一个Eth-Trunk口。如果把一个以太接口加入另一个Eth-Trunk口,必须先把该以太接口从当前所属的Eth-Trunk口中删除。
    7. 一个Eth-Trunk口的成员口类型必须相同。例如,一个快速以太口(FE口)和一个千兆以太口(GE口)不能加入同一个Eth-Trunk。
    8. 位于不同接口板(LPU)上的以太口可以加入同一个Eth-Trunk口。如果一个对端接口直接和本端Eth-Trunk口的一个成员口相连,该对端接口也必须加入一个Eth-Trunk口。否则两端无法通信。
    9. 如果成员口的速率不同,速率较低的接口可能会拥塞,报文可能会被丢弃。
    10. 接口加入Eth-Trunk口后,Eth-Trunk口学习MAC地址,成员口不再 学习。
    11. 如果要在路由器上配置三层链路聚合,需要首先创建Eth-Trunk接口,然后在Eth-Trunk逻辑口上执行undo portswitch命令,把聚合链路从二层转为三层链路。执行undo portswitch命令后,可以为Eth-Trunk逻辑口分配一个IP地址。
    [Huawei]interface Eth-Trunk 1 
    [Huawei-Eth-Trunk1]interface GigabitEthernet0/0/1
    [Huawei-GigabitEthernet0/0/1]eth-trunk 1
    [Huawei-GigabitEthernet0/0/1]interface GigabitEthernet0/0/2
    [Huawei-GigabitEthernet0/0/2]eth-trunk 1
    

    2.1 手工负载分担模式:

    实验拓扑:
    在这里插入图片描述

    <Huawei>system-view 
    [Huawei]vlan batch 10 20
    [Huawei]interface Eth-Trunk 1
    [Huawei-Eth-Trunk1]trunkport GigabitEthernet 0/0/1 to 0/0/2
    [Huawei-Eth-Trunk1]mode manual load-balance
    [Huawei-Eth-Trunk1]portswitch
    [Huawei-Eth-Trunk1]load-balance src-dst-ip
    [Huawei-Eth-Trunk1]port link-type trunk
    [Huawei-Eth-Trunk1]port trunk allow-pass vlan 10 20
    

    LSW2配置相同。

    2.2静态LACP

    实验拓扑:
    在这里插入图片描述
    LSW1:

    <Huawei>system-view 
    [Huawei]vlan batch 10 20
    [Huawei]interface Eth-Trunk 1
    [Huawei-Eth-Trunk1]trunkport GigabitEthernet 0/0/1 to 0/0/3
    [Huawei-Eth-Trunk1]mode lacp-static
    [Huawei-Eth-Trunk1]load-balance src-dst-mac  # 设置负载分担模式
    [Huawei-Eth-Trunk1]max active-linknumber 2   # 设置活动链路为2条
    [Huawei-Eth-Trunk1]max bandwidth-affected-linknumber  3 # 设置最大链路数量为3
    [Huawei-Eth-Trunk1]lacp preempt enable    # 开启LACP抢占
    [Huawei-Eth-Trunk1]lacp preempt delay 10  # 设置LACP抢占延时
    [Huawei-Eth-Trunk1]port link-type trunk
    [Huawei-Eth-Trunk1]port trunk allow-pass vlan 10 20
    [Huawei-Eth-Trunk1]quit
    [Huawei]interface GigabitEthernet 0/0/4
    [Huawei-GigabitEthernet0/0/4]port link-type access
    [Huawei-GigabitEthernet0/0/4]port default vlan 10
    [Huawei-GigabitEthernet0/0/4]quit
    [Huawei]interface GigabitEthernet 0/0/5
    [Huawei-GigabitEthernet0/0/5]port link-type access
    [Huawei-GigabitEthernet0/0/5]port default vlan 20
    [Huawei-GigabitEthernet0/0/5]quit
    

    LSW2配置相同。

    展开全文
  • Eth-Trunk 链路聚合

    千次阅读 2020-05-01 09:21:04
    链路聚合模式、 Eth-Trunk的优势、 Eth-Trunk接口配置流程、 LACP抢占机制、 Eth-Trunk接口负载分担、 Eth-Trunk接口配置注意事项

    介绍

          Eth-Trunk 是一种捆绑技术,它将多个物理接口捆绑成一个逻辑接口,这个逻辑接口就称为 Eth-Trunk 接口,捆绑在一起的每个物理接口称为成员接口。EthTrunk 只能由以太网链路构成。
          系统 LACP 优先级值越小优先级越高,缺省系统LACP 优先级值为32768。

    为什么需要这种技术?
    在这里插入图片描述
    Eth-Trunk可以用于二层的链路聚合,也可以用于三层的链路聚合。缺省情况下,以太网接口工作在二层模式。如果需要配置二层Eth-Trunk接口,可以通过portswitch命令将该接口切换成二层接口;如果需要配置三层Eth-Trunk接口,可以通过undo portswitch命令将该接口切换成三层接口。

     

    链路聚合模式

    手动负载均衡(manual load-balance)模式(当设备比较陈旧,不支持LACP模式就选这个)
    LACP(Link Aggregation Control Protocol)模式 (首选LACP)
    LACP模式也称为M:N模式,其中M条链路处于活动状态转发数据,N条链路处于非活动状态作为备份链路。

    1.手工负载分担模式链路聚合
    手工负载分担模式是一种最基本的链路聚合方式,在该模式下,Eth-Trunk 接口的建立,成员接口的加入完全由手工来配置,没有链路聚合控制协议的参与。该模式下所有成员接口(selected)都参与数据的转发,分担负载流量,因此称为手工负载分担模式。手工汇聚端口的 LACP 协议为关闭状态,禁止用户使能手工汇聚端口的LACP 协议。

    2.LACP 协议链路聚合
    LACP(Link Aggregation Control Protocol)链路聚合包含两种类型:

    1) 静态 LACP 模式链路聚合

    a)静态 LACP 模式链路聚合简介
    静态 LACP 模式下,Eth-Trunk 接口的建立,成员接口的加入,都是由手工配置完成的。但与手工负载分担模式链路聚合不同的是,该模式下LACP 协议报文参与活动接口的选择。也就是说,当把一组接口加入Eth-Trunk 接口后,这些成员接口中哪些接口作为活动接口,哪些接口作为非活动接口还需要经过LACP 协议报文的协商确定

    静态汇聚端口的 LACP 协议为使能状态,当一个静态汇聚组被删除时,其成员端口
    将形成一个或多个动态LACP 汇聚,并保持LACP 使能。禁止用户关闭静态汇聚端口的LACP 协议。

    b)静态汇聚组中的端口状态
    在静态汇聚组中,端口可能处于两种状态:Selected 或Standby。Selected 端口和
    Standby 端口都能收发LACP 协议,但Standby 端口不能转发用户报文。

    说明:
    在一个汇聚组中,处于Selected 状态且端口号最小的端口为汇聚组的主端口,其他
    处于Selected 状态的端口为汇聚组的成员端口。

    2) 动态 LACP 模式链路聚合

    a)动态 LACP 模式链路聚合简介
    动态 LACP 模式下,Eth-Trunk 接口的建立,成员接口的加入,活动接口的选择完全由LACP 协议通过协商完成。这就意味着启用了动态LACP 协议的两台直连设备上,不需要创建Eth-Trunk 接口,也不需要指定哪些接口作为聚合组成员接口,两台设备会通过LACP 协商自动完成链路的聚合操作。动态 LACP 汇聚是一种系统自动创建/删除的汇聚,不允许用户增加或删除动态LACP 汇聚中的成员端口。只有速率和双工属性相同、连接到同一个设备、有相同基本配置的端口才能被动态汇聚在一起。即使只有一个端口也可以创建动态汇聚,此时为单端口汇聚。动态汇聚中,端口的LACP 协议处于使能状态。

    b)动态汇聚组中的端口状态
    在动态汇聚组中,端口可能处于两种状态:Selected 或Standby。
    Selected 端口和Standby 端口都能收发LACP 协议,但Standby 端口不能转发用户报文。由于设备所能支持的汇聚组中的最大端口数有限制,如果当前的成员端口数量超过了最大端口数的限制,则本端系统和对端系统会进行协商,根据设备ID 优的一端的端口ID 的大小,来决定端口的状态。具体协商步骤如下:

    确定设备主动端: 比较设备 ID(系统优先级+系统MAC 地址)。先比较系统优先级,如果相同再比较系统MAC 地址。设备ID 小的一端被认为优。

    确定活动接口: 比较端口 ID(端口优先级+端口号)。对于设备ID 优的一端的各个端口,首先比较端口优先级,如果优先级相同再比较端口号。端口ID 小的端口为 Selected 端口,剩余端口为Standby 端口。在一个汇聚组中,处于Selected 状态且端口号最小的端口为汇聚组的主端口,其他处于Selected 状态的端口为汇聚组的成员端口。

    说明:
    与手工汇聚组不同的是,在静态汇聚组和动态汇聚组中,处于 DOWN 的端口为Standby 状态。
     

    两种链路聚合模式比较

    维度手工模式LACP模式
    定义Eth-Trunk的建立、成员接口的加入由手工配置,没有链路聚合控制协议的参与。Eth-Trunk的建立是基于LACP协议的,LACP为交换数据的设备提供一种标准的协商方式,以供系统根据自身配置自动形成聚合链路并启动聚合链路收发数据。聚合链路形成以后,负责维护链路状态。在聚合条件发生变化时,自动调整或解散链路聚合。
    设备是否需要支持LACP协议不需要需要
    数据转发一般情况下,所有链路都是活动链路。所有活动链路均参与数据转发。如果某条活动链路故障,链路聚合组自动在剩余的活动链路中分担流量。一般情况下,部分链路是活动链路。所有活动链路均参与数据转发。如果某条活动链路故障,链路聚合组自动在非活动链路中选择一条链路作为活动链路,参与数据转发的链路数目不变。
    是否支持跨设备的链路聚合不支持支持
    检测故障只能检测到同一聚合组内的成员链路有断路等有限故障,但是无法检测到链路故障、链路错连等故障。不仅能够检测到同一聚合组内的成员链路有断路等有限故障,还可以检测到链路故障、链路错连等故障。

    LACP模式实现原理

    基于IEEE802.3ad标准的LACP是一种实现链路动态聚合与解聚合的协议。LACP通过链路聚合控制协议数据单元LACPDU(Link Aggregation Control Protocol Data Unit)与对端交互信息。

    在LACP模式的Eth-Trunk中加入成员接口后,这些接口将通过发送LACPDU向对端通告自己的系统优先级、MAC地址、接口优先级、接口号和操作Key等信息。对端接收到这些信息后,将这些信息与自身接口所保存的信息比较,用以选择能够聚合的接口,双方对哪些接口能够成为活动接口达成一致,确定活动链路。
     

    Eth-Trunk的优势

    增加带宽:Eth-Trunk 接口的带宽是各成员接口带宽的总和。
    提高可靠性:当某个成员链路出现故障时,流量会自动的切换到其他可用的链路上,从而提供整个 Eth-Trunk 链路的可靠性。
    负载分担:在一个 Eth-Trunk 接口内,通过对各成员链路配置不同的权重,可以实现流量负载分担。

    在这里插入图片描述

     

    Eth-Trunk接口配置流程

    ①创建Eth-trunk
    ②选择链路聚合模式,默认是手工负载分担
    ③加入成员接口
    系统优先级小的为主动端
    在这里插入图片描述

    LACP抢占机制

    若LACP开启抢占机制,假如一条主链路发生故障,此时备用链路就会被启用,进行数据转发。假设过了一段时间之后发生故障的主链路回复正常,则端口开始抢占,在抢占延时超时后,成为活跃端口,进入转发状态。备份链路不再转发数据。

    为什么要设置抢占延时:
    避免由于某些原因链路状态频繁变化而导致的链路聚合数据传输不稳定。(主动链路恢复后,立马抢占,然后突然又故障,有恢复。在恢复和故障之间来回徘徊)

     

    LACP模式Eth-Trunk建立过程

    1.两端互相发送LACPDU报文。
    如下图所示,在DeviceA和DeviceB上创建Eth-Trunk并配置为LACP模式,然后向Eth-Trunk中手工加入成员接口。此时成员接口上便启用了LACP协议,两端互发LACPDU报文。

    在这里插入图片描述

    2.确定主动端和活动链路。

    如下图所示,两端设备均会收到对端发来的LACPDU报文。以DeviceB为例,当DeviceB收到DeviceA发送的报文时,DeviceB会查看并记录对端信息,然后比较系统优先级字段,如果DeviceA的系统优先级高于本端的系统优先级,则确定DeviceA为LACP主动端。如果DeviceA和DeviceB的系统优先级相同,比较两端设备的MAC地址,确定MAC地址小的一端为LACP主动端。

    选出主动端后,两端都会以主动端的接口优先级来选择活动接口,两端设备选择了一致的活动接口,活动链路组便可以建立起来,从这些活动链路中以负载分担的方式转发数据。
    在这里插入图片描述

    3.LACP抢占:
    使能LACP抢占功能后,聚合组会始终保持高优先级的接口作为活动接口的状态。
    在这里插入图片描述

     

    Eth-Trunk接口负载分担

    在这里插入图片描述
    Eth-Trunk接口进行负载分担时,可以选择IP地址或者包作为负载分担的散列依据;同时还可以设置成员接口的负载分担权重。

    两种散列依据造成的问题:
    假如主机A向主机B发送一个数据比较大的100个包。

    • 逐流负载分担的处理方式是:这100个包都从一条物理链路发送。这时可能会造成一条物理链路负载较大,一条物理链路空闲。
    • 逐包负载分担的处理方式是:可能第1,3,5…个包从一条物理链路发送;第2,4,6…个包从另一条物理链路发送。此时数据包可能不能按顺序到达目的端,可能会造成数据乱码。

    配置命令

    进入Eth-Trunk接口视图,执行命令load-balance { ip | packet-all },配置Eth-Trunk接口的散列依据。(缺省情况下,当Eth-Trunk接口根据IP进行散列。)
    

     
    负载分担权重:配置成员接口的负载分担权重,某成员接口的权重值占所有成员接口负载分担权重之和的比例越大,该成员接口承担的负载就越大。
    配置命令

    进入以太网接口视图。执行命令distribute-weight weight-value,配置Eth-Trunk成员接口的负载分担权重。(缺省情况下,成员接口的负载分担权重为1。)
    

     

    Eth-Trunk接口配置注意事项

    将成员接口加入Eth-Trunk时,需要注意以下问题:

    1. 成员接口不能有IP地址等三层配置项,也不可以配置任何业务;
    2. 成员接口不能配置静态MAC地址;
    3. Eth-Trunk接口不能嵌套,即成员接口不能是Eth-Trunk;
    4. 一个以太网接口只能加入到一个Eth-Trunk接口,如果需要加入其他Eth-Trunk接口,必须先退出原来的Eth-Trunk接口;
    5. 如果本地设备使用了Eth-Trunk,与成员接口直连的对端接口也必须捆绑为Eth-Trunk接口,两端才能正常通信;
    6. Eth-Trunk有两种工作模式:二层工作模式和三层工作模式。Eth-Trunk的工作模式不影响成员链路的加入,例如,以太网接口既可以加入二层模式的Eth-Trunk,也可以加入三层模式的Eth-Trunk。

    配置需求

    在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述
    dis eth-trunk
    dis interface eth-trunk 查看详细信息

     

    综合配置

    在这里插入图片描述

    SW1和SW2:
    int Eth-Trurnk 1
    mode lacp-static
    int g0/0/1
     eth-trunk 1
    int g0/0/2
     eth-trunk 1
    int g0/0/5
     eth-trunk 1
    
    
    系统 LACP 优先级值越小优先级越高,缺省系统LACP 优先级值为32768。
    修改系统优先级,希望SW1作为主动端
    [SW1]lacp priority 100
    
    
    修改最大活动数目MAX为2,  先看端口优先级,一样就看ID,越小越优.  选择两条
    [SW1]int eth-trunk 1
    [   ]max active-linknumber 2
    修改端口优先级,让15作为活动链路,接口2作为备份
    [SW1]int g0/0/1
    [ 	]lacp priority 100
    [   ]int g0/0/5
    [ 	]lacp priority 100
    
    
    LACP模式的抢占机制 (端口故障后 又恢复正常,抢回来)
    [SW1]int eth-trunk 1
    [SW1-Eth-Trunk1]lacp preempt enable  默认是关闭的,如果开了,默认是30[SW1-Eth-Trunk1]lacp preempt delay 10
    
    展开全文
  • Eth-Trunk是一种捆绑技术,它将多个物理接口捆绑成一个逻辑接口,这个逻辑接口就称为Eth-Trunk接口,捆绑在一起的每个物理接口称为成员接口。...所有Eth-Trunk中物理接口参数必须一致,Eth-Trunk链路

    Eth-Trunk是一种捆绑技术,它将多个物理接口捆绑成一个逻辑接口,这个逻辑接口就称为Eth-Trunk接口,捆绑在一起的每个物理接口称为成员接口。Eth-Trunk只能由以太网链路构成,其优势在于:

    • 负载分担:在某一个Eth-Trunk接口内可以实现流量负载分担
    • 提高可靠性:当某个成员接口连接的物理链路出现故障时,流量会切换到其他可用的链路上,从而提高整个Trunk链路的可靠性
    • 增加带宽Trunk接口的总带宽是各成员接口带宽之和

    所有Eth-Trunk中物理接口参数必须一致,Eth-Trunk链路两端要求一致的物理参数有:物理接口类型、物理接口数量、物理接口速率、物理接口的双工方式以及物理接口的流控方式

    实验拓扑

    image-20220401195729325

    实验目的

    • 理解Eth-Trunk的应用场景
    • 掌握两种配置Eth-Trunk链路聚合的方法
      1. 手工负载分担方式:需要手动创建链路聚合组,并配置多个接口加入到所创建的Eth-Trunk
      2. 静态LACP模式:该模式通过LACP协议协商Eth-Trunk参数后自主选择活动接口
    • 掌握配置Eth-Trunk链路聚合的方法

    实验步骤

    1. 验证各PC间可以相互Ping通后关闭g0/0/2g0/0/5,以便后边可以进行实验

      S1:
      [S1]interface g0/0/2
      [S1-GigabitEthernet0/0/2]shutdown	//关闭接口
      [S1-GigabitEthernet0/0/2]interface g0/0/5
      [S1-GigabitEthernet0/0/5]shutdown
          
      S2:
      [S2]interface g0/0/2
      [S2-GigabitEthernet0/0/2]shutdown	//关闭接口
      [S2-GigabitEthernet0/0/2]interface g0/0/5
      [S2-GigabitEthernet0/0/5]shutdown
      
      
    2. 模拟链路增加,打开S1S2g0/0/2接口,此时默认开启的MSTP协议一定会阻塞其中某条链路以防形成回路

      image-20220401201719347

      可以观察到g0/0/2链路并没有被利用起来,因此无法实质性增加S1S2之间的带宽。由此也证明单靠增加链路条数是不足以增加带宽的。

    3. 为了实质性增加S1S2之间的带宽,我们决定将g0/0/1g0/0/2逻辑化成一条物理线路

      S1:
      [S1]interface Eth-Trunk 1		//在S1上配置链路聚合,创建Eth-Trunk 1接口	
      [S1-Eth-Trunk1]mode manual load-balance //指定为手工负载分担模式
      [S1-Eth-Trunk1]quit
      [S1]interface g0/0/1
      [S1-GigabitEthernet0/0/1]eth-trunk 1	//将g0/0/1加入Eth-Trunk 1接口
      [S1-GigabitEthernet0/0/1]interface g0/0/2
      [S1-GigabitEthernet0/0/2]eth-trunk 1
      
      S2:
      [S2]interface Eth-Trunk 1 			//在S2上配置链路聚合,创建Eth-Trunk 1接口
      [S2-Eth-Trunk1]mode manual load-balance 
      [S2-Eth-Trunk1]quit
      [S2]interface g0/0/1
      [S2-GigabitEthernet0/0/1]eth-trunk 1
      [S2-GigabitEthernet0/0/1]int g0/0/2
      [S2-GigabitEthernet0/0/2]eth-trunk 1
      

      配置完成后,我们查询当下Eth-Trunk 1的情况

      image-20220401203542163

      再查询聚合链路后MSTP生成树的情况

      image-20220401203737218

      Eth-Trunk组中只要有一条物理链路是正常的,Eth-Trunk接口就不会断开,仍然可以保证数据的转发。可见,其不仅提升了带宽也实现了链路冗余。

    4. 接着我们再部署一条链路作为备份链路,并采用静态LACP模式配置Eth-Trunk实现两条链路同时转发,一条链路备份,当其中一条转发链路出现问题时,备份链路可立即进行数据转发

    5. 打开S1S2g0/0/5模拟增加了一条新链路

    6. 将先前加入到Eth-Trunk接口下的物理接口进行删除,否则无法修改模式

      S1:
      [S1]interface g0/0/1	
      [S1-GigabitEthernet0/0/1]undo eth-trunk 	//将g0/0/1从先前配置的Eth-Trunk中移除
      [S1-GigabitEthernet0/0/1]interface g0/0/2
      [S1-GigabitEthernet0/0/2]undo eth-trunk
          
      S2:
      [S2]interface g0/0/1	
      [S2-GigabitEthernet0/0/1]undo eth-trunk 	
      [S2-GigabitEthernet0/0/1]interface g0/0/2
      [S2-GigabitEthernet0/0/2]undo eth-trunk
      
    7. 重新创建Eth-Trunk 1接口,并将其工作模式定位静态LACP模式

      S1:
      [S1]interface Eth-Trunk 1	//创建Eth-Trunk 1接口
      [S1-Eth-Trunk1]mode lacp-static 	//工作模式定为静态LACP模式
      [S1-Eth-Trunk1]interface g0/0/1		
      [S1-GigabitEthernet0/0/1]eth-trunk 1		//将g0/0/1加入Eth-Trunk 1接口
      [S1-GigabitEthernet0/0/1]interface g0/0/2
      [S1-GigabitEthernet0/0/2]eth-trunk 1
      [S1-GigabitEthernet0/0/2]interface g0/0/5  
      [S1-GigabitEthernet0/0/5]eth-trunk 1
          
      S2:
      [S2]interface Eth-Trunk 1	//创建Eth-Trunk 1接口
      [S2-Eth-Trunk1]mode lacp-static 	//工作模式定为静态LACP模式
      [S2-Eth-Trunk1]interface g0/0/1		
      [S2-GigabitEthernet0/0/1]eth-trunk 1		
      [S2-GigabitEthernet0/0/1]interface g0/0/2
      [S2-GigabitEthernet0/0/2]eth-trunk 1
      [S2-GigabitEthernet0/0/2]interface g0/0/5  
      [S2-GigabitEthernet0/0/5]eth-trunk 1
      

      我们观察链路聚合后各端口的情况

      image-20220401211048844
    8. 我们将S1的优先级由默认的32768改为100,使其成为主动端【值越低优先级越高】,并按照主动端设备的接口来选择活动接口。两端设备选出主动端后,两端都会以主动端的接口优先级来选择活动端口。两端选择了一致的活动接口,活动链路便可以建立起来,设置这些活动链路以负载分担的方式转发数据。

      S1:
      [S1]lacp priority 100		//将S1在Eth-Trunk下的优先级设为100
      [S1]interface Eth-Trunk 1
      [S1-Eth-Trunk1]max active-linknumber 2	//设置Eth-Trunk 1的最大活动链路数为2
      [S1-Eth-Trunk1]interface g0/0/1
      [S1-GigabitEthernet0/0/1]lacp priority 100	//将g0/0/1接口优先级设为100
      [S1-GigabitEthernet0/0/1]interface g0/0/2
      [S1-GigabitEthernet0/0/2]lacp priority 100
      

      此时我们再次查看Eth-Trunk 1接口的情况

      image-20220401212200708

      此时我们手动关闭g0/0/1接口模拟故障,看看g0/0/5是否会接替g0/0/1的位置

      image-20220401212409377

    本实验取自华为公司《HCNA网络技术实验指南》,此书对于新手学习计算机网络协议以及熟悉eNSP操作十分友好,强烈推荐!!!

    展开全文
  • 华为配置eth-trunk接口下的LACP模式的链路聚合示例(交换机之间直连
  • 华为实验14-配置Eth-Trunk链路聚合

    千次阅读 2021-10-14 09:55:01
    原理概述 将多个接口捆绑在一起,较低的成本满足接口带宽的需求,比如可以将3个100M的全双工接口绑在一起,可以达到300M的带宽。...掌握配置eth-trunk链路聚合的(手工负载分但模式)方法 掌握配置eth
  • Eth-Trunk链路聚合的配置

    万次阅读 2019-04-14 11:17:35
    一。原理简述 ...Eth-Trunk就是一种捆绑技术,他可以将多个物理接口捆绑成一个逻辑接口,这个逻辑接口就称为Eth-Trunk接口,而捆绑在在一起的每个物理接口称为成员接口。Eth-Trunk只能由以太网链...
  • 链路聚合技术Eth-Trunk链路聚合技术,作为一种捆绑技术,可以吧多个独立的物理接口绑定在一起,作为一个大宽带的逻辑接口使用好处:增加设备之间的宽带互联提高设备之间的的可靠性对流量负载均衡,提高链路利用率。...
  • 配置eth-trunk链路聚合 原理概念: 优势:1、负载分担。 2、提高可靠性。 3、增加带宽。 实验目的: 1、 理解使用eth-trunk的应用场景。 2、 掌握配置eth-trunk链路聚合的方法。 3、 掌握配置eth-trunk链路聚合的...
  • /配置有效链路最大数量,当聚合链路超过...链路聚合:顾名思义,就是将多条链路聚合成一条链路,这条链路的带宽等于所有有效链路的总和;例如:[Huawei-Eth-Trunk1]load-balance src-dst-mac。eth-trunk [聚合口-id]
  • 1]Eth-Trunk1 创建Eth-Trunk1端口 [S1-Eth-Trunk1]mode lacp-static 工作模式设为静态模式 [S1-Eth-Trunk1]interface g0/0/1 进入配置g0/0/1端口 ...
  • 目录一、Eth-Trunk链路聚合背景二、链路聚合应用场景三、链路聚合概述四、链路聚合模式1 手工负载分担模式2 LACP模式3 对比4 LACP模式活动链路的选取5 LACP模式的抢占机制五、链路聚合条件六、链路聚合负载分担类型...
  • eth-trunk拓扑
  • 华为数通基础27-Eth-Trunk链路聚合分享.pdf
  • Eth-Trunk链路聚合

    千次阅读 多人点赞 2021-01-24 12:50:38
    Eth-Trunk链路聚合) 以太网链路聚合Eth-Trunk简称链路聚合,它通过将多条以太网物理链路捆绑在一起成为一条逻辑链路,从而实现增加链路带宽的目的。同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效地提高...
  • Eth-Trunk链路聚合)原理与配置

    千次阅读 2020-03-27 16:03:03
    文章目录前言Eth-Trunk链路聚合技术)手工负载分担模式手工负载分担模式配置LACP模式LACP模式活动链路选取LACP抢占机制LACP模式配置Eth-Trunk接口负载分担散列依据负载分担权重Eth-Trunk接口配置注意Eth-Trtunk...
  • 华为 Eth-Trunk链路聚合

    千次阅读 多人点赞 2020-09-09 20:11:32
    文章目录一、为什么要用到聚合二、链路聚合三、拓扑四、基本配置五、部署Link Aggregation-链路聚合 一、为什么要用到聚合 1、二层环境为什么要用到聚合 (1)接入层的流量剧增; (2)现行存储数据剧增; (3)监控...
  • 链路聚合Eth-Trunk

    千次阅读 2021-08-12 08:43:16
    目录 一,链路聚合定义 二,链路聚合实现的条件 三,链路聚合划分 四,二层链路捆绑步骤 ...一,链路聚合定义 ...1,链路聚合的定义 ...端口捆绑技术:链路聚合是将一组物理接口...1,每个eth-trunk接口下最多可包含8个.
  • 配置Eth-Trunk链路实现链路聚合(手工负载分担模式) [S1]interface eth-trunk 1 [S1-Eth-Trunk1]mode manual load-balance [S2]interface eth-trunk 1 [S2-Eth-Trunk1]mode manual load-balance 将S1和S2的G0/0/...
  • Eth-Trunk(链路聚合)之负载分担模式

    万次阅读 2022-01-27 21:51:11
    链路聚合技术可以在不进行硬件升级的条件下,通过将多个相同属性的物理接口捆绑为一个逻辑接口,达到增加链路带宽的目的。同时采用备份链路的机制,可以有效地提高设备之间链路的可靠性
  • 链路聚合实验
  • ETH-trunk(链路聚合协议)&lacp

    千次阅读 2022-05-05 19:44:52
    以太网链路聚合Eth-Trunk简称链路聚合,它通过将多条以太网物理链路捆绑在一起成为一条逻辑链路,从而实现增加链路带宽的目的。同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效地提高链路的可靠性。可以...
  • Eth-Trunk链路聚合)之LACP(二层)

    万次阅读 2022-01-28 21:57:51
    LACP模式的链路聚合是两...Eth-Trunk链路两端相连的物理接口的数量、速率、双工方式、流控方式必须一致。 二层配置实验 第一步:创建链路聚合组 [Huawei]int Eth-Trunk 2 第二步:模式为静态LACP [Huaw..
  • 大家好! 我叫风清云淡,有句话说“相识是缘”,我也希望多多认识一些志同道和的朋友。作为一名互联网行业的小萌新,写博客一方面是为了...文章目录实验十一 GVRP基础配置实验内容实验步骤实验十二 配置Eth-Trunk 链路
  • 链路聚合 eth-trunk

    2022-02-21 18:00:29
    链路聚合概述 链路聚合(链路捆绑):通过将多个以太网物理接口捆绑在一起形成一条逻辑接口。 作用:增加链路带宽,同时提供链路冗余 转发原理:eth-trunk位于mac于llc子层,属于数据链路层。 eth-trunk模块内部维护...
  • Eth-Trunk是指设备的链路聚合,即将该设备的多个接口捆绑成一个接口,从而达到了增加带宽和提高可靠性的目的。我们要注意它是将多条物理链路,在逻辑上合并成一条,而不是串在一起。例我们将LSW1交换机S5700的三个...
  • Eth-Trunk链路聚合)之LACP(三层)

    万次阅读 2022-01-28 22:55:32
    Eth_Trunk链路两端相连的物理接口的速率是可以不一致的!!!

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,396
精华内容 958
关键字:

eth-trunk链路聚合