精华内容
下载资源
问答
  • H3C交换机配置vlan

    万次阅读 2017-05-27 08:42:02
    创建VLAN system-view System View: return to User View ...[H3C_TEST]vlan 99 [H3C_TEST-vlan99]name asd [H3C_TEST-vlan99]quit  把交换机的端端口划分到相应的Vlan中 [H3C_TEST]interface ethernet1/0/2 
    创建VLAN
    <H3C_TEST>system-view
    System View: return to User View with Ctrl+Z.
    [H3C_TEST]vlan 99
    [H3C_TEST-vlan99]name asd
    [H3C_TEST-vlan99]quit

     把交换机的端端口划分到相应的Vlan中
    [H3C_TEST]interface ethernet1/0/2       //进入端口模式
    [H3C_TEST-Ethernet1/0/2]port link-type access //设置端口的类型为access
    [H3C_TEST-Ethernet1/0/2]port access vlan 99  //把当前端口划到vlan 99

    [H3C_TEST]vlan 99
    [H3C_TEST-vlan99]port ethernet1/0/1 to ethernet1/0/24  //把以及网端口1/0/1到1/0/24划到vlan99
    [H3C_TEST-vlan99]quit
    [H3C_TEST]interface ethernet1/2/1

    [H3C_TEST-GigabitEthernet1/2/1]port trunk permit vlan  99 100 101    //{ID|All} 设置trunk端口允许通过的VLAN

    [H3C_TEST-GigabitEthernet1/2/1]port trunk permit vlan all(*) //也可以设置trunk端口允许通过的所有VLAN





    展开全文
  • 一、基本设置 1.console线连接成功 2.进入系统模式 <H3C>system-view //提示符由<H3C>变为[H3C] ...[H3C]sysnameTEST ...4.查看所有配置信息 ...[H3C]display current-configuration //displ...
    1. 一、基本设置
    2. 1. console线连接成功
    3. 2. 进入系统模式
    4.     <H3C>system-view //提示符由<H3C> 变为 [H3C]
    5.     
    6. 3. 更改设备名称
    7.     [H3C]sysname TEST
    8.     
    9. 4. 查看所有配置信息
    10.     [H3C]display current-configuration //display this 为查看当前路径下的设备信息
    11.     
    12. 5. 创建并进入VLAN 10
    13.     [H3C]vlan 10
    14. 6. 把1-4端口划入VLAN 10
    15.     [TEST-vlan10]port e1/0/1 to e1/0/4 //查看配置信息时就知道interface的命名规则,可以缩写。
    16.     //或者针对每个端口进行单独操作
    17.     [TEST]int e1/0/7
    18.     [TEST-Ethernet1/0/7]port access vlan 10
    19.     //从VLAN里删除一个端口
    20.     [TEST]vlan 10
    21.     [TEST-vlan10]undo port e1/0/7
    22.     
    23. 7. 创建并进入vlan 20
    24.     [TEST-vlan20]vlan 20
    25. 8. 把端口5-7加入VLAN 20
    26.     [TEST-vlan20]port e1/0/5 to e1/0/7
    27.     [TEST-vlan20]quit
    28.     
    29. 9. 进入第8个端口
    30.     [TEST]interface e1/0/8
    31.     
    32. 10.设置该端口为trunk模式
    33.     [TEST-Ethernet1/0/8]port link-type trunk //vlan端口默认为access模式
    34.     
    35. 11.设置允许vlan 10和20的tag通过该端口
    36.     [TEST-Ethernet1/0/8]port trunk permit vlan 10 20 //替换后面的数字为all则是允许所有vlan tag通过该端口
    37.     
    38. 12.允许第1端口poe供电
    39.     [TEST]interface e1/0/1
    40.     [TEST-Ethernet1/0/1]poe enable
    41. 二、配置远程管理
    42. 1. 配置管理地址
    43.     [TEST]interface Vlan-interface 1
    44.     [TEST-Vlan-interface1]ip address 10.0.0.1 255.255.255.0
    45.     //这里给默认的vlan 1配置上管理地址,然后在上层设备连接该接口的interface上配置同网段的IP地址即可管理交换机
    46.     
    47. 2. 创建远程账户
    48.     [TEST]local-user zooyo
    49.     [TEST-luser-zooyo]password simple 123456 //可更改参数为cipher,则是加密模式
    50.     [TEST-luser-zooyo]service-type telnet //设置连接协议
    51.     [TEST-luser-zooyo]level 3 //提升为最高全选
    52.     
    53. 3. 配置telnet
    54.     [TEST]user-interface vty 0 4
    55.     [TEST-ui-vty0-4]authentication-mode scheme
    56.     
    57. 4.保存配置
    58.     save //会提示你配置文件名等,按Y回车即可
    59.     
    60. 其他命令:
    61. undo //取消生效规则
    62. undo vlan 10 //删除vlan 10
    63. undo info-center enable //关闭日志信息
    64. display mac-address //显示每个端口收到的设备的MAC地址
    65. display saved-configuration //显示flash中配置文件,即下次上电启动时所用的配置文件
    66. reset saved-configuration //檫除旧的配置文件,需要在普通模式下也就是提示符为<>
    67. super password //修改特权用户密码
    68. ip route-static 0.0.0.0 0.0.0.0 192.168.0.1 //默认路由
    69. ip route-static 192.168.2.0 255.255.255.0 192.168.12.2 //静态路由
    70. undo interface vlan 1 //取消默认VLAN即management-vlan, 这样可以设置其他VLAN为management-vlan,则可以设置管理地址
    71. management-vlan 10 //设置vlan 10为management-vlan
    72. 发现BUG:
    73. 当9/10光电复用端口(combo)连接光模块时,由于协商问题该交换机光口一直无法启用,这里需要手动指定协商参数:
    74. [TEST]interface g1/1/2
    75. [TEST-GigabitEthernet1/1/2]duplex full
    76. [TEST-GigabitEthernet1/1/2]speed 1000

    转载于:https://www.cnblogs.com/liqing1009/p/5145601.html

    展开全文
  • H3C交换机配置创建vlan

    千次阅读 2020-07-26 19:48:18
    一、H3C交换机的基本配置 我们先来了解下h3c的配置命令与功能,都是常用的,基本上大部分网络配置都少不了这些命令。 1、基本配置 <H3C> //用户直行模式提示符,用户视图 <H3C>system-view //进入配置...

    一、H3C交换机的基本配置

    我们先来了解下h3c的配置命令与功能,都是常用的,基本上大部分网络配置都少不了这些命令。
    1、基本配置

    <H3C>           //用户直行模式提示符,用户视图 
    <H3C>system-view        //进入配置视图 
    [H3C] sysname xxx     //设置主机名成为xxx这里使用修改特权用户密码
    

    2、用户配置

    <H3C>system-view
    [H3C]super passwordH3C         //设置用户分级密码
    [H3C]undo superpassword         //删除用户分级密码
    [H3C]localuser bigheap 1234561         //Web网管用户设置,1为管理级用户
    [H3C]undo localuser bigheap        //删除Web网管用户
    [H3C]user-interface aux 0         //只支持0
    [H3C-Aux]idle-timeout 250         //设置超时为2分50秒,若为0则表示不超时,默认为5分钟
    
    [H3C-Aux]undoidle-timeout         //恢复默认值
    [H3C]user-interface vty 0         //只支持0和1
    [H3C-vty]idle-timeout 250         //设置超时为2分50秒,若为0则表示不超时,默认为5分钟
    [H3C-vty]undoidle-timeout         //恢复默认值
    [H3C-vty]set authentication password123456         //设置telnet密码,必须设置
    [H3C-vty]undo set authenticationpassword      //取消密码
    [H3C]displayusers         //显示用户
    [H3C]displayuser-interface         //用户界面状态
    

    3、vlan配置

    [H3C]vlan 2                //创建VLAN2
    [H3C]undo vlanall         //删除除缺省VLAN外的所有VLAN,缺省VLAN不能被删除
    [H3C-vlan2]port Ethernet 0/4 to Ethernet0/7         //将4到7号端口加入到VLAN2中,此命令只能用来加access端口,不能用来增加trunk或者hybrid端口
    
    [H3C-vlan2]port-isolate enable       //打开VLAN内端口隔离特性,不能二层转发,默认不启用该功能
    
    [H3C-Ethernet0/4]port-isolate uplink-portvlan 2       //设置4为VLAN2的隔离上行端口,用于转发二层数据,只能配置一个上行端口,若为trunk,则建议允许所有VLAN通过,隔离不能与汇聚同时配置
    
    [H3C]display vlan all         //显示所有VLAN的详细信息
    
    [H3C]user-group 20         //创建user-group 20,默认只存在user-group 1
    
    [H3C-UserGroup20]port Ethernet 0/4 toEthernet 0/7         //将4到7号端口加入到VLAN20中,初始时都属于user-group 1中
    [H3C]display user-group 20         //显示user-group 20的相关信息
    

    四、交换机ip配置

    [H3C]vlan 20                //创建vlan
    [H3C]management-vlan 20          //管理vlan
    [H3C]interface vlan-interface 20         //进入并管理vlan20
    [H3C]undo interface vlan-interface 20         //删除管理VLAN端口
    [H3C-Vlan-interface20]ip address192.168.1.2 255.255.255.0      //配置管理VLAN接口静态IP地址
    
    [H3C-Vlan-interface20]undo ipaddress         //删除IP地址
    [H3C-Vlan-interface20]ip gateway 192.168.1.1         //指定缺省网关(默认无网关地址)
    [H3C-Vlan-interface20]undo ip gateway
    [H3C-Vlan-interface20]shutdown        //关闭接口
    [H3C-Vlan-interface20]undo shutdown         //开启
    [H3C]display ip         //显示管理VLAN接口IP的相关信息
    [H3C]display interface vlan-interface20         //查看管理VLAN的接口信息
    <H3C>debugging ip         //开启IP调试功能
    <H3C>undo debugging ip
    

    5、DHCP客户端配置

    [H3C-Vlan-interface20]ip address dhcp-alloc        // 管理VLAN接口通过DHCP方式获取IP地址
    [H3C-Vlan-interface20]undo ip address dhcp-alloc        // 取消
    [H3C]display dhcp        //显示DHCP客户信息
    <H3C>debugging dhcp-alloc         //开启DHCP调试功能
    <H3C>undo debugging dhcp-alloc
    

    6、端口配置

    [H3C]interface Ethernet0/3             //进入端口
    [H3C-Ethernet0/3]shutdown           //关闭端口
    [H3C-Ethernet0/3]speed 100         //速率可为10,100,1000和auto(缺省)
    [H3C-Ethernet0/3]duplexfull         //双工,可为half,full和auto,光口和汇聚后不能配置
    [H3C-Ethernet0/3]flow-control        //开启流控,默认为关闭
    [H3C-Ethernet0/3]broadcast-suppression 20         //设置抑制广播百分比为20%,可取5,10,20,100,缺省为100,同时组播和未知单播也受此影响
    [H3C-Ethernet0/3]loopback internal         //内环测试
    [H3C-Ethernet0/3]port link-type trunk         //设置链路的类型为trunk
    [H3C-Ethernet0/3]port trunk pvid vlan 20         //设置20为该trunk的缺省VLAN,默认为1(trunk线路两端的PVID必须一致)
    [H3C-Ethernet0/3]port access vlan 20         //将当前access端口加入指定的VLAN
    [H3C-Ethernet0/3]port trunk permit vlanall         //允许所有的VLAN通过当前的trunk端口,可多次使用该命令
    [H3C-Ethernet0/3]mdiauto         //设置以太端口为自动监测,normal为直通线,across为交叉线                            
    [H3C]link-aggregation Ethernet 0/1 toEthernet 0/4         //将1-4口加入汇聚组,1为主端口,两端需要同时配置,设置了端口镜像以及端口隔离的端口无法汇聚
    
    [H3C]undo link-aggregation Ethernet 0/1     //删除该汇聚组
    [H3C]link-aggregation mode egress         //配置端口汇聚模式为根据目的MAC地址进行负荷分担,可选为  ingress,egress和both,缺省为both
    [H3C]monitor-port Ethernet 0/2         //将该端口设置为镜像端口,必须先设置镜像端口,删除时必须先删除被镜像端口,而且它们不能同在一个端口,该端口不能在汇聚组中,设置新镜像端口时,新取代旧,被镜像不变
    
    [H3C]mirroring-port Ethernet 0/3 toEthernet 0/4 both         //将端口3和4设置为被镜像端口,both为同时监控接收和发送的报文,inbound表示仅监控接收的报文,outbound表示仅监控发送的报文
    
    [H3C]display mirror
    [H3C]display interface Ethernet 0/3
    <H3C>resetcounters         //清除所有端口的统计信息
    [H3C]display link-aggregation Ethernet0/3         //显示端口汇聚信息
    [H3C-Ethernet0/3]virtual-cable-test        //诊断该端口的电路状况
    

    7、qos优先级配置
    QoS配置步骤:设置端口的优先级,设置交换机信任报文的优先级方式,队列调度,端口限速

    [H3C-Ethernet0/3]priority 7         //设置端口优先级为7,默认为0
    [H3C]priority-trustcos         //设置交换机信任报文的优先级方式为cos(802.1p优先级,缺省值),还可以设为dscp方式
    
    [H3C]queue-scheduler hq-wrr 2 4 6 8         //设置队列调度算法为HQ-WRR(默认为WRR),权重为2,4,6,8
    [H3C-Ethernet0/3]line-rate inbound 29      //将端口进口速率限制为2Mbps,取1-28时,速率为rate*8*1024/125,即64,128,192...1.792M;
    29-127,速率为(rate-27)*1024,2M,3M,4M...100M。
    
    [H3C]displayqueue-scheduler         //显示队列调度模式及参数
    [H3C]displaypriority-trust         //显示优先级信任模式
    

    二、H3C交换机vlan配置案例

    为了避免广播报文泛滥和通信的安全性,某公司网络中使用VLAN技术来隔离部门间的二层流量。其中部门A使用VLAN 100,部门B使用VLAN 200。

    部门A的终端用户使用192.168.1.0/24 IP网段,各终端用户配置的网关地址为192.168.1.1;
    部门B的终端用户使用192.168.2.0/24 IP网段,各终端用户配置的网关地址为192.168.2.1;

    现要求通过配置基于端口的VLAN和VLAN接口实现下面应用需求:
    1 同一VLAN内的主机能够二层互通,不同VLAN内的主机不能二层互通,能够三层互通。
    2、通过配置使Device A作为部门A中用户的网关,Device B作为部门B中用户的网关。

    组网拓扑图如下:
    在这里插入图片描述

    配置步骤

    1、配置Device A

    # 创建VLAN 100,并将GigabitEthernet 1/0/1加入VLAN 100。
    <DeviceA> system-view
    [DeviceA] vlan 100
    [DeviceA-vlan100] port gigabitethernet 1/0/1
    [DeviceA-vlan100] quit
    
    # 创建Vlan-interface 100,并配置其IP地址为192.168.1.1/24。
    [DeviceA] interface Vlan-interface 100
    [DeviceA-Vlan-interface100] ip address 192.168.1.1 24
    [DeviceA-Vlan-interface100] quit
    
    # 创建VLAN 200,并将GigabitEthernet 1/0/2加入VLAN 200。
    [DeviceA] vlan 200
    [DeviceA-vlan200] port gigabitethernet 1/0/2
    [DeviceA-vlan200] quit
    
    # 创建Vlan-interface 200,并配置其IP地址为192.168.2.2/24。
    [DeviceA] interface Vlan-interface 200
    [DeviceA-Vlan-interface200] ip address 192.168.2.2 24
    [DeviceA-Vlan-interface200] quit
    
    # 为了使Device A上VLAN 100和VLAN 200的报文能发送给Device B,将GigabitEthernet 1/0/3的链路类型配置为Trunk,并允许VLAN 100和VLAN 200的报文通过,取消允许VLAN 1通过。
    [DeviceA] interface gigabitethernet 1/0/3
    [DeviceA-GigabitEthernet1/0/3] port link-type trunk
    [DeviceA-GigabitEthernet1/0/3] port trunk permit vlan 100 200
    [DeviceA-GigabitEthernet1/0/3] undo port trunk permit vlan 1
    [DeviceA-GigabitEthernet1/0/3] quit
    

    2、配置Device B

    # 创建VLAN 100,并将GigabitEthernet 1/0/1加入VLAN 100。
    <DeviceB> system-view
    [DeviceB] vlan 100
    [DeviceB-vlan100] port gigabitethernet 1/0/1
    [DeviceB-vlan100] quit
    
    # 创建Vlan-interface 100,并配置其IP地址为192.168.1.2/24。
    [DeviceB] interface Vlan-interface 100
    [DeviceB-Vlan-interface100] ip address 192.168.1.2 24
    [DeviceB-Vlan-interface100] quit
    
    # 创建VLAN 200,并将GigabitEthernet 1/0/2加入VLAN 200。
    [DeviceB] vlan 200
    [DeviceB-vlan200] port gigabitethernet 1/0/2
    [DeviceB-vlan200] quit
    
    # 创建Vlan-interface 200,并配置其IP地址为192.168.2.1/24。
    [DeviceB] interface Vlan-interface 200
    [DeviceB-Vlan-interface200] ip address 192.168.2.1 24
    [DeviceB-Vlan-interface200] quit
    
    # 为了使Device A上VLAN 100和VLAN 200的报文能发送给Device B,将GigabitEthernet 1/0/3的链路类型配置为Trunk,并允许VLAN 100和VLAN 200的报文通过,取消允许VLAN 1通过。
    [DeviceB] interface gigabitethernet 1/0/3
    [DeviceB-GigabitEthernet1/0/3] port link-type trunk
    [DeviceB-GigabitEthernet1/0/3] port trunk permit vlan 100 200
    [DeviceB-GigabitEthernet1/0/3] undo port trunk permit vlan 1
    [DeviceB-GigabitEthernet1/0/3] quit
    

    这里面弱电君补充下:
    对于一些名字,大家可以了解下它的意义。
    1、静态IP:ISP提供给您固定的IP地址、子网掩码、默认网关、DNS。
    2、动态IP:电脑的TCP/IP属性设置为“自动获取IP地址”,每次启动电脑即可。
    3、WEB认证:每次上网之前,打开IE浏览器,会自动跳到ISP指定的主页,填入ISP提供的用户名密码,通过认证以后才可以进行其他得上网操作。
    4、DHCP功能:开启后,可以自动分配IP,主要是用来给网络客户机分配动态的IP地址,不需要手动设置ip,一般路由器和三层交换机有DHCP功能,二层交换机不能提供DHCP服务,但可以提供dhcp代理/中继功能。

    交换机的每个端口是不是都要配置加入vlan?
    基于端口的划分vlan是需要的。

    每个端口可以批量划分吗?
    可以批量划分端口的,先进入vlan中,使用命令#port ethernet 1/0/1 to 1/0/48 批量划分端口到vlan中。

    参考链接 :
    H3C交换机配置创建vlan :https://mp.weixin.qq.com/s/HRcjf1Apgl0q66aE_edVXQ

    展开全文
  • 现从笔者编著,目前在全国热销的《Cisco/H3C交换机配置与管理完全手册》(第二版)(与之配套的姊妹篇为《Cisco/H3C交换机高级配置与管理技术手册》)一书中摘选一部分H3C交换机MAC VLAN内容,希望对这些读者有所...

    对于不是很常用的MAC VLAN,许多读者都感到很陌生,读者QQ群中也经常见到有读者提到这方面的问题,希望我给予解答。现从笔者编著,目前在全国热销的《Cisco/H3C交换机配置与管理完全手册》(第二版)(与之配套的姊妹篇为《Cisco/H3C交换机高级配置与管理技术手册》)一书中摘选一部分H3C交换机MAC VLAN内容,希望对这些读者有所帮助。如要全面了解Cisco和H3C交换机的MAC VLAN相关知识和配置方法,请参见Cisco/H3C交换机配置与管理完全手册》(第二版)。

    19.6  H3C交换机基于MAC地址VLAN配置

      Cisco IOS中的基于MAC地址VLAN一样,H3C交换机中的基于MAC地址VLAN也是一种动态VLAN划分方式。它并不会把某个端口静态地划分到一个特定的VLAN,而是要根据所连主机的MAC地址来动态选择加入到对应的VLAN中。

        我们在第一篇学习Cisco IOS交换机基于MAC地址划分VLAN时已体会到,总体来说还是比较麻烦的,要配置VMPS服务器,还要配置VPMS客户端,而且VMPS服务器目前来说只能由CatOS系统交换机担当,所以要实现基于MAC地址来划分VLAN网络中必须同时有两种操作系统的Cisco交换机,条件也是比较比较苛刻的。相比之下,本节介绍的H3C交换机基于MAC地址的VLAN划分就简单许多。它是按照报文的源MAC地址来定义VLAN成员,将指定报文加入该VLAN的标记后发送。但在H3C以太网交换机中,支持基于MAC地址的VLAN不多,与前面介绍的基于IP子网VLAN一样,主要有S5500S5510S7500E等交换机系列。

       与前面介绍的基于协议VLAN和基于IP子网VLAN一样,基于MAC地址VLAN功能也只能在Hybrid端口配置,而且也主要用于在用户的接入设备的下行端口上进行配置(基于协议VLAN和基于IP子网VLAN也仅在接入设备的下行端口上配置),因此不和聚合功能同时使用。

    19.6.1  基于MAC地址VLAN的实现机制

    在支持基于MAC地址划分VLANH3C交换机中,划分方式又有三种形式:手动配置静态MAC VLAN动态触发端口加入静态MAC VLAN和动态MAC VLAN

    1.    手动配置静态MAC VLAN

        在手动配置静态MAC VLAN方式中,管理员需要手动配置MAC VLAN表项,启动基于MAC划分VLAN的功能,然后手动将对应的端口加入MAC VLAN。这种方式显然工作量比较大,常用于MAC VLAN中用户相对较少的网络环境。在该方式下,MAC VLAN的划分原理如下:

    l  当端口收到的报文为不带VLAN标记的报文时,会根据报文的源MAC匹配MAC VLAN表项。首先进行模糊匹配,即查询表中MASKMAC地址掩码)不是全为F(只比较非F的位)的表项。将源MACMASK进行逻辑与运算后再与MAC VLAN表项中的MAC地址匹配,如果完全相同,则匹配成功,给报文添加表项中指定的VLAN ID并转发该报文;如果模糊匹配失败,则进行精确匹配,即查询表中MASK为全F的表项。如果报文中的源MACMAC VLAN表项中的MAC地址完全相同,则匹配成功,给报文添加表项中指定的VLAN ID并转发该报文;如果没有找到匹配MAC VLAN表项,则继续按照基于IP子网VLAN、协议VLAN、端口VLAN的先后顺序进行匹配。

    l  当端口收到的报文为带有VLAN标记的报文时,如果VLAN ID在端口中允许通过的VLAN ID列表里时,则接收该报文;否则丢弃该报文。

    2.    动态触发端口加入静态MAC VLAN

        在手动配置静态MAC VLAN划分方式中,管理员需要把端口一一加入相应的MAC VLAN,但这里有一个问题,那就是我们有时往往根本不能确定交换机从哪些端口收到属于MAC VLAN的报文,这时我们就不能通过手动方式把相应端口加入到MAC VLAN。此时,就需要借助另一种更加智能的MAC VLAN配置方式,使用动态触发端口加入静态MAC VLAN中。在这种MAC VLAN配置方式中,配置MAC VLAN表项后,管理员只需在端口上启用基于MACVLAN划分功能和MAC VLAN动态触发功能,在端口收到与MAC VLAN表项匹配的报文后,可以通过此报文动态触发端口加入MAC VLAN。其划分原理如下:

    l  当端口收到的报文为不带VLAN标记的报文时,按图19-11所示流程进行处理。

    l  当收到的报文为带VLAN标记的报文时,处理方式和基于端口的VLAN一样:如果端口允许携带该VLAN标记的报文通过,则正常转发;如果不允许,则丢弃该报文。

      【说明】如果用户在同一端口上同时启用了手动配置静态MAC VLAN和动态触发端口加入静态MAC VLAN,此时端口对收到的非精确匹配的报文将做丢弃处理。

    19-11 在收到不带VLAN标记报文时,动态触发端口加入静态MAC VLAN的处理流程

     3. 动态MAC VLAN

       动态MAC VLAN需要和接入认证(比如基于MAC地址的802.1x认证)配合使用,以实现终端的安全、灵活接入。用户在交换机上配置动态MAC VLAN功能以后,还需要在接入认证服务器上配置MAC地址和VLAN的关联关系,这种MAC VLAN的配置就比较麻烦了,本书不做介绍。

       在动态MAC VLAN中,用户访问网络时,接入认证服务器先对用户进行认证,如果认证通过,服务器下发VLAN信息。交换机会根据用户报文的源MAC地址和下发的VLAN信息生成MAC VLAN表项,并将MAC VLAN添加到端口允许通过的VLAN列表中。用户下线后,交换机自动删除MAC VLAN表项,并将MAC VLAN从端口允许通过的VLAN列表中删除。

    19.6.2 手动配置静态MAC VLAN配置(略)

    19.6.3   动态触发端口加入静态MAC VLAN配置(略)

    19.6.4  手动配置静态MAC VLAN配置示例

       本示例拓扑结构如图19-11所示。SwitchASwitchBGigabitEthernet1/0/1端口分别连接到两个会议室,Laptop1Laptop2是会议用笔记本电脑,会在两个会议室间移动使用。Laptop1Laptop2MAC地址分别为000d-88f8-4e710014-222c-aa69

        使用时,Laptop1Laptop2要分别用于两个部门的员工,两个部门间使用VLAN100VLAN200进行隔离。现要求这两台笔记本电脑无论在哪个会议室使用,均只能访问自己部门的服务器,即Server1Server2

    19-11  手动配置静态MAC VLAN示例拓扑结构

     本示例配置所适用的H3C交换机系列和对应的软/硬件版本如表19-18所示。

    19-18  示例适用的H3C交换机系列及软/硬件版本

    H3C交换机系列

    软件版本

    硬件版本

    S5500-SI系列以太网交换机

    Release 1207软件版本

    全系列硬件版本(除S5500-20TP-SI

    Release 1301软件版本

    S5500-20TP-SI

    S5500-EI系列以太网交换机

    Release 2102软件版本

    全系列硬件版本

    S7500E系列以太网交换机

    Release 6100Release 6300软件版本

    全系列硬件版本

    1SwitchA的配置。

    1)创建VLAN100VLAN200,并将GigabitEthernet1/0/2配置为Trunk端口,允许VLAN100VLAN200的报文通过。

    <SwitchA> system-view

    [SwitchA] vlan 100

    [SwitchA-vlan100] quit

    [SwitchA] vlan 200

    [SwitchA-vlan200] quit

    [SwitchA] interface GigabitEthernet1/0/2

    [SwitchA-GigabitEthernet1/0/2] port link-type trunk

    [SwitchA-GigabitEthernet1/0/2] port trunk permit vlan 100 200

    [SwitchA-GigabitEthernet1/0/2] quit

    2)将GigabitEthernet1/0/1配置为Hybrid端口,并使其在发送VLAN 100VLAN 200的报文时去掉VLAN Tag

    [SwitchA] interface GigabitEthernet1/0/1

    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid

    [SwitchA-GigabitEthernet1/0/1] port hybrid vlan 100 200 untagged

    [SwitchA-GigabitEthernet1/0/1] quit

    3)创建Laptop1MAC地址与VLAN 100的关联,创建Laptop2MAC地址与VLAN 200的关联,开启GigabitEthernet1/0/1端口的MAC-VLAN功能。

    [SwitchA] mac-vlan mac-address 000d-88f8-4e71 vlan 100

    [SwitchA] mac-vlan mac-address 0014-222c-aa69 vlan 200

    [SwitchA] interface GigabitEthernet 1/0/1

    [SwitchA-GigabitEthernet1/0/1] mac-vlan enable

    2. SwitchB的配置。

    SwitchB的配置与SwitchA完全一致,这里不再赘述。

    3Core Switch的配置

    1)创建VLAN100VLAN200,并将GigabitEthernet1/0/13GigabitVLANEthernet
    1/0/14
    端口分别加入这两个VLAN

    <CoreSwitch> system-view

    [CoreSwitch] vlan 100

    [CoreSwitch-vlan100] port gigabitethernet 1/0/13

    [CoreSwitch-vlan100] quit

    [CoreSwitch] vlan 200

    [CoreSwitch-vlan200] port gigabitethernet 1/0/14

    [CoreSwitch-vlan200] quit

    2)配置GigabitEthernet1/0/3GigabitEthernet1/0/4端口为Trunk端口,均允许VLAN100VLAN200的报文通过。从这里也可以看出,同一个VLAN中可以基于多种VLAN划分方式来添加端口,因为在VLAN 100VLAN 200中,上一步已通过基于端口VLAN划分方式添加了gigabitethernet 1/0/13gigabitethernet 1/0/14两个Access端口。而此处添加的了Trunk端口(在SwitchASwitchB中还通过基于MAC地址划分方式添加了Hybird端口)。

    [CoreSwitch] interface GigabitEthernet1/0/3

    [CoreSwitch-GigabitEthernet1/0/3] port link-type trunk

    [CoreSwitch-GigabitEthernet1/0/3] port trunk permit vlan 100 200

    [CoreSwitch-GigabitEthernet1/0/3] quit

    [CoreSwitch] interface GigabitEthernet1/0/4

    [CoreSwitch-GigabitEthernet1/0/4] port link-type trunk

    [CoreSwitch-GigabitEthernet1/0/4] port trunk permit vlan 100 200

    [CoreSwitch-GigabitEthernet1/0/4] quit

    本文转自王达博客51CTO博客,原文链接http://blog.51cto.com/winda/1076785如需转载请自行联系原作者


    茶乡浪子

    展开全文
  • 交换机划分Vlan及DHCP----H3C S5110 Series一、划分VLAN1. 保证交换机不连接到外网,因为连接到外网后,交换机容易自动转变为转发功能。然后进入系统视图。 &lt;H3C&gt;system-view2. VLAN 100---创建VLAN ...
  • 一 组网需求: 1.SwitchA与SwitchB用trunk互连,相同VLAN的PC之间可以互访,不同VLAN的PC之间禁止互访; 2.PC1与PC2之间在不同VLAN,通过设置上层三层交换机SwitchB的VLAN接口1...
  • 如果直接使用“undo vlan”是删不干净的,因为配置VLAN时还配置过接口,下面就由小编介绍H3C交换机是如何删除VLAN的吧
  • H3C交换机VLAN配置实例

    2011-06-23 15:57:57
    介绍H3C交换机VLAN配置方法说明,并有详细的实例说明
  • 下面两个交换机配置,现在提示PVID不匹配,但能ping通!如何解决报错?或者有什么更好的配置方法? [img=https://img-bbs.csdn.net/upload/202008/14/1597401642_373109.png][/img][img=...
  • H3C 交换机VLAN配置及DHCP服务配置,用户接口配置
  • H3C交换机删除VLAN与其绑定端口配置

    千次阅读 2019-09-23 19:56:32
    在系统视图下,执行 undo int vlan 2 undo vlan 2 可以删除vlan2的配置信息。...[H3C-vlan2]undo port GigabitEthernet 3/1/1 可以解除GE3/1/1和VLAN2的绑定。 在系统视图下,输入: dis int v b 可以查看当前的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 536
精华内容 214
关键字:

h3c交换机配置vlan