精华内容
下载资源
问答
  • H3C交换机配置

    2021-08-27 11:20:36
    h3c 交换机配置命令 通过 console 连接到交换机 交换机所使用的 console 接口看上去像是一个普通的 RJ45 网卡接口,但是并不能使用普通的网线与 PC 连接 ^_^ 。它要通过 RJ45-RS232 转换线转换为 RS232 接口...

    h3c 交换机的配置命令

    通过 console 连接到交换机

    交换机所使用的 console 接口看上去像是一个普通的 RJ45 网卡接口,但是并不能使用普通的网线与 PC 连接 ^_^ 。它要通过 RJ45-RS232 转换线转换为 RS232 接口(串口),才能和 PC 连接。 现在很多 PC ,包括笔记本,已经没有了 RS232 接口(串口),就需要再通过一个 USB-RS232 的转换线再次转换。

    线路物理连接之后,再通过 PC 的 COM 口与交换机进行通信。 一般可使用的工具包括 securetCRT 和超级终端等( Linux 上使用一些其它的工具)。需要设置的内容包括:

    1.端口,为COMx
    2.波特率,一般可用9600/19200等,默认为9600
    3.数据量,5-8bits,默认为8
    4.奇偶校验,默认没有
    5.停止位,默认为1
    6.流量控制方法,默认没有

    配置好后,如果 secureCRT 上按几下 enter 能有反应,表明连接成功。

    进入配置界面

    通过 console 连接进入交换机时,得到的是 console 界面,这个界面的权限很大(除非是已经配置了用户和权限,否则能执行所有的配置命令),因此要小心配置。

    如果不知道命令,在界面输入个 ? ,可获得帮助。

    一此常用的命令:
    1.system-view 系统配置视图
    2.interface 进入接口配置
    3.port 对端口进行配置
    4.undo 删除/取消/反向
    5.display
    6.quit 退出

    配置实例

    配置接口vlan

    建立 vlan 2

    vlan 能对局域网划分,让不同 vlan 的 PC 进行相互隔离。

    system-view
    vlan 2
    port GigabitEthernet1/0/3 to GigabitEthernet1/0/10
    quit
    display current-configuration

    删除 vlan 2

    删除一个vlan

    system-view
    undo vlan 2

    配置端口 trunk 模式

    一般情况下,端口是以 access 模式工作,即只能通过特定号码的 vlan 。 trunk 模式的端口用于交换机与交换机之间连接,能通过很多的 vlan 。以下配置端口为 trunk 模式,并允许 vlan 129-4094 通过。

    system-view
    interface GigabitEthernet1/0/1
    port link-type trunk
    port trunk permit all
    undo port trunk permit 1 to 128

    有些通过 port trunk all-pass vlan all 配置允许通过的 vlan 。

    批量配置端口(端口组)

    创建端口组,在端口中进行批量配置。

    port-group 1
    group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/12
    port link-type trunk
    port trunk all-pass vlan all

    trunk 模式转 access 模式

    这个问题有点意思,因为在 H3C 的交换机中,如果一个 trunk 端口直接用 port link-type 命令转为 access 端口时,很多时候会报告一个很奇怪的错误,意思是要先做一些其它的配置。其实,过程是这样的,必须先把端口允许通过的vlan只保留vlan 1,其它全部取消,然后才能配置为access模式,最后才能把这个端口配置到其它的vlan里面。

    undo port trunk  allow-pass vlan all
    port trunk allow-pass vlan 1
    port link-type access

    保存配置 save

    退出到普通视图,然后

    save

    等待配置保存完毕

    看不懂的可以私聊我

    展开全文
  • Cisco_H3C交换机配置与管理完全手册

    千次下载 热门讨论 2012-10-02 11:53:06
    《Cisco/H3C交换机配置与管理完全手册》采用用户手册编写方式,综合比较两大品牌的主 要功能配置方法,目的就是让广大读者从思路上全面、系统地掌握交换机各主要功能的配置与管理方法。《Cisco/H3C交换机配置与管理...
  • H3C交换机常用配置命令大全
  • H3C交换机配置管理口和SNMP客户端

    千次阅读 2019-10-22 20:26:48
    H3C配置snmp客户端 1. 配置管理口 interface M-GenEnternet 0/0/0 ip address 192.168.1.2 255.255.255.0 save 配置网关(静态路由) ip route-static 0.0.0.0 0.0.0.0 192.168.1.254 save 2. H3C配置snmp...

    1. 配置管理口

    interface M-GenEnternet 0/0/0 
    ip address 192.168.1.2 255.255.255.0  
    save
    
    • 配置网关(静态路由)
    ip route-static 0.0.0.0 0.0.0.0 192.168.1.254
    save
    

    2. H3C配置snmp客户端

    snmp-agent
    snmp-agent community read public
    snmp-agent sys-info version all
    save
    
    展开全文
  • H3C交换机SSH配置完全攻略 1.使用SSH+密码认证(基本SSH配置方法)** 注:在用户使用SSH登录交换机时,交换机对所要登录的用户使用密码对其进行身份验证 生成RSA和DSA密钥对 [H3C]public-key local create rsa [H3C]...

    H3C交换机SSH配置完全攻略

    1.使用SSH+密码认证(基本SSH配置方法)**

    注:在用户使用SSH登录交换机时,交换机对所要登录的用户使用密码对其进行身份验证
    生成RSA和DSA密钥对
    [H3C]public-key local create rsa
    [H3C]public-key local create dsa
    设置用户接口上的认证模式为AAA,并让用户接口支持SSH协议
    [H3C]user-interface vty 0 4
    [H3C-ui-vty0-4]authentication-mode scheme
    [H3C-ui-vty0-4]protocol inbound ssh
    创建用户luwenju-juzi,设置认证密码为luwenju-!@# 登录协议为SSH,能访问的命令级别为3
    [H3C]local-user luwenju-juzi
    [H3C-luser-luwenju-juzi]password cipher luwenju-!@#
    [H3C-luser-luwenju-juzi]service-type ssh level 3
    指定用户luwenju-juzi的认证方式为password
    [H3C]ssh user luwenju-juzi authentication-type password
    一个基本的SSH配置就结束了,配置完成后即可使用SSH登录工具进行连接交换机

    2.使用SSH+密钥、密码认证(高级SSH配置方法)

    注:客户端在使用SSH工具登录交换机时,交换机同时使用密钥和密码对所要登录的用户实行身份验证
    生成RSA和DSA密钥对
    [H3C]public-key local create rsa
    [H3C]public-key local create dsa
    设置用户接口上的认证模式为AAA认证,并在接口上开启SSH协议,并设置用户能访问的命令级别为3
    [H3C]user-interface vty 0 4
    [H3C-ui-vty0-4]authentication-mode scheme
    [H3C-ui-vty0-4]protocol inbound ssh
    [H3C-ui-vty0-4]user privilege level 3
    创建用户,并指定认证方式为公钥认证,用户名为luwenju-juzi,密码为luwenju-!@#
    [H3C]local-user luwenju-juzi
    [H3C-luser-luwenju-juzi]password cipher luwenju-!@#
    [H3C-luser-luwenju-juzi]service-type ssh level 3
    [H3C]ssh user luwenju-juzi authentication-type password-publickey
    客户端生成公钥和私钥
    用puttygen.exe生成公私钥对,然后放到某个文件夹下,在此,我们生成的公钥叫luwenjukey私钥为luwenju.ppk,然后我们把公钥文件luwenjukey上传到FTP服务器,然后登录交换机,将luwenjukey下载到交换机
    ftp 202.106.0.20
    [ftp]get luwenjukey
    为用户生成公钥,在交换机上把文件luwenjukey中导入客户端的公钥,公钥名为luwenju-juzikey 注:luwenju-juzikey是为用户生成的公钥
    [H3C]public-key peer luwenju-juzikey import sshkey luwenjukey
    为用户luwenju-juzi指定公钥luwenju-juzikey
    [H3C]ssh user luwenju-juzi assign publickey luwenju-juzikey
    然后打开SSH登录工具,导入私钥luwenju.ppk,然后输入交换机的IP地址登录即可

    3.使用SSH+密码认证(基本SSH配置方法)

    注:在用户使用SSH登录交换机时,交换机对所要登录的用户使用密码对其进行身份验证
    生成RSA和DSA密钥对
    [H3C]public-key local create rsa
    [H3C]public-key local create dsa
    设置用户接口上的认证模式为AAA,并让用户接口支持SSH协议
    [H3C]user-interface vty 0 4
    [H3C-ui-vty0-4]authentication-mode scheme
    [H3C-ui-vty0-4]protocol inbound ssh
    创建用户luwenju-juzi,设置认证密码为luwenju-!@# 登录协议为SSH,能访问的命令级别为3
    [H3C]local-user luwenju-juzi
    [H3C-luser-luwenju-juzi]password cipher luwenju-!@#
    [H3C-luser-luwenju-juzi]service-type ssh level 3
    指定用户luwenju-juzi的认证方式为password
    [H3C]ssh user luwenju-juzi authentication-type password
    一个基本的SSH配置就结束了,配置完成后即可使用SSH登录工具进行连接交换机

    4.使用SSH+密钥、密码认证(高级SSH配置方法)

    注:客户端在使用SSH工具登录交换机时,交换机同时使用密钥和密码对所要登录的用户实行身份验证
    生成RSA和DSA密钥对
    [H3C]public-key local create rsa
    [H3C]public-key local create dsa
    设置用户接口上的认证模式为AAA认证,并在接口上开启SSH协议,并设置用户能访问的命令级别为3
    [H3C]user-interface vty 0 4
    [H3C-ui-vty0-4]authentication-mode scheme
    [H3C-ui-vty0-4]protocol inbound ssh
    [H3C-ui-vty0-4]user privilege level 3
    创建用户,并指定认证方式为公钥认证,用户名为luwenju-juzi,密码为luwenju-!@#
    [H3C]local-user luwenju-juzi
    [H3C-luser-luwenju-juzi]password cipher luwenju-!@#
    [H3C-luser-luwenju-juzi]service-type ssh level 3
    [H3C]ssh user luwenju-juzi authentication-type password-publickey
    客户端生成公钥和私钥
    用puttygen.exe生成公私钥对,然后放到某个文件夹下,在此,我们生成的公钥叫luwenjukey私钥为luwenju.ppk,然后我们把公钥文件luwenjukey上传到FTP服务器,然后登录交换机,将luwenjukey下载到交换机
    ftp 202.106.0.20
    [ftp]get luwenjukey
    为用户生成公钥,在交换机上把文件luwenjukey中导入客户端的公钥,公钥名为luwenju-juzikey 注:luwenju-juzikey是为用户生成的公钥
    [H3C]public-key peer luwenju-juzikey import sshkey luwenjukey
    为用户luwenju-juzi指定公钥luwenju-juzikey
    [H3C]ssh user luwenju-juzi assign publickey luwenju-juzikey
    然后打开SSH登录工具,导入私钥luwenju.ppk,然后输入交换机的IP地址登录即可

    展开全文
  • 华三交换机配置工具

    2018-06-20 17:25:04
    华三交换机配置工具软件.华三交换机配置工具软件.华三交换机配置工具软件.
  • H3C交换机SSH配置(20200922)

    千次阅读 2020-09-23 21:03:36
    H3C交换机SSH配置(20200922)H3C SSH配置方案1: (AAA认证+Password认证)H3C SSH配置方案2: (AAA认证+Publickey认证+FTP上传文件) 实验拓扑: H3C SSH配置方案1: (AAA认证+Password认证) #配置VLAN...

    实验拓扑:
    在这里插入图片描述

    H3C SSH配置方案1: (AAA认证+Password认证)

    #配置VLAN接口1的IP地址,客户端将通过该地址连接SSH服务器。

    [H3C] interface vlan-interface 1
    [H3C-Vlan-interface1] ip address 192.168.56.2 255.255.255.0
    [H3C-Vlan-interface1] quit

    #开启SSH

     system-view
    [H3C] ssh server enable

    #设置SSH客户端登录用户界面的认证方式为AAA认证。

    [H3C] user-interface vty 0 4  (最大允许5个用户登录)
    [H3C-line-vty0-4] authentication-mode scheme

    #设置Switch上远程用户登录协议为SSH。

    [H3C-line-vty0-4] protocol inbound ssh (可用此协议登录)或者: protocol inbound telnet
    [H3C-line-vty0-4] quit

    #创建用户admin,设置认证密码为admin@123 登录协议为SSH,能访问的命令级别为3

    [H3C]local-user admin
    [H3C-luser-manage-admin]password simple admin@123
    [H3C-luser-manage-admin]service-type ssh
    [H3C-luser-manage-admin]authorization-attribute user-role level-3

    #指定用户admin的认证方式为password;服务类型为Stelnet链接:

    [H3C]ssh user admin service-type stelnet authentication-type password

    #保存配置信息

    < H3C>save

    H3C SSH配置方案2: (AAA认证+Publickey认证+FTP上传文件)

    #配置Stelnet客户端,生成RSA密钥对(略)

    使用Xshell工具生成公钥与私钥,将公钥(Public Key)上传至到服务的文件目录中

    #配置VLAN接口1的IP地址,客户端将通过该地址连接SSH服务器。

    [H3C] interface vlan-interface 1
    [H3C-Vlan-interface1] ip address 192.168.56.2 255.255.255.0
    [H3C-Vlan-interface1] quit

    #开启SSH与FTP服务器Switch

     system-view
    [H3C] ssh server enable
    [H3C] fto server enable

    #设置SSH客户端登录用户界面的认证方式为AAA认证。

    [H3C] user-interface vty 0 4  (最大允许5个用户登录)
    [H3C-line-vty0-4] authentication-mode scheme

    #设置Switch上远程用户登录协议。

    [H3C-line-vty0-4] protocol inbound all (缺省情况下,默认允许所有)
    [H3C-line-vty0-4] quit

    #生成密钥对

    [H3C]public-key local create rsa (一般情况下只要生成一种既可以)
    [H3C]public-key local create dsa
    [H3C]public-key local create ecdsa

    #创建登录用户工作文件目录

    cd flash:/ (进入falsh:/)
    mkdir admintest (创建工作目录【文件夹】)

    #创建用户admin,设置认证密码为admin@123 登录协议为SSH,能访问的命令级别为3(或network-admin)

    [H3C]local-user admin
    [H3C-luser-manage-admin]password simple admin@123
    [H3C-luser-manage-admin]service-type ssh
    [H3C-luser-manage-admin]service-type FTP
    [H3C-luser-manage-admin]authorization-attribute work-directory flash:/admintest
    [H3C-luser-manage-admin]authorization-attribute user-role network-admin

    #将公钥文件上传至服务器

    ftp:/> put id_rsa_1024.pub

    #将ssh产生的公钥,导入服务器,并命名为公钥

    [H3C]public-key peer gongyao import sshkey id_rsa_1024.pub

    #指定用户admin的认证方式为publickey;服务类型为Stelnet链接:

    [H3C]ssh user admin service-type stelnet authentication-type publickey

    #保存配置信息

    < H3C>save

    H3C路由器/交换机使用FTP上传下载文件

    #通过console口配置FTP用户,设置该用户的优先级level为3

    [H3C]local-user admin
    [H3C-luser-manage-admin]password simple admin@123
    [H3C-luser-manage-admin]service-type ftp
    [H3C-luser-manage-admin]authorization-attribute user-role level-3
    [H3C-luser-manage-admin]authorization-attribute user-role network-admin

    #打开FTP服务

    [H3C]ftp server enable
    info: Start FTP server

    #指定本地用户的ftp目录

    [H3C-luser-manage-admin]authorization-attribute work-directory flash:/test/

    #使用FTP登陆

    在PC命令行窗口中,FTP路由器的以太口IP地址,并键入回车。
    输入FTP用户名及口令

    步骤四:使用FTP上传文件

    使用put命令上传系统文件。

    步骤五:使用FTP下载文件

    使用FTP中的get命令下载配置文件到本地目录。

    展开全文
  • H3C交换机最详细命令详解,非常有用的工具书,给懂的人用。
  • 目录H3C交换机基础配置设备配置方式登录设备交换机视图用户视图系统视图其它视图退出当前视图交换机常用功能命令命令查询显示命令保存配置 H3C交换机基础配置 设备配置方式 CLI(命令行)界面 WEB(图形)界面 ...
  • [H3C-S3600v2-3F-10.1-ui-vty0-15]authentication-mode scheme   /*scheme 参数表示需要进行本地或远端用户名和密码认证,具体采用本地认证还是远端认证视配置而定,默认使用本地认证,选择 command-authorization ...
  • echo Huawei、H3C使用窗口记录方式获取配置信息 echo echo ------------------------------------------------------------ echo echo 备份文件存放位置: /home/Network_Config_Backup/$BACKUP_DATA echo echo ...
  • H3C交换机配置的备份与恢复(转)

    千次阅读 2019-02-26 22:08:29
     相信有很多网管员备份配置都是采用display current命令查询当前设备运行配置信息,然后采用ctrl+c,ctrl+v的方式将信息保存到txt文档中;或者直接用捕捉屏幕输出的方法保存信息。还原的时候再复制命令到交换机中...
  • 相信有很多网管员备份配置都是采用display current命令查询当前设备运行配置信息,然后采用ctrl+c,ctrl+v的方式将信息保存到txt文档中;或者直接用捕捉屏幕输出的方法保存信息。还原的时候再复制命令到交换机中...
  • H3C交换机nat配置

    千次阅读 2017-07-18 14:05:00
    因下属店铺与银行线路调整,银行不使用前置机和路由器与店铺内网连接,二是采用mstp网络直连店铺交换机,通过静态路由和nat转换实现与银行数据的交互。 首先脑海中浮出的第一个问题是路由和nat的优先级谁高,经查,...
  • 使用SSH+密码认证(基本SSH配置方法)注:在用户使用SSH登录交换机时,交换机对所要登录的用户使用密码对其进行身份验证生成RSA和DSA密钥对[H3C]public-key local create rsa[H3C]public-key local create dsa设置用户...
  • 第一种(使用ftp下载配置文件): #!/bin/bash export datetime=date +%Y%m%d export BAKTIME=date +%Y%m%d%H%M%S export user="xiaoming" export password="xiaomingpasswd" ...export BAK_DIR=/back/H3C_bac...
  • TFTP是一个传输文件的简单协议,它基于UDP协议而实现,但是我们也不能确定有些TFTP协议是基于其它传输协议完成的。此协议设计的时候是进行小文件传输的。...iis7服务器管理工具(曾用名:IIS7远程桌面): 一、适用
  • H3C交换机SSH配置举例

    千次阅读 2016-03-02 10:46:49
    password认证配置举例1.组网需求如图,配置Host(SSH客户端)与Switch建立本地连接。Host采用SSH协议登录到Switch上,以保证数据信息交换的安全。SSH用户采用的认证方式为password认证,用户名和密码保存在Switch上...
  • 这是一款用于H3C交换机进行端口和IP地址绑定的可视化软件。
  • zabbix监控H3C交换机CPU和内存详细方法 一般会用SNMP协议监控设备的资源,用到SNMP协议其实也就是监控设备的一些OID的数值,不同厂商的设备的MIB库是不一样的。所以要监控一台设备务必提前获取设备的MIB库或者直接...
  • cacti监控H3C交换机

    千次阅读 2018-06-16 11:11:11
    1. 用超级终端或其他工具连接到交换机,如CRT等。如果有VLAN IP,则不需要设置,如果没有,先配置VLAN。system-viewinterface ... 开启snmp功能snmp-agent #H3C默认SNMP是关闭的,需要先开启snmp-agent community r...
  • SecureCRTPortable首次连接H3C交换机,首次连接完成之后就可以用telnet或者网页的方式了
  • 添加H3C交换机到Zabbix监控

    千次阅读 2019-11-01 14:40:16
    添加H3C交换机到Zabbix监控 zabbix可以通过Agent/SNMP/JMX/IPMI等多种接口方式进行主机管理,对于能够安装zabbix-agent客户端的平台应尽量使用agent客户方式添加主机,对于普通路由器和交换机虽然不能安装agent但是...
  • H3C交换机在企业中的常见配置 华为交换机中小企业或大企分支机构的常用配置 在中小企业或大企业的分支机构中,二层以太网交换机作为二层汇聚交换机,可以直接接用户,上行连接到二/三层以太网交换机,可以通过...
  • NULL 博文链接:https://23497465-qq-com.iteye.com/blog/2246221

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,906
精华内容 3,162
关键字:

h3c交换机配置工具