精华内容
下载资源
问答
  • 文章目录前言一、OSPF的基本概念1.1定义1.2协议概述1.2.1自治系统(AS)1.2.2内部网关协议(IGP)1.2.3外部网关协议(EGP)1.3OSPF区域1.4Router ID1.5DR与BDR1.5.1指定路由器(DR)1.5.2其它路由器(DRother)1.5.3DR与...

    前言

    OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(autonomous system,AS)内决策路由。是对链路状态路由协议的一种实现,隶属内部网关协议(IGP),故运作于自治系统内部。著名的迪克斯加算法被用来计算最短路径树。OSPF支持负载均衡和基于服务类型的选路,也支持多种路由形式,如特定主机路由和子网路由等

    一、OSPF的基本概念

    1.1定义

    OSPF路由协议是一种典型的链路状态(Link-state)的路由协议,一般用于同一个路由域内。在这里,路由域是指一个自治系统(Autonomous System),即AS,它是指一组通过统一的路由政策或路由协议互相交换路由信息的网络。在这个AS中,所有的OSPF路由器都维护一个相同的描述这个AS结构的数据库,该数据库中存放的是路由域中相应链路的状态信息,OSPF路由器正是通过这个数据库计算出其OSPF路由表的。
    作为一种链路状态的路由协议,OSPF将链路状态组播数据LSA(Link State Advertisement)传送给在某一区域内的所有路由器,这一点与距离矢量路由协议不同。运行距离矢量路由协议的路由器是将部分或全部的路由表传递给与其相邻的路由器。
    在信息交换的安全性上,OSPF规定了路由器之间的任何信息交换在必要时都可以经过认证或鉴别(Authentication),以保证只有可信的路由器之间才能传播选路信息。OSPF支持多种鉴别机制,并且允许各个区域间采用不同的鉴别机制。OSPF对链路状态算法在广播式网络(如以太网)中的应用进行了优化,以尽可能地利用硬件广播能力来传递链路状态报文。通常链路状态算法的拓扑图中一个结点代表一个路由器。若K个路由器都连接到以太网上,在广播链路状态时,关于这K个路由器的报文将达到K的平方个。为此,OSPF在拓扑结构图允许一个结点代表一个广播网络。每个广播网络上所有路由器发送链路状态报文,报告该网络中的路由器的链路状态。

    1.2协议概述

    1.2.1自治系统(AS)

    多个路由跑相同路由进程协议的区域 成为AS区域系统。
    在这里插入图片描述

    1.2.2内部网关协议(IGP)

    在区域内部跑的进程协议,如:RIP,OSPF,ISIS等
    在这里插入图片描述

    1.2.3外部网关协议(EGP)

    在区域外跑的进程协议
    在这里插入图片描述

    1.3OSPF区域

    为了适应大型的网络,OSPF在AS内划分多个区域
    每个OSPF路由器只维护所在区域的完整链路状态信息
    在这里插入图片描述
    区域ID
    ●区域ID可以表示成一个十进制的数字
    ●也可以表示成一个IP
    骨干区域Area 0
    ●负责区域间路由信息传播
    非骨干区域

    1.4Router ID

    OSPF区域内唯一标识路由器的IP地址

    Router ID选取规则
    ●选取路由器loopback接口上数值最高的IP地址
    ●如果没有loopback接口,在物理端口中选取IP地址最高的
    ●也可以使用router-id命令指定Router ID

    1.5DR与BDR

    DR ,BDR 和其他路由
    ● DR: 区域当中的主路由,有且仅有一个
    ●2BDR:区域当中的备份路由,有且仅有一个
    ● 除了DR 和 BDR 都是其他路由

    其他路由器只和 DR 和 BDR 形成邻接关系。主路由负责通告信息,备份路由负责准备顶替 DR
    其他路由器发送信息只能到达DR 和BDR(一个组播) ,DR再发送通告信息(第二个组播)。其中存在两个组播信息。
    DR 和 BDR 负责监控其他路由发来的信息

    1.5.1指定路由器(DR)

    在这里插入图片描述

    1.5.2其它路由器(DRother)

    DRother只和DR及BDR发生关系
    在这里插入图片描述

    1.5.3DR与BDR的选举方法

    自动选举DR和BDR
    网段上Router ID最大的路由器将被选举为DR,第二大的将被选举为BDR
    手工选择DR和BDR
    ●优先级范围是0~ 255,数值越大,优先级越高,默认为1
    ●如果优先级相同,则需要比较Router ID
    ●如果路由器的优先级被设置为0,它将不参与DR和DBR
    的选举

    1.5.4DR与BDR的选举过程

    路由器的优先级可以影响一个选举过程,但是他不能强制更换已经存在的DR或BDR路由器。
    即,我们第一个启动的OSPF路由器就会变成DR。第二个启动的OSPF的路由器会变成BDR。而第三个和以后开启的路由器即使路径再短,也无法更改现有的DR和BDR。

    1.6OSPF的组播地址

    Drother会通过224.0.0.6向DR和BDR通告网络状态信息,DR会通过
    224.0.0.5向所有邻居通告信息

    1.7OSPF的数据包类型

    OSPF数据包
    承载在IP数据包内,使用协议号89
    OSPF的包类型
    在这里插入图片描述

    二、OSPF的工作原理

    2.1、工作原理简述

    OSPF的简单说就是两个相邻的路由器通过发报文的形式成为邻居关系,邻居再相互发送链路状态信息形成邻接关系,之后各自根据最短路径算法算出路由,放在OSPF路由表,OSPF路由与其他路由比较后优的加入全局路由表。整个过程使用了五种报文、三个阶段、四张表。
    五种报文
    Hello报文:建立并维护邻居关系。
    DBD报文:发送链路状态头部信息。
    LSR报文:把从DBD中找出需要的链路状态头部信息传给邻居,请求完整信息。
    LSU报文:将LSR请求的头部信息对应的完整信息发给邻居。
    LSACK:收到LSU报文后确认该报文。
    三个阶段
    邻居发现:通过发送Hello报文形成邻居关系。
    路由通告:邻居间发送链路状态信息形成邻接关系。
    路由计算:根据最短路径算法算出路由表。
    四张表
    邻居表:主要记录形成邻居关系路由器。
    链路状态数据库:记录链路状态信息。
    OSPF路由表:通过链路状态数据库得出。
    全局路由表:OSPF路由与其他比较得出。

    2.2、OSPF的工作过程

    2.2.1了解自身链路

    每台路由器了解其自身的链路,即与其直连的网络。

    2.2.2寻找邻居

    不同于RIP,OSPF协议运行后,并不立即向网络广播路由信息,而是先寻找网络中可与自己交换链路状态信息的周边路由器。可以交互链路状态信息的路由器互为邻居。

    2.2.3创建链路状态数据包

    路由器一旦建立了邻居关系,就可以创建链路状态数据包。

    2.2.4链路状态信息传递

    路由器将描述链路状态的LSA泛洪到邻居,最终形成包含网络完整链路状态信息的链路状态数据库。

    2.2.5计算路由

    路由区域内的每台路由器都可以使用SPF算法来独立计算路由。

    三、OSPF协议主要优点

    (1)OSPF 适合在大范围的网络:OSPF 协议当中对于路由的跳数,它是没有限制的,所以 OSPF 协议能用在许多场合,同时也支持更加广泛的网络规模。只要是在组播的网络中,OSPF协议能够支持数十台路由器一起运作。
    (2)组播触发式更新:OSPF 协议在收敛完成后,会以触发方式发送拓扑变化的信息给其他路由器,这样就可以减少网络宽带的利用率;同时,可以减小干扰,特别是在使用组播网络结构,对外发出信息时,它对其他设备不构成其他影响
    (3)收敛速度快:如果网络结构出现改变,OSPF 协议的系统会以最快的速度发出新的报文,从而使新的拓扑情况很快扩散到整个网络;而且,OSPF 采用周期较短的 HELLO 报文来维护邻居状态。
    (4)以开销作为度量值:OSPF 协议在设计时,就考虑到了链路带宽对路由度量值的影响。OSPF 协议是以开销值作为标准,而链路开销和链路带宽,正好形成了反比的关系,带宽越是高,开销就会越小,这样一来,OSPF 选路主要基于带宽因素。
    (5)OSPF 协议的设计是为了避免路由环路:在使用最短路径的算法下,收到路由中的链路状态,然后生成路径,这样不会产生环路。(6)应用广泛:广泛的应用在互联网上,其他会有大量的应用实例。证明这是使用最广泛的IGP 之一。

    四、OSPF单域配置报文解析

    4.1拓扑图

    在这里插入图片描述
    1、R1、R2、R3上配置物理接口和环回口的IP地址
    2、R1、R2、R3上启动0SPF
    3、OSPF配置循序先R3、R2、R1

    4.2报文分析

    在最后一步前进行抓包,可以看到OSPF中Hello报文,这时候DR、BDR还未选举
    在这里插入图片描述
    等待40S后可以看到DBD、LSR、LSU、LSA报文
    在这里插入图片描述
    Router-id选举完成后,再次抓取Hello报文,这时候可以发现DR为13.0.0.3(R3),BDR为13.0.0.2(R2)
    在这里插入图片描述
    这时候断开R3(DR),发现R3已经不再进行组播
    在这里插入图片描述
    R2与R1在尝试联系R3
    在这里插入图片描述
    在联系不通后,原BDR(R2)成为DR,原Drother(R1)成为BDR
    在这里插入图片描述
    我们重新恢复R3,重新建立链路链接
    在这里插入图片描述
    这时的DR(R2),BDR(R1)均未发生变化
    在这里插入图片描述
    断开R1,R2与R3尝试联系R1
    在这里插入图片描述
    联系不通后,选取R3为BDR
    在这里插入图片描述

    4.3总结

    通过此次实验可以清楚地看到OSPF在选取DR,BDR的一个过程,在DR断开后,BDR会成为DR,在Drother中选举一台成为BDR,在原DR路由器重新连接后会成为Drother,不会与现在的DR、BDR路由器产生冲突。
    配置OSPF命令

    [R2]ospf 1 router-id 2.2.2.2                              #配置route-id
    [R2-ospf-1]area 0.0.0.0                                   #进入区域0 骨干区域
    [R2-ospf-1-area-0.0.0.0]network 13.0.0.0 0.0.0.255        #宣告网段、反掩码
    [R2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0           #宣告网段、反掩码
    
    展开全文
  • 一、OSPF定时更新和触发更新 1、定时更新 LSA每1800S更新一次,3600S失效 2、触发更新: 当链路状态发生变化之后,立即发送链路状态更新 二、认证的类型 1、不认证 2、明文认证 3、密文认证 三、认证的数据...

    一、OSPF定时更新和触发更新

    1、定时更新

    LSA每1800S更新一次,3600S失效

    2、触发更新:

    当链路状态发生变化之后,立即发送链路状态更新

    二、认证的类型

    1、不认证

    2、明文认证

    3、密文认证

    三、认证的数据

    认证的类型和认证的数据都需要匹配

    四、认证的方式

    1、区域认证

    2、接口认证

    3、vlink

    两种认证方式都存在,优先使用接口认证!

    [R1-ospf-1-area-0.0.0.0]authentication-mode hmac-md5 1 plain huawei//配置区域认证类型和密码,所有接口均开启认证

    [R4-Serial1/0/0]ospf authentication-mode hmac-md5 1 plain huawei//配置接口认证类型和密码,key ID 也必须相同(hash参数之一)

    现网主流动态路由OSPF网络技术,OSPF更新和认证详解,两分钟掌握

     

    查看区域认证:

    现网主流动态路由OSPF网络技术,OSPF更新和认证详解,两分钟掌握

     

    三、虚链路认证

    R3和R4之间配置虚链路

    [R3-ospf-1-area-0.0.0.34]vlink-peer 0.0.4.4 hmac-md5 1 plain huawei//配置R3和R4之间的vlink虚链路认证

    [R4-ospf-1-area-0.0.0.34]vlink-peer 33.1.1.1 hmac-md5 1 plain huawei

    现网主流动态路由OSPF网络技术,OSPF更新和认证详解,两分钟掌握

     

    vlink可以理解为ospf区域0的一部分,我们把R4的vlink认证取消然后配置区域0认证

    现网主流动态路由OSPF网络技术,OSPF更新和认证详解,两分钟掌握

     

    R3仍然为vlink认证,仍然可以正常建立vlink

    现网主流动态路由OSPF网络技术,OSPF更新和认证详解,两分钟掌握

     

    欢迎关注转发零基础学网络的小伙伴们,关注分享该WX Gongzhonghao:  华亿网络实验室  或   huayinetwork 

    Gongzhonghao内免费下载资料和网络技术视频,及最新考试认证信息,持续分享干货网络技术!

    展开全文
  • 动态路由OSPF协议!一.OSPF基本概念1.OSPF简介2.OSPF的基本特点3.Router-ID4.OSPF Cost二.OSPF的三张表1.邻居表(peer table)2.链路状态数据库(LSDB)3.OSPF路由表(Routing table)三.OSPF五种报文1.OSPF Hello...

    一.OSPF基本概念

    1.OSPF简介

    开放式最短路径优先OSPF是IETF组织开发的一个机遇链路状态的内部网关协议(Interior Gateway Protocol);
    其中开放式代表公有协议,不受厂商的限制,在任意设备上使用,应用最广泛的协议。
    版本:IPV2/IPV3,本文的OSPF均为OSPF IPV2协议。

    2.OSPF的基本特点

    作为基于链路状态的协议,除了能够解决RIP所面临的诸多问题以外,还有以下四点优点:

    ① OSPF采用组播形式收发协议报文,组播地址是:224.0.0.5(.5代表OSPF内所有的路由器)/244.0.0.6(代表OSPF指定路由器DR);

    ② 支持无类型域间选路;

    ③ 支持对等价路由器进行负载分担:路径开销相等的情况下,相等的两条路都可以选择;

    ④ 支持报文认证。

    3.Router-ID

    ① OSPF的术语是Router-ID,一台路由器指定唯一的Router-ID。一旦设定无法更改。若想更改需要重启OSPF进程,但是重启的风险:网络需要重新收敛,重新计算,数据传输有风险;

    ② Router-ID的设定可以通过手工配置,用32位点分十进制表示的。一般指的就是回环地址(loopback 0),因为loopback 0属于虚拟主机,接口不会断掉,从而保证了协议的稳定性。

    4.OSPF Cost

    ① OSPF使用cost“开销”作为路由度量值;

    ② OSPF接口cost=100M/接口宽带,其中100M为OSPF的参考带宽,可以修改。数值取整,并非四舍五入;

    ③ 每一个激活OSPF的接口都有一个cost值

    ④ 一条OSPF路由的cost由该路由从起源一路到达本地所有入接口cost值得总和
    在这里插入图片描述

    二.OSPF的三张表

    1.邻居表(peer table)

    OSPF是一种可靠的路由协议,需要先建立OSPF邻居关系之后才能发送hello报文,建立邻接关系(全毗邻的邻居关系),网络收敛,形成邻居表;

    OSPF邻居关系:直连的路由器是邻居

    邻接关系:全毗邻的邻居关系

    2.链路状态数据库(LSDB)

    OSPF是由LSA(链路状态通告)来描述网络拓扑信息的,用LSDB存储网络的LSA,运行OSPF时LSDB表必须同步

    3.OSPF路由表(Routing table)

    基于LSDB进行SPF(Dijkstra算法是Dijkstra发明的)计算,得出路由表

    三.OSPF五种报文

    1.OSPF Hello报文

    邻居到邻接关系,中间发送hello报文,到网络收敛之后,仍会发送hello报文,周期性是10s,为了确认邻居仍然存在,若40s没有响应(down),即4倍的周期性时间,就重新寻找邻居(发的组播是255.0.0.5);

    2.OSPF DD报文

    描述LSDB,相当于携带LSA头部信息,一个摘要;

    3.OSPF LSR报文

    链路状态请求。用于向对方请求所需的LSA,会携带具体的信息;

    4.OSPF LSU报文

    用于向对方发送其所需要的LSA,LSA是承载在LSU报文里面的,注意:抓包时只能发现LSU;

    5.OSPF LSAck报文

    确认报文。对收到的LSA进行确认。

    四.OSPF邻居关系的建立

    在这里插入图片描述
    第一步:建立关系R1发送hello包,R1的route-id会记录进去,R2收到hello信息,只有R1的1.1的信息,R2会再记录1.2,这时R2再回hello包给R1时,就建立了关系;

    第二步:首先协商主(master)/从(slave)关系,为了选择谁先发送DD报文;发送DD报文,交互LSA头部摘要信息;

    第三步:包含LSR(请求)、LSU(发送LSA)、LSAck(确认);

    第四步:同步之后进入OSPF全毗邻的邻接关系。

    邻居关系建立的7种状态

    1.down状态

    时间很短,开启了OSPF协议,还没有收到hello包;

    2.INT状态

    OSPF协议启动之后立马发送hello包,R2刚收到R1的hello包,在R1里面只建立了自己的ip,还没有R2的信息,没有双向建立,对于R2来说把R1置于INT状态,在R2里面去设置;

    3.Two-way状态

    R2发送自己的ip,把邻居设为R1,双向关系建立之后R1就是Two-way状态;MA网络会选举DR(指定路由器)、BDR(备份指定路由器)(这两个名词后面会做详解);

    4.Ex-start状态(就绪状态)

    发送DD报文,产生序列号(Seq=x),route-id 大的为主,选择主从关系的时候,DD报文是不携带LSA头部关系的,标志位:I、M、MS
    I=1:正在协商主从,I=0:确认主从;
    M=1:代表还有DD报文要发送 ,M=0:表示发送DD报文是最后一个;
    MS=1:表示报文是主(master)发的,MS=0,表示报文是从(slave)发的;

    5.Exchange状态

    交换信息,确定主从,开始携带(LSA头部信息)摘要,I=0,MS=0置为从,master发送DD报文11,slave就用原来的DD报文,也是11,这时主再发,主需要+1,DD报文就是12。周而复始,是交互的过程,等到R1和R2都没有了,就进入下一个阶段;

    6.Loading状态

    发LSR请求–收到全部的信息发送LSU信息–LAck ,R1和R2都是Loading;

    7.FULL状态

    交换结束进入OSPF全毗邻的邻接关系

    五.OSPF网络类型

    1.OSPF支持的网络类型

    ①点到点网络

    ②广播型多路访问网络

    ③非广播型多路访问(NBMA)网路.

    ④P2MP网络

    2.常见链路层协议对应的默认网络类型

    在这里插入图片描述

    六.OSPF的基本工作机制

    1.DR BDR

    DR、BDR的特性
    在上面提到OSPF邻居关系的建立的Two-way状态时,MA网络会选举DB、BDR,下面详细讲解下概念以及工作原理:

    1)选举规则:先优先级大的,若优先级相同,选routeid大的,默认优先级:1,可选范围是0-255,若没有0则不参加选取;

    2) 没有抢占性
    DR:指定路由器
    BDR:备份指定路由器

    在这里插入图片描述

    在OSPF系统中,建立邻居关系之后,会存在DR和BDR,若DR坏了,BDR承载,当DR恢复正常之后,不会变成BDR,不存在抢占

    DR BDR监听组播地址224.0.0.6
    DRother 监听组播地址 224.0.0.5

    路由器除了被定于为DR和BDR,其余都是DRother。

    2.LSA的泛洪

    路由器R3用224.0.0.6通知DR及BDR–DR、BDR监听224.0.0.6这一组播地址–DR向组播地址224.0.0.5发送更新以通知其他路由器–所有的OSPF路由器监听224.0.0.5这一组播地址–路由器收到包含变化后的LSA的LSU后–更新自己的LSDB,过一段时间(SPF延迟)-对更新链路状态数据库执行SPR算法–更新路由表

    3.OSPF area(区域)的概念

    (1)单区域的问题

    ① LSA泛洪严重,OSPF路由器的负担很大;

    ② 区域内部动荡会引起全网络路由器的SPF计算;

    ③ LSDB庞大,资源消耗过多,设备性能下降,影响数据转发;

    ④ 每台路由器都需要维护的路由表越来越大,但区域内路由无法汇总
    那么就要划分多区域

    (2)OSPF多区域的优点

    ① 减少了LSA洪泛的范围,有效的把拓扑图变化控制在区域内,达到网络优化的目的;

    ② 在区域边界可以做路由汇总,减少了路由表

    ③ 充分利用OSPF特殊区域的特性,进一步减少了LSA泛洪,从而优化路由

    ④ 多区域提高了网络扩展性,有理由组件大规模的网络

    (3)OSPF area(区域)的概念

    Area0为骨干区域,负责在非骨干区域之间中转由区域边界路由器归纳的链路状态通告信息。为了防止出现环路,OSPF要求所有的非骨干区域之间不能直接进行LSA的交互,而必须通过Area0骨干区域进行中转,因此所有的非骨干区域必须都与Area0“直接相连”。
    在这里插入图片描述

    路由器的角色名称

    在这里插入图片描述

    IR
    区域内路由器 lnternal Router

    ABR
    区域边界路由器(ABR) Area Border Router

    BR
    骨干路由器 Backbone Router

    ASBR
    AS边界路由器(ASBR) AS Boundary Router

    (4)OSPF的4种特殊区域

    除了骨干区域,还可以配置一下四种区域类型:

    stub 末梢区域:后面没有路由器设备

    totally 完全末梢区域:只有一条默认路由出去

    nssa 非完全末梢区域:完全的不够彻底,这一段在OSPF的末梢,但是后面还连着起亚区域,就叫非完全末梢区域,跑的就是7类LSA,不会泛洪到其他区域

    totally nssa 完全非完全末梢区域

    ① Stub Area 末梢区域

    特点

    禁止来自area0的Type-4、Type-5进入
    通过ABR自动向该区域下发使用Type-3 LSA描述的默认路由
    路由器禁止执行外部路由重发布动作

    配置

    ospf 1
    area 1
    stub

    ② totally 完全末梢区域

    特点

    禁止来自Area 0的3、 4/5类LSA进入
    ABR会自动向该区域下发使用Type-3 LSA描述的默认路由
    路由器禁止执行外部路由重发布动作

    配置

    ospf 1
    area 1
    stub no-summary 完全末梢区域, 只配置当前路由器即可,无须双向配置

    ③ nssa区域 非完全区域

    特点

    禁止Type-4、Type-5 LSA泛洪。允许本区域路由器注入AS外部路由器,这些路由注入之后以Type-7 LSA形式在NSSA内泛洪,并且Type-7LSA只能在NSSA内泛洪
    NSSA的ABR将Type-7 LSA转换成Type-5 LSA并泛洪到Area0
    NSSA的ABR下发一条Type-7 LSA的0.0.0.0/0默认路由进NSSA

    配置

    ospf 1
    area 2
    nssa 非完全末梢区域 在ABR上配置,需要双向配置

    ④ totally nssa 完全非完全末梢区域

    特点

    在NSSA的基础上,禁止从Area 0区域进入的3类LSA,同时NSSA ABR下发一条3类的缺省路由

    配置

    ospf 1
    area 2
    nssa no-summary 在ABR上配置

    补充说明

    Area 0不能配置成Stub Area

    如果要将一个Area配置成Stub Area ,则该Area中的所有路由器都要配置Stub Area 属性,否则邻居关系无法正常建立

    Stub Area 内不能存在ASBR,即自治系统外部的路由不能再Stub Area 内传播

    Stub Area 内不能存在虚连接

    在这里插入图片描述

    特殊区域及LSA泛洪小结

    在这里插入图片描述

    七.OSPF六类LSA与链路状态数据库

    OSPF使用LSA(链路状态通告)来在网络中的路由器之间交换网络拓扑信息。LSA详尽地描述了网络的拓扑,OSPF总共有LSA-1、LSA-2、LSA-3、LSA-4、LSA-5、LSA-7共6类LSA他们分别拥有不同的职能
    在这里插入图片描述

    1.Type-1 LSA:Router LSA

    又称:LSA1或者type-1 LSA,每一台运行OSPF的设备都会产生LSA-1;

    传播范围:只能在本区域传播,不能跨越ABR

    宣告者:每个OSPF路由器

    内容:直连接口的网段信息和cost,即路由和拓扑信息

    查看方法:dis ospf lsdb router 1.1.1.1

    Link-id为Router-id,ADV为通告者

    注意,在LSA-1中看不到掩码,掩码信息需要在LSA-2中查看

    2.Type-2 LSA: Network LSA

    只在多路访问MA网络中存在

    传播范围:只能在本区传播,不能跨越ABR

    宣告者:DR(通告一共有多少台路由器运行)

    内容:描述有多少成员以及掩码信息,直连接口的网段信息和cost值

    查看方法:dis ospf lsdb network

    1类2类小结:
    借助一个区域内所泛洪的Type-1LSA及Type2,该区域中的所有路由器能够还原出区域的完整拓扑,并在此基础上计算出到达区域内各个网段的最佳、无环路由

    3.Type-3LSA: Summary LSA

    汇总LSA,可通过操作拦截

    传播范围:整个OSPF域

    通告者:ABR(本区域边界路由器,可能发生改变)

    内容:域间路由,LSA-3穿越多个ABR时,通告者改变;数据汇总到area0中,归纳汇总的作用

    查看方法:dis ospf lsdb summary

    4.Type-4 LSA:Summary ASB LSA

    告诉其他区域ASBR所在的位置,根据LSA-5而来

    传播范围:除ASBR所在区域外的整个OSPF区域

    宣告者:ABR(穿越多个ABR时改变)

    内容:ASBR的Router-id

    查看方法:dis ospf lsdb asbr

    5.Type-5 LSA:LSA-5 External LSA

    外部LSA,描述外部信息,不属于任何一个区域

    传播范围:整个OSPF域;

    宣告者:ASBR(只有引入了外部路由并且重分发动作执行后才会成为ASBR,通告在穿过多个区域时一直不改变);

    内容:外部路由,在路由表中标记为“O-ASE”;

    查看方法:dis ospf lsdb ase

    LSA-4和LSA-5通常是一起出现的,LSA-5讲述的是外部路由,而LSA-4则是说ASBR的位置,所以是先有LSA-5再有LSA-4

    6.Type-7 LSA:LSA-7 AS External LSA

    与LSA-5只是称呼的不同,都是关于域外路由的

    传播范围:整个NSSA区域;

    宣告者:ASBR(穿过多个区域时一直不改变);

    内容:外部路由,会出现在NSSA区域,不允许进入到其他Area

    查看方法:dis ospf lsdb nssa

    NSSA的ABR在收到Type-7 LSA后,负责将其转换成Type-5 LSA,然后注入到Area0中,进而传播到整个OSPF域。

    Type-5 LSA和Type-7 LSA都有两种度量值Type1和Typ2,将外部路由引入OSPF是,如果为指定该外部路由的度量值类型,则缺省为Type2,且路由的外部cost缺省为1。

    八.路由重发布和路由汇总

    1.路由重发布

    (1)路由重发布的概念

    ① 在某些组网中,可能存在多种路由协议,每种路由协议对路由信息的理解及处理是不同的,因此初始情况下,路由信息在不同的路由协议之间是相互隔离的

    ② 路由重发布(Route redistribution)也被称为路由引入(Route
    importation),指的是将路由信息从一种路由协议发布到另一种路由协议的操作

    ③ 在网络中部署路由重发布,可以使得路由信息能够在多种路由协议之间实现传递,从而全网的数据能够实现互通

    (2)路由重发布相关要点

    ① 路由重发布的操作,是在路由选择域的边界设备上完成将路由信息从一个路由协议引入到另一个路由协议

    ② 将路由信息从路由协议A引入到路由协议B,则是在路由协议B的配置视图下完成相关配置

    ③ 路由重发布是具有方向性的,将路由信息从路由协议A引入到路由协议B则路由协议B可获知A中的路由信息,但是此时,A还并不知晓B路由协议中的路由信息,除非配置b-to-A的路由重发

    ④ 只有存在于路由表中的路由才能够被顺利地重发布。

    2.路由汇总

    路由汇总是一个非常重要的设计思想,通常在一个大中型网络的设计过程中,必须时刻考虑路由及路由的可优化型,其中,路由可汇总性就是一个非常关键的指标,不仅静态路由支持路由汇总,动态路由基本也都支持。

    (1)路由汇总的概念

    ① 路由汇总,又被称为路由聚合(Route Aggregation,或 route summary),即是将一组有规律的路由汇聚成一条路由,从而达到减小路由表规模以及优化设备资源利用率的目的

    ② 路由汇总是一个非常重要的网络设计思想,一个可汇总的网络设计方案将使得我们的网络更加优化、路由条目更加精简、网络管理更加简单在网络设计及部署中应时刻保有路由汇总的意识

    ③ 不仅仅静态路由能够部署路由汇总,动态路由协议也都支持由汇总功能

    ④ 路由汇总实际上是通过对目的网络地址和网络掩码的灵活操作实现的,形象的理解就是,用一个能够囊括这些小网段的大网段来代替它们

    在这里插入图片描述
    在这里插入图片描述

    在这里插入图片描述

    在这里插入图片描述

    (2)OSPF和RIP路由汇总的区别

    ①ospf没有自动汇总的功能

    ②rip的自动汇总,因为系统开启了水平分割,所以需要手动汇总

    展开全文
  • OSPF路由协议详解

    万次阅读 多人点赞 2019-06-18 16:44:48
    无类别链路状态路由协议,组播更新224.0.0.5/6;跨层封装到三层,协议号89; 基于拓扑工作,故更新量大-----需要结构化部署–区域划分、地址规划 触发更新、每30min周期更新 OSPF的数据包: Hello包 DBD–数据库描述...

    OSPF:开放式最短路径优先协议
    无类别链路状态路由协议,组播更新224.0.0.5/6;跨层封装到三层,协议号89;
    基于拓扑工作,故更新量大-----需要结构化部署–区域划分、地址规划
    触发更新、每30min周期更新

    OSPF的数据包:
    Hello包
    DBD–数据库描述包
    LSR–链路状态请求
    LSU–链路状态更新 携带各种LSA
    LSack–链路状态确认
    在这里插入图片描述

    状态机----OSPF建立时,存在各个阶段;
    1、down 本地一旦发出hello包进入下一状态
    2、Init初始化 本地接收到的hello包存在本地的RID进入下一状态
    3、2way双向通信 邻居关系建立标志;
    条件匹配:点到点网络直接进入下一状态;MA网络将进行DR/BDR选举(40S),非DR/BDR间不得进入下一状态;
    4、exstart 预启动 使用类似hello的DBD进行主从关系选举,RID大为主,主优先进入下
    一状态
    5、Exchange 准交换 使用真实的DBD包进行数据库目录共享,需要ACK;
    6、Loading 加载 使用LSR/LSU/LSack来获取未知的LSA信息;
    7、Full转发 邻接关系建立的标志

    OSPF工作过程:
    启动配置完成后,本地使用hello包建立邻居关系,生成邻居表;
    进行条件匹配,匹配失败者间保持为邻居关系,仅hello包周期保活即可;
    匹配成功者间,将使用DBD/LSR/LSU/LSack来获取未知的LSA信息,当收集其网络中所有LSA后,生成LSDB–数据表;之后使用最短路径算法,计算本地到达所有未知网段的最佳路由,然后将其加载路由表中,收敛完成。
    结构突变—1、新增网段 发送新的DBD 未知设备会使用LSR获取
    2、断开网段 发送新的DBD 未知设备会使用LSR获取

    名词:
    LSA–链路状态通告 —存在多种类别,携带不同环境下产生的拓扑或路由信息;该信息依赖
    LSU数据包传递;
    LSDB–链路状态数据库 —各种的LSA的集合
    OSPF的收敛行为------LSA洪泛 LSDB同步

    配置:
    r1(config)#router ospf 1 启动OSPF协议,启动时需要配置进程号,进行号仅具有本地意义
    r1(config-router)#router-id 1.1.1.1 全网唯一,手工–环回最大数值–物理接口最大数值
    宣告:1、激活 2、路由或拓扑 3、区域划分
    r1(config-router)#network 12.1.1.1 0.0.0.0 area 0
    r1(config-router)#network 1.1.1.1 0.0.0.0 area 0
    宣告时必须携带反掩码

    区域划分规则:
    1、星型结构
    2、必须存在ABR-边界路由器

    【1】当启动配置完成后,邻居间使用hello包建立邻居关系,生成邻居表:
    Hello包–用于邻居的发现、关系、保活
    hello time为10s或30s dead time 为hello time 的4倍;
    在这里插入图片描述

    Hello包中和邻居必须完全一致的参数:hello time和dead time
    区域ID
    认证字段
    末梢区域标记
    r2#show ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface
    1.1.1.1 0 FULL/ - 00:00:39 12.1.1.1 Serial1/0
    3.3.3.3 0 FULL/ - 00:00:38 23.1.1.2 Serial1/1
    状态机
    【2】邻居关系建立后,进行条件匹配,匹配失败保持为邻居关系,仅hello包保活
    匹配成功成为邻接关系,将使用DBD/LSR/LSU/LSACK来获取未知的LSA信息,生成数据库表:
    DBD:携带MTU值;强制邻居间MTU值必须一致,否则卡在exstart或exchange状态;
    DBD包中的描述字段:I 为1标示该包为本地发出的第一个DBD包
    M为0标示该包为本地发出的最后一个DBD包
    MS为1标示本地为主;
    隐性确认:从使用主的序列号来对主进行确认;

    r1#show ip ospf database 查看数据库简表
    OSPF存在各种类别的LSA,简表内仅记录分类的基础信息;

    【3】OSPF协议在生成好数据库表后,将基于最短路径规则将最佳路径加载到本地的路由表中
    O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2

    O标示本地区域内的路由–本地基于拓扑计算所得
    O IA 标示其他区域的路由通过ABR导入 --域间路由
    O E1/2 标示通过其他协议或进程计算所得,之后ASBR重发布导入 域外路由
    ON1/2 标示通过其他协议或进程计算所得,之后ASBR重发布导入,同时本地为NSSA或完
    全NSSA区域 -----域外路由

    管理距离为110;度量为cost=开销值=参考带宽/接口实际带宽
    Ospf选路,就是选择cost值之和最小路径;默认参考带宽为100M;若接口带宽大于参考带宽,将可能导致选路不佳,可以修改参考带宽
    r1(config)#router ospf 1
    r1(config-router)#default auto-cost reference-bandwidth ?
    <1-4294967> The reference bandwidth in terms of Mbits per second
    r1(config-router)#default auto-cost reference-bandwidth 1000
    注:所有设备均需修改;

    【4】OSPF建立邻接关系的条件
    网络类型:点到点网络类型 ----必然成为邻接关系
    MA----进行DR/BDR选举,所有非DR/BDR仅与DR/BDR建立邻接关系;非DR/BDR间正常保持为邻居关系;
    选择规则:1、比较接口优先级,默认为1,大优;
    2、若优先级相同,比较RID,数值大优;

    干涉选举:
    1、DR优选级最大,BDR次大;DR选择为非抢占,故修改优先级后,正常需要重启OSPF进程
    r1(config)#interface fastEthernet 0/0
    r1(config-if)#ip ospf priority 3
    r1#clear ip ospf process
    Reset ALL OSPF processes? [no]: yes
    2、DR优选级最大,BDR次大;其他设备优先级修改为0,标示不参选;
    切记:不能将所有参选接口优先级修改为0;

    【5】OSPF接口网络类型
    设备接口网络类型: 环回 点到点 BMA NBMA
    所谓的OSPF接口网络类型,是指OSPF协议在设备不同网络类型下的不同工作方式;

    设备接口网络类型 OSPF 接口网络类型(工作方式)
    环回接口 LOOPBACK LOOPBACK 无hello包,发送32位主机路由
    串口(HDLC/PPP)点到点 POINT_TO_POINT hello time 10s;不选DR;
    以太网接口 BMA BROADCAST hello time 10s;选DR;

    MGRE NBMA
    注:在tunnel接口上,OSPF默认的工作方式为点到点;这种工作方式在MGRE环境下,将无法正常建立邻居关系—因为点到点工作方式只能和一个邻居建邻;
    可以将接口工作方式修改为BROADCAST;切记BROADCAST和POINT_TO_POINT工作方式均为10s的hello time,故能够建立邻居关系,但由于一个选DR,另一个不选,不能正常收敛路由;
    r2(config)#interface tunnel 0
    r2(config-if)#ip ospf network broadcast
    注:若ROADCAST的工作环境为星型或部分网状结构都可能出现DR位置错误问题;
    必须修改DR的位置到最合适的地方;

    建议:
    1、在星型结构中可以定义为broadcast 类型,但注意DR位置;或修改为点到多点工作方式;
    2、在部分网状结构中直接定义为点到多点
    3、在全连网状建议broadcast ;
    r1(config)#interface tunnel 0
    r1(config-if)#ip ospf network point-to-multipoint

    点到多点工作方式:hello time 为30s;不选DR;
    2、不连续骨干

    解决方法:
    1、tunnel --在两台ABR上建立tunnel,然后将其宣告到OSPF协议中;
    缺点:选路不佳,对中间区域周期、触发占用;

    2、OSPF虚链路—相当于OSPF关闭了区域限制;
    在两台ABR上配置,然后骨干区域的ABR为非骨干区域间的ABR授权;
    R2(config)#router ospf 1
    R2(config-router)#area 1 virtual-link 4.4.4.4
    优点:选路正常,为减少对中间区域的资源占用,取消所有周期信息–hello、更新
    缺点:不可靠

    3、多进程双向重发布 --在一台设备启动多个进程时,每个进程为独立协议,用于自己的RID,自己的数据库和邻居关系,这些数据库不共享,仅将所以计算所得路径加载到同一张路由表中;若多个进程工作于同一接口上,仅最先启动进程生效;
    R4(config)#router ospf 1
    R4(config-router)#redistribute ospf 2 subnets
    R4(config-router)#exit
    R4(config)#router ospf 2
    R4(config-router)#redistribute ospf 1 subnets

    二、OSPF的数据库表 -----该表格由各种类别的LSA组成;
    所有类别LSA均存在以下参数:
    LS age: 119 老化时间,周期1800s归0,触发更新归0;最大老化3609;
    Options: (No TOS-capability, DC)
    LS Type: Router Links 类别名,此处为1类;
    Link State ID: 1.1.1.1 link-id—目录中番号
    Advertising Router: 1.1.1.1 通告者的RID;
    LS Seq Number: 80000003
    Checksum: 0x67F8
    Length: 60
    Number of Links: 3

               传播范围               通告者              携带信息 
    

    LSA1 Router 单区域(本区域) 本区域内所有设备 本地直连拓扑
    LSA2network 本区域 DR MA部分的拓扑
    LSA3Summary 整个OSPF区域 ABR O IA 域间路由
    LSA4 asbr-summary 除ASBR所在区域 ABR ASBR的位置
    外的整个OSPF区域
    和ASBR同区域的设备是通过1类来获取ASBR位置;
    LSA5 external 整个OSPF区域 ASBR O E 域外路由
    LSA7 nssa-external NSSA区域 ASBR O N 域外路由

             LINK ID(目录中的番号)            通告者     
    

    LSA1 通告者的RID 本地区域内所有设备
    LSA2 DR接口IP地址 DR
    LSA3 IA 路由目标 ABR,在经过下一个ABR时修改为本地
    LSA4 ASBR的RID ABR,在经过下一个ABR时修改为本地
    LAS5 E 路由目标 ASBR
    LSA7 N 路由目标 ASBR

    三、优化,减少OSPF的LSA的更新量
    【1】汇总 --减少骨干区域的LSA量
    (1)域间汇总–只能在ABR上操作
    r1(config)#router ospf 1
    r1(config-router)#area 2 range 5.5.4.0 255.255.254.0
    通过本区域内1/2类LSA计算所得
    (2)域外汇总–在ASBR上操作
    r4(config)#router ospf 1
    r4(config-router)#summary-address 99.1.0.0 255.255.252.0

    【2】特殊区域—减少非骨干区域
    不得为骨干区域,不能存在虚链路;

    (1)不存在ASBR
    {1}末梢区域----拒绝4/5的LSA,自动产生一条3类的缺省路由指向骨干
    r5(config)#router ospf 1
    r5(config-router)#area 2 stub 本区域内所有设备均需配置

    {2}完全末梢区域----在末梢区域的基础上进一步拒绝3类的LSA,仅保留一条3类缺省
    先将整个区域配置为末梢区域,然后仅在ABR上定义完全即可
    r1(config-router)#area 2 stub no-summary

    (2)存在ASBR
    {1}NSSA ----非完全末梢区域
    拒绝4/5的LSA,本区域ASBR产生的5类使用7类传输;7类LSA在离开本区域时被ABR修改为5类;不会自动产生缺省;
    作用:拒绝网络中其他区域的ASBR产生的4/5的信息;但为了避免环路产生,故不自动产生缺省,在管理员确定无环的前提下可以手工添加缺省路由;
    r3(config)#router ospf 1
    r3(config-router)#area 1 nssa

    {2}完全NSSA
    在NSSA的基础上进一步拒绝3类LSA;自动产生3类的缺省指向区域0;
    先将该区域配置为NSSA,然后仅在ABR上定义完全即可
    r3(config-router)#area 1 nssa no-summary

    四、OSPF的扩展配置
    1、认证
    【1】接口认证
    1)接口明文
    r1(config)#interface ethernet 0/0
    r1(config-if)#ip ospf authentication 开启明文认证需求,开启后本地所有ospf数据包中认证类型字段被修改,邻居间若不一致将不能建立邻居关系
    r1(config-if)#ip ospf authentication-key cisco123 配置明文密码

    2)接口密文
    r6(config)#int s0/1
    r6(config-if)#ip ospf authentication message-digest 开启秘文认证需求,开启后本地所有ospf数据包中认证类型字段被修改,邻居间若不一致将不能建立邻居关系
    r6(config-if)#ip ospf message-digest-key 1 md5 cisco123

    【2】区域认证
    例:在R1上开启关于区域0的明文或密文认证;然后仅仅只是将R1上所有属于区域0的接口,认证类型字段修改,相当于在R1上所有区域0接口配置明文或密文认证需求;但每个接口的秘钥还是需要逐一配置;
    r12(config)#router ospf 1
    r12(config-router)#area 2 authentication 明文
    r12(config-router)#area 2 authentication message-digest 密文

    【3】虚链路认证
    r1(config)#router ospf 1
    r1(config-router)#area 1 virtual-link 4.4.4.4 authentication
    r1(config-router)#area 1 virtual-link 4.4.4.4 authentication-key cisco
    r1(config-router)#area 1 virtual-link 4.4.4.4 authentication message-digest
    r1(config-router)#area 1 virtual-link 4.4.4.4 message-digest-key 1 md5 cisco123

    2、被动接口
    r1(config)#router ospf 1
    r1(config-router)#passive-interface ethernet 0/1

    3、加快收敛—邻居间直连接口hello和dead 必须完全一致
    r7(config)#interface s0/1
    r7(config-if)#ip ospf hello-interval 5
    r7(config-if)#ip ospf dead-interval 20
    注:修改本端的hello time本端的dead time自动4倍关系匹配;

    4、缺省
    3类缺省—通过特殊区域自动产生;
    末梢、完全末梢、完全NSSA自动产生;

    5类缺省—本地路由表中必须已经存在缺省路由,通过什么方式产生的无所谓;
    之后,可以使用专用指令将其重发布到OSPF协议中
    r9(config)#router ospf 2
    r9(config-router)#default-information originate
    默认进入路由为类型2,OE2;度量为1;
    类型1:在内部传递时不叠加内部度量;
    类型2:在内部叠加度量; 默认
    若网络中存在多台边界路由器,均进行重发布行为,建议修改为类型1;
    r9(config-router)#default-information originate metric-type 1

    r9(config-router)#default-information originate always 强制向内网发布缺省路由信息;

    7类缺省–ASBR上通过其他协议学习到的缺省导入OSPF,同时所导入区域为NSSA区域;
    r12(config)#router ospf 1
    r12(config-router)#area 2 nssa default-information-originate

    注:若一台设备同时学习多种缺省; 内部优于外部 3类优于5/7类;
    若5类和7类相遇,先比度量,小优;若度量一致那么5类优于7类;

    展开全文
  • 17-OSPF路由协议详解——OSPF路由汇总

    千次阅读 2019-07-23 13:26:25
    通常在一个大型的企业网或校园网中,其网络拓扑是非常复杂的,路由器的路由表也会非常冗余,这会造成网络设备在转发数据流量时需要消耗更多的硬件资源,OSPF路由协议也不例外,因此就需要用到路由汇总技术。...
  • 本次介绍OSPF区域间路由技术,内容包括区域间路由原理,使用Network-Summary-LSA描述区域间路由信息,虚连接技术,区域间路由汇聚等内容。
  • 文章目录一、OSPFv2基本概念1.1 OSPF的基本概念1.2 层次划分模型1.3 OSPF区域划分优势1.4 OSPF路由器类型1.5 OSPF路由类型1.6 OSPF支持的网络1.6.1 P2P1.6.2 广播型网络1.6.3 NBMA网络1.6.4 P2MP网络1.7 OSPF报文...
  • OSPF路由协议详解 OSPF

    2010-05-20 12:37:58
    1.OSPF的骨干区域及虚拟链路(Virtual-link) ——在OSPF路由协议中存在一个骨干区域(Backbone),该区域包括属于这个区域的网络及相应的路由器,骨干区域必须是连续的,同时也要求其余区域必须与骨干区域直接相连...
  •   OSPF(Open Shortest Path First:开放最短链路优先)路由协议是一种基于链路状态的路由协议, 它保证了无路由环路,并且支持划分区域,通过SPF最短路径算法保证了区域内部中的路由器不会出现路由环路问题。...
  • OSPF路由协议详解三——OSPF高级配置前言一、路由重分发1、理解路由重分发2、路由重分发的考虑3、重分发到OSPF域中路由的路径类型4、路由器A有两条到达外部目的网络10.1.2.0的路径5、OSPF路由重分发配置命令二、NSSA...
  • OSPF详解

    2021-03-19 19:29:52
    开放式最短路径优先(Open Shortest Path First,OSPF)是广泛使用的一种动态路由协议,它属于链路状态路由协议,具有路由变化收敛速度快、无路由环路、支持变长子网掩码(VLSM)和汇总、层次区域划分等优点。...
  • ospf详解

    2019-09-18 23:21:28
    ospf详解包括基础指令)ospf概念ospf数据包ospf状态机状态机异常处理建邻失败常用lsa类型 ospf概念 开放性最短路径优先协议 ospf数据包 1、hello 包 2、DBD包 -数据库描述包 3、LSR链路状态请求 4、LSU链路...
  • 内部网关协议和外部网关协议2.OSPF是链路状态路由协议二、OSPF的工作过程(3张表)OSPF区域三、DR和BDR1.DR和BDR的选举2.OSPF的组播地址3.OSPF的度量值四、OSPF的数据包类型(5种包)1.OSPF数据包2.OSPF的包类型五、...
  • 为了优化网络,OSPF 协议可以通过划分区域来减小这些不利的影响,也就是说,OSPF协议划分多个区域后,每一个区域的路由器只需要了解所在区域的网络路由拓扑,并不需要了解整个网络的路由拓扑,这样就减小了路由表,...
  • 介绍 RIP 简述RIP环路的形成 RIP防环机制 RIP和OSPF对比 OSPF 关键字 ...而内部路由协议又分为静态路由协议和动态路由协议2种,他们的区别在于静态路由协议是网管手工指定的灵活性差,且一般是应用...
  • OSPF也称为接口状态路由协议,通过路由器之间通告网络接口的状态来建立链路状态数据库,生成最短路径树,OSPF会在网络上发送HELLO包,如果HELLO包里面有3个内容匹配的话,就会建立邻居关系

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,664
精华内容 1,465
关键字:

动态路由ospf详解