精华内容
下载资源
问答
  • IIS8支持.NET framework1.1步骤.txt
  • 详细描述了在windows server 2012(64位)环境下安装配置IIS支持framework1.1的步骤,并配有详细截图!
  • IIS7中更改.net framework版本

    千次阅读 2012-04-23 13:44:09
    IIS7中配置的站点如果需要更改.net framework版本只需要更该站点对应的应用程序池的.net framework版本即可
    在IIS7中配置的站点如果需要更改.net framework版本只需要更该站点对应的应用程序池的.net framework版本即可
    展开全文
  • WIN2003 IIS 支持 ASP.NET插件 .net framework 2.0
  • IIS部署 10版发布注意事项 原版应用程序池的.netFramework版本为v2.0 换成10版后 需下载安装.netFramework v4.0版本
  • 利用dism工具 执行下面命令...dism /online /enable-feature /featurename:IIS-ISAPIFilter dism /online /enable-feature /featurename:IIS-ISAPIExtensions dism /online /enable-feature /featurename:IIS-...

    利用dism工具 执行下面命令才成功

    dism /online /enable-feature /featurename:IIS-ISAPIFilter
    
    dism /online /enable-feature /featurename:IIS-ISAPIExtensions
    
    dism /online /enable-feature /featurename:IIS-NetFxExtensibility45
    
    dism /online /enable-feature /featurename:IIS-ASPNET45
    

     

    作者:天国的声音 链接:https://www.jianshu.com/p/7b453b7495d3 來源:简书 简书著作权归作者所有,任何形式的转载都请联系作者获得授权并注明出处。

    转载于:https://www.cnblogs.com/shuzehui/p/10164002.html

    展开全文
  • IIS添加.net framework 4的支持

    千次阅读 2016-06-14 10:25:57
    然后,"可执行文件" 处填写:C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll "名称" 处随便写



    然后,"可执行文件" 处填写:C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll
    "名称" 处随便写

    展开全文
  • iis+zendframework

    2011-08-25 18:16:15
    ZendFramework的控制器可以被设置支持使用clean urls,这点在apache下很好写,前提是apache支持mod_rewrite模块,然后通过设置.htaccess可以对ZendFramework单独控制.但是在IIS写如何设置呢? 问题很简单,通过...
  • framework4.0 ... IIS添加对ashx文件的支持 http://www.cnblogs.com/szytwo/archive/2012/09/04/2670493.html 添加托管处理程序 *.ashx System.Web.UI.S...

    framework4.0

    https://www.microsoft.com/zh-cn/download/details.aspx?id=17718

     

     

    IIS添加对ashx文件的支持

    http://www.cnblogs.com/szytwo/archive/2012/09/04/2670493.html

     

    添加托管处理程序

    *.ashx

    System.Web.UI.SimpleHandlerFactory

    SimpleHandlerFactory-Integrated

    GET,HEAD,POST,DEBUG

    脚本

     

    SimpleHandlerFactory-ISAPI-2.0

    SimpleHandlerFactory-ISAPI-2.0-64

     

    %windir%\Microsoft.NET\Framework

    %windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll

    解析ashx文件的时候报错
    HTTP 错误 500.21 - Internal Server Error
    处理程序“SimpleHandlerFactory-Integrated”在其模块列表中有一个错误模块“ManagedPipelineHandler”
    在cmd下运行32或64位的Framework重新安装就好了。
    %windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i
    %windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i


    未能创建类型“WebServer.WebServer.Handler1”

    IIS,访问ashx网页,提示

     分析器错误消息: 未能创建类型“WebServer.WebServer.Handler1”。

    fix:.ashx文件放在网站目录下。和.aspx文件一样;而.ashx.cs文件要放在App_Code目录下。

    怎么才能让ashx和ashx.cs在同一个文件夹里可以解析,而不要放在App_Code目录里?

    解决方案:bin目录里要有网站的dll文件。iis会自动从bin里dll文件解析类名。bin里没有dll文件,IIS只会在根目录下的app_code找cs类名,都找不到就报错未能创建类。

    转载于:https://www.cnblogs.com/cb168/p/5372144.html

    展开全文
  • iis + zendframework

    2011-08-25 18:09:39
    ZendFramework的控制器可以被设置支持使用clean urls,这点在apache下很好写,前提是apache支持mod_rewrite模块,然后通过设置.htaccess可以对ZendFramework单独控制.但是在IIS写如何设置呢?  问题很简单,通过...
  • 一、建立网站时设置.net框架版本:   二、对于已经添加的应用程序设置.net框架版本   三、更改IIS 默认.net框架版本
  • 部署版本IIS 7.5+.Net Framework 4.5 登录window 2008系统,打开服务器管理器; 先安装IIS。 添加角色;下一步; 勾选“Web服务器(IIS)”,下一步 下一步; 因为是需要匹配.net框架的,增加勾选应用程序...
  • 由于win10不在支持通过命令的方式自动注册.net framework 4.0,我们只能通过命令来注册: 控制面板 - 程序和功能 - 启动或关闭windows功能 - Internet Information services - 万维网服务 - 应用程序开发功能 勾选:...
  • Windows2003 + IIS6 安装.Net FrameWork 4.0 兼容早期版本的测试    看到文档说.net4的框架可以向下兼容2.0、3.0、3.5这几个版本,觉得是一件好事,以后服务器上就不用费时费力的安装 2.0、3.5之类的...
  • 可能使用了VS2012吧,framework版本比较高,出的错以前都没见过。这里把详细过程写出来方便大众,也给自己留个备份,所以才定了是怀旧篇。毕竟大家都说我很笨。 第一步、安装IIS 1,打开控制面板-程序-打开或关闭...
  • IIS6+Framework4.0上部署Silverlight4+WCF应用程序 特殊用途
  • IIS7是站点需要 服务器管理器 角色 添加角色 选择IIS .NET FrameWork 3.5 SP是安装SqlServer 2008R2 需要 服务器管理器 添加功能
  • 这篇文章主要介绍了win2012中让IIS同时支持版本ASP.NET 3.5/4.0/4.5的方法,需要的朋友可以参考下 Windows 2012系统天然就支持ASP.NET 4.5框架,就像Windows 2008系统默认支持ASP.NET 3.5一样。我们也可以在2012...
  • IIS7.0下部署.Net Framework 1.1项目

    千次阅读 2018-03-28 14:22:03
    开始以为不支持了,但是网上找了下资料东拼西凑完成了,记录下,以防忘记下次再找。 1、安装.NET Framework 1.1和.NET Framework 1.1 SP1 分别到以下微软官方站点下载并依次安装它们(一定要依次安装): 1).NET ...
  • net framework 并安装,下载时注意版本,并不一定高版本就完全兼容低版本, 2。安装了但是没有注册到IIS中,开始-》运行-》cmd-》 C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i 您可能...
  • 需要把.Net Framework版本为4.5的项目部署到windows 2003 sp2服务器上,但是2003的iis6.0支持最大的.Net Framework版本为4.0,如何在不降项目版本或升级服务器系统的情况下,将项目部署运行起来?
  • IIS 支持 php jsp

    2018-06-01 15:51:30
    https://neosmart.net/blog/2006/configuring-jsp-for-iis/iis支持aspC:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_regiis -i -enable
  • IIS 和Windows 版本历史

    2019-11-30 20:19:47
    IIS 1.0最初是作为Windows NT 3.51的免费附件发布的。 Windows NT 4.0附带了IIS 2.0。 Windows NT 4.0 Service Pack 2 附带的IIS 3.0 引入了Active Server Pages动态脚本环境。[5] IIS 4.0作为Windows NT 4.0的...
  • 刚刚接触windows server 2008, iis7也才装上, 我的asp.net应用程序是.net3.5版本的,但是在设置iis7的时候,其应用程序池只能选择“.net framework 2.0”或者“无托管代码”,但是我又确实安装好了.net framework ...
  • 故障说明:1)Windows Server 2008 R2环境下安装的IIS7.52)安装... 代码如下:”%WINDIR%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe” -iru -enable四、这个时候,我们看到,IIS中,4.0运行库支持注册成
  • IIS支持APS.Net

    千次阅读 2009-06-30 09:57:00
     在XP上安装过IIS5.1以后,可以运行asp,但是却不能运行aspx文件。此时要安装.Net Framework。.Net FrameworkSDK 可以从微软的官方网站下载。安装完毕后,运行下面的命令: C:/WINDOWS/Microsoft.NET/Fram
  • 运行Zend Framework + IIS7.5组合需要添加IIS组件支持URL Rewriting。   1、Zend Framework http://www.zendframework.com/download/latest; 2、URL Rewrite Module http://www.iis.net/expand/URLRewrite; ...
  • 一、打开Internet 信息服务...二、安装好:dotNetFx40_Full_x86_x64.exe三、应用程序池,选中c_data ,高级设置, .NET Framework 版本改为 v4.0 ,托管管道模式改为“经典”。四、点击网站的父项,右边, ASP.NE...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 24,470
精华内容 9,788
关键字:

iis支持framework版本