精华内容
下载资源
问答
  • 华为pppoe拨号配置

    千次阅读 2019-04-28 15:25:01
    server配置: [hw-server]ip pool pppoe //建立地址pool池 [hw-server-ip-pool-pppoe]network 112.1.1.0 mask 24 //定义地址池范围 [hw-server-ip-pool-pppoe]gateway-list 112.1.1.1 ...

                               

    server配置:

    [hw-server]ip pool pppoe      //建立地址pool池

    [hw-server-ip-pool-pppoe]network 112.1.1.0 mask 24      //定义地址池范围

    [hw-server-ip-pool-pppoe]gateway-list 112.1.1.1          //网关地址=pppoe server 地址

    当前pool的配置:

    [hw-server-ip-pool-pppoe]display this 
    [V200R003C00]
    #
    ip pool pppoe
     gateway-list 112.1.1.1 
     network 112.1.1.0 mask 255.255.255.0 
    #
    return
    [hw-server-ip-pool-pppoe]

    [hw-server-aaa]local-user pppoe password cipher pppoe    //创建用于pppoe-client拨入的账号密码

    [hw-server-aaa]local-user pppoe service-type ppp    //设置用于pppoe-client拨号的服务类型

    [hw-server]interface Virtual-Template 100                 //创建虚拟接口模板

    [hw-server-Virtual-Template100]ppp authentication-mode chap    //定义pppoe-client的ppp的验证方式

    [hw-server-Virtual-Template100]remote address pool pppoe        //定义为pppoe-client分配的地址池

    [hw-server-Virtual-Template100]ip address 112.1.1.1 24       //添加虚拟接口地址(等于pool网关地址)

    [hw-server]interface GigabitEthernet 0/0/0                        //进入接口

    [hw-server-GigabitEthernet0/0/0]pppoe-server bind virtual-template 100   //将虚拟接口模板绑定到物理接口(与Virtual-Template 100  一致)

    client配置:

    [hw-client]dialer-rule                     //创建拨号访问规则

    [hw-client-dialer-rule]dialer-rule 10 ip permit     //定义用于触发pppoe会话建立的流量类型,一般是ip

    [hw-client]interface Dialer 0     //创建拨号接口模板

    [hw-client-Dialer0]link-protocol ppp    //定义链路层协议类型

    [hw-client-Dialer0]ppp chap user pppoe   //配置用于chap验证的用户名

    [hw-client-Dialer0]ppp chap password cipher pppoe   //配置用于chap验证的密码

    [hw-client-Dialer0]ip address ppp-negotiate   //定义地址获取方式

    [hw-client-Dialer0]dialer user pppoe    //改命令必须配置,否则不能配置后续命令(用户名任意)

    [hw-client-Dialer0]dialer bundle 1  //定义拨号接口捆绑编号,用于绑定到物理接口

    [hw-client-Dialer0]dialer-group 10  //定义拨号访问规则 (匹配dialer-rule)

    [hw-client-Dialer0]mtu 1400   //设置mtu

    当前接口配置如下:

    [hw-client-Dialer0]display this 
    [V200R003C00]
    #
    interface Dialer0
     link-protocol ppp
     ppp chap user pppoe
     ppp chap password cipher %$%$|`6AGem[=V0~{O-{~S[;,&V)%$%$
     mtu 1400
     ip address ppp-negotiate
     dialer user pppoe
     dialer bundle 1
     dialer-group 10
    #
    return
    [hw-client-Dialer0]

    [hw-client]interface GigabitEthernet 0/0/0   //进入接口模式下

    [hw-client-GigabitEthernet0/0/0]pppoe-client dial-bundle-number 1   //将拨号接口绑定到物理接口(与dialer bundle 1 一致)

    当前接口配置信息:

    [hw-client-GigabitEthernet0/0/0]display this 
    [V200R003C00]
    #
    interface GigabitEthernet0/0/0
     pppoe-client dial-bundle-number 1 
    #
    return
    [hw-client-GigabitEthernet0/0/0]

    验证是否配置成功:

    [hw-client]display interface Dialer 0
    Dialer0 current state : UP                               //接口是UP 说明已经启动
    Line protocol current state : UP (spoofing)
    Description:HUAWEI, AR Series, Dialer0 Interface
    Route Port,The Maximum Transmit Unit is 1400, Hold timer is 10(sec)
    Internet Address is negotiated, 112.1.1.254/32   //有地址说明已经配置成功
    Link layer protocol is PPP
    LCP initial
    Physical is Dialer
    Current system time: 2019-04-28 15:17:03-08:00
        Last 300 seconds input rate 0 bits/sec, 0 packets/sec
        Last 300 seconds output rate 0 bits/sec, 0 packets/sec
        Realtime 0 seconds input rate 0 bits/sec, 0 packets/sec
        Realtime 0 seconds output rate 0 bits/sec, 0 packets/sec
        Input: 0 bytes
        Output:0 bytes
        Input bandwidth utilization  :    0%
        Output bandwidth utilization :    0%
    Bound to Dialer0:0:
    Dialer0:0 current state : UP ,
    Line protocol current state : UP

    Link layer protocol is PPP
    LCP opened, IPCP opened
    Packets statistics:
      Input packets:0,  0 bytes
      Output packets:0, 0 bytes
      FCS error packets:0
      Address error packets:0
      Control field control error packets:0


    [hw-client]

     

    查看接口信息:

    [hw-client]display ip interface brief 
    *down: administratively down
    ^down: standby
    (l): loopback
    (s): spoofing
    The number of interface that is UP in Physical is 4
    The number of interface that is DOWN in Physical is 2
    The number of interface that is UP in Protocol is 3
    The number of interface that is DOWN in Protocol is 3

    Interface                         IP Address/Mask      Physical   Protocol  
    Dialer0                           112.1.1.254/32       up         up(s)     
    GigabitEthernet0/0/0              unassigned           up         down      
    GigabitEthernet0/0/1              unassigned           down       down      
    NULL0                             unassigned           up         up(s)     
    Serial1/0/0                       unassigned           up         up        
    Serial1/0/1                       unassigned           down       down      
    [hw-client]

     

     

     

     

     

     

     

     

    展开全文
  • 华为防火墙的PPPOE拨号配置。挺实用的
  • 1、在华为路由器上PPPOE服务器的配置 2、在华为路由器上PPPOE 客户端的配置(工作上常用) 3、配置NAT(上网使用) 4、默认路由配置 拓扑图 1、在华为路由器上PPPOE服务器的配置 (1)地址池配置 [HW-Server]ip...

    掌握目标

    1、在华为路由器上PPPOE服务器的配置
    2、在华为路由器上PPPOE 客户端的配置(工作上常用)
    3、配置NAT(上网使用)
    4、默认路由配置

    拓扑图

    pppoe

    1、在华为路由器上PPPOE服务器的配置

    (1)地址池配置
    [HW-Server]ip pool pppoe
    [HW-Server-ip-pool-pppoe]network 123.1.1.0 mask 24
    [HW-Server-ip-pool-pppoe]dns-list 114.114.114.114

    (2)配置虚拟模板
    [HW-Server]int e0/0/0
    [HW-Server-Ethernet0/0/0]ip address 123.1.1.1 24

    [HW-Server]interface Virtual-Templa 1
    [HW-Server-Virtual-Template1]ip address unnumbered interface e0/0/0
    [HW-Server-Virtual-Template1]remote address pool pppoe
    说明:这里是调用了出接口的地址,也可以手工配置,另外调用全局定义的地址池

    (3)接口调用
    [HW-Server]interface e0/0/0
    [HW-Server-Ethernet0/0/0]pppoe-server bind virtual-template 1

    (4)用户名定义
    [HW-Server]aaa
    [HW-Server-aaa]local-user ccieh3c password cipher ccieh3c.taobao.com
    [HW-Server-aaa]local-user ccieh3c service-type ppp

    2、在华为路由器上PPPOE 客户端的配置(工作上常用)

    客户端的配置在企业的环境中是最常见遇到的,掌握是非常有必要。
    (1)定义拨号规则
    [HW-Client]dialer-rule
    [HW-Client-dialer-rule]dialer-rule 1 ip permit
    说明:这里就是定义的拨号规则,允许所有的IPV4流量通过。

    (2)拨号接口
    [HW-Client]interface Dialer 1
    [HW-Client-Dialer1]dialer user ccieh3c
    [HW-Client-Dialer1]dialer-group 1 (这里是关联的拨号接口)
    [HW-Client-Dialer1]dialer bundle 1 (这里是定义一个bundle,后面在接口调用)
    [HW-Client-Dialer1]ppp chap user ccieh3c
    [HW-Client-Dialer1]ppp chap password simple ccieh3c.taobao.com
    [HW-Client-Dialer1]ip address ppp-negotiate

    (3)接口下调用
    [HW-Client]interface e0/0/0
    [HW-Client-Ethernet0/0/0]HW-Client dial-bundle-number 1

    (4)验证结果

    pppoe

    可以看到接口已经UP了,说明PPP的协商已经成功

    pppoe

    地址也已经成功获取。

    3、配置NAT(上网使用)+4、默认路由配置

    对于在工作上面还会用到的就是NAT配置让内网能够访问internet了。
    (1)默认路由配置
    [HW-Client]ip route-static 0.0.0.0 0 Dialer 1

    (2)NAT配置
    [HW-Client]acl number 2000
    [HW-Client-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
    [HW-Client]interface Dialer 1
    [HW-Client-Dialer1]nat outbound 2000
    说明:这里ACL的含义就是允许哪些网段可以上网,这里为192.168.1.0/24这个网段,然后调用在拨号接口下。

    优化部分

    对于PPPOE拨号经常容易遇到的一个问题,就是有时候打开一些网页会显示打不开,或者图片不显示的问题。这个的话可以通过把MTU与TCP的MSS修改下就可以了。
    建议的话,MTU在1492即可,因为PPPOE会多出8字节的头部,而MSS在1200~1452之间。

    [HW-Client]interface Dialer 1
    [HW-Client-Dialer1]mtu 1492
    [HW-Client-Dialer1]tcp adjust-mss 1452

    如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路Blog(其他平台同名),版权归网络之路Blog所有,原创不易,侵权必究,觉得有帮助的,关注、转发、点赞支持下!~。

    展开全文
  • 1、在华为USG上PPPOE服务器的配置 2、在华为USG上PPPOE 客户端的配置(工作上常用) 3、配置NAT(上网使用) 4、默认路由+策略配置 拓扑 1、在华为USG上PPPOE服务器的配置 (1)用户配置与地址池 [USG-Server]...

    掌握目标

    1、在华为USG上PPPOE服务器的配置
    2、在华为USG上PPPOE 客户端的配置(工作上常用)
    3、配置NAT(上网使用)
    4、默认路由+策略配置

    拓扑

    pppoe

    1、在华为USG上PPPOE服务器的配置

    (1)用户配置与地址池
    [USG-Server]aaa
    [USG-Server-aaa]local-user test password cipher ccieh3c.com
    [USG-Server-aaa]local-user test service-type ppp
    [USG-Server-aaa]ip pool 1 123.1.1.2 123.1.1.254

    (2)虚拟模板接口
    [USG-Server]interface g0/0/0
    [USG-Server-GigabitEthernet0/0/0]ip address 123.1.1.1 24

    [USG-Server]interface Virtual-Template 1
    [USG-Server-Virtual-Template1]ppp authentication-mode chap
    [USG-Server-Virtual-Template1]ip address unnumbered interface g0/0/0
    [USG-Server-Virtual-Template1]remote address pool 1

    [USG-Server]interface g0/0/0
    [USG-Server-GigabitEthernet0/0/0]USG-Server bind virtual-template 1

    说明:G0/0/0接口已经加入对应的Zone了,否则需要加入后才能正常工作。

    2、在华为USG上PPPOE 客户端的配置(工作上常用)

    (1)拨号规则定义
    [USG-Client]dialer-rule 1 ip permit

    (2)拨号接口配置
    [USG-Client]interface Dialer 1
    [USG-Client-Dialer1]dialer user test (用该帐号拨号)
    [USG-Client-Dialer1]dialer-group 1 (对应规则1)
    [USG-Client-Dialer1]dialer bundle 1 (后续bundle调用在接口)
    [USG-Client-Dialer1]ip address ppp-negotiate
    [USG-Client-Dialer1]ppp chap user test
    [USG-Client-Dialer1]ppp chap password cipher ccieh3c.com

    (3)物理接口调用
    [USG-Client]interface GigabitEthernet 0/0/0
    [USG-Client-GigabitEthernet0/0/0]USG-Client dial-bundle-number 1

    (4)注意事项
    有的版本需要把拨号接口加入到对应的zone,有的版本则不需要,所以如果看到拨号一直没有成功,可以把拨号接口加入到Zone。
    [USG-Client]firewall zone untrust
    [USG-Client-zone-untrust]add interface Dialer 1

    3、配置NAT(上网使用)

    [USG-Client]nat-policy interzone trust untrust outbound
    [USG-Client-nat-policy-interzone-trust-untrust-outbound]policy 0
    [USG-Client-nat-policy-interzone-trust-untrust-outbound-0]policy source 192.168.1.0 mask 24
    [USG-Client-nat-policy-interzone-trust-untrust-outbound-0]action source-nat
    [USG-Client-nat-policy-interzone-trust-untrust-outbound-0]easy-ip Dialer 1
    说明:这里NAT规定了从192.168.1.0/24网段来的流量进行源NAT转换,使用的是拨号接口的公网地址。

    4、默认路由+策略配置

    默认路由是为了访问internet用的,如果内网跨网段了,也需要写回程路由,而策略的话,对于型号不一样,默认策略也不一样,有的是全部允许放行了,有得没有默认策略,都是deny的,需要自己放行。
    [USG-Client]ip route-static 0.0.0.0 0 Dialer 1

    [USG-Client]policy interzone trust untrust outbound
    [USG-Client-policy-interzone-trust-untrust-outbound]policy 0
    [USG-Client-policy-interzone-trust-untrust-outbound-0]action permit
    说明:这里是允许了全部的内网网段能主动访问外网。

    容易遇到的问题

    (1)一些网站或者应用打开慢以及打不开的情况,这个很有可能是MTU与TCP MSS导致,可以多尝试几个值来达到比较理想的效果。
    [USG-Dialer0]mtu 1400
    [USG]firewall tcp-mss 1200
    (2)一些小企业或者SOHO级别的网络可能申请的是民用的拨号线路,那这个时候有可能自己用电脑先拨入测试效果,然后发现在路由器上面怎么都拨入不了,那很有可能是运营商那边绑定了,需要打电话过去松绑。
    (3)ADSL有可能采用私网地址分配,所以在申请的时候需要考虑是否需要做映射服务出去或者一些VPN拨入,在申请的时候需要跟对方说明清楚。(包括80端口是否可以用)

    如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路Blog(其他平台同名),版权归网络之路Blog所有,原创不易,侵权必究,觉得有帮助的,关注、转发、点赞支持下!~。

    展开全文
  • 华为PPPoe拨号上网实验

    千次阅读 2018-06-16 21:53:07
    华为配置pppoe #sysname Server //配置设备名字#aaa authentication-scheme default authorization-scheme default accounting-scheme default domain default domain default_admin local-user admin ...
    华为配置pppoe
     


    #
    sysname Server //配置设备名字
    #
    aaa 
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default 
     domain default_admin 
     local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
     local-user admin service-type http
     local-user xiaoming password cipher xiaoming //配置PPPOE客户的用户名和密码
     local-user xiaoming service-type ppp //配置用户的接入类型为PPP
    #
    interface Virtual-Template0 //进入虚模板接口
     ppp authentication-mode chap //配置ppp认证的类型为chap
     remote address 100.0.0.2 //配置客户的地址
     ip address 100.0.0.1 255.255.255.255 //配置本接口的地址
    #
    interface GigabitEthernet0/0/0
     pppoe-server bind Virtual-Template 0 //将虚模板和接口关联在一起
    #




    PPPOE client 
     
    #
     sysname client
    #
    interface Dialer0 //进入拨号口
     link-protocol ppp //配置链路配置为ppp
     ppp ipcp default-route //通过IPCP自动获取默认路由
     ppp chap user xiaoming //配置ppp用户名
     ppp chap password cipher xiaoming //配置ppp密码
     ip address ppp-negotiate //地址为自动协商
     dialer user xiaoming //配置为共享拨号中心
     dialer bundle 1 //配置拨号捆绑接口为1
    #
    interface GigabitEthernet0/0/0
     pppoe-client dial-bundle-number 1 //通过拨号捆绑接口1关联本接口
    #




    测试
     
    已经获取到IP地址。


     


    获取到默认路由





    欢迎加入QQ群:792810619

    展开全文
  • 华为配置PPPOE拨号

    千次阅读 2015-01-07 09:45:33
    dialer-rule  dialer-rule 10 ip permit ... pppoe-client dial-bundle-number 2 on-demand   ip address 10.10.10.20 255.255.255.0  ip route-static 0.0.0.0 0.0.0.0 dialer 1
  • 华为路由器pppoe拨号

    2018-08-05 14:20:00
     模拟pppoe 拨号 , 软件 ensp , 简单拓扑:   二、配置  1.基本环境配置  pc1    AR1  int gi 0/0/0 ip add 192.168.10.254 24  2.开始 ppp 配置  AR2 :  1.设置地址池,用于拨号  2....
  • 华为AR1220-S 配置PPPOE拨号上网 dis cur [V200R002C01SPC200] # sysname lvxinghao # snmp-agent local-en...
  • 基本上都是使用WEB方式进行管理配置的,本文介绍如何使用命令方式来配置拨号上网,通过基本上实际使用中我们只要配置客户端的即可,但是我们也需要知道服务端配置也是需要知道的,有助于我们理解PPPoE。(一)配置...
  • 教程名称:网管必备之企业常见的PPPOE拨号课程目录:【】PPPOE拨号之一:Cisco路由器PPPOE拨号配置【】PPPOE拨号之七:华为防火墙 USG PPPoE拨号配置【】PPPOE拨号之三:H3C路由器PPPoE典型配置【】PPPOE拨号之二:...
  • 【JAVA、C&plus;&plus;】LeetCode 007 Reverse IntegerReverse digits of an integer. Example1: x = 123, return 321 Example2: x = -123, return -321 解题思路:将数字 ...java细节,细的你想象不到一....
  •    
  • 由于这个时代对网络的依赖,多条宽带的接入变得很平常,本文讲述某企业申请了两条电信光纤,一条是固定IP的城域网,另一条则是PPPOE拨号的普通宽带,前者用于服务器和硬盘录像机,后者用来办公上网。接入设备是华为...
  • # //创建dialer-rule 1 dialer-rule 1 ip permit ...//配置进行NAT的ACL acl number 2000 rule 0 permit source 192.168.1.0 0.0.0.255 # //创建dialer 1 interface Dialer1 ...
  • 配置ISP的两台设备使之能够提供PPPOE拨号与专线服务 ISP的PPPOE采用动态地址池向公司提供专线服务 ISP的专线通过PPP的链路绑定向公司提供专线服务,并通过地址协商向公司分配固定地址 ISP的PPPOE采用PAP认证,...
  • 华为PPPoE简单实验

    千次阅读 2018-03-31 22:32:06
    一、PPPoE协议是基于C/S架构的一种...本次实验的目标:掌握PPPoE拨号技术; 实验拓扑: 1、基本的IP配置如图所示; 2、配置虚拟模板用来承载多种同层协议: [pppoe-server]interface Virtual-Template1 //创...
  • 那么华为USG通过PPPoE拨号接入互联网是如何配置的呢?今天通过一个案例来介绍一下USG通过PPPoE接入Internet。PPPoE接入Internet拓扑图组网需求如上图所示,FW1作为出口网关,为局域网内PC提供接入Internet出口。公司...
  • SecPath防火墙PPPoE Server典型配置 一、 组网需求: ...PC通过PPPOE拨号上网,公司内部WEB服务器、邮件服务器和FTP服务器需要映射到公网。 二、 组网图 0 && p_w_picpath.height>0){if...
  • 用一台路由器作为PPPoE服务器,局域网中的一台主机使用PPPoE拨号通过路由器连接到因特网。 PPPoE服务器为主机动态分配IP地址和 DNS服务器,且PPPoE服务器通过AAA本地认证 来 验证局域网中的主机用户。 实验拓扑: ...
  • 引子:家里的电信无线路由器连接之后无法直接上上网,只能再次通过PPPoe方式拨号上网。经过网上查询和一番折腾之后,整理攻略如下。 1. 用超级用户登录192.168.1.1(默认密码) 用户名:telecomadmin 密码...
  • 2.2.2 配置PPPoE拨号上网 .............................................. 16 2.3 IP+MAC绑定防止内网非法用户接入 ........................................ 17 2.4 配置DHCP服务器 ...............................
  • 本课程全面、系统、深入地介绍了华为AR G3系列路由器所支持主要拨号WAN接入方式技术原理和配置与管理方法,包括DCC、3G Cellular、4G LTE Cellular、PPP、MP、PPPoE、ADSL、VDSL、G.SHDSL等常用的一些WAN接入方式。...
  • MAT5680 华为OLT

    2019-03-26 12:03:04
    华为MAT5680 OLT上自动配置onu注册,pppoe拨号使用的脚本。脚本通过Python语言实现,在SecureCRT上直接运行即可,运行路径为:MAT5680(config)#路径下,出错的话,需要自行进行更改。
  • 需要符合如下要求:1....2.指定接口后实现内网的隔离/互联互通操作环境:路由:AR1220E-S 软件版本V200R007C00SPCc00Dialer1 电信PPPoE拨号Dialer2 联通PPPoE拨号GE0/0/6 内网接口内网网段:192.168.100.1/24 1...
  • 需要符合如下要求:1....2.指定接口后实现内网的隔离/互联互通操作环境:路由:AR1220E-S 软件版本V200R007C00SPCc00Dialer1 电信PPPoE拨号Dialer2 联通PPPoE拨号GE0/0/6 内网接口内网网段:192.168.100.1/2...
  • 本课程全面、系统、深入地介绍了华为AR G3系列路由器所支持主要拨号WAN接入方式技术原理和配置与管理方法,包括DCC、3G Cellular、4G LTE Cellular、PPP、MP、PPPoE、ADSL、VDSL、G.SHDSL等常用的一些WAN接入方式。...
  • 华为ME60常见的业务配置指导和一些电信业务场景下的配置、故障等说明 IPv4/v6双栈 PPPOE拨号 IPOE接入 哑终端接入
  • 需要符合如下要求:1....2.指定接口后实现内网的隔离/互联互通操作环境:路由:AR1220E-S 软件版本V200R007C00SPCc00Dialer1 电信PPPoE拨号Dialer2 联通PPPoE拨号GE0/0/6 内网接口内网网段:192.168.100.1/2...
  • 1)Modem采用内置PPPOE拨号模式;局域网采用私网地址,地址分配可以采用静态配置或者DHCP动态分配的方法。2)我推荐采用静态分配的方式(如上图)设置本机IP地址为192.168.1.*(*范围2-224)网关 DNS 都一定要设置....

空空如也

空空如也

1 2
收藏数 38
精华内容 15
关键字:

华为pppoe拨号配置