精华内容
下载资源
问答
  • 实验:华为MUX VLAN配置与管理

    万次阅读 多人点赞 2014-09-19 08:47:35
    华为的MUX VLAN功能既可以实现位于同一IP网段的不同VLAN间(所有从VLAN与主VLAN间)用户的二层互通,又可实现不同从VLAN间的二层隔离,以及同一交换机上同一VLAN内部用户之间的二层隔离,不同交换机上同一VLAN中的...

    以下实验摘自笔者为《华为交换机学习指南》设计的一个实验型视频教学课程,点击这里查看详情:http://edu.51cto.com/course/course_id-2091.html

    华为的MUX VLAN功能既可以实现位于同一IP网段的不同VLAN间(所有从VLAN与主VLAN间)用户的二层互通,又可实现不同从VLAN间的二层隔离,以及同一交换机上同一VLAN内部用户之间的二层隔离,不同交换机上同一VLAN中的用户不隔离。通过这一技术可以实现在多VLAN用户服务器共享的同时,隔离相同VLAN中的不同用户主机的目的

    下面是一个具体的实验方案


    实验环境:PC1~6,以及Server都在同一IP网段,并按图所示划分到对应的主,或者相应类型的从VLAN中

    实验要求:各从VLAN主机都可以直接访问Server,但各从VLAN间不能直接访问,隔离VLAN20中的PC2PC3不能互访,但它们都可以与同处VLAN20PC5互访

    实验配置:

    SW1上的配置

    <Huawei>sys

    [Huawei]sysname SW1

    [SW1]vlanbatch 10 2030 40

    [SW1]vlan40

    [SW1-VLAN40]mux-vlan

    [SW1-VLAN40]subordinategroup10 30

    [SW1-VLAN40]subordinateseparate20

    [SW1-VLAN40]quit

    [SW1]interface GigabitEthernet0/0/1

    [SW1-GigabitEthernet0/0/1]port link-typetrunk

    [SW1-GigabitEthernet0/0/1]porttrunk allow-pass vlan 10 2030 40

    [SW1-GigabitEthernet0/0/1]quit

    [SW1]interface GigabitEthernet0/0/2

    [SW1-GigabitEthernet0/0/2]port link-typetrunk

    [SW1-GigabitEthernet0/0/2]port trunkallow-pass vlan 10 2030 40

    [SW1-GigabitEthernet0/0/2]quit

    [SW1]interface GigabitEthernet0/0/3

    [SW1-GigabitEthernet0/0/3]port link-typeaccess

    [SW1-GigabitEthernet0/0/3]portdefault vlan 40

    [SW1-GigabitEthernet0/0/3]port mux-vlanenable

    [SW1-GigabitEthernet0/0/3]quit

    SW2 的配置

    <Huawei>sys

    [Huawei]sysname SW2

    [SW2]vlanbatch 10 20 30 40

    [SW2]vlan 40

    [SW2-VLAN40]mux-vlan

    [SW2-VLAN40]subordinate group 10 30

    [SW2-VLAN40]subordinate separate 20

    [SW2-VLAN40]quit

    [SW2]interface Ethernet0/0/1

    [SW2-Ethernet0/0/1]port link-type trunk

    [SW2-Ethernet0/0/1]port trunk allow-pass vlan 10 20 30 40

    [SW2-Ethernet0/0/1]quit

    [SW2]interface Ethernet0/0/2

    [SW2-Ethernet0/0/2]port link-type access

    [SW2-Ethernet0/0/2]port default vlan 10

    [SW2-Ethernet0/0/2]port mux-vlanenable

    [SW2-Ethernet0/0/2]quit

    [SW2]interface Ethernet0/0/3

    SW3 的配置

    <Huawei>sys

    [Huawei]sysname SW3

    [SW3]vlanbatch 10 20 40

    [SW3]vlan 40

    [SW3-VLAN40]mux-vlan

    [SW3-VLAN40]subordinate group 10

    [SW3-VLAN40]subordinate separate 20

    [SW3-VLAN40]quit

    [SW3]interface Ethernet0/0/1

    [SW3-Ethernet0/0/1]port link-type trunk

    [SW3-Ethernet0/0/1]port trunk allow-pass vlan10 20 40

    [SW3-Ethernet0/0/1]quit

    [SW3]interface Ethernet0/0/2

    [SW3-Ethernet0/0/2]port link-type access

    [SW3-Ethernet0/0/2]port default vlan 10

    [SW3-Ethernet0/0/2]port mux-vlanenable

    [SW3-Ethernet0/0/2]quit

    [SW3]interface Ethernet0/0/3

    [SW3-Ethernet0/0/3]port link-type access

    [SW3-Ethernet0/0/3]port default vlan20

    [SW3-Ethernet0/0/3]port mux-vlanenable

    [SW3-GigabitEthernet0/0/3]quit


    实验结果验证:

    display mux-vlan命令查看MUX VLAN配置信息


    各从VLAN中的PC机均能ping通位于主VLAN中的Server



    不同从VLAN间不能ping


    同一交换机上同一隔离VLAN中的主机不能ping


    不同交换机上同一隔离VLAN中的主机仍可以Ping



    展开全文
  • 华为交换机vlan配置教程

    万次阅读 多人点赞 2018-07-24 15:56:14
    Sys \\进入系统视图 ...Vlan bacth 2 3 4 \\批量创建vlan 2 3 4 Int vlanif 2 \\进入vlan 2 Ip add 192.168.xxx.1 255.255.255.0 \\为vlan2分配IP地址及子网掩码 Dhcp select global \\dhcp选择全局开启 Q \...

    Sys   \\进入系统视图

    Dhcp enable  \\全局开启dhcp功能

    Vlan bacth 2 3 4  \\批量创建vlan 2 3 4

    Int vlanif 2  \\进入vlan 2

    Ip add 192.168.xxx.1  255.255.255.0  \\为vlan2分配IP地址及子网掩码

    Dhcp select global \\dhcp选择全局开启

    Q  \\退出

    Dhcp enable  \\全局开启dhcp功能

    Ip pool vlan2  \\进入vlan2的ip地址池

    Gateway-list 192.168.xxx.1  \\vlan2的网关地址

    Network 192.168.xxx.0 mask 255.255.255.0  \\vlan2下网络地址以及子网掩码

    Dns-list 114.114.114.114 8.8.8.8  \\Dns地址

    Q  \\退出

    Port-group1  \\创建端口组1

    Group-member gigabitethernet 0/0/1 to gigabitethernet 0/0/2  \\将交换机端口1和2加入端口组1

    Port link-type access  \\端口链路类型访问

    Port default vlan 2 \\将端口组加入vlan2

    展开全文
  • 华为MUX VLAN原理和实验

    千次阅读 2020-12-12 20:38:25
    对不同用户进行网络隔离,如果都使用VLAN的方式进行隔离,可能会因为VLAN的数量多少受到限制(华为交换机默认4094个),并且VLAN越多,管理会越复杂 使用MUX VLAN,可以实现网络隔离,节约VLAN,并且有足够的灵活性...

    MUX VLAN产生目的:
    对不同用户进行网络隔离,如果都使用VLAN的方式进行隔离,可能会因为VLAN的数量多少受到限制(华为交换机默认4094个),并且VLAN越多,管理会越复杂。

    使用MUX VLAN,可以实现网络隔离,节约VLAN,并且有足够的灵活性。

    技术原理:
    MUX VLAN也包括了两个类型的vlan,也就是主vlan和从vlan,跟VLAN聚合的规划有些相似,但是从vlan又划分为两种类型(隔离型从vlan和互通型从vlan)。
    其中主端口可以和MUX VLAN内的所有端口进行通信;隔离型从vlan,vlan中的设备无法互访通信,而互通型从vlan,vlan中的设备可以互相通信;需要注意的是,不同vlan之间,就算都是互通型vlan(如果是跨设备的互通型从vlan,可以通信),是无法通信的。
    在这里插入图片描述

    实验:
    在这里插入图片描述
    拓扑规划:
    vlan2是隔离型从vlan,主vlan是vlan4,vlan3是互通型从vlan。配置完成后,保证vlan2和vlan3间无法进行通信,但是它们互相可以和主vlan4进行通信。另外隔离型从vlan2之中PC1和PC4不能互相通信,互通型vlan3中设备PC2和PC3可以通信。

    实验配置:
    SW1:
    vlan batch 2 to 4 //创建需要用到的vlan2,3,4
    vlan 4 //进入vlan4的视图下
    mux-vlan //将vlan4规划为主vlan
    subordinate separate 2 //配置vlan2是其隔离型从vlan
    subordinate group 3 //配置vlan3是其互通型从vlan
    interface GigabitEthernet0/0/1 //进入与交换机相连的接口
    port link-type trunk //和聚合vlan相似,与交换机相连的接口为trunk,只不过允许的是所有的vlan通过
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/2
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/3 //进入与终端(服务器)相连的vlan
    port link-type access //端口必须设置为Access类型或者Hybrid Untagged类型,并且端口只能允许一个vlan通过,否则无法正常使能
    port default vlan 4 //只允许vlan4通过
    port mux-vlan enable //只有允许一个vlan通过的接口才能开启MUX VLAN功能

    SW2:
    vlan batch 2 to 4
    vlan 4
    mux-vlan
    subordinate separate 2
    subordinate group 3
    interface Ethernet0/0/1 //进入与交换机相连的接口
    port link-type trunk //设置接口类型为trunk并允许所有vlan通过
    port trunk allow-pass vlan 2 to 4094
    interface Ethernet0/0/2//进入与PC相连的接口
    port link-type access //注意必须配置为只允许一个vlan通过的接口
    port default vlan 3 //将这个接口下的主机划入相应的从vlan3
    port mux-vlan enable //在接口上开启相应的mux vlan功能
    interface Ethernet0/0/3
    port link-type access
    port default vlan 3
    port mux-vlan enable

    SW3:
    vlan batch 2 to 4
    vlan 4
    mux-vlan
    subordinate separate 2
    subordinate group 3
    interface Ethernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface Ethernet0/0/2
    port link-type access
    port default vlan 2
    port mux-vlan enable
    interface Ethernet0/0/3
    port link-type access
    port default vlan 2
    port mux-vlan enable

    终端设备的ip地址规划:
    PC1:10.1.4.1/24 //注意,IP地址的规划,虽然VLAN的编号不同,但是必须配置在同一个子网区域内,这才满足MUX VLAN的规划
    PC2:10.1.4.2/24
    PC3:10.1.4.3/24
    PC4:10.1.4.4/24
    服务器:10.1.4.100/24

    查看现象:
    1.验证隔离型从vlan之间能否互相通信:
    PC1pingPC4:(不通,说明mux vlan起了相应作用)
    在这里插入图片描述
    2.再验证互通型从vlan之间能否互相通信:
    PC2pingPC3:(互通,符合相应的要求)
    在这里插入图片描述
    3.最后验证主vlan4能否ping通两个从vlan:
    Server Ping PC3:(互通,符合要求)
    在这里插入图片描述
    Server Ping PC4:(互通,符合要求)
    在这里插入图片描述
    MUX vlan和聚合vlan的比较:

    1. 大多都运用在企业中,但是实际运用的时候有差别,mux vlan通常是运用在有很多服务器,需要各个部门进行访问,但是各个部门又要进行隔离的情况下。而聚合vlan因为只能通过super vlan进行通信(无论是内部或者是外网),并且对于各个vlan的隔离性没有较大的要求,如果需要各个部门可以互访,直接开启arp代理即可,对于一些不互访的设备设置相应的ACL进行过滤,但是相对复杂。
    2. MUX隔离性更强,划分了互通型从vlan和隔离型从vlan,不仅仅能保证不同vlan可以相互隔离,也可以保证同一vlan可以相互隔离。

    模拟器:eNSP;有错误处请指出。

    展开全文
  • 华为vlan配置)

    2021-10-19 19:36:16
    vlan原理:vlan起到一个逻辑分割广播域的作用,相当于一个逻辑子网,一个独立的广播域。

    目录

    一.vlan介绍

    1.1vlan虚拟局域网

    二.vlan配置

     2.1LSW1配置

    2.2LSW2配置

    2.3测试连通性

    三.单臂路由配置

    3.1LSW1配置

    3.2AR1配置

    3.3测试连通性​


    一.vlan介绍

    1.1vlan虚拟局域网

    1.vlan原理:vlan起到一个逻辑分割广播域的作用,相当于一个逻辑子网,一个独立的广播域。

    2.vlan好处:1.逻辑上分割广播域,将广播域范围减小。
                         2.便于管理诊断故障点,缩小故障范围。
                         3.起到一个安全作用。

    二.vlan配置

     2.1LSW1配置

    <Huawei>undo terminal monito                                            ##关闭弹出信息##
    <Huawei>system-view                                                          ##进入系统视图##
    [Huawei]user-interface console 0                                          ##配置永不超时##
    [Huawei-ui-console0]idle-timeout 0  
    [Huawei-ui-console0]quit                                                        ##退回上一级##
    [Huawei]sysname SW1                                                          ##重命名为SW1##
    [SW1]vlan batch 10 20                                                           ##创建VLAN 10 20##
    [SW1]int e0/0/1                                                                       ##进入接口##
    [SW1-Ethernet0/0/1]port link-type access                              ##将接口配置为access##
    [SW1-Ethernet0/0/1]port default vlan 10                                ##将接口划分为VLAN 10##
    [SW1-Ethernet0/0/1]quit                                                         ##退回上一级##
    [SW1]int e0/0/2                                                                       ##进入接口##
    [SW1-Ethernet0/0/2]port link-type access                              ##将接口配置为access##
    [SW1-Ethernet0/0/2]port default vlan 20                                ##将接口划分为VLAN 20##
    [SW1-Ethernet0/0/2]quit                                                         ##退回上一级##
    [SW1]int g0/0/1                                                                       ##进入接口##
    [SW1-GigabitEthernet0/0/1]port link-type trunk                      ##将接口配置为trunk##
    [SW1-GigabitEthernet0/0/1port trunk allow-pass vlan 10 20  ##设置trunk允许VLAN 10 20 通过##

    2.2LSW2配置

    <Huawei>undo terminal monito                                            ##关闭弹出信息##
    <Huawei>system-view                                                          ##进入系统视图##
    [Huawei]user-interface console 0                                          ##配置永不超时##
    [Huawei-ui-console0]idle-timeout 0  
    [Huawei-ui-console0]quit                                                        ##退回上一级##
    [Huawei]sysname SW2                                                         ##重命名为SW2##
    [SW2]vlan batch 10 20                                                           ##创建VLAN 10 20##
    [SW2]int e0/0/1                                                                       ##进入接口##
    [SW2-Ethernet0/0/1]port link-type access                              ##将接口配置为access##
    [SW2-Ethernet0/0/1]port default vlan 10                                ##将接口划分为VLAN 10##
    [SW2-Ethernet0/0/1]quit                                                         ##退回上一级##
    [SW2]int e0/0/2                                                                       ##进入接口##
    [SW2-Ethernet0/0/2]port link-type access                              ##将接口配置为access##
    [SW2-Ethernet0/0/2]port default vlan 20                                ##将接口划分为VLAN 20##
    [SW2-Ethernet0/0/2]quit                                                         ##退回上一级##
    [SW2]int g0/0/1                                                                       ##进入接口##
    [SW2-GigabitEthernet0/0/1]port link-type trunk                      ##将接口配置为trunk##
    [SW2-GigabitEthernet0/0/1port trunk allow-pass vlan 10 20  ##设置trunk允许VLAN 10 20 通过##

    2.3测试连通性

     不同vlan不通,可以使用单臂路由配置实现vlan互通。

    三.单臂路由配置

    3.1LSW1配置

    <Huawei>undo terminal monito                                         ##关闭弹出信息##
    <Huawei>system-view                                                      ##进入系统视图##
    [Huawei]user-interface console 0                                      ##进入console配置模式##
    [Huawei-ui-console0]idle-timeout 0                                   ##配置永不超时##
    [Huawei-ui-console0]quit                                                   ##退回上一级##
    [Huawei]sysname SW1                                                     ##重命名为SW1##
    [SW1]vlan batch 10 20                                                      ##创建VLAN 10 20##
    [SW1]int e0/0/2                                                                 ##进入接口##
    [SW1-Ethernet0/0/2]port link-type access                        ##将接口配置为access##
    [SW1-Ethernet0/0/2]port default vlan 10                          ##将接口划分为VLAN 10##
    [SW1]int e0/0/3                                                                 ##进入接口##
    [SW1-Ethernet0/0/3]port link-type access                        ##将接口配置为access##
    [SW1-Ethernet0/0/3]port default vlan 20                          ##将接口划分为VLAN 20##
    [SW1]int e0/0/1                                                                ##进入接口##
    [SW1-Ethernet0/0/1]port link-type trunk                          ##将接口配置为trunk##
    [SW1-Ethernet0/0/1]port trunk allow-pass vlan 10 20     ##设置trunk允许VLAN 10 20 通过##

    3.2AR1配置

    <Huawei>undo terminal monito                                        ##关闭弹出信息##
    <Huawei>system-view                                                      ##进入系统视图##
    [Huawei]user-interface console 0                                     ##进入console配置模式##
    [Huawei-ui-console0]idle-timeout 0                                  ##配置永不超时##
    [Huawei-ui-console0]quit                                                  ##退回上一级##
    [Huawei]sysname R1                                                       ##重命名为R1##
    [R1]int g0/0/0.1                                                                 ##进入子接口##
    [R1-GigabitEthernet0/0/0.1]dot1q termination vid 10       ##封装协议##
    [R1-GigabitEthernet0/0/0.1]ip address 192.168.10.1 24  ##配置IP##
    [R1-GigabitEthernet0/0/0.1]arp broadcast enable            ##开启ARP广播##
    [R1]int g0/0/0.2                                                                 ##进入子接口##
    [R1-GigabitEthernet0/0/0.2]dot1q termination vid 20       ##封装协议##
    [R1-GigabitEthernet0/0/0.2]ip address 192.168.20.1 24  ##配置IP##
    [R1-GigabitEthernet0/0/0.2]arp broadcast enable            ##开启ARP广播##

    3.3测试连通性

     

    展开全文
  • 华为交换机管理VLAN——ip设置

    千次阅读 2008-03-14 21:44:25
    华为交换机在原设有管理VLAN的情况下,相变更管理vlan的ID时需做些改动。  例如原管理vlan是4094,需要改成4088则:  [HuaWei]undo mangement-vlan 删除mangement-vlan [HuaWei]int vlan-interface 4094 进入vlan ...
  • VLAN概述与优势 分割广播域 物理分割 逻辑分割 VLAN的优势 控制广播 增强网络安全性 简化网络管理
  • VLAN交换机的工作原理洪泛MAC地址表和CAM的区别交换机的作用VLAN配置思路Cisco的vlan华为vlan华为VLAN规则交换机接口模式 交换机的工作原理 数据帧进入到交换机,交换机基于报文中的源mac生成——MAC地址表,表...
  • 华为eNSP vlan综合实验

    2021-04-26 19:52:27
    3.在S1、S2、S3交换机上配置VLAN 100和VLAN 200的相关内容。 4.在S1、S2、S3交换机上配置配置RIP V2版本路由协议,使得全网通信。 提示:借助VLAN 100完成S2和S1的通信,VLAN200完成S1和S3的通信。 实验配置: 测试...
  • Quidway S3100 系列以太网交换机 命令手册 配置管理 VLAN
  • MUX VLAN是一种二层流量隔离机制MUX VLAN 分为Principal VLAN (主VLAN)和 Subordinate VLAN(从VLAN),从VLAN分为Group VLAN(互通从VLAN) 和 Separate VLAN(隔离型从VLAN)通信权限一丶主VLAN端口可以和所有...
  • 一、什么是VLANVLAN(virtual LAN)虚拟局域网:是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,同一VLAN设备相互之间的通信就好像它们在同一个...
  • 华为vlan技术基础

    千次阅读 2017-10-10 09:49:49
    vlan有动态vlan和静态vlan之分,具体划分如下 静态vlan:基于端口 动态vlan:基于MAC地址、基于...管理vlan管理vlan是一种特殊的vlan,通过vlanif的ip地址来为用户提供远程管理的vlan,其只有管理流二无数据流。sup
  • 之前已经讲解过了思科交换机的VLAN间路由以及路由器与二层交换机组网的单播路由形式【子接口】,这次主要讲解华为上面的VLAN间路由的配置,以及单臂路由的组网方式。华为的三层VLAN接口,就叫做VLANIF接口,思科的叫...
  • 华为交换机VLAN Trunk模式设置

    万次阅读 2018-01-09 14:32:15
    通过console线连接交换机。...输入system-view命令切换到管理模式。 设置端口1为trunk模式 interface GigabitEthernet 0/0/1 port link-type trunk port trunk allow-pass vlan all display this
  • 早期以太网是一种基于CSMA/CD(Carrier Sense Multiple ...在这种情况下出现了VLAN技术,这种技术可以把一个LAN划分成多个逻辑的VLAN,每个VLAN是一个广播域,VLAN内的主机间通信就和在一个LAN内一样,而VLAN间则不能
  • 华为交换机Vlan间访问控制配置案例

    千次阅读 2014-04-05 18:19:21
    华为交换机Vlan间访问控制配置案例 华为交换机ACL/QOS调用ACL配置案例 1 ACL概述 随着网络规模的扩大和流量的增加,对网络安全的控制和对带宽的分配成为网络管理的重要内容。 通过对报文进行过滤,可以有效防止非法...
  • vlan 10 创建vlan 10 quit 退出 interface vlanif 10 进入VLAN 10 ip address 192.168.1.250 255.255.255.0 设置网关和掩码 quit 退出 vlan 20 创建vlan 20 quit 退出 interface vlanif 10 进入VLAN 20 ip address ...
  • 了解华为VLAN配置

    2021-01-15 21:06:19
    文章目录前言VLAN配置思路1 交换机上创建vlan2 交换机上的各个接口划分到对应的vlan中3 trunk干道—中继干道4 VLAN间路由例例:关于华为设备vlan接口的类型问题access:只能允许一个vlan进或出;trunk :可以允许多...
  • 实验要求:1)VLAN的规划:VLAN10为主VLANVLAN 2为互通型从VLANVLAN 3为隔离型从VLAN。2)CLIENT1与CLIENT2划分到VLAN2,CLIENT3与CLIENT4划分到VLAN3,CLIENT5划分到VLAN10。3)查看PC间的通信情况LSW上配置LSW...
  • 华为vlan实验

    千次阅读 2020-05-16 21:43:24
    untagged VLAN 4 5 , tagged vlan 2 3。相当于把vlan 45 在这儿换成 vlan3。 1、交换机和pc间的vlan接口模式 SW1 [sw1]vlan batch 2 to 5 [sw1]int GigabitEthernet 0/0/3 [sw1-GigabitEthernet0/0/3]port link-type...
  • 华为交换机配置VLANVLANif

    万次阅读 多人点赞 2016-10-20 16:49:56
    以便于telnet管理或者是用于作为vlan的网关地址; 那么今天小编将指导大家完成华为交换机的vlan配置和vlanif接口的配置 工具/原料 华为交换机一台 电脑一台 方法/步
  • 我们通常会把业务vlan和管理vlan区分开来,使用不同的VLAN,增加安全性,这二者其实可以分离的。 业务vlan: 业务vlan就是我们使用无线设备获取到的IP地址所属的vlan 管理vlan管理vlan就是我们的AP设备自身的...
  • 华为交换机网页配置vlan 一、华为交换机vlan介绍 交换机支持4094个VLAN,编号为1~4094。 通过划分VLAN,将没有互通需求的主机进行二层隔离,限制广播域同时增强了网络的安全性。 二、配置步骤 新建VLAN ...
  • 以及方便管理员的管理。最终使得网络更加的健康和稳定。 背景: 随着网络中计算机的数量越来越多,传统的以太网开始面临冲突严重、广播泛滥以及安全性无法保障等各种问题,因此,才有了我们VLAN技术的产生。 备注

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,293
精华内容 2,117
关键字:

华为管理vlan