精华内容
下载资源
问答
  • 华为静态路由实验

    2020-11-29 21:39:01
    华为静态路由实验 一、实验要求 二、划分地址,配置IP 三、配置静态路由 1、静态路由 2、路径备份(浮动静态路由) 3)空接口防环 四、单臂路由 SW1 ...

    华为静态路由实验

    一、实验要求

     

    二、划分地址,配置IP

     

     

    三、配置静态路由

    1、静态路由

     

     

     

     

     

     

    2、路径备份(浮动静态路由)

     

    3)空接口防环

     

    四、单臂路由

     

    SW1

     

     

     

     

    SW2

     

     

     

     

     

     

     

     

     

    展开全文
  • 本试验主要实验静态路由的三个主要特性1、单向性 仅为数据提供沿着下一跳的方向进行路由,不提供反向路由。如果要使源节点域目标网络进行双向通信,必须同时配置回程静态路由2、接力性 如果某条静态路由中间经过的跳...

    本试验主要实验静态路由的三个主要特性

    1、单向性

    仅为数据提供沿着下一跳的方向进行路由,不提供反向路由。如果要使源节点域目标网络进行双向通信,必须同时配置回程静态路由

    2、接力性

    如果某条静态路由中间经过的跳数大于1(路由要经过3个或以上路由节点),则必须在除最后一个路由器外的其他路由器上依次配置到达相同目的节点或目的网络的静态路由。(路由器各端口上直连的各个网络都是直连互通的,因此之间默认是直连路由,因而无需另外配置路由。)

    3、迭代性

    理论上来说,静态路由的下一跳可以是路径中其他路由器中的任意一个接口,只要能保证路由到达下一跳就行了。

    2fbc73394f62fab936f885c68a6d74de.png

    具体配置:

    dis cu

    [V200R003C00]

    #

    sysname r6

    #

    interface GigabitEthernet0/0/1

    ip address 10.1.3.254 255.255.255.0

    #

    ip route-static 10.1.1.0 255.255.255.0 10.1.2.254

    ip route-static 10.1.2.0 255.255.255.0 10.1.3.1

    ip route-static 172.16.1.0 255.255.255.0 10.1.3.1

    ip route-static 172.16.2.0 255.255.255.0 10.1.3.1

    ip route-static 192.168.0.0 255.255.0.0 10.1.2.254 #此处聚合性静态路由 以及迭代性示例

    #

    return

    ------------------

    dis cu

    [V200R003C00]

    #

    sysname r4

    #

    interface GigabitEthernet0/0/0

    ip address 172.16.1.254 255.255.255.0

    #

    interface GigabitEthernet0/0/1

    ip address 10.1.3.1 255.255.255.0

    #

    interface GigabitEthernet0/0/2

    ip address 10.1.2.254 255.255.255.0

    #

    ip route-static 10.1.1.0 255.255.255.0 10.1.2.1

    ip route-static 172.16.2.0 255.255.255.0 172.16.1.1

    ip route-static 172.16.10.0 255.255.255.0 172.16.1.1

    ip route-static 192.168.0.0 255.

    #

    return

    ------------------

    dis cu

    #

    sysname s1

    #

    vlan batch 2 10 100

    #

    interface Vlanif2

    ip address 172.16.2.254 255.255.255.0

    #

    interface Vlanif10

    ip address 172.16.10.254 255.255.255.0

    #

    interface Vlanif100

    ip address 172.16.1.1 255.255.255.0

    #

    interface GigabitEthernet0/0/2

    port link-type access

    port default vlan 2

    #

    interface GigabitEthernet0/0/23

    port link-type access

    port default vlan 10

    #

    interface GigabitEthernet0/0/24

    port link-type trunk

    port trunk pvid vlan 100

    port trunk allow-pass vlan 2 to 4094

    #

    ip route-static 0.0.0.0 0.0.0.0 172.16.1.254

    ip route-static 10.1.2.0 255.255.255.0 172.16.1.254

    ip route-static 10.1.3.0 255.255.255.0 172.16.1.254

    #

    return

    --------------------------

    dis cu

    [V200R003C00]

    #

    sysname r5

    #

    interface GigabitEthernet0/0/1

    ip address 10.1.1.254 255.255.255.0

    #

    interface GigabitEthernet0/0/2

    ip address 10.1.2.1 255.255.255.0

    #

    ip route-static 10.1.3.0 255.255.255.0 10.1.2.254

    ip route-static 172.16.0.0 255.255.0.0 10.1.2.254

    ip route-static 192.168.0.0 255.255.0.0 10.1.1.1

    #

    return

    ------------------

    dis cu

    [V200R003C00]

    #

    sysname r3

    #

    interface GigabitEthernet0/0/0

    ip address 192.168.1.254 255.255.255.0

    #

    interface GigabitEthernet0/0/1

    ip address 10.1.1.1 255.255.255.0

    #

    ip route-static 10.1.2.0 255.255.255.0 10.1.1.254

    ip route-static 10.1.3.0 255.255.255.0 10.1.1.254

    ip route-static 172.16.2.0 255.255.255.0 10.1.1.254

    ip route-static 172.16.10.0 255.255.255.0 10.1.1.254

    ip route-static 192.168.2.0 255.255.255.0 192.168.1.1

    #

    return

    --------------------

    dis cu

    #

    sysname s3

    #

    vlan batch 20 100

    #

    interface Vlanif20

    ip address 192.168.2.254 255.255.255.0

    #

    interface Vlanif100

    ip address 192.168.1.1 255.255.255.0

    #

    interface GigabitEthernet0/0/24

    port link-type trunk

    port trunk pvid vlan 100

    port trunk allow-pass vlan 2 to 4094

    #

    ip route-static 0.0.0.0 0.0.0.0 192.168.1.254

    ip route-static 10.1.1.0 255.255.255.0 192.168.1.254

    ip route-static 172.16.0.0 255.255.0.0 10.1.1.1

    #

    展开全文
  • ​1静态路由静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给...

    ​1静态路由

    静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。当然,网管员也可以通过对路由器进行设置使之成为共享的。静态路由一般适用于比较简单的网络环境,在这样的环境中,网络管理员易于清楚地了解网络的拓扑结构,便于设置正确的路由信息。

    在一个支持DDR(dial-on-demand routing)的网络中,拨号链路只在需要时才拨通,因此不能为动态路由信息表提供路由信息的变更情况。在这种情况下,网络也适合使用静态路由。

    2主要优点

    使用静态路由的另一个好处是网络安全保密性高。动态路由因为需要路由器之间频繁地交换各自的路由表,而对路由表的分析可以揭示网络的拓扑结构和网络地址等信息。因此,网络出于安全方面的考虑也可以采用静态路由。不占用网络带宽,因为静态路由不会产生更新流量。

    3主要缺点

    大型和复杂的网络环境通常不宜采用静态路由。一方面,网络管理员难以全面地了解整个网络的拓扑结构;另一方面,当网络的拓扑结构和链路状态发生变化时,路由器中的静态路由信息需要大范围地调整,这一工作的难度和复杂程度非常高。

    4默认路由

    默认路由是一种特殊的静态路由,指的是当路由表中与包的目的地之间没有匹配的表项时路由器能做出的选择,如果没有默认路由,那么目的地地址在路由表中没有匹配的包将被丢弃。

    另外,适当地使用默认路由还可以减小路由表的大小。在路由表中只添加少数的静态路由,同时添加一条默认路由,这样当收到的包的目的网络没有包含在路由表中,就按照默认路由表转发。(当然默认路由又可能不是最好的路由)。

    5浮动路由

    浮动静态路由也是静态路由的一种,浮动静态路由主要是考虑链路的冗余,可以在备份链路上配置浮动路由,这条备份链路在主链路状态正常的情况下是不会转发数据的。只有当主链路发生故障的时候才会开始转发数据,起到备份路由的作用。

    6常见问题

    1)为什么要有默认路由

    路由得查看路由表而决定怎么转发数据包,用静态路由一个个的配置,繁琐易错。如果路由器有个邻居知道怎么前往所有的目的地,可以把路由表匹配的任务交给它,省了很多事。

    例,网关会知道所有的路由,如果一个路由器连接到网关,就可以配置默认路由,把所有的数据包都转发到网关。

    2)为什么默认路由是0.0.0.0

    匹配IP地址时,0表示wildcard,任何值都可以。所以0.0.0.0和任何目的地址匹配都会成功,造成默认路由要求的效果。

    7实验测试

    7.1 静态路由实验

    拓扑:

    fab5738a9a2907a0b7e1478928f3bdf3.png

    配置步骤:

    【初始化路由器】:

    【AR1】:

    3995dfd19ec601e3b9ee33db8b7f5570.png

    说明:给路由器接口配置相应的ip

    【AR2】:

    f604fdebc8d6a0668a7be41eb66ac0ae.png

    配置PC

    【pc1】:

    fac9ef9ae1765e51d803969004080b38.png

    【pc2】:

    0d728b77d48b03ed04ef6d4bf5964289.png

    注意:配置完PC一定要点应用哦,不然会不生效的哦

    【静态路由配置】

    4cd40d1ed07997762c790a88c769976f.png
    ae6f4529eda66be20bc6e27a16abf9b3.png

    测试:

    首先查看路由表:

    0d32a1ac80464ecf8abe17b433763bc2.png

    AR1上面路由表中已经通过静态路由学习到了172网段路由了,在查看AR2看看。

    325568b0d55639b9d5ddbd21a5cc5ba3.png

    AR2上也正常的学习到192网段的路由了。

    ping测试两台pc之间是否能正常通信:

    36257e4531556b8d06c92e1b596af2c9.png
    0042aefde0500d0d66868c58b1b2a69e.png

    测试结果可以正常访问。

    7.2默认路由

    拓扑:

    如上

    在上面实验的基础调整配置,具体如下:

    【AR1】:

    60fc79cb9f9738d897495d67544a6e56.png

    【AR2】:

    afaf4fc1f85fdc6f1ddb26e3aa8f22b9.png

    说明:首先使用dis cu | in ip route 命令查看静态路由相关配置,然后删除以前的配置改成默认路由方式。

    测试:

    查看路由表:

    77901dcac45281cf9ec56286d3dd2ca6.png
    ec07ac03b0f9ec2eaa2b1808bd225f24.png

    ping测试:

    bfaca7fb02a6b91d95e8100a4078fc34.png
    6af3577cfcd2e20094100cc0b0427aee.png

    测试结果正常。

    7.3浮动路由:

    拓扑:在上图的基础上略做调整

    9af3002e6dae23176d56be93957414e4.png

    实验步骤,在上面7.1静态路由的基础添加配置:

    首先给路由器接口配置IP:

    9162260365f88df13144da0d37340df6.png
    0518da9a4313d50e35c236781421390a.png

    然后配置浮动路由:

    df2ed72b848e33a8b24d9b2d1b04882e.png
    3873096a2cfd72cc97d9772f95f0c7b7.png

    说明:华为里,默认静态路由优先级为60,值越大优先级越低。

    测试:

    首先查看路由表:

    d1d370456c7e87d2c13d6213007e1c39.png
    cff9087153152171f627f516023dd444.png

    说明:可以看到去往目标网络的路由有两条,只是下一跳不同而已,现在测试,主链路正常的情况下通信情况:

    a488103a2fc4c0f02f19d88667271d8a.png
    2ba490c87bc10ac99790749206faefd6.png

    测试结果正常,主链路正常的情况下数据转发都是走的主链路。

    现在假设主链路断了(接口shutdown),然后在测试,是否会切换到备链路:

    2b2bf984f9fee8d10ac3102cfa8912a7.png
    6420f7ee7f56b5755265a03c9721620a.png
    2b9cadaab94549e08fc4c50ad8e42fbb.png

    测试正常跳转到了备用链路了。

    展开全文
  • 华为ENSP静态路由实验

    2021-02-06 10:10:37
    静态路由是指用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路状态发生改变时,需要网络管理人员手工修改静态路由信息。相比于动态路由协议,静态路由无需频繁地交换各自的路由表,配置简单。比较适合...
    1. 静态路由是指用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路状态发生改变时,需要网络管理人员手工修改静态路由信息。相比于动态路由协议,静态路由无需频繁地交换各自的路由表,配置简单。比较适合小型,简单的网络环境。

    2. 在这里插入图片描述

    3. 首先配置IP
      端口配置IP地址部分略 命令=ip add “ip地址” “子网掩码”
      IP 地址的主机位为其设备编号如R1 S0/0/0 端口在192.168.12.0网段,则该端口IP为192.168.12.1.以此类推.
      这里我将R2的 E 0/0/0 口配置为192.168.20.2 /24.故PC2的网关地址为192.168.20.3/24.
      这里将R1的 E 0/0/0 口配置为192.168.10.1/24.故PC1的网关地址为192.168.10.1/24.

    实验步骤

    [R1][R1]ip route-static 192.168.20.0 24 10.0.12.2
    在R1上配置目的网段为PC-2所在网段的静态路由,地址为
    192.168.20.0 子网掩码为255.255.255.0,数据发送到PC-2
    需要先发送给R2,所以R2为R1的下一跳路由器,之间的直连链路
    上的物理接口的IP地址即为下一跳IP地址,为10.0.12.2.
    
    <R1>display ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8        Routes : 8        
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          10.0.12.0/24  Direct  0    0           D   10.0.12.1       Serial0/0/0
          10.0.12.1/32  Direct  0    0           D   127.0.0.1       Serial0/0/0
          10.0.12.2/32  Direct  0    0           D   10.0.12.2       Serial0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
       192.168.10.0/24  Direct  0    0           D   192.168.10.1    Ethernet0/0/0
       192.168.10.1/32  Direct  0    0           D   127.0.0.1       Ethernet0/0/0
       192.168.20.0/24  Static  60   0          RD   10.0.12.2       Serial0/0/0
       **(就在上面,我头顶)可以看到R1上有PC-2所在网段的路由信息.**
    
    
    [R2]ip route-static 192.168.20.0 24 10.0.23.3
    **R2上做同样的配置,下一跳为R3的10.0.23.3.**
    
    [R2]display ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 9        Routes : 9        
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          10.0.12.0/24  Direct  0    0           D   10.0.12.2       Serial0/0/0
          10.0.12.1/32  Direct  0    0           D   10.0.12.1       Serial0/0/0
          10.0.12.2/32  Direct  0    0           D   127.0.0.1       Serial0/0/0
          10.0.23.0/24  Direct  0    0           D   10.0.23.2       Serial0/0/1
          10.0.23.2/32  Direct  0    0           D   127.0.0.1       Serial0/0/1
          10.0.23.3/32  Direct  0    0           D   10.0.23.3       Serial0/0/1
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
       192.168.20.0/24  Static  60   0          RD   10.0.23.3       Serial0/0/1
    **这里再查看一下,确定有PC-2所在的网段路由信息.**
    
    
    PC>ping 192.168.20.20
    
    Ping 192.168.20.20: 32 data bytes, Press Ctrl_C to break
    Request timeout!
    Request timeout!
    Request timeout!
    Request timeout!
    Request timeout!
    
    --- 192.168.20.20 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    **这里用PC-1pingPC-2 发现无法建立连接,因为现在的配置
    只是PC-1能够发送给PC-2数据,但是PC-2无法传送给PC-1.**
    
    [R3]ip route-static 192.168.10.0 24 10.0.23.2
    **在R3上配置去往PC-1网段的静态路由.**
    
    [R2]ip route-static 192.168.10.0 24 10.0.12.1
    **在R2上配置去往PC-1网段的静态路由.**
    
    PC>ping 192.168.20.20
    
    Ping 192.168.20.20: 32 data bytes, Press Ctrl_C to break
    From 192.168.20.20: bytes=32 seq=1 ttl=125 time=94 ms
    From 192.168.20.20: bytes=32 seq=2 ttl=125 time=125 ms
    From 192.168.20.20: bytes=32 seq=3 ttl=125 time=125 ms
    From 192.168.20.20: bytes=32 seq=4 ttl=125 time=109 ms
    From 192.168.20.20: bytes=32 seq=5 ttl=125 time=125 ms
    
    --- 192.168.20.20 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 94/115/125 ms
    **最后成功ping通**
    

    新人博主,资历有限,如果有哪些不足之处请不吝赐教。

    展开全文
  • 实验要求: 合理分配IP地址: 骨干链路 192.168.1.0/27 192.168.1.0/30 192.168.1.4/30 192.168.1.8/30 192.168.1.12/30 192.168.1.16/30 192.168.1.20/30 192.168.1.24/30 环回地址 R1 192.168.1.32/27 192.168....
  • quit [AR2]ip route-static 10.0.0.0 8 12.0.0.1 配置到10.0.0.0的静态路由 [AR2]ip route-static 30.0.0.0 8 23.0.0.1 配置到30.0.0.0的静态路由 AR3 system-view [AR3]interface GigabitEthernet 0/0/2 [AR3-...
  • 关注我,你的眼睛会怀孕一、静态路由功能介绍静态路由就是手工配置的路由,使得数据包能够按照预定的路径传送到指定的目标网络。当不能通过动态路由协议学到一些目标网络的路由时,配置静态路由就会显得十分重要。二...
  • 华为网络设备-静态路由实验 作者: 梁文婷    排版: 赖裕鑫    审核: 蔡宗唐 文章目录实验拓扑图实验配置实验验证 实验拓扑图 任务1:使用静态路由实现R1到10.0.13.0/24和10.0...
  • 静态路由实验

    2020-12-05 02:19:13
    华为静态路由配置 1. 实验华为静态路由配置 1.1实验目的 掌握华为静态路由配置 1.2实验拓展 1.3实验要求 1.R1——R4每台设备均有两个环回 2.实验中所有的IP地址均由192.168.1.0/24 划分所得 ...
  • 静态路由静态路由指由用户或网络管理员手工配置的路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。静态路由一般适用于比较简单的网络环境 优点: 运行稳定 节省设备链路的开销 缺点: ...
  • 华为静态路由实验

    千次阅读 2019-09-10 13:34:28
    静态路由: 静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他...
  • 华为eNSP静态路由配置实验

    千次阅读 2020-05-25 00:28:22
    学习静态路由配置 实验任务 实现网络中设备互通 实验环境 实验拓扑如图所示: 实验配置 路由器R3配置 Ip地址配置 sys [Huawei]sysname R3 [R3]int g0/0/0 [R3-g0/0/0]ip address 20.0.0.1 24 [R3-g0/0/0]dis this ...
  • 华为静态路由及默认路由的配置

    千次阅读 2020-05-18 21:41:33
    一、 静态路由及默认路由配置: 原理概述: 实验目的: 掌握配置静态路由(指定接口)的方法。 掌握配置静态路由(指定下一跳ip地址)的方法 掌握测试静态路由的连通性的方法。 掌握配置默认路由的方法 掌握测试...
  • ENSP静态路由实验,两台交换机不同网段间互通。适用于高速行业收费及监控网络。新手必回技能。配置简单,适用性强。
  • 华为(ensp)静态路由实验

    万次阅读 多人点赞 2018-07-23 00:34:54
    本次实验的拓扑图  第一步,配置ip地址 PC1 和 PC2的ip地址就不用我说了吧。左边红色区域的网段是:192.168.1.0/24这个网络 右边网络为:192.168.2.0/24这个网络。下面配置路由器AR1。看下图 然后我们配置...
  • 华为实验2静态路由

    2019-03-30 14:47:18
    华为实验2静态路由 实验目的 使用静态路由使 IP 数据可达 实验步骤 1:更名及配置 IP 地址 system-view [Huawei]sysname R1 [R1]interface Ethernet 0/0/0 [R1-Ethernet0/0/0]ip address 12.1.1.1 255.255.255.0 ...
  • HCIA静态路由实验报告

    2020-11-04 18:09:33
    HCIA静态路由实验报告 实验日期: 2020年11月4日 课程名称: HCIA 实验名称: 静态路由HCIA 一、实验目的 熟练掌握华为静态路由配置命令 二、实验内容 三、概要设计 1、划分地址,配置IP 2、静态路由配置 3、单臂...
  • [R1]display current-configuration [V200R003C00] # sysname R1 # snmp-agent local-engineid 800007DB03000000000000 snmp-agent # clock timezone China-Standard-Time minus 08:00:00 # portal local-serv...
  • 华为 eNSP RIP+静态路由+单臂路由实验

    千次阅读 2020-06-08 20:07:09
    这里要求:静态路由+RIP协议+单臂路由实验 一、单臂路由实验,结果如下图: AR1的相关配置:(有些不规范,慎重粘贴复制) sys sysname AR1 int g0/0/1.10 dot1q termination vid 10 ip add 192.168.16.1 28

空空如也

空空如也

1 2 3 4 5 ... 15
收藏数 283
精华内容 113
关键字:

华为静态路由实验