精华内容
下载资源
问答
  • 华为路由器配置实例

    万次阅读 2018-05-18 09:32:08
    #sysname GZ //路由器名字GZftpserver enable //ftp 服务开通以便拷贝出配置文件备份#voice#http server port 1025  //httpundo ...
    #
    
    sysname GZ //路由器名字GZ
    ftpserver enable //ftp 服务开通以便拷贝出配置文件备份
    #
    voice
    #
    http server port 1025   //http
    undo http server enable
    #
    drop illegal-mac alarm
    #
    l2tp aging 0
    #
    vlan batch 10 20 30 40 50 //本路由器设置的VLAN ID       
    #
    igmp global limit 256
    #
    multicast routing-enable //开启组播
    #
    dhcp enable //全局下开启DHCP服务然后在各VLAN上开启单独的DHCP
    #
    ipvpn-instance 1
    ipv4-family
    #
    acl number 2000
    rule 10 permit
    #
    acl number 2001 //以太网访问规则列表。
    rule6 permit source 172.23.68.0 0.0.0.255 //允许此网段访问外网
    rule7 permit source 172.23.69.0 0.0.0.255  //允许此网段访问外网
    rule 8 permit source 172.23.65.0 0.0.0.3  //允许此网段的前三个IP访问外网
    rule9 deny   //不允许其他网段访问外网




    #
    acl number 3000 //此规则并未应用
    rule 40 permit ip source 172.23.65.00.0.0.255 destination 172.23.69.0 0.0.0.25
    5
    #
    acl number 3001//定义两个网段主机互不访问,学生不能访问65网段。
    rule 5 deny ip source 172.23.65.0 0.0.0.255destination 172.23.68.0 0.0.0.255
    rule 10 deny ip source 172.23.68.00.0.0.255 destination 172.23.65.0 0.0.0.255
    #
    aaa //默认视图窗口定义本地登录帐号和密码
    authentication-scheme default
    authorization-scheme default
    accounting-scheme default
    domain default
    domaindefault_admin
    local-user admin password cipher ]MQ;4\]B+4Z,YWX*NZ55OA!!
    local-user admin service-type telnet webhttp
    local-userdfwd password cipher'VE5U!@7QCO;V2HX\']\,1!!
    local-userdfwd privilege level 15
    local-userdfwd service-type telnet terminalweb http
    local-userhuawei password cipherRY,UPVHCMV+Q=^Q`MAF4<1!! //新建用户dfwd密码
    local-user huawei ftp-directory flash: //该用户名默认配置指向的ftp路径
    local-user huawei service-type ftp  // 该用户采用FTP访问
    #
    firewall zone trust //定义信任区域
    priority 15 //定义信任区域下的策略
    #
    firewall zone untrust //定义不信任区域
    priority 1 //定义不信任区域下的策略
    #
    firewall interzone trust untrust //配置安全域间
    firewall enable//该安全域间启用防火墙
    packet-filter 3001 inbound //入口执行3001规则
    packet-filter 3001 outbound //出口执行3001规则
    packet-filter default deny outbound
    #
    interface Vlanif10
    ip address 172.23.65.100 255.255.255.0 //定义vlan的网关地址和子网掩码
    pimdm //组播协议需开启的功能
    igmp enable //组播协议需开启的功能
    zonetrust //定义VLAN是信任区域
    #
    interface Vlanif20 
    ip address 172.23.1.1 255.255.255.240  //定义vlan的网关地址和子网掩码
    pimdm    //组播协议需开启的功能
    igmp enable//组播协议需开启的功能
    zonetrust//定义VLAN是信任区域
    #
    interface Vlanif30
    ip address 10.10.10.1 255.255.255.252  //定义vlan的网关地址和子网掩码
    pimdm  //组播协议需开启的功能
    igmp enable //组播协议需开启的功能
    zonetrust  //定义VLAN是信任区域

    interface Vlanif40
    ip address 172.23.68.100 255.255.255.0 //定义vlan的网关地址和子网掩码
    pimdm //组播协议需开启的功能
    igmp enable //组播协议需开启的功能
    dhcp select interface //自动分配该VLAN网关所在的地址段IP
    dhcp server excluded-ip-address172.23.68.201 172.23.69.254 //定义该段IP不自动分配
    dhcp server dns-list 61.139.2.69  //定义该VLAN所在IP地址段的DNS地址
    zoneuntrust //定义该VLAN为不信任区域
    #
    interface Vlanif50
    ip address 172.23.69.100 255.255.255.0  //定义vlan的网关地址和子网掩码
    pimdm //组播协议需开启的功能
    igmp enable //组播协议需开启的功能
    dhcp select interface //开启本VLAN的DHCP功能并选择端口为定义的网关地址
    dhcp server excluded-ip-address172.23.69.201 172.23.69.252 //定义手动获取的IP地址段
    dhcp server dns-list 61.139.2.69  //定义该VLAN段IP的DNS
    #
    interface Ethernet0/0/0 //物理端端口0
    portlink-type access //定义该端口类型
    portdefault vlan 10 //定义端口所在VLAN
    #
    interface Ethernet0/0/1  //物理端端口1
    portlink-type access  //定义该端口类型
    portdefault vlan 30 //定义端口所在VLAN
    #
    interface Ethernet0/0/2 //物理端端口2
    portlink-type access // 定义该端口类型
    portdefault vlan 20 //定义端口所在VLAN
    qosgtscir 6000 cbs 600000 //定义该端口数据缓存带宽范围
    #
    interface Ethernet0/0/3 //物理端端口3
    port link-type access
    port default vlan 30
    #
    interface Ethernet0/0/4 //物理端端口4
    portlink-type access  //定义该端口类型
    portdefault vlan 40 //定义端口所在VLAN
    #
    interface Ethernet0/0/5 //物理端端口5
    portlink-type access //定义该端口类型
    portdefault vlan 50 //定义端口所在VLAN
    #
    interface Ethernet0/0/6 //物理端端口6
    portlink-type access //定义该端口类型
    #
    interface Ethernet0/0/7 //物理端端口6
    portlink-type access //定义该端口类型
    portdefault vlan 10 //定义端口所在VLAN
    #
    interface GigabitEthernet0/0/0  //三层口不在任何一个VLAN中,有映射功能。
    ip address 125.69.71.128 255.255.255.0  //定义该端口的网关地址和子网掩码
    nat server protocol tcp globalcurrent-interface 10001 inside 172.23.68.222 10001 //允许内网IP端口映射到外网
    nat server protocol tcp globalcurrent-interface 10002 inside 172.23.68.222 10002
    nat server protocol tcp globalcurrent-interface 10003 inside 172.23.68.222 10003
    nat server protocol tcp globalcurrent-interface 10004 inside 172.23.68.222 10004
    nat server protocol tcp globalcurrent-interface 10005 inside 172.23.68.222 10005
    nat server protocol tcp globalcurrent-interface 10006 inside 172.23.68.222 10006
    nat server protocol tcp globalcurrent-interface 10007 inside 172.23.68.222 10007
    nat server protocol tcp globalcurrent-interface 10008 inside 172.23.68.222 10008
    nat server protocol tcp globalcurrent-interface 10009 inside 172.23.68.222 10009
    nat server protocol tcp globalcurrent-interface 10010 inside 172.23.68.222 10010
    nat server protocol udp globalcurrent-interface 11001 inside 172.23.68.222 11001
    nat server protocol udp globalcurrent-interface 11002 inside 172.23.68.222 11002
    nat server protocol udp globalcurrent-interface 11003 inside 172.23.68.222 11003
    nat server protocol udp globalcurrent-interface 11004 inside 172.23.68.222 11004
    nat server protocol udp globalcurrent-interface 11005 inside 172.23.68.222 11005
    nat server protocol udp globalcurrent-interface 11006 inside 172.23.68.222 11006
    nat server protocol udp globalcurrent-interface 11007 inside 172.23.68.222 11007
    nat server protocol udp globalcurrent-interface 11008 inside 172.23.68.222 11008
    nat server protocol udp globalcurrent-interface 11009 inside 172.23.68.222 11009
    nat server protocol udp global current-interface11010 inside 172.23.68.222 11010
    nat outbound 2001 //在该端口上执行编号为2001的访问规则
    #
    interface GigabitEthernet0/0/1   //三层口不在任何一个VLAN中,有映射功能。
    ip address 10.10.10.6 255.255.255.252 //定义该端口的网关地址和子网掩码
    pimdm   //组播协议需开启的功能
    igmp enable //组播协议需开启的功能
    undonegotiation auto //关闭端口自动协商功能
    zonetrust   //定义该端口是信任区域
    #
    interface Cellular0/0/0
    link-protocolppp
    #
    interface Cellular0/0/1
    link-protocolppp
    #
    interface NULL0
    #
    igmp
    #
    pim
    c-bsr GigabitEthernet0/0/0
    c-rp GigabitEthernet0/0/0 group-policy 2000
    c-rp GigabitEthernet0/0/1 group-policy 2000
    #
    ip route-static 0.0.0.0 0.0.0.0125.71.213.1  //新增静态路由列表,访问外网
    ip route-static 10.1.187.0 255.255.255.010.10.10.2
    ip route-static 10.102.0.0 255.255.0.0172.23.1.2
    ip route-static 10.110.0.0 255.255.0.0172.23.1.2
    ip route-static 172.23.66.0 255.255.255.010.10.10.2
    ip route-static 172.23.67.0 255.255.255.010.10.10.5
    ip route-static 192.168.14.0 255.255.255.0172.23.1.2
    ip route-static 192.168.18.0 255.255.255.0172.23.1.2
    ip route-static 192.168.20.0 255.255.255.0172.23.1.2
    #
    super password level 3 cipherEO2\:%&(X.$'CLYaDZ]EJ1!!
    user-interface con 0
    user-interfacevty 0 4
    authentication-modeaaa
    user-interfacevty 16 20
    #
    port-group 1
    group-member Ethernet0/0/0
    group-member Ethernet0/0/1
    group-member Ethernet0/0/2
    group-member Ethernet0/0/3
    group-member Ethernet0/0/4
    group-member Ethernet0/0/5
    group-member Ethernet0/0/6
    group-member Ethernet0/0/7
    #
    port-group eth0/0/2
    #
    Return
    展开全文
  • 来自华为官网的文档,适用于华为所有路由器机型。本文档介绍了AR中安全特性的基本概念、在不同应用场景中的配置过程和配置举例。本文档提供了安全特性的配置方法。
  • 详细说明: 华为各种路由器配置实例 目录:LANSWITCH配置实例-200309-C 华为3Com中低端路由器典型配置实例 交换机 中低LANSWITCH典型配置实例 中低端路由器典型配置实例 中低端路由器典型配置实例V1.30 中低端...
  • H3C华为路由器配置实例.doc
  • H3C华为路由器配置实例.pdf
  • 华为路由器产品文档,产品的详解,产品的安装、配置、运维及故障处理。包含协议的使用命令及二次开发;
  • 华为路由器DHCP配置实例,主要是DHCP的配置例子简单明了。
  • 华为中低端路由器典型配置实例v1.50.exe 华为中低端路由器典型配置实例V1.60.exe 华为中低端路由器典型配置实例V1.40.chm 华为中低端路由器典型配置实例V1.30.chm 华为中低端路由器典型配置实例.pdf 华为中低...
  • 华为路由器BGP路由配置实例
  • 华为路由器配置命令 <Huaiwei>system-view 进入系统视图模式 [Huaiwei]display interfaces 显示接口信息 [Huaiwei]display ip route 显示路由 [Huaiwei]link-protocol hdlc 绑定HDLC [Huaiwe...

                                    华为路由器配置命令

     

    <Huaiwei>system-view   进入系统视图模式
    [Huaiwei]display interfaces  显示接口信息
    [Huaiwei]display ip route     显示路由
    [Huaiwei]link-protocol hdlc    绑定HDLC
    [Huaiwei]ip route-static {interfacenumber|nexthop}[value][reject|blackhole]
    [Huaiwei]ip route-static 202.1.0.0 255.255.0.0 210.0.0.2
    [Huaiwei]ip route-static 202.1.0.0 Serial2
    [Huaiwei]rip                   设置动态路由
    [Huaiwei]rip work              设置工作允许
    [Huaiwei]rip input             设置入口允许
    [Huaiwei]rip ouput             设置出口允许
    [Huaiwei-rip]network 10.0.0.0   设置路由交换网络
    [Huaiwei-rip]network all         设置与所有网络交换
    [Huaiwei-rip]peer ip-address     
    [Huaiwei-rip]summary              路由汇聚
    [Huaiwei-rip]rip version 1        设置工作在版本1
    [Huaiwei-rip]rip version 2 multicast    设置版本2,组播方式
    [Huaiwei-Ethernet0]rip split-horizon     水平分隔
    [Huaiwei]route id A.B.C.D               配置路由器的ID
    [Huaiwei]ospf enable                    启动OSPF协议
    [Huaiwei-ospf]import-route direct       引入直联路由
    [Huaiwei-Serial0]ospf enable area       配置OSPF区域

    展开全文
  • (思科,华为)路由器配置实例--各100例.rar
  • 华为路由器Qos配置

    2018-07-14 19:28:37
    华为官方网站下载,介绍了怎么基于VLAN进行网络限速,非常实用。
  • 华为路由器详细配置命令是学习华为交换机路由器最好学习资料
  • 史上最全华为路由器交换机配置命令大合集(辛苦整理),史上最全华为路由器交换机配置命令大合集(辛苦整理)
  • 华为路由器配置OSPF实例

    万次阅读 多人点赞 2016-07-26 13:44:37
    session 2 ospf的配置实例 一、ospf的基本功能配置  按照拓扑图上配置ospf的三个区域,相互学习到路由并查看每个路由器的LSDB和相关LSA信息,AR4与AR6分别扮演ASBR角色并将自己的环回接口网络重分布进...

    session 1 ospf

           ospf 开放式最短路径优先路由协议,是一种状态链路协议,采用Dijkstra算法计算路由。

           ospf的进程,每个ospf的进程都是单独的,并且地址族也是每一个进程一个。

           ospf的区域划分,area 0是骨感区域,有且只有一个;其他区域为非骨干区域,并且必须与骨干区域直接相连或者通过虚链路相连,非骨干区域分为一般区域、末梢区域(只有lsa1、2、3)、完全末梢区域(只有lsa1、2)、非纯末梢区域(lsa1、2、3、7)、完全非纯末梢区域(lsa1、2、7)

           ospf的接口类型:广播(选举DR、BDR)、NBMA(不选举DR、BDR)、P2P(不选举DR、BDR)、P2MP(不选举DR、BDR)

           ospf的LSA类型:lsa1=路由器lsa,由路由器产生宣告直连。lsa2=网络lsa,由DR/BDR产生宣告网段。lsa3=网络汇总lsa,由ABR产生宣告不同区域的路由。                                                                   lsa4=ASBRlsa,由ABR产生宣告到达ASBR的路由。lsa5=外部lsa,由asbr产生宣告外部路由。lsa7=NSSA外部lsa,由asbr产生宣告nssa区域的外部路由

           ospf的角色:ABR区域边界路由器,连接不同区域并宣告不同区域路由。ASBR区域边界路由器,连接区域和外部网络宣告外部网络到ospf中。

           ospf的邻居建立过程:down(接口down)、init(选举DR/BDR)、2-way(邻居关系完成)、exstart/exchange(交换链路状态数据库DBD信息)、loading(LSA更新)、full(邻接关系建立)

           ospf的组播地址:224.0.0.5(所有路由器发送hello选举DR/BDR,后DB统一下发LSU给其他路由器)、224.0.0.6(DR监听其他路由器发的LSU)

           ospf中DR/BDR不具备抢占机制,为了稳定性已经成为DR的路由器不会因为优先级比其他路由器小而失去DR/BDR资格,除非ospf协议重启重新选举DR/BDR

           ospf中DR/BDR的选举规则:优先级>r-id>环回口最大ip>接口最大ip

           ospf的DR/BDR是以网段选举的而不是区域,宣告也是以接口进行的*(也支持宣告网络)


    session 2 ospf的配置实例

    一、ospf的基本功能配置


           按照拓扑图上配置ospf的三个区域,相互学习到路由并查看每个路由器的LSDB和相关LSA信息,AR4与AR6分别扮演ASBR角色并将自己的环回接口网络重分布进ospf网络中,AR6的外部路由使type1(AR4的使用默认的type2)分布进ospf,并查看LSA5

    AR1的配置

    interface GigabitEthernet0/0/0
     ip address 12.1.1.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 13.1.1.1 255.255.255.0 
    #

    ospf 1 router-id 1.1.1.1                              ospf的r-id
     area 0.0.0.0                                                      创建area0
      network 12.1.1.1 0.0.0.0                                   在area0中宣告属于area0区域的接口(允许该接口在area0收发ospf报文

     area 0.0.0.1                                                      创建area1
      network 13.1.1.1 0.0.0.0                                   在area1中宣告属于area1区域的接口
    #

    AR2的配置

    interface GigabitEthernet0/0/0
     ip address 12.1.1.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 25.1.1.2 255.255.255.0 
    #

    ospf 1 router-id 2.2.2.2 
     area 0.0.0.0 
      network 12.1.1.2 0.0.0.0 
     area 0.0.0.2 
      network 25.1.1.2 0.0.0.0 
    #

    AR3的配置

    interface GigabitEthernet0/0/0
     ip address 13.1.1.3 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 34.1.1.3 255.255.255.0 
    #

    ospf 1 router-id 3.3.3.3 
     area 0.0.0.1 
      network 13.1.1.3 0.0.0.0 
      network 34.1.1.3 0.0.0.0 
    #

    AR4的配置

    interface GigabitEthernet0/0/0
     ip address 34.1.1.4 255.255.255.0 
    #

    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255 
    #
    ospf 1 router-id 4.4.4.4 
     import-route direct                                        重分布直连路由到ospf中,类型为默认的type2(cost固定为1)
     area 0.0.0.1 
      network 34.1.1.4 0.0.0.0 
    #

    AR5的配置

    interface GigabitEthernet0/0/0
     ip address 25.1.1.5 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 56.1.1.5 255.255.255.0 
    #

    ospf 1 router-id 5.5.5.5 
     area 0.0.0.2 
      network 25.1.1.5 0.0.0.0 
      network 56.1.1.5 0.0.0.0 
    #

    AR6上的配置

    interface GigabitEthernet0/0/0
     ip address 56.1.1.6 255.255.255.0 
    #

    interface LoopBack0
     ip address 6.6.6.6 255.255.255.255 
    #

    ospf 1 router-id 6.6.6.6 
     import-route direct type 1            重分布直连路由到ospf中,类型为type1(类型区别在于路由的metric不同,type1的cost大)
     area 0.0.0.2 
      network 56.1.1.6 0.0.0.0 
    #

    查看ospf的LSDB数据库,在AR1上查看,做为ABR应该有2个区域的lsa1-3信息以及外部重分布的lsa5和到达asbr的lsa4

    [Huawei]display ospf 1 lsdb 
    OSPF Process 1 with Router ID 1.1.1.1
    Link State Database 
            Area: 0.0.0.0 区域0的lsa
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    2.2.2.2         2.2.2.2            878  36    80000013       1
     Router    1.1.1.1         1.1.1.1            823  36    80000015       1
     Network   12.1.1.1        1.1.1.1           1565  32    8000000E       0
     Sum-Net   56.1.1.0        2.2.2.2            208  28    8000000C       2
     Sum-Net   34.1.1.0        1.1.1.1            634  28    8000000D       2
     Sum-Net   25.1.1.0        2.2.2.2            868  28    8000000D       1
     Sum-Net   13.1.1.0        1.1.1.1            803  28    8000000D       1
     Sum-Asbr  34.1.1.4        1.1.1.1            611  28    8000000C       2
     Sum-Asbr  6.6.6.6         2.2.2.2            208  28    8000000B       2
            Area: 0.0.0.1 区域1的lsa
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    34.1.1.4        34.1.1.4           754  36    8000000F       1
     Router    13.1.1.3        13.1.1.3           638  48    80000014       1
     Router    1.1.1.1         1.1.1.1            716  36    80000011       1
     Network   34.1.1.3        13.1.1.3           638  32    8000000E       0
     Network   13.1.1.1        1.1.1.1            716  32    8000000E       0
     Sum-Net   12.1.1.0        1.1.1.1            803  28    8000000D       1
     Sum-Net   56.1.1.0        1.1.1.1            207  28    8000000C       3
     Sum-Net   25.1.1.0        1.1.1.1            803  28    8000000D       2
     Sum-Asbr  6.6.6.6         1.1.1.1            207  28    8000000B       3
    AS External Database 外部重分布的lsa5和到达asbr的lsa4
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     External  6.6.6.6         6.6.6.6            235  36    8000000C       1
     External  4.4.4.4         34.1.1.4           754  36    8000000C       1
     External  34.1.1.0        34.1.1.4           754  36    8000000C       1
     External  56.1.1.0        6.6.6.6            235  36    8000000C       1
    [Huawei] 

    在AR4上查看lsa信息库

    [Huawei]display ospf 1 lsdb 
    OSPF Process 1 with Router ID 34.1.1.4
    Link State Database 
            Area: 0.0.0.1                                             area1的lsa信息
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    34.1.1.4        34.1.1.4          1078  36    8000000F       1
     Router    13.1.1.3        13.1.1.3           964  48    80000014       1
     Router    1.1.1.1         1.1.1.1           1044  36    80000011       1
     Network   34.1.1.3        13.1.1.3           964  32    8000000E       0
     Network   13.1.1.1        1.1.1.1           1044  32    8000000E       0
     Sum-Net   12.1.1.0        1.1.1.1           1132  28    8000000D       1
     Sum-Net   56.1.1.0        1.1.1.1            531  28    8000000C       3
     Sum-Net   25.1.1.0        1.1.1.1           1132  28    8000000D       2
     Sum-Asbr  6.6.6.6         1.1.1.1            531  28    8000000B       3
    AS External Database 外部lsa信息
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     External  4.4.4.4         34.1.1.4          1078  36    8000000C       1
     External  34.1.1.0        34.1.1.4          1078  36    8000000C       1
     External  6.6.6.6         6.6.6.6            560  36    8000000C       1
     External  56.1.1.0        6.6.6.6            560  36    8000000C       1
    [Huawei]

    在AR1上查看AR4上重分布的type2路由和AR6上重分布的type1的路由的cost(metric)的区别

    [Huawei]display ip routing-table protocol ospf 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Public routing table : OSPF
             Destinations : 5        Routes : 5        
    OSPF routing table status : <Active>
             Destinations : 5        Routes : 5
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
            4.4.4.4/32  O_ASE   150         1           D   13.1.1.3        GigabitEthernet0/0/1              默认的type2,cost固定为1
            6.6.6.6/32  O_ASE   150         4           D   12.1.1.2        GigabitEthernet0/0/0              非默认的type1真实的cost值

           25.1.1.0/24  OSPF    10          2           D   12.1.1.2         GigabitEthernet0/0/0
           34.1.1.0/24  OSPF    10          2           D   13.1.1.3         GigabitEthernet0/0/1
           56.1.1.0/24  OSPF    10          3           D   12.1.1.2         GigabitEthernet0/0/0
    OSPF routing table status : <Inactive>
             Destinations : 0        Routes : 0
    [Huawei]


    展开全文
  • 华为路由器配置流程和命令详解!!!!!!
  • 华为路由器dhcp简单配置实例

    万次阅读 多人点赞 2016-07-18 11:10:01
     DHCP(Dynamic Host Configuration Protocol,动态主机配置协议)是一个局域网的网络协议,使用UDP协议工作, 主要有两个用途:给内部网络或网络服务供应商自动分配IP地址,给用户或者内部网络管理员作为对所有...

    session 1 DHCP的工作原理

           DHCP(Dynamic Host Configuration Protocol,动态主机配置协议)是一个局域网的网络协议,使用UDP协议工作, 主要有两个用途:给内部网络或网络服务供应商自动分配IP地址,给用户或者内部网络管理员作为对所有计算机作中央管理的手段,在RFC 2131中有详细的描述。DHCP有3个端口,其中UDP67和UDP68为正常的DHCP服务端口,分别作为DHCP Server和DHCP Client的服务端口;546号端口用于DHCPv6 Client,而不用于DHCPv4,是为DHCP failover服务,这是需要特别开启的服务,DHCP failover是用来做“双机热备”的。

           DHCP协议采用UDP作为传输协议,主机发送请求消息到DHCP服务器的67号端口,DHCP服务器回应应答消息给主机的68号端口,DHCP的IP地址自动获取工作原理及详细步骤如下:

    1、DHCP Client以广播的方式发出DHCP Discover报文。

    2、所有的DHCP Server都能够接收到DHCP Client发送的DHCP Discover报文,所有的DHCP Server都会给出响应,向DHCP Client发送一个DHCP Offer报文。DHCP Offer报文中“Your(Client) IP Address”字段就是DHCP Server能够提供给DHCP Client使用的IP地址,且DHCP Server会将自己的IP地址放在“option”字段中以便DHCP Client区分不同的DHCP Server。DHCP Server在发出此报文后会存在一个已分配IP地址的纪录。

    3、DHCP Client只能处理其中的一个DHCP Offer报文,一般的原则是DHCP Client处理最先收到的DHCP Offer报文。DHCP Client会发出一个广播的DHCP Request报文,在选项字段中会加入选中的DHCP Server的IP地址和需要的IP地址。

    4、DHCP Server收到DHCP Request报文后,判断选项字段中的IP地址是否与自己的地址相同。如果不相同,DHCP Server不做任何处理只清除相应IP地址分配记录;如果相同,DHCP Server就会向DHCP Client响应一个DHCP ACK报文,并在选项字段中增加IP地址的使用租期信息。

    5、DHCP Client接收到DHCP ACK报文后,检查DHCP Server分配的IP地址是否能够使用。如果可以使用,则DHCP Client成功获得IP地址并根据IP地址使用租期自动启动续延过程;如果DHCP Client发现分配的IP地址已经被使用,则DHCP Client向DHCPServer发出DHCP Decline报文,通知DHCP Server禁用这个IP地址,然后DHCP Client开始新的地址申请过程。

    6、DHCP Client在成功获取IP地址后,随时可以通过发送DHCP Release报文释放自己的IP地址,DHCP Server收到DHCP Release报文后,会回收相应的IP地址并重新分配。



    session 2 dhcp的中继代理和snooping

    一、dhcp中继代理的作用就是:在一个L3层网络中,如果dhcp服务器和客户端不在同一个网段时,客户端发送的dhcp-discovery广播包将会被网关设备丢弃(L3层隔离广播特性)。dhcp中继就是在网关接口上配置一种能让网关识别客户端发送的dhcp-discovery广播包,当网关收到该包后不做丢弃处理,而是以单播形式代理客户端来向dhcp服务器请求ip地址,然后再将dhcp回应的offer包转发给客户端,帮助客户端完成ip地址的获取过程。
    只需要再L3网关的接口上配置中继代理:


    二、为了防止网络中非法dhcp向用户提供dhcp服务,可以使用dhcp snooping(dhcp探测功能)。
           DHCP Snooping技术是DHCP安全特性,通过建立和维护DHCP Snooping绑定表过滤不可信任的DHCP信息,这些信息是指来自不信任区域的DHCP信息(也就是非法dhcp服务器)。DHCP Snooping绑定表包含不信任区域的用户MAC地址、IP地址、租用期、VLAN-ID 接口等信息,该技术在接口上设置是否信任该接口上连接的dhcp服务器(如果有)。
           当交换机开启了 DHCP-Snooping后,交换机所有端口会对自己接受来的DHCP报文进行侦听,并可以从接收到的DHCP Request或DHCP Ack报文中提取并记录IP地址和MAC地址信息。另外,DHCP-Snooping允许将某个物理端口设置为信任端口或不信任端口。信任端口可以正常接收并转发DHCP Offer报文,而不信任端口会将接收到的DHCP Offer报文丢弃。这样,可以完成交换机对假冒DHCP Server的屏蔽作用,确保客户端从合法的DHCP Server获取IP地址。
           默认情况下开启了DHCP Snooping后,交换机所有接口都被设置为不信任状态,就是任何一个端口收到dhcp服务器的offer响应包后都会丢弃,可以手动配置合法dhcp所在的端口为信任端口,不丢弃dhcp服务器向外发送的offer包,来实现dhcp的安全。
           一般所有交换机都开启dhcp snooping功能,信任接口一般都是sw之间相连的接口(如果是汇聚层交换机的话需要在该交换机连接上游核心sw和下游接入sw的接口上都开启dhcp trust才可以,核心L3层交换机作为dhcp服务器的话),非信任接口都是sw连接PC的接口。


    session 3 dhcp的配置实例

    拓扑如下:


          根据拓扑配置,要求PC1和PC2分别在不同的vlan中获取AR2这台DHCP分配的ip地址,并且在LSW2和AR2上开启dhcp snpooping功能防止非法dhcp服务器接入网络和非法用户对于AR2的dhcp泛红攻击,在LSW2上开启中继代理功能为PC1和P2代理dhcp服务器的ip地址。

    具体配置如下:

    一、将AR2配置成dhcp服务器

    [Huawei]interface g0/0/0

    [Huawei-GigabitEthernet0/0/0] ip address 12.1.1.2 255.255.255.0

    [Huawei-GigabitEthernet0/0/0] quit

    [Huawei]

    [Huawei] ip pool net1                                                                         配置为vlan2分配IP地址的地址池,名为net1

    [Huawei-ip-pool-net1] network 192.168.1.0 mask 255.255.255.0          分配的ip是192.168.1.0/24

    [Huawei-ip-pool-net1] gateway-list 192.168.1.1

    [Huawei-ip-pool-net1] dns-list 218.30.19.40 61.134.1.4

    [Huawei-ip-pool-net1] static-bind ip-address 192.168.1.10 mac-address 0000-1111-2222        为固定mac分配固定ip

    [Huawei-ip-pool-net1] excluded-ip-address 192.168.1.2                      不分配的ip地址

    [Huawei-ip-pool-net1] quit

    [Huawei]

    [Huawei] ip pool net2                                                                          配置为vlan2分配IP地址的地址池,名为net1

    [Huawei-ip-pool-net2] network 192.168.2.0 mask 255.255.255.0           分配的ip是192.168.1.0/24

    [Huawei-ip-pool-net2] gateway-list 192.168.2.1

    [Huawei-ip-pool-net2] dns-list 218.30.19.40 61.134.1.4

    [Huawei-ip-pool-net2] static-bind ip-address 192.168.2.10 mac-address 0001-1111-2222        为固定mac分配固定ip

    [Huawei-ip-pool-net2] excluded-ip-address 192.168.2.2                       不分配的ip地址

    [Huawei-ip-pool-net2] quit

    [Huawei]

    [Huawei]interface g0/0/0

    [Huawei-GigabitEthernet0/0/0] ip address 12.1.1.2 255.255.255.0            

    [Huawei-GigabitEthernet0/0/0] dhcp select global                                接口下开启器全局DHCP分配功能

    [Huawei-GigabitEthernet0/0/0] quit                                                     

    [Huawei]dhcp server ping packet 10 timeout 100                                 配置dhcp服务器分配某个ip之前先探测该ip是否已被网络中pc使用的功能,dhcp服务器会向该ip地址发10个包且每次100ms,无应答才会分配该ip地址给客户端

    [Huawei]dhcp check dhcp-rate enable                                                 开启dhcp的速率检测功能开关
    [Huawei]dhcp check dhcp-rate 90                       检测收到dhcp请求包的速率最大为90个/s,默认100个/s,防止dhcp泛红攻击

    [Huawei] quit

    [Huawei] ip route-static 0.0.0.0 0.0.0.0 12.1.1.1                                       配置一条能够到达客户端网络的默认路由


    二、配置SW成为dhcp中继代理为vlan2和vlan3中的客户端提供对应的dhcp中继代理服务,并配置dhcp-snooping功能防止非法的dhcp服务器分配ip地址给客户端

    [Huawei]interface Vlanif 1
    [Huawei-Vlanif1]ip address 12.1.1.1 255.255.255.0

    [Huawei-Vlanif1]quit
    [Huawei]

    [Huawei]vlan 2                                                                创建vlan2、3
    [Huawei-vlan2]quit
    [Huawei]vlan 3 
    [Huawei-vlan3]quit
    [Huawei]

    [Huawei] interface vlan 2
    [Huawei-Vlanif2] ip address 192.168.1.1 255.255.255.0

    [Huawei-Vlanif2] dhcp relay server-ip 12.1.1.2                      在vlan2中开启dhcp中继功能

    [Huawei-Vlanif2] quit
    [Huawei]

    [Huawei] interface vlan 3
    [Huawei-Vlanif3] ip address 192.168.2.1 255.255.255.0

    [Huawei-Vlanif3] dhcp relay server-ip 12.1.1.2                       在vlan3中开启dhcp中继功能

    [Huawei-Vlanif3] quit
    [Huawei]

    [Huawei]interface g0/0/1                                                       配置接口g0/0/1和g/0/2为access接口

    [Huawei-GigabitEthernet0/0/1]port link-type access 
    [Huawei-GigabitEthernet0/0/1]quit
    [Huawei]

    [Huawei]interface g0/0/2

    [Huawei-GigabitEthernet0/0/1]port link-type access 
    [Huawei-GigabitEthernet0/0/1]quit
    [Huawei]

    [Huawei]vlan 2                                                                      将g/0/1接口加入vlan2,g/0/2加入vlan3
    [Huawei-vlan2]port g0/0/1
    [Huawei-vlan2]quit

    [Huawei]

    [Huawei]vlan 3 
    [Huawei-vlan3]port g0/0/2

    [Huawei-vlan3]quit

    [Huawei]

    [Huawei]ip route-static 0.0.0.0 0.0.0.0 12.1.1.2                       配置能够到达dhcp服务器的路由

    [Huawei]

    [Huawei]dhcp snooping enable                                            开启全局dhcp-snooping检测功能

    [Huawei]interface g0/0/3

    [Huawei-GigabitEthernet0/0/3]dhcp snooping trusted          在连接dhcp服务器的接口信任dhcp-offer报文
    [Huawei-GigabitEthernet0/0/3]quit
    [Huawei]

    [Huawei]interface g0/0/1

    [Huawei-GigabitEthernet0/0/1]dhcp snooping enable          在连接客户端的接口不信任dhcp-offer报文,建议每个连接客户端的接口都配置dhcp-snooping,防止非法dhcp服务器提供ip地址
    [Huawei-GigabitEthernet0/0/1]quit
    [Huawei]

    [Huawei]interface g0/0/2
    [Huawei-GigabitEthernet0/0/2]dhcp snooping enable           在连接客户端的接口不信任dhcp-offer报文,建议每个连接客户端的接口都配置dhcp-snooping,防止非法dhcp服务器提供ip地址
    [Huawei-GigabitEthernet0/0/2]quit
    [Huawei]


    三、完成配置后,可以再客户端pc1和pc2上使用ipconfig/renew来获取ip地址

     



    展开全文
  • 华为路由器配置简单NAT实例

    万次阅读 多人点赞 2016-07-19 15:21:38
    session 1 NAT ...简单的配置分为静态NAT、动态NAT、端口PAT、NAT-server发布等,下面以实际配置为例: 一、静态NAT转换 AR1上配置 interface GigabitEthernet0/0/0  ip address 192.168.1.1 255.255.
  • 如果要让vlan10 ping不通vlan20,可以在R1路由器上设置普通的acl策略,阻止源为vlan10网段的ip的访问,然后把策略映射到vlan20网关的接口上 如果要让R1访问不了ftp服务器,可以在R2上做扩展acl策略,源为R1的出口ip...
  • 华为路由器AR100-S&AR110;-S&AR120;-S&AR150;-S&AR160;-S&AR200;-S&AR1200;-S&AR2200;-S&AR3200;-S 典型配置案例(命令行)(pdf)
  • 华为路由器、交换机典型配置实例,包含华为路由器模拟器,一些简单的配置实例
  • 通过与华为合作伙伴共同组织,现提供完整的华为 eNSP关于 路由器、交换机设备,配置单臂路由、链路聚合、三层交换机的实例,包含拓朴图、配置命令及详细设置,亲测可用。希望有需要的朋友下载,交流。
  • 华为路由器配置RIP协议

    千次阅读 2020-01-06 16:42:06
    1、路由器基本配置 R1: <Huawei>system-view [Huawei]sysname R1 [R1]interface g0/0/0 [R1-GigabitEthernet0/0/0]ip address 10.10.10.1 255.255.255.0 [R1-GigabitEthernet0/0/0]interface g0/0/1 [R1-...
  • 华为路由器配置VRRP(实操可跟做)

    千次阅读 2019-09-04 07:36:37
    原理性的东西我就不啰嗦了,关于华为防火墙VRRP双机热备的原理及配置大家可以参看博文华为防火墙VRRP双机热备的原理及实例配置 此博文主要是一个模拟环境,在路由器配置VRRP,模拟主路由器故障网络走备份路由器...
  • 中低端华为路由器配置实例
  • 华为路由器配置VRRP

    2020-10-23 13:21:46
    配置: R1: 配置直连 [R1]interface GigabitEthernet 0/0/1 [R1-GigabitEthernet0/0/1]ip address 192.168.1.1 24 [R1-GigabitEthernet0/0/1]quit [R1]int GigabitEthernet 0/0/0 [R1-GigabitEthernet0/0/0]ip ...
  • 华为ospf路由配置实例操作

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,940
精华内容 1,176
关键字:

华为路由器配置实例