精华内容
下载资源
问答
  • 为什么网上用ensp配置单臂路由的方案中,将网络划分为vlan2和vlan3,而不是vlan1和vlan2。 为什么会问这个问题,因为我将网络划分成了vlan1和vlan2时,按照网上的命令,pc1和pc2ping不通,划分成vlan2和vlan3的话,...
  • 路由器,交换机,华为
  • 注意:F0/1接口的配置是一个三层交换机实现单臂路由的模型: 1:配置二层交换机、划分vlan、设置trunk En Conf t Host s1 Vlan 2 Exit Vlan 3 Exit Int f0/1 Switchport access vlan 2 Int f0/2 Switchport access ...

    配置代码
    三层交换机:
    注意:F0/1接口的配置是一个三层交换机实现单臂路由的模型:
    1:配置二层交换机、划分vlan、设置trunk 
    En
    Conf t
    Host s1
    Vlan 2
    Exit
    Vlan 3
    Exit
    Int f0/1
    Switchport access vlan 2
    Int f0/2
    Switchport access vlan 3
    Int f0/3
    Switchport mode trunk
    
    2:三层交换机
    En
    Conf t
    Host s3
    Vlan 2
    Exit
    Vlan 3
    Exit
    Int vlan 2
    Ip address 192.168.1.254 255.255.255.0     —–ip为pc的网关
    Exit
    Int vlan 3
    Ip address 192.168.2.254 255.255.255.0     —–ip为pc的网关
    Int f0/1
    Switchport mode access      ——该命令是为了能设置下一条命令否则设置不成功
    
    Switchport mode trunk
    Ip routing         —–开启路由
    Int f0/3
    No switchport      ----三层交换机接口升为三层口
    Ip address 192.168.0.254 255.255.255.0
    Int f0/2   
    No switchport      ----三层交换机接口升为三层口
    Ip address 192.168.5.1 255.255.255.252
    Ip route 192.168.3.0 255.255.255.0 192.168.5.2     ---设置静态路由
    Ip route 192.168.4.0 255.255.255.0 192.168.5.2
    
    路由器r1:
    注意:F0/0接口是路由器实现单臂路由的模型,划分子接口:
    1:配置二层交换机、划分vlan、设置trunk 
    En
    Conf t
    Host s2
    Vlan 4
    Exit
    Vlan 5
    Exit
    Int f0/1
    Switchport access vlan 4
    Int f0/2
    Switchport access vlan 5
    Int f0/3
    Switchport mode trunk
    
    2:路由器:
    En
    Conf t
    Host r1
    No ip domain-lookup
    Int f0/0
    No shut
    Int f0/0.1//配置子接口
    Encapsulation dot1q 4//封装(数字在1-1005里随便选)
    Ip address 192.168.3.254 255.255.255.0
    Int f0/0.2//配置子接口
    Encapsulation dot1q 5//封装(数字在1-1005里随便选)
    Ip address 192.168.4.254 255.255.255.0
    Int f0/1
    No shut
    Ip address 192.168.5.2 255.255.255.252
    Ip route 192.168.0.0 255.255.255.0 192.168.5.1   ---设置静态路由
    Ip route 192.168.1.0 255.255.255.0 192.168.5.1
    Ip route 192.168.2.0 255.255.255.0 192.168.5.1

     

    展开全文
  • 实验:如上图公司 划分了4个局域网、分别是1.0、 2.0、 3.0...然后配置SW2交换机,命令如下:SW2>enableconfigure terminalenable secret 163.com(设置密文密码163.com)line vyt 0 4 设置虚拟端口0-4 用于远程t...

    单臂路由和交换机配置实验
    实验:如上图
    公司 划分了4个局域网、分别是1.0、 2.0、 3.0、 4.0网段,分别接到2个交换机,再连上路由器后上网,现需要4个网段能够互通。
    首先把PC机IP 按图配好。然后配置SW2交换机,命令如下:
    SW2>
    enable
    configure terminal
    enable secret 163.com(设置密文密码163.com)
    line vyt 0 4 设置虚拟端口0-4 用于远程telnet
    password 163.com
    login 设置生效
    line console 0 配置接口
    password 163.com
    login
    exit
    vlan 10创建Vlan10
    interface vlan 10进入vlan 10
    ip address 192.168.1.100 255.255.255.0 配置IP
    no shutdown 启用
    vlan 20
    interface vlan 20
    ip address 192.168.2.100 255.255.255.0
    no shutdown
    interface fa0/1
    switchport mode access 设置fa0/1端口为 access 模式
    switchport access vlan 10把端口加入vlan 10
    spanning-tree portfast 设置成快速端口
    interface fa0/2
    switchport mode access
    switchport access vlan 20
    spanning-tree portfast
    interface range fa 0/11,fa 0/13,fa 0/16 - fa 0/20
    switchport access vlan 10 把fa 0/11 13 16 17 18 19 20 端口加入Vlan10
    单臂路由和交换机配置实验

    interface fa 0/10
    switchport trunk encapsulation dot1q 把端口封装成dot1q协议
    switchport mode trunk 把 10端口设成trunk 模式,就是可以跑多个vlan
    switchport trunk allowed vlan all (允许所有vlan通过此端口,可写可不写,一般情况下trunk本来就默认所有vlan通过)
    no shutdown
    interface fa 0/5
    switchport mode trunk
    switchport trunk encapsulation
    no shutdown
    到这里SW2交换机配置完毕,查看一下有没有配置错误:查看结果和上面配置无误
    show vlan查 vlan
    show ip interface brief查IP和端口状态
    show ip running-config 查看所有配置
    单臂路由和交换机配置实验单臂路由和交换机配置实验

    右边交换机SW3配置方法一样。
    现在用PC 测试一下网络连通性、发现相同网段、相同vlan的可以互通,而不同网段不同vlan的不能通。
    单臂路由和交换机配置实验
    我再在SW2 交换机上加2台PC ,PC5 加入vlan 30 IP 192.168.3.2 ,PC6 加入vlan10 IP 192.168.3.3
    再测试互通性,得出相同网段、相同vlan的可以互通,相同网段不同vlan也是不能互通的。
    单臂路由和交换机配置实验单臂路由和交换机配置实验
    现在要在路由器R1上配置网关、使全网互通。
    enable
    configure terminal
    interface fa 0/0
    no shutdown
    interface fa 0/0.10 创建.10子接口并进入
    encapsulation dot1q 10 封装端口为dot1q 标记为10(这里要注意,标记号一定要和vlan号一致,不然有时候会导致网络不通)
    ip address 192.168.1.254 255.255.255.0配置网关IP
    no shutdown
    interface fa0/0.20
    encapsulation dot1q 20
    ip address 192.168.2.254 255.255.255.0
    no shutdown
    interface fa 0/0.30
    encapsulation dot1q 30
    ip address 192.168.3.254 255.255.255.0
    no shutdown
    interface fa 0/0.40
    encapsulation dot1q 40
    ip address 192.168.4.254 255.255.255.0
    no shutdown
    end
    单臂路由和交换机配置实验

    查看一下配置情况,看看是否正确。
    show ip interface brief
    单臂路由和交换机配置实验

    现在整个网络配置全部完成,测试一下整个网络的联通性。
    发现整个网络通不了,原来是交换机SW2 的fa 0/10连路由器的端口没有设置为trunk 模式,确记,要跑多个vlan 的端口接口处,一定要改成trunk 模式。
    再测试后,发现192.168.3.3 与其它的不通,因为在同一个网络里有一个192.168.3网段在VLAN 30 里,而3.3在VLAN 10里,所以不通. 其它的网络全是通的。

    展开全文
  • 二层交换机vlan单臂路由配置

    千次阅读 2019-11-26 09:46:01
    3、熟练掌握二层交换机vlan单臂路由实验配置过程。 二、实验内容 1、绘制拓扑图,根据拓扑图进行试验: 2、配置路由器和二层交换机,并最终验证网络的连通性。 三、实验过程 1、实验任务说明 1、配置二层vlan...

    一、实验目的

    1、掌握vlan的基本原理和作用。

    2、熟练掌握二层交换机vlan路由的定义。

    3、熟练掌握二层交换机vlan单臂路由实验配置过程。

    二、实验内容

    1、绘制拓扑图,根据拓扑图进行试验:

    2、配置路由器和二层交换机,并最终验证网络的连通性。

    三、实验过程

    1、实验任务说明

    1、配置二层vlan单臂路由,使不同网段的PC可以互通;

    2、查看配置端口状态和路由表信息,并给出说明。

    2、业务配置流程图

    3、实验配置过程

    1、switch1

    Switch>enable
    
    Switch#configure terminal
    
    Switch(config)#vlan 10             
    
    Switch(config-vlan)#exit
    
    Switch(config)#vlan 20             
    
    Switch(config-vlan)#exit
    
    Switch(config)#interface fa0/1
    
    Switch(config-if)#switchport mode access             
    
    Switch(config-if)#switchport access vlan 10             
    
    Switch(config-if)#exit
    
    Switch(config)#interface fa0/2
    
    Switch(config-if)#switchport mode access            
    
    Switch(config-if)#switchport access vlan 20           
    
    Switch(config-if)#exit
    
    Switch(config)#interface gig0/1
    
    Switch(config-if)#switchport mode trunk          
    
    Switch(config-if)#switchport trunk allowed vlan 1,10,20              
    
    Switch(config-if)#exit

    2

    Router>enable
    
    Router#configure terminal
    
    Router(config)#hostname R-WR-1
    
    R-WR-1(config)#ip routing
    
    R-WR-1(config)#interface gig0/0
    
    R-WR-1(config-if)#no shutdown
    
    R-WR-1(config-if)#exit
    
    R-WR-1(config)#interface gig0/0.1            
    
    R-WR-1(config-subif)#no shutdown            
    
    R-WR-1(config-subif)#encapsulation dot1q 10            
    
    R-WR-1(config-subif)#ip address 1.1.1.254 255.255.255.0              
    
    R-WR-1(config-subif)#exit
    
    R-WR-1(config)#interface gig0/0.2              
    
    R-WR-1(config-subif)#encapsulation dot1q 20            
    
    R-WR-1(config-subif)#ip address 1.1.2.254 255.255.255.0              
    
    R-WR-1(config-subif)#no shutdown             
    
    R-WR-1(config-subif)#exit
    
    R-WR-1(config)#exit
    
    R1#show ip interface brief
    
    R1#show ip route

     

     

    展开全文
  • 单臂路由 三层交换机原理与配置

    前言

    单臂路由
    三层交换机
    动态路由
    动态路由多区配置
    动态路由重分发

    实验目的

    结合之前所学习的单臂路由、三层交换机、动态路由配置,在一个实验拓扑图中实现PC机之间的互通

    实验环境

    实验拓扑图如下,通过配置使PC机之间互通
    在这里插入图片描述
    实验软件:GNS3、CRT

    实验过程

    (1)配置PC机的IP地址和网关
    在这里插入图片描述(2)单臂路由设置,因为路由器处于area1区域中,还需要通过ospf协议对外宣告所在的网络段,PC1与PC2通过交换机与路由器R1相连,PC1、PC2所在的网络段也在area1区域中

    sw2-1交换机配置
    在这里插入图片描述
    路由器R1配置
    在这里插入图片描述
    (3)设置路由器R3,R3在两个区域中需要分别在接口所在区域宣告网段
    在这里插入图片描述
    (4)设置路由器R4,R4处于的两个区域协议不同,需要对R4进行路由重分发,使两个区域之间能互相宣告所在网络段
    在这里插入图片描述
    (5)设置三层交换机

    sw3配置
    在这里插入图片描述在这里插入图片描述
    sw2-2配置
    在这里插入图片描述

    实验结果

    PC1与PC2、PC3、PC4互通
    在这里插入图片描述

    总结

    本实验将自己所学习的单臂路由、三层交换机、动态路由配置,结合在同一个实验中体现出来,需要注意的是单臂路由和三层交换机的配置,他们处于动态路由协议中,设置完相应的配置后,需要对所处的网络段进行宣告

    展开全文
  • 1.修改交换机名称为S1,路由器名称为R1 2.在AR1上配置子接口G0/0/0.1G0/0/0.2G0/0/0.3 3.分别在子接口上做适当配置,使得3个VLAN之间能够通信 (二)在右侧拓扑完成: 1.修改交换机名称为S2S3 2.在S2S3上做适当配置,...
  • 单臂路由单臂路由作用单臂路由原理单臂路由的命令单臂路由产生的瓶颈 单臂路由作用 1.单臂路由是为了实现不同VLAN之间的通信 2.链路类型 交换机连接主机的链路为access链路 交换机连接路由器的链路为Trunk链路 3 子...
  • 详细介绍华为交换机单臂路由配置方法(附图)
  • 单臂路由仅有1个网口 该网口同时处理WAN和LAN网络的数据 容易导致报文拥塞, 严重时甚至产生网络风暴 使用VLAN可以做到WAN口和LAN口的逻辑隔离 有效减少无用报文, 提高数据交换效率 设置思路 在n口网管交换机上 WAN ...
  • 单臂路由配置-ZTE中兴交换机

    千次阅读 2019-11-12 16:12:24
    小型局域网的实训测评 一、实验目的及要求: 1、掌握vlan的基本概念、作用、工作...5、掌握路由器的单臂路由的基本配置,实现不同vlan间的通信。 二、实验设备: 1、中兴二层交换机(2950) 2台; 2、中兴三层...
  • 网关用.254 [LSW1]vlan batch 4 7 [LSW1]int g0/0/2 [LSW1-GigabitEthernet0/0/2]port link-type access [LSW1-GigabitEthernet0/0/2]port de [LSW1-GigabitEthernet0/0/2]port default ...[LS...
  • 实验一、单臂路由实验目标在路由器上做单臂路由设置,实现不同VLAN 间的通信实验环境一台路由器,两台交换机,四台PC机,设 PC0的ip:192.168.1.1 网关:192.168.1.254PC1的ip:192.168.2.1 网关:192.168.2.254PC2...
  • 单臂路由的实现方式,其实就是普通二层交换机加路由器,从而实现不同vlan间的互相通信。 那什么是三层交换机呢? 对于小型的网络,单臂路由可以应付,但随着VLAN之间流量的不断增加,很可能导致路由器成为整个网络...
  • 华为单臂路由实验配置(共8篇)华为 AR2200路由器单臂路由配置实例华为 AR2200路由器单臂路由配置实例作者:救世主220实验日期:2015 6 29实验拓扑如下:AR5配置:[AR5]dis current-configuration[V200R003C00]sysname...
  • 背景: 为了能够使不同的vlan能够通信,而且节省路由器的端口资源,产生了单臂路由技术和三层交换技术 单臂路由 1、单臂路由介绍 通过在路由器上创建逻辑接口...交换机配置 各个交换机相连的接口配置为trunk 构建vtp
  • 目录一、 单臂路由链路类型子接口单臂路由实现不同vlan间通信的原理配置二.三层交换三层交换技术MLS条目配置三.链路聚合配置 一、 单臂路由 单臂路由实现不同vlan间通信 链路类型 交换机连接主机的端口为access链路...
  • 单臂路由及三层交换机基础知识 单臂路由概述以及原理 单臂路由—实现不同VLAN之间的通信 路由器的物理接口可以分化成多个逻辑子接口,每个子接口对应一个vlan网段的网关 原理:路由器重新封装MAC地址,转换Vlan标签 ...
  • 单臂路由与三层交换机动态配置实验01:单臂路由实验目标:通过单臂路由实现VLAN间通信实验环境:在Cisco模拟器上开启四台PC机和两台交换机和一台台路由器,实 现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通...
  • 用三层交换机来实现单臂路由,实现不同vlan间的通信,有详细的实验拓扑图和命令
  • 3、熟练掌握三层交换机vlan单臂路由实验配置过程。 二、实验内容 1、绘制拓扑图,根据拓扑图进行试验: 2、配置路由器和三层交换机,并最终验证网络的连通性。 三、实验过程 1、实验任务说明 1、配置三层vlan...
  • 单臂路由的结构是二层交换机、路由器 拓扑图和配置信息 SW1交换机的名称改为 SW1 Switch>enable # 进入特权模式 Switch#config terminal # 进入全局模式 Switch(config)#hostname SW1 #交换机的名称改为SW1 SW...
  • 单臂路由配置

    2021-03-16 11:47:00
    单臂路由配置实例一、单臂路由概述 一、单臂路由概述 单臂路由–实现不同VLAN之间的通信 路由器的物理接口可以分化为多个逻辑子接口,每个子接口对应一个vlan网段的网关 原理:路由器重新封装MAC地址,转换Vlan标签...
  • 不同vlan之间的通信:单臂路由和三层交换机 dot1q :vlan的封装标准 需要配置路由器的子接口配置每个vlanid的 网关地址对应不同的vlan传输
  • 多臂路由配置,使得两个VLAN能够通信。 (二)在右侧拓扑完成: 1.修改交换机名称为S1,路由器名称为R1 2.在AR1上配置子接口G0/0/0.1G0/0/0.2G0/0/0.3 3.分别在子接口上做适当配置,使得3个VLAN之间能够通信 三、...
  • 单臂路由带来的问题: “单臂”为网络骨干链路,容易形成网络瓶颈 子接口依然依托于物理接口,应用不灵活 VLAN间转发需要查看路由表,严重浪费设备资源 二:三层交换机,一次路由,多次交换 三:三层交换机配置: 第...
  • 一份关于VLAN间单臂路由配置计算机网络实验报告 实验的几个步骤 1搭建主机交换机路由间的拓扑图 2交换机端口配置,Access口和Trunk口 3路由器子接口配置 4PC机IP地址配置
  • 目录 1.冲突 2.VLAN原理 一.... 二....集线器/交换机的冲突域:集线器所有接口都有处于一个冲突域中,交换机一个接口一个冲突域。...交换机/路由器的广播域:交换机的所有接口处于一个广播域中,路由器一个接...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,931
精华内容 1,572
关键字:

单臂路由交换机配置