精华内容
下载资源
问答
  • 单臂路由实现vlan间通信,请使用Cisco Packet Tracer Student打开
  • 实验名称 单臂路由 实验目的 利用路由器的单臂路由功能实现VLAN间路由 背景描述 ...通过划分 VLAN 减小广播域的范围,为了节约成本并且充分利用现有设备,在路由器上配置单臂路由实现 VLAN 路...

    实验名称
    单臂路由

    实验目的
    利用路由器的单臂路由功能实现VLAN间路由

    背景描述
    为减小广播包对网络的影响,网络管理员在公司内部网络中进行了VLAN的划分。在实
    现VLAN间路由上,为节约成本充分并且利用现有设备,网络管理员计划利用路由器的单臂路由功能实现VLAN间路由。

    需求分析
    通过划分 VLAN 减小广播域的范围,为了节约成本并且充分利用现有设备,在路由器上配置单臂路由实现 VLAN 间路由。

    实验拓扑
    在这里插入图片描述

    预备知识
    交换机转发原理、交换机基本配置、单臂路由原理。

    实验原理
    VLAN间的主机通信为不同网段间的通信,需要通过三层设备对数据进行路由转发才可
    以实现,在路由器上对物理接口划分子接口并封装 802.1q 协议,使每一个子接口都充当一个 VLAN 网段中主机的网关,利用路由器的三层路由功能可以实现不同VLAN 间的通信。

    实验步骤
    路由器Router1

    Router>enable
    Router#configure terminal
    
    Router(config)#interface fastethernet 0/0 //可以简写成 int f0/0
    Router(config-if)#no ip address //确保接口没有 IP
    Router(config-if)#no shutdown //确保接口处于启动状态
    Router(config-if)#exit
    
    Router(config)#interface fastethernet 0/0.10 //进入子接口,数字自定义
    Router(config-subif)#encapsulation dot1q 10 //将接口配置上 802.1q 协议,定义给 VLAN 10。
    Router(config-subif)#ip address 192.168.10.254 255.255.255.0 //定义 IP 跟子网掩码
    Router(config-subif)#no shutdown //启用子接口
    Router(config-subif)#exit
    
    Router(config)#interface fastethernet 0/0.20 //进入子接口,数字自定义
    Router(config-subif)#encapsulation dot1q 20 //将接口配置上 802.1q 协议,定义给 VLAN 20。
    Router(config-subif)#ip address 192.168.20.254 255.255.255.0 //定义 IP 跟子网掩码
    Router(config-subif)#no shutdown //启用子接口
    
    Router(config)#interface fastethernet 0/0.30 //进入子接口,数字自定义
    Router(config-subif)#encapsulation dot1q 30 //将接口配置上 802.1q 协议,定义给 VLAN 30。
    Router(config-subif)#ip address 192.168.30.254 255.255.255.0 //定义 IP 跟子网掩码
    Router(config-subif)#no shutdown //启用子接口
    Router(config-subif)#exit
    

    二层交换机Switch0

    Switch>enable
    Switch#configure terminal
    
    Switch(config)#vlan 10
    Switch(config-vlan)#vlan 20
    Switch(config-vlan)#vlan 30
    Switch(config-vlan)#exit
    
    Switch(config)#interface fastethernet 0/1 //可以简写成 int f0/1
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#exit
    
    Switch(config)# interface fastethernet 0/2 //可以简写成 int f0/2
    Switch(config-if)#switchport access vlan 20
    Switch(config-if)#exit
    
    Switch(config)# interface fastethernet 0/3 //可以简写成 int f0/3
    Switch(config-if)#switchport access vlan 30
    Switch(config-if)#exit
    
    Switch(config)# interface fastethernet 0/24 //可以简写成 int f0/24
    Switch(config-if)#switchport mode trunk //将 f0/24 设为 tag vlan 模式
    

    PC0
    在这里插入图片描述
    PC1
    在这里插入图片描述
    PC2
    在这里插入图片描述
    实验验证
    PC0 ping PC1和PC2
    在这里插入图片描述

    注意事项
    1、在为子接口定义时候,也就是 int f0/0.10 时候,后面的 10 是自定义数字。
    2、在为子接口配置 802.1q 协议时候,也就是 enc dot1q 10 时候,后面的 10 代表着 vlan10,因为有创建 vlan 10。

    展开全文
  • 【工程实验室】【利用单臂路由实现VLAN间路由】
  • 单臂路由实现vlan间路由 在SW2上创建vlan10 和vlan 20 [SW2]vlan 10 [SW2-vlan10]description HR [SW2-vlan10]vlan 20 [SW2-vlan20]description Market [SW2-vlan20]interface Ethernet 0/0/1 [SW2-Ethernet0/0/1]...

    单臂路由实现vlan间路由

    在这里插入图片描述
    在SW2上创建vlan10 和vlan 20
    [SW2]vlan 10
    [SW2-vlan10]description HR
    [SW2-vlan10]vlan 20
    [SW2-vlan20]description Market
    [SW2-vlan20]interface Ethernet 0/0/1
    [SW2-Ethernet0/0/1]port link-type access
    [SW2-Ethernet0/0/1]port default vlan 10
    [SW2-Ethernet0/0/1]interface Ethernet 0/0/2
    [SW2-Ethernet0/0/2]port link-type access
    [SW2-Ethernet0/0/2]port default vlan 20
    [SW2-Ethernet0/0/2]interface GigabitEthernet 0/0/2
    [SW2-GigabitEthernet0/0/2]port link-type trunk
    [SW2-GigabitEthernet0/0/2]port trunk allow-pass vlan all

    [SW3]vlan 30
    [SW3-vlan30]description Manager
    [SW3-vlan30]interface Ethernet 0/0/1
    [SW3-Ethernet0/0/1]port link-type access
    [SW3-Ethernet0/0/1]port default vlan 30
    [SW3-Ethernet0/0/1]interface GigabitEthernet 0/0/2
    [SW3-GigabitEthernet0/0/2]port link-type trunk
    [SW3-GigabitEthernet0/0/2]port trunk allow-pass vlan all

    [SW1]vlan 10
    [SW1-vlan10]vlan 20
    [SW1-vlan20]vlan 30
    [SW1-vlan30]interface GigabitEthernet 0/0/2
    [SW1-GigabitEthernet0/0/2]port link-type trunk
    [SW1-GigabitEthernet0/0/2]port trunk allow-pass vlan all
    [SW1-GigabitEthernet0/0/2]interface GigabitEthernet 0/0/3
    [SW1-GigabitEthernet0/0/3]port link-type trunk
    [SW1-GigabitEthernet0/0/3]port trunk allow-pass vlan all
    [SW1-GigabitEthernet0/0/3]interface GigabitEthernet 0/0/1
    [SW1-GigabitEthernet0/0/1]port link-type trunk
    [SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan all

    由于路由器只有一个实际的物理接口与SW1相连接,可以在路由器上配置不同逻辑子接口来作为不同vlan的网关(物理接到哪个口,就用哪个口来创建子接口)。
    [R1]interface GigabitEthernet 0/0/1.1
    [R1-GigabitEthernet0/0/1.1]ip address 192.168.1.254
    使用dot1q termination vid 10 命令配置子接口对一层tag报文的终结功能,路由器子接口在接收带有vlan tag的报文时,将剥掉tag进行三层转发,在发送报文时,会将与该子接口对应vlan的vlan tag添加到报文中
    [R1-GigabitEthernet0/0/1.1]dot1q termination vid 10
    使用arp broadcast enable开启子接口的arp广播功能,如果不配置该命令,会导致该子接口无法主动发送ARP广播报文,以及向外转发IP报文
    [R1-GigabitEthernet0/0/1.1]arp broadcast enable
    [R1]interface GigabitEthernet 0/0/1.2
    [R1-GigabitEthernet0/0/1.2]ip address 192.168.2.254
    [R1-GigabitEthernet0/0/1.2]dot1q termination vid 20
    [R1-GigabitEthernet0/0/1.2]arp broadcast enable
    [R1]interface GigabitEthernet 0/0/1.3
    [R1-GigabitEthernet0/0/1.3]ip address 192.168.3.254
    [R1-GigabitEthernet0/0/1.3]dot1q termination vid 30
    [R1-GigabitEthernet0/0/1.3]arp broadcast enable
    用PC1 ping PC2 PC3
    PC>ping 192.168.2.1
    Ping 192.168.2.1: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.1: bytes=32 seq=2 ttl=127 time=125 ms
    From 192.168.2.1: bytes=32 seq=3 ttl=127 time=125 ms

    PC>ping 192.168.3.1
    Ping 192.168.3.1: 32 data bytes, Press Ctrl_C to break
    From 192.168.3.1: bytes=32 seq=2 ttl=127 time=125 ms
    From 192.168.3.1: bytes=32 seq=3 ttl=127 time=109 ms

    展开全文
  • 3.4利用单臂路由实现vlan间路由原理概述一、实验目的及编址二、实验拓扑二、实验内容1.配置ip地址 默认ping不通2.在s2 s3先创建vlan 并将连接pc的接口绑定相应vlan2. 交换机之间需要传递更多的vlan 信息配turnk3....


    原理概述

    以太网中使用vlan技术隔离二层广播来减少广播的影响,增加网络的安全 性和可管理性。缺点是严格隔离了所有vlan间流量。单臂路由就是实现vlan间通信的一种方法。
    原理是vlan间的流量一使用路由器来进行三层转发。通过路由器配置子接口,不同子接口作为不同的vlan网关。vlan间数据先发送给网关,网关处理后在发送致该主机所以的vlan。


    一、实验目的及编址

    理解单臂路由 路由器子接口的配置方法 工作 原理

    模拟企业网,r1是公司的出口网关。员工通过接入交换机接入入网,接入层交换机通过汇聚交换机与r1相连。公司内部划分不同vlan来隔离二层 通信。由于业务需要vlan 1 0 20 30 都需要实现跨vlan通论。借助r1来实现单臂路由

    在这里插入图片描述
    )

    二、实验拓扑

    在这里插入图片描述

    二、实验内容

    1.配置ip地址 默认ping不通

    2.在s2 s3先创建vlan 并将连接pc的接口绑定相应vlan

    s2
    vlan batch 10 20 
    进入相应接口
    port link-tyep access
    port default vlan n
    
    s1:
    vlan 30 
    port link-tyep access
    port default vlan n
    
    

    2. 交换机之间需要传递更多的vlan 信息配turnk

     s2 s3 
    port link-type trunk
    port trunk allow-pass vlan all
    
    s1 :先创建vlan 10 20 30 
    在把连接交换机和路由器链路接口都设置成trunk
    
    

    3.封装 vlan

    成功 但尝试ping了一下还是不通 目的网络不可达 why?
    因为路由器接收到的数据是带vlan tag的 路由器无法处理。
    因为需要在接口下配置对应的vlan封装 使路由器能够 识别处理 包括剥离带标签的vlan标签 。需要使用dot1q termination vid vlan n
    让路由器接收到带有vlan tag的报文时,将剥掉tag 来进行3层转发。
    在发送报文时,会将与该子接口对应的vlan的vlan tag添加到报文中。

    arp广播一定要开启

    在路由器不同的子接口下
    
    ```bash
    do1t termination vid n
    
    display ip int bri查看接口状态
    

    已经可以通了
    在这里插入图片描述
    ``


    在华为ar路由器上默认不会向外发送icmp端口不可达消息,需要开启 保证tarcert的测试准确性

    总结与思考

    利用单臂路由来实现数据转发会存在哪些问题,如何解决

    两个问题 一个是单点故障 二是一条链路可能 会成为整个网络的传输瓶颈 利用三层交换机会实现vlan间路由会解决单臂路由的问题

    展开全文
  • 防火墙做单臂路由实现VLAN间通信网络设备:1台USG2130,若干S2700交换机客户需求:交换机上划分VLAN,并在USG2130上做单臂路由,同时要求三个网段之间可以互访,而且三个网段都是可以上INTERNET由于USG2130仅有一个...

    防火墙做单臂路由实现

    VLAN

    间通信

    网络设备

    1

    USG2130

    ,若干

    S2700

    交换

    客户需求:

    交换

    机上划分

    VLAN

    ,并在

    USG2130

    上做单臂

    路由

    ,同时要求三个网段之间可以互访,

    而且三个网段都是可以上

    INTERNET

    由于

    USG2130

    仅有一个三层接口

    WAN

    口,

    支持子接口的端口也是

    WAN

    (即

    E0/0/0

    )

    ,

    基于目前需求,

    现须将该端口作为内网接口。再通过创建

    VLAN

    ,将其中一个

    VLAN

    接口作为

    互联网

    接口。

    若将各

    VLAN

    放在同一个区域,实现

    VLAN

    间访问控制比较复杂。若将各

    VLAN

    子接口划分到不同的

    区域,通过域间包滤的方式实现,既简单又可靠。

    重要配置如下:

    1

    、进入子接口,配置

    IP

    地址,并进行

    802.1Q

    封装。

    [USG2130]int e0/0/0.1

    [USG2130-Ethernet0/0/0.1]description VLAN10

    [USG2130-Ethernet0/0/0.1]ip address 192.168.1.1 24

    [USG2130-Ethernet0/0/0.1]vlan-type dot1q 10

    展开全文
  • 单臂路由实现VLAN间通信

    千次阅读 2019-12-12 17:36:23
    单臂路由的原理是通过一台路由器,使VLAN间通过路由器的三层转发能够互通数据,在路由器的一个物理接口通过配置子接口(即逻辑接口)的方式来实现以一当多的功能、路由器同一物理接口的不同子接口作为不同VLAN的默认...
  • eNSP-利用单臂路由实现VLAN 路由 原理概述 以太网中, 通常会使用VLAN 技术隔离二层广播域来减少广播的影响,并增强网络的安全性和可管理性。其缺点是同时也严格地隔离了不同VLAN 之间的任何二层流量,使分属于...
  • 单臂路由实现VLAN间相互通信

    千次阅读 2020-07-10 23:51:17
    单臂路由实现vlan间相互通信 概述 单臂路由是指路由器的一个网络端口上通过配置子接口(或者逻辑接口,即不存在真的物理子接口)的方式,实现相互隔离的不同VLAN之间的互联互通。单臂路由的结构。 配置子接口时,...
  • 我们将以上面的拓扑图开始进行配置,目的为设置单臂路由实现vlan间通信,设置4个vlan,pc0,1,2为vlan10 pc3,4,5为vlan20;pc6,7,8为vlan30;server0,1为vlan40,为求方便,我们使用vtp来配置vlan配置...
  • 单臂路由实现vlan间的通信 首先要用到vtp协议 switch 5 配置 Switch(config)#vtp domain test switch 4配置 Switch(config)#vtp domain testChanging VTP domain name from NULL to testSwitch(config)#vtp ...
  • 【实验名称】利用单臂路由实现VLAN间路由。【实验目的】掌握如何在路由器上划分子接口、封装Dot1q(IEEE 802.1q)协议,实现VLAN间的路由。【需求分析】 需要在交换机上配置VLAN,然后在路由器连接交换机的端口上划...
  • 【实验名称】利用单臂路由实现VLAN间路由【实验目的】掌握如何在路由器端口上划分接口、封装Dotlq协议,实现VLAN间的路由。【需求分析】需要在交换机上配置VLAN,然后在路由器连接交换机的端口上划分接口,给相应的...
  • 单臂路由配置,实迂曲VLAN间访问访配置实例,附图详细步骤
  • 1、实验名称利用单臂路由实现VLAN间路由2、实验目的掌握如何在路由器端口上划分子接口、封装Dotlq协议,实现VLAN间的路由。3、背景描述假设某企业有两个主要部门:销售部和技术部,员工都连接在1台二层交换机上,...
  • 上篇文章讲了VLAN局限性,解决VLAN间通信问题的三种方法,今天,我们开始讲单臂路由配置单臂路由是什么? 为什么要使用单臂路由单臂路由配置 交换机LSW1的配置 sys vlan batch 20 30 inter e0/0/1...
  • 通过单臂路由实现VALN路由实验,熟悉单臂路由的基本配置指令,掌握单臂路由的用处。 二、实验设备 Ensp 三、实验拓扑图 四、实验内容与主要步骤 (1)延续配置跨环境的vlan的实验拓扑图及配置,将PC的IP从192.168...
  • 实验50:单臂路由实现VLAN间路由 1.实验目的 通过本实验,读者可以掌握如下...(2)单臂路由实现VLAN间路由的配置 2.实验拓扑 拓扑图 3.实验步骤 Switch#vlan da % Warning: It is recommended to configu...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,565
精华内容 1,826
关键字:

单臂路由实现vlan间路由的配置