精华内容
下载资源
问答
  • 华为交换机VLAN间通信

    2019-03-21 16:46:27
    使用华为模拟器做实验,模拟交换机VLAN进行间通信实现互通
  • 上一篇文章讲了vlan间不能通信的实现方法,这次来讲一下,如何在华为交换机上实现vlan间通信的实现方法。由于划分vlan的目的只是要更加安全一点,并不是以隔离他们的通信为主要目的,所以配置好vlan以后,两个不同...

    上一篇文章讲了vlan间不能通信的实现方法,这次来讲一下,如何在华为交换机上实现vlan间通信的实现方法。

    由于划分vlan的目的只是要更加安全一点,并不是以隔离他们的通信为主要目的,所以配置好vlan以后,两个不同部门的人如何实现通信,还是要进行配置的。

    被Vlan隔离的部门的相互通信,我们可以在交换机上的虚拟接口开启以后来实现。划分VLAN后,为了实现VLAN间通信,可通过配置逻辑的三层接口接口来实现(华为交换机的逻辑接口一般我们是用vlanif来表示)。

    VLAN内主机的缺省网关必须是对应VLANIF接口的IP地址,也就是说虚拟接口的IP地址就是这个vlan内的默认网关。下面看一下案例。

    实验一个交换机下面两个vlan能通信的案例

    拓扑图如下图

    d84d267a7b054ec013b0fba57b92c87f.png

    配置如下

    要是想相互通信的话,就开启虚拟接口,也就是配置上虚拟接口的IP地址,就可以vlan间相互通信了。

    [SW1]interface vlanif 1

    [SW1-Vlanif1]ip address 192.168.1.1 24

    [SW1]interface vlanif 2

    [SW1-Vlanif2]ip address 192.168.2.1 24

    测试如下图

    要实现的是

    1、 PC1可以ping通PC2

    f8a10fb49525186c0afb47fc72df0b60.png

    2、 PC1可以ping通PC3、PC4

    af93b4c50df25479f37eb79318f1eff2.png
    4b0419b7250282a57b8e31ef5450aaae.png

    模拟环境:华为eNSP

    展开全文
  • 一、三层交换机VLAN路由功能解决不同VLAN间通信二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN 的划分、VLAN 内部的二层交换和VLAN 间路由的功能。三层交换机vlanif 接口up 条件...

    VLAN 隔离广播的同时,也禁止了不同VLAN 之间的用户通信,VLAN 间的通信成为新的焦点,VLAN 路由( 三层路由功能) 成功地解决了VLAN 间的通信。

    一、三层交换机VLAN路由功能解决不同VLAN间通信

    二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN 的划分、VLAN 内部的二层交换和VLAN 间路由的功能。

    d4d97e3871d947f28fd58e98d3635a0f.png

    三层交换机

    vlanif 接口up 条件:

    1.必须存在该vlan

    2.必须有接口属于该vlan中,并且该接口必须处于活动接口

    3.如果接口是trunk接口,必须要允许相对应的vlan通过

    2、单臂路由解决不同VLAN间通信

    三层交换机:一次路由,多次交换

    二、单臂路由解决方案:

    dc1c912e0d082c526caee6e99ad93e0c.png

    传统的三层以太网接口不支持VLAN报文,当收到VLAN报文时,会将VLAN报文当成非法报文而丢弃。为了实现VLAN间互通,在三层以太网接口上可创建以太网子接口,通过在子接口上部署终结子接口功能将VLAN报文中的Tag剥掉

    ,从而实现VLAN间互通。

    交换机SW1配置创建VLAN并接口划分VLAN:

    734820032a1cfb7f126510ea2ff88e5e.png

    interface Ethernet0/0/11

    port link-type trunk

    port trunk allow-pass vlan 10 20 上联路由器接口配置trunk

    interface GigabitEthernet0/0/0 // 接口使能up

    interface GigabitEthernet0/0/0.10 //配置子接口

    dot1q termination vid 10 //dot1q 终结 vlan 10

    arp broadcast enable //默认情况下,关闭ARP 广播,开启ARP广播功能

    ip address 10.1.10.254 255.255.255.0 //配置子接口IP地址

    interface GigabitEthernet0/0/0.20

    dot1q termination vid 20

    ip address 10.1.20.254 255.255.255.0

    arp broadcast enable

    PC1与PC2可以实现正常通信:

    7f585a8e12911b67692da035f668db9f.png

    欢迎关注和转发,想深入学习更多网络技术或者有问题需要咨询,可以单独私信交流!

    展开全文
  • 华为三层交换机VLAN间通信

    千次阅读 2018-09-11 10:22:01
    Sw1: [SW1]SYS Sw1 ...[Sw1]vlan batch 100 200 [Sw1-GigabitEthernet0/0/1]port link-type trunk [Sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan all [Sw1-GigabitEthernet0/0/1]qu...

    这里写图片描述

    Sw1:

    [SW1]SYS Sw1
    [Sw1]int g0/0/1
    [Sw1]vlan batch 100 200
    [Sw1-GigabitEthernet0/0/1]port link-type trunk
    [Sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [Sw1-GigabitEthernet0/0/1]qu
    [Sw1]int Vlanif 100
    [Sw1-Vlanif100]ip add 1.1.1.254 24
    [Sw1-Vlanif100]quit
    [Sw1]int Vlanif 200
    [Sw1-Vlanif200]ip add 2.2.2.254 24
    [Sw1-Vlanif200]quit
    [Sw1]

    Sw2:

    [Huawei]sys SW2
    [Sw2]vlan batch 100 200
    [Sw2]interface e0/0/1
    [Sw2-Ethernet0/0/1]port trunk allow-pass vlan all
    [Sw2-Ethernet0/0/1]quit
    [Sw2]int E0/0/2
    [Sw2-Ethernet0/0/2]port link-type acc
    [Sw2-Ethernet0/0/2]port def vlan 100
    [Sw2-Ethernet0/0/2]quit
    [Sw2]int e0/0/3
    [Sw2-Ethernet0/0/3]port link-type acc
    [Sw2-Ethernet0/0/3]port def vlan 200
    [Sw2-Ethernet0/0/2]quit
    [Sw2]

    展开全文
  • 三层交换机实现VLAN间路由(思科、华为)配置、实例华为三层交换机VLAN间路由配置:(1)在二层交换机上配置VLAN2、VLAN3,分别将端口2、端口3划到VLAN2、VLAN3;(2)将二层交换机与三层交换机相连的端口F0/1都定义为...

    三层交换机实现VLAN间路由(思科、华为)配置、实例

    华为三层交换机VLAN间路由配置:

    0ec65f9feedce8e25ce73f03f8e13322.png

    (1)在二层交换机上配置VLAN2、VLAN3,分别将端口2、端口3划到VLAN2、VLAN3;

    (2)将二层交换机与三层交换机相连的端口F0/1都定义为trunk模式;

    (3)在三层交换机上配置VLAN2、VLAN3,此时验证二层交换机VLAN2、VLAN3下带主机之间不能互相通信;

    (4)设置三层交换机VLAN间通信,创建VLAN2、3的虚拟接口,并配置虚拟接口VLAN2、3的IP地址;

    (5)查看三层交换机路由表

    (6)将二层交换机VLAN2、VLAN3下的主机默认网关分别设置为相应虚拟接口的IP地址;

    (7)验证二层交换机VLAN2、VLAN3下的主机之间可以互相通信;

    (1)在二层交换机上配置VLAN2、VLAN3,分别将端口2、端口3划到VLAN2、VLAN3;

    [Switch2]vlan 2

    [Switch2-vlan2]port Ethernet 0/2

    [Switch2-vlan2]vlan 3

    [Switch2-vlan3]port ethernet 0/3

    [Switch2-vlan3]quit

    (2) 两主机互ping,不通;

    (3) 定义二层交换机与三层交换机相连的端口F0/1为tag vlan (trunk)模式,允许所有vlan通过;

    [Switch2]interfa e 0/1 (进入交换机接口0/1)

    [Switch2-Ethernet0/1]port link-type trunk (将端口设置为trunk)

    [Switch2-Ethernet0/1] port trunk permit vlan all //允许所有vlan通过。

    [Switch2-Ethernet0/1]quit

    [Switch3]interface e 1/0/1

    [Switch3-Ethernet1/0/1]port link-type trunk

    [Switch3-Ethernet1/0/1] port trunk permit vlan all

    [Switch2-Ethernet0/1]quit

    (4) 设置三层交换机VLAN间通信,创建VLAN2、3的虚拟接口,并配置虚拟接口VLAN2、3的IP地址;(先创建VLAN2、VLAN3)

    [Switch3]vlan 2 //创建vlan 2

    [Switch3-vlan2] port e 1/0/2

    [Switch3-vlan2]vlan 3

    [Switch3-vlan3]interface vlan 2 //进入vlan 2虚接口

    [Switch3-Vlan-interface2]ip address 192.168.2.1 255.255.255.0

    [Switch3-Vlan-interface2]undo shutdown

    VLAN3的虚拟接口配置同上(ip address 192.168.3.1 255.255.255.0);

    (5) 查看交换机路由表

    [Switch3]dis ip routing-table

    (6) 将二层、三层交换机VLAN2、VLAN3下带主机默认网关分别设置为相应虚拟接口的IP地址;

    【实训测试】

    (1)用网线将计算机和交换机的以太口相连,计算机的默认网关分别设为192.168.2.1、 192.168.3.1

    (2)计算机pc1、pc2、pc3的ip地址分别设置为192.168.2.2; 192.168.3.2和192.168.2.3

    (3)在计算机上ping 默认网关地址192.168.2.1

    (4) ping通后,ping 对方的默认网关地址192.168.3.1 及主机地址192.168.3.2;

    思科应用三层交换机实现VLAN间路由实例

    一、案例背景及需求

    某公司的网络原有两台两层交换机,分别是交换机A和交换机B。在这两台交换机上划分了两个VLAN,即VLAN1和 VLAN2.两台交换机通过trunk端口相连,使得两台交换机上的两个VLAN的主机可以在各种VLAN内通信,而两个VLAN间不能通信。由于业务增长,公司开始扩大,人员开始增加,原有交换机已经不能全部接入公司主机了,而且,由于业务需要,原有两个VLAN需要能够通信。

    二、案例分析

    原有的两个VLAN之间不能通信,这是由于二层交换机不具备三层交换的能力,不能在VLAN之间提供路由。

    如果需要为两个VLAN之间提供路由,则必须在网络中添加路由器或者三层交换机这样的路由设备。

    而由于该公司主机太多,现有两个交换机已经接满,无法再连接主机,所以需要购置三层交换机来接入增加的主机,同时为两个VLAN之间提供路由能力,连通两个VLAN的主机。

    三、案例解决

    我们应将交换机A、交换机B和三层交换机A利用trunk端口相连,并使他们共同属于一个VTP域,在此VTP域中有两个VLAN:VLAN1和VLAN2,交换机A和交换机B各有若干台主机属于这两个VLAN,提供三层交换机A上进行VLAN间路由的配置,从而实现VLAN1和VLAN2中主机的通信。

    四、配置步骤及配置实例

    1、配置trunk端口

    Switch# configure teminal //进入全局配置模式

    Switch(config)#interface interface-id //进入交换机指定端口

    Switch(config-if)#switchport mode trunk //将该端口设置为trunk属性

    2、配置VTP域

    Switch# configure teminal //进入全局配置模式

    Switch(config)#vtp domain name //配置管理域名 1-32个字符

    Switch(config)#vtp {client|server|transparent} //配置交换机VTP模式,默认情况下,交换机的VTP都是 server模式

    3、配置VLAN

    Switch#vlan database //进入VLAN数据库

    Switch(vlan)#vlan vlan-number //声明VLAN号 vlan-number是我们配置的VLAN号

    Switch(vlan)#exit //退出

    进入所有分配的端口,将该端口分配给某VLAN

    Switch(config)#interface port-number //指定欲配置接口

    Switch(config-if)#switchport mode access //规定该端口为访问链路

    Switch(config-if)#switchport access vlan vlan-number //使该端口属于某个VLAN

    Switch(config-if)#exit //退出

    4、配置VLAN间路由

    目前,使用三层交换机的路由模块为VLAN之间做路由是非常普遍的。由于三层交换机的路由模块和交换模块直接通过交换机的背板总线连接,所以只需要在三层交换机的路由模块上定义与VLAN数量相当的逻辑接口,并使这些接口和VLAN对应,为这些接口分配IP地址即可。

    下面是一个在三层交换机上为VLAN做路由的简单配置:

    Router(config)#interface vlan1

    Router(config-if)#ip add 192.168.1.1 255.255.255.0

    Router(config-if)#interface vlan2

    Router(config-if)#ip add 192.168.2.1 255.255.255.0

    其中interface vlan1和interface vlan2是逻辑上的接口,从接口的名字我们也能看出其与VLAN之间的对应关系。基本上,只要在这些逻辑接口上分配了属于VLAN所对应子网的IP地址,就可以简单的实现VLAN间的通信了。 另外,在三层交换机上需要使用如下命令打开其路由功能:

    Router(config)#ip routing

    文章摘抄自网络,侵删。

    展开全文
  • 华为三层交换机VLAN间路由怎么设置三层交换机怎么设置VLAN间路由?三层交换机相当于交换机和路由器的结合,可以生鲜不同VLAN的PC之间进行通信,下面我们就来看看三层交换机设置vlan路由的方法,需要的朋友可以参考下...
  • 一、三层交换机VLAN路由功能解决不同VLAN间通信 二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN 的划分、VLAN 内部的二层交换和VLAN 间路由的功能。 三层交换机 vlanif ...
  • 为了实现VLAN间通信,可通过配置逻辑的三层接口——VLANIF接口来实现。当VLAN中接口状态变为Down而引起VLAN状态变为Down时,VLAN会向VLANIF接口上报Down事件,从而引起VLANIF接口状态变化。为避免由于VLANIF接口状态...
  • Huawei>SYS Enter system view, return user view with Ctrl+Z. [Huawei]sys swh1 [swh1] [swh1]int g0/0/1 [swh1-GigabitEthernet0/0/1]port link-type access [swh1-GigabitEthernet0/0/1]int g0/0/2 [swh1-...
  • 一、三层交换机VLAN路由功能解决不同VLAN间通信二层交换机和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN 的划分、VLAN 内部的二层交换和VLAN 间路由的功能。三层交换机vlanif 接口up 条件...
  • Cisco 三层交换机实现VLAN间路由华为三层交换机VLAN间路由配置: (1)在二层交换机上配置VLAN2、VLAN3,分别将端口2、端口3划到VLAN2、VLAN3; (2)将二层交换机与三层交换机相连的... (4)设置三层交换机VLAN间通信,...
  • 用防火墙来实现vlan间通信。不过好像不太稳定,配置好了可以用,再重启就不可以用了。配置防火墙FW1创建vlansys[SRG]sysname FW1[FW1]vlan 1[FW1-vlan-1]quit[FW1]vlan 2[FW1-vlan-2]quit[FW1]vlan 3[FW1-vlan-3]...
  • ·掌握通过三层交换机实现VLAN间通信的配置方法 ·掌握通过以太网Trunk链路实现VLAN间通信的配置方法 拓扑图 图1.4 三层交换实验拓扑图 场景 在企业网络中,通过使用三层交换机可以简便的实现...
  • 交换机实现vlan间通信交换机1(左) undo terminal monitor system-view [Huawei]sysname sw1 [sw1]vlan batch 10 20 [sw1]int e0/0/1 [sw1-Ethernet0/0/1]port link-type access [sw1-Ethernet0/0/1]port ...
  • 为了实现VLAN间通信,可通过配置逻辑的三层接口——VLANIF接口来实现。当VLAN中接口状态变为Down而引起VLAN状态变为Down时,VLAN会向VLANIF接口上报Down事件,从而引起VLANIF接口状态变化。为避免由于VLANIF接口状态...
  • 华为S5700交换机配置 不同vlan 间通信—eNSP 实验目的 实现不同交换机上不同vlan间的通信 要求 1、根据实验要求配置实验拓扑如下图所示(注意同一个vlanif 下的 不同交换机的网关地址必须一样,不然不能通信,LSW1 ...
  • 三层交换机一般用在企业网和教学网的核心层,其千兆端口、百兆端口下连不同的VLAN,实现通信。需要注意的是,三层交换机的作用是加快大型局域网内部的数据交换,所具备的部分路由功能也是为了数据交换展开,路由...
  • 拓扑图: W1配置: <Huawei>system-view [Huawei]vlan batch 10 20 ...[Huawei-Vlanif10]interface vlanif 20 [Huawei-Vlanif20]ip address 192.168.2.1 24 [Huawei-Vlanif20]quit [Huawei]interface g
  • (1)在二层交换机上配置VLAN2、VLAN3,分别将端口2、端口3划到VLAN2、VLAN3;(2)将二层交换机与三层交换机相连的端口F0/1都...(4)设置三层交换机VLAN间通信,创建VLAN2、3的虚拟接口,并配置虚拟接口VLAN2、3的...
  • 华为三层交换机实现不同vlan间通信

    千次阅读 2018-01-04 23:49:25
    实验名称:华为三层交换机实现不同vlan间通信实验目的:pc1/pc2/pc3实现通信实验拓扑:实验步骤:1.配置PC机2.配置三层交换机<huawei>syste-mview[huawei]sysname gateway[gateway]vlan batch 10 20 30...
  • 早期以太网是一种基于CSMA/CD(Carrier Sense Multiple ...在这种情况下出现了VLAN技术,这种技术可以把一个LAN划分成多个逻辑的VLAN,每个VLAN是一个广播域,VLAN内的主机间通信就和在一个LAN内一样,而VLAN间则不能
  • 前面我们曾提到关于vlan组网及一些配置,仍然有不少的朋友问到关于交换机的配置?...要实现vlan间通信,就需要路由;解决的方法要么是二层交换机加路由器,要么就是直接使用三层交换机,为什么要使用...

空空如也

空空如也

1 2 3 4 5 ... 7
收藏数 130
精华内容 52
关键字:

华为交换机vlan间通信