精华内容
下载资源
问答
  • 文件粉碎bat
  • MFC文件粉碎代码

    2012-02-29 09:11:47
    这是一个按照美国标准来实现的粉碎文件的一段MFC代码,详细信息见代码解释,不足之处请指出,谢谢。
  • 文件名FileID = 打开文件 (通用对话框1.文件名, , #禁止读写).如果 (FileID ≠ 0)编辑框2.加入文本 (“文件名:” + 取文本右边 (通用对话框1.文件名, 取文本长度 (通用对话框1.文件名) - 倒找文本 (通用对话框1....

    .程序集变量 FileID, 整数型

    .子程序 _按钮1_被单击

    .如果真 (通用对话框1.打开 ())

    编辑框1.内容 = 通用对话框1.文件名

    FileID = 打开文件 (通用对话框1.文件名, , #禁止读写)

    .如果 (FileID ≠ 0)

    编辑框2.加入文本 (“文件名:” + 取文本右边 (通用对话框1.文件名, 取文本长度 (通用对话框1.文件名) - 倒找文本 (通用对话框1.文件名, “\”, , 真)) + #换行符)

    编辑框2.加入文本 (“目录:” + 取文本左边 (通用对话框1.文件名, 倒找文本 (通用对话框1.文件名, “\”, , 真) - 1) + #换行符)

    编辑框2.加入文本 (“粉碎后可释放空间:” + 数值到格式文本 (取文件长度 (FileID), , 真) + “ 字节” + #换行符)

    连续赋值 (假, 按钮2.禁止, 按钮3.禁止)

    连续赋值 (真, 按钮1.禁止, 编辑框1.禁止)

    .否则

    编辑框2.加入文本 (“文件载入失败,无法完成粉碎。”)

    .如果结束

    .如果真结束

    .子程序 _按钮2_被单击

    .局部变量 Temp_byte, 字节集

    .局部变量 id, 整数型

    .如果真 (信息框 (“该操作不可恢复,确定继续吗?”, 36, “询问:”) = #是钮)

    连续赋值 (真, 按钮2.禁止, 按钮3.禁止)

    删除数据 (FileID, 取文件长度 (FileID))

    延时 (50)

    进度条1.位置 = 20

    id = 打开内存文件 ()

    写出字节集 (id, 取空白字节集 (取文件长度 (FileID)))

    移到文件首 (id)

    延时 (50)

    进度条1.位置 = 40

    写出字节集 (FileID, 读入字节集 (id, 取文件长度 (id)))

    延时 (50)

    进度条1.位置 = 60

    删除数据 (FileID, 取文件长度 (FileID))

    删除数据 (id, 取文件长度 (id))

    延时 (50)

    进度条1.位置 = 80

    关闭文件 (id)

    关闭文件 (FileID)

    删除文件 (通用对话框1.文件名)

    延时 (50)

    进度条1.位置 = 100

    连续赋值 (假, 按钮1.禁止, 编辑框1.禁止)

    编辑框2.加入文本 (“粉碎时间:” + 时间到文本 (取现行时间 (), ) + #换行符)

    编辑框2.加入文本 (“文件粉碎成功。” + #换行符 + “———————————————————” + #换行符 + #换行符)

    延时 (1000)

    进度条1.位置 = 0

    编辑框1.内容 = “”

    .如果真结束

    .子程序 _编辑框2_内容被改变

    编辑框2.起始选择位置 = -1

    .子程序 _按钮3_被单击

    关闭文件 (FileID)

    连续赋值 (假, 按钮1.禁止, 编辑框1.禁止)

    连续赋值 (真, 按钮2.禁止, 按钮3.禁止)

    编辑框1.内容 = “”

    编辑框2.加入文本 (“取消粉碎:” + 时间到文本 (取现行时间 (), ) + #换行符 + “———————————————————” + #换行符 + #换行符)

    展开全文
  • 顽固文件粉碎工具主要功能可帮助用户来快速的删除电脑上被占用的文件,可同时删除右键关联菜单,同时为您提供了DLL文件卸载,进程管理,注入进程,文件分析等功能。 使用方法: 1、将要删除的文件拖入至软件中。 2、...
  • C#强烈粉碎文件代码

    2015-06-05 16:17:12
    360的文件粉碎机还是很强大的,在我们客户端winform升级的时候,必须将有些文件进行强力删除后下载更新,如果删除失败很有可能整个 程序就无法更新到最新的版本,所以这里参考了网上的资料整理了一个文件粉碎的小...

    360的文件粉碎机还是很强大的,在我们客户端winform升级的时候,必须将有些文件进行强力删除后下载更新,如果删除失败很有可能整个 程序就无法更新到最新的版本,所以这里参考了网上的资料整理了一个文件粉碎的小demo,总结了一个类出来,方便以后升级或者其他开发工作的调用

    程序运行界面截图

    操作gif动画图片

    整理的实际类,为了以后使用,提高工作效率

    //-------------------------------------------------------------------------------------
    // All Rights Reserved , Copyright (C) 2015 , ZTO , Ltd .
    //-------------------------------------------------------------------------------------
    
    using System;
    using System.Diagnostics;
    using System.IO;
    using System.Text.RegularExpressions;
    
    namespace ZTO.WayBill.Utilities
    {
        /// <summary>
        /// 文件帮助类
        ///
        /// 修改纪录
        ///
        ///          2015-6-5  版本:1.0 YangHengLian 创建主键,注意命名空间的排序。
        /// 
        /// 版本:1.0
        ///
        /// <author>
        ///        <name>YangHengLian</name>
        ///        <date>2015-6-5</date>
        /// </author>
        /// </summary>
        public class FileHelper
        {
            /// <summary>
            /// 强力粉碎文件,文件如果被打开,很难粉碎
            /// </summary>
            /// <param name="filename">文件全路径</param>
            /// <param name="deleteCount">删除次数</param>
            /// <param name="randomData">随机数据填充文件,默认true</param>
            /// <param name="blanks">空白填充文件,默认false</param>
            /// <returns>true:粉碎成功,false:粉碎失败</returns>
            public static bool KillFile(string filename, int deleteCount, bool randomData = true, bool blanks = false)
            {
                const int bufferLength = 1024000;
                bool ret = true;
                try
                {
                    using (FileStream stream = new FileStream(filename, FileMode.Open, FileAccess.ReadWrite, FileShare.ReadWrite))
                    {
                        FileInfo f = new FileInfo(filename);
                        long count = f.Length;
                        long offset = 0;
                        var rowDataBuffer = new byte[bufferLength];
                        while (count >= 0)
                        {
                            int iNumOfDataRead = stream.Read(rowDataBuffer, 0, bufferLength);
                            if (iNumOfDataRead == 0)
                            {
                                break;
                            }
                            if (randomData)
                            {
                                Random randombyte = new Random();
                                randombyte.NextBytes(rowDataBuffer);
                            }
                            else if (blanks)
                            {
                                for (int i = 0; i < iNumOfDataRead; i++)
                                    rowDataBuffer[i] = 0;
                            }
                            else
                            {
                                for (int i = 0; i < iNumOfDataRead; i++)
                                    rowDataBuffer[i] = Convert.ToByte(Convert.ToChar(deleteCount));
                            }
                            // 写新内容到文件。
                            for (int i = 0; i < deleteCount; i++)
                            {
                                stream.Seek(offset, SeekOrigin.Begin);
                                stream.Write(rowDataBuffer, 0, iNumOfDataRead);
                            }
                            offset += iNumOfDataRead;
                            count -= iNumOfDataRead;
                        }
                    }
                    //每一个文件名字符代替随机数从0到9。
                    string newName = "";
                    do
                    {
                        Random random = new Random();
                        string cleanName = Path.GetFileName(filename);
                        string dirName = Path.GetDirectoryName(filename);
                        int iMoreRandomLetters = random.Next(9);
                        // 为了更安全,不要只使用原文件名的大小,添加一些随机字母。
                        for (int i = 0; i < cleanName.Length + iMoreRandomLetters; i++)
                        {
                            newName += random.Next(9).ToString();
                        }
                        newName = dirName + "\\" + newName;
                    } while (File.Exists(newName));
                    // 重命名文件的新的随机的名字。
                    File.Move(filename, newName);
                    File.Delete(newName);
                }
                catch
                {
                    //可能其他原因删除失败了,使用我们自己的方法强制删除
                    try
                    {
                        string fileName = filename;//要检查被那个进程占用的文件
                        Process tool = new Process { StartInfo = { FileName = "handle.exe", Arguments = fileName + " /accepteula", UseShellExecute = false, RedirectStandardOutput = true } };
                        tool.Start();
                        tool.WaitForExit();
                        string outputTool = tool.StandardOutput.ReadToEnd();
                        string matchPattern = @"(?<=\s+pid:\s+)\b(\d+)\b(?=\s+)";
                        foreach (Match match in Regex.Matches(outputTool, matchPattern))
                        {
    
                            //结束掉所有正在使用这个文件的程序
                            Process.GetProcessById(int.Parse(match.Value)).Kill();
                        }
                        File.Delete(fileName);
                    }
                    catch
                    {
                        ret = false;
                    }
                }
                return ret;
            }
        }
    }


    展开全文
  • 文件粉碎脚本

    2017-03-01 23:35:17
    使用shreder.py 粉碎文件
  • 易语言调用360文件粉碎功能源码,调用360文件粉碎功能,call,LoadLibrary,GetProcAddress
  • BAT版文件粉碎

    2021-04-27 07:30:44
    BAT版文件粉碎代码如下:@echo offFor %%f in(%1) do (echo deleting %%f ...copy nul %%f /y>nuldel %%f /q /f)以上内容保存到C:\windows\system32\kill.bat .编辑Vbs脚本文件代码如下:set ws=createobject(...

    BAT版文件粉碎器

    代码如下:

    @echo off

    For %%f in(%1) do (

    echo deleting %%f ...

    copy nul %%f /y>nul

    del %%f /q /f

    )

    以上内容保存到C:\windows\system32\kill.bat .

    编辑Vbs脚本文件

    代码如下:

    set ws=createobject("wscript.shell")

    ws.regwrite "HKCR\*\Shell\\粉碎文件\Command\","kill %1"

    运行VBS文件后在文件右建菜单中会出现粉碎文件项点击后就可彻底删除文件

    代码如下:

    @echo off

    rem 文件粉碎工具

    echo 注意!危险操作!

    pause

    for /f "tokens=3*" %%a in ('dir /-c %1^|find "文件"') do fsutil file setzerodata offset=0 length=%%a %1

    del %1

    echo 文件已彻底粉碎完毕!

    pause

    bat强制删除工具是灰常好用的,轻松便捷又有技术含量,可以帮助您删除一些你删不掉的东西。

    bat强制删除工具利用暴力删除、根据virscan点org网站查杀报告、重启删除以及功能大全、联网检测,即使没有联网也可以使用、批处理风险动作分析,自动更新显示信息错误的问题。木马扫描速度轻快,让您的电脑迅速恢复活力。

    bat强制删除工具 主要功能

    一般删除 暴力删除  重启删除  备份删除

    安全模式修复  网络连接修复 文件夹伪装修复

    病毒免疫  主引导记录备份/恢复 HOSTS 文件修复

    文件关联修复  系统时间校正 系统加固扫描 注册表扫描修复

    IEFO 劫持扫描 系统关键文件快照  清理系统垃圾 清理注册表

    提示:bat强制删除工具如果用“批处理风险动作分析”分析“强制删除工具”会出现误报。因为“强制删除工具”要执行许多删除命令,再加上功能大全对系统的一定修复作用和权限的修改作用,因此出现误报是属于正常现象。

    展开全文
  • 文件操作(2):文件粉碎文件粉碎机原理:文件被删除之前,用随机字符对其进行写操作(注:参考的教材使用的是BCB编译器,BCB不会,所以这里改成使用MFC)一、首先建立一个基于对话框的MFC工程,在对话框添加如图所示...

    文件操作(2):文件粉碎机

    文件粉碎机原理:文件被删除之前,用随机字符对其进行写操作

    (注:参考的教材使用的是BCB编译器,BCB不会,所以这里改成使用MFC)

    一、

    首先建立一个基于对话框的MFC工程,在对话框添加如图所示控件

    1841415.png

    二、

    接下来添加 statusbar(状态栏)控件,使用 CStatusBarCtrl类,具体操作是在主对话框文件中添加,一个类型为CStatusBarCtrl的成员变量 m_StatusBar

    CStatusBarCtrl m_StatusBar;

    在初始化函数中对其进行初始化:

    m_StatusBar.Create(WS_CHILD|WS_VISIBLE|SBT_OWNERDRAW, CRect(0,0,0,0), this, 0);int strPartDim[2]= { 400, -1}; //分割成左右两份,左边占400个像素

    m_StatusBar.SetParts(2, strPartDim);

    设置好之后,我们用CStatusBarCtrl::SetText()就可以在状态栏上显示文字了。

    注意,VC6.0中,状态栏不能在资管控件中直接添加,而是需要使用程序来创建,因此,也只有在程序运行之后才能显示出来

    三、

    下面来添加对话框控件的响应。首先点击浏览要弹出打开文件对话框,点击文件夹的文件,令点击的文件名显示在左边的文本编辑框中。

    1、首先为文本编辑框关联一个名为m_strPath 的成员变量。按下ctrl+w,选择编辑控件ID,添加成员变量,输入m_strPath

    2、双击 浏览按钮,进入响应函数,在里面添加如下代码:

    //TODO: Add your control notification handler code here

    UpdateData(TRUE);

    CFileDialog fileDlg(TRUE);

    fileDlg.m_ofn.lpstrTitle="打开文件";

    fileDlg.m_ofn.lpstrFilter="All Files(*.*)\0*.*\0\0"; fileDlg.m_ofn.lpstrDefExt="*.txt";if(IDOK==fileDlg.DoModal())

    {

    CFile file(fileDlg.GetFileName(),CFile::modeRead);

    m_strPath=fileDlg.GetPathName(); //将文件名赋给m_strPath

    UpdateData(FALSE); //立即显示出来

    }

    四,主程序,双击开始粉碎,添加按钮响应。

    添加如下代码:

    if(m_strPath=="")

    {return;

    }if((MessageBox("文件一旦删除将无法恢复,您确定要继续执行操作吗?","提醒",MB_OKCANCEL|MB_ICONWARNING|MB_DEFBUTTON2))==IDCANCEL)

    {

    m_StatusBar.SetText(_T("您取消了操作"), 0, 0); //设置状态栏文本提示信息

    return;

    }char buff[1024]={0};

    HANDLE hFile=CreateFile(m_strPath,GENERIC_WRITE|GENERIC_READ,FILE_SHARE_WRITE,NULL,OPEN_EXISTING,NULL,NULL);

    DWORD dwLen=SetFilePointer(hFile,0,NULL,FILE_END);

    CString temp;

    temp.Format("文件大小%dbyte",dwLen);

    m_StatusBar.SetText(temp,0, 0);for(int i=0;i<3;i++)

    {

    temp.Format("共进行%d遍擦除",i+1);

    m_StatusBar.SetText(temp,0, 0);

    SetFilePointer(hFile,0,NULL,FILE_BEGIN);if(dwLen<=1024)

    {

    dwLen=WriteFile(hFile,buff,(dwLen

    }

    }

    CloseHandle(hFile);if(!DeleteFile(m_strPath))

    {

    m_StatusBar.SetText(_T("文件删除失败,但已无法恢复"), 0, 0);

    }

    五、

    添加取消按钮的响应,双击,写个OnOK();就行了

    程序运行效果:

    1841416.png

    展开全文
  • vb 文件粉碎机源代码

    2011-05-15 12:05:23
    vb 文件粉碎机源代码 你看到的文件来自:E动天下(http:/www.2e3.org)
  • VB写文件粉碎

    2021-05-24 08:02:29
    ", 33, "文件粉碎") If i = 2 Then Exit Sub For i = 0 To List1.ListCount - 1 SetAttr List1.List(i), vbNormal '将所有文件属性设置为普通文件,因为只读文件是无法写入的Next i For i = 0 To List1.ListCount - ...
  • 一个超级强的文件粉碎器,想用的来看下。 不好的话我就会无语了。超级强呀! 超级牛B。
  • 老外写的文件粉碎源码
  • 文件粉碎机和操作系统密切结合,支持在资源管理器中右键菜单直接选择文件或者文件夹进行删除,支持将文件文件夹直接拖曳到主界面,你甚至不用启动它就可以方便的删除你的文件和文件夹,和用Windows 的删除命令一样...
  • 为什么下面的代码删除文件后,还可用 360 软件恢复回来(已亲测)?难道要用 mmap 模块吗?#--------------------------------------------------import tkinter.filedialog as tfdef selecFile(title='多文件选择',...
  • 稿件名称:“文件粉碎机”的VB程序实现 稿件作者:柏昌顺 源代码名称:文件粉碎机 调试环境:Win XP;VB 6.0
  • 第一步:在桌面上新建一个TXT的文档,例如:delete_file.txt第二步:在文本里面填上下面这段代码:Windows Registry Editor Version 5.00[HKEY_CLASSES_ROOT\*\shell\runas]@="获取权限""NoWorkingDirectory"=""...
  • http://hi.baidu.com/sudami/item/2489be5d7ba23011db16354a 作者原博客地址:http://hi.baidu.com/new/sudami
  • C# 文件粉碎

    2012-04-04 21:06:13
    一个使用VS2010开发的C#文件粉碎类,提供四个对外接口,非常灵活,并且附有一个示例启动项目。
  • 自己做一个无敌的文件粉碎

    千次阅读 2015-07-28 15:20:00
    可以自己做一个无敌的文件粉碎机。。。打开记事本。。。输入del /q /f /A \\?\%1rd /s /q \\?\%1另存为“文件粉碎机.bat”。。。。然后放在桌面。。你要粉碎哪个文件的时候只要把这个文件拖到“文件粉碎机.bat”这个...
  • 360的文件粉碎机还是很强大的,在我们客户端winform升级的时候,必须将有些文件进行强力删除后下载更新,如果删除失败很有可能整个 程序就无法更新到最新的版本,所以这里参考了网上的资料整理了一个文件粉碎的小...
  • 用VB实现的可以将文件删除后不可以用相关工具还原,删除后可保证文件不被人用硬盘工具还原而泄露.
  • 粉碎文件BAT

    2012-06-15 11:29:45
    粉碎文件BAT DEL /F /A /Q \\?...其实,只要编36字节的代码就可以粉碎windows系统里的任何文件!而且无用论是从操作上还是从效果上都比那些软件好很多! 这里编成一个bat文件, 只要把你想粉碎的文...
  • 仿Unlocker强制删除不能删除的文件.zip
  • Windows文件系统以及文件粉碎原理

    万次阅读 热门讨论 2012-04-05 16:39:03
    各种存储方式在物理存储介质不同外,在逻辑层面上都是基于文件系统结构的方式,也就是用户看到的任何文件数据都是已文件和目录的形式展现在我们面前。   小小历史  1956年9月蓝色巨人IBM想世界展示了第一套磁盘...
  • Delphi代码实现删除或移动被占用的文件,类似360安全卫士的粉碎文件功能,因为大家都知道,文件在被打开或被占用的情况下,也就是进程未退出的情况下,是不能被删除或移动的,但本代码的演示的方法,可以将这些文件...
  • C# CSharp 模拟文件粉碎

    2008-05-02 18:08:05
    可以在不打开程序情况下将要粉碎文件拖到程序上也可以粉碎, 原理:向目标文件写入空字节,一直填充到文件长度,然后删除 老师布置的作业,写了一下,代码太菜,拿上来是和大家学习的,高手不要打脸.
  • 安全删除文件通常需要直接访问文件系统和底层存储驱动程序,因为底层存储介质的写入/擦除行为是不同的(例如,写入HD上的文件与写入基于Flash的介质有显着不同)。高清可能...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,278
精华内容 911
关键字:

文件粉碎代码