精华内容
下载资源
问答
  • 有N个软件包未被升级

    千次阅读 2019-12-03 13:23:00
    还是升级: sudo apt-get dist-upgrade

    还是升级:

    sudo apt-get dist-upgrade

     

    展开全文
  • 升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包, 0 个软件包未被升级 2 个软件包没有被完全安装或卸载。 解压缩后会消耗 0 B 的额外空间。 您希望继续执行吗? [Y/n] y 正在...

    wangyetao@wangyetao-Lenovo-G510:~$ sudo apt install nginx
    正在读取软件包列表... 完成
    正在分析软件包的依赖关系树       
    正在读取状态信息... 完成       
    nginx 已经是最新版 (1.18.0-0ubuntu1)。
    升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
    有 2 个软件包没有被完全安装或卸载。
    解压缩后会消耗 0 B 的额外空间。
    您希望继续执行吗? [Y/n] y
    正在设置 nginx-core (1.18.0-0ubuntu1) ...
    Job for nginx.service failed because the control process exited with error code.
    See "systemctl status nginx.service" and "journalctl -xe" for details.
    invoke-rc.d: initscript nginx, action "start" failed.
    ● nginx.service - The NGINX HTTP and reverse proxy server
         Loaded: loaded (/etc/systemd/system/nginx.service; enabled; vendor preset: enabled)
         Active: failed (Result: exit-code) since Sat 2020-11-21 00:14:02 CST; 9ms ago
        Process: 9115 ExecStart=/usr/local/nginx/sbin/nginx -c /usr/local/nginx/conf/nginx.conf (code=exited, status=203/EXEC)

    11月 21 00:14:02 wangyetao-Lenovo-G510 systemd[1]: Starting The NGINX HTTP and reverse proxy server...
    11月 21 00:14:02 wangyetao-Lenovo-G510 systemd[9115]: nginx.service: Failed to execute command: No such file or directory
    11月 21 00:14:02 wangyetao-Lenovo-G510 systemd[9115]: nginx.service: Failed at step EXEC spawning /usr/local/nginx/sbin/nginx: No such file or directory
    11月 21 00:14:02 wangyetao-Lenovo-G510 systemd[1]: nginx.service: Control process exited, code=exited, status=203/EXEC
    11月 21 00:14:02 wangyetao-Lenovo-G510 systemd[1]: nginx.service: Failed with result 'exit-code'.
    11月 21 00:14:02 wangyetao-Lenovo-G510 systemd[1]: Failed to start The NGINX HTTP and reverse proxy server.
    dpkg: 处理软件包 nginx-core (--configure)时出错:
     已安装 nginx-core 软件包 post-installation 脚本 子进程返回错误状态 1
    dpkg: 依赖关系问题使得 nginx 的配置工作不能继续:
     nginx 依赖于 nginx-core (<< 1.18.0-0ubuntu1.1~) | nginx-full (<< 1.18.0-0ubuntu1.1~) | nginx-light (<< 1.18.0-0ubuntu1.1~) | nginx-extras (<<
     1.18.0-0ubuntu1.1~);然而:
      软件包 nginx-core 尚未配置。
      未安装软件包 nginx-full。
      未安装软件包 nginx-light。
      未安装软件包 nginx-extras。
     nginx 依赖于 nginx-core (>= 1.18.0-0ubuntu1) | nginx-full (>= 1.18.0-0ubuntu1) | nginx-light (>= 1.18.0-0ubuntu1) | nginx-extras (>= 1.18.0-0
    ubuntu1);然而:
      软件包 nginx-core 尚未配置。
      未安装软件包 nginx-full。
      未安装软件包 nginx-light。
      未安装软件包 nginx-extras。

    dpkg: 处理软件包 nginx (--configure)时出错:
     依赖关系问题 - 仍未被配置
    因为错误消息指示这是由于上一个问题导致的错误,没有写入 apport 报告。
                                                                        在处理时有错误发生:
     nginx-core
     nginx
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    wangyetao@wangyetao-Lenovo-G510:~$ 

     

     

    wangyetao@wangyetao-Lenovo-G510:~$ date
    2020年 11月 21日 星期六 00:34:49 CST
    wangyetao@wangyetao-Lenovo-G510:~$ lsb_release -a
    No LSB modules are available.
    Distributor ID:    Ubuntu
    Description:    Ubuntu 20.04.1 LTS
    Release:    20.04
    Codename:    focal
    wangyetao@wangyetao-Lenovo-G510:~$ uname -a
    Linux wangyetao-Lenovo-G510 5.4.0-54-generic #60-Ubuntu SMP Fri Nov 6 10:37:59 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
    wangyetao@wangyetao-Lenovo-G510:~$ 
     

    按照这个链接解决问题,失败,无效 https://blog.csdn.net/dym755833564/article/details/103835396 ,,唉!不知道怎么办!有大佬知道怎么解决么?2020年 11月 21日 星期六 00:23:38 CST。

    展开全文
  • 升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包, 13 个软件包未被升级N: 忽略‘google-chrome.list.1’(于目录‘/etc/apt/sources.list.d/’),鉴于它的文件扩展名无效 然后查询 python版本 ...
  • 升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包, 335 个软件包未被升级 1 个软件包没有被完全安装或卸载。 需要下载 0 B/116 kB 的归档。 解压缩后会消耗 285 kB 的额外空间。 您希望继续执行...

    kali linux 报错

    将会同时安装下列软件:
      libpng12-0
    下列【新】软件包将被安装:
      libpng12-0
    升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 335 个软件包未被升级。
    有 1 个软件包没有被完全安装或卸载。
    需要下载 0 B/116 kB 的归档。
    解压缩后会消耗 285 kB 的额外空间。
    您希望继续执行吗? [Y/n] 
    (正在读取数据库 ... 系统当前共安装有 376219 个文件和目录。)
    准备解压 .../libpng12-0_1.2.54-1ubuntu1_amd64.deb  ...
    正在解压 libpng12-0:amd64 (1.2.54-1ubuntu1) ...
    dpkg: 处理归档 /var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_amd64.deb (--u
    npack)时出错:
     无法安装 /lib/x86_64-linux-gnu/libpng12.so.0 的新版本: 没有那个文件或目录
    在处理时有错误发生:
     /var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    

    解决方式:

    1. 下载libpng12.so.0,放置到/usr/lib/x86_64-linux-gnu/ 目录下(未解决问题)

    2. 更新软件源地址为中科源(已解决问题)

    中科源地址:
    deb http://mirrors.ustc.edu.cn/kali kali-rolling main non-free contrib
    deb-src http://mirrors.ustc.edu.cn/kali kali-rolling main non-free contrib
    
    展开全文
  • 升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包, 233 个软件包未被升级 8 个软件包没有被完全安装或卸载。解压缩后会消耗掉 0 B 的额外空间。您希望继续执行吗? [Y/n] ...

    ~$ sudo apt-get install python-pip

    正在读取软件包列表... 完成

    正在分析软件包的依赖关系树

    正在读取状态信息... 完成

    python-pip 已经是最新的版本了。

    升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 233 个软件包未被升级。

    有 8 个软件包没有被完全安装或卸载。

    解压缩后会消耗掉 0 B 的额外空间。

    您希望继续执行吗? [Y/n] Y

    正在设置 mercurial-common (2.8.2-1ubuntu1.3) ...

    Traceback (most recent call last):

    File "/usr/bin/pycompile", line 38, in

    from debpython.namespace import add_namespace_files

    ImportError: No module named 'debpython.namespace'

    dpkg: 处理软件包 mercurial-common (--configure)时出错:

    子进程 已安装 post-installation 脚本 返回了错误号 1

    dpkg: 依赖关系问题使得 mercurial 的配置工作不能继续:

    mercurial 依赖于 mercurial-common (= 2.8.2-1ubuntu1.3);然而:

    软件包 mercurial-common 尚未配置。

    dpkg: 处理软件包 mercurial (--configure)时出错:

    依赖关系问题 - 仍未被配置

    正在设置 python-colorama (0.2.5-0.1ubuntu2) ...

    因为错误消息指示这是由于上一个问题导致的错误,没有写入 apport 报告。

    Traceback (most recent call last):

    File "/usr/bin/pycompile", line 38, in

    from debpython.namespace import add_namespace_files

    ImportError: No module named 'debpython.namespace'

    dpkg: 处理软件包 python-colorama (--configure)时出错:

    子进程 已安装 post-installation 脚本 返回了错误号 1

    正在设置 python-distlib (0.1.8-1ubuntu1) ...

    Traceback (most recent call last):

    File "/usr/bin/pycompile", line 38, in

    from debpython.namespace import add_namespace_files

    ImportError: No module named 'debpython.namespace'

    由于已经达到 MaxReports 限制,没有写入 apport 报告。

    dpkg: 处理软件包 python-distlib (--configure)时出错:

    子进程 已安装 post-installation 脚本 返回了错误号 1

    正在设置 python-html5lib (0.999-3

    e123

    ~ubuntu1) ...

    Traceback (most recent call last):

    File "/usr/bin/pycompile", line 38, in

    from debpython.namespace import add_namespace_files

    ImportError: No module named 'debpython.namespace'

    dpkg: 处理软件包 python-html5lib (--configure)时出错:

    子进程 已安装 post-installation 脚本 返回了错误号 1

    由于已经达到 MaxReports 限制,没有写入 apport 报告。

    正在设置 python-setuptools (3.3-1ubuntu2) ...

    Traceback (most recent call last):

    File "/usr/bin/pycompile", line 38, in

    from debpython.namespace import add_namespace_files

    ImportError: No module named 'debpython.namespace'

    由于已经达到 MaxReports 限制,没有写入 apport 报告。

    由于已经达到 MaxReports 限制,没有写入 apport 报告。

    dpkg: 处理软件包 python-setuptools (--configure)时出错:

    子进程 已安装 post-installation 脚本 返回了错误号 1

    dpkg: 依赖关系问题使得 python-pip 的配置工作不能继续:

    python-pip 依赖于 python-colorama;然而:

    软件包 python-colorama 尚未配置。

    python-pip 依赖于 python-distlib;然而:

    软件包 python-distlib 尚未配置。

    python-pip 依赖于 python-html5lib;然而:

    软件包 python-html5lib 尚未配置。

    python-pip 依赖于 python-setuptools (>= 0.6c1);然而:

    软件包 python-setuptools 尚未配置。

    dpkg: 处理软件包 python-pip (--configure)时出错:

    依赖关系问题 - 仍未被配置

    正在设置 python-wheel (0.24.0-1~ubuntu1) ...

    Traceback (most recent call last):

    File "/usr/bin/pycompile", line 38, in

    from debpython.namespace import add_namespace_files

    ImportError: No module named 'debpython.namespace'

    dpkg: 处理软件包 python-wheel (--configure)时出错:

    子进程 已安装 post-installation 脚本 返回了错误号 1

    由于已经达到 MaxReports 限制,没有写入 apport 报告。

    E: Sub-process /usr/bin/dpkg returned an error code (1)

    首先输入:

    sudo dpkg -C

    显示:

    :~$ sudo dpkg -C

    下列软件包已被解开,但是尚未配置。

    要令它们运行正常,您必须借助 dpkg --configure

    或者 dselect 菜单中的配置项:

    python-pip alternative Python package installer

    mercurial easy-to-use, scalable distributed version control system

    下列软件包只是被不全面地配置了,这也许要归咎于

    第一次配置它们时出的问题。您最好能重新配置它们。

    借助 dpkg --configure 或者用 dselect

    菜单中的配置项重新配置软件包:

    python-distlib low-level components of python distutils2/packaging

    mercurial-common easy-to-use, scalable distributed version control system

    python-colorama Cross-platform colored terminal text in Python - Python 2

    python-html5lib HTML parser/tokenizer based on the WHATWG HTML5 specifica

    python-setuptools Python Distutils Enhancements

    python-wheel built-package format for Python

    分析:

    原因是,我们在将python2.7升级到python3.3时,只是将/usr/local/bin目录下修改了(使用ln -s 或者其他),然而我们的配置目录并没有修改..

    使用如下的方式可以有效的解决:

    sudo apt-get clean

    sudo apt-get update

    sudo apt-get install --reinstall python-minimal python-lockfile

    声明:本文章是转载的,特附上原链接:http://www.cnblogs.com/gongxijun/p/5823595.html

    posted @ 2016-09-05 11:22 龚细军 阅读(9549)

    评论(2) 编辑 收藏

    展开全文
  • 升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包, 122 个软件包未被升级 1 个软件包没有被完全安装或卸载。 解压缩后将会空出 612 kB 的空间。 您希望继续执行吗? [Y/n] y  (正在读取数据库 ....
  • 升级了0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包, 233个软件包未被升级8个软件包没有被完全安装或卸载。解压缩后会消耗掉0B 的额外空间。您希望继续执行吗? [Y/n] Y正在设置 ...
  • ubuntu apt-get install更新域名解析失败问题的处理方法

    万次阅读 热门讨论 2018-05-11 15:11:21
    升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包, 285 个软件包未被升级。 需要下载 252 kB 的归档。 解压缩后会消耗 1,461 kB 的额外空间。 您希望继续执行吗? [Y/n] y 错误:1 ...
  • 升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包, 126 个软件包未被升级 2 个软件包没有被完全安装或卸载。 解压缩后会消耗 0 B 的额外空间。 您希望继续执行吗? [Y/n] y 正在设置 mysql-...
  • 0 个软件包未被升级 11 个软件包没有被完全安装或卸载。 需要下载 6,162 kB 的归档。 解压缩后将会空出 348 MB 的空间。 您希望继续执行吗? [Y/n] y 正在卸载 deepin-libwine-dbg:i386 (2.18-12)......
  • 升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包, 371 个软件包未被升级 2 个软件包没有被完全安装或卸载。 解压缩后会消耗 0 B 的额外空间。 您希望继续执行吗? [Y/n] Y 正在设置 mysql-...
  • Ubuntu dns的配置方法

    2009-09-06 15:09:58
    一,DNS的安装: $sudo apt-get install bind9 ...共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包 4 个软件未被升级。 二,DNS的配置: DNS的相关配置文件存放在 /etc/bind下,其中n...
  • 升级了 0 个软件包,新安装了 5 个软件包,要卸载 1 个软件包, 37 个软件包未被升级。 需要下载 68.0 MB 的归档。 解压缩后会消耗 206 MB 的额外空间。 您希望继续执行吗? [Y/n] y 获取:1 ...
  • ubuntu 18.04lts安装问题

    2021-01-12 14:02:33
    0 个软件包未被升级 8 个软件包没有被完全安装或卸载。 解压缩后将会空出 224 MB 的空间。 您希望继续执行吗? [Y/n] n 中止。</p><p>该提问来源于开源项目:wszqkzqk/deepin-wine-ubuntu</p></...
  • 升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包, 0 个软件包未被升级 3 个软件包没有被完全安装或卸载。 需要下载 0 B/118 kB 的归档。 解压缩后会消耗 313 kB 的额外空间。 您希望继续...
  • 1 个软件包未被升级。 需要下载 54.5 MB 的归档。 解压缩后会消耗 24.6 MB 的额外空间。 您希望继续执行吗? [Y/n] y 获取:1 ...
  • 树莓派3B+语音无输出

    2021-01-06 16:02:28
    11 个软件包未被升级。 需要下载 1,187 kB 的归档。 解压缩后会消耗 6,164 kB 的额外空间。 获取:1 http://mirrors.ustc.edu.cn/raspbian/raspbian stretch/main armhf libpulsedsp armhf 10.0-1+deb9u1 ...
  • 选择要升级软件包 A.5.1. 解决的依赖关系 A.6. 升级软件包 A.7. 创建引导盘 A.8. 升级完成 B. 删除 Red Hat Linux C. 获取技术支持 C.1. 记住来注册 C.2. Red Hat 支持总览 C.3. Red Hat 支持范围 C.4. 如何...
  • linux.chm文档

    2015-07-07 06:37:39
    find /usr/bin -type f -atime +100 搜索在过去100天内未被使用过的执行文件 find /usr/bin -type f -mtime -10 搜索在10天内被创建或者修改过的文件 find / -name \*.rpm -exec chmod 755 '{}' \; 搜索以 '.rpm' ...
  • <div><h3>问题类型 / Type of issues <ul><li>其它 / other</li></ul> 受影响的软件包 / Affected packages ...没有软件包被更新。 </code></pre>该提问来源于开源项目:archlinuxcn/repo</p></div>
  • 8 c6 p0 N( J1 o域控制器就是存储活动目录的地方,一域可以或几域控制器。在域中,各域控制器相互复制活动目录的改变,在目录林中,各域控制器相互之间也把信息自动复制给对方。 $ j D* X9 F, S$ @ X1 Q+ ...
  • Squid 中文权威指南

    2011-08-19 13:38:16
    假如你使用unix 一段时间,并且已编译过许多其他软件包,那么只需快速的扫描本章。编译安装squid 的过程与安装其他软件相似。 为了编译squid,你需要一ANSI C 编译器。不要ANSI 字眼吓倒。假如你已经...
  • 升级了 0 个软件包,新安装了 28 个软件包,要卸载 0 个软件包, 737 个软件包未被升级。 需要下载 3,425 kB 的软件包。 解压缩后会消耗掉 13.0 MB 的额外空间。 您希望继续执行吗? [Y/n] y 获取:1 ...
  • 升级了 0 个软件包,新安装了 28 个软件包,要卸载 0 个软件包, 737 个软件包未被升级。 需要下载 3,425 kB 的软件包。 解压缩后会消耗掉 13.0 MB 的额外空间。 您希望继续执行吗? [Y/n] y 获取:1 ...

空空如也

空空如也

1 2
收藏数 25
精华内容 10
关键字:

有n个软件包未被升级