精华内容
下载资源
问答
  • MPLS LDP邻居建立

    2021-07-16 09:23:58
    使用32位环回口地址做MPLS LDP的路由器ID 基础配置 AR1 interface GigabitEthernet0/0/0 ip address 12.1.1.1 255.255.255.0 # interface GigabitEthernet0/0/1 ip address 13.1.1.1 255.255.255.0

    拓扑图

    在这里插入图片描述

    AR1、AR2、AR3运行OSPF
    AR1—AR2 12.1.1.0 24
    AR1—AR3 13.1.1.0 24
    分别创建32位环回口IP地址
    使用32位环回口地址做MPLS LDP的路由器ID

    基础配置

    AR1
    interface GigabitEthernet0/0/0
     ip address 12.1.1.1 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 13.1.1.1 255.255.255.0 
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255 
    
    AR2
    interface GigabitEthernet0/0/0
     ip address 12.1.1.2 255.255.255.0 
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    
    AR3
    interface GigabitEthernet0/0/1
     ip address 13.1.1.3 255.255.255.0 
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    

    配置OSPF

    AR1
    ospf 100 router-id 1.1.1.1 
     area 0.0.0.0 
      network 1.1.1.1 0.0.0.0 
      network 12.1.1.1 0.0.0.0 
      network 13.1.1.1 0.0.0.0
    
    AR2
    ospf 100 router-id 2.2.2.2 
     area 0.0.0.0 
      network 2.2.2.2 0.0.0.0 
      network 12.1.1.2 0.0.0.0 
    
    AR3
    ospf 100 router-id 3.3.3.3 
     area 0.0.0.0 
      network 3.3.3.3 0.0.0.0 
      network 13.1.1.3 0.0.0.0
    

    检查OSPF邻居建立情况及路由接收情况

    AR1

    在这里插入图片描述

    AR1成功与AR2、AR3建立邻居关系,并且状态都到了FULL

    在这里插入图片描述

    AR1正常接收到了AR2与AR3的环回口路由。

    AR2

    在这里插入图片描述

    AR2成功收到AR1与AR3的环回口路由

    AR3

    在这里插入图片描述

    AR3成功收到AR1与AR3的环回口路由

    配置MPLS LDP

    AR1
    mpls lsr-id 1.1.1.1
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/0/0
     ip address 12.1.1.1 255.255.255.0 
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/0/1
     ip address 13.1.1.1 255.255.255.0 
     mpls
     mpls ldp
    
    AR2
    mpls lsr-id 2.2.2.2
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/0/0
     ip address 12.1.1.2 255.255.255.0 
     mpls
     mpls ldp
    
    AR3
    mpls lsr-id 3.3.3.3
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/0/1
     ip address 13.1.1.3 255.255.255.0 
     mpls
     mpls ldp
    

    检查MPLS LDP邻居建立情况

    AR1

    在这里插入图片描述

    AR2

    在这里插入图片描述

    AR3

    在这里插入图片描述

    查看MPLS标签分发情况

    在这里插入图片描述

    展开全文
  • MPLS LDP 邻居的建立和IGP(eigrp,ospf)的邻居建立一样也是直连才可以建立邻居


    MPLS LDP 邻居的建立和IGP(eigrp,ospf)的邻居建立一样也是直连才可以建立邻居,

    R01#show mpls ldp neighbor 
        Peer LDP Ident: 123.4.4.4:0; Local LDP Ident 123.1.1.1:0
             TCP connection: 123.4.4.4.32366 - 123.1.1.1.646
            State: Oper; Msgs sent/rcvd: 260/260; Downstream
            Up time: 03:32:04
            LDP discovery sources:
              Ethernet0/2, Src IP addr: 123.10.1.1
            Addresses bound to peer LDP Ident:
              123.10.1.18     123.4.4.4       123.10.1.1      123.10.1.21     
        Peer LDP Ident: 123.5.5.5:0; Local LDP Ident 123.1.1.1:0
             TCP connection: 123.5.5.5.27762 - 123.1.1.1.646
            State: Oper; Msgs sent/rcvd: 257/258; Downstream
            Up time: 03:31:53
            LDP discovery sources:
              Ethernet0/1, Src IP addr: 123.10.1.6
            Addresses bound to peer LDP Ident:
              123.10.1.14     123.5.5.5       123.10.1.6      123.10.1.29     
    R01#
    R01#
    ------------------------------------
    R02#show mpls ldp neighbor 
        Peer LDP Ident: 123.4.4.4:0; Local LDP Ident 123.2.2.2:0
            TCP connection: 123.4.4.4.46777 - 123.2.2.2.646
            State: Oper; Msgs sent/rcvd: 266/263; Downstream
            Up time: 03:35:19
            LDP discovery sources:
              Ethernet0/2, Src IP addr: 123.10.1.18
            Addresses bound to peer LDP Ident:
              123.10.1.18     123.4.4.4       123.10.1.1      123.10.1.21     
        Peer LDP Ident: 123.3.3.3:0; Local LDP Ident 123.2.2.2:0
            TCP connection: 123.3.3.3.22712 - 123.2.2.2.646
            State: Oper; Msgs sent/rcvd: 262/262; Downstream
            Up time: 03:35:12
            LDP discovery sources:
              Ethernet0/1, Src IP addr: 123.10.1.10
            Addresses bound to peer LDP Ident:
              123.10.1.10     123.3.3.3       123.10.1.13     
    R02#  
    R02#
    -------------------------------
    R04#show mpls ldp nei
    R04#show mpls ldp neighbor 
         Peer LDP Ident: 123.1.1.1:0; Local LDP Ident 123.4.4.4:0
             TCP connection: 123.1.1.1.646 - 123.4.4.4.32366
            State: Oper; Msgs sent/rcvd: 264/264; Downstream
            Up time: 03:35:58
            LDP discovery sources:
              Ethernet0/1, Src IP addr: 123.10.1.2
            Addresses bound to peer LDP Ident:
              123.10.1.5      123.1.1.1       123.10.1.2      
         Peer LDP Ident: 123.2.2.2:0; Local LDP Ident 123.4.4.4:0
             TCP connection: 123.2.2.2.646 - 123.4.4.4.46777
            State: Oper; Msgs sent/rcvd: 264/267; Downstream
            Up time: 03:35:48
            LDP discovery sources:
              Ethernet0/0, Src IP addr: 123.10.1.17
            Addresses bound to peer LDP Ident:
              123.10.1.9      123.2.2.2       123.10.1.17     
         Peer LDP Ident: 123.6.6.6:0; Local LDP Ident 123.4.4.4:0
             TCP connection: 123.6.6.6.62324 - 123.4.4.4.646
            State: Oper; Msgs sent/rcvd: 262/266; Downstream
            Up time: 03:35:41
            LDP discovery sources:
              Ethernet0/2, Src IP addr: 123.10.1.22
            Addresses bound to peer LDP Ident:
              123.10.1.25     123.6.6.6       123.10.1.22     
    R04# 
    R04#
    R04#


    展开全文
  • MPLS-2 LDP邻居建立

    千次阅读 2016-07-08 20:25:04
    session 1 LDP协议  LDP,Label Distribution Protocol 标签分发协议,用来建立LDP会话发送LDP... LDP邻居建立:直连的邻居使用udp协议(因为udp只负责本地有效),而非直连的邻居使用TCP(要保证会话的连接)发
    session 1 LDP协议
     
    
           LDP, Label Distribution Protocol 标签分发协议,用来建立LDP会话发送LDP信息,该协议使用tcp和udp进行承载,hello包的发送目的地址224.0.0.10,端口为646。
           LDP邻居的建立:直连的邻居使用udp协议(因为udp只负责本地有效),而非直连的邻居使用TCP(要保证会话的连接)发送hello包来建立邻居关系。
           LDP的hello报文:在hello报文中,LDP的ID是该LSR上所有接口上最大的ip地址。
           LDP hello报文中的label空间字段:2个byte,分为基于全局的(值为0)和基于接口的(值非0)。基于全局表明接口使用同一套label库,而基于接口的表明不同接口使用不同的一套label库,例如在LSP中f0/0和f0/1口使用同一套lable的时候那么这两个接口的lable是不能相同的,而不适用同一台label的时候两个接口的label都拥有自己的一套lable所以label相同时也是不冲突的。 f0/0 x=25和f0/1 x=25。
           LDP ID:LSR接口最大的ip地址+label空间字段

    1、LDP邻居建立过程:
    LDP的hello报文格式

    MPLS邻居的建立过程:

    1、有所LSR发送LDP的hello报文到224.0.0.10:646端口,来发现是否有邻居LSR
    2、如果发现有其他的LSR后,LSR开始向其他LSR发送hello报文
    3、LSR之间交换hello报文后由接口ip地址最大的LSR发送LDP的初始化信息(包括LDP ID、 label空间字段版本号等)以及keepalive保活信息
    4、其他LSR发送keepalive信息

    展开全文
  • 华为设备ldp邻居建立

    2019-10-24 02:47:33
    mpls lsr-id 10.1.1.1 指定LSR-ID mpls 开启MPLS功能 lsp-trigger all 触发标签方式,默认是...mpls ldp 启用LDP mpls ldp remote-peer ar4 配置LDP远程会话 remote-ip 10.1.1.4 指定远程会话IP interface Gigabi...

    mpls lsr-id 10.1.1.1 指定LSR-ID
    mpls 开启MPLS功能
    lsp-trigger all 触发标签方式,默认是给主机路由分发标签,调整为所有路由分发标签
    #
    mpls ldp 启用LDP

    mpls ldp remote-peer ar4  配置LDP远程会话
     remote-ip 10.1.1.4   指定远程会话IP
    
    interface GigabitEthernet0/0/0
    ip address 10.1.12.1 255.255.255.0 
    mpls  接口开启mpls(支持标签必须开启)
     mpls ldp  接口开启LDP     注意  先配置lsr-id 然后开启mpls 以及mpls ldp  然后再各个端口开启
    

    在这里插入图片描述

    展开全文
  • mpls配置,每个接口也有配 [img=https://img-bbs.csdn.net/upload/202102/22/1613982554_770597.png][/img] [img=https://img-bbs.csdn.net/upload/202102/22/1613982582_864923.png][/img] [img=...
  • MPLS LDP原理

    千次阅读 多人点赞 2020-07-27 00:06:48
    由映射一个标签,然后再将标签信息通告给所有邻居,路由器之间通过这种方式来建立标签转发表,最终形成LSP,当网络拓扑发生变化时,LDP还会实时地响应这种变化,动态建立LSP。 二、LDP的基本概念 1、标签空间 LDP.
  • MPLS 排错之LDP邻居无法建立(原创)

    千次阅读 2010-08-27 18:54:37
    router ospf 100 //启用OSPF路由,为BGP建立邻居关系打好通道  router-id 2.2.2.2 //指定router-id 如不指定使用最大的环回口IP,如果环回口IP掩码设为24位,会导致LDP邻居无法建立  log-adjacency-changes ...
  • MPLS LSR-ID只能是一个,默认会选择router id来作为LDP邻居建立的源地址,当存在多个loopback地址,且需用不同的loopback地址建立Targe-LDP邻居时,就需要为T-LDP邻居指定lsr-id。 组网模型 配置思路 3台设备...
  • 缺省情况下,网络的路由改变时,如果有一个边缘节点(Egress)发现自己的路由表中出现了新的主机路由,并且这一路由不属于任何现有的FEC,则该边缘节点需要为这一路由建立一个新的FEC。  如果MPLS网络的Egress有可供...
  • MPLS LDP

    2019-05-06 10:57:26
    MPLS LDP LDP 邻接体:1、 本地邻接体(Local Adjacency):链路 Hello 消息发现的邻接体叫做本地邻接体。2、 远端邻接体(Remote Adjacency): Target Hello 消息发现的邻接体叫做远端邻接体。 LDP 会话:1、 ...
  • MPLS LDP基础

    万次阅读 多人点赞 2018-05-29 22:51:52
    标签分发协议LDP(Label Distribution Protocol)是多协议标签交换MPLS的一种控制协议,相当于传统网络中的信令协议,负责转发等价类FEC(Forwarding Equivalence Class)的分类、标签的分配以及标签交换路径LSP...
  • MPLS LDP 故障排查

    2017-11-12 20:13:00
    Technorati 标签:MPLS LDP,...两个设备建立直连LDP邻居: R2和R3.R2的interface Giga 2/0和R3的interface G1/0建立LDP的直连邻居。 首先,再回顾一下LDP邻居建立过程: LDP实用的是UDP/TCP的端口646来发现邻居的...
  • MPLS LDP故障排除

    千次阅读 2019-01-01 14:38:50
    最近在准备CCIE的lab考试,在其中MPLS VPN的环节配完ldp后其他路由器和R2的LDP邻居始终无法建立。 拓扑如下: 故障排除流程如下: 1.在R4上show mpls ldp discovery,发现与R2相对的e0/2口显示no route 2.查看ospf...
  • MPLSLDP

    千次阅读 2019-08-06 19:08:42
    MPLS:多协议标签交换 最初的目的是为了解决TCP/IP路由器转发路由表过慢的问题。 LDP的状态机制: 1:initialized 2:open-received 3:open-sent 4:operational 5:non-existent 初始状态为initalized,若被动方收到可...
  • MPLS LDP随堂笔记2

    千次阅读 2018-01-05 11:03:29
    Acl 1 匹配所有ospf的数据包 (目的 ospf建立邻居关系 传递路由条目) 2 放行UDP报文 让LDP邻居能互相收发HELLO包 4 放行TCP报文 让LDP邻居能够建立TCP会话 互传标签 5 放行ICMP报文 让R1能ping通3.3.3.3 ...
  • 自制mpls ldp实验

    千次阅读 2018-01-05 11:00:34
    实验步骤 步骤1:完成EIGRP BGP ...步骤1:校验和理解LDP 邻居关系的发现和邻接关系的建立 R4#show mpls ldp discovery detail Local LDP Identifier: 4.4.4.4:0 Discovery Sources: Interfaces: FastEthernet0
  • 最近在做MPLS的实验 发现LDP总是起不来 一开始以为是模拟器的问题 但后来发现不是这个原因 然后以为是IOS问题 但是同样的IOS 换个拓扑后可以马上起来。。。。 然后在网上查了资料 得出如下原因: 1, 这个是R4 ...
  • MPLSLDP协议

    万次阅读 2018-03-18 11:58:34
    MPLS需要使用标签分发协议完成...运行LDP协议的LSR之间通过交换LOp消息来发现邻居建立和维护LOpSession并管理标签。LD叫肖息承载在UOP或下CP之上,端口号为646。这里简单介绍LDP常用的一些消息和各个消息的主要功...
  • 自制mpls ldp实验

    2017-09-04 10:12:00
    实验步骤 步骤1:完成EIGRP BGP 及宣告配置 ...步骤1:校验和理解LDP 邻居关系的发现和邻接关系的建立 R4#show mpls ldp discovery detail Local LDP Identifier: 4.4.4.4:0 Discovery Sources: Interfaces: ...
  • MPLS LDP简介-ielab

    2019-10-16 16:40:55
    标签分发协议LDP(Label Distribution Protocol)是多协议标签交换MPLS的一种控制协议,相当于传统网络中的信令协议,负责转发等价类FEC(Forwarding Equivalence Class)的分类、标签的分配以及标签交换路径LSP...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 818
精华内容 327
关键字:

ldp建立邻居mpls