精华内容
下载资源
问答
  • vue less 安装报错

    2020-07-27 22:39:46
    vue less 安装报错(版本过高导致) error in ./src/components/Home.vue Module build failed: TypeError: loaderContext.getResolve is not a function at createWebpackLessPlugin (D:\我的办公\智慧答题\zhdt\...

    vue less 安装报错(版本过高导致)

    error  in ./src/components/Home.vue
    Module build failed: TypeError: loaderContext.getResolve is not a function
        at createWebpackLessPlugin (D:\我的办公\智慧答题\zhdt\node_modules\less-loader\dist\utils.js:36:33)
        at getLessOptions (D:\我的办公\智慧答题\zhdt\node_modules\less-loader\dist\utils.js:150:31)
        at Object.lessLoader (D:\我的办公\智慧答题\zhdt\node_modules\less-loader\dist\index.js:29:49)
    
     @ ./node_modules/vue-style-loader!./node_modules/css-loader?{"sourceMap":true}!./node_modules/vue-loader/lib/style-compiler?{"vue":true,"id":"data-v-8dc7cce2","scoped":false,"hasInlineConfig":false}!./node_modules/less-loader/dist/cjs.js?{"sourceMap":true}!./node_modules/vue-loader/lib/selector.js?type=styles&index=0!./src/components/Home.vue 4:14-370 13:3-17:5 14:22-378
     @ ./src/components/Home.vue
     @ ./src/router/index.js
     @ ./src/main.js
     @ multi (webpack)-dev-server/client?http://localhost:8080 webpack/hot/dev-server ./src/main.js
    

    解决方法(指定版本安装)
    cnpm install less@3.9.0 -s
    cnpm install less-loader@5.0.0 -s

    展开全文
  • vue less报错

    2019-11-07 15:25:03
    This dependency was not found: * !!vue-style-loader!css-loader?...../node_modules/_vue-loader@13.7.3@vue-loader/lib/style-compiler/index?{"vue":true,"id":"data-v-7ba5bd90","scoped"...

     

    This dependency was not found:

    * !!vue-style-loader!css-loader?{"sourceMap":true}!../node_modules/_vue-loader@13.7.3@vue-loader/lib/style-compiler/index?{"vue":true,"id":"data-v-7ba5bd90","scoped":false,"hasInlineConfig":false}!less-loader?{"sourceMap":true}!../node_modules/_vue-loader@13.7.3@vue-loader/lib/selector?type=styles&index=0!./App.vue in ./src/App.vue

    To install it, you can run: npm install --save !!vue-style-loader!css-loader?{"sourceMap":true}!../node_modules/_vue-loader@13.7.3@vue-loader/lib/style-compiler/index?{"vue":true,"id":"data-v-7ba5bd90","scoped":false,"hasInlineConfig":false}!less-loader?{"sourceMap":true}!../node_modules/_vue-loader@13.7.3@vue-loader/lib/selector?type=styles&index=0!./App.vue      

    npm install sass-loader --save;
    
    npm install node-sass --save;

    webpack.base.conf.js中添加less 

     

    {
            test: /\.less$/,
            loader: "style-loader!css-loader!less-loader",
          }

     

    展开全文
  • vue安装less-loader报错

    2021-03-31 11:03:17
    问题描述 在vue项目中,如果组件内style的声明上加上lang='less' <style lang='less' scoped> <...npm install less-loader@7.0.0 // 安装 备注 截至我当前日期2021/3/31 : vue版本为3.0.

    问题描述
    在vue项目中,如果组件内style的声明上加上lang='less'

    <style lang='less' scoped>
    </style>
    

    则表示可以使用less语法。在写完less/css运行后,可能会报错误。
    在这里插入图片描述
    这表示需要安装less-loader
    当按照npm install less-loader --save安装则会报如下错误
    在这里插入图片描述
    出现原因
    npm安装不指定包版本,将安装最新版本。此问题由于less-loader版本过高引发

    npm uninstall less-loader // 卸载
    npm install less-loader@7.0.0 --save // 安装
    

    备注
    截至我当前日期2021/3/31 : vue版本为3.0.0, less-loader 版本只能为 8.0.0 以下

    不使用less
    如果不想写less,不想安装,直接删除lang='less'即可

    展开全文
  • 关于ant-design-vue安装报错的解决方法

    千次阅读 2020-06-04 14:39:50
    Vue-CLI@4.3.0 Less-Loader@6.1.0 解决方法 在vue.config.js里加入解决~ module.exports = { + css: { + loaderOptions: { + less: { + lessOptions: { + javascriptEnabled: true + } + } + } + } } ...

    版本

    Vue-CLI@4.3.0
    Less-Loader@6.1.0

    解决方法

    在vue.config.js里加入解决~

    	module.exports = {
    +	  css: {
    +	    loaderOptions: {
    +	      less: {
    +	        lessOptions: {
    +	          javascriptEnabled: true
    +	        }
    +	      }
    +	    }
    +	  }
    	}
    

    下面是我的吐槽,可以不看


    说来也是无语,按照官方文档来,竟然还会报错,类似这样👇

    .bezierEasingMixin();
    ^
    Inline JavaScript is not enabled. Is it set in your options?
    

    第一次报错,是因为我没装less-loader,好嘛~ 我装,可是官方文档不应该写一下需要less-loader依赖吗?run serve失败体验很不好欸~
    在这里插入图片描述
    等我装好了loader,满心欢喜npm run serve又报错,比较搞笑的是官方知道这个错,还把解决网页在Terminal告诉了我,emmmmmm…在官方文档多写几行说明,后果很严重吗?????
    在这里插入图片描述
    于是,我哼哧哼哧去github找解决方案,评论竟然是按时间排序,2017年的问题压根不是这个,从2018的回答才是正解(是的,这问题都存活两年了(⊙ˍ⊙)),可是咱less-loader都更新到6+了呀,于是,我终于在接近底部找到了正解。

    幸好评论就几十条,不然我就去用Element-UI了ㄟ( ▔, ▔ )ㄏ

    展开全文
  • 1、创建vue项目后安装less,执行 npm install less less-loader –save-dev 下载版本为:less-loader@6.1.0 , less@3.11.3,重启服务报错报错信息如下: 2、报错原因 less 本版太高需要降低版本,执行代码 先...
  • 1、创建vue项目后安装less,执行npm install less less-loader --save-dev 下载版本为:less-loader@6.1.0 ,less@3.11.3,重启服务报错报错信息如下: 2、报错原因 less 本版太高需要降低版本,执行代码 先...
  • { test: /\.less$/, loader: "style-loader!css-loader!less-loader",  options: { sourceMap: true }// 可以看到当前标签样式来自于哪个less文件 }
  • 创建vue项目安装less和lessloader之后就出现这个错误,各位大佬谁知道怎么解决一下<img alt="" height="309" src="https://img-ask.csdnimg.cn/upload/1617088590211.png" width="450" /><img alt="" height...
  • vue安装less报错

    千次阅读 2021-03-19 17:10:32
    1.安装less时报错了,原因是安装的版本太高了 npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tree npm ERR! npm ERR! While resolving: ceshi@1.0.0 npm ERR! Found: webpack@3.12.0 npm...
  • 1.问题:安装vue脚手架报错A complete log of this run can be found in。 2.报错如图: 根据下面的日志文件,打开查看错误如下: 查看资料发现errno -5错误为I/O error,也就是说可能是网络原因造成的。所以可以...
  • 在项目目录下执行安装命令: npm install less less-loader --save-dev 如图: 2. 配置: 在build/webpack.base.conf.js文件里配置: { test: /\.less$/, loader: "style-loader!css-loader!less-loader" } ...
  • 这个原因是版本控制的原因,可以cmd直接全局安装,也可以在IDE中安装在项目中。 npm install less@3.9.0 less-loader@4.1.0 --save-dev --答案参考了网上的答案。
  • vuecli3报Module build failed (from ./node_modules/less-loader/dist/cjs.js): 解决方式,降低less-loader的版本为7.3.0 npm install less-loader@7.3.0 --save-dev
  • vue项目安装less-loader报错yntax Error: TypeError: this.getOptions is not a function 百度了一下 less-loader版本过高,再安装一个旧点的版本就好了
  • 问题描述:在vue中 npm 引入less 后,编译报错,具体错误信息可查看下边的报错信息。后经过查证,是因为less-loader的版本过高造成的,emmmm… 好了问题已经找到后,直接更改less-loader的版本即可。首先移除原来的...
  • AntDesignVue运行报错

    2021-04-18 22:47:46
    AntDesignVue 错误日志 ERROR Failed to compile with 1 error 下午10:45:00 error in ./node_modules/ant-design-vue/es/dropdown/style/index.less Syntax Err
  • 一、简介 安装 Less ...但是在安装 less-loader 的时候失败,报错: npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tree npm ERR! npm ERR! Found: webpack@4.46.0 npm ERR! n
  • 安装less npm install less less-loader -D 配置less 在build/webpack.base....在vue 文件中的style标签上加上 lang=“less”,即可使用: 如果启动后报错,如下图所示: 原因是由于less-loader安装的版本过高,可以
  • 报错如下: ERROR Failed to compile with 1 error error in ./src/components/Login.vue?vue&type=style&index=0&id=ef68022e&lang=less&sc
  • 关于vue中引入less时的报错

    千次阅读 2019-06-23 19:28:52
    vue中引入并使用less时的相关错误及解决方案: 1、错误一: 错误如下图所示: 因为当前项目版本2.9.6 已经在build/utils里配置了less的处理,所以和之前在build/webpack.base.conf.js中配置的less-loader冲突 ...
  • vue脚手架安装lessless-loader报错的解决方法 Failed to compile. ./src/components/Login.vue?vue&type=style&index=0&id=ef68022e&lang=less&scoped=true& (./node_modules/css-...
  • Vue日常报错

    2018-11-21 22:51:00
    报错信息: Error: Cannot find module 'webpack/bin/config-yargs' at Function.Module._resolveFilename (internal/modules/cjs/loader.js:580:15) at Function.Module._load (internal/modules/cjs/loade....
  • 解决vue使用less出现语法报错

    千次阅读 2019-10-04 10:27:45
    要在vue中使用less需要执行以下指令 npm install less less-loader --save-dev 出现如下图错误 直接修改为 转载于:https://www.cnblogs.com/chenmiaosong/p/9232902.html...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,016
精华内容 2,406
关键字:

lessvue安装报错

vue 订阅