精华内容
下载资源
问答
  • Linux升级tomcat

    2020-02-26 11:40:38
    1.先在官网下载所需要的tomcat安装包 (最好是apache-tomcat-8.5.5.1.tar.gz) 2.删除新tomcat包下的 webapps 子...4.对比要升级的apache-tomcat-8.5.5.1包,修改server.xml 5.解压.tar.gz (tar -zxvf apache-to...

    1.先在官网下载所需要的tomcat安装包 (最好是apache-tomcat-8.5.5.1.tar.gz)
    2.删除新tomcat包下的 webapps 子目录,work目录全删
    3.把原tomcat下的server.xml 文件复制到本地
    4.对比要升级的apache-tomcat-8.5.5.1包,修改server.xml
    5.解压.tar.gz (tar -zxvf apache-tomcat-8.5.5.1.tar.gz)
    6.赋予tomcat包权限 (chmod -R777 apache-tomcat-8.5.5.1)
    7.然后重启新的tomcat包,如果重启报错 则(删除apache-tomcat-8.5.5.1 bin下的slf4j-simple-1.5.8.jar),没报错 则就不是jar包冲突
    8.如果要对应升级jdk,则只需要改动apache-tomcat-8.5.5.1/bin/catalina.sh文件
    在这里插入图片描述

    展开全文
  • Linux服务器升级tomcat

    千次阅读 2016-09-08 17:31:20
    背景:最近获知tomcat多个版本出现漏洞,于是需要对Linux服务器中的tomcat进行升级Linux里开启了三个部署不同应用的tomcat tomcat6,应用在jdk1.6环境下开发的 1,首先需要知道各应用开发时候用的jdk,因为这...

    背景:最近获知tomcat多个版本出现漏洞,于是需要对Linux服务器中的tomcat进行升级,Linux里开启了三个部署不同应用的tomcat

    tomcat6,应用在jdk1.6环境下开发的

    1,首先需要知道各应用开发时候用的jdk,因为这关系到Linux里的jre是否需要升级,以及是否能够升级,

          比如我的三个应用都是在jdk1.6环境下开发的,所以jre最好不要升级,否则可能需要重新编译,不然可能会发生未知的错误(一家之言,未测过);

    2,tomcat6需要至少jre1.5以上,tomcat7需要至少jre1.6以上,依次类推;我升级tomcat6到tomcat7,jre可以不改变,如果需要改变的同学,

          可以搜下Linux安装jre及配置的方法,都不会太难;

    3,旧tomcat下的配置,如catalina.sh,server.xml,context.xml等配置需要搬到新tomcat下,

          如跟环境有关的jre可能在catalina里面设置,跟启动有关的端口及应用路径可能在server.xml里甚至在Catania/localhost内,都需要搬到新tomcat内;

          端口及路径需要特别注意,因为设置不好就启动不了;

    4,Linux命令ps -ef|grep tomcat查看当前启动了哪些tomcat服务,进各旧tomcat执行sh shutdown.sh或直接kill -9 进程号

    5,进新tomcat执行相应的sh startup.sh

    6,至此,应该可以启动,端口及路径非常重要!

    展开全文
  • Linux服务器升级tomcat

    千次阅读 2016-09-09 15:43:32
    之前写过一篇关于升级tomcat的文章,今天写点比较细节的东西。 我们知道,升级tomcat,在“(我们认为)正常”的情况下,只要配置对了,升级都可以正常运行,那今天我们讨论一个反例:即我们配置错误的情况下会如何呢...

    之前写过一篇关于升级tomcat的文章,今天写点比较细节的东西。

    我们知道,升级tomcat,在“(我们认为)正常”的情况下,只要配置对了,升级都可以正常运行,那今天我们讨论一个反例:即我们配置错误的情况下会如何呢?

    我同时在 tomcat6 和 tomcat7 中的 server.xml 中的 <Host> 内配置 一个 <Context> 属性docBase指向一个不存在的应用路径,这个时候会发生什么呢?

    分别启动两个tomcat (同时启动也可以,不过要配置好其它地方,比如port的值最好不要一样),你会发现 tomcat6 可以肆无忌惮的启动,而tomcat7 执行完 sh startup.sh后虽然显示 tomcat started,但连影子都看不到;

    通过查看两个tomcat的日志,发现两个tomcat都有报错:

            java.lang.IllegalArgumentException: Document base /root/apache-tomcat/webapps/ABC does not exist or is not a readable directory

    但貌似tomcat6只是 “看的”,选择继续前进,而tomcat7却 “纠结”着这个不放,最后tomcat6启动了,tomcat7无动静;

    个人觉得这可能是tomcat6会放水,而tomcat7 有更严格的验证“审查”制度,眼里容不得沙子。

    如有高见,请评论,谢谢。

    展开全文
  • 下载你要升级Tomcat版本:wget http://mirrors.shu.edu.cn/apache/tomcat/tomcat-9/v9.0.16/bin/apache-tomcat-9.0.16.tar.gz 停止tomcattomcat1 stop 或者 ./shutdown.sh 备份旧的tomcat。先在该目录下创建一...
    1. 下载你要升级的Tomcat版本:wget http://mirrors.shu.edu.cn/apache/tomcat/tomcat-9/v9.0.16/bin/apache-tomcat-9.0.16.tar.gz
    2. 停止tomcat:tomcat1 stop 或者 ./shutdown.sh
    3. 备份旧的tomcat。先在该目录下创建一个文件并命名为:mkdir tomcat8.5.1-old
      复制旧的 tomcat到刚刚创建的tomcat目录下:cp -Rf /home/tomcat8.5.1/* /home/tomcat8.5.1-old/ (cp -Rf /原路径/* /目的路径/)
    4. 解压新的tomcat:tar -zxvf apache-tomcat-9.0.16.tar.gz(在原tomcat目录解压)
      删除原来的tomcat8.5.1:rm -rf tomcat8.5.1
      重命名为:mv apache-tomcat-9.0.16 tomcat8.5.1 (注意:此时tomcat8.5.1就是新的了)
    5. 把旧的server.xml移动到新的server.xml。
      先删除新的server.xml:rm -rf server.xml
      移动:mv /home/tomcat8.5.1-old/conf/server.xml /home/tomcat8.5.1/conf/
    6. 把旧的webapps移动到新的webapps下。
      先删除新的webapps文件:rm -rf webapps
      移动:mv /home/tomcat8.5.1-old/webapps /home/tomcat8.5.1
      修改了旧tomcat的某个文件,一定要复制或移动到新tomcat下:
      mv /home/tomcat8.5.2-old/bin/catalina.sh /home/tomcat8.5.2/bin
    7. 删除新的webapps下的examples:rm -rf examples
    8. 启动tomcat:tomcat1 start
      在这里插入图片描述
      关闭tomcat:tomcat1 stop
      在这里插入图片描述
      启动成功
      在这里插入图片描述
    展开全文
  • Linux上Tomcat升级版本

    千次阅读 2020-06-01 15:25:55
    Linux上Tomcat升级版本 根据业务需要将tomcat版本升级至apache-tomcat-5.5.51 1、下载你要升级Tomcat版本 https://tomcat.apache.org/ 2、解压新的tomcat tar -zxvf apache-tomcat-5.5.51.tar.gz 3、将所有的文件...
  • linux升级tomcat中的应用服务器

    千次阅读 2015-05-18 16:22:40
    1.用shell工具进入到linux下的tomcat的文件夹下  cd /usr/你的tomcat的路径 2.进入bin目录下 cd bin/ 3.调用关闭脚本 ./shutdown.sh 4.查看Tomcat是否以关闭 ps -ef|grep java 如果是下列情况,说明已经...
  • 在保留原因基础安装81、下载linux版本的jdk82、在/usr/目录下创建java目录,mkdir /usr/javacd /usr/java把下载的文件 jdk放在/usr/java/目录下。3. 解压 JDKtar -zxvf jdk-8.tar.gz4. 设置环境变量修改 /etc/prof...
  • linuxtomcat升级

    千次阅读 2015-10-14 08:45:41
    linuxtomcat升级 下载最新版的tomcat 例如目前tomcat6版本就是apache-tomcat-6.0.44.tar.gz 1)停【旧】tomcat 2)备份【旧】tomcat文件夹,文件夹改个名即可 3)上传【新】tomcat压缩文件;解压 ...
  • 1、在对应服务器解压apache-tomcat-7.0.105.zip后修改配置文件: context.xml 修改数据源(一般不需要修改) server.xml 修改端口(可以复制之前的) 2、将原Tomcat的应用拷贝到新Tomcat下 cp -r home/apache-...
  • 下载你要升级Tomcat版本:wget http://mirrors.shu.edu.cn/apache/tomcat/tomcat-9/v9.0.16/bin/apache-tomcat-9.0.16.tar.gz 停止tomcattomcat1 stop 或者 ./shutdown.sh 备份旧的tomcat。先在该目录下创建一个...
  • linux服务器下tomcat版本升级

    万次阅读 2018-10-15 11:24:59
    linuxtomcat版本升级(zws个人总结): 1:查看当前tomcat版本: 一版tomcat安装在/usr/local/下  cd 至apache-tomcat-xxx/bin  sh version.sh命令,查看版本信息 2:下载需要的tomcat安装包: 下载网址:...
  • linux下安装oracle11g连接地址:...linux下部署tomcat+升级firefox文档下载:https://download.csdn.net/download/qq_32836247/10920711 /******************************部署tomcat**************...
  • Linux-tomcat版本升级

    千次阅读 2020-02-26 17:14:16
    Linux-tomcat版本升级:version8.5.16升至version8.5.51 1.下载需要升级tomcat新版本 [root@izwz91l1b684105z37o7uqz data]# wget ...
  • 将对应升级版本的tomcat复制到路径下 解压tomcat,并修改tomcat名 tar -zxvf apache-tomcat-8.5.56.tar.gz mv apache-tomcat-8.5.56 tomcat_pms_xxx 修改conf/server.xml文件里的端口号(未停原tomc.
  • linux下部署tomcat

    2019-01-16 14:41:54
    linux下部署tomcat,包括firefox静默升级、配置本地yum仓库
  • 配置linux系统环境变量 vim /etc/profile export JAVA_BIN=/usr/local/java/jdk1.8.0_261/bin export PATH=$JAVA_HOME/bin:$NODE_HOME/bin:$PATH export CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 21,630
精华内容 8,652
关键字:

linux上升级tomcat

linux 订阅