精华内容
下载资源
问答
  • 一、OSPF基本概念OSPF(Open Shortest Path First)是一个内部网关协议(Interior Gateway Protocol,简称IGP)。...OSPF通过路由器之间通告网络接口的状态来建立链路状态数据库,生成最短路径树,每个OSPF路由器...

    一、OSPF基本概念
    OSPF(Open Shortest Path First)是一个内部网关协议(Interior Gateway Protocol,简称IGP)。与RIP相对,OSPF是链路状态路有协议,而RIP是距离向量路由协议。 链路是路由器接口的另一种说法,因此OSPF也称为接口状态路由协议。OSPF通过路由器之间通告网络接口的状态来建立链路状态数据库,生成最短路径树,每个OSPF路由器使用这些最短路径构造路由表。


    二、关于OSPF的实验操作
    1、组网需求
    • • 所有的交换机都运行 OSPF,并将整个自治系统划分为 3 个区域。
    • • 其中 Switch A 和 Switch B 作为 ABR 来转发区域之间的路由。
    • • 配置完成后,每台交换机都应学到 AS 内的到所有网段的路由
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    2配置步骤
    (1) 配置各接口的 IP 地址
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    例SwitchB:
    <H3C>sys
    [H3C]hostname SwitchB
    [SwitchB]vlan 100
    [SwitchB-vlan100]port g 1/0/10
    [SwitchB-vlan100]quit
    [SwitchB]vlan 200
    [SwitchB-vlan200]port g 1/0/20
    [SwitchB-vlan200]quit
    [SwitchB]inter vlan 100
    [SwitchB-Vlan-interface100]ip add 10.1.1.2 24
    [SwitchB-Vlan-interface100]quit
    [SwitchB]inter vlan 200
    [SwitchB-Vlan-interface200]ip add 10.3.1.1 24
    [SwitchB-Vlan-interface200]quit
    [SwitchB]

    (2) 配置 OSPF 基本配置
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    配置 Switch A。
    <SwitchA> system-view
    [SwitchA] router id 10.2.1.1
    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] network 10.2.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作

    配置 Switch B。
    <SwitchB> system-view
    [SwitchB] router id 10.3.1.1
    [SwitchB] ospf
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] area 2
    [SwitchB-ospf-1-area-0.0.0.2] network 10.3.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.2] quit
    [SwitchB-ospf-1] quit
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    配置 Switch C。
    <SwitchC> system-view
    [SwitchC] router id 10.4.1.1
    [SwitchC] ospf
    [SwitchC-ospf-1] area 1
    [SwitchC-ospf-1-area-0.0.0.1] network 10.2.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.1] network 10.4.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.1] quit
    [SwitchC-ospf-1] quit
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    配置 Switch D。
    <SwitchD> system-view
    [SwitchD] router id 10.5.1.1
    [SwitchD] ospf
    [SwitchD-ospf-1] area 2
    [SwitchD-ospf-1-area-0.0.0.2] network 10.3.1.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.2] network 10.5.1.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.2] quit
    [SwitchD-ospf-1] quit

    (3)验证配置
    查看 Switch A 的 OSPF 邻居。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    [SwitchA] display ospf peer verbose


    查看 Switch A 的 OSPF 路由信息。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    [SwitchA] display ospf routing


    查看 Switch D 的 OSPF 路由信息。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    [SwitchD] display ospf routing


    在 Switch D 上使用 Ping 进行测试连通性。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    [SwitchD] ping 10.4.1.1


    3、实验操作2
    配置OSPF引入自治系统外部路由

    1. 组网需求
      • • 所有的交换机都运行 OSPF,整个自治系统划分为 3 个区域。
      • • 其中 Switch A 和 Switch B 作为 ABR 来转发区域之间的路由。
      • • 在 Switch C 上配置为 ASBR 引入外部路由(静态路由),且路由信息可正确的在 AS 内传播。
      OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作

    2.配置步骤
    (1) 配置各接口的 IP 地址(略)
    (2) 配置OSPF(同前例 )
    (3) 配置引入自治系统外部路由
    在 Switch C 上配置一条到目的网段 3.1.2.0/24 的静态路由。
    <SwitchC> system-view
    [SwitchC] ip route-static 3.1.2.1 24 10.4.1.2
    在 Switch C 上配置 OSPF 引入静态路由。
    [SwitchC] ospf 1
    [SwitchC-ospf-1] import-route static
    验证配置
    查看 Switch D 的 ABR/ASBR 信息。
    <SwitchD> display ospf abr-asbr
    查看 Switch D 的 OSPF 路由表。
    <SwitchD> display ospf routing


    3、实验操作3
    配置OSPF发布聚合路由
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作

    1. 组网需求
      • • Switch A 和 Switch B 位于 AS 200 内,AS 200 内使用 OSPF 作为 IGP 协议。
      • • Switch C、Switch D 和 Switch E 位于 AS 100 内,AS 100 内使用 OSPF 作为 IGP 协议。
      • • Switch B 和 Switch C 之间建立 EBGP 连接,配置 BGP 引入 OSPF 和直连路由,配置 OSPF
      进程引入 BGP 路由。
      • • 为了减小 Switch A 的路由表规模,在 Switch B 上配置路由聚合,只发布聚合后的路由
      10.0.0.0/8。

    1. 配置步骤
      (1) 配置接口的 IP 地址
      OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作

    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作

    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作

    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作

    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    (2) 配置 OSPF
    配置 Switch A。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    <SwitchA> system-view
    [SwitchA] router id 11.2.1.2
    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 11.2.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit
    配置 Switch B。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    <SwitchB> system-view
    [SwitchB] router id 11.2.1.1
    [SwitchB] ospf
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 11.2.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit
    配置 Switch C。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    <SwitchC> system-view
    [SwitchC] router id 11.1.1.2
    [SwitchC] ospf
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit
    配置 Switch D。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    <SwitchD> system-view
    [SwitchD] router id 10.3.1.1
    [SwitchD] ospf
    [SwitchD-ospf-1] area 0
    [SwitchD-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] quit
    配置 Switch E。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    <SwitchE> system-view
    [SwitchE] router id 10.4.1.1
    [SwitchE] ospf
    [SwitchE-ospf-1] area 0
    [SwitchE-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [SwitchE-ospf-1-area-0.0.0.0] network 10.4.1.0 0.0.0.255
    [SwitchE-ospf-1-area-0.0.0.0] quit
    [SwitchE-ospf-1] quit

    (3) 配置 BGP,引入 OSPF 和直连路由
    配置 Switch B。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    [SwitchB] bgp 200
    [SwitchB-bgp] peer 11.1.1.2 as 100
    [SwitchB-bgp] address-family ipv4 unicast
    [SwitchB-bgp-ipv4] import-route ospf
    [SwitchB-bgp-ipv4] import-route direct
    [SwitchB-bgp-ipv4] peer 11.1.1.2 enable 注意不要少了这句
    [SwitchB-bgp-ipv4] quit
    [SwitchB-bgp] quit
    配置 Switch C。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    [SwitchC] bgp 100
    [SwitchC-bgp] peer 11.1.1.1 as 200
    [SwitchC-bgp] address-family ipv4 unicast
    [SwitchC-bgp-ipv4] import-route ospf
    [SwitchC-bgp-ipv4] import-route direct
    [SwitchC-bgp-ipv4] peer 11.1.1.1 enable #注意不要少了这句
    [SwitchC-bgp-ipv4] quit
    [SwitchC-bgp] quit

    (4) 在 Switch B 和 Switch C 上配置 OSPF 引入 BGP 路由
    在 Switch B 上配置 OSPF 引入 BGP 路由。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    [SwitchB] ospf
    [SwitchB-ospf-1] import-route bgp
    在 Switch C 上配置 OSPF 引入 BGP 路由。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    [SwitchC] ospf
    [SwitchC-ospf-1] import-route bgp
    查看 SwitchA 的路由表信息。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    [SwitchA] display ip routing-table

    (5) 在 Switch B 上配置路由聚合,只发布聚合路由 10.0.0.0/8。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    [SwitchB-ospf-1] asbr-summary 10.0.0.0 8
    查看 Switch A 的路由表信息。
    OSPF基本概念以及DR/BDR和虚连接OSPF特殊区域的实验操作
    [SwitchA] display ip routing-table

    转载于:https://blog.51cto.com/14220480/2402412

    展开全文
  • OSPF虚连接

    千次阅读 2019-07-25 16:08:06
    配置好 area 0 1 2 上的IP地址和loopback接口IP,邻居ip,router id 连接 进入area 1,进入区域1 [AR3-ospf-1-area-0.0.0.1]vlink-peer 4.4.4.4 //写对端的router id [AR4-ospf-1-area-0.0.0.1]vlink-peer 3.3.3.3...

    在这里插入图片描述
    配置好 area 0 1 2 上的IP地址和loopback接口IP,邻居ip,router id

    虚连接
    进入area 1,进入区域1

    [AR3-ospf-1-area-0.0.0.1]vlink-peer 4.4.4.4     //写对端的router id
    [AR4-ospf-1-area-0.0.0.1]vlink-peer 3.3.3.3
    
    展开全文
  • OSPF虚连接配置

    2020-04-20 11:11:20
    在配置连接的时候,我们需要想到ospf的两个特性: 1、非骨干区域必须与骨干区域保持连接 2、ospf通信必须依靠骨干区域来传输 连接(virtual link) 作用:1、解决骨干区域被分割的问题 2、解决非骨干区域...

    在配置虚连接的时候,我们需要想到ospf的两个特性:

    1、非骨干区域必须与骨干区域保持连接

    2、ospf通信必须依靠骨干区域来传输

    虚连接(virtual link)

    作用:1、解决骨干区域被分割的问题

    2、解决非骨干区域无法和骨干区域保持连接的问题

    组网方式:

    配置命令:

    1、配置网络各个接口的IP地址,并能够与相邻网段通信

    2、配置命令:ospf组网和虚连接

    AR1:
    [AR1]ospf 1 router-id 1.1.1.1
    [AR1-ospf-1]area 0
    [AR1-ospf-1-area-0.0.0.0]net 1.1.1.1 0.0.0.0
    [AR1-ospf-1-area-0.0.0.0]net 10.0.0.0 0.0.0.255

    AR2:
    [AR2]ospf 1 router-id 2.2.2.2
    [AR2-ospf-1]area 1
    [AR2-ospf-1-area-0.0.0.1]net 2.2.2.2 0.0.0.0 
    [AR2-ospf-1-area-0.0.0.1]net 20.0.0.0 0.0.0.255
    [AR2-ospf-1-area-0.0.0.1]vlink-peer 3.3.3.3
    [AR2-ospf-1-area-0.0.0.1]area 0
    [AR2-ospf-1-area-0.0.0.0]net 10.0.0.0 0.0.0.255

    AR3:
    [AR3]ospf 1 router-id 3.3.3.3
    [AR3-ospf-1]area 1
    [AR3-ospf-1-area-0.0.0.1]net 20.0.0.0 0.0.0.255
    [AR3-ospf-1-area-0.0.0.1]net 3.3.3.3 0.0.0.0
    [AR3-ospf-1-area-0.0.0.1]vlink-peer 2.2.2.2
    [AR3-ospf-1-area-0.0.0.1]area 0
    [AR3-ospf-1-area-0.0.0.0]net 30.0.0.0 0.0.0.255

    AR4:
    [AR4]ospf 1 router-id 4.4.4.4
    [AR4-ospf-1]area 0
    [AR4-ospf-1-area-0.0.0.0]net 4.4.4.4 0.0.0.0
    [AR4-ospf-1-area-0.0.0.0]net 30.0.0.0 0.0.0.255
     

    当我们没有建立虚连接的时候,就会发现路有表中的路由信息并不全面;而建立虚连接后,路由器就能完美的学到各个路由信息。我们同时也看到,所谓虚连接,就是在相同区域并相邻的邻居之间建立的一条虚拟链路

    调试命令:

    display ospf vlink

     

    展开全文
  • 绘图;OSPF 连接

    2019-10-02 17:15:27
    OSPF 连接 原图如下 绘图 实验拓扑 实验需求 按照图示分区域配置OSPF 配置连接认证 实验步骤 配置相应接口IP地址及loopback 环回口地址 按照图示分区域配置OSPF AR1 [Huawei]ospf router-id 1.1.1.1 ...

    绘图;OSPF 虚连接

    原图如下

    1735097-20190802174704367-428788776.png

    绘图

    1735097-20190802174623459-1309023913.png

    实验拓扑

    1735097-20190802175117079-999347499.png

    实验需求

    按照图示分区域配置OSPF
    配置虚连接认证

    实验步骤

    1. 配置相应接口IP地址及loopback 环回口地址
    2. 按照图示分区域配置OSPF
      AR1
    [Huawei]ospf router-id 1.1.1.1
    [Huawei-ospf-1]area 0
    [Huawei-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0
    [Huawei-ospf-1-area-0.0.0.0]network 20.1.1.0 0.0.0.255

    AR2

    [Huawei]ospf router-id 2.2.2.2
    [Huawei-ospf-1]area 0
    [Huawei-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
    [Huawei-ospf-1-area-0.0.0.0]network 20.1.1.0 0.0.0.255
    [Huawei-ospf-1]area 1
    [Huawei-ospf-1-area-0.0.0.1]network 30.1.1.0 0.0.0.255

    AR3

    [Huawei]ospf router-id 3.3.3.3
    [Huawei-ospf-1]area 1
    [Huawei-ospf-1-area-0.0.0.1]network 3.3.3.3 0.0.0.0
    [Huawei-ospf-1-area-0.0.0.1]network 30.1.1.0 0.0.0.255
    [Huawei-ospf-1]area 2
    [Huawei-ospf-1-area-0.0.0.1]network 40.1.1.0 0.0.0.255

    AR4

    [Huawei]ospf router-id 4.4.4.4
    [Huawei-ospf-1]area 2
    [Huawei-ospf-1-area-0.0.0.1]network 4.4.4.4 0.0.0.0
    [Huawei-ospf-1-area-0.0.0.1]network 40.1.1.0 0.0.0.255

    AR1 PING AR3 测试连通性

    [Huawei]ping 3.3.3.3
      PING 3.3.3.3: 56  data bytes, press CTRL_C to break
        Reply from 3.3.3.3: bytes=56 Sequence=1 ttl=254 time=20 ms
        Reply from 3.3.3.3: bytes=56 Sequence=2 ttl=254 time=20 ms
        Reply from 3.3.3.3: bytes=56 Sequence=3 ttl=254 time=30 ms
        Reply from 3.3.3.3: bytes=56 Sequence=4 ttl=254 time=40 ms
        Reply from 3.3.3.3: bytes=56 Sequence=5 ttl=254 time=40 ms
    
      --- 3.3.3.3 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 20/30/40 ms

    配置虚连接

    ospf非骨干区域必须和骨干区域相连才能通信,为了不改变网络拓扑,我们可以实现虚连接来扩大区域0的面积,实现区域互通。
    AR2

    [Huawei-ospf-1-area-0.0.0.1]vlink-peer 3.3.3.3

    AR3

    [Huawei-ospf-1-area-0.0.0.1]vlink-peer 2.2.2.2

    在AR3上查看虚连接

    建成邻居后 是P2P的一个链路

    [Huawei]dis ospf vlink 
    
         OSPF Process 1 with Router ID 3.3.3.3
             Virtual Links 
    
     Virtual-link Neighbor-id  -> 2.2.2.2, Neighbor-State: Full
    
     Interface: 30.1.1.2 (GigabitEthernet0/0/0)
     Cost: 1  State: P-2-P  Type: Virtual 
     Transit Area: 0.0.0.1 
     Timers: Hello 10 , Dead 40 , Retransmit 5 , Transmit Delay 1 
     GR State: Normal 

    AR1 PING AR4

    [Huawei]ping 4.4.4.4
      PING 4.4.4.4: 56  data bytes, press CTRL_C to break
        Reply from 4.4.4.4: bytes=56 Sequence=1 ttl=253 time=40 ms
        Reply from 4.4.4.4: bytes=56 Sequence=2 ttl=253 time=40 ms
        Reply from 4.4.4.4: bytes=56 Sequence=3 ttl=253 time=30 ms
        Reply from 4.4.4.4: bytes=56 Sequence=4 ttl=253 time=30 ms
        Reply from 4.4.4.4: bytes=56 Sequence=5 ttl=253 time=30 ms
    
      --- 4.4.4.4 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 30/34/40 ms

    虚连接上做认证

    AR2

    [Huawei-ospf-1-area-0.0.0.1]vlink-peer 3.3.3.3 simple cipher 123

    AR3

    [Huawei-ospf-1-area-0.0.0.1]vlink-peer 2.2.2.2 simple cipher 123

    测试连通性,AR4 PING AR1

    <Huawei>ping 1.1.1.1
      PING 1.1.1.1: 56  data bytes, press CTRL_C to break
        Reply from 1.1.1.1: bytes=56 Sequence=1 ttl=253 time=40 ms
        Reply from 1.1.1.1: bytes=56 Sequence=2 ttl=253 time=30 ms
        Reply from 1.1.1.1: bytes=56 Sequence=3 ttl=253 time=40 ms
        Reply from 1.1.1.1: bytes=56 Sequence=4 ttl=253 time=30 ms
        Reply from 1.1.1.1: bytes=56 Sequence=5 ttl=253 time=50 ms
    
      --- 1.1.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 30/38/50 ms

    转载于:https://www.cnblogs.com/yu15/p/11290224.html

    展开全文
  • OSPF虚链路与认证

    2019-08-20 15:10:33
    拓扑图: ...2.OSPF 链路被认为是骨干区域的一个接口,一条链路,也需要建立 OSPF 邻居,但在邻居建立之后,链路上是没有 Hello 包传递的。 3.链路地址一定要是对方的 router-id 认证: OSPF ...
  • OSPF虚链路技术

    2019-08-23 20:43:41
    OSPF架构:所有非骨干区域必须骨干区域相邻,如果不相邻必须有链路技术 配置的位置:区域边界路由器 注意:每个OSPF路由器都有一个router-id(标识符) 相当于人的身份证 默认路由器会自动选择本路由器接口的...
  • ospf支持简单口令认证和MD5验证,认证分两种: 1)接口验证:明文和密文:可以按照直连来做 2)区域验证:明文和密文:一个区域内的所有设备都得做 注:区域验证中电路属于区域0. 一、 接口与区域验证 配置条件:...
  • OSPF虚链路配置实验

    千次阅读 2018-12-06 10:11:44
    OSPF虚链路配置 1.组网需求 如图所示,Aea2没有与骨干区域直接相连。Area1被用作传输区域( Transit Area来连接Area2和Area0。 Area1区域为连接。 2.配置思路 (1)在各路由器上配置OSPF基本功能 (2)在AR2和 ...
  • ospf连接配置

    2019-01-07 16:44:00
    配置OSPF虚连接 组网需求 在图1中,Area2没有与骨干区域直接相连。Area1被用作传输区域(Transit Area)来连接Area2和Area0。SwitchA、SwitchB之间配置一条连接。 图1配置OSPF虚连接的组网图 ...
  • ospf 链路配置

    2010-06-22 20:54:32
    Authentication Over a Virtual Linksetp1 接口下配置KEY ip ospf authentication-key ciscosetp2 ospf进程下开启认证 router ospf 1 area 0 authenticationsetp3 在链路下开启认证 area 1 v...
  • 配置OSPF虚链路 如下图所示,Area 2没有与骨干区域Area 0直接连接,Area 1被用作传输区域来连接Area 2和Area 0,R1和R2之间配置一条链路; 接口IP地址配置: [r1]int g0/00/0 [r1-GigabitEthernet0/0/0]ip ...
  • 配置ospf 电路

    2009-09-01 14:29:36
    配置ospf电路,是一个与核心区域不相连的区域可以访问ospf的核心区域! 二、 拓扑结构 三、 实验步骤 1. 基本接口的配置 测试:auckland ping 192.168.240.1 通 Singapore ping 192.168.224.1 通 2......
  • HCL ospf 连接

    2020-04-22 11:44:44
    接口 IP地址 RTA G0/0 10.0.0.1/24 Loopback0 1.1.1.1/32 RTB G0/0 10.0.0.2/24 G0/1 20.0.0.1/24 Loopback0 2.2.2.2/32 RTC G0/0 30.0.0.1/24 G0/1 20.0.0.1/24 Loopback0 3.3.3...
  • H3C OSPF虚连接配置

    2021-04-17 17:30:24
    H3C OSPF虚连接配置 本篇介绍H3C路由器的OSPF虚连接配置 基本概念 连接是指在两台peer路由器互相建立的一条逻辑上的连接通道(一般要存在ABR路由的连接才是有效的连接)。 拓扑图 如图所示,如果每个路由器的...
  • 配置OSPF虚链路

    2020-02-29 08:43:31
    拓扑图如下: 条件: 4台路由 AR1220 ======================================================== AR-1配置: <Huawei>system-view //进系统视图 ...[AR-1]int g0/0/0 //进接口g0/0/0 [AR-1-Gi...
  • 思科上配置OSPF虚链路

    2020-08-16 16:11:56
    要求: R1与R4、R5相连属于区域0; R1与R2相连属于区域1; R2与R3相连属于区域2;...ip ospf 110 area 0 \将接口加入到区域0 router ospf 110 router-id 4.4.4.4 network 10.1.14.0 0.0.0.255 area 0 //宣告路由.
  • OSPF虚链路实验报告

    2008-02-24 15:56:29
    OSPF虚链路实验报告 1.实验拓扑: 2.实验目的:2.1按照拓扑图正确连接三台路由器。 2.2 正确配置相应的接口IP地址 2.3 配置OSPF虚链路把不与主干区域相连的区域逻辑连接 ( Conf...
  • 链路通信用的两个路由器在SPF中距离最近的两个接口单播通信 –用法: 。连接原理骨干的普通区域 。缝合断裂的骨干区域 1.实验目的 :r2与r3断开,r1仍可r4互通 实验目的:r2与r3断开,r1仍可r4互通 实验思路:运用...
  • ospf虚链路环路问题-1

    千次阅读 2014-11-03 18:59:11
    R4-R1,R1的1号接口-R2的1号接口 处于OSPF的Area0; R1的2号接口-R2的2号接口,R2-R3 处于OSPF的Area2; R3-R5 处于OSPF的Area2; R1和R3在Area1中建立起Vlink; HUAWEI中: LSA传递/路由...
  • 2.进入R1,设置接口IP,开启OSPF协议 3.进入R2,设置接口IP,开启OSPF协议 4.进入R3,设置接口IP,开启OSPF协议 5.进入R4,设置接口IP,开启OSPF协议 6.进入R2,开启链路 7.进入R3,开启链路 8.设置PC1,...
  • 实验任务一:连接的配置 建立物理连接 配置ospf协议 RTA G0/0 lo0加入area0,使能接口。 RTB G0/0 加入area0,G0/1.lo0加入area1,使能接口 RTC G0/2 加入area2,G0/1.lo0加入area1,使能接口 RTD G0/2 ,lo0加入area2...
  • 当骨干网络的线路断开后,使用链路使网络正常 二、实验拓扑 三、配置 1、规划地址(略) 2、基础配置,环回/接口IP(略) 3、启动OSPF,并划分区域 R1路由器: [r1]ospf 1 router-id 1.1.1.1 [r1-ospf-1]...
  • 4、链路通信用的两个路由器在SFP中距离最近的两个接口单播通信 用途 1、链接远离骨干域的普通区域 2、缝合断裂的骨干域 实验目的: R2与R3断开后,R1仍可与R4互通 实验配置 R1 sysname 1 interface ...
  • Cisco路由器的ospf虚链路路由配置

    千次阅读 2019-10-28 15:24:58
    通过OSPF虚链路的配置,实现跨区域主机的通信。 三 实验环境 GNS3,Windows10操作系统,SecureCRT8.0 四 实验过程 1.对路由器R1,R2,R3,R4进行接口ip配置 R1:conf t int f0/0 ip add 192.168.1.1 255.255.255.0 ...
  • 前言: 理论知识我在上一篇博客已经写过了,但光是掌握理论,而不去实践就如同纸上谈兵。只有理论与实践相结合,我们下能更深的理解与记忆。闲话少叙,接下来我会直接演示...需要注意的是R1与R3的接口不够,需要分别...
  • 认证 1:链路认证 //防止链路接入非法路由器(无授权...int e0/0 //进入需要做认证的接口 ip ospf authentication //开启明文认证 ip ospf authentication key-chain k //k为key-chain的名字,自行决定 key chain k ...
  • 课题内容:OSPF虚链路研究实验拓扑:基本IP地址规划:R3-R5之间使用 10.1.35.0/30 子网R1、R3、R4之间使用 10.1.1.0/24子网R1、R2、R4之间使用 10.1.124.0/24子网每台设备的环回接口使用 10.1.6.X/32 X = 设备编号帧...
  • ospf的认证 认证的过程;密文认证;把数据头部写入认准参数 1、链路认证 :防止链路接入非法路由器, 1.明文认证 //不安全 接口下 int e0/0 ip ospf authentication ip ospf authentication-key cisco 2.md5 认证 //...
  • OSPF通过路由器之间通告网络接口的状态来建立链路状态数据库,生成最短路径树,每个OSPF路由器使用这些最短路径构造路由表。在一个AS(Autonomous System,自治系统)中,所有的OSPF路由器都维护一个相同的描述这个...

空空如也

空空如也

1 2 3 4 5 ... 8
收藏数 145
精华内容 58
关键字:

虚接口ospf