精华内容
下载资源
问答
  • 最近在升级IntelliJ IDEA 2021.2是出现异常窗口,跳出的提示窗口只能选择 Cancel 取消升级。 我们可以在官方网站上下载JetBrains Toolbox。 网址:https://www.jetbrains.com/toolbox-app/ 下载完毕之后可以在...

    最近在升级IntelliJ IDEA 2021.2是出现异常窗口,跳出的提示窗口只能选择 Cancel 取消升级。

    我们可以在官方网站上下载JetBrains Toolbox。

    网址:https://www.jetbrains.com/toolbox-app/

    下载完毕之后可以在其中下载或升级软件,不会出现上面的异常冲突。

     

     

    展开全文
  • 今天到工作室比较晚,在电脑前吃着早饭,看到提示IDEA提示升级,寻思已经有好久没有升过级了。一样等着,就升级下吧。 升级完毕重启之后,突然发现好多错误,原来的应用也没法启动了。仔细一看报错信息,是由于...

    今天到工作室比较晚,在电脑前吃着早饭,看到提示IDEA提示升级,寻思已经有好久没有升过级了。一样等着,就升级下吧。

    升级完毕重启之后,突然发现好多错误,原来的应用也没法启动了。仔细一看报错信息,是由于Lombok相关的注解似乎都没有生效。

    比如:用到@Slf4j的类里,会有类似这样的报错:

    java: 找不到符号
      符号:   变量 log
      位置: 类 com.didispace.UserService

    IDEA还提示,现在使用的编译器不支持lombok

    java: You aren't using a compiler supported by lombok, so lombok will not work and has been disabled.
      Your processor is: com.sun.proxy.$Proxy26
      Lombok supports: sun/apple javac 1.6, ECJ

    搜索一番,是由于IDEA版本导致的Lombok失效,不过这个问题后来解决了。 所以,我们只需要更新lombok版本,使用1.18.14及之后的版本即可:

    <dependency>
     <groupId>org.projectlombok</groupId>
     <artifactId>lombok</artifactId>
     <version>1.18.14</version>
     <scope>provided</scope>
    </dependency>

    如果是Spring Boot用户,往往不写版本号,因为2.x开始,就Spring Boot就把lombok的版本一起纳入了。有些Spring Boot的老版本就比较容易出现这个问题,比如DD这边出问题的工程就是使用的2.1.3,这里默认引入的lombok版本是1.18.6。

    因为Lombok版本低,所以在IDEA升级之后就出了这样的问题。手工维护版本到1.18.14之后,得到解决。


    如果上面的办法无法解决你的问题,那么再看看下面这些,或许可以帮你解决问题:

    1. Lombok插件是否安装、是否开启

    1. Annotation Processors中的Enable annotation processing是否勾选

    1. 在Compiler中增加参数配置:-Djps.track.ap.dependencies=false

    欢迎关注我的公众号:程序猿DD,分享其他地方看不到的知识与思考

    展开全文
  • 昨天IDEA升级到2021.2之后发现启动界面没了,双击等待后直接进入项目。 经过多方查找,发现先问题如下: idea 2021.2版本启动界面消失,是因为从旧版升级到新版的jvm启动参数-Dsplash=true导致的。 新版jvm是G1。...

    昨天IDEA升级到2021.2之后发现启动界面没了,双击等待后直接进入项目。

    经过多方查找,发现先问题如下:

    idea 2021.2版本启动界面消失,是因为从旧版升级到新版的jvm启动参数-Dsplash=true导致的。

    新版jvm是G1。

    下面是我本人的配置,内存大小分配大家根据自己情况修改。

    -Xms3072m
    -Xmx5120m
    -XX:ReservedCodeCacheSize=1024m
    -XX:+UseG1GC
    -XX:SoftRefLRUPolicyMSPerMB=50
    -XX:CICompilerCount=2
    -XX:+HeapDumpOnOutOfMemoryError
    -XX:-OmitStackTraceInFastThrow
    -ea
    -Dsun.io.useCanonCaches=false
    -Djdk.http.auth.tunneling.disabledSchemes=""
    -Djdk.attach.allowAttachSelf=true
    -Djdk.module.illegalAccess.silent=true
    -Dkotlinx.coroutines.debug=off
    -Dsplash=true
    -Dfile.encoding=utf-8

    展开全文
  • 升级idea之后无法启动

    2021-12-15 11:21:41
    升级idea后无法启动 问题: 将老版本idea卸载,装最新版本的idea之后双击开始下载插件,插件下载好后出现idea启动页面,但是过一会儿启动页面就消失了,然后多次双击idea图标均启动不了idea。 原因: 老版本idea...

    问题:

    将老版本idea卸载,装最新版本的idea之后双击开始下载插件,插件下载好后出现idea启动页面,
    但是过一会儿启动页面就消失了,然后多次双击idea图标均启动不了idea。
    

    原因:

    老版本idea卸载的时候会有配置文件未被清理,如果原来使用过破解版本,
    那么就会在idea的配置文件中配置破解文件的位置,一般在安装目录的bin下面“idea64.exe.vmoptions”中,
    还可能在“C:\Users\Administrator\.IntelliJIdea2020.3\config\idea64.exe.vmoptions”
    及“C:\Users\Administrator\AppData\Roaming\JetBrains\IntelliJIdea2020.3\idea64.exe.vmoptions”中,配置一般为“-
    javaagent:盘符:\JetBrains\ideaIU-2020.3.3\bin\jetbrains-agent.jar”。
    

    解决办法:

    三个位置都要将配置删除,保存之后重启即可。
    

    备注:目录“C:\Users\Administrator.IntelliJIdea2020.3”和目录“C:\Users\Administrator\AppData”可能隐藏了,需要勾选显示隐藏文件才行。

    展开全文
  • 升级idea前使用idea 2020.1 maven多模块项目运行正常,升级到idea 2021.1后,每次修改代码,项目均无法正常编译。 2.解决办法 删除.idea文件夹以及其它配置文件,重新导入项目,idea会自动将其识别为maven multi ...
  • 是否是自己的jdk版本安装为32导致的与64位idea不匹配 答案:否。因为2021.1为最后一个同时支持idea32/64版本,排除。 解决 死马当活马医,刚刚都能成功启动一次,刚又配置了jdk,现在重新恢复原始配置文件。 右键...
  • IDEA 下 Gradle 构建的 WEB 项目,如何将 Java7 升级到 Java8 呢(其他版本通用)?过程如下:1、修改 gradle 的 build.gradle修改 Java 编译版本。如下所示,将 sourceCompatibility 和 targetCompatibility 分别由 ...
  • 联想今天在美国市场发布了新版上网本IdeaPad S10-2,主要对S10的用户体验特性进行了提升,让上网本更加方面易用。IdeaPad S10-2的硬件平台和S10完全相同,包括10.1寸LED背光液晶屏幕,Atom N270处理器,1GB DDR2内存...
  • idea升级问题导致的编译器打不开问题 原因分析: 因为之前用过jetbrains-agent-latest插件,所以应该是插件导致的升级无法打开编译器问题 解决方案: **1.**找到你的idea安装路径的bin目录下的idea.bat 批处理...
  • file–project structure–SDKs,依照红色数字标记依次选择,3处为升级选项。
  • 下载IDEA并安装2. 启动IDEA试用,按下图添加PLUGINS仓库地址3. 重启IDEA使用 1. 下载IDEA并安装 2. 启动IDEA试用,按下图添加PLUGINS仓库地址 在市场里搜索IDE EVAL RESET,下载安装 3. 重启IDEA使用
  • IntelliJ IDEA 直接在软件中更新为最新版

    万次阅读 多人点赞 2020-12-31 15:17:56
    当我们的 IDEA 工具许久没有更新,已经拖了好几个版本时,此时,想跨大版本更新,比如从2020.2.1 -> 2020.3.1 此时,我们菜单栏点击 Help -> Check for Updates… 时,提示的更新可能不是我们想要的最新版,...
  • IDEA的scala版本更换

    2021-11-19 11:34:51
    1.查看IDEA版本 2.IDEA官网下载scala对应的版本:http://plugins.jetbrains.com/plugin/1347-scalaScala - IntelliJ IDEs Plugin | Marketplacehttp://plugins.jetbrains.com/plugin/1347-scala
  • 有时候自动生成的web.xml版本太旧,需要自己手动更新。 Project Structure——>Moudels——>项目展开,选中Web——>点击右边的减号,删掉那一排——>...随便加点数字字母(因为有个小bug)——>......
  • Intellj IDEA 设置默认maven版本
  • 引言有小伙伴留言:Intellj IDEA升级新版本或者卸载老版本安装新版本后出现双击图标无法运行的情况。今天,就向大家介绍如何解决这个问题。1 步骤找到电脑上的idea安装路径的bin目...
  • 最近遇到一个非常头疼的事情,idea升级2020.1.1后运行多moudle项目报错: 解决:Error(5, 33) java 找不到符号符号 解决办法: 1.勾选Delegate IDE build/run actions Maven选项 2.执行maven clean 3.执行build ...
  • 因为升级之后 ReCompile 的选项没了 找了半天,发现还有个快捷键可以用 ctrl+shift+F9 (但是你鼠标光标要在你要编译的java文件的源码里面而不是左边的文件上线,切记) 总结下快捷键 首先先说一下从IDEA上获取...
  • IDEA中使用git版本管理

    2020-12-23 23:49:18
    首先通过idea打开工程 1、idea导航栏中file–settings 2、在界面中选择Version Control,找到Git,为工程选择git路径(安装目录-bin-git.exe) 3、idea界面导航栏中,VCS–Import into Version Control–Create Git ...
  • idea升级迁移问题总结

    2021-10-27 00:14:31
    随着idea版本升级,以前的配置还是需要用,就得用到idea配置迁移 迁移步骤 方法1: 下载最新的idea,配置idea.properties文件,修改两个配置路径 修改为以前idea配置的路径 然后启动最新的idea 方法2: ...
  • idea版本和maven版本不兼容问题 环境: maven: maven-3.8.1 idea: ULTIMATE 2019.2 问题:在一个新的项目中出现了异常,不能下载maven依赖。 class org.jetbrains.idea.maven.server.embedder.CustomMaven3...
  • 1、点击蓝色项目结构 2、在Moudle里找到web 点 - 减号 删掉原来的 3、+ 新生成web.xml 记住得改个名字 不然生成不出来 生成好再该回去就行
  • 升级到 IntelliJ IDEA 2021.2,启动项目报错问题描述解决方案 问题描述 升级到 IntelliJ IDEA 2021.2,启动项目报错。 Unrecognized option: --add-opens=jdk.compiler/com.sun.tools.javac.code=ALL-UNNAMED 解决...
  • 使用Idea建立新的模块后,jdk选择了Java 11,新的版本功能总是无法使用。 配置JDK 个人使用的是openjdk,主要原因是oracle的账号密码忘记了…当然也可以使用其他第三方jdk,比如亚马逊。 Maven 配置 <...
  • IDEA修改JDK(全)

    2020-12-24 15:32:42
    确定pom.xml配置是否正确: [java] view plain copy org.apache.maven.plugins maven-compiler-plugin 2.3.2 1.8 1.8 UTF-8 我是死在最后一步的,公司的项目很多是依赖关系,部分还升级到jdk1.8版本,但是其中一个...
  • IDEA pom.xml 依赖版本号报错 IDEA pom文件的 spring-boot-maven-plugin报红
  • 升级jetbrain idea 2019.2后,maven编译报错,提示重复的类打开项目,看到idea的更新提示有新版本2019.2,我想都没想直接点了升级,结果升级后,maven编译同样的项目,总是提示”xxx重复的类”。尝试解决的过程:1....
  • 1. Intellj 升级新版版或者卸载老版本安装新版本后出现双击图标无法运行的情况 找到你的idea安装路径的bin目录下的idea.bat 批处理脚本,使用文本编辑器打开 idea.bat 脚本,在最后一行加上pause IDEA 2020.2.2...
  • 作者 |码农小胖哥来源 |https://mp.weixin.qq.com/s/1go69A0uhiadVb-mOrd5mA更新到Intellij IDEA 2021.3之后,Mave...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 31,506
精华内容 12,602
关键字:

升级idea