精华内容
下载资源
问答
  • 端口有三种模式:access,Hybrid,Trunk。access就不说了,trunk可以属于多个VLAN,可以接收和发送多个vlan的报文,一般用于交换机...trunkhybrid的区别主要是,hybrid端口可以允许多个vlan的报文不打标签,而tr...

    端口有三种模式:access,Hybrid,Trunk。access就不说了,trunk可以属于多个VLAN,可以接收和发送多个vlan的报文,一般用于交换机之间的连接;hybrid也可以属于多个vlan,可以接收和发送多个vlan的报文,可以用于交换机之间的连接也可以用于交换机和用户计算机之间的连接。trunk和hybrid的区别主要是,hybrid端口可以允许多个vlan的报文不打标签,而trunk端口只允许缺省vlan的报文不打标签,同一个交换机上不能hybrid和trunk并存。

    下边详细介绍一下三种端口:

    untag就是普通的ethernet报文,普通PC机的网卡是可以识别这样的报文进行通讯;

    tag报文结构的变化是在源MAC地址和目的mac地址之后,加上了4bytes的vlan信息,也就是vlan tag头;一般来说这样的报文普通PC机的网卡是不能识别的

    下图说明了802.1Q封装tag报文帧结构

    带802.1Q的帧是在标准以太网帧上插入了4个字节的标识。其中包含:

    2个字节的协议标识符(TPID),当前置0x8100的固定值,表明该帧带有802.1Q的标记信息。

    2个字节的标记控制信息(TCI),包含了三个域。

    Priority域,占3bits,表示报文的优先级,取值0到7,7为最高优先级,0为最低优先级。该域被802.1p采用。

    规范格式指示符(CFI)域,占1bit,0表示规范格式,应用于以太网;1表示非规范格式,应用于Token Ring。

    VLAN ID域,占12bit,用于标示VLAN的归属。

    以太网端口有三种链路类型:Access、Hybrid和Trunk。

    Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;

    Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;

    Hybrid类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。

    Hybrid端口和Trunk端口在接收数据时,处理方法是一样的,唯一不同之处在于发送数据时:Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    在这里先要向大家阐明端口的缺省VLAN这个概念

    Access端口只属于1个VLAN,所以它的缺省VLAN就是它所在的VLAN,不用设置;

    Hybrid端口和Trunk端口属于多个VLAN,所以需要设置缺省VLAN ID。缺省情况下,Hybrid端口和Trunk端口的缺省VLAN为VLAN 1

    当端口接收到不带VLAN Tag的报文后,则将报文转发到属于缺省VLAN的端口(如果设置了端口的缺省VLAN ID)。当端口发送带有VLAN Tag的报文时,如果该报文的VLAN ID与端口缺省的VLAN ID相同,则系统将去掉报文的VLAN Tag,然后再发送该报文。

    注:对于华三交换机缺省VLAN被称为“Pvid Vlan”,对于思科交换机缺省VLAN被称为“Native Vlan”交换机接口出入数据处理过程如下:

    Acess端口收报文:

    收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则直接丢弃(缺省)

    Acess端口发报文:

    将报文的VLAN信息剥离,直接发送出去

    (所以,Access端口可以实现同一交换机上相同VLAN下的主机通信;也可以实现交换机级连时的缺省VLAN1报文交换,但不能实现VLAN透传。)

    trunk端口收报文:

    收到一个报文,判断是否有VLAN信息:如果有,判断该trunk端口是否允许该 VLAN的数据进入:如果可以则转发,否则丢弃;如果没有VLAN信息则打上端口的PVID,并进行交换转发。

    trunk端口发报文:

    比较将要发送报文的VLAN信息和端口的PVID,如果不相等则直接发送。如果两者相等则剥离VLAN信息,再发送。

    (所以,将交换机级连口统统设置为Trunk并允许所有VLAN通过后,VLAN2-VLAN4000直接透传,而VLAN1则因为和Trunk缺省 PVID相同,需要通过剥离VLAN信息又添加VLAN信息实现了透传。而如果更改Trunk的缺省PVID,则可以实现某一交换机下的VLAN-X和另一交换机下的VLAN-Y通信。)

    hybrid端口收报文:

    收到一个报文,判断是否有VLAN信息:如果有,则判断该hybrid端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃(此时端口上的untag配置是不用考虑的,untag配置只对发送报文时起作用);

    如果没有则打上端口的PVID,并进行交换转发。

    hybrid端口发报文:

    1、判断该VLAN在本端口的属性(disp interface 即可看到该端口对哪些VLAN是untag,哪些VLAN是tag)

    2、如果是untag则剥离VLAN信息,再发送,如果是tag则直接发送

    (所以,Hybrid实现了不同VLAN下的主机的通信。)

    以下案例可以帮助大家深入理解华三交换机的hybrid端口模式

    [Switch-Ethernet0/1]int e0/1

    [Switch-Ethernet0/1]port link-type hybrid

    [Switch-Ethernet0/1]port hybrid pvid vlan 10

    [Switch-Ethernet0/1]port hybrid vlan 10 20 untagged

    [Switch-Ethernet0/1] int e0/2

    [Switch-Ethernet0/2]port link-type hybrid

    [Switch-Ethernet0/2]port hybrid pvid vlan 20

    [Switch-Ethernet0/2]port hybrid vlan 10 20 untagged

    此时inter e0/1和inter e0/2下的所接的PC是可以互通的,但互通时数据所走的往返vlan是不同的。

    以下以inter e0/1下的所接的pc1访问inter e0/2下的所接的pc2为例进行说明

    pc1所发出的数据,由inter0/1所在的pvid vlan10封装vlan10的标记后送入交换机,交换机发现inter e0/2允许vlan 10的数据通过,于是数据被转发到inter e0/2上,由于inter e0/2上vlan 10是untagged的,于是交换机此时去除数据包上vlan10的标记,以普通包的形式发给pc2,此时pc1->p2走的是vlan10

    再来分析pc2给pc1回包的过程,pc2所发出的数据,由inter0/2所在的pvid vlan20封装vlan20的标记后送入交换机,交换机发现inter e0/1允许vlan 20的数据通过,于是数据被转发到inter e0/1上,由于inter e0/1上vlan 20是untagged的,于是交换机此时去除数据包上vlan20的标记,以普通包的形式发给pc1,此时pc2->pc1走的是vlan20

    展开全文
  • vlan标签详解 access、trunkhybrid的区别 我们知道,不同网段间需要通过路由转发才能通信; 那在同一网段不同vlan之间的PC,是不能互相通信的。其实这并不是绝对的。了解vlan的各种标签后,我们就能不通过路由也能...

    vlan标签详解 access、trunk和hybrid的区别

    我们知道,不同网段间需要通过路由转发才能通信;
    那在同一网段不同vlan之间的PC,是不能互相通信的。其实这并不是绝对的。了解vlan的各种标签后,我们就能不通过路由也能实现不同网段的数据互通。

    Vlan的三种接口

    access、trunk和hybrid
    我们所说的vlan,就是给数据打上了vlan的标签
    交换机的数据转发,我们可以理解为
    数据进入时,默认是要带标签进入的
    若数据没标签,我们可以选择给数据打上标签后放通和不打标签放通
    若有标签,在根据我们的配置来检查是否要放通数据

    数据离开时,默认是要给他脱标签的
    若无标签,那也省事,直接放通
    若有标签,查看设置,又分三种情况:1脱去标签放通 2带标签放通 3丢弃数据

    接口特性

    Access口特性,默认数据进入时打上此端口所属vlan的标签,数据出去时脱去所属vlan的标签

    Trunk口特性,可以设置允许通过哪些标签的数据通过,也就是可以阻止部分数据通过。
    华为交换机的命令port trunk allow-pass vlan 10 20 30 //10,20,30为vlan标签号,也可以用all表示所有vlan号

    hybrid口,就比较灵活,可以设置打的标签号,命令port hybrid pvid vlan 10
    也可以设置脱哪些标签,命令port hybrid untagged vlan 30 40
    还可以设置放哪些标签通过,命令port hybrid tagged vlan 20 50

    实验

    下面,来做个实验验证一下
    拓扑图
    在这里插入图片描述
    Lsw3配置
    vlan batch 10 20 30

    interface Ethernet0/0/1
    port link-type access
    port default vlan 10

    interface Ethernet0/0/2
    port link-type access
    port default vlan 20

    interface Ethernet0/0/3
    port link-type access
    port default vlan 30

    interface GigabitEthernet0/0/1
    port link-type trunk
    undo port trunk allow-pass vlan 1
    port trunk allow-pass vlan 10 20

    Lsw6配置
    vlan batch 10 20 30

    interface Ethernet0/0/1
    port hybrid pvid vlan 10
    port hybrid untagged vlan 10 20

    interface Ethernet0/0/2
    port hybrid pvid vlan 20
    port hybrid untagged vlan 10 20

    interface Ethernet0/0/3
    port link-type access
    port default vlan 30

    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 10 20

    各pc机IP如图上所标
    测试结果
    PC6与PC7不通 我们常规理解的不同vlan不能通信
    PC6与PC8通,却PC6与PC9不通,是因为PC9回数据时,打上了vlan20的标签,在传到PC6的过程中,始终带着标签。而PC只接受无标签数据,故不通
    PC8与PC9通,是应为数据最后都被脱去了标签
    PC12与PC13不通,是因为他们的数据带的是vlan30的标签,在trunk口这,没有被允许通过,故不通

    展开全文
  • access trunk hybrid的区别

    千次阅读 2010-12-22 23:24:00
    1.... trunk端口 (1)收到一个二层帧 (2)判断是否有VLAN标签:没有则转到第3步,有则转到第4步 (3)打上端口PVID,并进行交换转发 (4)判断该trunk端口是否允许该VLA

    1. Access端口

    (1)收到一个二层帧

    (2)判断是否有VLAN标签:没有则转到第3步,有则转到第4步

    (3)打上端口的PVID,并进行交换转发

    (4)若VLAN标签和PVID一致,转发VLAN帧;否则直接丢弃

    2. trunk端口

    (1)收到一个二层帧

    (2)判断是否有VLAN标签:没有则转到第3步,有则转到第4步

    (3)打上端口的PVID,并进行交换转发

    (4)判断该trunk端口是否允许该VLAN帧进入:允许则转发,否则直接丢弃

    (注意:trunk口允许或不允许VLAN帧,是对进入的帧而言的,对出去的帧没有限制。)

    3. hybrid端口

    (1)收到一个二层帧

    (2)判断是否有VLAN标签:没有则转到第3步,有则转到第4步

    (3)打上端口的PVID,并进行交换转发

    (4)判断该hybrid端口是否允许该VLAN帧进入:允许则转发,否则

    直接丢弃

    可以看到,trunk口和hybrid口对接收到的数据帧的处理规则是一样的。

     

    展开全文
  • 端口有三种模式:access,Hybrid,Trunk。access就不说了,trunk可以属于多个VLAN,可以接收和发送多个vlan的报文,一般用于交换机...trunkhybrid的区别主要是,hybrid端口可以允许多个vlan的报文不打标签,而tr...

    端口有三种模式:access,Hybrid,Trunk。access就不说了,trunk可以属于多个VLAN,可以接收和发送多个vlan的报文,一般用于交换机之间的连接;hybrid也可以属于多个vlan,可以接收和发送多个vlan的报文,可以用于交换机之间的连接也可以用于交换机和用户计算机之间的连接。trunk和hybrid的区别主要是,hybrid端口可以允许多个vlan的报文不打标签,而trunk端口只允许缺省vlan的报文不打标签,同一个交换机上不能hybrid和trunk并存。

    下边详细介绍一下三种端口:

    untag就是普通的ethernet报文,普通PC机的网卡是可以识别这样的报文进行通讯;

    tag报文结构的变化是在源MAC地址和目的mac地址之后,加上了4bytes的vlan信息,也就是vlan tag头;一般来说这样的报文普通PC机的网卡是不能识别的

    下图说明了802.1Q封装tag报文帧结构

    带802.1Q的帧是在标准以太网帧上插入了4个字节的标识。其中包含:

    2个字节的协议标识符(TPID),当前置0x8100的固定值,表明该帧带有802.1Q的标记信息。

    2个字节的标记控制信息(TCI),包含了三个域。

    Priority域,占3bits,表示报文的优先级,取值0到7,7为最高优先级,0为最低优先级。该域被802.1p采用。

    规范格式指示符(CFI)域,占1bit,0表示规范格式,应用于以太网;1表示非规范格式,应用于Token Ring。

    VLAN ID域,占12bit,用于标示VLAN的归属。

    以太网端口有三种链路类型:Access、Hybrid和Trunk。

    Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;

    Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;

    Hybrid类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。

    Hybrid端口和Trunk端口在接收数据时,处理方法是一样的,唯一不同之处在于发送数据时:Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    在这里先要向大家阐明端口的缺省VLAN这个概念

    Access端口只属于1个VLAN,所以它的缺省VLAN就是它所在的VLAN,不用设置;

    Hybrid端口和Trunk端口属于多个VLAN,所以需要设置缺省VLAN ID。缺省情况下,Hybrid端口和Trunk端口的缺省VLAN为VLAN 1

    当端口接收到不带VLAN Tag的报文后,则将报文转发到属于缺省VLAN的端口(如果设置了端口的缺省VLAN ID)。当端口发送带有VLAN Tag的报文时,如果该报文的VLAN ID与端口缺省的VLAN ID相同,则系统将去掉报文的VLAN Tag,然后再发送该报文。

    注:对于华三交换机缺省VLAN被称为“Pvid Vlan”,对于思科交换机缺省VLAN被称为“Native Vlan”交换机接口出入数据处理过程如下:

    Acess端口收报文:

    收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则直接丢弃(缺省)

    Acess端口发报文:

    将报文的VLAN信息剥离,直接发送出去

    (所以,Access端口可以实现同一交换机上相同VLAN下的主机通信;也可以实现交换机级连时的缺省VLAN1报文交换,但不能实现VLAN透传。)

    trunk端口收报文:

    收到一个报文,判断是否有VLAN信息:如果有,判断该trunk端口是否允许该 VLAN的数据进入:如果可以则转发,否则丢弃;如果没有VLAN信息则打上端口的PVID,并进行交换转发。

    trunk端口发报文:

    比较将要发送报文的VLAN信息和端口的PVID,如果不相等则直接发送。如果两者相等则剥离VLAN信息,再发送。

    (所以,将交换机级连口统统设置为Trunk并允许所有VLAN通过后,VLAN2-VLAN4000直接透传,而VLAN1则因为和Trunk缺省 PVID相同,需要通过剥离VLAN信息又添加VLAN信息实现了透传。而如果更改Trunk的缺省PVID,则可以实现某一交换机下的VLAN-X和另一交换机下的VLAN-Y通信。)

    hybrid端口收报文:

    收到一个报文,判断是否有VLAN信息:如果有,则判断该hybrid端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃(此时端口上的untag配置是不用考虑的,untag配置只对发送报文时起作用);

    如果没有则打上端口的PVID,并进行交换转发。

    hybrid端口发报文:

    1、判断该VLAN在本端口的属性(disp interface 即可看到该端口对哪些VLAN是untag,哪些VLAN是tag)

    2、如果是untag则剥离VLAN信息,再发送,如果是tag则直接发送

    (所以,Hybrid实现了不同VLAN下的主机的通信。)

    以下案例可以帮助大家深入理解华三交换机的hybrid端口模式

    [Switch-Ethernet0/1]int e0/1

    [Switch-Ethernet0/1]port link-type hybrid

    [Switch-Ethernet0/1]port hybrid pvid vlan 10

    [Switch-Ethernet0/1]port hybrid vlan 10 20 untagged

    [Switch-Ethernet0/1] int e0/2

    [Switch-Ethernet0/2]port link-type hybrid

    [Switch-Ethernet0/2]port hybrid pvid vlan 20

    [Switch-Ethernet0/2]port hybrid vlan 10 20 untagged

    此时inter e0/1和inter e0/2下的所接的PC是可以互通的,但互通时数据所走的往返vlan是不同的。

    以下以inter e0/1下的所接的pc1访问inter e0/2下的所接的pc2为例进行说明

    pc1所发出的数据,由inter0/1所在的pvid vlan10封装vlan10的标记后送入交换机,交换机发现inter e0/2允许vlan 10的数据通过,于是数据被转发到inter e0/2上,由于inter e0/2上vlan 10是untagged的,于是交换机此时去除数据包上vlan10的标记,以普通包的形式发给pc2,此时pc1->p2走的是vlan10

    再来分析pc2给pc1回包的过程,pc2所发出的数据,由inter0/2所在的pvid vlan20封装vlan20的标记后送入交换机,交换机发现inter e0/1允许vlan 20的数据通过,于是数据被转发到inter e0/1上,由于inter e0/1上vlan 20是untagged的,于是交换机此时去除数据包上vlan20的标记,以普通包的形式发给pc1,此时pc2->pc1走的是vlan20

    展开全文
  • TRUNKHYBRID的区别是什么?

    千次阅读 2006-10-22 12:46:03
    端口有三种模式:access,hybrid,trunk。access就不说了,trunk可以属于多个vlan,可以接收和发送多个vlan的报文,一般用于交换机之间的连接;...trunkhybrid的区别主要是,hybrid端口可以允许多个vlan...
  • 首先我们看三种端口对接收不带Tag和带tag报文...access性质端口只能属于一个vlan,且该端口不打tag,trunk可以属于多个vlan,可以接收和发送多个vlan报文,一般用于交换机之间连接;hybrid也可以属于多个v...
  • 端口有三种模式:access,hybrid,trunk。access就不说了,trunk可以属于多个vlan,可以接收和发送多个vlan的报文,一般用于交换机之间的连接;...trunkhybrid的区别主要是,hybrid端口可以允许多个vlan...
  • 以太网端口有三种链路类型:Access、HybridTrunk。 Access类型端口只能属于1个VLAN,一般用于连接计算机端口; Trunk类型端口可以属于多个VLAN,可以接收和发送多个VLAN报文,一般用于交换机之间...
  • 本文主要讲述华为access、trunkhybrid端口。
  • 这三种链路类型连接终端有所区别: Access类型端口只能属于1个VLAN,一般用于连接计算机端口; Trunk类型端口可以允许多个VLAN通过,可以接收和发送多个VLAN报文,一般用于交换机之间连接端口; ...
  • 转载自:https://blog.51cto.com/shyln/2087240一,Access、HybridTrunk三种模式理解Tag,untag以及交换机各种端口模式是网络工程技术人员调试交换机时接触最多概念了,然而笔者发现在实际工作中技术人员...
  • 有网友问这样一个问题:  vlan 1  #  vlan 2  #  vlan 3  #  vlan 4  #  vlan 5  #  interface Ethernet0/1 ... port link-type hybrid ... port hybrid vlan 1 to 4 untagged ... port hybrid p...
  • 以下是我对vlan一点理解。 大家知道,交换机会把广播报文(目的mac地址全1报文)和未知单播报文从所有端口转发出去(除了报文接收端口),这就是广播。(对未知多播报文如何处理呢,我不知道,应该也会广播...
  • VLAN中access、TrunkHybrid三种端口区别: acesss:1、发送不带标签报文 2、一般与PC\server相连时使用 3、只可以属于一个VLAN Trunk:1、发送带标签报文 2、一般用于交换机级联端口传递多组VLAN信息使用...
  • 2、Trunk口:可以属于多个VLAN ,且默认VLAN数据帧会发出会去掉VLAN标签,其他VLAN发送不去除VLAN标签,所以只有默认VLAN端口可以连客户端 3、Hybrid口:可以属于多个VLAN,可以让属于多个VLAN端口为数据帧...
  • 大家知道,交换机会把广播报文(目的mac地址全1报文)和未知单播报文从所有端口转发出去(除了报文接收端口),这就是广播。(对未知多播报文如何处理呢,我不知道,应该也会广播出去,这是一个遗留问题,哪位...
  • Access/Hybrid/Trunk 端口模式及区别

    千次阅读 2010-10-27 18:17:00
    Access/Hybrid/Trunk 端口模式及区别 2010-10-27在工作和交流中,总会有人为HybridTrunk的概念和区别争吵,前几天面试时候还和面试官争论了起来, 现做一个总结和概念涔清。 首先看下 IEEE-820.1Q-1998中 ...
  • 有网友问这样一个问题: vlan 1 # vlan 2 # vlan 3 # vlan 4 # vlan 5 # interface Ethernet0/1 port link-type hybrid port hybrid vlan 1 to 4 un
  • 交换机以太网端口有3种链路类型:access、trunk、hybird。...Hybrid类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,可以用于交换机间连接也可以用于连接用户计算机。下面就一起来了解下...
  • access、trunkhybrid三种网络端口类型的区别:access:只允许有一个VLAN,且为pvid,通常连接电脑或服务器;trunk:允许有多个VLAN,但只允许有一个为pvid,通常为交换机与交换机互连端口 ;hybrid:1)为access及...

空空如也

空空如也

1 2 3 4 5
收藏数 86
精华内容 34
关键字:

hybrid的区别trunk