精华内容
下载资源
问答
  • Cisco路由器配置DHCP

    2010-12-14 13:57:01
    某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。 在整个网络中有二个VLAN,为简...

     了解一些关于路由器配置DHCP的知识还是很重要的,这里主要分析了Cisco路由器配置DHCP的主要步骤和配置语句。某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。

    在整个网络中有二个VLAN,为简化描述,假设每个VLAN都采用24位网络地址,其中VLAN1的IP地址为192.168.1.254,VLAN2的IP地址为192.168.2.254。在Cisco设备上实现IOS DHCP Server功能以使各VLAN中的主机自动获得IP地址。

    路由器配置DHCP地址池、附加信息以及租约期限

    路由器配置DHCP服务器的数据库被组织成一个树形结构,树根是用于动态分配的所有网络段的地址池,树枝是子网地址池,树叶是手工绑定给节点的地址。具体操作步骤如下:首先登陆到Cisco 3640路由器上:

     

    1. ghq>enable  
    2. Password(输入路由器的特权口令)  
    3. ghq #config terminal (进入配置模式)  
    4. Enter configuration commands one per line.  End with CNTL/Z.  
    5. ghqconfig # ip dhcp pool global  
    6. ghq dhcp-config #network 192.168.0.0 255.255.0.0(动态分配的地址段)  
    7. ghqdhcp-config #domain-name ghq.com(为客户机配置域后缀)  
    8. ghqdhcp-config #dns-server 192.168.1.1(为客户机配置DNS服务器)  
    9. ghqdhcp-config #netbios-name-server 192.168.1.1(为客户机配置wins服务器)  
    10. ghqdhcp-config #netbios-node-type h-node(为客户机配置h节点模式)  
    11. ghqdhcp-config #lease 30 (地址租用期为30天)  
    12. ghqdhcp-config #ip dhcp pool vlan1   
    13. ghqdhcp-config #network 192.168.1.0 255.255.255.0   
    14. ghqdhcp-config#default-router 192.168.1.254   
    15. ghqdhcp-config #ip dhcp pool vlan2   
    16. ghqdhcp-config#network 192.168.2.0 255.255.255.0  
    17. ghqdhcp-config #default-router 192.168.2.254 
     

    设置不能用于动态分配的IP地址

    在整个网络中,有些IP地址需要静态的指定给一些特定的设备,例如路由器端口、wins服务器以及VLAN的地址等。显然,这些静态IP地址是不能用于动态分配的,这就需要将它们排除掉。其步骤如下:

     

    1. ghqconfig #ip dhcp excluded-address 192.168.1.1 192.168.1.5    
    2. ghqconfig # ip dhcp excluded-address 192.168.1.254  
    3. ghqconfig # ip dhcp excluded-address 192.168.2.254  

    转载于:https://blog.51cto.com/shenjianzhousx/455041

    展开全文
  • Cisco路由器上配置DHCP全程详解,使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。
  • CISCO路由器配置DHCP

    2007-12-19 21:13:33
    某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。 在整个网络中有二个VLAN,为简化描述,假设每...
    由于原文使用了某些禁止的语言,图片没能显示。不过我上传了原文附件,可下载阅读。
     
    某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。
      
      在整个网络中有二个VLAN,为简化描述,假设每个VLAN都采用24位网络地址,其中VLAN1的IP地址为192.168.1.254,VLAN2的IP地址为192.168.2.254。在Cisco设备上实现IOS DHCP Server功能以使各VLAN中的主机自动获得IP地址,如下图所示:

    转载于:https://blog.51cto.com/ttkx365/55884

    展开全文
  • 某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。在整个网络中有二个VLAN,为简化描述,假设每个...

    了解一些关于路由器配置DHCP的知识还是很重要的,这里主要分析了Cisco路由器配置DHCP的主要步骤和配置语句。某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。

    在整个网络中有二个VLAN,为简化描述,假设每个VLAN都采用24位网络地址,其中VLAN1的IP地址为192.168.1.254,VLAN2的IP地址为192.168.2.254。在Cisco设备上实现IOS DHCP Server功能以使各VLAN中的主机自动获得IP地址。

    路由器配置DHCP地址池、附加信息以及租约期限

    路由器配置DHCP服务器的数据库被组织成一个树形结构,树根是用于动态分配的所有网络段的地址池,树枝是子网地址池,树叶是手工绑定给节点的地址。具体操作步骤如下:首先登陆到Cisco 3640路由器上:

     

    1. ghq>enable  
    2. Password(输入路由器的特权口令)  
    3. ghq #config terminal (进入配置模式)  
    4. Enter configuration commands one per line.  End with CNTL/Z.  
    5. ghqconfig # ip dhcp pool global  
    6. ghq dhcp-config #network 192.168.0.0 255.255.0.0(动态分配的地址段)  
    7. ghqdhcp-config #domain-name ghq.com(为客户机配置域后缀)  
    8. ghqdhcp-config #dns-server 192.168.1.1(为客户机配置DNS服务器)  
    9. ghqdhcp-config #netbios-name-server 192.168.1.1(为客户机配置wins服务器)  
    10. ghqdhcp-config #netbios-node-type h-node(为客户机配置h节点模式)  
    11. ghqdhcp-config #lease 30 (地址租用期为30天)  
    12. ghqdhcp-config #ip dhcp pool vlan1   
    13. ghqdhcp-config #network 192.168.1.0 255.255.255.0   
    14. ghqdhcp-config#default-router 192.168.1.254   
    15. ghqdhcp-config #ip dhcp pool vlan2   
    16. ghqdhcp-config#network 192.168.2.0 255.255.255.0  
    17. ghqdhcp-config #default-router 192.168.2.254 

    设置不能用于动态分配的IP地址

    在整个网络中,有些IP地址需要静态的指定给一些特定的设备,例如路由器端口、wins服务器以及VLAN的地址等。显然,这些静态IP地址是不能用于动态分配的,这就需要将它们排除掉。其步骤如下:

     

    1. ghqconfig #ip dhcp excluded-address 192.168.1.1 192.168.1.5    
    2. ghqconfig # ip dhcp excluded-address 192.168.1.254  
    3. ghqconfig # ip dhcp excluded-address 192.168.2.254  
    展开全文
  • 【IT168 专稿】某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。 在整个网络中有二个VLAN,为...
    Cisco路由器上配置DHCP全程详解<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

    IT168 专稿】某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550

        在整个网络中有二个VLAN,为简化描述,假设每个VLAN都采用24位网络地址,其中VLAN1IP地址为192.168.1.254VLAN2IP地址为192.168.2.254。在Cisco设备上实现IOS DHCP Server功能以使各VLAN中的主机自动获得IP地址,如下图所示。

    <?xml:namespace prefix = v ns = "urn:schemas-microsoft-com:vml" />

    配置DHCP地址池、附加信息以及租约期限

    DHCP服务器的数据库被组织成一个树形结构,树根是用于动态分配的所有网络段的地址池,树枝是子网地址池,树叶是手工绑定给节点的地址。具体操作步骤如下:

        首先登陆到Cisco 3640路由器上:

        ghq>enable
        Password
      (输入路由器的特权口令)
        ghq #config terminal (
    进入配置模式
    )
        Enter configuration commands one per line.  End with CNTL/Z.
        ghq
    config # ip dhcp pool global(配置一个根地址池,global是地址池的名称,你可以采用有意义的字符串来表示)

        ghq dhcp-config #network 192.168.0.0 255.255.0.0(动态分配的地址段)
        ghq
    dhcp-config #domain-name ghq.com(为客户机配置域后缀)
        ghq
    dhcp-config #dns-server 192.168.1.1(为客户机配置DNS服务器

        ghqdhcp-config #netbios-name-server 192.168.1.1(为客户机配置wins服务器)
        ghq
    dhcp-config #netbios-node-type h-node(为客户机配置h节点模式)
        ghq
    dhcp-config #lease 30 (地址租用期为30天)
        ghq
    dhcp-config #ip dhcp pool vlan1 (为VLAN1配置地址池,本池是global池的子池,将从global继承域后缀、DNS服务器、wins服务器等参数)

        ghqdhcp-config #network 192.168.1.0 255.255.255.0 VLAN1动态分配192.168.1这个网段内可以被分配的地址,没有被排除的地址)
        ghq
    dhcp-config#default-router 192.168.1.254 (为客户机配置默认的网关,即VLAN1IP地址)

        ghqdhcp-config#ip dhcp pool vlan2 (为VLAN2配置地址池,本池是global池的子池,将从global继承域后缀、DNS服务器、wins服务器等可继承的参数)
        ghq
    dhcp-config#network 192.168.2.0 255.255.255.0
        ghq
    dhcp-config#default-router 192.168.2.254

    设置不能用于动态分配的IP地址

    在整个网络中,有些IP地址需要静态的指定给一些特定的设备,例如路由器的端口、DNS服务器wins服务器以及VLAN的地址等。显然,这些静态IP地址是不能用于动态分配的,这就需要将它们排除掉。其步骤如下:

        ghqconfig#ip dhcp excluded-address 192.168.1.1 192.168.1.5  IP地址       192.168.1.1192.168.1.5不能用于动态分配)

        ghqconfig# ip dhcp excluded-address 192.168.1.254
       
    IP地址192.168.1.254固定为VLAN1的地址,不能用于动态分配)

        ghqconfig# ip dhcp excluded-address 192.168.2.254
       
    IP地址192.168.2.254固定为VLAN2的地址,不能用于动态分配)

    设置DHCP数据库代理

    DHCP数据库代理是用于存储DHCP绑定信息的一台主机,它可以是FTPTFTP或者是RCP服务器。当然,如有必要,你可以配置多个DHCP数据库代理。同样,不配置DHCP数据库代理也是允许的,但这是以不能在DHCP数据库代理上存储地址冲突日志为代价的。如果我们不想配置数据库代理,只要取消掉地址冲突日志的记录功能即可,操作命令如下:

        ghqconfig# no ip dhcp conflict logging (取消地址冲突记录日志)

    配置路由器的静态路由表

    要使客户机能从用作DHCP Server的路由器中自动获得IP地址,首要条件就是各个VLAN中的客户机都能和路由器通信,因此首先就需要在路由器中设置一个路由以使路由器能和各个客户机通信。我们可以按如下设置:

        ghqconfig#ip route 192.168.1.0 255.255.255.0 FastEthernet0
    FastEthernet0为路由器和内网相连的以太网接口,该命令的作用是在以太网接口和VLAN1 192.168.1.254间建立一条静态路由。)

        ghqconfig#ip route 192.168.2.0 255.255.255.0 FastEthernet0
    (该命令在以太网接口和VLAN2 192.168.2.254间建立一条静态路由)

        设置好之后,在配置模式中键入EXIT命令回到特权模式下,Ping一下VLAN1VLAN2IP地址192.168.1.254192.168.2.254,如果能够Ping通则表明配置正确,可以直接进入下一步的保存过程。

    在交换机上为不同的VLAN指定DHCP服务器地址

    这一步骤只须在不同的VLAN中通过设置IP HELPER-ADDRESS即可搞定,指令如下:

        switch>enable  (进入交换机的特权模式)
        Password

        switch #config t
    (进入配置模式)

        Enter configuration commandsone per line.  End with CNTL/Z.
        switch
    config#interface vlan1 (配置VLAN1

        switch
    config-if#ip helper-address 192.168.1.4(指定DHCP服务器的地址,即路由器的地址)

        ghqconfig-if#interface vlan2 (配置VLAN2
        ghq
    config-if#ip helper-address 192.168.1.4

    对所有直接连到客户机的二层访问端口开启Portfast功能

    要使客户机正确获得IP地址,就需要将和客户机相连的交换机端口的Portfast功能打开(Cisco 2950)。这里需要特别注意的是,只能在连接一个单一客户机的二层端口上开启该功能,如果在一个连接到交换机或集线器的端口上开启该功就有可能引起广播风暴或“地址学习”问题。开启Portfast功能的步骤如下:

        switch #configure terminal
        switch
    config#interface interface-id
        switch
    config-if#spanning-tree portfast (开启portfast功能)

        switch
    config-if #end

        经过以上规划与设置操作后,在路由器和交换机上的设置全部完成,剩下的工作只要在客户机上打开“自动获得IP地址”功能即可(如图2所示)。对于Windows 2000/2003 Server系统,还需要将“DHCP CLIENT”服务启用(如下图3所示),否则在Windows 2000/2003 Server中将不能自动得到IP地址。

    1

    2

    至此,通过启用Cisco路由器的DHCP Server功能与客户端DHCP的配合使用,使局域网VLAN中的主机自动获得IP地址,真正实现了DHCP服务全部功能。相比在服务器上用windows/Linux 操作系统实现的DHCP服务器,从稳定性和功能上看,路由器实现的DHCP服务器要优越得多。

     

    转载于:https://blog.51cto.com/566577/182112

    展开全文
  • 某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。  在整个网络中有二个VLAN,为简化描述,...
  • 某单位使用 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层机采用两台 2950,三层机采用一台Cisco 3550。 在整个网络中有二个VLAN,为简化描述,假设每个VLAN都采用24位...
  • 【IT168 专稿】某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。 在整个网络中有二个VLAN,为...
  • 某单位使用 3640作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层机采用两台 2950,三层机采用一台Cisco 3550。  在整个网络中有二个VLAN,为简化描述,假设每个VLAN都采用24位...
  • cisco dhcp配置

    2010-05-26 14:59:03
    某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。  在整个网络中有二个VLAN,为简化描述,假设...
  • cisco dhcp 配置

    2009-03-05 15:20:07
    某单位使用Cisco 3620作为IOS DHCP Server,它和内网相连的fastethernet0端口的IP地址为192.168.1.4,二层交换机采用两台Cisco 2950,三层交换机采用一台Cisco 3550。 在整个网络中有二个VLAN,为简化描述,假设每...
  • "一、概述 1 、DHCP(Dynamic ... 2 、DHCP最常见的应用是,自动给终端设备分配IP地址,掩码,默认网关,但是DHCP也同样可以给终端设备自动配置其他options,比如DNS server, 域名(比如 cisco.com)...
  • cisco DHCP

    2017-09-19 20:41:22
    在一些路由器配置中,我们通常会遇到DHCP使用。那么今天我们就针对这方面的一些设置来进行一下讲解。下面我们就来看看在cisco dhcp client...Cisco IOS 12.0 T1以后可以配置DHCP relay,cisco DHCP Client,DHCP Ser

空空如也

空空如也

1 2 3 4
收藏数 70
精华内容 28
关键字:

ios配置dhcp使用cisco