精华内容
下载资源
问答
  • 获取本机所有IP地址:这些地址是包含所有网卡(虚拟网卡)的ipv4和ipv6地址。string name = Dns.GetHostName();IPAddress[] ipadrlist = Dns.GetHostAddresses(name);获取本机所有IPV4地址:string name = Dns.Get...

    获取本机所有IP地址:

    这些地址是包含所有网卡(虚拟网卡)的ipv4和ipv6地址。

    string name = Dns.GetHostName();

    IPAddress[] ipadrlist = Dns.GetHostAddresses(name);

    获取本机所有IPV4地址:

    string name = Dns.GetHostName();

    IPAddress[] ipadrlist = Dns.GetHostAddresses(name);

    foreach (IPAddress ipa in ipadrlist)

    {

    if (ipa.AddressFamily == AddressFamily.InterNetwork)

    Console.Writeline(ipa.ToString());

    }

    若要单单获取ipv4地址,可以用IPAdress.AddressFamily 属性判断:对于 IPv4,返回 InterNetwork;对于 IPv6,返回 InterNetworkV6。

    然而如果本机可能有多个ipv4的地址,那如何获取访问默认网关时使用的网卡IP呢。在CSDN论坛找到了大神的方法,用的是查询本机路由表。

    获取本机正在使用的ipv4地址(访问互联网的IP)

    可别小看,还是有很多需要考虑的:

    1.一个电脑有多个网卡,有线的、无线的、还有vmare虚拟的两个网卡。

    2.就算只有一个网卡,但是该网卡配置了N个IP地址.其中还包括ipv6地址。

    ///

    /// 获取当前使用的IP

    ///

    ///

    public static string GetLocalIP()

    {

    string result = RunApp("route", "print",true);

    Match m = Regex.Match(result, @"0.0.0.0\s+0.0.0.0\s+(\d+.\d+.\d+.\d+)\s+(\d+.\d+.\d+.\d+)");

    if (m.Success)

    {

    return m.Groups[2].Value;

    }

    else

    {

    try

    {

    System.Net.Sockets.TcpClient c = new System.Net.Sockets.TcpClient();

    c.Connect("www.baidu.com", 80);

    string ip = ((System.Net.IPEndPoint)c.Client.LocalEndPoint).Address.ToString();

    c.Close();

    return ip;

    }

    catch (Exception)

    {

    return null;

    }

    }

    }

    ///

    /// 获取本机主DNS

    ///

    ///

    public static string GetPrimaryDNS()

    {

    string result = RunApp("nslookup", "",true);

    Match m = Regex.Match(result, @"\d+\.\d+\.\d+\.\d+");

    if (m.Success)

    {

    return m.Value;

    }

    else

    {

    return null;

    }

    }

    ///

    /// 运行一个控制台程序并返回其输出参数。

    ///

    /// 程序名

    /// 输入参数

    ///

    public static string RunApp(string filename, string arguments,bool recordLog)

    {

    try

    {

    if (recordLog)

    {

    Trace.WriteLine(filename + " " + arguments);

    }

    Process proc = new Process();

    proc.StartInfo.FileName = filename;

    proc.StartInfo.CreateNoWindow = true;

    proc.StartInfo.Arguments = arguments;

    proc.StartInfo.RedirectStandardOutput = true;

    proc.StartInfo.UseShellExecute = false;

    proc.Start();

    using (System.IO.StreamReader sr = new System.IO.StreamReader(proc.StandardOutput.BaseStream, Encoding.Default))

    {

    //string txt = sr.ReadToEnd();

    //sr.Close();

    //if (recordLog)

    //{

    // Trace.WriteLine(txt);

    //}

    //if (!proc.HasExited)

    //{

    // proc.Kill();

    //}

    //上面标记的是原文,下面是我自己调试错误后自行修改的

    Thread.Sleep(100); //貌似调用系统的nslookup还未返回数据或者数据未编码完成,程序就已经跳过直接执行

    //txt = sr.ReadToEnd()了,导致返回的数据为空,故睡眠令硬件反应

    if (!proc.HasExited) //在无参数调用nslookup后,可以继续输入命令继续操作,如果进程未停止就直接执行

    { //txt = sr.ReadToEnd()程序就在等待输入,而且又无法输入,直接掐住无法继续运行

    proc.Kill();

    }

    string txt = sr.ReadToEnd();

    sr.Close();

    if (recordLog)

    Trace.WriteLine(txt);

    return txt;

    }

    }

    catch (Exception ex)

    {

    Trace.WriteLine(ex);

    return ex.Message;

    }

    }

    另有一种方法通过用ipconfig来获取:

    private void GetIP()

    {

    Process cmd = new Process();

    cmd.StartInfo.FileName = "ipconfig.exe";//设置程序名

    cmd.StartInfo.Arguments = "/all"; //参数

    //重定向标准输出

    cmd.StartInfo.RedirectStandardOutput = true;

    cmd.StartInfo.RedirectStandardInput = true;

    cmd.StartInfo.UseShellExecute = false;

    cmd.StartInfo.CreateNoWindow = true;//不显示窗口(控制台程序是黑屏)

    //cmd.StartInfo.WindowStyle = ProcessWindowStyle.Hidden;//暂时不明白什么意思

    /*

    收集一下 有备无患

    关于:ProcessWindowStyle.Hidden隐藏后如何再显示?

    hwndWin32Host = Win32Native.FindWindow(null, win32Exinfo.windowsName);

    Win32Native.ShowWindow(hwndWin32Host, 1); //先FindWindow找到窗口后再ShowWindow

    */

    cmd.Start();

    string info = cmd.StandardOutput.ReadToEnd();

    cmd.WaitForExit();

    cmd.Close();

    textBox1.AppendText(info);

    }

    以上就是本文的全部内容,希望本文的内容对大家的学习或者工作能带来一定的帮助,同时也希望多多支持脚本之家!

    展开全文
  • DNS 解析找到 IP地址 ping命令 :ping命令会回显出对方域名对应的IP,但只有一个,一般是非权威应答。 nslooup:会返回自己的服务器以及对方所有的服务器 dig +域名 :回显出域名对应的服务器 dig +trace +...

    DNS 解析找到 IP地址

    • ping命令 :ping命令会回显出对方域名对应的IP,但只有一个,一般是非权威应答。

    • nslooup:会返回自己的服务器以及对方所有的服务器

    • dig +域名 :回显出域名对应的服务器
      在这里插入图片描述

    • dig +trace +域名:显示解析过程(网络不好):
      在这里插入图片描述

    • dig @服务器IP +域名:指定服务器查找域名:
      在这里插入图片描述

    • 站长工具有很多功能
      https://tool.chinaz.com/

    CDN加速情况:
    CDN是内容分发网络,一种节点保存机制,可以在一个节点保存内容,使用户访问速度加快,但是有可能用户只能获得节点的IP而不是域名本身真正的IP。

    IP查询

    比如定位到百度服务器:
    在这里插入图片描述

    在这里插入图片描述

    展开全文
  • —— IN ) 类型(例如 A 表示 IP 地址,而 MX 则表示邮件服务器的地址) 而在 ANSWER SECTION 中,则是 DNS 服务的响应结果,上图中显示了总有 6 条 DNS 记录,并且在后面返回了其对应的 IP 地址。 而其中的 69 则...

    可能大家都知道或者被问过一个问题,那就是很经典的「从浏览器输入 URL 再到页面展示,都发生了什么」。这个问题虽然简单,但是真的能够从回答的各种细节上看出不同人之间的水平差距。

    这篇文章主要是聊一聊输入 URL 之后的第一步——域名解析

    域名就类似于 www.google.com,而通过 ping 命令,就可以查询到对应域名的 IP 地址了。

    那为什么又要有域名,又要有 IP 呢?

    域名、IP 共存

    首先还是解释一下,为什么会出现现在这种域名、IP 地址共存的情况。主要有两个点:

    1. 提升用户体验

    2. 提高运行效率

    分别解释一下,IP 地址长度为 32 位,平时用十进制来表示的话,就长这样——192.168.1.0 ,但是想象一下,如果我们要访问某个网站需要让我们输入这么一长串数字,体验肯定相当差,首先记忆这么长串数字对很多人来说就很痛苦,更何况我们常用的网站肯定不止一个。

    除此之外,如果你给其他人推广你的网站,你吧啦吧啦说了一大堆,然后来个「如果你感兴趣,请访问我们的网站 192.168.1.0」,然后就没有然后了。

    这也是为啥现在仍然在使用域名,方便人脑去记忆。

    那为啥还需要 IP 地址呢?因为 IPv4 中的 IP 地址只需要 4 个字节,而用字符串表示的域名最少也需要几十个字节,长的甚至达到几百字节,而这会大大的增加底层路由器的负担。

    这也是为啥 IP 地址仍然在被使用。人来使用域名,而路由器层则使用 IP 地址,就跟我们书写的是我们能认识的字符,而最终计算机认识的是一堆二进制一样。

    DNS 解析

    知道了这个背景之后,我们就可以来看看「域名」是如果变成「IP 地址」的。

    首先我们知道,会往 DNS 服务器发送请求,那问题就来了,浏览器怎么知道 DNS 服务器的地址是啥?

    答案是提前配置好的。当然这不是唯一的方式,DNS 也有可能通过 DHCP(Dynamic Host Configuration Protocol) 动态分配的。

    例如,MacOS 中的 DNS 配置就长下面这样。

    当然,你也可以通过命令行来查看、修改,地址在 /etc/resolv.conf

    有了 DNS 服务器,那么你可能会觉得,接下来的事情就很简单了:

    我给你传个域名,你返给我对应的 IP 地址即可。那问题来了,现在互联网中有数万台的 DNS 服务器,我怎么知道数据在哪台服务器上?难道要一台一台的遍历请求这数万台服务器吗?

    我相信你肯定没有感知到在浏览器中输入域名到页面展示会花费那么久,这也说明肯定不是一台一台服务器进行遍历的。

    域名的组成

    要了解 DNS 是如何对其进行优化的,我们需要先知道域名的组成部分。看到这,很可能你会这么想:

    啥组成?不就是一堆字符串吗?

    实际上,域名是有由不同的组成的,每个 .  隔开的部分就是一个

    这里举个例子,假设我们分析的域名为 www.google.com ,从我们平时写快递的收货地址的惯性思维来看,这个域的各个部分大小可能是这样的:

    www > google > com

    但是实际上并不是这样,而是:

    . > com > google > www

    你甚至发现,最大的还是个 . 。其实完整的域名应该是 www.google.com.. 代表根域,因为根域对于所有的域名来说,意义都一样,所以平时我们都把最后的点给省略了。

    每个域都有自己的专属名词:

    . > com > google > www

    根域 | 一级级域|二级域名|(子域名)|主机名

    当然,我们知道还可以针对二级域名再划分子域名,类似于 mail.google.com

    所以看到这,你应该能够理解域名是由层次的这个概念了,我再举个比较的通俗的例子。

    com 公司的 google 部门的 www。https://mail.google.com/mail/u/0/#inbox

    DNS 的分层

    了解完域名的分层之后,DNS 是如何优化域名解析的问题就迎刃而解了,那就是——分层。

    DNS 服务器会将域名的数据分布式的存储在各个 DNS 服务器上,但是同一个域的数据,会存储在同一台 DNS 服务器上,同一台 DNS 服务器可以存储多个域的数据。

    这么说可能会有些抽象,一图胜千言,其实就是这样:

    有了对数据的分层,那么查询数据就会很有节奏感

    查询域名数据

    一图胜千言,有了分层的机制,整个的查询过程就会长这样:

    首先会去配置的 DNS 服务器中查询,这个其实一般都是本地或者内网中的 DNS 服务器。如果没有找到,就会去问根域要,说哥们,我这里需要 www.google.com 的 IP 地址。

    根域一看,我这里没有啊,但是我知道 com 域的 DNS 服务器地址,他可能知道。

    然后 com 域的 DNS 服务器一看,www.google.com 的 IP 地址我也不知道,但是我知道 google.com  域的 DNS  服务器的地址,他可能知道,你再去问问他。

    就这样一路问下去,最终就能够找到 www.google.com 所对应的 IP 地址了。

    根域名服务器

    看了上面的流程,可能你还是会有点疑问。因为去找 DNS 服务器查询 IP 地址时,初始的 DNS 的服务器的 IP 地址是走的本地计算机的配置的。那在分层查询时,我怎么知道有哪些根服务器?以及我怎么知道这些根服务器的 IP 地址是啥?

    答案是内置

    我们的设备,或者说所有能上网的设备都会内置根服务器的列表。总共有 13 台根 DNS 服务器,分别是[a-m].root-servers.net ,这些根服务器的地址根本不需要查询就能直接获取。

    当然,稍微想想也知道,13 台服务器是很难扛住全球互联网用户的请求的,实际上对于这 13 台服务器有很多的镜像服务器

    眼见为实

    说了这么多虚的概念,接下来我们通过 dig 命令来实际操作一下。

    可以看到,在 QUESTION SECTION 下的完整域名是 www.google.com. 是带了根域的,那后面的这个 INA 又是啥意思呢?

    这是因为,在向 DNS 服务器查询请求的时候,需要三个参数,分别是:

    1. 域名(例如 www.google.com)

    2. 网络类型(Class 设计之初,考虑到了多种网络并存的场景,但是目前实际上只有一种网络——互联网,所以该参数的值一直都会为 —— IN

    3. 类型(例如 A 表示 IP 地址,而 MX 则表示邮件服务器的地址)

    而在 ANSWER SECTION 中,则是 DNS 服务的响应结果,上图中显示了总有 6 条 DNS 记录,并且在后面返回了其对应的 IP 地址。

    而其中的 69 则是 TTL,单位是秒,代表了在 69 之内都不用再次发送请求了。

    最下面则是统计的信息,本次 DNS 查询所话费的时间,以及请求的 DNS 服务器的地址和端口。这个服务器地址是我们本机配置的 DNS 服务器的地址。

    眼尖的可能发现了,上图中根本没有设计到对根服务器的请求。这是因为这个命令把这部分给省略掉了,我们可能通过加上 +trace 命令行参数来查看详细的分级查询过程

    这次我们以 www.36kr.com 来作为例子。

    可以看到,上图中列出了所有的根域名服务器,然后去找 com 域要,然后再找 36kr.com 域去要,最终是拿到了 www.36kr.com 的 IP 地址。

    缓存机制

    当然,如果每次都从根服务器开始往下找,明显是不合理的,因为域名和 IP 地址的对应关系本来变动的就不频繁,所以 DNS 服务器是都会将结果缓存的。

    并且,在下图中:

    我只写了一个 DNS 服务器中有同级别的域信息,但是实际上不同层级的域信息可能存在于同一个 DNS 服务器,举个例子,com 域和 google.com 域可能在同一台机器上。

    但是,这个缓存是有有效期的。如果在这个有效期内 DNS 数据发生了变化,那么缓存中的数据就会不正确,此时需要手动的将 DNS 删除。

    有道无术,术可成;有术无道,止于术

    欢迎大家关注Java之道公众号

    好文章,我在看❤️

    展开全文
  • IP地址 HCIA

    2021-03-16 22:15:01
    TCP/IP模型 四层模型 五层模型 ISO—国际标准化组织 OSI七层参考模型 开放式系统互联模型 应用层:应用程序 APP:通过人机交互提供(实现)各种各样的服务 表示层:编码 解码 加密 解密 会话层:发现 建立 维持 终止...

    计算机 软件 硬件
    二进制
    网络—数据通信
    什么是计算机?
    什么是二进制?
    什么是网络?
    作用—传递信息—拿线—无线—
    网络连接设备通过传输介质将网络终端设备连接起来,传递信息—资源共享的平台
    RAM—随机
    ROM—只读
    OSI七层参考模型—标准
    TCP/IP模型 四层模型 五层模型
    ISO—国际标准化组织
    OSI七层参考模型 开放式系统互联模型
    应用层:应用程序 APP:通过人机交互提供(实现)各种各样的服务
    表示层:编码 解码 加密 解密
    会话层:发现 建立 维持 终止会话
    上三层—产生数据的地方
    下四层—搬运数据—运输—传递数据
    传输层:1.根据端口号来区分不同的服务
    0-65535
    静态端口号(著名端口号)
    1-1023
    动态端口号
    1024-65535
    2.提供可靠的传输 确认 重传 排序 流控
    3.数据分段
    MSS 最大段长度 1480B
    MTU 最大传输单元 1500B
    TCP 传输控制协议
    面向连接的可靠传输协议
    三次握手 四次断开
    UDP 用户数据报文协议
    非面向连接的不可靠传输协议
    数据的封装和解封装
    网络层:通过IP地址来进行寻址
    数据链路层:1.MAC 媒介访问控制子层—通过物理地址(MAC地址)来进行物理寻址
    2.LLC 逻辑链路控制子层—为上层服务提供FCS校验
    物理层:定义电气电压,光学特性 接口规范
    物数网传会表应
    数据的封装与解封装
    PDU 协议数据单元
    机房—插板
    数据报文
    四层 数据段
    三层 数据包
    二层 数据帧
    一层 比特流

    TCP 传输控制协议
    面向连接的可靠传输协议
    UDP 用户数据报文协议
    非面向连接的不可靠传输协议
    面向连接:三次握手 四次断开
    在这里插入图片描述
    SYN 同步序列号请求
    Ctl标志位
    序列号—记录发送的次数—不同的厂商序列号不一样
    Ack 确认
    Ack=seq+1
    握手为什么需要三次
    为什么要进行三次握手
    为什么断开需要四次,三次不行吗?
    四次断开
    在这里插入图片描述
    可靠:确认 重传 排序 流控
    tcp报头 bit byte

    在这里插入图片描述

    紧急指针

    FTP:文件传输协议
    数据端口(数据传送端口)TCP 20
    控制端口(传送控制信号)一般为TCP 21
    telnet TCP 23 明文
    SSH(安全外壳) TCP 22 密文
    http TCP 80 8080
    https TCP 443
    SMTP(发邮件) TCP 25
    POP3(收邮件) TCP 110

    tftp UDP 69
    DNS TCP/UDP 53
    VNC TCP 5900

    114.114.114.114
    8.8.8.8
    Ping 测试连通性指令
    14.215.177.39
    www.baidu.com–便于记忆、
    UDP的报头

    在这里插入图片描述
    IP的
    在这里插入图片描述
    跨层封装
    TTL生存时间 0-255 默认每经过一台路由器减一 防止环路
    协议号 标识上层协议
    TCP 6
    UDP 17
    OSPF 89
    在这里插入图片描述
    TCP/IP协议栈
    在这里插入图片描述
    相同点: 2者都是模型化层次化
    下层对上层提供服务支持
    每层协议彼此相互独立

    不同点:OSI先有模型才有协议 TCP/IP先有协议才有模型
    TCP/IP协议栈只适用于TCP/IP网络
    层数量不同

    信号衰减—物理加压—中继器—信号失真
    ----交换机—广播风暴—
    路由器—划分广播域—用于连接不同的网络
    交换机作用:
    1.无限延长传输距离
    2.解决冲突域
    3.实现单播
    CSMA/CD 带冲突检测的载波多路访问技术
    FIFO 先进先出
    冲突域:可能产生冲突的地方
    广播域:洪泛的范围
    ARP—地址解析协议 通过对方的某个地址来获取对方的另一个地址
    AARP–正向ARP—通过对端的IP地址获取对端的MAC地址
    RARP–反向ARP—通过对端的MAC地址获取对端的IP地址
    无故(免费)ARP----检测地址冲突
    代理ARP—ARP欺骗
    ip地址 IPv4 IPv6
    192.168.1.105点分十进制
    ipv4地址:32位的二进制数
    00000000.00000000.00000000.00000000
    27……20.27……20

    128 64 32 16 8 4 2 1
    11000000.10101000.00000001.01101001
    完整的IP地址需要掩码
    192.168.0.0/24
    255.255.255.0
    子网掩码区分网络位和主机位
    网络位的作用:标记此IP地址处于哪个广播域内
    主机位:可以给主机(网络终端设备)分配的地址
    172.16.1.1
    10101100.00010000.00000001.00000001
    192.168.1.1/24
    分为ABCDE 五类
    在默认情况下通过第一个8位就可以辨别类别;
    A 0 0000000—0 1111111 0-126(127)
    B 10 000000—10 111111 128-191
    C 110 00000—110 11111 192-223
    D 1110 0000—1110 1111 224-239
    E 1111 0000----1111 1110 240-254
    单播地址:ABC 既可以作为源也可以作为目标的地址
    组播地址:D 只可以作为目标
    科研使用:E

    主类网:A 255.0.0.0 /8 B:255.255.0.0 /16 C:255.255.255.0 /24
    A 前8位为网络位后24位为主机位 2^24-2 可用主机
    B 16 16 2^16-2
    C 24 8 2^8-2

    在单播地址中还存在私有地址和公有地址分类:
    公有地址:全球唯一性需要付费使用
    私有地址:本地唯一性无需付费

    A:10.0.0.0/8 255.0.0.0
    B:172.16.0.0/16-172.31.0.0/16 255.255.0.0
    C:192.168.0.0/24-192.168.255.0/24 255.255.255.0

    32位 2^32个 有限的地址

    特殊ip地址:
    0.0.0.0/0 无效地址/缺省地址
    255.255.255.255 受限广播地址
    127.0.0.1/8 本地环回地址
    192.168.1.00000000/24 代表本网段内所有主机 192.168.1.0/24
    一个网段,一段网络—IP地址
    192.168.1.11111111/24 代表本网段内的广播地址
    169.254.x.x/16 本地私有地址
    一个网段是一个广播域
    一个广播域不一定是一个网段
    网络位的作用:标记IP地址处于哪个广播域

    子网划分将一个大网络划分为一些小网络
    VLSM 可变长子网掩码
    子网
    借用主机位来充当网络位
    192.168.1.0/24+1=25 借一位主机位
    192.168.1.00000000-01111111=127
    192.168.1.0/25和192.168.1.127/25
    192.168.1.1/25-192.168.1.126/25
    192.168.1.10000000
    既可以是0 也可以是1
    192.168.1.0/25 可用主机数量 2^7-2 =126
    可用地址范围:192.168.1.1/25-192.168.1.126/25
    192.168.1.128/25
    可用地址范围:192.168.1.129/25-192.168.1.254/25
    划分出最多的网段
    192.168.1.01000000/24+2=26
    00 01 10 11
    192.168.1.0/26 1.1-1.62
    192.168.1.64/26 1.65-1.126
    192.168.1.128/26 1.129-1.190
    192.168.1.192/26 1.193-1.254

    192.168.1.00000000/24+3=27
    000 001 010 011 100 101 110 111
    192.168.1.0/27
    192.168.1.32/27
    192.168.1.64/27
    192.168.1.96/27
    192.168.1.128/27
    192.168.1.160/27
    192.168.1.192/27
    192.168.1.224/27
    172.16.1.0/22 划分5个网段
    1 2 3
    借3位
    172.16.00000001.00000000/22+3=25
    00.0
    00.1
    01. 0
    172.16.0.0/25
    172.16.0.128/25
    汇总将一些小网络汇聚成一个大网络
    CIDR 无类域间路由
    超网
    母网号一致,取相同位,去除不同位
    192.168.1.0/24 01
    192.168.2.0/24 10
    192.168.3.0/24 11
    192.168.0.0/22<24—超网
    C 主类网掩码–24
    超网的概念:
    汇总后的子网掩码长度小于主类网子网掩码的长度,超网

    一、192.168.1.0/24 进行子网划分
    要求:每个子网至少可以容纳5台主机,划分出最多的子网

    二、172.16.1.0/22 划分5个子网

    VRP(versatile routing platform通用路由平台)基础及操作

    图形界面化
    CLI-命令行
    设备的登录方式:
    1.console口登录
    2.远程登录:telnet SSH TCP 23 22
    华为路由器的接口默认都是开启的
    思科路由器的接口默认都是关闭的

    在交换机模拟器及真机上,每次修改配置文件都会有相应配置改变提示,影响配置阅读:
    undo terminal trapping 关闭日志同步

    undo terminal monitor //会把所有信息都会关闭(包括接口的up/down消息)
    [R1]undo info-center enable //会把所有告警信息全部关掉(包括接口的up/down消息)。会不记录日志,慎用
    帮助系统:
    TAB—自动补全
    ?—询问
    NTP
    基础命令
    在这里插入图片描述
    在这里插入图片描述
    1.用户视图
    system-view

    2.系统视图

    3.子视图模式
    在这里插入图片描述
    注:
    真机AR2220不支持修改语言模式
    模拟器上所有的路由器上不支持
    模拟器上所有的交换机都支持(要使用默认的putty,CRT显示为乱码)

    修改设备主机名:
    sysname R1
    display—查看指令
    dis this //查看当前视图下的配置
    dis current-configuration //查看当前配置
    dis history-command //查看最近的10条历史命令
    dis logbuffer //查看系统日志
    在这里插入图片描述
    dis clock //查看当前的系统时间

    修改系统时间:
    clock datetime 8:00:00 2014-01-16
    clock timezone HK add 8:00:00
    在这里插入图片描述
    最后一条命令为巡检时使用
    在这里插入图片描述
    删除文件时不能自定义本地路径:
    在这里插入图片描述
    在这里插入图片描述
    cd … //返回上一级目录

    配置文件管理
    在这里插入图片描述
    当前配置保存在RAM中,启动配置保存在flash中
    作业1:华为路由器以及交换机的启动过程
    重启:reboot

    保存现有配置:
    在这里插入图片描述
    清除启动配置:
    在这里插入图片描述
    重启:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    真机上的VRP软件名:

    AR2200的VRP软件名为:sd1:/ar2220-v200r001c01spc500.cc

    模拟器上的启动配置文件名:
    在这里插入图片描述
    console口密码设置
    某些设备默认为none,某些设备默认为password,可以查看dis cu确定

    不需要密码直接登陆
    user-interface con 0
    authentication-mode none //如果为默认配置,可能并不显示在当前配置文件中

    使用密码登陆
    user-interface con 0
    authentication-mode password //使用密码登陆
    set authentication password simple/cipher huawei //在当前配置文件中存储的明文/密文密码

    模拟器上console口下的用户权限默认为15

    使用用户名和密码登陆
    user-interface con 0
    authentication-mode aaa

    aaa
    local-user huawei password cipher huawei
    local-user huawei service-type terminal //用于console口
    local-user huawei privilege level 15 //模拟器上权限默认为15,权限较低则无法进入系统试图,但可使用super命令进入

    super password level 3 cipher 123456 //模拟器上level显示为1-15,但最高只能输入为3(只支持0到3共4个级别),其他权限级别拒绝输入,或输入了反而无法进入
    在这里插入图片描述
    权限级别:
    0、1:只能进入用户试图,没有进入系统试图的权限,需要用super进入
    2:可以进入系统试图,但不能执行dis cu或aaa命令
    》3:可以进入系统试图,可以执行dis cu或aaa命令

    接口类型
    Ethernet 10m. 带宽/
    Fastethernet 100m
    GigabitEthernet 1000m
    0/0/0
    100M网—理论下载速度有多快=100M/8*80%

    display interface brief
    查看接口摘要信息
    PHY—表示接口是否可以正确识别电信号
    状态
    Up—表示可以正确识别电信号
    Down—表示设备无法正确识别电信号
    *down—可以正确识别电信号,但是人为关闭接口
    Protocol—表示接口是否可以正确识别数据
    Up—表示接口可以正确识别数据
    Down—表示接口无法正确识别数据

    Ping 测试连通性指令—基于ICMP协议(跨层封装协议)
    开启telnet功能 远程登录
    telnet server enable //telnet服务器端开启telnet服务,看设备型号,不一定默认开启(模拟器上默认开启)

    使用密码登陆
    VTY:(Virtual Teletype Terminal)虚拟终端

    模拟器上:
    user-interface vty 0 4 //vty为虚拟终端信道
    authentication-mode password //设置认证模式,要使用密码进行登录验证(默认模式——默认配置在配置文件中不显示出来),或改为none:登录时不进行认证(模拟器上不支持)
    set authentication password simple/cipher huawei //设置配置文件中存储的明文/密文密码

    对于telnet用户一般要提供两层密码保护,否则默认客户是有权限限制的:
    super password level 3 cipher 123456 //超级密码,一般用于二次telnet用户(使用super密码提供二次验证更加安全,比方法二更好),此密码至少为6位

    telnet 127.0.0.1 //telnet命令只能在用户视图下使用
    super //登陆上去后输入super password口令

    方法二:
    模拟器上:
    user-interface vty 0 4
    user privilege level 3 //设置VTY用户权限,默认为1,undo user privilege level //恢复用户权限为1

    使用用户名和密码登陆
    user-interface vty 0 4
    authentication-mode aaa

    aaa
    local-user huawei password cipher huawei
    local-user huawei service-type telnet //必须指定用户的服务类型,否则用户无效
    local-user huawei privilege level 15 //默认权限为1,如未设置权限则可使用super的权限登陆

    路由协议基础
    路由协议的优先级
    在这里插入图片描述
    思科和华为AD值的区别:
    在这里插入图片描述
    浮动静态路由的查看
    在这里插入图片描述
    ping后面的参数设置 测试连通性指令
    ping –a 1.1.1.1 2.2.2.2 //带源1.1.1.1 ping目的2.2.2.2
    tracert -a 1.1.1.1 2.2.2.2 //带源1.1.1.1 trace目的2.2.2.2
    ping -t 192.168.1.1 //长ping
    ping –c 1000 2.2.2.2 //发包数量,默认为5个
    ping –s 9600 2.2.2.2 //发包字节数,模拟器上默认为56字节,最大可设置为9600字节

    ping -c 1000 -a 1.1.1.1 3.3.3.3

    华为设备的debug功能
    terminal debugging //必须把debug信息显示在控制台才可以看到debug信息
    debugging arp packet

    undo debugging all
    华为基础指令
    Undo terminal trapping -关闭日志
    System-view 从用户视图进入到系统视图
    Sysname xx 修改设备名称
    退出指令
    quit 一层一层的退
    return 从其他视图直接退出到用户视图
    查看指令:
    Display
    查看时间-display clock
    修改时间-clock datetime 正确的时间
    帮助系统 TAB ?
    查看当前视图下的配置 display this
    查看运行配置文档—display current-configuration
    查看最近的十条指令—display history-commad
    保存指令 save
    擦除指令 reset saved-configuration
    重启指令 reboot
    设置密码登录
    user-interface con 0
    authentication-mode password //使用密码登陆
    set authentication password simple/cipher huawei //在当前配置文件中存储的明文/密文密码
    模拟器上console口下的用户权限默认为15
    设置用户名+密码登录
    user-interface con 0
    authentication-mode aaa
    aaa
    local-user huawei password cipher huawei
    local-user huawei service-type terminal //用于console口
    local-user huawei privilege level 15 //模拟器上权限默认为15,权限较低则无法进入系统试图,但可使用super命令进入
    查看接口信息
    display interface brief
    display ip interface brief

    配置IP地址
    Interface g0/0/0
    Ip address 192.168.1.1 24

    测试连通性指令
    Ping
    设置远程登录
    user-interface vty 0 4
    authentication-mode aaa
    aaa
    local-user huawei password cipher huawei
    local-user huawei service-type telnet //用于远程登录
    local-user huawei privilege level 15 //模拟器上权限默认为15,权限较低则无法进入系统

    静态路由
    路由—VRP
    交换机的作用
    1.无限延长传输距离
    2.解决冲突域
    3.实现单播
    路由器的作用
    1.划分广播域
    2.实现不同网络间的互联 不同广播域
    私网—公网
    3.路由功能—选路
    127.0.0.1 本地环回地址—检测网卡的好坏
    检测TCP/IP协议栈道是否能够正常的封装和解封装数据
    PC中,在系统安装完成之后默认存在
    当数据包进入路由器后,路由器会基于数据包中的目标IP地址,查询本地的路由表,
    Dis ip routing-table
    如果存在记录,则无条件转发,如果不存在,则直接丢弃。
    路由表内仅存在直连的路由条目,且以一个网段的形式存在
    非直连的路由条目—未知网段
    获取未知网段的方法-
    静态路由—管理员手工配置
    动态路由—各台路由器之间运行了一定的算法之后,相互学习沟通产生路由条目
    出接口:流量从本地发出的接口 一般不用
    点到点网络当中使用(串行网络)
    [wangcai]ip route-static 192.168.2.0 24 g0/0/0+下一跳
    前缀 未知网段 出接口
    下一跳写法
    [wangcai]ip route-static 192.168.2.0 24 192.168.1.1
    前缀。 未知网段。 下一跳
    Nexthop:流量从本地发出后,下一个入接口的IP地址
    点到点1对1
    点到多点
    MA网络
    出接口+下一跳写法—指定路径
    网关:网络关卡—三层设备与二层设备直接相连的物理接口IP地址。
    在这里插入图片描述
    优先级(管理距离–AD):衡量路由协议的好坏
    值越小(优先级值越小)表示协议越好,表示优先使用协议,取值范围0-255
    当为255时,就算是有可达路径,也不采用
    Cost 值(度量值)metric值:衡量路径的优劣
    只在动态路由协议中使用,值越小表示路径越优

    路由表加表规则:
    当学习到多条路由条目后,路由器会优先比较优先级,优先级值小的优先加表,如果优先级相同,则比较COST值,cost值小的优先加表,如果COST值相同,则同时加表—负载均衡

    负载均衡—到达一个目标地址时,如果拥有多条开销相似的路径时,路由器会将流量拆分同时传输
    浮动静态路由
    通过修改默认的优先级,来完成路径备份的效果。
    [R1]ip route-static 192.168.2.0 24 192.168.1.2 preference 80
    静态路由的扩展配置:
    1.环回接口
    本地环回地址-127.0.0.1
    检测网卡的好坏
    检测TCP/IP协议栈道是否能够正常的封装和解封装数据,PC中在系统安装完成之后默认存在-127.0.0.1,设备中默认不存在
    需要手工创建
    华为设备中存在—127.0.0.1
    模拟PC
    2.手工汇总
    当到达多个目标地址时,如果在本地拥有相同的下一跳, 且可以进行汇总运算,那么只需要编辑一条到达目标的汇总路由条目即可。

    汇总前
    ip route-static 192.168.1.0 255.255.255.0 12.1.1.2
    ip route-static 192.168.2.0 255.255.255.0 12.1.1.2
    ip route-static 192.168.3.0 255.255.255.0 12.1.1.2
    汇总后
    ip route-static 192.168.0.0 255.255.252.0 12.1.1.2
    3.路由黑洞
    汇总后,如果出现了网络中实际不存在的地址,则有可能导致流量有去无回的现象—路由黑洞
    4.缺省路由:
    缺省地址:0.0.0.0/0
    一条不限定目标的路由,在路由表中以*表识,查表时在查完所有的静态、动态路由条目后,若依然没有可达路径,则使用该条目。
    [R3]ip route-static 0.0.0.0 0 23.1.1.2
    环路!!!
    5.空接口防环路由
    当黑洞和缺省相遇时,必然产生环路
    在黑洞路由器上编辑一条到达目标的汇总路由条目。
    路由表的查表规则—递归查找、最长匹配
    D 172.16.2.0/24 lo 0
    D 172.16.3.0/24 lo 0
    S 172.16.0.0/22 null 0
    [R2]ip route-static 192.168.0.0 22 NULL 0

    1.创建vlan
    vlan ID
    vlan batch 2 to 5
    vlan batch 2 3 4 5
    2.将接口划入vlan
    1)进入接口 interface e0/0/1
    2)更改接口类型 port link-type access
    3)划入vlan。 port default vlan 2
    TRUNK
    1)进入接口 interface e0/0/1
    2)更改接口类型 port link-type trunk
    3)允许通过的vlan port trunk allow-pass vlan all
    查看vlan
    display vlan
    单臂路由
    interface g0/0/0.1 //创建虚拟子接口
    dot1q termination vid 2 //封装给vlan
    ip address 192.168.1.1 24 //配置IP(网关)
    arp broadcast enable //开启arp广播

    DHCP 动态主机配置协议
    统一分发 管理IP地址—统一下放IP地址—自动获取IP地址
    基于C/S模型
    DHCP sever
    DHCP client
    成为DHCP server的条件
    1.必须拥有合法IP地址
    2.必须已经连接到所要下放广播域

    dhcp discover 发现包
    dhcp offer 提供包
    dhcp request 请求包
    dhcp ack 确认包
    DHCP配置
    [Huawei]dhcp enable //启用dhcp服务
    [Huawei]ip pool xixi //创建名为xixi的地址池
    Info: It’s successful to create an IP address pool.
    [Huawei-ip-pool-xixi]network 192.168.1.0 mask 24 下放地址
    [Huawei-ip-pool-xixi]gateway-list 192.168.1.1 网管地址
    [Huawei-ip-pool-xixi]dns-list 8.8.8.8 dhs服务器地址
    [Huawei]interface g0/0/0.1
    [Huawei-GigabitEthernet0/0/0.1]dhcp select global 使能

    ACL的配置
    定义基本acl
    [Huawei]acl 2000 进入基本acl
    [Huawei-acl-basic-2000]rule deny source ? 定义规则
    IP_ADDR<X.X.X.X> Address of source
    any Any source
    基本ACL在使用时应尽量靠近目标
    定义高级acl
    [Huawei]acl 3000
    [Huawei-acl-adv-3000]rule deny tcp source 12.1.1.1 0 destination 23.1.1.3 0 dest
    ination-port eq ?
    <0-65535> Port number
    高级acl在使用时应靠近源,但是不能在源上,因为路由器不能限制自身产生的流量。
    将acl掉用于接口上
    [Huawei]interface g0/0/0
    [Huawei-GigabitEthernet0/0/0]traffic-filter outbound 2000
    NAT配置
    NAPT
    [wangcai]nat address-group 1 100.1.1.3 100.1.1.10 //定义地址池
    [wangcai]acl 2000
    [wangcai-acl-basic-2000]rule permit source any 使用acl抓取内网流量
    [wangcai]interface g0/0/2
    [wangcai-GigabitEthernet0/0/2]nat outbound 2000 address-group 1 no-pat 进行NAT转换
    Easy-ip
    acl 2000
    rule permit source 12.1.1.0 0.0.255

    int s2/0/1
    nat outbound 2000

    静态nat (一对一NAT)(端口映射)
    内网边界路由器

    接口下的配置:
    int s2/0/0 //外口
    nat static global 23.1.1.10 inside 12.1.1.1 //不能和外口地址冲突
    外网设备操作外网地址,实际访问内网

    展开全文
  • trace命令和tracert命令的用途 matlab中的trace 怎么用的?trace命令和tracert命令的用途 matlab中的trace 怎么用的?相关问题:匿名网友:tracert /?Usage: tracert [-d] [-h maximum_hops] [-j host-list] [-w time...
  • strace和ltrace的区别: (1) strace —— Trace system calls and signals (跟踪一个进程的系统调用或信号产生的情况) (2) ltrace —— A library call tracer (跟踪进程调用库函数的情况) PS: n strace最初是...
  • 1、背景在项目中随着项目的业务越来越复杂,...traceId也是属于追溯当前链路操作日志的一种有效手段.当有效的日志信息不是很明显,我们需要追溯本次操作整个链路的关键信息时,由于日志的散乱,可能在此事上面耗费较...
  • 之前在公司用过,网段不一样,打算设置一下IP地址,结果点“本地连接“属性,怎么也无法打开,去”控制面板“里居然找不到”网络连接“,一时踌躇满志。突然灵光一现,可以在MS-DOS下使用命令设置IP,在网上搜索...
  • 通过SQLNET.ora文件限制Ip地址访问tcp.validnode_checking=yestcp.invited_nodes=(ip1,ip2......)tcp.excluded_nodes=(ip1,ip2......)在未设置这些参数前,测试数据库可以正常访问:D:\>tnsping eygleTNS Ping ...
  • 今天小编给大家分享一下RAC怎么增加管理IP地址、名称、端口等信息。希望对大家有帮助。在生产实践中,往往需要一个集群的维护IP,这个IP同样需要高可用,如果不与原先公网在一个网段,可以采用今天我们测试的方法为...
  • oracle怎么捕获用户登录信息,如SID,IP地址等 标签:declare trigger loop exce 语句 logo obj users ror 本条技术文章来源于互联网,如果无意侵犯您的权益请点击此处反馈版权投诉 本文系统来源:...
  • dig命令后+trace的含义

    千次阅读 2021-03-20 21:50:01
    dig @ip 域名 类型 +trace 工作过程 以 dig pbc.gov.cn +trace 为例。 用户看到的结果 wireshark抓包看到的结果(只显示了查询部分,响应就是查询目的对源地址的响应) 步骤 源 目的 查询 1 本机 @...
  • 语 法:traceroute[-dFlnrvx][-f][-g...][-i][-m][-p][-s][-t][-w][主机名称或IP地址][数据包大小]补充说明:traceroute指令让你追踪网络数据包的路由途径,预设数据包大小是40Bytes,用户可另行设置。参 数:-d ...
  • MySQL 5.6.3提供了对SQL语句的跟踪功能,通过trace文件可以进一步了解优化器是如何选择某个执行计划的,和Oracle的10053事件类似。使用时需要先打开设置,然后执行一次SQL,最后查看INFORMATION_SCHEMA.OPTIMIZER_...
  • win7命令行设置IP地址

    2021-09-18 14:30:52
    开始--cmd 设置ipv4地址值:(dhcp) ...--static 后面依次为 IP地址、子网掩码、默认网关 netsh interface ip set address "无线网络连接" static 192.198.0.2 255.255.255.0 192.198.0.1 netsh ? 用法: nets
  • 为了改善普通访客与网站服务器之间的连接状况,我们需要测试...besttrace是国内专业的IP地址库提供商IPIP.net提供的一款路由跟踪工具。使用方法如下://下载 besttrace Linux 版本wget https://cdn.ipip.net/17mon...
  • Oracle限制IP登录

    2021-05-02 05:18:12
    限制登录Oracle的IP地址有两种方法一、编辑$ORACLE_HOME/network/admin/sqlnet.ora,增加tcp.validnode_checking = yes#tcp.invi限制登录Oracle的IP地址有两种方法一、编辑$ORACLE_HOME/network/admin/sqlnet.ora,...
  • 11 Log and Trace 11.1 What is Log and Trace 日志和跟踪是自适应平台体系结构中的一个功能集群。 作为一个功能集群,日志和跟踪向应用程序提供了一个C++ API,支持不同级别的状态消息和不同目的地的日志记录。...
  • 在上文ELK日志集成中讲到了日志的排查方法,现在聊聊使用spring-cloud-sleuth和MDC+拦截器两种方法操作traceId实现全链路调用日志跟踪 方法一:直接使用spring-cloud-starter-sleuth进行日志链路跟踪 在pom.xml...
  • 目录前言编译阶段|- -未开启ftrace|- -开启...通过观察钩子函数的创建过程以及替换过程,理解trace的原理。本文同样以blk_update_request函数为例进行说明。 kernel版本:5.10 平台:arm64 编译阶段 |- -未开启ftrace
  • springboot整合netty,利用slf4j的MDC来生成traceId做链路追踪,sleuth配合使用【sleuth和MDC可选择不使用,那就不需要编写aop和注解,不需要引入aop和sleuth】。 1:所需要依赖的jar(根据自己需求选择) <!-- ...
  • 1、区别节点、网段、广播三种类型IP地址 2、掌握IP子网掩码的两种表示方法 3、明确IP网关含义 4、掌握IP子网划分、网络规划的基本方法 5、熟悉组网仿真工具GNS3使用方法 6、学会使用路由器的基本配置命令 7、深入...
  • 天萃荷净开发DBA反映需求,在连接Oracle数据库的Ip地址进行限制,通过触发器限制IP地址登陆数据库,对具有dba权限用户无效。测试主机不能连接生产的数据库,首先想到了通过listener来搞定,修改sqlnet.ora文件,然后...
  • besttrace linux下载

    2021-05-17 07:53:20
    besttrace linux版是款可用于linux服务器上的ip追踪工具!目前besttrace已经覆盖了安卓、苹果、Windows等多个平台,功能强大,使用简单,附带链路可视化,可以让大家清楚的知道ip归属地!并且兼容性强,稳定运行,...
  • 展开全部Ping命令Ping是最常使用的故障诊断与排除...ICMP消息以IP数据包传输,因此接收到ICMP回应应答消息能够表明第三层以下的连接都工作正常。Cisco的ping命令不但支持IP协议,而且支持大多数其他的桌面协议,如...
  • trace命令是什么意思?

    2021-01-14 14:35:01
    使用 tracert 命令跟踪路径 打开 命令提示符,然后键入: tracert host_name 或者键入 tracert ip_address 其中 host_name 或 ip_address 分别是远程计算机的主机名或 IP 地址. 例如,要跟踪从该计算机到 [url]...
  • 环境:OraDB10g_home问题:1....2.使用Net Manager 更改本地数据库服务IP地址后抛出“ORA-12541:TNS:无监听程序”错误。步骤:1、检查listener.log日志, 发现下面错误:TNSLSNR for 32-bit Windows: Version 10.2.0....
  • 1)首先安装mtr yum install mtr 2)mtr的使用示例 mtr -n www.baidu.com 第一列(Host):IP地址和域名,按n键可以切换IP和域名 第二列(Loss%):丢包率 第三列(Snt):设置每秒发送数据包的数量,默认值是10 可以...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 56,141
精华内容 22,456
关键字:

ip地址trace