精华内容
下载资源
问答
  • 图文并茂~用华为eNSP模拟Ospf优先级

    千次阅读 2020-06-26 07:56:31
    利用我们之前安装过得华为eNSP来模拟ospf优先级 实验环境: 某公司新加了三台交换机,领导要求需要用ospf做优先级配置 实验描述: 1,使用eNSP模拟环境 2,抓包查看是否符合要求! 推荐步骤 1,依次配置 R1路由器 R2...

    利用华为eNSP模拟拓扑

    实验案例:

    利用我们之前安装过得华为eNSP来模拟ospf优先级

    实验环境:

    某公司新加了三台交换机,领导要求需要用ospf做优先级配置

    实验描述:

    1,使用eNSP模拟环境
    2,抓包查看是否符合要求!

    推荐步骤

    1,依次配置 R1路由器 R2路由器 R3路由器 2,抓包验证是否符合要求

    实验设计图:

    在这里插入图片描述按照图片要求 可一次拖动进入拓扑中并按照要求写上条件

    步骤描述:

    步骤一:为三台路由器 R1,R2 R3 配置ospf优先级,在配置优先级之前我们首先给三台路由器配置ip 地址,如图所示:
    在这里插入图片描述配置R1ip地址
    int g/0/0/0
    ip add 13.0.0.1 24
    q

    然后 配置R1 loo
    在这里插入图片描述配置R1 loo
    Int loo 0
    Ip add 1.1.1.1 23
    q

    其次就是给R1配置ospf在这里插入图片描述配置ospf
    Ospf router-ip 1.1.1.1
    Area 0.0.0.0
    Network 13.0.0.0 0.0.0.255
    Network 1.1.1.1 0.0.0.0
    Q

    在这里插入图片描述配置R2 如上图几个步骤

    在这里插入图片描述
    配置loo 0

    在这里插入图片描述Ospf router-ip 2.2.2.2
    Area 0.0.0.0
    Network 13.0.0.0 0.0.0.255
    Network 2.2.2.2 0.0.0.0
    Q

    到这里第二台路由器R2配置完毕

    第三部 配置R3路由器在这里插入图片描述
    配置R3ip地址
    int g/0/0/0
    ip add 13.0.0.3 24
    q

    在这里插入图片描述配置R3 loo
    Int loo 0
    Ip add 3.3.3.3 23
    q
    在这里插入图片描述Ospf router-ip 3.3.3.3
    Area 0.0.0.0
    Network 13.0.0.0 0.0.0.255
    Network 3.3.3.3 0.0.0.0
    Q

    到这样第三台R3路由器配置完毕

    然后我们就开始进行抓包验证
    在这里插入图片描述
    验证符合要求 步骤完毕 希望能给大家带来帮助

    展开全文
  • 华为 OSPF基本概念与基础配置

    万次阅读 多人点赞 2020-05-19 17:48:37
    在战胜敌人之前,先战胜自己。 文章目录 一、拓扑 ...OSPF 是一种应用非常广泛发基于链路状态的动态路由协议,它具有区域(Area)化的层次结构,扩展性好,收敛速度快,适合部署在各种规模的网络上。

    在战胜敌人之前,先战胜自己。

    OSPF 是一种应用非常广泛发基于链路状态的动态路由协议,它具有区域(Area)化的层次结构,扩展性好,收敛速度快,适合部署在各种规模的网络上。

    一、OSPF 基本概念

    1、AS:自治系统,也叫路由域

    同一个 AS 中的所有路由器必须运行相同的路由协议,且必须彼此互相连接(中间不能被其他协议路由域间断)
    在 OSPF 网络中只有再同一个 AS 内的路由器才会相互交互链路状态信息。

    2、AREA:区域是 OSPF 非常重要的一个特征,在一个 AS 内划分不同的区域,每个 OSPF 路由器只能在所属区域内部学习到完整的链路状态信息

    (1)Area 0 骨干区域:用来连接不同区域的骨干区域,OSPF 网络设计规定普通区域必须和骨干区域直接连接,

    3、OSPF 特殊区域

    在 OSPF 中,除了 Stub,Totally Stub,NSSA,Totally NSSA;其他区域通常为普通区域(包括AREA 0 骨干区域)

    4、OSPF 五种数据包的类型和作用描述

    (1)Hello 包

    作用:发现,建立/协商,维持邻居。

    (2)DD(DBD)数据库描述包

    作用:LSA 更新时的主从选举;MTU LSA 简略新的交互

    (3)LSR 链路状态请求包

    作用:请求自身缺少的 LSA 信息

    (4)LSU 链路状态更新包

    作用:LSA 更新信息(回应对方的LSR的请求)

    (5)LSACK 链路状态确认

    作用:LSA 更新新的确认回复

    5、邻居与邻接

    在OSPF 路由器通告任何 LSA 之前,OSPF 路由器必须首先发现邻居路由器并建立起邻接关系。

    (1)邻居:仅通过 hello 包发现运行 OSPF 的其他路由器
    (2)邻接:建立了邻居关系,并且 OSPF 关系更进一步,互相发送各自的 LSA 信息。

    6、OSPF 的网络类型:

    (1)点对点网络(point-to-point----P2P)

    a.成员关系:邻接(自动形成)
    b.组播地址:224.0.0.5
    c.更新方式:组播
    d.DR/BDR:无

    (2)广播型网络(broadcast—MA)

    a.成员关系:邻居/邻接(自动形成)
    b.组播地址:224.0.0.5,224.0.0.6
    c.更新方式:组播
    d.DR/BDR:有

    (3)非广播多路访问(NBMA)

    a.成员关系:邻居(手动)
    b.组播地址:不适用
    c.更新方式:单播
    d.DR/BDR:有

    (4)点到多点网络(point-to-multipoint-point—P2MP)

    a.成员关系:邻居
    b.组播地址:不适用
    c.更新方式:组播hello;单播其他ospf报文
    d.DR/BDR:无

    7、OSPF 在 MA 网络的 DR,BDR

    (1)DR:Designated Router 指定路由器
    在 MA 网络建立和维护邻接关系并负责 LSA 的同步;
    DR 与其他所有的路由器形成邻接关系并交换链路状态信息,其他路由器之间不直接交换链路状态信息,这样就大大减少了 MA 网络中的邻接关系数据 及交换链路状态信息消耗的资源。

    (2)BDR:Backup Designated Router 备份指定路由器
    规避单点故障风险,通过选举备份指定路由器 BDR,在 DR 失效时快速接管 DR 的工作

    (3)DR,BDR 的选举:
    DR/BDR 的选举是基于接口的;接口 DR 优先级为 0,表示不参与选举
    a:比较接口优先级,越大越优先(默认为1)
    b:优先级一致比较 R-ID,越大越优先

    8、OSPF 的计时器

    (1)Hello 包,默认10S一发,超时时间为 Hello 间隔的 4 倍。
    (2)LSA 全网通告时间默认 30 分钟。

    9、OSPF 的 LSA

    LSA:Link State Advertiserment 链路状态通告:OSPF 邻居路由器直接互相交互 LSA 并保存整个网络的链路状态信息,并生成链路状态数据库(LSDB),从而 掌握全网的拓扑结构,并通过 SPF 最短路径优先算法,独立计算自身去往目的的最佳路由。
    OSPF 的 LSA 有 10 多种,常用的为以下6类

    (1)Type1 LSA:路由器 LSA(Router LSA)

    (2)Type2 LSA:网络 LSA(Network LSA)(广播网专有)

    (3)Type3 LSA:网络聚合/网络汇总 LSA(Network summary LSA)

    (4)Type4 LSA:ASBR 聚合/汇总 LSA(ASBR summary)

    (5)Type5 LSA:自治系统外部 LSA(Autonomous system external LSA)

    (6)Type7 LSA:NSSA 外部 LSA(NSSA External LSA)

    二、拓扑

    在这里插入图片描述

    三、基础配置

    1、如图配置个接口地址及系统名称

    AR-1
    
    [Huawei]sysname AR-1
    [AR-1]int LoopBack 0
    [AR-1-LoopBack0]ip address 1.1.1.1 32
    [AR-1-LoopBack0]int g0/0/1
    [AR-1-GigabitEthernet0/0/1]ip address 192.168.1.1 24
    [AR-1-GigabitEthernet0/0/1]int g0/0/0
    [AR-1-GigabitEthernet0/0/0]ip address 12.1.1.1 24
    [AR-1-GigabitEthernet0/0/0]quit	
    [AR-1]ospf 1 router-id 1.1.1.1
    [AR-1-ospf-1]a 0
    [AR-1-ospf-1-area-0.0.0.0]net 12.1.1.1 0.0.0.0
    [AR-1-ospf-1-area-0.0.0.0]net 1.1.1.1 0.0.0.0
    [AR-1-ospf-1-area-0.0.0.0]a 1
    [AR-1-ospf-1-area-0.0.0.1]net 192.168.1.1 0.0.0.0
    

    2、按照图示信息宣告 OSPF 网络和 RIP 网络,OSPF 配置时手动指定 OSPF的 R-ID
    例:AR-1 为1.1.1.1,AR-2 为 2.2.2.2 依次类推

    3、实现全网互通

    AR-6 ping AR-3(192.168.1.3)
    在这里插入图片描述

    四、观察与分析

    1、路由器角色划分

    IR:internal Router 区域内路由器;
    BR:Backbone Router 骨干路由器;
    ABR:Area Border Router 区域边界路由器;
    ASBR:AS Border Router 自治系统边界路由器。

    (1)请标识出图中所有路由器各自所属的角色
    在这里插入图片描述
    注意:的是一个 ospf 设备可能会对应几个角色,但是 IR 和 BR 只能对应一个角色,即路由器如果是一个 BR 或者 IR 之后就不会再是其他角色了。

    2、指定 AR-3 为 192.168.1.0 网段的 DR,AR-4 为 BDR

    [AR-1-GigabitEthernet0/0/1]ospf dr-priority 0  //修改接口的OSPF优先级为0,表示本接口不参与OSPF的DR,BDR选举
    

    在这里插入图片描述
    dis ospf peer
    在这里插入图片描述
    3、分析

    (1)在 AR-1 的 G0/0/0 接口开启抓包,然后配置 AR-1 与 AR-2 的 ospf,抓包观察 AR-1 与 AR-2 ospf 建立邻居过程中交互了几种数据包

    重启 OSPF 进程,可观察 OSPF 邻居关系的建立过程。

    Reset ospf process
    在这里插入图片描述
    五种数据包

    ① Hello
    ② DD
    ③ LSR
    ④ LSU
    ⑤ LSAck

    (2)查看 AR-1 在建立邻居过程中弹出的日志信息,截图标识出建立邻居时的 OSPF 状态 信息(即找出inter 2-way这些状态)

    192.168.1.3
    在这里插入图片描述
    12.1.1.2
    在这里插入图片描述
    192.168.1.4
    在这里插入图片描述

    五、OSPF 一些性质

    1、层次化设计:

    当只有一个 ospf 区域时所带来的问题:

    (1)LSA 泛洪数量大,导致路由器的 LSDB 中的 LSA 数量多,这时用SPF进行路径算法时,由于LSA 条目多比较耗时,而且耗费 CPU 等资源。从而导致路由表数目过大。

    (2)如果一条链路一会 UP 一会 Down,这样故障翻动。这样对网络冲击是比较恶劣。这个冲击会导致每当翻动一下,这个网络所有路由器就会对这个条目重新计算,这样既耗时,又会导致路由迟迟无法同步。

    2、ospf 多区域带来的好处:

    (1)限制 LSA 泛洪范围。

    (2)部署区域之后,有 ABR 产生,ABR 可以把区域条目汇总后发向其他区域。

    a.这样减小了其他区域路由器路由表的条目数量。
    b.当一个区域内的链路翻动时,它只会相应本区域内的所有路由器,而不影响其他区域。

    3、关于区域设计,OSPF 协议支持中到大型网络到底有多大呢?

    这边有个参考原则:
    (1)一台路由器可以成为 ABR,但官方建议,无论这台 ABR 有多高端。一台 ABR 建议最多关联三个区域。

    (2)在一个区域内,路由器数量最多只有 50 台。

    (3)对于一台运行 OSPF 路由器,其 OSPF 邻接状态的邻居最多最多只能有 60 台。

    (4)对于 OSPF 协议算法 SPF 来说,它本身在被设计时,就仅支持大概一万条路由条目。

    注意:OSPF 协议虽然支持中到大型网络,但一定要基于这个设计。
    在这里插入图片描述

    本人所有文章都受版权保护,著作权归艺博东所有!未经授权,转载必究或附上其原创链接。

    展开全文
  • OSPF路由协议基本配置及手动配置路由器优先级 R1: interface GigabitEthernet0/0/0 ip address 10.1.1.1 255.255.255.0 ospf dr-priority 100 //手工配置路由器优先级,确保指定路由器接口成为DR interface ...

    在这里插入图片描述
    OSPF路由协议基本配置及手动配置路由器优先级
    R1:
    interface GigabitEthernet0/0/0
    ip address 10.1.1.1 255.255.255.0
    ospf dr-priority 100 //手工配置路由器优先级,确保指定路由器接口成为DR

    interface LoopBack0
    ip address 1.1.1.1 255.255.255.255

    ospf 1
    area 0.0.0.1
    network 1.1.1.1 0.0.0.0
    network 10.1.1.0 0.0.0.255
    R2:
    interface GigabitEthernet0/0/0
    ip address 10.1.2.2 255.255.255.0

    interface GigabitEthernet0/0/1
    ip address 10.1.1.2 255.255.255.0

    interface GigabitEthernet0/0/2

    ospf 1
    area 0.0.0.0
    network 10.1.2.0 0.0.0.255
    area 0.0.0.1
    network 2.2.2.2 0.0.0.0
    network 10.1.1.0 0.0.0.255
    R3:
    interface GigabitEthernet0/0/0
    ip address 10.1.3.3 255.255.255.0

    interface GigabitEthernet0/0/1
    ip address 10.1.2.3 255.255.255.0
    ospf dr-priority 0
    interface LoopBack0
    ip address 3.3.3.3 255.255.255.255

    ospf 1
    area 0.0.0.0
    network 10.1.2.0 0.0.0.255
    area 0.0.0.2
    network 3.3.3.3 0.0.0.0
    network 10.1.3.0 0.0.0.255
    R4:
    interface GigabitEthernet0/0/1
    ip address 10.1.3.4 255.255.255.0

    interface LoopBack0
    ip address 4.4.4.4 255.255.255.255

    ospf 1
    area 0.0.0.2
    network 4.4.4.4 0.0.0.0
    network 10.1.3.0 0.0.0.255

    验证:
    查看OSPF邻居信息
    dis ospf peer

     OSPF Process 1 with Router ID 1.1.1.1
    	 Neighbors                   本地路由器ID           
    

    Area 0.0.0.1 interface 10.1.1.1(GigabitEthernet0/0/0)'s neighbors
    区域号 接口IP
    Router ID: 2.2.2.2 Address: 10.1.1.2
    对端路由器ID 对端路由器IP
    State: Full Mode:Nbr is Master Priority: 1
    DR: 10.1.1.1 BDR: 10.1.1.2 MTU: 0
    Dead timer due in 37 sec
    Retrans timer interval: 5
    Neighbor is up for 05:24:04
    Authentication Sequence: [ 0 ]

    查看OSPF路由信息:
    dis ospf routing
    OSPF Process 1 with Router ID 1.1.1.1
    Routing Tables
    Routing for Network
    Destination Cost Type NextHop AdvRouter Area
    1.1.1.1/32 0 Stub 1.1.1.1 1.1.1.1 0.0.0.1
    10.1.1.0/24 1 Transit 10.1.1.1 1.1.1.1 0.0.0.1
    2.2.2.2/32 1 Stub 10.1.1.2 2.2.2.2 0.0.0.1
    3.3.3.3/32 2 Inter-area 10.1.1.2 2.2.2.2 0.0.0.1
    4.4.4.4/32 3 Inter-area 10.1.1.2 2.2.2.2 0.0.0.1
    10.1.2.0/24 2 Inter-area 10.1.1.2 2.2.2.2 0.0.0.1
    10.1.3.0/24 3 Inter-area 10.1.1.2 2.2.2.2 0.0.0.1
    Total Nets: 7
    7条路由条目
    Intra Area: 3 Inter Area: 4 ASE: 0 NSSA: 0
    区域内部条目3 区域间条目4
    查看路由信息:
    display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------**
    Routing Tables: Public
    Destinations : 13 Routes : 13
    Destination/Mask Proto Pre Cost Flags NextHop Interface
    1.1.1.1/32 Direct 0 0 D 127.0.0.1 LoopBack0
    2.2.2.2/32 OSPF 10 1 D 10.1.1.2 GigabitEthernet
    0/0/0
    3.3.3.3/32 OSPF 10 2 D 10.1.1.2 GigabitEthernet
    0/0/0
    4.4.4.4/32 OSPF 10 3 D 10.1.1.2 GigabitEthernet
    0/0/0
    10.1.1.0/24 Direct 0 0 D 10.1.1.1 GigabitEthernet
    0/0/0
    10.1.1.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
    0/0/0
    10.1.1.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
    0/0/0
    10.1.2.0/24 OSPF 10 2 D 10.1.1.2 GigabitEthernet
    0/0/0
    10.1.3.0/24 OSPF 10 3 D 10.1.1.2 GigabitEthernet
    0/0/0
    127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
    127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
    127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
    255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0

    配置结果:
    任意路由器上可以Ping通其它路由器上LoopBack0地址

    展开全文
  • 系统为每一种路由协议都设置了不同的默认优先级,当在不同协议中发现同一条路由时,协议优先级高的将被优选。 如果没有直接配置OSPF接口的开销值,OSPF会根据接口的带宽自动计算开销值。计算公式为:接口开销=带宽...
    实验原理

    由于路由器上可能运行多种动态路由协议,就存在路由协议志建路由信息的共享和选择问题。系统为每一种路由协议都设置了不同的默认优先级,当在不同协议中发现同一条路由时,协议优先级高的将被优选。
    如果没有直接配置OSPF接口的开销值,OSPF会根据接口的带宽自动计算开销值。计算公式为:接口开销=带宽参考值/接口带宽,取计算结果的整数部分作为接口的开销值,通过改变带宽参考值可以间接改变接口的开销值。
    OSPF常见的计时器澳阔hello timer 和dead timer,分别决定了ospf发送hello报文的间隔和保持邻居关系的计时器,默认情况下,P2P,Broadcast类型接口发送hello报文的时间为10s,邻居失效时间为40s,P2MP,NBMA类型接口发送hello报文的时间间隔为30s,邻居失效时间为120s。

    实验目的

    掌握配置ospf协议优先级的方法
    掌握配置ospf开销的方法
    掌握配置ospf hello timer 的方法
    掌握配置ospf dead timer的方法

    实验拓扑

    在这里插入图片描述

    实验步骤

    1.基本配置,并测试联通性
    2,配置协议优先级
    部署OSPF网络,实现A和B通过R2通信,在路由器R1,R2,R4部署OSPF网络,通告相关网络属于区域0

    [R1]ospf 1
    [R1-ospf-1]area 0
    [R1-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.0]network 10.0.1.0 0.0.0.255
    
    [R2]ospf 1
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]network 10.0.24.0 0.0.0.255
    
    [R4]ospf 1
    [R4-ospf-1]area 0
    [R4-ospf-1-area-0.0.0.0]network 10.0.24.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.0]network 10.0.45.0 0.0.0.255
    
    [R5]ospf 1
    [R5-ospf-1]area 0
    [R5-ospf-1-area-0.0.0.0]network 10.0.45.0 0.0.0.255
    [R5-ospf-1-area-0.0.0.0]network 10.0.2.0 0.0.0.255
    

    测试pc1和pc2的联通性,可以通
    在这里插入图片描述
    现在在部署通过R3 的线路,运行RIP协议

    [R1]rip 1
    [R1-rip-1]version 2	
    [R1-rip-1]undo summary 	
    [R1-rip-1]network 10.0.0.0
    
    [R3]rip 1
    [R3-rip-1]version 2
    [R3-rip-1]undo summary 
    [R3-rip-1]network 10.0.0.0
    
    [R4]rip 1
    [R4-rip-1]version 2
    [R4-rip-1]undo summary 	
    [R4-rip-1]network 10.0.0.0
    
    [R5]rip 1
    [R5-rip-1]version 2
    [R5-rip-1]undo summary 
    [R5-rip-1]network 10.0.0.0
    

    配置完成后,在分支的网关设备R1上查看路由表中关于分支B网段的10.0.2.0
    在这里插入图片描述
    发现数据还是通过R2 转发,R3带宽更大的路径没有参与数据转发,从pc1去往pc2的同一条路由条目可以通过两个路由条目获得,首先比较两个协议的优先级,会优先选择优先级高的路由条目,ospf的路由协议为10,rip为100,值越低,优先级越高,所以选择ospf来获得.,
    现在修改路由器的优先级 ospf的为110,rip为100,

    [R1]ospf 1
    [R1-ospf-1]preference 110
    
    [R4]ospf 1	
    [R4-ospf-1]preference 110
    
    [R5]ospf 1
    [R5-ospf-1]preference 110
    

    再一次查看路由表,发现线路经过r3.
    在这里插入图片描述
    查看R4上去往pc1的路由表
    在这里插入图片描述
    3.配置ospf的开销值,现在修改R3的配置,使得运行ospf协议当R3和R2都运行ospf协议的时候,这个时候会比较ospf的开销值,来决定走哪条链路.

    [R3]ospf 1
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 10.0.13.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]network 10.0.34.0 0.0.0.255
    
    [R1]ospf 1
    [R1-ospf-1]area 0
    [R1-ospf-1-area-0.0.0.0]network 10.0.13.0 0.0.0.255
    
    [R4]ospf 1
    [R4-ospf-1]area 0
    [R4-ospf-1-area-0.0.0.0]network 10.0.34.0 0.0.0.255
    

    再次查看R1上关于10.0.2.0的路由
    在这里插入图片描述
    两条一样,在R1上修改开销值,在g0/0/1修改

    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]ospf cost 1000
    

    再次查看就只变成1条了.
    在这里插入图片描述
    开销值是基于接口修改的.
    4,配置ospf的计时器.

    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]ospf timer hello 20
    [R1-GigabitEthernet0/0/1]ospf timer dead 80
    发现R1和R3的邻居关系中断,这是因为hello计时器和dead计时器在ospf广播网络中建立邻居关系需要校验,校验一致才能建立邻居关系.
    [R3]int g0/0/1
    [R3-GigabitEthernet0/0/1]ospf timer hello 20
    [R3-GigabitEthernet0/0/1]ospf timer dead 80
    

    查看R1的邻居状态
    在这里插入图片描述

    展开全文
  • 华为OSPF详解、总结

    千次阅读 2020-07-24 22:58:12
    OSPF:开放式最短路径优先协议 目录 OSPF:开放式最短路径优先协议 一、数据包—5种基本数据包 二、OSPF的状态机 三、OSPF的工作过程 四、区域划分规则: 五、数据包 六、各类LSA: 七.OSPF 邻居状态机制 ...
  • OSPF原理和优先级(学习笔记)

    万次阅读 2020-04-21 16:05:40
    (1)ospf是基于链路状态的动态路由协议 (2)特点: 具有区域化(area)的层次结构,扩展性好,收敛速度快。 (3)网络类型: 广播网络(Broadcast) NBMA(Non-Broadcast Multi-Access)网络 点到点网络(Point-to...
  • 华为ospf综合实验(认证+缺省路由)个人笔记 ————————————————————————————— 第一步:把R1、2、3、6,主机名、IP、ospf这些基础配好 R1: sys sys R1 int g0/0/0 ip add 192.168.0.1 ...
  • 现整理一部分华为系列交换机、路由器各项配置优先级,欢迎各位朋友收藏备查,若有遗漏或者是错误,也欢迎在评论区提出交流。 本文主要适合具有一定基础的网络工程师查阅参考,阅读本文,需要对本文中提到的各项网络...
  • 现整理一部分华为系列交换机、路由器各项配置优先级,欢迎各位朋友收藏备查,若有遗漏或者是错误,也欢迎在评论区提出交流。 本文主要适合具有一定基础的网络工程师查阅参考,阅读本文,需要对本文中提到的各项网络...
  • 华为OSPF详解及配置

    万次阅读 多人点赞 2020-04-15 02:13:23
    OSPF:开放式最短路径优先协议 目录 OSPF:开放式最短路径优先协议 一、数据包—5种基本数据包 二、OSPF的状态机 三、OSPF的工作过程 四、区域划分规则: 五、数据包 六、各类LSA: 七.OSPF 邻居状态机制 ...
  • 华为ospf知识点整理(HCIA): 1.ospf出现的原因: RIP协议有着最大条数(max=15跳)的限制,无法适应适应网络的扩展和丰富性。 2.ospf的优势: (1)无环路(利用SPF算法保证ospf协议无环) (2)收敛快,触发更新...
  • IR域内路由器 ABR区域边界路由器 BR骨干路由器 ASBR自治系统边界路由器 全局router-id,如果后面的ospf不宣告的话,默认加入全局...注:华为高端设备,查看隐藏命令 display ip routing-table _vrbd 诊断视...
  • 现整理一部分华为系列交换机、路由器各项配置优先级,欢迎各位朋友收藏备查,若有遗漏或者是错误,也欢迎在评论区提出交流。 本文主要适合具有一定基础的网络工程师查阅参考,阅读本文,需要对本文中提到的各项网络...
  • 华为OSPF抓包分析七种状态

    千次阅读 2020-02-13 23:26:27
    OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(Autonomous System,AS)内决策路由。是对链路状态路由协议的一种实现,隶属内部网关...
  • 华为路由器规定的路由协议优先级为: 路由协议 | 优先级 ———————————— DIRECT | 0 OSPF | 10 STATIC | 60 IGRP | 80 RIP | 110 OSPFASE | 150 BGP | 170 Cisco 路由器规定的路由协议优先级为: 路由协议...
  • OSPF接口优先级

    千次阅读 2011-06-10 12:36:33
    由于 DR 成为 LSA 的集散中心,所以它必须具有足够的 CPU 和存储性能才能担此重责。与其依赖路由器 ID 来确定 DR 和 BDR 结果,不如使用 ip ospf priority ...在前述讨论中,各台路由器的 OSPF 优先级相等,原因在于...
  • 华为路由交换 OSPF

    2020-02-08 16:13:05
    OSPF 笔记
  • 华为 OSPF协议

    千次阅读 多人点赞 2020-02-13 19:37:40
    成功,就是比放弃多坚持了一次。 文章目录 一、拓扑 二、基础配置与状态机测试 三、ospf建立邻居“4+1”条件总结 四、邻居状态和数据包
  • 华为路由器:ospf协议入门介绍

    千次阅读 多人点赞 2020-10-19 00:05:02
    Huawei> <Huawei>sys Enter system view, return user view with Ctrl+Z. [Huawei]sys R1 [R1]int g0/0/0 [R1-GigabitEthernet0/0/0]ip address 192.168.1.254 24 Oct 18 2020 23:45:50-08:00 R1 %%01...
  • 如图所示,OSPF网络中有四台交换机,同属于区域0。要求配置负载分担,使得SWA流量,可以分别通过SWB和SWC送到SWD。 二、配置思路 1、在各交换机上配置OSPF基本功能,实现OSPF网络的基本互通。 2、在SwitchA配置...
  • 系统为每一种路由协议设置了不同的默认优先级,当在不同协议中发现同一条路由时,协议优先级高的将被优选。 如果没有直接配置OSPF接口的开销值,OSPF会根据该接口的带宽自动计算其开销值。计算公式为:接口开销=带宽...
  • 华为设备路由协议默认优先级 华为设备路由协议默认优先级 路由协议 路由协议外部优先级 路由协议内部优先级 直连 0 0 OSPF 10 10 IS-IS 15 15(Level-1)18(Level-2) Static ...
  • OSPF的基础配置/原理及认证
  • 华为OSPF路由配置详解教程

    千次阅读 2017-02-27 09:17:24
    一、OSPF的基本功能在同一区域内配置多台交换机时,大多数的配置数据(如定时器、过滤、聚合等)都应该以区域为单位进行统一规划。错误的配置可能会导致相邻交换机之间无法...1、OSPF进程、路由ID配置 [Huawei]ospf...
  • OSPF同区域(改接口开销、修改DR优先级值)配置命令 拓扑图: 配置命令 实验要求: 1.AR1和AR2能够进行路由的学习 2.指定R1作为DR 3.要求R1学习的2.2.2.2路由的开销要为20 [R1]int LoopBack 0 [R1-LoopBack0]ip add ...
  • OSPF的认证机制: 接口认证和区域认证同时开启时,接口认证优于区域认证。如下图: R1和R2之间开启链路认证: 认证的方式有多种,例如md5,keychain等,这里我们用md5进行认证: ospf authentication-mode md5 1 ...
  • 华为路由器OSPF配置

    2021-05-13 14:31:18
    【欢迎关注微信公众号:厦门微思网络】 学习目标 ·掌握OSPF中Router ID的配置...·掌握OSPF路由优先级的修改方法 拓扑图 图2.2 OSPF单域配置实验拓扑图 场景 您是公司的网络管理员。现...
  • 华为OSPF基础命令汇总

    2021-10-07 12:02:22
    接口视图上:ospf timer hello "number" 接口视图上:ospf timer dead "number" 接口视图上:ospf cost "number" 其他协议视图上:import-route ospf 1 cost "number" // 路由的重分布 默认default-route-...
  • OSPF(Open Shortest Path First),开放式最短路径优先。OSPF作为链路状态的协议,具有收敛快、路由无环、扩展性好等优点。链路状态算法路由协议互相通告的是链路状态信息,每台路由器都将自己的链路状态信息(包含...
  • 华为ospf入门

    2021-07-08 18:50:01
    ospf入门实验 题目要求 1、使用OSPF实现全网可达 2、R1-3之间R1为DR,没有BDR; 3、R3与R4,R4为DR,没有BDR; R1 <Huawei> <Huawei>sys <Huawei>system-view [Huawei]sysn r1 [r1]int gi 0/0/...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,536
精华内容 1,014
关键字:

华为ospf优先级