精华内容
下载资源
问答
  • OSPF-汇总+路由管理.txt

    2019-05-23 15:38:13
    OSPF-汇总+路由管理
  • ospf路由汇总(聚合)实例

    千次阅读 2021-03-04 11:02:23
    非骨干区域路由汇总(聚合) 这里我们在AR4上创建两个环回口 Lo8 Lo9,IP地址分别设置为:Lo8-192.168.8.1/24,Lo9-192.168.9.1/24 然后设置环回口的OSPF的网络类型为广播,这里如果不设置为广播

    拓扑

    在这里插入图片描述

    先根据拓扑图把基础配置做好
    做好后检查连通性
    基础配置不知道怎么做的可以查看我的另一篇文章
    https://blog.csdn.net/qq_43492336/article/details/114132931?spm=1001.2014.3001.5501

    非骨干区域路由汇总(聚合)

    这里我们在AR4上创建两个环回口 Lo8 Lo9,IP地址分别设置为:Lo8-192.168.8.1/24,Lo9-192.168.9.1/24
    然后设置环回口的OSPF的网络类型为广播,这里如果不设置为广播,ospf则默认以32位掩码的形式传递路由,所以我们需要设置为广播类型,让ospf以24为掩码形式传递这两个环回口的路由

    命令

    AR4
    在这里插入图片描述

    做好之后,我们把这两个地址宣告进ospf的Area 2区域
    在这里插入图片描述
    然后我们去AR1上看一下,可以发现已经收到了192.168.8.0/24以及192.168.9.0/24两条路由

    AR1
    在这里插入图片描述

    接下来我们需要做路由聚合,把192.168.8.0/24与192.168.9.0/24合并成192.168.8.0/23,这里为什么要叫聚合请看我的另一篇文章
    https://blog.csdn.net/qq_43492336/article/details/114298916?spm=1001.2014.3001.5501
    这里我们需要进到AR2的 ospf的Area 2 区域内进行配置

    AR2
    在这里插入图片描述

    通过abr-summary 命令可以实现将Area2 区域内的192.168.8.0 192.168.9.0路由合并成192.168.8.0/23
    做好之后我们返回AR1查看路由

    AR1
    在这里插入图片描述

    从图中可以看到原本的8.0/24路由跟9.0/24路由已经不见了,取而代之的是8.0/23的路由,通过这种方式,如果当area 2区域某个接口出现路由翻动的时候,我们可以把影响控制在一个区域内,将不会影响到该AS域下的其他区域

    注意事项

    这种非骨干区域的路由汇总或聚合,必须要在汇总路由对应区域的ABR上做,我们这个实验由于路由条目是由AR4产生的,AR4属于Area 2区域,然后AR2又是该区域的ABR 所以我们要在AR2上做路由聚合

    外部路由的路由

    这里呢由于AR4与AR5之间是通过RIP来获悉路由的,所以我们通过路由引入的方式,把RIP的路由引入到OSPF内

    命令

    在AR4上引入RIP
    在这里插入图片描述
    进入OSPF进程,直接通过import-route 引入RIP
    引入之后,我们在AR1上查看LSDB
    在这里插入图片描述
    可以发现AR5的路由已经通过5类LSA传递给AR1了
    接下来查看一下AR1的路由表
    在这里插入图片描述
    可以看到已经收到了AR5的环回口路由以及45.1.1.0网络路由

    AR5

    接下来我们在AR5上创建两个环回口,Lo8,Lo9,分别对应IP地址Lo8:172.16.8.1/24,Lo9:172.16.9.1/24
    在这里插入图片描述
    然后把这两个环回口的IP地址宣告进RIP中去
    在这里插入图片描述
    由于RIP是通过主类IP宣告的,所以只需要宣告172.16.0.0即可包含这两个IP地址
    当我们把IP宣告进RIP后,由于我们已经做了路由引入,所以我们可以直接在AR1上查看到172.16.8.0/24的路由与172.16.9.0/24的路由

    AR1·
    在这里插入图片描述

    接下来我们就需要合并这两条外部路由,做路由汇总了,这里为什么又叫路由汇总呢,请看我另一篇文章
    https://blog.csdn.net/qq_43492336/article/details/114298916?spm=1001.2014.3001.5501

    我们需要在AR4上做汇总操作,因为AR4是ASBR,是引入这些外部路由的主导设备

    AR4
    在这里插入图片描述

    直接在AR4的OSPF进程中输入asbr-summary就可以把8.0/24与9.0/24的路由合并成8.0/23
    当我们做好操作后,直接去到AR1上查看

    AR1
    在这里插入图片描述

    可以看到原本172.16.8.0/24与172.16.9.0/24的路由现在汇总成一条172.16.8.0/23的外部路由了。这就是外部路由的汇总(聚合)

    注意事项

    外部路由做路由汇总(聚合),必须要在该外部路由所连接的ASBR上操作

    汇总后路由检测

    我们直接在AR3上做ping检测,看看汇总后的路由是否正常
    在这里插入图片描述
    在这里插入图片描述
    可以看到这4个IP都没有任何问题,可以正常通信

    展开全文
  • 华为ospf配置 及3.5类汇总

    千次阅读 2020-03-15 10:01:54
    华为曾经一个rs面试问题:有没有一种情况就是你们没有收到5类lsa但你能收到4类lsa。首先这在思科是不可能的,但华为可以,华为对asbr的定义是只要做了重分发。所以你在通告1类lsa的时候 你会通告我是asbr 启用ospf ...

    华为曾经一个rs面试问题:有没有一种情况就是你们没有收到5类lsa但你能收到4类lsa。首先这在思科是不可能的,但华为可以,华为对asbr的定义是只要做了重分发。所以你在通告1类lsa的时候 你会通告我是asbr

    启用ospf

    ospf 10 router-id x.x.x.x//router id要在进程外敲里面敲不了
    area n //创建区域0 
    network x.x.x.x n.n.n.n area id 
    

    在这里插入图片描述在r3和r5上启用rip,ar3是asbr,将外部路由rip引入到ospf

    ar3:
    rip 100 
    version 2 
    undo summary 
    network 35.0.0.0
    import-route ospf 10  
    在到ospf 10 中
    import-route rip 100 //华为默认将外部路由引入ospf子网路由和主类路由都能进的来
    //cisco默认将ospf重分发默认只有区域内和区域间
    
    查看命令
    display ospf interface 
    display ospf peer brief 邻居
    display ospf lsdb /

    华为所以区域内和区域间的路由标识都是ospf
    所以外部路由都是 O_ASE。
    router lsa 里 Priority : Medium

    华为ospf汇总

    3类汇总

    在R2上创建两个环回口 
    int loo 8  172.16.8.2 24 ospf network-type broadcast
    int loo 9  172.16.9.2 24 ospf network-type broadcast
    全宣告进area 0
    abr汇总始发路由器上做
    ospf 10 
    area 0
    abr-summary 172.16.8.0 255.255.254.0 
    

    操作后r4的路由表
    在这里插入图片描述

    5汇总

    在R5上创建两个环回口 
    int loo 8  172.16.8.2 24 ospf network-type broadcast
    int loo 9  172.16.9.2 24 ospf network-type broadcast
    全宣告进area 0
    在R3上ospf 10进程中
    asbr-summary v192.168.8.0 255.255.254.0 
    
    

    边界路由器default-route-advertise 可以向内网下放OE2 默认路由,没带always可以把默认下放给其它路由器,它能接收他们下放的路由,添加alyways意味这个区域内只有你才能下放默认,其它不接收,只加入lsdb。

    展开全文
  • 17-OSPF路由协议详解——OSPF路由汇总

    千次阅读 2019-07-23 13:26:25
    OSPF路由汇总需要注意的是:不能在区域内汇总,区域内部的路由器无法执行汇总功能,一般汇总的流程是从常规区域汇总到主干区域。例如下图中展示了OSPF路由汇总的流程中area 0是主干区域,其他ar...

    通常在一个大型的企业网或校园网中,其网络拓扑是非常复杂的,路由器的路由表也会非常冗余,这会造成网络设备在转发数据流量时需要消耗更多的硬件资源,OSPF路由协议也不例外,因此就需要用到路由汇总技术。

    OSPF路由汇总需要注意的是:不能在区域内汇总,区域内部的路由器无法执行汇总功能,一般汇总的流程是从常规区域汇总到主干区域。例如下图中展示了OSPF路由汇总的流程中area 0是主干区域,其他area 10,20,30则是常规区域。

     

    下面我们分别在R1,R2,R3三台路由设备中配置接口的IP地址信息,以R1设备为例:

    R1#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R1(config)#int loopback 1
    R1(config-if)#ip address 1.1.1.1 255.255.255.255
    R1(config-if)#exit
    R1(config)#int f0/0
    R1(config-if)#ip address 12.1.1.1 255.255.255.0
    R1(config-if)#no shutdown 
    R1(config-if)#exit
    R1(config)#int f0/1        
    R1(config-if)#ip address 13.1.1.1 255.255.255.0
    R1(config-if)#no shutdown 
    R1(config-if)#exit
    
    //再创建一个lo2口,配置4个ip地址
    R1(config)#int loopback 2
    R1(config-if)#ip address 192.168.0.1 255.255.255.0
    R1(config-if)#ip address 192.168.1.1 255.255.255.0 secondary 
    R1(config-if)#ip address 192.168.2.1 255.255.255.0 secondary 
    R1(config-if)#ip address 192.168.3.1 255.255.255.0 secondary 
    R1(config-if)#exit

    R2和R3设备的配置IP地址命令是类似的,这里直接略过......

     

     

    接下来分别在R1,R2,R3三台路由设备中配置OSPF路由协议并相互通告所在网络,R1设备配置如下:

    R1(config)#router ospf 100
    R1(config-router)#router-id 1.1.1.1
    R1(config-router)#network 1.1.1.1 0.0.0.0 area 10
    R1(config-router)#network 12.1.1.0 0.0.0.255 area 0
    R1(config-router)#network 13.1.1.0 0.0.0.255 area 0
    //通告lo2口所在网段
    R1(config-router)#network 192.168.0.0 0.0.0.255 area 10
    R1(config-router)#network 192.168.1.0 0.0.0.255 area 10
    R1(config-router)#network 192.168.2.0 0.0.0.255 area 10                                            
    R1(config-router)#network 192.168.3.0 0.0.0.255 area 10 
    R1(config-router)#

     

    R2设备配置如下:

    R2(config)#router ospf 100
    R2(config-router)#router-id 2.2.2.2
    R2(config-router)#network 2.2.2.2 0.0.0.0 area 20
    R2(config-router)#network 12.1.1.0 0.0.0.255 area 0
    R2(config-router)#network 23.1.1.0 0.0.0.255 area 0 
    R2(config-router)#exit

     

    R3设备配置如下:

    R3(config)#router ospf 100
    R3(config-router)#router-id 3.3.3.3
    R3(config-router)#network 3.3.3.3 0.0.0.0 area 30
    R3(config-router)#network 13.1.1.0 0.0.0.255 area 0
    R3(config-router)#network 23.1.1.0 0.0.0.255 area 0
    R3(config-router)#exit

     

     

    然后再查看R3的OSPF路由表信息:

    R3#show ip route ospf
         1.0.0.0/32 is subnetted, 1 subnets
    O IA    1.1.1.1 [110/2] via 13.1.1.1, 00:09:50, FastEthernet0/0
         2.0.0.0/32 is subnetted, 1 subnets
    O IA    2.2.2.2 [110/2] via 23.1.1.2, 00:09:40, FastEthernet0/1
         192.168.0.0/32 is subnetted, 1 subnets
    O IA    192.168.0.1 [110/2] via 13.1.1.1, 00:03:08, FastEthernet0/0
         12.0.0.0/24 is subnetted, 1 subnets
    O       12.1.1.0 [110/2] via 23.1.1.2, 00:09:40, FastEthernet0/1
                     [110/2] via 13.1.1.1, 00:09:50, FastEthernet0/0
    O IA 192.168.1.0/24 [110/2] via 13.1.1.1, 00:02:58, FastEthernet0/0
    O IA 192.168.2.0/24 [110/2] via 13.1.1.1, 00:02:38, FastEthernet0/0
    O IA 192.168.3.0/24 [110/2] via 13.1.1.1, 00:02:28, FastEthernet0/0

    我们发现R3从R1设备中学到了4条路由信息,当然R2也从R1设备中学到了这4条路由信息(通过show命令可以查看R2的OSPF路由表信息进行验证),为了减少主干区域的链路状态数据库和路由表大小从而降低路由器的压力,因此需要在R1设备采用路由汇总技术。

     

     

    这里我们在R1设备处进行路由汇总,配置如下:

    R1(config)#router ospf 100
    R1(config-router)#area 10 range 192.168.0.0 255.255.252.0
    R1(config-router)#exit

    area 10 range 192.168.0.0 255.255.252.0,这条命令的意思是把常规区域10中192.168.1.0开始的4条精细路由信息全部都汇总到主干区域0中。

     

     

    经过OSPF路由汇总后,再查看R3设备的OSPF路由表信息:

    R3#show ip route ospf
         1.0.0.0/32 is subnetted, 1 subnets
    O IA    1.1.1.1 [110/2] via 13.1.1.1, 00:17:47, FastEthernet0/0
         2.0.0.0/32 is subnetted, 1 subnets
    O IA    2.2.2.2 [110/2] via 23.1.1.2, 00:17:37, FastEthernet0/1
         12.0.0.0/24 is subnetted, 1 subnets
    O       12.1.1.0 [110/2] via 23.1.1.2, 00:17:37, FastEthernet0/1
                     [110/2] via 13.1.1.1, 00:17:47, FastEthernet0/0
    O IA 192.168.0.0/22 [110/2] via 13.1.1.1, 00:00:12, FastEthernet0/0

     

    很明显,进行路由汇总之后,R3的路由表明显简化了很多,将这4条精细路由信息都汇总成了192.168.0.0这一条路由信息。

    注意路由信息前面的“O IA”,上面的“O IA”表示R3路由设备收到R1和R2区域间路由汇总的路由信息。

     

    展开全文
  • 包括区域间路由汇总和外部路由汇总 ####区域间路由汇总 1、只能在 ABR上执行 2、只能对直连区域的路由做汇总(即对区域内的路由做汇总) 3、汇总的默认开销继承明细路由中开销最大的 4、明细路由全部失效,汇总路由...

    ##前言

    ####路由汇总

    包括区域间路由汇总和外部路由汇总

    ####区域间路由汇总

    1、只能在 ABR上执行
    2、只能对直连区域的路由做汇总(即对区域内的路由做汇总)
    3、汇总的默认开销继承明细路由中开销最大的
    4、明细路由全部失效,汇总路由也会失效
    5、如果区域有多个ABR,所有ABR都要执行汇总,否则失去汇总效果。
    6、我们可以使用命令将路由汇总却不通告。

    ####第一特性第二特性

    1、只能在 ABR上执行
    2、只能对直连区域的路由做汇总(即对区域内的路由做汇总)
    以R2进行实验,汇总前

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-KfF5DJPz-1618391983969)(//upload-images.jianshu.io/upload_images/14535918-075b2963e1e6ef2a.png?imageMogr2/auto-orient/strip|imageView2/2/w/676/format/webp)]

    汇总命令
    172.的路由是区域1路由,我们需要在区域1做路由汇总实验,

    [R2-ospf-1-area-0.0.0.1]abr-summary 172.16.0.0 255.255.0.0
    
    

    查看结果

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-RzVOqGyI-1618391984004)(//upload-images.jianshu.io/upload_images/14535918-d2e1e82444bc92d6.png?imageMogr2/auto-orient/strip|imageView2/2/w/676/format/webp)]

    在需要汇总的路由所产生的区域做汇总,它就会根据汇总的路由在其他区域产生一条3类LSA,

    ####第三特性

    3、汇总的默认开销继承明细路由中开销最大的

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-styLkgsZ-1618391984012)(//upload-images.jianshu.io/upload_images/14535918-18428f1fc0b415d9.png?imageMogr2/auto-orient/strip|imageView2/2/w/676/format/webp)]

    我们可以看到汇总之后的路由开销值是1
    此时我们在R1再起一个环回口l1,创建 172.16.110.1 24 路由开销为100
    将原来lo 0中的路由开销改为88

    int lo 1
    ip add 172.16.110.1 24
    ospf network-type broadcast 
    ospf cost 100
    int lo 0    
    ospf cost 88
    
    

    此时我们再次查看,汇总路由开销

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-8XanoX7i-1618391984020)(//upload-images.jianshu.io/upload_images/14535918-3f28180312e23611.png?imageMogr2/auto-orient/strip|imageView2/2/w/676/format/webp)]

    因此,汇总的默认开销继承明细路由中开销最大的
    我们还可以手动修改这个开销值
    进入区域1

    abr-summary 172.16.0.0 255.255.0.0 cost 10
    
    

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-L5kSspBS-1618391984023)(//upload-images.jianshu.io/upload_images/14535918-3909149fc069a4cf.png?imageMogr2/auto-orient/strip|imageView2/2/w/676/format/webp)]

    对于R3来说,它在计算这条汇总路由的开销值时,值就变为了11,

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-hiIv7NjF-1618391984027)(//upload-images.jianshu.io/upload_images/14535918-bcb10e8dbe669d88.png?imageMogr2/auto-orient/strip|imageView2/2/w/676/format/webp)]

    ####特性四

    4、明细路由全部失效,汇总路由也会失效,可以增强网络的稳定性
    特殊区域能不能增强网络的稳定性?
    能,因为是通过缺省路由访问外部路由,所以外部路由明细变化不影响缺省路由。

    ####特性五

    5、如果区域有多个ABR,所有ABR都要执行汇总,否则失去汇总效果。
    如果区域内有多个ABR,其中有一个ABR没有做路由汇总,那这个ABR就会将进过改路由未做汇总的同类路由进行泛洪,失去了汇总路由的效果。

    ####特性六

    6、我们可以使用命令将路由汇总却不通告。相当于某种意义上的路由过滤
    我们在R2上进行路由汇总之后,

    abr-summary 172.16.0.0 255.255.0.0 not-advertise 
    
    

    此时我们在R3上查看是否还存在172.16.0.0的汇总路由

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-WQ9yKGd2-1618391984029)(//upload-images.jianshu.io/upload_images/14535918-c3179ab02c87f260.png?imageMogr2/auto-orient/strip|imageView2/2/w/666/format/webp)]

    ##外部路由汇总

    1、只能在ASBR上 执行,
    2、汇总路由的开销类型继承明细路由的开销类型,如果明细路由的开销类型不一致,则开销类型为2(默认的类型)
    3、NSSA区域的外部路由可以在ASBR上 执行,也可以在NSSA区域上的ABR执行

    ####特性一

    我们将192.168.0.0 的路由引入,让R1做ASBR,此时,我们可以查看下之前是否做过这个,如果没有请添加

    import-route static
    
    

    查看lsdb

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-tsNANp4P-1618391984030)(//upload-images.jianshu.io/upload_images/14535918-9d719360e833e91e.png?imageMogr2/auto-orient/strip|imageView2/2/w/676/format/webp)]

    然后继续执行将192,168.0.0汇总

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-34RZbWJ2-1618391984032)(//upload-images.jianshu.io/upload_images/14535918-abd9c4e0bada9caa.png?imageMogr2/auto-orient/strip|imageView2/2/w/675/format/webp)]

    可以看到,汇总之后五类lSA明显减少了,

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-EB9UqqaT-1618391984034)(//upload-images.jianshu.io/upload_images/14535918-042f2adec83f25a0.png?imageMogr2/auto-orient/strip|imageView2/2/w/658/format/webp)]

    ####特性二

    2、汇总路由的开销类型继承明细路由的开销类型,如果明细路由的开销类型不一致,则开销类型为2(默认的类型)
    查看路由信息
    使用以下命令

    dis ospf lsdb ase
    
    

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-z9Z9Eqlj-1618391984035)(//upload-images.jianshu.io/upload_images/14535918-8e7217ad72c4c96d.png?imageMogr2/auto-orient/strip|imageView2/2/w/655/format/webp)]

    默认开销为2
    我们静态路由引入的时候类型为2,现在修改为1,
    使用

    import-route static type 1
    
    

    在R2使用命令查看

    dis ospf lsdb ase
    
    

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-hdGbva6k-1618391984037)(//upload-images.jianshu.io/upload_images/14535918-2d46baa427481fbd.png?imageMogr2/auto-orient/strip|imageView2/2/w/615/format/webp)]

    现在我们在R1创建一个环回口10
    创建一条路由
    [R1-LoopBack10]ip add 192.168.100.1 24
    然后做一个前缀列表
    [R1]ip ip-prefix 1 permit 192.168.100.0 24
    [R1]route-policy dire permit node 10
    [R1-route-policy]if-match ip-prefix 1
    [R1-ospf-1]import-route direct route-policy dire type 2
    引入一条直连前缀列表路由,引入ospf,类型为2

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-SiIay8xy-1618391984038)(//upload-images.jianshu.io/upload_images/14535918-5c007f4f85530884.png?imageMogr2/auto-orient/strip|imageView2/2/w/613/format/webp)]

    可以看到验证结果:
    ps:汇总路由的开销类型继承明细路由的开销类型,如果明细路由的开销类型不一致,则开销类型为2(默认的类型)

    特性三

    因为NSSA区域的ABR可以进行7转5操作,NSSA区域的外部路由可以在ASBR上 执行,也可以在NSSA区域上的ABR执行,

    我们可以做个实验
    在R4上继续引入一条静态路由,取消R3上的ospf引入静态路由配置,并设置为NSSA区域

    [R4]ip route-static 182.1.5.0 255.255.255.0 null 0
    [R4-ospf-1-area-0.0.0.2]nssa
    
    

    R3

    [R3-ospf-1]undo import-route static 
    [R3-ospf-1-area-0.0.0.2]nssa
    
    

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-a8o51nuV-1618391984040)(//upload-images.jianshu.io/upload_images/14535918-70b9c27c0aae51eb.png?imageMogr2/auto-orient/strip|imageView2/2/w/676/format/webp)]

    执行命令

          [R4-ospf-1]asbr-summary 182.1.0.0 255.255.0.0 
    
    

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-CTAaLfWe-1618391984046)(//upload-images.jianshu.io/upload_images/14535918-2ea0af810a651372.png?imageMogr2/auto-orient/strip|imageView2/2/w/642/format/webp)]

    这时候R3就会用这个汇总的七类做一个7转5

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-XmyY5hxO-1618391984050)(//upload-images.jianshu.io/upload_images/14535918-fc90f5e9cd505635.png?imageMogr2/auto-orient/strip|imageView2/2/w/666/format/webp)]

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-7yJuVQqc-1618391984051)(//upload-images.jianshu.io/upload_images/14535918-370aac15831631a3.png?imageMogr2/auto-orient/strip|imageView2/2/w/676/format/webp)]

    我们看到还有同网段的182.1.6/5 这是为什么呢?
    这些其实是还没有老化的路由过一段时间就会消失。
    上边我们实验了在ASBR上做汇总的结果,现在我们实验在ABR上进行汇总,现在将ASBR上的汇总命令进行删除

    [R4-ospf-1]undo asbr-summary 182.1.0.0 255.255.0.0
    
    

    接下来我们在R3上进行汇总路由的配置

    [R3-ospf-1]asbr-summary 182.1.0.0 255.255.0.0
    
    

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-Mm7Noe6G-1618391984053)(//upload-images.jianshu.io/upload_images/14535918-84578dc2c020237d.png?imageMogr2/auto-orient/strip|imageView2/2/w/676/format/webp)]

    展开全文
  • 华为 OSPF特殊区域

    千次阅读 多人点赞 2020-06-01 10:46:02
    (静 稳 忙 忍)!我个人理解为以下意思: 静:静的一半需要“争”;稳:稳的一半需要“急”,这里的急是指行动上;忙:忙的一半是不能急躁,做事要脚踏...一、概括 二、拓扑 三、配置与分析 四、总结 五、OSPF特殊区域
  • 华为OSPF总结

    2018-07-16 10:24:35
    OSPF把自治系统划分成逻辑意义上的一个或多个区域,所有其他区域必须与区域0相连。 OSPF把自治系统划分成逻辑意义上的一个或多个区域,所有其他区域必须与区域0相连。
  • OSPF路由过滤方式总结

    2021-05-05 15:35:54
    过滤方式 可以调用的方式 注意点 用途 ... 用来控制进入全局路由表的... 命令对接收的路由设置过滤策略,只有通过过滤的路由才被添加到路由表中并被发布,没有通过过滤的路由既不...
  • 配置OSPF区域认证的方法:
  • OSPF路由汇总的配置实例实验

    千次阅读 2012-07-12 15:00:56
     C汇总前验证OSPF路由协议  D配置OSPF路由协议的汇总  E汇总后验证OSPF路由协议  F验证OSPF路由协议的汇总  本人个人经验所写,有误的话请愿谅。  A 配置基本IP地址  A:A>  A>enable  A#...
  • OSPF路由过滤、汇总和默认路由

    千次阅读 2020-05-18 09:00:20
    OSPF路由过滤、汇总和默认路由 1、路由过滤 1类LSA和2类LSA不能进行过滤,因为链路状态逻辑要求区域内的所有路由器维持完全相同的LSDB;否则会导致SPF无法正常工作和计算出的路由出错。 因此OSPF只有一下过滤方法:...
  • 华为OSPF基础命令汇总

    2021-10-07 12:02:22
    其他协议视图上:import-route ospf 1 cost "number" // 路由的重分布 默认default-route-advertise always //宣告默认路由 area区域视图上:vlink peer router id //建立OSPF虚拟链路 接口视图上:ospf dr-...
  • 一、 RIP配置为RIPv2,rip路由重分发,rip路由汇总 二、 Ospf多区域,路由重分发,ospf身份认证 三、 R2配置单臂路由 四、 开启所有路由器的Telnet远程 五、 桥接PC访问全网和远程路由器 实验过程 一、 R1、R2...
  • OSPF的区域间防环规则及路由汇总
  • OSPF 路由汇总

    2017-08-02 12:30:00
    1. 关于路由汇总 路由汇总,又被称为路由聚合(Route Aggregation or RouteSummarization),指的是把一组路由汇聚成一条路由条目的操作。这组路由被称为明细路由,而所汇聚成的路由被称为汇总路由。路由汇总是...
  • **与静态路由相比:OSPF依靠报文传输路由信息,保密性差,而且传输报文会占用线路带宽。但静态路由配置繁琐且容易出错,不适用大型网络。当网络的拓扑结构和链路状态发生变化时,路由器中路由信息需要大范围地调整。...
  • 华为OSPF详解、总结

    千次阅读 2020-07-24 22:58:12
    OSPF:开放式最短路径优先协议 目录 OSPF:开放式最短路径优先协议 一、数据包—5种基本数据包 ...OSPF 路由控制: 特点: 无类别链路状态路由协议—组播更新协议:224.0.0.5/6 触发更新、周期更...
  • 华为实验之OSPF协议

    千次阅读 多人点赞 2019-04-03 11:05:01
    华为实验之OSPF协议 实验目的 掌握单区域 OSPF 的配置方法 掌握 OSPF 区域认证的配置方法 修 改 OSPF 的 Loopback 的 32 位主机路由 掌握对 OSPF 接口代价值进行修改的方法 掌握 OSPF 中 Silent-interface 的配置...
  • 配置OSPF引入缺省路由4.配置OSPF stub区域5.配置OSPF接口开销cost,实现OSPF选路优化6.配置OSPF网络类型,加快OSPF收敛速度7.配置网络边界ASBR,实现外网连8.配置OSPF被动接口,加强安全性9.配置OSPF验证,加强安全...
  • 2. OSPF协议原理 3. OSPF报文类型 3.1 Hello报文 3.2 DD报文 3.3 LSR报文 3.4 LSU报文 3.5 LSA报文 4. OSPF邻居状态机 5. OSPF工作流程 5.1 建立邻居关系 5.2 建立邻接关系 5.3 建立邻居的条件 6. 网络...
  • OSPF路由协议 在同一个OSPF自制系统内每一台运行OSPF协议的路由器总是将本地网络的连接状态用LSA(链路状态通告)描述,并广播到整个自制系统中去。这样,每台路由器都收到了自制系统中所有路由器生成的LSA,这些...
  • 华为 BGP路由聚合

    千次阅读 多人点赞 2020-07-01 11:03:17
    业精于勤,荒于嬉;行成于思,毁于随。 文章目录BGP路由聚合的作用和聚合的方式拓扑基础配置策略与观察TS排错 BGP的聚合相对其他协议的聚合差异较大,且重要性较高,关于手动聚合...1、AS-200运行OSPF协议属于区域0 2.
  • 使用华为ENSP模拟器验证OSPF ABR路由聚合,附上幕布笔记链接 https://share.mubu.com/doc/tXlkiNt1Hn
  • 华为ospf与思科ospf对比

    千次阅读 2019-06-08 16:42:55
    1.ospf对比:1)华为ospf基本配置:系统试图:设置router-id:router id 路由器id系统试图:进入ospf配置试图:ospf进入区域配置试图:area 区域编号将接口网段加入ospf:network 网段 反码返回用户试图:return2...
  • 华为路由RIP OSPF相互引入路由

    千次阅读 2017-11-27 17:33:00
    掌握从OSPF向RIP注入路由的方法 掌握从RIP向OSPF注入路由的方法 拓扑图: 场景 你是公司的网络管理员。当前公司网络使用了RIPv2和OSPF协议。为了实现RIP区域设备与OSPF区域设备之间的互通。你需要配置路由的...
  • 1.ospf双进程重发布 重发布前R1路由表 [r3-ospf-101]import-route ospf 100 [r3-ospf-101]ospf 100 [r3-ospf-100]import-route ospf 101 重发布后R1路由表 2. virtual link —虚链路 配置前R1路由表 穿越区域1上...
  • 路由汇总,又被称为路由聚合(Route Aggregation or RouteSummarization),指的是把一组路由汇聚成一条路由条目的操作。这组路由被称为明细路由,而所汇聚成的路由被称为汇总路由。路由汇总是一种重要的思想,在...
  • 对于从其他协议(例EIGRP)重分发到OSPF...在ASBR中,可对5类LSA(重分发而来的的路由)进行汇总,然后将其注入OSPF域中。 R1配置: interface Loopback1 ip address 1.1.1.1 255.255.255.255 ! interfa...
  • 华为OSPF详解及配置

    万次阅读 多人点赞 2020-04-15 02:13:23
    OSPF:开放式最短路径优先协议 目录 OSPF:开放式最短路径优先协议 一、数据包—5种基本数据包 二、OSPF的状态机 三、OSPF的工作过程 四、区域划分规则: 五、数据包 六、各类LSA: 七.OSPF 邻居状态机制 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,354
精华内容 541
关键字:

华为ospf路由汇总