精华内容
下载资源
问答
  • 思科Cisco)系列路由器上,show ip route 这个命令是一个非常常用并且十分重要的命令。里面可以查看该设备的当前直连的或者学习到的全部路由信息,即路由表:routing table。 R2#show ip route ? WORD Network ...

    路由表的介绍

    在思科(Cisco)系列路由器上,show ip route 这个命令是一个非常常用并且十分重要的命令。里面可以查看该设备的当前直连的或者学习到的全部路由信息,即路由表:routing table。

    R2#show ip route ?
      WORD       Network to display information about or hostname   #显示有关或主机名的信息的网络
      bgp        Border Gateway Protocol (BGP)                      #BGP协议是用于自治系统AS之间的动态路由协议
      connected  Connected   #直连
      eigrp      Enhanced Interior Routing Protocol (EIGRP)   #EIGRP协议是一种综合的路由选择协议
      ospf       Open Shortest Path First (OSPF)              #OSPF是一种链路状态型路由选择协议
      rip        Routing Information Protocol (RIP)           #RIP动态路由选择协议
      static     Static routes         #静态路由
      summary    Summary of all routes #所有路线汇总
      |          Output Modifiers
    

    若需使用该命令,你应当通过命令行进入路由器的执行模式(EXEC mode),其输出结果会按行列出:具体的路由条目,路由类型,管理距离(administrative distance),相邻路由器地址,获得该路由信息的物理端口名等信息。Show ip route可以简化为:sh ip ro,在进行路由配置、排错时,它是一个非常重要、实用的必备工具。

    路由表的查看

    show ip route
    
    R2#show ip route      #查看路由器
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         1.0.0.0/32 is subnetted, 1 subnets
    O       1.1.1.1/32 [110/2] via 10.0.0.1, 01:17:10, GigabitEthernet0/0
         2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       2.2.2.0/24 is directly connected, Loopback0
    L       2.2.2.2/32 is directly connected, Loopback0
         3.0.0.0/32 is subnetted, 1 subnets
    O IA    3.3.3.3/32 [110/2] via 20.0.0.2, 01:21:53, GigabitEthernet0/1
         10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       10.0.0.0/24 is directly connected, GigabitEthernet0/0
    L       10.0.0.2/32 is directly connected, GigabitEthernet0/0
         20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       20.0.0.0/24 is directly connected, GigabitEthernet0/1
    L       20.0.0.1/32 is directly connected, GigabitEthernet0/1
    O IA 192.168.10.0/24 [110/2] via 10.0.0.1, 01:16:39, GigabitEthernet0/0
    O IA 192.168.20.0/24 [110/2] via 20.0.0.2, 01:21:53, GigabitEthernet0/1
    

    在show ip route命令的输出中,会列出关于路由类型的简写代码,包括:I, R, O, C, S, E, B, i等。它们的含义分别为:

    • I,指从内部网关协议(IGRP)中学到的路由。
    • R,从RIP协议中学到的路由。
    • O,从OSPF(开放式最短路径优先)协议学到。
    • C,直连路由。
    • S,静态配置的路由,请注意,静态路由的管理距离为 0。
    • E,从外部网关协议(EGP)学到的路由。
    • B,指从BGP协议、
    • I,指IS-IS协议学到的路由信息。

    C直接相连connected

    C       10.0.0.0/24 is directly connected, GigabitEthernet0/0
    

    C是connected直接相连的意思,10.0.0.0/24是直连的网段,24是255.255.255.0的缩写,要转发数据包到10.0.0.0/24网段,通过GigabitEthernet0/0接口转发。

    R2#show ip route connected    #仅查看路由表中的直连
     C   2.2.2.0/24  is directly connected, Loopback0
     C   10.0.0.0/24  is directly connected, GigabitEthernet0/0
     C   20.0.0.0/24  is directly connected, GigabitEthernet0/1
    

    R - RIP协议

    R 192.168.3.0/24 [120/1] via 192.168.65.2, 00:00:04, Serial2/0
    

    这条例子中没有。

    • R是RIP协议,通过动态路由协议RIP学到的路由,
    • 192.168.3.0/24就是学到的路由
    • [120/1]即[管理距离/度量值(此数为路由跳数)],是度量值和管理距离,也就是优先级的意思。
    • via 192.168.65.2 via 有“经由”的意思,一般路由表中理解为“下一跳” ,指下一跳的接口IP地址为192.168.65.2,就是你要发送数据包到下个路由器的接口,从Seria2/0口转发。

    S-静态路由

    show ip route static
    
    展开全文
  • ip route 命令将三台路由器相接的两台电脑连通   实验工具: Cisco Packet Tracer 6.0   使用设备:   1841 路由器 三台(路由器1 、 路由器2 、 路由器3 )   PC-PT 电脑 2 台(电脑 1...

    实验内容:通过ip route命令将三台路由器相接的两台电脑连通

     

    实验工具:Cisco Packet Tracer 6.0

     

    使用设备:

     

    1841路由器三台(路由器1路由器2路由器3

     

    PC-PT电脑2台(电脑1、电脑2

     


    连接图:通过交叉线将路由器、电脑互连

     

    将电脑1Fa端口与路由器1Fa0/0端口相连

    将路由器1Fa0/1端口与路由器2Fa0/0端口相连

    将路由器2的Fa0/1端口与路由器3Fa0/0端口相连

    将路由器3的Fa0/1端口与电脑2Fa端口相连

     

    实验目的:


    电脑1与电脑2互通

     

    实验步骤:

     

    1.首先,进入电脑1的【桌面】界面,添加IP地址、子网掩码和网关

     

    2.点击电脑2进入【桌面】界面,添加IP地址、子网掩码和网关

     

    3.进入路由器1的【命令行】界面,开启并设置端口IP

    首先,他会询问是否对路由器进行对话框配置,我们回答no即可跳过

     

    然后再按一下回车,即可输入命令

     

    正确命令如下:

    Router>enable

    Router#configure terminal

    Router(config)#interface FastEthernet0/0

    Router(config-if)#no shutdown

    Router(config-if)#ip address 192.168.0.1 255.255.255.0

    Router(config)#interface FastEthernet0/1

    Router(config-if)#no shutdown

    Router(config-if)#ip address 192.168.1.1 255.255.255.0

     

     

    4.进入路由器2的【命令行】界面,开启并设置端口IP

    正确命令如下:

    Router>enable

    Router#configure terminal

    Router(config)#interface FastEthernet0/0

    Router(config-if)#no shutdown

    Router(config-if)#ip address 192.168.1.2 255.255.255.0

    Router(config)#interface FastEthernet0/1

    Router(config-if)#no shutdown

    Router(config-if)#ip address 192.168.2.1 255.255.255.0

     

     

     

    5.进入路由器3的【命令行】界面,开启并设置端口IP

    正确命令如下:

    Router>enable

    Router#configure terminal

    Router(config)#interface FastEthernet0/0

    Router(config-if)#no shutdown

    Router(config-if)#ip address 192.168.2.2 255.255.255.0

    Router(config)#interface FastEthernet0/1

    Router(config-if)#no shutdown

    Router(config-if)#ip address 192.168.3.1 255.255.255.0

     

    6.此时,拓扑上的各个连接点应该都是绿的

     

    7.然后,我们再进入路由器1的【命令行】,输入以下命令:

    Router(config-if)#exit

    Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.2

    Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2

     

    8.进入路由器2的【命令行】,输入以下命令:

    Router(config-if)#exit

    Router(config)#ip route 192.168.0.0 255.255.255.0 192.168.1.1

    Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2

     

    9.进入路由器3的【命令行】,输入以下命令:

    Router(config-if)#exit

    Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1

    Router(config)#ip route 192.168.0.0 255.255.255.0 192.168.1.1

     

    10.然后,我们进入电脑1的命令提示符界面,ping一下另一台电脑的IP

     

    Ping通,说明两台电脑成功连接,如果没有ping通,可能因为路由器反应较慢,等一会再试,若依旧没成功,请检查命令行IP地址是否输入正确,端口是否设置正确。

    展开全文
  • 通过ip-route命令将两台路由相连的两台电脑互通 1.打开Cisco Packet Tracer 2.放置两个2811路由器 3.点击路由器route0 (可以发现电源是开启状态) (现在点击电源关闭) (将NM-4A/S拖到下图所示位置) (打开电源,...

    思科仿真模拟实验1

    通过ip-route命令将两台路由相连的两台电脑互通

    1.打开Cisco Packet Tracer

    2.放置两个2811路由器
    在这里插入图片描述
    3.点击路由器route0
    (可以发现电源是开启状态)
    在这里插入图片描述
    (现在点击电源关闭)
    在这里插入图片描述
    (将NM-4A/S拖到下图所示位置)
    在这里插入图片描述
    (打开电源,关闭窗口)
    在这里插入图片描述
    (Route1的设置与上述一样)

    4.用时钟连线将两个路由器相连,接口如图所示
    在这里插入图片描述
    (拖拽两个PC到界面)
    在这里插入图片描述
    (将线路连接起来,线条、端口如图所示)
    在这里插入图片描述

    5.为每一个点备注ip,方便后续设置
    在这里插入图片描述

    6.为PC配置ip
    Desktop > >>ip congiguration
    pc0:
    在这里插入图片描述
    pc1:
    在这里插入图片描述

    7. 打开 route0 命令行窗口.!
    在这里插入图片描述

    为 route0 的 serial1/0 配置ip
    Router>en
    Router#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#interface serial1/0
    Router(config-if)#ip address 192.168.2.1 255.255.255.0**
    在这里插入图片描述
    为 route1 的 serial1/1 配置ip
    Router>en
    Router#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#interface serial1/1
    Router(config-if)#ip address 192.168.2.2 255.255.255.0
    在这里插入图片描述
    为 route0 的 fastethernet0/0 配置ip
    Router(config)#interface f0/0
    Router(config-if)#ip address 192.168.1.1 255.255.255.0
    在这里插入图片描述
    为 route1 的 fastethernet0/0 配置ip
    Router(config)#interface f0/0
    Router(config-if)#ip address 192.168.3.1 255.255.255.0
    在这里插入图片描述
    为route0配置路由表
    Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2
    在这里插入图片描述
    为route1配置路由表
    Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
    在这里插入图片描述
    打开route0和route1 的端口
    (以下为route0的操作,route1类似)
    在这里插入图片描述
    在这里插入图片描述
    可以看到,线路原来的红点全部变绿
    在这里插入图片描述
    8.设置端口serial1/0的时钟频率
    点击 route0 ,进入命令行
    Router(config-if)#interface serial1/0
    Router(config-if)#clock rate 64000
    显示“%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up”表示设置成功
    在这里插入图片描述
    9.点击PC0进入命令窗口

    在这里插入图片描述
    输入“ping 192.168.3.2”,检查是否可以ping通
    在这里插入图片描述
    在这里插入图片描述

    已ping通,说明两台电脑已连接
    如果没有ping通,请检查命令行IP地址是否输入正确,端口是否设置正确。

    展开全文
  • 公司希望汇聚层Switch上送到核心层设备的报文中,源IP地址为192.168.100.0/24的报文通过高速链路传输,而源IP地址为192.168.101.0/24的报文则通过低速链路传输。 配置思路 采用重定向方式实现策略路

    如图所示,汇聚层Switch做三层转发设备,接入层设备LSW做用户网关,接入层LSW和汇聚层Switch之间路由可达。汇聚层Switch通过两条链路连接到两个核心路由器上,一条是高速链路,网关为10.1.20.1/24;另外一条是低速链路,网关为10.1.30.1/24。

    公司希望汇聚层Switch上送到核心层设备的报文中,源IP地址为192.168.100.0/24的报文通过高速链路传输,而源IP地址为192.168.101.0/24的报文则通过低速链路传输。

    配置思路

    采用重定向方式实现策略路由,进而提供差分服务,具体配置思路如下:

    1. 创建VLAN并配置各接口,实现公司和外部网络设备互连。
    2. 配置ACL规则,分别匹配源IP地址为192.168.100.0/24和192.168.101.0/24的报文。
    3. 配置流分类,匹配规则为上述ACL规则,使设备可以对报文进行区分。
    4. 配置流行为,使满足不同规则的报文分别被重定向到10.1.20.1/24和10.1.30.1/24。
    5. 配置流策略,绑定上述流分类和流行为,并应用到接口GE0/0/3的入方向上,实现策略路由。

    操作步骤

    1. 创建VLAN并配置各接口

       

      # 在Switch上创建VLAN100和VLAN200。

      <HUAWEI> system-view
      [HUAWEI] sysname Switch
      [Switch] vlan batch 100 200

      # 配置Switch上接口GE0/0/1、GE0/0/2和GE0/0/3的接口类型为Trunk,并加入VLAN100和VLAN200。

      [Switch] interface gigabitethernet 0/0/1
      [Switch-GigabitEthernet0/0/1] port link-type trunk
      [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 200
      [Switch-GigabitEthernet0/0/1] quit
      [Switch] interface gigabitethernet 0/0/2
      [Switch-GigabitEthernet0/0/2] port link-type trunk
      [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 200
      [Switch-GigabitEthernet0/0/2] quit
      [Switch] interface gigabitethernet 0/0/3
      [Switch-GigabitEthernet0/0/3] port link-type trunk
      [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 200
      [Switch-GigabitEthernet0/0/3] quit

      # 创建VLANIF100和VLANIF200,并配置各虚拟接口IP地址。

      [Switch] interface vlanif 100
      [Switch-Vlanif100] ip address 10.1.20.2 24
      [Switch-Vlanif100] quit
      [Switch] interface vlanif 200
      [Switch-Vlanif200] ip address 10.1.30.2 24
      [Switch-Vlanif200] quit

       

    2. 配置ACL规则

       

      # 在Switch上创建编码为3001、3002的高级ACL,规则分别为允许源IP地址为192.168.100.0/24和192.168.101.0/24的报文通过。

      [Switch] acl 3001
      [Switch-acl-adv-3001] rule permit ip source 192.168.100.0 0.0.0.255
      [Switch-acl-adv-3001] quit
      [Switch] acl 3002
      [Switch-acl-adv-3002] rule permit ip source 192.168.101.0 0.0.0.255
      [Switch-acl-adv-3002] quit

       

    3. 配置流分类

       

      在Switch上创建流分类c1、c2,匹配规则分别为ACL 3001和ACL 3002。

      [Switch] traffic classifier c1 operator or
      [Switch-classifier-c1] if-match acl 3001
      [Switch-classifier-c1] quit
      [Switch] traffic classifier c2 operator or
      [Switch-classifier-c2] if-match acl 3002
      [Switch-classifier-c2] quit

       

    4. 配置流行为

       

      # 在Switch上创建流行为b1、b2,并分别指定重定向到10.1.20.1/24和10.1.30.1/24的动作。

      [Switch] traffic behavior b1
      [Switch-behavior-b1] redirect ip-nexthop 10.1.20.1
      [Switch-behavior-b1] quit
      [Switch] traffic behavior b2
      [Switch-behavior-b2] redirect ip-nexthop 10.1.30.1
      [Switch-behavior-b2] quit

       

    5. 配置流策略并应用到接口上

       

      # 在Switch上创建流策略p1,将流分类和对应的流行为进行绑定。

      [Switch] traffic policy p1
      [Switch-trafficpolicy-p1] classifier c1 behavior b1
      [Switch-trafficpolicy-p1] classifier c2 behavior b2
      [Switch-trafficpolicy-p1] quit

      # 将流策略p1应用到接口GE0/0/3的入方向上。

      [Switch] interface gigabitethernet 0/0/3
      [Switch-GigabitEthernet0/0/3] traffic-policy p1 inbound
      [Switch-GigabitEthernet0/0/3] return

       

    6. 验证配置结果

       

      # 查看ACL规则的配置信息。

      <Switch> display acl 3001
      Advanced ACL 3001, 1 rule
      Acl's step is 5
       rule 5 permit ip source 192.168.100.0 0.0.0.255
      <Switch> display acl 3002
      Advanced ACL 3002, 1 rule
      Acl's step is 5
       rule 5 permit ip source 192.168.101.0 0.0.0.255

      # 查看流分类的配置信息。

      <Switch> display traffic classifier user-defined
        User Defined Classifier Information:
          Classifier: c2
           Operator: OR
           Rule(s) :if-match acl 3002
              
          Classifier: c1
            Operator: OR
            Rule(s) : if-match acl 3001
      
      Total classifier number is 2   
      

      # 查看流策略的配置信息。

      <Switch> display traffic policy user-defined p1
        User Defined Traffic Policy Information:
        Policy: p1
         Classifier: c1
          Operator: OR
           Behavior: b1
            Redirect: no forced
              Redirect ip-nexthop
              10.1.20.1
         Classifier: c2
          Operator: OR
           Behavior: b2
            Redirect: no forced
              Redirect ip-nexthop
              10.1.30.1

    笔记记录:这个方法类似思科route-map队列匹配的方式,可将相同源地址访问不同目的的时候做策略路由控制路径,很实用。

    展开全文
  • wan1:218.85.224.100wan2:219.85.224.200内网 : 192.168.201.x 和192.168.202.x走wan1192.168.203.x走wan2其他网段随机wan1和wan2一、 思科路由器: interface GigabitEthernet0/1ip address 219.85.224.200 255....
  • 实验配置思路1:按照拓扑图所示配置IP地址示例:R1(config)#interface gigabitEthernet 0/2R1(config-if)#ip address192.168.1.2 255.255.255.0R1(config-if)#noshutdown(思科路由器默认关闭需手动开启)2:明...
  • IP INPUT负荷高的原因: 未在端口上打开快速转发选项; 解决方法:在端口上面打开快速转发,如CEF 当同一个端口主IP和... 解决方法:端口上面打开:ip route-cache same-interface 可能的原因: 有大量未缓存...
  • IP INPUT负荷高的原因 未在端口上打开快速转发选项; ...解决方法:在端口上面打开快速转发,如CEF ... 当同一个端口主IP和辅助... 解决方法:端口上面打开:ip route-cache same-interface 有大量未能利...
  • wan1:218.85.224.100wan2:219.85.224.200内网 : 192.168.201.x 和192.168.202.x走wan1192.168.203.x走wan2其他网段随机wan1和wan2一、 思科路由器:interface GigabitEthernet0/1ip address 219.85.224.200 255....
  • 思科 VACL

    2019-08-24 21:12:04
    SW .254 R2 R3 R4 R5 vlan20 192.168.20.1 R2: int e0/0 ip add 192.168.20.1 255.255.255.0 no sh ip route 0.0.0.0 0.0.0.0 192.168.20.254 SW: vlan 20,30,40,50...

空空如也

空空如也

1 2 3 4 5 ... 7
收藏数 140
精华内容 56
关键字:

route思科ip