精华内容
下载资源
问答
  • 利用三层交换机实现rip动态路由配置。有详细的拓扑图和命令
  • 根据要求,进行连通。 第一步:画好拓补图 第二步:配置PC机: 第三步:配置环回地址: ...如: R1中e0/0/0接口,配置192.168.30.1的IP,e0/0/1接口,配置10.0.1.1的IP,子网掩码均为24位 第五步:路.

    在这里插入图片描述
    根据要求,进行连通。
    第一步:画好拓补图
    在这里插入图片描述
    第二步:配置PC机:
    在这里插入图片描述
    在这里插入图片描述

    第三步:配置环回地址:
    R1:int loopback 1
    ip add 172.16.40.2 24
    R2:int loopback 2
    ip add 192.168.10.2 24

    第四步:配置各个接口的IP
    注意:路由器靠近主机端的接口,配置与主机同一网段的IP,远离的配置指定网段的IP
    如: R1中e0/0/0接口,配置192.168.30.1的IP,e0/0/1接口,配置10.0.1.1的IP,子网掩码均为24位

    第五步:路由器配置rip
    R1:rip 1
    version 2
    undo summary
    network 10.0.0.0
    network 172.16.0.0
    network 192.168.30.0
    R2:rip 1
    undo summary
    network 10.0.0.0
    network 172.16.0.0
    network 192.168.10.0

    第六步:配置网关:请参照截图来比较
    在这里插入图片描述
    在这里插入图片描述

    个人总结:对于rip配置网关的问题,需要弄清楚的有三点,也是难点:
    1.网关问题:需要搞清楚,网关需要和PC机IP在同一网段,也就是取路由器与PC机接口直接相连的接口IP地址。这样保证了同一网段,可以连通
    2.rip问题:首先,rip要搞清楚,network后面的参数:
    也就是lo回环IP地址的主类网段,路由器两个接口所在的主类网段
    3.接口问题:要搞清楚接口到底是0/0/0还是0/0/1,配置的路由器是r1还是r2。因为自己的不细心,导致实验完成的时间几乎是正常的一倍不止,还需要改来改去。
    以上个人观点。在这里插入图片描述

    展开全文
  • 作者:最铁头的网工 (全球首批HCIA-DATACOM认证者) 认证技术:关于华为认证技术知识会在我...一、RIP路由汇总功能介绍 rip的路由汇总功能,能够对rip 学习/自己产生 的明细路由做汇总后传递给rip邻居,减少路由器...

    作者:最铁头的网工 (全球首批HCIA-DATACOM认证者)
    认证技术:关于华为认证技术知识会在我博客做持续更新。。。
    本期分享:系列15点到16点半-技术热讯
    感谢大家关注-最铁头的网工,请大家持续关注就可以了哦!关于进阶级手册在下方↓↓↓
    众元教育-华为HCIA-HCIE技术认证课:课程通道
    众元教育-华为HCIA-HCIE技术认证裙:696283186  
        

    一、RIP路由汇总功能介绍

       rip的路由汇总功能,能够对rip 学习/自己产生 的明细路由做汇总后传递给rip邻居,减少路由器的路由条目

    二、RIP应用场景:

     当RIP域内某台设备自己宣告或者重分布了大量的路由,或者学习到了上游设备传递过来的大量的路由,而这些路由条目又是连续的,可以汇总成几条子网掩码更大的路由条目的时候,就可以考虑在这台设备上做路由汇总,以便向下游传递的时候只通告这些汇总的路由,减少RIP域内的路由数量,节约设备资源。

     

    三、实验配置:

      1.拓扑图

     

    更多网工学习资料,获取认证相关学习内容,可以加q:696283186

      2.实验目的:

        通过rip协议学习到的明细路由,为了减少路由条目,对明细路由进行汇总

      3.配置思路:

         1)搭建好拓扑图环境,标出规划好的IP地址

         2)修改网络设备默认名称、配置好IP地址

         3)配置基本RIP

         4)在路由器AR1接口G4/0/0上配置路由汇总

      4.配置过程:

    步骤一:修改网络设备默认名称、配置好IP地址

     1)配置各PC信息 (略)

         2)配置路由器AR1默认名称及接口IP

    <Huawei>sys

    Enter system view, return user view with Ctrl+Z.

    [Huawei]sysname AR1

    [AR1]int g0/0/0

    [AR1-GigabitEthernet0/0/0]ip add 192.168.10.2 24

    [AR1-GigabitEthernet0/0/0]int g0/0/1

    [AR1-GigabitEthernet0/0/1]ip add 192.168.20.2 24

    [AR1-GigabitEthernet0/0/1]int g0/0/2

    [AR1-GigabitEthernet0/0/2]ip add 192.168.30.2 24

    [AR1-GigabitEthernet0/0/2]int g4/0/0

    [AR1-GigabitEthernet4/0/0]ip add 172.16.0.1 16

    3)配置路由器R2默认名称及接口IP

            <Huawei>sys

    Enter system view, return user view with Ctrl+Z.

    [Huawei]sysname AR2

    [AR2]int g0/0/0

    [AR2-GigabitEthernet0/0/0]ip add 172.16.0.2 16

    [AR2-GigabitEthernet0/0/0]int g0/0/1

    [AR2-GigabitEthernet0/0/1]ip add 192.168.40.2 24

    步骤二、配置基本RIP

    1)配置路由器AR1基本RIP

       R1(config)#router rip

    R1(config-router)#version 2

    R1(config-router)#no auto-summary    //关闭汇总功能

    R1(config-router)#network 172.16.0.0

    R1(config-router)#network 192.168.10.0

    R1(config-router)#network 192.168.20.0

    R1(config-router)#network 192.168.30.0

    2)配置路由器AR2基本RIP

     R2(config)#router rip

    R2(config-router)#version 2

    R2(config-router)#no auto-summary    //关闭汇总功能

    R2(config-router)#network 192.168.40.0

    R2(config-router)#network 172.16.0.0

    步骤三、在路由器AR1接口G4/0/0上配置路由汇总

    [AR1]int g4/0/0

    [AR1-GigabitEthernet4/0/0]rip summary-address 192.168.0.0 255.255.0.0    //将路由汇总成192.168.0.0/16

      注意:1)rip的路由汇总,可以在任何路由传递的out接口,对 自己产生或从邻居学习 的路由做汇总,不能做超网汇总。 如在该实验配置中,将汇总路由的命令配置在路由器AR1的接口G4/0/0上。

    2)在对rip做手工汇总前,必须先关闭自动汇总功能。rip默认会在主类网络边界做自动汇总,若有不连续网络,会导致路由学习异常,所以建议启用rip协议后,关闭自动汇总,采用手工汇总的方式

     

    五、配置验证:

        1、在本实验中,将左侧的3个不同网段汇总为192.168.0.0/16网段,若不做汇总路由在路由器AR2上的路由表里可以查看到3条明细路由,做了路由汇总后,在路由器AR2路由表中只能查看到一条汇总路由,如下图

     

       2、查看各主机通信情况:

     

     

    至此,RIP路由汇总实验完成,配置路由汇总后,各主机也可以正常通信,但减少了路由器的路由条目,即在对端路由器只会查看到一条汇总后的路由条目

    展开全文
  • 文章目录一、动态路由及RIP协议工作原理1.1 动态路由概述1.1.2 动态路由协议1.1.3 动态路由协议分类1.2 RIP路由协议工作原理1.2.1 RIP的基本概念1.2.2 路由表的形成1.2.3 RIP的度量值与更新时间1.2.4 水平分割1.2.5 ...

    一、动态路由及RIP协议工作原理

    1.1 动态路由概述

    ●动态路由
    基于某种路由协议实现
    ●动态路由特点
    优点:减少了管理任务
    缺点:占用了网络带宽

    1.1.2 动态路由协议

    ●动态路由协议概述
    路由器之间用来交换信息的语言
    ●度量值
    度量值是用来衡量路径优劣的参数
    •跳数:一个路由器就是一条,跳数越小越好。
    •带宽:用来标识信号传输的数据传输能力、标识单位时间内通过链路的数据量、标识显示器的显示能力。
    •负载:承载的传输数据量。
    •时延:指一个报文或分组从一个网络的一端传送到另一个端所需要的时间
    •可靠性:数据传输的稳定性和效率。
    •成本:带宽越高,路径成本越低。
    ●收敛
    使所有路由表都达到一致状态的过程
    ●静态路由与动态路由的比较
    网络中静态路由和动态路由互相补充

    1.1.3 动态路由协议分类

    按照路由执行的算法分类:
    ●距离矢量路由协议
    •依据从源网络到目标网络所经过的路由器的个数选择路由
    •RIP、IGRP
    ●链路状态路由协议
    •综合考虑从源网络到目标网络的各条路径的情况选择路由
    •OSPF , IS-IS

    1.2 RIP路由协议工作原理

    1.2.1 RIP的基本概念

    ●RIP是距离-矢量路由选择协议
    ●RIP的基本概念
    •定期更新(路由器每经过一段时间周期-30S后,向邻居发送更新信息)
    •邻居(与其相连的路由器)
    •广播更新(RIPv1 255.255.255.255)
    •组播更新(RIPv2 224.0.0.9)
    •泛洪路由表(路由器将从邻居学习到的路由放进自己的路由表中,然后将路由表所有的路由信息通告给其他路由器,直到整个网络学习到)

    1.2.2 路由表的形成

    路由器学习到直连路由
    更新周期30s到时,路由器环回向邻居发送路由表
    在这里插入图片描述

    1.2.3 RIP的度量值与更新时间

    ●RIP度量值为跳数:
    最大跳数15跳,16跳为不可达。
    ●RIP更新时间:
    每隔30s发送路由更新消息,UDP520端口
    ●RIP路由更新消息:
    发送整个路由表信息

    1.2.4 水平分割

    ●路由环路的形成:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    ●执行水平分割可以阻止路由环路的发生
    •从一个接口学习到路由信息,不再从这个接口发送出去。
    •同时也能减少路由更新信息占用的链路带宽资源
    在这里插入图片描述

    1.2.5 RIP配置和验证

    [R1]rip 1     ###1是进程号,范围为1~65535
    [R1-rip-1]version 2     ###2是版本号,还有一个版本1
    [R1-rip-1]network 1.0.0.0      ###宣告网络号
    [R1-rip-1]network 12.0.0.0
    

    1.2.6 ripv1和v2的区别

    在这里插入图片描述

    1.2.7 rip兼容模式

    ●兼容模式默认跑rip v1版本
    ●rip没有启动,路由表中只有一些直连路由,为了从邻居获取rip路由,会以广播或组播向邻居发动request请求报文
    ●邻居收到后,会发送response回复报文,报文中包括路由表的信息
    ●路由器收到response报文后,根据rip路由更新原则更新路由表
    ●以后没经过30秒,路由器都会发送response报文保持邻居关系

    二、动态路由协议实验

    2.1 实验目的

    三台路由连接,配置路由矢量协议rip,R1、R3分别配置为Version1、Version2,R2配置为兼容模式,抓包发现三台路由器无法互相学习,尝试通过更改R2、R3的g0/0/1达到全路由的收敛。配置完成后查看路由表,三台路由器是否相互学习,并观察路由表更新方式。

    2.2 实验环境

    在这里插入图片描述

    2.3 实验步骤

    2.3.1 配置R1

    在这里插入图片描述
    rip 1 ###启动RIP进程
    Version 1 ###宣告RIP版本号
    network 12.0.0.0 ###宣告主网络号
    network 1.0.0.0
    在这里插入图片描述

    2.3.2 配置R2

    在这里插入图片描述
    rip 1 ###启动RIP进程
    network 12.0.0.0 ###宣告主网络号
    network 23.0.0.0
    network 2.0.0.0
    在这里插入图片描述

    2.3.3 配置R3

    在这里插入图片描述
    rip 1 ###启动RIP进程
    version 2 ###宣告RIP版本号
    network 12.0.0.0 ###宣告主网络号
    network 1.0.0.0
    在这里插入图片描述

    2.4 验证测试

    进入系统视图模式输入
    dis ip routing-table
    查看路由表信息
    发现R1可以学习到R2和R3的信息
    在这里插入图片描述
    dis ip routing-table 查看路由表信息
    发现R2可以学习到R1和R3的信息
    在这里插入图片描述
    dis ip routing-table 查看路由表信息
    发现R3不能学习到R1和R2的信息
    因为R2发出去的信息是version 2
    在这里插入图片描述
    因为兼容模式收 rip V1 和 rip V2 路由信息,发只能是rip V1路由信息
    解决方法:
    第一种方法:
    进入R3的接口
    Int g0/0/1
    rip version 1
    在这里插入图片描述

    第二种方法:
    进入R2的接口
    Int g0/0/1
    rip version 2 multicast
    在这里插入图片描述
    再进入R3输dis ip routing-table
    就可以看到R3可以学习到R1R2的路由信息
    在这里插入图片描述
    在这里插入图片描述

    三、实验总结

    ●华为rip路由的模式
    V1,V2和兼容模式
    ●兼容模式概述
    兼容模式可以接受rip V1和rip V2的路由信息
    兼容模式只能发送rip V1的路由信息
    ●解决兼容模式不能接受V2路由信息的问题方法:
    第一种:

    在兼容模式的路由接口,配置将数据转化成V2
    interface g0/0/1
     rip version 2 multicast 
     RIP协议中,UDP最大支持25条路由条目
    

    第二种:

    在rip V2路由接口配置,将信息转化成V1
    interface g0/0/1
     rip version 1
    
    展开全文
  • 本文写了:RIP配置方法,工作原理,认证

    基础配置原理及认证

    RIP路由协议:内部网关路由协议,使用的是距离矢量算法
    距离矢量算法:简单的来说,到达目标地址如果有多条线路,就走经过路由器数量最少的线路

    rip协议工作原理:使路由器可以通过RIP协议动态的学习到路由条目,然后根据路由表转发数据

    下面用ENSP软件来模拟这个实验
    1.拿出三台路由器(以AR2220为例)按照我的拓扑搭建好
    在这里插入图片描述
    2.将设备改名,并配置好IP地址
    路由器R1:

    <Huawei>system-view 	//进入系统视图
    [Huawei]sysname R1      //将设备名称改为R1
    [R1-GigabitEthernet0/0/0]ip address 12.1.1.1 24    //配置IP地址 掩码 24

    路由器R2:

    <Huawei>system-view 
    [Huawei]sysname R2
    [R2-GigabitEthernet0/0/0]ip address 12.1.1.2 24
    [R2-GigabitEthernet0/0/0]quit  
    [R2]interface GigabitEthernet 0/0/1	
    [R2-GigabitEthernet0/0/1]ip address 23.1.1.2 24
    

    路哟器R3:

    <Huawei>system-view 	
    [Huawei]sysname R3
    [R3]interface GigabitEthernet 0/0/1	
    [R3-GigabitEthernet0/0/1]ip address 23.1.1.3 24
    

    配置完成后一定要测试直连的连通性:
    在R2路由器ping两端

    [R2]ping 12.1.1.1
    [R2]ping 23.1.1.3
    

    3.下面要配置RIP协议:
    路由器R1:

    [R1]rip 1                  //进入RIP进程 1 
    [R1-rip-1]version 2        //修改RIP版本为2 (华为缺省为1)1和2的区别在于认证,1不支持,2支持
    [R1-rip-1]undo summary     //关闭自动汇总
    [R1-rip-1]network 12.0.0.0 //宣告网段,注意这里宣告的是主类网段,A类地址掩码是8位。
    

    路由器R2:

    [R2]rip 1
    [R2-rip-1]version 2	
    [R2-rip-1]undo summary 	
    [R2-rip-1]network 12.0.0.0	 
    [R2-rip-1]network 23.0.0.0
    

    路由器R3:

    [R3]rip 1	
    [R3-rip-1]version 2
    [R3-rip-1]undo summ
    [R3-rip-1]network 23.0.0.0
    

    这里一定要注意:
    在宣告时,宣告的是自己接口IP地址的主类网段,如果两个设备之间运行的是RIP协议,设备两端就都要配置,你想让已经运行RIP协议的设备学习到那些网段,你就把那些网段宣告进RIP里

    4.检测配置是否正确:
    用R1路由器 ping R3路由器

    [R1]ping 23.1.1.3
    

    在这里插入图片描述
    如果上述配置全部正确是能通的,如果不通请仔细检查哦
    查看路由表:

    [R1]display ip routing-table  //查看路由表
    

    在这里插入图片描述
    这里有个重点:
    Cost : 开销,这个值是你R1路由器到目标网段,之间要经过几个路由器所产生的(有些人也把他理解为跳数)
    这个值是可以修改的,根据Cost去控制数据传输时线路的选择,具体配置请看我(华为:RIP动态路由协议,实现控制选路

    5.添加认证:
    路由器R1:

    [R1]interface GigabitEthernet 0/0/0     //进入接口
    [R1-GigabitEthernet0/0/0]rip authentication-mode simple plain huawei //启用接口认证密码为华为
    

    路由器R2:

    [R2]interface GigabitEthernet 0/0/0
    [R2-GigabitEthernet0/0/0]rip authentication-mode simple plain huawei  //启用接口认证密码为华为
    

    这里需要注意:
    如果在一条链路上开启了认证,链路两端就都要开启,否则这个链路是不能运行这个协议的。

    展开全文
  • 实验拓扑图如下: 提前配置好主机IP地址以及端口IP地址 R8配置: [R8]rip 1 #RIP进程号 [R8-rip-1]version 2 #使用RIP 2版本 [R8-rip-1]undo summary #关闭路由自动汇总 [R8-rip-1]network 192.168.1.0 # 宣告直连...
  • 实验序号:06 实验项目名称:实验6 RIPv2动态路由协议 学 号 姓 名 班 级 实验地点 信息学院网络实验室 指导教师 一、实验目的 通过实验理解并掌握在路由器上配置RIP V2; 二、实验要求 通过实验理解并掌握在...
  • 主要为大家介绍了给华为路由器eNSP配置rip OSPF 路由重发布的过程,不了解路由器rip OSPF 路由重发布的朋友可以和脚本之家的小编一起来学习一下
  • 华为设备--动态路由rip协议配置

    千次阅读 2020-06-21 21:40:01
    分别配置三台路由器:R1ripv1版本,R3ripv2版本,R2兼容模式,调整R2端口rip协议版本让三台路由器能互相学习路由表 二、实验环境 在华为ENSP中建立如图所示拓扑图 在R1中设置 [R1]interface g0/0/0 ##配置接口ip [R1...
  • 实验一:RIP动态路由协议实验

    千次阅读 2019-09-22 16:14:31
    实验报告一:RIP动态路由协议实验 实验拓扑: Requirment: 某网络整体结构如果所示,在Router1上有3个回环口,IP地址如图,Router3连接两台主机,现要求通过使用路由协议实现全网互联。 在各路由器上配置静态路由...
  • 文章目录华为模拟器--动态路由器+RIP路由协议配置及验证前言一、动态路由1.1动态路由协议基础1.1.1动态路由1.1.2动态路由特点1.2动态路由协议概述1.2.1度量值1.2.2收敛1.2.3静态路由与动态路由的比较1.3动态路由协议...
  • 华为ensp ospf动态路由配置实验

    千次阅读 多人点赞 2020-06-02 21:05:22
    华为ensp ospf动态路由配置实验 开放式最短路径优先OSPF(Open Shortest Path First)协议是IETF定义的一种基于链路状态的内部网关路由协议,采用OSFP协议的路由器均知道它所属于的区域内的所有接口和链路的状态...
  • 基于eNSP的华为设备--单臂路由配置,静态路由配置RIP动态路由配置,OSPF动态路由配置华为模拟器配置单臂路由功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何插入一段漂亮的代码...
  • 动态路由RIP配置 R1配置 R2配置 R3配置 P1和p2互ping
  • 动态路由协议-RIP原理与配置实验

    千次阅读 2020-06-01 17:33:40
    最简单的拓扑图解释RIP配置RIP协议特点,华为模拟器中详细的配置命令
  • 实验原理 是最早的距离矢量IP路由协议,也是最先得到广泛使用的一种路由协议,使用跳数来衡量网络间的距离,从一台路由器到直连网络的跳数定义为1,到非直连的距离没经过一台路由器...掌握测试rip路由网络连通性的方法
  • 使用华为的HW-RouteSim路由模拟器配置RIP计算机网络实验,教会你配置RIP动态路由
  • 华为RIP路由配置教程

    2020-10-01 14:45:22
    主要介绍了华为RIP路由配置教程,需要的朋友可以参考下
  • 华为ESDN下配置RIP路由聚合实验

    千次阅读 2018-12-05 13:31:33
    ②将AR1的三个回环地址聚合一条最优路由,并禁止AR1从接口G0/0/0学习到该聚合路由。 ③修改各个路由器RIP定时器,对网络进行优化。 ④在AR2和AR3路由器上配置报文认证,对网络安全进行加固。 3.操作步骤 ①配置...
  • 分类二、RIP路由协议工作原理1.基本原理2.路由环路 前言 前面我们学习了静态路由,在进行实验配置时,通过手动一个一个进行配置,久了感到非常麻烦,尤其在规模较大的网络配置里 而且一旦网络拓扑发生改变,这样...
  • [华为动态路由-RIP协议] RIP协议的介绍和配置

    千次阅读 多人点赞 2019-02-10 21:37:31
    0x0 RIP协议如何工作? 在路由器上开启RIP协议,并将路由器的直连网段宣告进RIP后,RIP会将这些直连网段信息封装成RIP协议报文,发送给...注:在动态路由中我们添加的网段都是直连网段 0x2 配置RIP 宣告 rip 100 ...
  • 华为HCNA之RIP路由协议基本配置实验

    千次阅读 2020-06-16 09:02:31
    RIP(Routing Information Protocol,路由信息协议)是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数...
  • 华为单臂路由配置

    2021-01-09 10:05:57
    [Huawei]sysname SW-1 //修改主机名 [SW-1]vlan batch 10 20 //创建vlan 10 20 [SW-1]interface e0/0/1 //进接口 [SW-1-Ethernet0/0/1]port link-type access //配置工作模式为access  [SW-1-Ethernet0/0/1]...
  • RIP路由基础配置 一、RIP路由功能介绍 RIP (Routing Information Protocol) 路由协议是一种相对古老,在小型以及同介质网络中得到了广泛应用的路由协议。RIP 采用距离向量算法,是一种距离向量协议。RIP分为 RIPv1...
  • 华为路由器配置RIP
  • 本文讲述:通过RIP协议的开销值,实现数据传输选路的方法。
  • 路由汇聚的“含义”是把一组路由汇聚为一个单个的路由广播。路由汇聚的最终结果和最明显的好处是缩小网络上的路由表的尺寸。 拓扑图: 步骤: 1.基本配置: 如拓扑图和下表所示,完成各个物理设备和接口的配置,并...
  • 华为模拟器eNSP动态路由协议RIP

    千次阅读 2021-01-12 18:41:43
    动态路由信息协议RIP配置RIP命令;测试路由器之间联通情况;Wireshark抓包分析e/0/0/0。
  • 实验原理 当路由条目很多的时候,可以使用路由汇总来减少路由条目,加快收敛和...基于RIP进程的有类自动汇总:比如对于10.1.1.0/24(metric=2)和10.1.2.0/24(metric=3)这两条路由,聚合成自然网段路由10.0.0.0/8
  • 动态路由实验一、RIP1.1实验拓扑图1.2配置命令1.3实验过程1.4实验结果二、OSPF2.1 实验拓扑图2.2 配置命令2.3实验过程2.4实验结果 一、RIP 1.1实验拓扑图 配置图如下,验证R1、R2、R3能否互相RIP进行发送和接收广播...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,164
精华内容 1,665
关键字:

华为rip动态路由配置实验