精华内容
下载资源
问答
  • 实验名称:华为设备stpvrrp的实力应用实验拓扑:实验目的:1.熟练地应用stpvrrp的应用及配置 2.了解环路以及解决方案 3.使全网互通实验思路:首先把拓扑图分为三个部分 1.配置相同vlan相通,相同网段看交换,先...

    实验名称:华为设备stp 、vrrp的实力应用

    实验拓扑:

    1.png

    spacer.gif

    实验目的:1.熟练地应用stp、vrrp的应用及配置

              2.了解环路以及解决方案

              3.使全网互通

    实验思路:首先把拓扑图分为三个部分

              1.配置相同vlan相通,相同网段看交换,先配置交换机,左右两边各有三个交换机,所有会有环路,就要用到stp ,把sw2,3配置为根网桥,所有交换流量都要通过他俩:    配置命令:stp root primary

    其他两个交换机配置stp,实现负载均衡,以及备份链路

      [sw]stp region-configuration

    [sw-mst-region]region-name haha

        

    [sw-mst-region]instance 1 vlan 10 

    [sw-mst-region]instance 2 vlan 20     

    [sw-mst-region]active region-configuration

    [sw]stp instance 1 priority 4096

    [sw]stp instance 2 priority 8192

    交换机与交换机之间用trunk链接

    2. 在配置第二部分,不同网段用路由。

     三个路由器都要使用的情况下,要实现冗余,就用vrrp协议配置优先级

    配置命令:

    R1

    vrrp vrid 10 virtual-ip 192.168.10.250 创建虚拟网关

    vrrp vrid 10 priority 150    配置优先级为150,默认100

    vrrp vrid10 interface gi 0/0/2 reduce 100 

    配置链路跟踪,当interface gi0/0/2 端口为down时,优先级减100

     R2

    vrrp vrid 10 virtual-ip 192.168.10.250

    vrrp vrid 10 priority 100

    R3

    vrrp vrid 10 virtual-ip 192.168.10.250

    vrrp vrid 10 priority 80

    3.配置第三部分

     交换机端口开启

     R4 

    配置ip interface gi0/0/0   0/0/1

    配置步骤:

    设备ip网关子网掩码
    pc1192.168.10.1192.168.10.250255.255.255.0
    pc2192.168.20.1192.168.20.250255.255.255.0
    pc3192.168.10.2192.168.10.250255.255.255.0
    pc4192.168.20.2192.168.20.250255.255.255.0
    服务器192.168.30.1192.168.30.254255.255.255.0
    R1-0/0/0192.168.10.254
    255.255.255.0
    R1-0/0/1192.168.20.254
    255.255.255.0
    R1-0/0/2192.168.100.1
    255.255.255.0
    R1-虚拟ip192.168.10.250

    R1-虚拟ip192.168.20.250

    R2-0/0/0192.168.10.253
    255.255.255.0
    R2-0/0/1192.168.20.253
    255.255.255.0
    R2-0/0/2192.168.100.1
    255.255.255.0
    R2-虚拟ip192.168.10.250

    R2-虚拟ip192.168.20.250

    R3-0/0/0192.168.10.252
    255.255.255.0
    R3-0/0/1192.168.20.252
    255.255.255.0
    R3-0/0/2192.168.100.1
    255.255.255.0
    R3-虚拟ip192.168.10.250

    R3-虚拟ip192.168.20.250

    R4-0/0/0192.168.100.2
    255.255.255.0
    R4-0/0/1192.168.30.254
    255.255.255.0

    第一部分

    spacer.gif2.png

    sw4 

    interface gi0/0/1 :port link-tyde access   端口1加入vlan 10

                 port default vlan 10

    interface gi0/0/2 :port link-tyde trunk       设置为trunk链路

                 port trunk allow-pass vlan all

    interface gi0/0/3 :port link-tyde trunk        设置为trunk链路

                 port trunk allow-pass vlan all

     [sw4]stp region-configuration                  创建stp

    [sw4-mst-region]region-name haha                stp 名称为  haha  

    [sw4-mst-region]instance 1 vlan 10               vlan 10加入 1组

    [sw4-mst-region]instance 2 vlan 20               vlan 20加入 2组

    [sw4-mst-region]active region-configuration      开启配置

    [sw4]stp instance 1 priority 4096                 1组设置优先级为 4096    (stp优先级只能为为4096的倍数)

    [sw4]stp instance 2 priority 8192                2组设置优先级为 8192


    sw5

    interface gi0/0/1 :port link-tyde access           加入vlan 20

                 port default vlan 20

    interface gi0/0/2 :port link-tyde trunk             设置为trunk链路

                 port trunk allow-pass vlan all            

    interface gi0/0/3 :port link-tyde trunk              设置为trunk链路

                 port trunk allow-pass vlan all

     [sw5]stp region-configuration

    [sw5-mst-region]region-name haha                创建stp,以及名称 haha

    [sw5-mst-region]instance 1 vlan 10              vlan10 加入1组

    [sw5-mst-region]instance 2 vlan 20                vlan20 加入2组

    [sw5-mst-region]active region-configuration       开启配置

    [sw5]stp instance 1 priority 8192                  配置优先级 1组为8192

    [sw5]stp instance 2 priority 4096                   配置优先级 2组为 4096


    sw2 

    interface gi0/0/1 :port link-tyde trunk            配置为trunk链路

                 port trunk allow-pass vlan all

    interface gi0/0/2 :port link-tyde trunk            配置为trunk链路

                 port trunk allow-pass vlan all

    interface gi0/0/3 :port link-tyde access           加入vlan10

                 port default vlan 10

    interface gi0/0/4 :port link-tyde access            加入vlan10

                 port default vlan 10

    interface gi0/0/5 :port link-tyde access            加入vlan10

                 port default vlan 10

    interface gi0/0/6 :port link-tyde trunk             配置为trunk链路

                 port trunk allow-pass vlan all 

    sw2:stp root primary                                  设置为root 根交换机



    3.png

    spacer.gif

    sw6 

    interface gi0/0/1 :port link-tyde access             加入vlan10

                 port default vlan 10

    interface gi0/0/2 :port link-tyde trunk               配置为trunk链路

                 port trunk allow-pass vlan all 

    interface gi0/0/3 :port link-tyde trunk               配置为trunk链路

                 port trunk allow-pass vlan all

     [sw6]stp region-configuration                     创建stp 以及名称 haha

    [sw6-mst-region]region-name haha  

    [sw6-mst-region]instance 1 vlan 10                 vlan10加入 1组

    [sw6-mst-region]instance 2 vlan 20                   vlan20加入 2组

    [sw6-mst-region]active region-configuration          开启配置

    [sw6]stp instance 1 priority 4096                   配置优先级 组1 为4096

    [sw6]stp instance 2 priority 8192                              组2 为8192


    sw7

    interface gi0/0/1 :port link-tyde access              加入vlan 20

                 port default vlan 20

    interface gi0/0/2 :port link-tyde trunk              配置trunk链路

                 port trunk allow-pass vlan all

    interface gi0/0/3 :port link-tyde trunk              配置trunk链路

                 port trunk allow-pass vlan all

     [sw7]stp region-configuration                      创建stp 以及名称 haha

    [sw7-mst-region]region-name haha

        

    [sw7-mst-region]instance 1 vlan 10                    vlan10 加入1组

    [sw7-mst-region]instance 2 vlan 20                   vlan20加入2组

    [sw7-mst-region]active region-configuration         开启配置

    [sw7]stp instance 1 priority 8192                   配置优先级  1组8192

    [sw7]stp instance 2 priority 4096                               2组4096


    sw3

    interface gi0/0/1 :port link-tyde trunk              配置trunk链路

                 port trunk allow-pass vlan all

    interface gi0/0/2 :port link-tyde trunk              配置trunk链路

                 port trunk allow-pass vlan all

    interface gi0/0/3 :port link-tyde access             加入vlan20

                 port default vlan 20

    interface gi0/0/4 :port link-tyde access             加入vlan20

                 port default vlan 20

    interface gi0/0/5 :port link-tyde access              加入vlan20

                 port default vlan 20

    interface gi0/0/6 :port link-tyde trunk               配置trunk链路

                 port trunk allow-pass vlan all

    sw3:stp root primary                                 配置为root 根交换机

    验证:

     

    pc1 ping pc3

    spacer.gif

    pc2 ping pc4

    spacer.gif

    第二部分

    spacer.gifImage.png

    R1

       interface gi  0/0/0 :ip addess 192.168.10.254 255.255.255.0               配置ip

                         vrrp vrid 10 virtual-ip 192.168.10.250                      创建vrrp,虚拟ip (三个路由器都加入组vrrp vrid10 ,他们都是为虚拟ip服务

                         vrrp vrid 10 priority 150              优先级为150                                  当其中一个路由器坏了另外一个路由器就会启用)

           vrrp vrid 10 track interface GigabitEthernet0/0/2 reduced 100       配置跟踪链路,当0/0/2口为down时,优先级下降100,变为50

      interface gi  0/0/1 :ip addess 192.168.20.252 255.255.255.0

                                      vrrp vrid 20 virtual-ip 192.168.20.250                  创建vrrp vlan20的

                                      vrrp vrid 10 priority 80                                    优先级为80

       interface gi  0/0/2 :ip addess 192.168.100.1   255.255.255.0

    ospf 1 router-id 1.1.1.1                                                           配置路由协议ospf

     area 0.0.0.0

      network 192.168.10.0 0.0.0.255

      network 192.168.20.0 0.0.0.255                                          宣告网段

     area 0.0.0.30

      network 192.168.100.0 0.0.0.255


    R2

     interface gi  0/0/0 :ip addess 192.168.10.253 255.255.255.0             配置ip

                       vrrp vrid 10 virtual-ip 192.168.10.250                   创建vrrp,配置虚拟ip

                                     vrrp vrid 10 priority 100                         配置优先级

    vrrp vrid 10 track interface GigabitEthernet0/0/2 reduced 50            配置跟踪链路

       interface gi  0/0/1 :ip addess 192.168.20.253 255.255.255.0           

                                      vrrp vrid 20 virtual-ip 192.168.20.250         

                        vrrp vrid 10 priority 100

     vrrp vrid 20 track interface GigabitEthernet0/0/2 reduced 50

       interface gi  0/0/2 :ip addess 192.168.100.1   255.255.255.0

    ospf 1 router-id 2.2.2.2

     area 0.0.0.0

      network 192.168.10.0 0.0.0.255

      network 192.168.20.0 0.0.0.255

     area 0.0.0.30

      network 192.168.100.0 0.0.0.255

     

    R3

     interface gi  0/0/0 :ip addess 192.168.10.252 255.255.255.0

     vrrp vrid 10 virtual-ip 192.168.10.250

    vrrp vrid 10 priority 80

       interface gi  0/0/1 :ip addess 192.168.20.252 255.255.255.0

     vrrp vrid 20 virtual-ip 192.168.20.250

     vrrp vrid 20 priority 150

     vrrp vrid 20 track interface GigabitEthernet0/0/2 reduced 100

      interface gi  0/0/2 :ip addess 192.168.100.1   255.255.255.0

    ospf 1 router-id 3.3.3.3

     area 0.0.0.0

      network 192.168.10.0 0.0.0.255

      network 192.168.20.0 0.0.0.255

     area 0.0.0.30

      network 192.168.100.0 0.0.0.255

    验证vlan与vlan之间

    pc1 ping pc2、pc4


    第三部分

    sw1不用配置,端口默认开启

    R4

    interface gi0/0/0 :ip addess 192.168.100.2 255.255.255.0

    interface gi0/0/1 :ip addess 192.168.30.254 255.255.255.0

    ospf 1 router-id 4.4.4.4

     area 0.0.0.30

      network 192.168.30.0 0.0.0.255

      network 192.168.100.0 0.0.0.255

    验证全网通

    pc1 ping 服务器


    转载于:https://blog.51cto.com/13555885/2064698

    展开全文
  • 实验拓扑:实验目的:应用STP,VRRP;了解环路以及解决;使全网互通PC1与PC3属于vlan 10;PC2与PC4属于VLAN 20实验思路:把拓扑图分为三个部分;从底层终端设备开始往上做,配置步骤:第一部分1. 配置PC1 与PC2的IP ...

    实验拓扑:

    blob.png

    实验目的:应用STP,VRRP;了解环路以及解决;使全网互通

    PC1与PC3属于vlan 10;PC2与PC4属于VLAN 20

    实验思路:把拓扑图分为三个部分;从底层终端设备开始往上做,


    配置步骤:第一部分

    blob.png

    1. 配置PC1 与PC2的IP 子网掩码 网关

      PC1 192.168.10.1 255.255.255.0 192.168.10.250(网关为虚拟网关,在第三部分体现)

    blob.png

    blob.png

    2.配置SW4

       在SW4上创建VLAN 10 20;

       把gi 1接口配置为access链路,加入VLAN 10

       把gi 2接口配置为trunk链路,允许所有VLAN通过

       把gi 3接口配置为trunk链路,允许所有VLAN通过

    blob.png

       在SW4上创建STP,命名为LLL

                  将VLAN 10加入一组,优先级设置为4096;

                  将VLAN 20加入二组,优先级设置为8192;

    blob.png

    3.配置SW5

       在SW5上创建VLAN 10 20;

       把gi 1接口配置为access链路,加入VLAN 20

       把gi 2接口配置为trunk链路,允许所有VLAN通过

       把gi 3接口配置为trunk链路,允许所有VLAN通过

    blob.png

       

    在SW5上创建STP,命名为LLL

                  将VLAN 10加入一组,优先级设置为4096;

                  将VLAN 20加入二组,优先级设置为8192;


    [SW5]stp region-configuration                 创建STP           

    [SW5-mst-region]region-name LLL                命名位 LLL

    [SW5-mst-region]instance 1 vlan 10          将1组加入VLAN 10

    [SW5-mst-region]instance 2 vlan 20              将2组加入VLAN 20

    [SW5-mst-region]active region-configuration        开启配置         

    [SW5]stp instance 1 priority 8192               配置1组优先级

    [SW5]stp instance 2 priority 4096               配置2组优先级

    blob.png

    4.配置SW2

       在SW2上创建VLAN 10 20;

       把gi 1接口配置为trunk链路,允许所有VLAN通过

       把gi 2接口配置为trunk链路,允许所有VLAN通过

       把gi 3接口配置为access链路,加入VLAN 10

       把gi 4接口配置为access链路,加入VLAN 10

        把gi 5接口配置为access链路,加入VLAN 10

       把gi 6接口配置为trunk链路,允许所有VLAN通过 

    blob.png    把SW2设置为根交换机

    blob.png


    5.配置SW6

       在SW6上创建VLAN 10 20;

       把gi 1接口配置为access链路,加入VLAN 10

       把gi 2接口配置为trunk链路,允许所有VLAN通过

       把gi 3接口配置为trunk链路,允许所有VLAN通过

    blob.png

    在SW6上创建STP,命名为LLL

                  将VLAN 10加入一组,优先级设置为4096;

                  将VLAN 20加入二组,优先级设置为8192;


    [SW6]stp region-configuration                 创建STP           

    [SW6-mst-region]region-name LLL                命名位 LLL

    [SW6-mst-region]instance 1 vlan 10          将1组加入VLAN 10

    [SW6-mst-region]instance 2 vlan 20              将2组加入VLAN 20

    [SW6-mst-region]active region-configuration        开启配置         

    [SW6]stp instance 1 priority 4096               配置1组优先级

    [SW6]stp instance 2 priority 8192               配置2组优先级

    blob.png

    6.配置SW7

       在SW7上创建VLAN 10 20;

       把gi 1接口配置为access链路,加入VLAN 20

       把gi 2接口配置为trunk链路,允许所有VLAN通过

       把gi 3接口配置为trunk链路,允许所有VLAN通过

    blob.png


    [SW7]stp region-configuration                 创建STP           

    [SW7-mst-region]region-name LLL                命名位 LLL

    [SW7-mst-region]instance 1 vlan 10          将1组加入VLAN 10

    [SW7-mst-region]instance 2 vlan 20              将2组加入VLAN 20

    [SW7-mst-region]active region-configuration        开启配置         

    [SW7]stp instance 1 priority 8192               配置1组优先级

    [SW7]stp instance 2 priority 4096               配置2组优先级

    blob.png


    7.配置SW3

       在SW3上创建VLAN 10 20;

       把gi 1接口配置为trunk链路,允许所有VLAN通过

       把gi 2接口配置为trunk链路,允许所有VLAN通过

       把gi 3接口配置为access链路,加入VLAN 20

       把gi 4接口配置为access链路,加入VLAN 20

        把gi 5接口配置为access链路,加入VLAN 20

       把gi 6接口配置为trunk链路,允许所有VLAN通过 

       这张图命令输入错误没有一次成型就不截图了,跟SW2的配置一样


       把SW3设置为根网桥

    blob.png

    8.此时二层交换网络已经做好 可以PC1 ping PC 3验证

    blob.png

    第二部分:

    配置步骤

    1. 配置R1

    [R1]inter gi 0/0/0

    [R1-GigabitEthernet0/0/0]ip address 192.168.10.254 255.255.255.0     -配置GI 0口的IP

    [R1-GigabitEthernet0/0/0]vrrp vrid 10 virtual-ip 192.168.10.250     -创建VRRP,配置虚拟IP(三台都加入vrrp vrid 10)

    [R1-GigabitEthernet0/0/0]vrrp vrid 10 priority 150              -配置R1上VRRP优先级为150

    [R1-GigabitEthernet0/0/0]vrrp vrid 10 track inter gi 0/0/2 reduced 100 -配置链路跟踪

    blob.png


    [R1]inter gi 0/0/1

    [R1-GigabitEthernet0/0/1]ip address 192.168.20.252 255.255.255.0   配置GI 0/0/1接口的物理IP

    [R1-GigabitEthernet0/0/1]vrrp vrid 20 virtual-ip 192.168.20.250    配置VRRP,虚拟IP

    [R1-GigabitEthernet0/0/1]vrrp vrid 20 priority 80             配置vrrp的优先级为80

    blob.png 


    [R1-GigabitEthernet0/0/2]ip add

    [R1-GigabitEthernet0/0/2]ip address 192.168.100.1 255.255.255.0  配置gi 2接口的物理IP

    [R1-GigabitEthernet0/0/2]ospf 1 router-id 1.1.1.1           在R1配置OSPF区域1 命名为1.1.1.1

    [R1-ospf-1]area 0                                进入ospf1的area0

    [R1-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255        宣告网段 10.0 20.0属于area 0区域

    [R1-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255

    [R1-ospf-1-area-0.0.0.0]area 30                       进入ospf1的area 30

    [R1-ospf-1-area-0.0.0.30]network 192.168.100.0 0.0.0.255      宣告网段100.0属于 area 30 区域    

    blob.png


    2.配置R2

    [R2]inter gi 0/0/0

    [R2-GigabitEthernet0/0/0]ip add 192.168.10.253 255.255.255.0   配置GI 0接口的物理IP

    [R2-GigabitEthernet0/0/0]vrrp vrid 10 virtual-ip 192.168.10.250  创建vrrp 10并且配置虚拟网关的IP

    [R2-GigabitEthernet0/0/0]vrrp vrid 10 priority 100            设置VRRP的优先级          

    [R2-GigabitEthernet0/0/0]vrrp vrid 10 track inter gi 0/0/2 reduced 50  设置链路跟踪

    blob.png



    [R2-GigabitEthernet0/0/1]ip address 192.168.20.253 255.255.255.0      配置物理接口IP

    [R2-GigabitEthernet0/0/1]vrrp vrid 20 virtual-ip 192.168.20.250       创建VRRP,配置虚拟网关IP

    [R2-GigabitEthernet0/0/1]vrrp vrid 20 priority 100               设置VRRP的优先级100

    [R2-GigabitEthernet0/0/1]vrrp vrid 20 track inter gi 0/0/2 reduced 50    链路跟踪

    blob.png


    [R2-GigabitEthernet0/0/1]inter gi 0/0/2

    [R2-GigabitEthernet0/0/2]ip address 192.168.100.1 255.255.255.0     配置gi 2物理接口IP

    [R2-GigabitEthernet0/0/2]ospf 1 router-id 2.2.2.2              创建OSPF 1

    [R2-ospf-1]area 0

    [R2-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255          在OSPF 1中area 0 宣告网段

    [R2-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255

    [R2-ospf-1-area-0.0.0.0]area 30

    [R2-ospf-1-area-0.0.0.30]network 192.168.100.0 0.0.0.255          在OSPF 1中area 30 宣告网段     

    blob.png

    3.配置R3

    [R3]inter gi 0/0/0

    [R3-GigabitEthernet0/0/0]ip address 192.168.10.252 255.255.255.0

    [R3-GigabitEthernet0/0/0]vrrp vrid 10 virtual-ip 192.168.10.250

    [R3-GigabitEthernet0/0/0]vrrp vrid 10 priority 80

    [R3-GigabitEthernet0/0/0]inter gi 0/0/1

    [R3-GigabitEthernet0/0/1]ip address 192.168.20.254 255.255.255.0

    [R3-GigabitEthernet0/0/1]vrrp vrid 20 virtual-ip 192.168.20.250

    [R3-GigabitEthernet0/0/1]vrrp vrid 20 priority 150

    [R3-GigabitEthernet0/0/1]vrrp vrid 20 track inter gi 0/0/2 reduced 100

    [R3-GigabitEthernet0/0/1]inter gi 0/0/2

    [R3-GigabitEthernet0/0/2]ip address 192.168.100.1 255.255.255.0

    [R3-GigabitEthernet0/0/2]ospf 1 router-id 3.3.3.3

    [R3-ospf-1]area 0

    [R3-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255

    [R3-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255

    [R3-ospf-1-area-0.0.0.0]area 30

    [R3-ospf-1-area-0.0.0.30]network 192.168.100.0 0.0.0.255

    blob.png


    验证此步骤做完PC1与PC2,PC4能互通

    blob.png

    第三部分: 配置步骤

    1. SW1端口默认开启,不用做任何配置

    2. 配置R4

    [R4]inter gi 0/0/0

    [R4-GigabitEthernet0/0/0]ip address 192.168.100.2 255.255.255.0      配置gi 0接口ip

    [R4-GigabitEthernet0/0/0]inter gi 0/0/1

    [R4-GigabitEthernet0/0/1]ip address 192.168.30.254 255.255.255.0     配置gi 1接口IP

    [R4-GigabitEthernet0/0/1]ospf 1 router-id 4.4.4.4               创建OSPF 1

    [R4-ospf-1]area 30

    [R4-ospf-1-area-0.0.0.30]network 192.168.30.0 0.0.0.255        在OSPF 1中area 30宣告网段

    [R4-ospf-1-area-0.0.0.30]net

    [R4-ospf-1-area-0.0.0.30]network 192.168.100.0 0.0.0.255

    blob.png

    验证 测试全网互通 

     用PC1 PC2分别PING server主机 192.168.30.1

    blob.png

    blob.png





    转载于:https://blog.51cto.com/13569390/2065192

    展开全文
  • stpvrrp的配置命令

    2018-03-01 08:35:00
    stp生成树协议) Switch(config)# spanning-tree vlan 10 prioity (4096的倍数) //配置vlan10生成树的优先级Switch(config)#spanning-tree vlan 10 root ...

    stp生成树协议)

    Switch(config)#

    spanning-tree vlan 10 prioity (4096的倍数) //配置vlan10生成树的优先级
    Switch(config)#spanning-tree vlan 10 root //配置本交换机为vlan10生成树为主根
    Switch(config)#spanning-tree vlan 10 secondary //配置本交换机为vlan10生成树为次根根

    Switch#show apanning-tree vlan 10 //查看vlan 10 生成树的状态

    vlan 10
    vlan 20
    vlan 30
    vlan 40

    配置VRRP)

    Switch(config-if)#standby 20 ip 192.168.20.254 //配置虚拟ip
    Switch(config-if)#standby 10 priority 105 //配置优先级
    Switch(config-if)#standby 10 preempt //开启占先权

    转载于:https://blog.51cto.com/13562306/2074133

    展开全文
  • IP课:stpvrrp实验

    2020-08-10 19:16:22
    stp region-configuration [sw5-mst-region]region-name huawei [sw5-mst-region]instance 1 vlan 2 [sw5-mst-region]instance 2 vlan 3 [sw5-mst-region]active region-configuration 四、网关冗余VRRP SW1: ...

    在这里插入图片描述
    一、 交换机的二层接口配置。
    SW1:
    [sw1]int g0/0/5
    [sw1-GigabitEthernet0/0/5]port link-type trunk
    [sw1-GigabitEthernet0/0/5]port trunk allow-pass vlan all
    [sw1]int g0/0/6
    [sw1-GigabitEthernet0/0/6]port link-type trunk
    [sw1-GigabitEthernet0/0/6]port trunk allow-pass vlan all
    [sw1]int g0/0/7
    [sw1-GigabitEthernet0/0/7]port link-type trunk
    [sw1-GigabitEthernet0/0/7]port trunk allow-pass vlan all

    SW2:
    [sw2]int g0/0/5
    [sw2-GigabitEthernet0/0/5]port link-type trun
    [sw2-GigabitEthernet0/0/5]port trunk allow-pass vlan all
    [sw2]int g0/0/6
    [sw2-GigabitEthernet0/0/6]port link-type trunk
    [sw2-GigabitEthernet0/0/6]port trunk allow-pass vlan all
    [sw2]int g0/0/7
    [sw2-GigabitEthernet0/0/7]port link-type trunk
    [sw2-GigabitEthernet0/0/7]port trunk allow-pass vlan all

    SW3:
    [sw3]vlan batch 2 3
    Info: This operation may take a few seconds. Please wait for a moment…done.
    [sw3]int e0/0/1
    [sw3-Ethernet0/0/1]port link-type access
    [sw3-Ethernet0/0/1]port default vlan 2
    [sw3]int e0/0/2
    [sw3-Ethernet0/0/2]port link-type access
    [sw3-Ethernet0/0/2]port default vlan 3
    [sw3]int e0/0/3
    [sw3-Ethernet0/0/3]port link-type trunk
    [sw3-Ethernet0/0/3]port trunk allow-pass vlan all
    [sw3]int e0/0/4
    [sw3-Ethernet0/0/4]port link-type trunk
    [sw3-Ethernet0/0/4]port trunk allow-pass vlan all

    SW4:
    [sw4]int e0/0/1
    [sw4-Ethernet0/0/1]port link-type access
    [sw4-Ethernet0/0/1]port default vlan 3
    [sw4]int e0/0/2
    [sw4-Ethernet0/0/2]port link-type access
    [sw4-Ethernet0/0/2]port default vlan 3
    [sw4]int e0/0/3
    [sw4-Ethernet0/0/3]port link-type trunk
    [sw4-Ethernet0/0/3]port trunk allow-pass vlan all
    [sw4]int e0/0/4
    [sw4-Ethernet0/0/4]port link-type trunk
    [sw4-Ethernet0/0/4]port trunk allow-pass vlan all

    SW5:
    [sw5]int e0/0/1
    [sw5-Ethernet0/0/1]port link-type access
    [sw5-Ethernet0/0/1]port default vlan 2
    [sw5]int e0/0/2
    [sw5-Ethernet0/0/2]port link-type access
    [sw5-Ethernet0/0/2]port default vlan 3
    [sw5]int e0/0/3
    [sw5-Ethernet0/0/3]port link-type trunk
    [sw5-Ethernet0/0/3]port trunk allow-pass vlan all
    [sw5]int e0/0/4
    [sw5-Ethernet0/0/4]port link-type trunk
    [sw5-Ethernet0/0/4]port trunk allow-pass vlan all

    二、 eth-trunk
    SW1:
    [sw1]int Eth-Trunk 0
    [sw1-Eth-Trunk0]q
    [sw1]int g0/0/3
    [sw1-GigabitEthernet0/0/3]eth-trunk 0
    Info: This operation may take a few seconds. Please wait for a moment…done.
    [sw1]int g0/0/4
    [sw1-GigabitEthernet0/0/4]eth-trunk 0
    Info: This operation may take a few seconds. Please wait for a moment…done.
    [sw1]int Eth-Trunk 0
    [sw1-Eth-Trunk0]port link-type trunk
    [sw1-Eth-Trunk0]port trunk allow-pass vlan all
    SW2:
    [sw2]int Eth-Trunk 0
    [sw2-Eth-Trunk0]q
    [sw2]int g0/0/3
    [sw2-GigabitEthernet0/0/3]eth-trunk 0
    Info: This operation may take a few seconds. Please wait for a moment…done.
    [sw2]int g0/0/4
    [sw2-GigabitEthernet0/0/4]eth-trunk 0
    Info: This operation may take a few seconds. Please wait for a moment…done.
    [sw2]int Eth-Trunk 0
    [sw2-Eth-Trunk0]port link-type trunk
    [sw2-Eth-Trunk0]port trunk allow-pass vlan all

    三、生成树MSTP
    SW1:
    [sw1]stp mode mstp
    [sw1]stp enable
    [sw1]stp region-configuration
    [sw1-mst-region]region-name huawei
    [sw1-mst-region]instance 1 vlan 2
    [sw1-mst-region]instance 2 vlan 3
    [sw1-mst-region]active region-configuration
    Info: This operation may take a few seconds. Please wait for a moment…done.
    [sw1]stp instance 1 root primary
    [sw1]stp instance 2 root secondary

    SW2:
    [sw2]stp mode mstp
    [sw2]stp enable
    [sw2]stp region-configuration
    [sw2-mst-region]region-name huawei
    [sw2-mst-region]instance 1 vlan 2
    [sw2-mst-region]instance 2 vlan 3
    [sw2-mst-region]active region-configuration
    Info: This operation may take a few seconds. Please wait for a moment…done.
    [sw2]stp instance 1 root secondary
    [sw2]stp instance 2 root primary

    SW3:
    [sw3]stp mode mstp
    [sw3]stp enable
    [sw3]stp re
    [sw3]stp region-configuration
    [sw3-mst-region]reg
    [sw3-mst-region]region-name huawei
    [sw3-mst-region]int
    [sw3-mst-region]ins
    [sw3-mst-region]instance 1 vlan 2
    [sw3-mst-region]instance 2 vlan 3
    [sw3-mst-region]ac
    [sw3-mst-region]active re
    [sw3-mst-region]active region-configuration

    SW4:
    [sw4]stp mode mstp
    [sw4]stp enable
    [sw4]stp region-configuration
    [sw4-mst-region]region-name huawei
    [sw4-mst-region]instance 1 vlan 2
    [sw4-mst-region]instance 2 vlan 3
    [sw4-mst-region]active region-configuration

    SW5:
    [sw5]stp mode mstp
    [sw5]stp enable
    [sw5]stp region-configuration
    [sw5-mst-region]region-name huawei
    [sw5-mst-region]instance 1 vlan 2
    [sw5-mst-region]instance 2 vlan 3
    [sw5-mst-region]active region-configuration

    四、网关冗余VRRP
    SW1:
    [sw1]int Vlanif 2
    [sw1-Vlanif2]ip add 12.1.1.1 24
    [sw1-Vlanif2]vrrp vrid 1 virtual-ip 12.1.1.1
    [sw1]int Vlanif 3
    [sw1-Vlanif3]ip add 23.1.1.2 24
    [sw1-Vlanif3]vrrp vrid 2 virtual-ip 23.1.1.1

    SW2:
    [sw2]int Vlanif 2
    [sw2-Vlanif2]ip add 12.1.1.2 24
    [sw2-Vlanif2]vrrp vrid 1 virtual-ip 12.1.1.1
    [sw2]int Vlanif 3
    [sw2-Vlanif3]ip add 23.1.1.1 24
    [sw2-Vlanif3]vrrp vrid 2 virtual-ip 23.1.1.1

    五、DHCP
    SW1:
    [sw1]dhcp enable
    Info: The operation may take a few seconds. Please wait for a moment.done.
    [sw1]ip pool 1
    Info:It’s successful to create an IP address pool.
    [sw1-ip-pool-1]net
    [sw1-ip-pool-1]network 12.1.1.0 mask 255.255.255.0
    [sw1-ip-pool-1]gateway-list 12.1.1.1
    [sw1-ip-pool-1]dns-list 8.8.8.8
    [sw1]ip pool 2
    Info:It’s successful to create an IP address pool.
    [sw1-ip-pool-2]network 23.1.1.0 mask 255.255.255.0
    [sw1-ip-pool-2]gateway-list 23.1.1.2
    [sw1-ip-pool-2]dns-list 8.8.8.8
    [sw1]int vlanif 2
    [sw1-Vlanif2]dhcp select global
    [sw1]int vlanif 3
    [sw1-Vlanif3]dhcp select global

    SW2:
    [sw2]dhcp enable
    Info: The operation may take a few seconds. Please wait for a moment.done.
    [sw2]ip pool 1
    Info:It’s successful to create an IP address pool.
    [sw2-ip-pool-1]network 12.1.1.0 mask 255.255.255.0
    [sw2-ip-pool-1]gateway-list 12.1.1.1
    [sw2-ip-pool-1]dns-list 8.8.8.8
    [sw2]ip pool 2
    Info:It’s successful to create an IP address pool.
    [sw2-ip-pool-2]network 23.1.1.0 mask 255.255.255.0
    [sw2-ip-pool-2]gateway-list 23.1.1.1
    [sw2-ip-pool-2]dns-list 8.8.8.8
    [sw2]int vlanif 2
    [sw2-Vlanif2]dhcp select global
    [sw2]int vlanif 3
    [sw2-Vlanif3]dhcp select global
    在这里插入图片描述

    六、三层配置
    vLanif 100 接口配ip、 上行接口access default vlan 100
    SW1:
    [sw1]vlan batch 100
    Info: This operation may take a few seconds. Please wait for a moment…done.
    [sw1]int vlanif 100
    [sw1-Vlanif100]ip add 192.168.1.2 24
    [sw1]int g0/0/1
    [sw1-GigabitEthernet0/0/1]port link-type access
    [sw1-GigabitEthernet0/0/1]port default vlan 100

    SW2:
    [sw2]vlan batch 100
    Info: This operation may take a few seconds. Please wait for a moment…done.
    [sw2]int vlanif 100
    [sw2-Vlanif200]ip add 192.168.2.2 24
    [sw2]int g0/0/2
    [sw2-GigabitEthernet0/0/2]port link-type access
    [sw2-GigabitEthernet0/0/2]port default vlan 200
    R1:
    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]ip add 10.1.1.1 24
    [r1]int g0/0/1
    [r1-GigabitEthernet0/0/1]ip add 192.168.1.1 24
    [r1]int g0/0/2
    [r1-GigabitEthernet0/0/2]ip add 192.168.2.1 24
    ISP:
    [ISP]int g0/0/0
    [ISP-GigabitEthernet0/0/0]ip add 10.1.1.2 24

    七、OSPF
    R1:
    [r1]ospf 1 router-id 1.1.1.1
    [r1-ospf-1]area 0
    [r1-ospf-1-area-0.0.0.0]network 192.168.1.1 0.0.0.0
    [r1-ospf-1-area-0.0.0.0]network 192.168.2.1 0.0.0.0

    SW1:
    [sw1]ospf 1 router-id 2.2.2.2
    [sw1-ospf-1]area 0
    [sw1-ospf-1-area-0.0.0.0]network 12.1.1.1 0.0.0.0
    [sw1-ospf-1-area-0.0.0.0]network 23.1.1.2 0.0.0.0
    [sw1-ospf-1-area-0.0.0.0]network 192.168.1.2 0.0.0.0

    SW2:
    [sw2]ospf 1 router-id 3.3.3.3
    [sw2-ospf-1]area 0
    [sw2-ospf-1-area-0.0.0.0]network 12.1.1.2 0.0.0.0
    [sw2-ospf-1-area-0.0.0.0]network 23.1.1.1 0.0.0.0
    [sw2-ospf-1-area-0.0.0.0]network 192.168.2.2 0.0.0.0
    在这里插入图片描述

    八、通外网
    [r1]ip route-static 0.0.0.0 0 10.1.1.2 缺省路由
    [r1]ospf 1
    [r1-ospf-1]default-route-advertise always ospf下放缺省
    [r1]acl 2000
    [r1-acl-basic-2000]rule 5 permit source any
    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]nat outbound 2000 Esay-IP (NAT)
    在这里插入图片描述

    展开全文
  • STP+VTP+VRRP

    2017-12-16 23:37:03
    该资料阐述企业小型网络STP、VTP、VRRP部署与配置案例!!
  • 本实验使用华为eNSP模拟器,采用了VLAN技术、MSTP技术、VRRP技术、RIP等技术,搭建了一个简单的公司内网环境,实现网络的冗余及负载均衡实验环境如下:在sw1上配置<Huawei>system-view [Huawei]sysnamesw1 [sw...
  • ; ; ; ; ; ;交换机端口接收数据帧的处理规则 ;3. hybrid端口 1收到一个二层帧 2判断是否有VLAN标签没有则转到第3步有则转到第4步 3打上端口的PVID并进行交换转发 4判断该hybrid端口是否允许该VLAN帧...STP的基本概念;
  • ; ; ; ; ; ;交换机端口接收数据帧的处理规则 ;3. hybrid端口 1收到一个二层帧 2判断是否有VLAN标签没有则转到第3步有则转到第4步 3打上端口的PVID并进行交换转发 4判断该hybrid端口是否允许该VLAN帧...STP的基本概念;
  • 3.SW1上vlanif10的vrrp vrid 1 virtual-ip 192.168.1.250 配置错误; 4.SW1的g0/0/14接口需允许所有vlan通过; 5.SW1的 vlanif 10未设置vrrp优先级; 6.SW1的 vlanif 20未设置vrrp优先级; 7.SW1的g0/0/12应配置未...
  • display stp 查看sw1,sw2,sw3的stp,确定根交换机和非根交换机,找出阻塞端口(阻塞端口为ALTE) 这里查出阻塞端口为Eth0/0/13,sw2为根交换机,sw1为非根交换机,为了给交换机减压将sw3设置成根交换机。配置如下: stp...
  • SW7,SW8上针对两个VLAN分别做VRRP,同时运行STP R1为路由器,在R1上做NAT,R2模拟外网 VRRP VRRP虚拟出一个网关设备,主机填写虚拟网关地址(vrid),主机的所有流量发送到虚拟网关设备,再由虚拟网关设备,发送给...
  • vrrp stp遇到的问题

    2009-04-24 14:38:07
    说明: 1 sw1与sw2为两三层交换,在两交换机上起vrrp , 2 f0/14与f0/15进行端口聚合,做为两交换机之间的一条心跳, 3 在两交换机上分别配置vlan10 :192.168.10.1 vlan 20:192.168.20.1 4 在vrrp上起两备份组1 ...
  • vlan+vrrp+ stp

    2018-01-29 21:16:32
    stp region-configuration region-name fxl revision-level 1 instance 1 vlan 10 instance 2 vlan 20 active region-configuration quit   sw2-------------- sys vlan 10 vlan 20 quit   int e0/0/1 port link-...
  • vrrp+stp+静态

    2017-02-19 11:32:39
     vrrpvrid 1 virtual-ip 192.168.2.252 vrrp1 ip 地址 vrrp 虚拟网关 # interface Vlanif3  ipaddress 192.168.3.254 255.255.255.0  vrrpvrid 2 virtual-ip 192.168.3.252 # interface Vlanif5  ipaddress ...
  • HCL配置 VRRP+STP 实验

    2020-07-21 17:20:47
    网关是该 VLAN 的 IP 地址 4台PC机可以相互ping 通 步骤六:配置 STP [SW1]stp instance 0 priority 0 //配置当前交换机的桥的优先级 [SW2]stp instance 0 priority 4096 步骤七:配置 DHCP SW1 [SW1]dhcp enable //...
  • 文章目录一.实验图二.配置三.结果 一.实验图 二.配置 SW1: SW2: SW3: R1: R2: R3: R4: 三.结果 PC3 ping PC1 PC5 ping PC2 客户机 ping 服务器
  • 通常配置MVRRP+MSTP,我们将root和secondary root分别配置在Master和Backup两台交换机上,如果两台三层交换机之间运行的是三层链路,那么某台接入交互机的所有端口将不会被STP阻断(假设是SW3),而其他接入交换机都...
  • 华为ensp vrrp/stp/vlan/trunk 的练习实验 实验要求 1、内网IP地址172.16.0.0/16合理分配 2、sW1/2之间互为备份 3、vrrp/stp/vlan/trunk均使用 4、所有PC通过DHCP获取ip 实验拓扑 实验配置 LSW5 [Huawei]display ...
  • 实验三: 分析:查看sw1 和sw2 的stp可知 sw1和sw2 是根网桥 sw3和sw6的11端口 为阻塞端口 ,因此可以知道pc机之间数据包的走向,也可以改变交换 机的角色:stp priority{id} (为409...
  • VRRP

    2021-03-16 15:45:30
    单点故障 STP Eth-trunk —>解决链路层的单点故障问题 VRRP 解决的是网路层单点故障的问题: 单网关缺陷的问题 VRRP自动化实现,多个冗余网关 之间的数据切换的问题 二、VRRP的概念以及如何实现 (一) VRRP概念: ...
  • 对新增加的三层交换机端口配置trunk划分vlan以及配置相应的网关,对vlanif配置IP将端口划分进vlan以及VRRP,RIP 配置MSTP 配置完成后实现冗余通过阻塞端口防止网络环路阻止广播风暴,还实现了链路备份...
  • STP 相关配置 STP命令 相关设置 • stp enable 开启stpstp mode stp/rstp/mstp 设置stp模式 • display stp 查看stp状态 • display stp brief 查看stp状态 • stp root primary/secondary 指定...
  • STP:生成协议(Spanning-tree-protocol) 为了提高网络可靠性,交换网络中通常会使用冗余链路,然而,冗余链路会给交换网络带来环路风险,并且导致广播风暴以及MAC地址表不稳定等问题,进而影响到用户的通信质量。...

空空如也

空空如也

1 2 3 4 5 ... 12
收藏数 233
精华内容 93
关键字:

stpvrrp