精华内容
下载资源
问答
  • 如果这篇文章对您有帮助,请关注并点赞,感谢您的支持,如果还有...当我们在port link-type 后面打问号的时候,会出现下图的样子这是华为端口的工作模式,有四种,今天我们来讲解其中的三种:access ,trunk,hybridAc...

    如果这篇文章对您有帮助,请关注并点赞,感谢您的支持,如果还有其他问题,请私信给我

    前几期我们介绍了华为交换机的vlan模式设置,里面有一条命令是port link-type access ,这个是设置端口工作模式为access。当我们在port link-type 后面打问号的时候,会出现下图的样子

    d042db4c321a48d6a2399c1f13f041ff

    这是华为端口的工作模式,有四种,今天我们来讲解其中的三种:access ,trunk,hybrid

    Access 端口只能属于一个vlan ,一般是连接计算机的端口,只能运行设置一个vlan

    例如设置端口工作模式为access ,并指定缺省的vlanID为100

    d168135cc6994f0d8534756fc6724e8f

    登录到e0/0/3接口,命令为int ethernet 0/0/3

    8857d24ef673466794715c225bd9ccc9

    更改端口工作模式为access,命令为 port link-type access

    aac1ee4ef6684f6a99179c6a62bbaf52

    指定端口默认vlan为100 ,命令为 port default vlan 100

    Trunk 端口允许多个vlan通过,一般用于交换机之间连接的端口,以华为s3700为例,我们设置千兆口为trunk模式,其中3口为光电复用端口,设置3口为trunk模式,默认vlan 为vlan 100,并允许vlan 101 102数据通过

    10fe6620521a458e8aeac98ee136ca3a

    登录光电口ge0/0/3 ,命令为interface gigabitethernet 0/0/3

    ee1c532e6e3b4e6ba0545438eaba1694

    设置工作模式为trunk,命令为:port link-type trunk

    020a5303a49b4301b6bd6609f9533a8c

    指定默认vlan 为100 ,命令为prot trunk pvid vlan 100

    57982328bc5a4d549205cff97631961b

    允许vlan 101 102 数据通过,即,vlan 100,101,102可以互相访问,命令为port trunk allow-pass vlan 101 102

    Hybrid 是华为设备中的新端口类型,特点是允许多个vlan通过,即可以用于交换机之间的连接,也可以用于连接用户的计算机

    配置光电4口为hybird端口。命令和其他端口模式更改差不多,不同的是可以设置哪些vlan添加tag,哪些vlan不添加

    命令如下:

    21bb3321a61d4a5eb2a7f4e61cd06487

    在转发vlan 101数据的时候添加tag,命令如下:port hybrid tagged vlan 101

    c1a3cb46ad4c4018a6f0e4d6372fc7ac

    在转发vlan 102数据的时候不添加tag,命令如下 port hybrid tagged vlan 102.

    到这里,华为交换机端口的三种模式就介绍完了,有什么不明白的可以留言或私信

    如果这篇文章对您有帮助,请关注并点赞,感谢您的支持,如果还有其他问题,请私信给我

    展开全文
  • 华为S2700交换机原来的trunk端口设置如下:interface Ethernet0/0/24port link-type trunkport trunk allow-pass vlan 1 to 4094ntdp enablendp enable现在想把trunk端口改为access端口,于是使用undo命令,却一直...

    华为S2700交换机原来的trunk端口设置如下:

    interface Ethernet0/0/24

    port link-type trunk

    port trunk allow-pass vlan 1 to 4094

    ntdp enable

    ndp enable

    现在想把trunk端口改为access端口,于是使用undo命令,却一直提示有错误。

    [S2700]int Ethernet0/0/24

    [S2700-Ethernet0/0/24]undo port link-type trunk

    ^

    Error:Too many parameters found at '^' position.

    [S2700-Ethernet0/0/24]undo port link-type

    Error: Please renew the default configurations.

    [S2700-Ethernet0/0/24]undo port link-type trunk

    ^

    Error:Too many parameters found at '^' position.

    于是希望先用命令undo port trunk allow-pass vlan all,然后再使用命令undo port link-type trunk 结果仍然出现错误提示Error: Please renew the default configurations.

    最后考虑到默认VLAN1,于是找到问题解决办法。

    [S2700-Ethernet0/0/24]port trunk allow-pass vlan 1

    [S2700-Ethernet0/0/24]undo port link

    [S2700-Ethernet0/0/24]undo port link-type trunk

    ^

    Error:Too many parameters found at '^' position. //仍然不成功,继续试验。

    [S2700-Ethernet0/0/24]undo port link-type

    [S2700-Ethernet0/0/24]port link

    [S2700-Ethernet0/0/24]port link-type access  //成功。

    [S2700-Ethernet0/0/24]q

    [S2700]

    展开全文
  • ibm北电与华为trunk端口汇聚,不同于北电与h3c的lacp
  • 具体含义如下:①TPID为固定值0x8100,表明加了一个vlan标签②PRI为优先级,0~7③CFI,取0表示为规范格式,取1表示非规范格式④vlan ID为vlan号,取值范围1-4094 首先提一个概念,即PVID(Port Vlan ID),这是端口的...
    24099721cf750f5a69e3c6300caeb16e.png

    按照IEEE802.1Q标准,vlan帧的格式如下:

    55797da679878666c1398f4b76df70d4.png

    此处的Tag就是vlan tag,即我们常说的vlan标签。

    具体含义如下:

    ①TPID为固定值0x8100,表明加了一个vlan标签

    ②PRI为优先级,0~7

    ③CFI,取0表示为规范格式,取1表示非规范格式

    ④vlan ID为vlan号,取值范围1-4094

    首先提一个概念,即PVID(Port Vlan ID),这是端口的一个基本属性,可手动设置,默认值为1。其次,所有的以太网帧在交换机中进行处理的时候,都是按照上图格式来进行处理,即帧都是带了vlan tag的。

    华为交换机的端口有三种类型,分别是access,trunk,hybrid。

    fc336dc00d69046ff1d065d4fba9de1f.gif

    access

    1、access端口接收帧时:

    • 如果接收的帧有vlan tag时,该帧的vlan ID和access端口的PVID相同时,则接收该帧;否则丢弃该帧。
    • 如果接收的帧没有携带vlan tag时,access端口会将该帧打上vlan tag,vlan ID即为本端口的PVID,则接收该帧。

    2、access端口发送帧时:

    • access端口只能发送vlan ID和端口PVID相同的帧,发送出去时会剥掉vlan tag。(即从access口出去的帧都是没有tag的帧)

    例子:

    [Huawei-GigabitEthernet0/0/3]port link-type access

    [Huawei-GigabitEthernet0/0/3]port default vlan 10

    将该端口配为access端口,PVID为10。

    该端口只能发送vlan ID为10的帧,发送出来的帧没有vlan tag。

    该端口可以接收vlan ID为10的帧(如交换机传出的帧);也可以接收没有vlan tag的帧(如PC传出的帧),此帧将打上vlan tag(vlan ID=10)传入交换机。

    fc336dc00d69046ff1d065d4fba9de1f.gif

    trunk

    1、trunk端口接收帧时:

    • 接收没有vlan tag的帧时,trunk端口将帧打上vlan tag,vlan ID和本端口的PVID相同,若该PVID在trunk端口允许放行的vlan中,接收该帧;否则丢弃该帧。
    • 接收有vlan tag的帧,若帧的vlan ID在trunk端口允许放行的vlan中,接收该帧;否则丢弃该帧。

    2、trunk端口发送帧时:

    • trunk端口只能发送允许放行的vlan帧,若该帧的vlan ID和trunk的PVID相同,则剥掉vlan tag发送;若该帧的vlan ID和trunk的PVID不同,则保留原有vlan tag发送。

    例子

    [Huawei-GigabitEthernet0/0/4]port link-type trunk

    [Huawei-GigabitEthernet0/0/4]port trunk pvid vlan 5

    [Huawei-GigabitEthernet0/0/4]port trunk allow-pass vlan 10 20 30

    配置该端口为trunk端口,PVID为5,放行vlan为10,20,30。

    该端口可以发送vlan ID为10,20,30的帧,发送出去的帧是有vlan tag的。

    该端口可以接收vlan ID为10,20,30的帧。

    [Huawei-GigabitEthernet0/0/5]port link-type trunk

    [Huawei-GigabitEthernet0/0/5]port trunk pvid vlan 5

    [Huawei-GigabitEthernet0/0/5]port trunk allow-pass vlan 5 10 20 30

    配置该端口为trunk端口,PVID为5,放行vlan为5,10,20,30。

    该端口可以发送vlan ID为5,10,20,30的帧,发送vlan ID为10、20、30的帧是有vlan tag的;发送vlan ID为5的帧时没有vlan tag。

    该端口可以接收vlan ID为5,10,20,30的帧,也可以接收没有vlan tag的帧。

    fc336dc00d69046ff1d065d4fba9de1f.gif

    hybrid

    1、hybrid端口接收帧时:

    • 接收没有vlan tag的帧,hybrid端口将帧打上vlan tag,vlan ID和本端口的PVID相同,若该PVID在hybrid端口的允许放行的vlan中,则接收该帧,否则丢弃该帧。
    • 接收有vlan tag的帧,若帧的vlan ID在hybrid端口允许放行的vlan中,则接收该帧,否则丢弃该帧。

    2、hybrid端口发送帧时:

    • hybrid端口只能发送允许放行vlan中的帧,可以通过命令来控制发送时是否携带vlan tag。

    例子:

    [Huawei-GigabitEthernet0/0/6]port hybrid pvid vlan 10

    [Huawei-GigabitEthernet0/0/6]port hybrid tagged vlan 10 20 30

    [Huawei-GigabitEthernet0/0/6]port hybrid untagged vlan 100 200 300

    配置此端口为hybrid端口,PVID为10,

    允许放行的vlan有10、20、30、100、200、300。

    端口接收帧时同trunk一样。

    端口发送帧时,vlan ID为10、20、30的帧时有vlan tag;vlan ID为100、200、300的帧时没有vlan tag。

    0bcb4e1246bf1118a98cb9d9e7182be2.png
    展开全文
  • 关注我,你的眼睛会怀孕华为交换机和其他品牌的交换机在端口的vlan划分上有一些区别,今天就和大家详细说说华为交换机的端口vlan属性~按照IEEE802.1Q标准,vlan帧的格式如下:此处的Tag就是vlan tag,即我们常说的...

    关注我,你的眼睛会怀孕

    6c54a27c2bafe649b6f4e73eac3c08d0.png

    华为交换机和其他品牌的交换机在端口的vlan划分上有一些区别,今天就和大家详细说说华为交换机的端口vlan属性~a8ef9db6853056df67fbfdfb16dd8b21.gif

    按照IEEE802.1Q标准,vlan帧的格式如下:

    c5e36ed9f0a59c656843851c3d534d5d.png

    此处的Tag就是vlan tag,即我们常说的vlan标签。

    具体含义如下:

    ①TPID为固定值0x8100,表明加了一个vlan标签

    ②PRI为优先级,0~7

    ③CFI,取0表示为规范格式,取1表示非规范格式

    ④vlan ID为vlan号,取值范围1-4094

    首先提一个概念,即PVID(Port Vlan ID),这是端口的一个基本属性,可手动设置,默认值为1。其次,所有的以太网帧在交换机中进行处理得时候,都是按照上图格式来进行处理得,即帧都是带了vlan tag的。

    华为交换机的端口有三种模式,分别是access,trunk,hybrid。

    8c4e937078fbfe9de4cc84c88508e6cd.gifaccess

    1、access端口接收帧时:

    ①如果接收的帧有vlan tag时,该帧的vlan ID和access端口的PVID相同时,将改帧送入交换机;该帧的vlan ID和access端口的PVID不同时,丢弃帧。

    ②如果接收的帧没有vlan tag时,access端口会将该帧打上vlan tag,vlan ID即为本端口的PVID,送入交换机。

    2、access端口发送帧时:

    access端口只能发送vlan ID和端口PVID相同的帧,发送出去时会剥掉vlan tag。

    例子:

    [Huawei-GigabitEthernet0/0/3]port link-type access

    [Huawei-GigabitEthernet0/0/3]port default vlan 10

    此时该端口为access端口,PVID为10。

    该端口只能发送vlan ID为10的帧,发送出来的帧没有vlan tag。

    该端口可以接收vlan ID为10的帧(如交换机传出的帧);也可以接收没有vlan tag的帧(如PC传出的帧),此帧将打上vlan tag(vlan ID=10)传入交换机。

    8c4e937078fbfe9de4cc84c88508e6cd.giftrunk

    1、trunk端口接收帧时:

    ①接收没有vlan tag的帧,trunk端口将帧打上vlan tag,vlan ID和本端口的PVID相同,若该PVID在trunk端口的放行vlan中,送入交换机,若PVID不在trunk端口的放行vlan中,丢弃该帧。

    ②接收有vlan tag的帧,若帧的vlan ID在trunk端口的放行vlan中,送入交换机,若vlan ID不在trunk端口的放行vlan中,丢弃该帧。

    2、trunk端口发送帧时:

    trunk端口只能发送放行vlan中的帧,若该帧的vlan ID和trunk的PVID相同,则剥掉vlan tag发送;若该帧的vlan ID和trunk的PVID不同,则保留原有vlan tag发送。

    例子

    [Huawei-GigabitEthernet0/0/4]port link-type trunk

    [Huawei-GigabitEthernet0/0/4]port trunk pvid vlan 5

    [Huawei-GigabitEthernet0/0/4]port trunk allow-pass vlan 10 20 30

    此时该端口为trunk端口,PVID为5,放行vlan为10,20,30。

    该端口可以发送vlan ID为10,20,30的帧,发送出去的帧时有vlan tag的。

    该端口可以接收vlan ID为10,20,30的帧。

    [Huawei-GigabitEthernet0/0/5]port link-type trunk

    [Huawei-GigabitEthernet0/0/5]port trunk pvid vlan 5

    [Huawei-GigabitEthernet0/0/5]port trunk allow-pass vlan 5 10 20 30

    此时该端口为trunk端口,PVID为5,放行vlan为5,10,20,30。

    该端口可以发送vlan ID,5,10,20,30的帧,发送vlan ID为10、20、30的帧,帧是有vlan tag的;发送vlan ID为5的帧,帧时没有vlan tag的。

    该端口可以接收vlan ID为5,10,20,30的帧,也可以接收没有vlan tag的帧。

    8c4e937078fbfe9de4cc84c88508e6cd.gifhybrid

    1、hybrid端口接收帧时:

    ①接收没有vlan tag的帧,hybrid端口将帧打上vlan tag,vlan ID和本端口的PVID相同,若该PVID在hybrid端口的放行vlan中,送入交换机,若PVID不在hybrid端口的放行vlan中,丢弃该帧。

    ②接收有vlan tag的帧,若帧的vlan ID在hybrid端口的放行vlan中,送入交换机,若vlan ID不在hybrid端口的放行vlan中,丢弃该帧。

    2、hybrid端口发送帧时:

    hybrid端口只能发送放行vlan中的帧,可以通过命令来控制发送时是否携带vlan tag。

    例子:

    [Huawei-GigabitEthernet0/0/6]port hybrid pvid vlan 10

    [Huawei-GigabitEthernet0/0/6]port hybrid tagged vlan 10 20 30

    [Huawei-GigabitEthernet0/0/6]port hybrid untagged vlan 100 200 300

    此端口为hybrid端口,PVID为10,放行的vlan有10、20、30、100、200、300。

    端口接收帧时同trunk是一样。

    端口发送帧时,vlan ID为10、20、30的帧时有vlan tag的;vlan ID为100、200、300的帧时没有vlan tag的。

    1

    end

    年度热文

    adcda22f3b3c0375081be38b39b5cc0d.png

    【收藏】华为5700系列交换机常用配置示例

    【科普】为什么ip地址通常以192.168开头?

    【干货】图文并茂磁盘阵列RAID详解

    【教程】手把手zabbix安装教程

    【实验】小型企业网三层架构

    【干货】运维常用的17款监控系统

    【热点】又一起删库跑路事件!公司损失近 10 亿

    干货】TCP协议详解

    【技术】老司机网络排障实例

    【必看】网工常见10大问题及解决方法

    【热点】11天竣工交付,火神山医院背后的网络建设

    【必看】中型企业网络构建——OSPF区域划分(特殊域)

    【必看】局域网ip地址不够用怎么办?

    【基础】Ansible 自动化运维工具简单入门

    【收藏】cisco设备报错消息汇总

    【干货】TCP连接的状态详解以及故障排查

    【必看】华为交换机型号解读

    【必看】常见23种网络速度变慢的解决方法



    7c80839a1cbf22927dc3b6a217fde499.png

    系统集成/认证培训

    买设备,找我们

    IT维保,找我们

    IT培训,找我们

    展开全文
  • 华为S2700交换机原来的trunk端口设置如下: interface Ethernet0/0/24 port link-type trunk port trunk allow-pass vlan 1 to 4094 ntdp enable ndp enable 现在想把trunk端口改为access端口,于是使用undo...
  • 华为交换机端口模式trunk⇌access互改 1.#access改为trunk# undo vlan 10 (假如端口加入vlan 10) port link-type trunk port trunk allow-pass vlan all 2.#trunk改为access# undo port trunk allow-pass vlan all...
  • 3026ef trunk端口环回受控功能未关闭造成环路问题 本博文由昆哥提供原稿,在此共享给有类似情况的同仁;以及对昆哥表示敬意! 现象描述:组网为S8016+++(trunk)+++3026EF+++2016在没有改变组网的情况下S8016 1/0/0...
  • 那里有图经常有网友问我端口聚合是指链路聚合还是VLAN trunking啊?为什么老师给他们讲的都是这个名称呢,是老师讲错了,还是书上有错。我学网络这么久了,也一直实际使用中在把这两个词混用,其实这完全不是一回事...
  • 原标题:华为交换机的配置及:access、trunk、hybird端口详解很多人朋友多次问到华为交换机的配置,确实用的比较多,上次我们有单独提到h3c交换机的配置,今天我们来了解下华为交换机的配置,以及以太网的三种链路...
  • 华为以太网端口三种链路类型access,trunk,hybrid的理解

    千次阅读 多人点赞 2019-07-22 18:42:23
    需要知道的是,三种端口本质上没有太大区别,读者千万不要走入这样的误区,例如不要trunk端口必须是交换机和交换机之间用到,它们本质都是为转发数据而存在的。 众所周知,我们初次接触这几个端口类型概念的时候,...
  • 很多人朋友多次问到华为交换机的配置,确实用的比较多,上次我们有单独提到h3c交换机的配置,今天我们来了解下华为交换机的配置,以及以太网的三种链路方式。为了让大家更加清楚,每行代码都有解释。一、华为交换机...
  • 以太网端口有 3种链路类型:access、trunk、hybirdAccess类型端口:只能属于1个VLAN,一般用于连接计算机端口Trunk类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,一般用于交换机与交换机相关的...
  • 华为交换机常用命令:查看交换机VLAN IP命令:display ip interface brief退出系统视图,保存更改: save查看交换机所有VLAN命令:dis vlan更改交换机名称为SW1: sysname SW1查看所有端口配置信息: dis ...
  • 如果这篇文章对您有帮助,请关注并点赞,感谢您的支持,如果还有...当我们在port link-type 后面打问号的时候,会出现下图的样子这是华为端口的工作模式,有四种,今天我们来讲解其中的三种:access ,trunk,hybridAc...
  • Trunk端口:一般用于交换机之间的连接在交换机之间传递tagged frame。允许多个VLAN通过,可以与PVID不同收到不带tagged frame的数据帧时,打上PVID 并转发收到带tagged frame数据帧时,检查VLAN I...
  • 华为交换机设备上端口链路类型access、trunk、hybrid如图示: 由上图可知三种端口类型的基本工作原理: a)access端口 发送(从交换机内部往外发送): 带有vlantag...
  • 3. hybird的专业说明二:华为交换机端口配置及实验1.实验配置2.具体命令详解 一:以太网的3种链接类型 1.什么是链路类型? vlan的链路类型可以分为接入链路和干道链路。 1、接入链路(access link)指的交换机到用户...
  • 华为端口access、trunk、hybrid模式

    千次阅读 2017-02-16 17:53:10
    端口缺省为VLAN 1,可以通过pvid设置。端口常禁止VLAN1 通过,防止环路。 port hybrid untagged和tagged是对报文出方向处理的。
  • 华为路由器交换机配置命令:计算机命令 PCAlogin:root;使用root用户 password:linux;口令是linux #shutdown-hnow;关机 #init0;关机 #logout;用户注销 #login;用户登录 #ifconfig;显示IP地址 #ifconfigeth0...
  • 求助,华为交换机肿么屏蔽445端口acl number 3000 rule 1 deny tcp destination-port eq 445 rule 5 deny udp destination-port eq 445华为交换机接口怎么建不了接口组答:华为的不一样,华为的配置做trunk的配置是...
  • 华为交换机端口hybird端口属性配置

    万次阅读 2018-06-02 13:32:08
    华为交换机的端口hybrid端口属性配置1 交换机端口链路类型介绍交换机以太网端口共有三种链路类型:Access、Trunk和Hybrid。l Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;l Trunk类型的端口可以...
  • 华为hybrid端口属性

    2011-03-14 08:22:55
    介绍华为hybrid端口的属性,介绍Layer2网络上access、trunk、hybird的区别
  • 无论如何配置,就是不能将端口trunk改为access 后面发现这样配置,就可以将端口更改: 用下面两条命令就可以更改端口类型 [Huawei-GigabitEthernet0/0/1]undo port trunk allow-pass vlan all //取消trunk...
  • 华为新版交换机端口配置由TRUNK改为ACCESS遇到的现象:在接口模式下直接修改TRUNK,报错:[Quidway-GigabitEthernet0/0/7]port link-type accessError: Please renew the default configurations.正确方法如下:...
  • 华为交换机-端口trunk改为access

    千次阅读 2014-10-30 10:26:05
    [S9306-GigabitEthernet2/0/42]dis this#interface GigabitEthernet2/0/42原先的为trunk,port link-type trunkport trunk allow-pass vlan 2 to 4094#interface GigabitEthernet2/0/42 现在改为accessundo port...
  • 华为交换机Trunk配置

    千次阅读 2019-11-13 18:12:37
    华为交换机Trunk配置 Trunk 采用Trunk中继链路技术可以实现不同交换机同网段的Vlan间通信。Trunk中继技术可以实现在一条物理线路中可以传递多个Vlan间的信息,如:交换机从属于Vlan2的端口接收到数据,在Trunk中继...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 460
精华内容 184
关键字:

华为trunk端口