精华内容
下载资源
问答
  • 原标题:华为交换机配置及:access、trunk、hybird端口详解很多人朋友多次问到华为交换机配置,确实用的比较多,上次我们有单独提到h3c交换机的配置,今天我们来了解下华为交换机配置,以及以太网的三种链路...

    原标题:华为交换机的配置及:access、trunk、hybird端口详解

    很多人朋友多次问到华为交换机的配置,确实用的比较多,上次我们有单独提到h3c交换机的配置,今天我们来了解下华为交换机的配置,以及以太网的三种链路方式。

    为了让大家更加清楚,每行代码都有解释。

    一、华为交换机的基本配置

    1、创建vlan:

    //用户视图,也就是在Quidway模式下运行命令。

    system-view //进入配置视图

    [Quidway] vlan 10 //创建vlan 10,并进入vlan10配置视图,如果vlan10存在就直接进入vlan10配置视图

    [Quidway-vlan10] quit //回到配置视图

    [Quidway] vlan 100 //创建vlan 100,并进入vlan100配置视图,如果vlan10存在就直接进入vlan100配置视图

    [Quidway-vlan100] quit //回到配置视图

    2、将端口加入到vlan中:

    [Quidway] interface GigabitEthernet2/0/1 (10G光口)

    [Quidway- GigabitEthernet2/0/1] port link-type access //定义端口传输模式

    [Quidway- GigabitEthernet2/0/1] port default vlan 100 //将端口加入vlan100

    [Quidway- GigabitEthernet2/0/1] quit 回到配置视图

    [Quidway] interface GigabitEthernet1/0/0 //进入1号插槽上的第一个千兆网口配置视图中。0代表1号口

    [Quidway- GigabitEthernet1/0/0] port link-type access //定义端口传输模式

    [Quidway- GigabitEthernet2/0/1] port default vlan 10 //将这个端口加入到vlan10中

    [Quidway- GigabitEthernet2/0/1] quit

    3、将多个端口加入到VLAN中

    system-view

    [Quidway]vlan 10

    [Quidway-vlan10]port GigabitEthernet 1/0/0 to 1/0/29 //将0到29号口加入到vlan10中

    [Quidway-vlan10]quit

    华为下的这个命令自己现在不知道,找了下答案也没有结果。

    4、交换机配置IP地址

    [Quidway] interface Vlanif100 // 进入vlan100接口视图与vlan 100命令进入的地方不同

    [Quidway-Vlanif100] ip address 119.167.200.90 255.255.255.252 // 定义vlan100管理IP三层 交换网关路由

    [Quidway-Vlanif100] quit 返回视图

    [Quidway] interface Vlanif10 // 进入vlan10接口视图与vlan 10命令进入的地方不同

    [Quidway-Vlanif10] ip address 119.167.206.129 255.255.255.128 // 定义vlan10管理IP三层交换网关路由

    [Quidway-Vlanif10] quit

    配置默认网关:

    [Quidway]ip route-static 0.0.0.0 0.0.0.0 119.167.200.89 //配置默认网关。

    5、 交换机保存设置和重置命令

    save //保存配置信息

    reset saved-configuration /重置交换机的配置

    reboot //重新启动交换机

    6、交换机常用的显示命令

    用户视图模式下:

    display current-configuration //显示现在交换机正在运行的配置明细

    display device //显示S9303各设备状态

    display interface ? //显示个端口状态,用?可以查看后边跟的选项

    display version //查看交换机固件版本信息

    display vlan ? // 查看vlan的配置信息

    7、恢复交换机出厂设置

    reset saved-configuration /重置交换机的配置

    二、以太网的3种链接类型

    以太网的三种链接类型:

    以太网端口有 3种链路类型:access、trunk、hybird

    Access类型端口:只能属于1个VLAN,一般用于连接计算机端口;

    Trunk类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,

    一般用于交换机与交换机相关的接口。

    Hybrid类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,

    可以用于交换机的间连接也可以用于连接用户计算机。

    首先,将交换机的类型进行划分,交换机分为低端(SOHO级)和高端(企业级)。

    其两者的重要区别就是低端的交换机每一个物理端口为一个逻辑端口,而高端交换机则是将多个物理端口捆绑成一个逻辑端口再进行的配置的。

    例如

    cisco网络中,交换机在局域网中最终稳定状态的接口类型主要有四种:access/trunk/ multi/ dot1q-tunnel。

    1、access: 主要用来接入终端设备,如PC机、服务器、打印服务器等。

    2、trunk: 主要用在连接其它交换机,以便在线路上承载多个vlan。

    3、multi: 在一个线路中承载多个vlan,但不像trunk,它不对承载的数据打标签。主要用于接入支持多vlan的服务器或者一些网络分析设备。现在基本不使用此类接口,在cisco的网络设备中,也基本不支持此类接口了。

    4、dot1q-tunnel: 用在Q-in-Q隧道配置中。

    什么是链路类型?

    vlan的链路类型可以分为接入链路和干道链路。

    1、接入链路(access link)指的交换机到用户设备的链路,即是接入到户,可以理解为由交换机向用户的链路。由于大多数电脑不能发送带vlan tag的帧,所以这段链路可以理解为不带vlan tag的链路。

    2、干道链路(trunk link)指的交换机到上层设备如路由器的链路,可以理解为向广域网走的链路。这段链路由于要靠vlan来区分用户或者服务,所以一般都带有vlan tag。

    什么是端口类型?

    端口类型在以前主要分为两种,基本上用的也是access和trunk这两种端口。

    1、access端口:它是交换机上用来连接用户电脑的一种端口,只用于接入链路。例如:当一个端口属于vlan 10时,那么带着vlan 10的数据帧会被发送到交换机这个端口上,当这个数据帧通过这个端口时,vlan 10 tag 将会被剥掉,到达用户电脑时,就是一个以太网的帧。而当用户电脑发送一个以太网的帧时,通过这个端口向上走,那么这个端口就会给这个帧加上一个vlan 10 tag。而其他vlan tag的帧则不能从这个端口上下发到电脑上。

    2、trunk端口:这个端口是交换机之间或者交换机和上层设备之间的通信端口,用于干道链路。一个trunk端口可以拥有一个主vlan和多个副vlan,这个概念可以举个例子来理解:例如:当一个trunk端口有主vlan 10 和多个副vlan11、12、30时,带有vlan 30的数据帧可以通过这个端口,通过时vlan 30不被剥掉;当带有vlan 10的数据帧通过这个端口时也可以通过。如果一个不带vlan 的数据帧通过,那么将会被这个端口打上vlan 10 tag。这种端口的存在就是为了多个vlan的跨越交换机进行传递。

    也可以看出,这两种链路方式恰好对应两种端口方式,理解起来也不算困难。原理理解了,当看到交换机时,配置几遍就完全明白了。

    access和truck 主要是区分VLAN中交换机的端口类型

    truck端口为与其它交换机端口相连的VLAN汇聚口,access端口为交换机与VLAN域中主机相连的端口。

    trunk一般是打tag标记的,一般只允许打了该tag标记的vlan 通过,所以该端口可以允许多个打tag标记的vlan 通过,而access端口一般是untag不打标记的端口,而且一个access vlan端口只允许一个access vlan通过。

    access,trunk,hybid是三种端口属性;

    具有access性质的端口只能属于一个vlan,且该端口不打tag;

    具有trunk性质的端口可以属于多个vlan,且该端口都是打tag的;

    具有hybid性质的端口可以属于多个vlan,至于该端口在vlan中是否打tag由用户根据具体情况而定;

    交换机三种端口模式Access、Hybrid和Trunk的理解

    端口有三种模式:access,hybrid,trunk。access性质的端口只能属于一个vlan,且该端口不打tag,trunk可以属于多个vlan,可以接收和发送多个vlan的报文,一般用于交换机之间的连接;hybrid也可以属于多个vlan,可以接收和发送多个vlan的报文,可以用于交换机之间的连接也可以用于交换机和用户计算机之间的连接。trunk和hybrid的区别主要是,hybrid端口可以允许多个vlan的报文不打标签,而 trunk端口只允许缺省vlan的报文不打标签,同一个交换机上不能hybrid和trunk并存。

    最后至于交换机这个端口如何如何配置,这里以华为举个例子。

    将端口加入到vlan中:

    [Quidway] interface GigabitEthernet2/0/1 (10G光口)

    [Quidway- GigabitEthernet2/0/1] port link-type access //定义端口传输模式

    [Quidway- GigabitEthernet2/0/1] port default vlan 100 //将端口加入vlan100

    [Quidway- GigabitEthernet2/0/1] quit 回到配置视图返回搜狐,查看更多

    责任编辑:

    展开全文
  • 很多人朋友多次问到华为交换机配置,确实用的比较多,上次我们有单独提到h3c交换机的配置,今天我们来了解下华为交换机配置,以及以太网的三种链路方式。为了让大家更加清楚,每行代码都有解释。一、华为交换机...

    很多人朋友多次问到华为交换机的配置,确实用的比较多,上次我们有单独提到h3c交换机的配置,今天我们来了解下华为交换机的配置,以及以太网的三种链路方式。

    为了让大家更加清楚,每行代码都有解释。

    一、华为交换机的基本配置

    1、创建vlan:  //用户视图,也就是在Quidway模式下运行命令。system-view   //进入配置视图 [Quidway] vlan 10    //创建vlan 10,并进入vlan10配置视图,如果vlan10存在就直接进入vlan10配置视图 [Quidway-vlan10] quit   //回到配置视图 [Quidway] vlan 100 //创建vlan 100,并进入vlan100配置视图,如果vlan10存在就直接进入vlan100配置视图

    [Quidway-vlan100] quit //回到配置视图

    2、将端口加入到vlan中:[Quidway] interface GigabitEthernet2/0/1    (10G光口) [Quidway- GigabitEthernet2/0/1] port link-type access //定义端口传输模式 [Quidway- GigabitEthernet2/0/1] port default vlan 100 //将端口加入vlan100 [Quidway- GigabitEthernet2/0/1] quit  回到配置视图

    [Quidway] interface GigabitEthernet1/0/0 //进入1号插槽上的第一个千兆网口配置视图中。0代表1号口 [Quidway- GigabitEthernet1/0/0] port link-type access //定义端口传输模式 [Quidway- GigabitEthernet2/0/1] port default vlan 10 //将这个端口加入到vlan10中 [Quidway- GigabitEthernet2/0/1] quit 3、将多个端口加入到VLAN中

    system-view [Quidway]vlan 10 [Quidway-vlan10]port GigabitEthernet 1/0/0 to 1/0/29   //将0到29号口加入到vlan10中 [Quidway-vlan10]quit华为下的这个命令自己现在不知道,找了下答案也没有结果。

    4、交换机配置IP地址

    [Quidway] interface Vlanif100  // 进入vlan100接口视图与vlan 100命令进入的地方不同 [Quidway-Vlanif100] ip address 119.167.200.90 255.255.255.252 // 定义vlan100管理IP三层 交换网关路由 [Quidway-Vlanif100] quit   返回视图[Quidway] interface Vlanif10 // 进入vlan10接口视图与vlan 10命令进入的地方不同 [Quidway-Vlanif10] ip address 119.167.206.129 255.255.255.128 // 定义vlan10管理IP三层交换网关路由

    [Quidway-Vlanif10] quit

    配置默认网关:

    [Quidway]ip route-static 0.0.0.0 0.0.0.0 119.167.200.89 //配置默认网关。

    5、 交换机保存设置和重置命令

    save //保存配置信息 reset saved-configuration /重置交换机的配置 reboot //重新启动交换机

    6、交换机常用的显示命令

    用户视图模式下:display current-configuration //显示现在交换机正在运行的配置明细 display device //显示S9303各设备状态 display interface ?//显示个端口状态,用?可以查看后边跟的选项 display version //查看交换机固件版本信息 display vlan ?// 查看vlan的配置信息

    7、恢复交换机出厂设置

    reset saved-configuration /重置交换机的配置

    二、基于端口的vlan划分方法

    这里面为了方便大家理解,直接用实例讲解更清楚。

    1、组网需求如图1所示,某企业的交换机连接有很多用户,且相同业务用户通过不同的设备接入企业网络。为了通信的安全性,也为了避免广播报文泛滥,企业希望业务相同用户之间可以互相访问,业务不同用户不能直接访问。

    可以在交换机上配置基于端口划分VLAN,把业务相同的用户连接的端口划分到同一VLAN。

    也就是不同VLAN的用户不能直接进行二层通信,同一VLAN内的用户可以直接互相通信。

    2、配置步骤

    步骤1 在SwitchA创建VLAN2和VLAN3,并将连接用户的端口分别加入VLAN。SwitchB配置与SwitchA类似,不再赘述。

    [Quidway] system-view          //进入配置视图[Quidway] sysname SwitchA   //给交换机命名[SwitchA] vlan batch 2 3          //同时创建vlan2与vlan3[SwitchA] interface ethernet 0/0/1   //进入端口0/0/1[SwitchA-Ethernet0/0/1] port link-type access   //设置端口模式为access[SwitchA-Ethernet0/0/1] port default vlan 2      //将端口加入vlan2中[SwitchA-Ethernet0/0/1] quit   //退出[SwitchA] interface ethernet 0/0/2   //进入端口0/0/2[SwitchA-Ethernet0/0/2] port link-type access  //端口模式为access[SwitchA-Ethernet0/0/2] port default vlan 3    //将端口加入vlan3中[SwitchA-Ethernet0/0/2] quit   //退出

    步骤2 配置SwitchA上与SwitchB连接的端口类型及通过的VLAN。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA] interface ethernet 0/0/3//进入端口0/0/3[SwitchA-Ethernet0/0/3] port link-type trunk//设置端口模式为trunk[SwitchA-Ethernet0/0/3] port trunk allow-pass vlan 2 3//trunk口允许通过vlan2与vlan3的数据包

    步骤3 验证配置结果将User1和User2配置在一个网段,比如192.168.100.0/24;将User3和User4配置在一个网段,比如192.168.200.0/24。

    User1和User2能够互相ping通,但是均不能ping通User3和User4。User3和User4能够互相ping通,但是均不能ping通User1和User2。

    三、以太网的3种链接类型

    以太网的三种链接类型:

    以太网端口有 3种链路类型:access、trunk、hybird

    Access类型端口:只能属于1个VLAN,一般用于连接计算机端口;

    Trunk类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,

    一般用于交换机与交换机相关的接口。

    Hybrid类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,

    可以用于交换机的间连接也可以用于连接用户计算机。

    什么是链路类型?vlan的链路类型可以分为接入链路和干道链路。1、接入链路(access link)指的交换机到用户设备的链路,即是接入到户,可以理解为由交换机向用户的链路。由于大多数电脑不能发送带vlan tag的帧,所以这段链路可以理解为不带vlan tag的链路。2、干道链路(trunk link)指的交换机到上层设备如路由器的链路,可以理解为向广域网走的链路。这段链路由于要靠vlan来区分用户或者服务,所以一般都带有vlan tag。

    什么是端口类型?端口类型在以前主要分为两种,基本上用的也是access和trunk这两种端口。1、access端口:它是交换机上用来连接用户电脑的一种端口,只用于接入链路。例如:当一个端口属于vlan 10时,那么带着vlan 10的数据帧会被发送到交换机这个端口上,当这个数据帧通过这个端口时,vlan 10 tag 将会被剥掉,到达用户电脑时,就是一个以太网的帧。而当用户电脑发送一个以太网的帧时,通过这个端口向上走,那么这个端口就会给这个帧加上一个vlan 10 tag。而其他vlan tag的帧则不能从这个端口上下发到电脑上。

    2、trunk端口:这个端口是交换机之间或者交换机和上层设备之间的通信端口,用于干道链路。一个trunk端口可以拥有一个主vlan和多个副vlan,这个概念可以举个例子来理解:例如:当一个trunk端口有主vlan 10 和多个副vlan11、12、30时,带有vlan 30的数据帧可以通过这个端口,通过时vlan 30不被剥掉;当带有vlan 10的数据帧通过这个端口时也可以通过。如果一个不带vlan 的数据帧通过,那么将会被这个端口打上vlan 10 tag。这种端口的存在就是为了多个vlan的跨越交换机进行传递。

    也可以看出,这两种链路方式恰好对应两种端口方式,理解起来也不算困难。原理理解了,当看到交换机时,配置几遍就完全明白了。

    access和truck 主要是区分VLAN中交换机的端口类型truck端口为与其它交换机端口相连的VLAN汇聚口,access端口为交换机与VLAN域中主机相连的端口。trunk一般是打tag标记的,一般只允许打了该tag标记的vlan 通过,所以该端口可以允许多个打tag标记的vlan 通过,而access端口一般是untag不打标记的端口,而且一个access vlan端口只允许一个access vlan通过。

    access,trunk,hybid是三种端口属性;具有access性质的端口只能属于一个vlan,且该端口不打tag;具有trunk性质的端口可以属于多个vlan,且该端口都是打tag的;具有hybid性质的端口可以属于多个vlan,至于该端口在vlan中是否打tag由用户根据具体情况而定;

    交换机三种端口模式Access、Hybrid和Trunk的理解端口有三种模式:access,hybrid,trunk。access性质的端口只能属于一个vlan,且该端口不打tag,trunk可以属于多个vlan,可以接收和发送多个vlan的报文,一般用于交换机之间的连接;hybrid也可以属于多个vlan,可以接收和发送多个vlan的报文,可以用于交换机之间的连接也可以用于交换机和用户计算机之间的连接。trunk和hybrid的区别主要是,hybrid端口可以允许多个vlan的报文不打标签,而 trunk端口只允许缺省vlan的报文不打标签,同一个交换机上不能hybrid和trunk并存。

    最后至于交换机这个端口如何如何配置,这里以华为举个例子。

    将端口加入到vlan中:

    [Quidway] interface GigabitEthernet2/0/1    (10G光口)[Quidway- GigabitEthernet2/0/1] port link-type access  //定义端口传输模式[Quidway- GigabitEthernet2/0/1] port default vlan 100  //将端口加入vlan100[Quidway- GigabitEthernet2/0/1] quit回到配置视图

    展开全文
  • 详解华为交换机中的批量处理端口配置(思科中叫端口配置),即快速配置具有相同配置的接口。 创建端口组名称 port-group name #命令用来创建Port Group名称。 undo port-group name #命令用来删除Port Group名称。...

    详解华为交换机中的批量处理端口的配置(思科中叫端口组配置),即快速配置具有相同配置的接口。

    1、创建端口组名称

    port-group name       #命令用来创建Port Group名称。
    undo port-group name  #命令用来删除Port Group名称。
    display port-group    #命令用来查看永久端口组的成员接口信息。
    

    在这里插入图片描述

    2、在端口组里面添加成员

    group-member        #命令将指定的以太网接口添加到端口组中。
    

    在这里插入图片描述

    2、查看端口组里面成员

    [Huawei-port-group-all_port_access]dis this
    #
    port-group all_port_access
     group-member GigabitEthernet0/0/1
     group-member GigabitEthernet0/0/2
    #
    return
    [Huawei-port-group-all_port_access]
    

    3、在端口组里面删除成员

    undo group-member    #命令将指定的以太网接口从端口组中删除。
    

    在这里插入图片描述

    4、给端口组配置命令

    例如:将all_port_access端口组中的接口模式设置为access模式。
    进入端口组后命令:

    port link-type access
    

    在这里插入图片描述

    展开全文
  • 华为交换机端口hybird端口属性配置

    万次阅读 2018-06-02 13:32:08
    华为交换机的端口hybrid端口属性配置交换机端口链路类型介绍交换机以太网端口共有三种链路类型:Access、Trunk和Hybrid。l Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;l Trunk类型的端口可以...

    华为交换机的端口hybrid端口属性配置

    1 交换机端口链路类型介绍

    交换机以太网端口共有三种链路类型:AccessTrunkHybrid

    l         Access类型的端口只能属于1VLAN,一般用于连接计算机的端口;

    l         Trunk类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;

    l         Hybrid类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。

    其中,Hybrid端口和Trunk端口的相同之处在于两种链路类型的端口都可以允许多个VLAN的报文发送时打标签;不同之处在于Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    三种类型的端口可以共存在一台以太网交换机上,但Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其他类型端口。例如:Trunk端口不能直接被设置为Hybrid端口,只能先设为Access端口,再设置为Hybrid端口。

    2 各类型端口使用注意事项

    配置Trunk端口或Hybrid端口,并利用Trunk端口或Hybrid端口发送多个VLAN报文时一定要注意:本端端口和对端端口的缺省VLAN ID(端口的PVID)要保持一致。

    当在交换机上使用isolate-user-vlan来进行二层端口隔离时,参与此配置的端口的链路类型会自动变成Hybrid类型

    Hybrid端口的应用比较灵活,主要为满足一些特殊应用需求。此类需求多为在无法下发访问控制规则的交换机上,利用Hybrid端口收发报文时的处理机制,来完成对同一网段的PC机之间的二层访问控制。

    3各类型端口在接收和发送报文时的处理

    1)      端口接收报文时的处理: 

    端口接收到的报文类型

    报文帧结构中携带VLAN标记

    报文帧结构中不携带VLAN标记

    Access端口

    丢弃该报文

    为该报文打上VLAN标记为本端口的PVID

    Trunk端口

    判断本端口是否允许携带该VLAN标记的报文通过。如果允许则报文携带原有VLAN标记进行转发,否则丢弃该报文

    同上

    Hybrid端口

    同上

    同上

    2)      端口发送报文时的处理: 

    Access端口

    剥掉报文所携带的VLAN标记,进行转发

    Trunk端口

    首先判断报文所携带的VLAN标记是否和端口的PVID相等。如果相等,则剥掉报文所携带的VLAN标记,进行转发;否则报文将携带原有的VLAN标记进行转发

    Hybrid端口

    首先判断报文所携带的VLAN标记在本端口需要做怎样的处理。如果是untagged方式转发,则处理方式同Access端口;
    如果是tagged方式转发,则处理方式同Trunk端口

    Tag通常是对进入端口的报文打上标签,untagged则是对出端口的报文去除标签。

    简记: Access端口只连接到计算机,此种类型的端口只能和相同vlan-id主机通信;连接到计算机,从计算机接收报文时打上标记,发送到计算机剥离标记;

    Trunk端口常用于交换机之间的连接,可以接收和发送多个vlan-id标记的报文,即多种标签报文混合在trunk管道上混跑,只有允许的才可以发送和接收。发送和接收都携带报文标签。可设置一个PVID标签,与此PVID相同的VLAN-ID数据,接收加上PVID,发送剥离此PVID.

    Hybrid端口可连接计算机,也可以连接在交换机之间。Hybrid端口连接到计算机时,都要在hybrid命令后加上untagged,因为计算机的网卡是不能接收带标签报文的。虽然hybrid端口在声明时,只声明其属于某一个vlan,但如果在hybrid命令后加上多个vlan-id,如:

    [Qw_A-Eth 0/1]port hybrid vlan 20 30 100 untagged

    则表明该vlan可以和多个vlan-id的主机通信。这是和access端口不相同的地方。这个有点类似于把一个主机划分到多个vlan中,或者更准确地讲,一个vlan内主机可以和多个vlan通信。当Hybrid端口用于连接在交换机之间时,则与trunk端口一样使用。

    功能需求和组网实例说明

    功能需求及组网说明实例一:

    华为交换机的端口hybrid端口属性配置

     

    『配置环境参数』

    1.        PC1PC2PC3分别连接到二层交换机SwitchA的端口E0/1 E0/2 E0/3,端口分属于VLAN102030,服务器连接到端口G2/1,属于VLAN100

    2.        PC1IP地址为10.1.1.1/24PC2IP地址为10.1.1.2/24PC3IP地址为10.1.1.3/24,服务器的IP地址为10.1.1.254/24

    『组网需求』

    1.        PC1PC2之间可以互访;

    2.        PC1PC3之间可以互访;

    3.        PC1PC2PC3都可以访问服务器;

    4.        其余的PC间访问均禁止。

    『交换机Hybrid端口配置流程』

    利用Hybrid端口的特性――一个端口可以属于多个不同的VLAN来完成分属不同VLAN内的同网段PC机的访问需求。

    『图1配置过程』

    SwitchA相关配置】

    1.        创建(进入)VLAN10,将E0/1加入到VLAN10
    [SwitchA]vlan 10
    [SwitchA-vlan10]port Ethernet 0/1     E0/1加到了VLAN10

    2.        创建(进入)VLAN20,将E0/2加入到VLAN20
    [SwitchA]vlan 20
    [SwitchA-vlan20]port Ethernet 0/2

    3.        创建(进入)VLAN30,将E0/3加入到VLAN30
    [SwitchA]vlan 30
    [SwitchA-vlan30]port Ethernet 0/3

    4.        创建(进入)VLAN100,将G2/1加入到VLAN100
    [SwitchA]vlan 100
    [SwitchA-vlan100]port GigabitEthernet 2/1

    5.        配置端口E0/1Hybrid端口,能够接收VLAN2030100发过来的报文
    [SwitchA]interface Ethernet 0/1

    [SwitchA-Ethernet0/1]port link-type hybrid

              前面E0/1加到了VLAN10中,这里又将其端口类型设置为hybrid

    [SwitchA-Ethernet0/1]port hybrid vlan 20 30 100 untagged

    这里对vlan 10没有作操作指示,10实际上是该hybrid端口的PVID

    6.        配置端口E0/2Hybrid端口,能够接收VLAN10100发过来的报文
    [SwitchA]interface Ethernet 0/2
    [SwitchA-Ethernet0/2]port link-type hybrid
    [SwitchA-Ethernet0/2]port hybrid vlan 10 100 untagged

    7.        配置端口E0/3Hybrid端口,能够接收VLAN10100发过来的报文
    [SwitchA]interface Ethernet 0/3
    [SwitchA-Ethernet0/3]port link-type hybrid
    [SwitchA-Ethernet0/3]port hybrid vlan 10 100 untagged

    8.        配置端口G2/1Hybrid端口,能够接收VLAN102030发过来的报文
    [SwitchA]interface GigabitEthernet 2/1
    [SwitchA-GigabitEthernet2/1]port link-type hybrid
    [SwitchA-GigabitEthernet2/1]port hybrid vlan 10 20 30 untagged 

    【补充说明】

    对于Hybrid端口来说,可以同时属于多个VLAN。这些VLAN分别是该Hybrid端口的PVID,以及手工配置的”untagged””tagged”方式的VLAN。一定要注意对应端口的VLAN配置,保证报文能够被端口进行正常的收发处理。

         此应用在二层网络中,对相同网段的主机进行访问权限的控制。

    功能需求及组网说明实例二:

    华为交换机的端口hybrid端口属性配置

    『配置环境参数』

    1.        PC1PC2PC3分别连接到二层交换机SwitchA的端口E0/1 E0/2 E0/3,端口分属于VLAN102030PC4PC5分别连接到二层交换机SwitchB的端口E0/1E0/2,端口分属于VLAN1020

    2.        SwitchA通过端口G2/1,连接到SwitchB的端口G1/1SwitchA的端口G2/1SwitchB的端口G1/1不是Trunk端口;

    3.        PC1IP地址为10.1.1.1/24PC2IP地址为10.1.1.2/24PC3IP地址为10.1.1.3/24PC4IP地址为10.1.1.4/24PC5IP地址为10.1.1.5/24

    『组网需求』

    1.        PC1PC3之间可以互访;

    2.        PC2PC3之间可以互访;

    3.        PC1PC4之间可以互访;

    4.        PC2PC5之间可以互访;

    5.        其余PC之间均禁止互相访问。

    『图2配置过程』

    SwitchA相关配置】

    1.        创建(进入)VLAN10,将E0/1加入到VLAN10
    [SwitchA]vlan 10
    [SwitchA-vlan10]port Ethernet 0/1

    2.        创建(进入)VLAN20,将E0/2加入到VLAN20
    [SwitchA]vlan 20
    [SwitchA-vlan20]port Ethernet 0/2

    3.        创建(进入)VLAN30,将E0/3加入到VLAN30
    [SwitchA]vlan 30
    [SwitchA-vlan30]port Ethernet 0/3

    4.        配置端口E0/1Hybrid端口,能够接收VLAN30发过来的报文
    [SwitchA]interface Ethernet 0/1
    [SwitchA-Ethernet0/1]port link-type hybrid
    [SwitchA-Ethernet0/1]port hybrid vlan 30 untagged

    5.        配置端口E0/2Hybrid端口,能够接收VLAN30发过来的报文
    [SwitchA]interface Ethernet 0/2
    [SwitchA-Ethernet0/2]port link-type hybrid
    [SwitchA-Ethernet0/2]port hybrid vlan 30 untagged

    6.        配置端口E0/3Hybrid端口,能够接收VLAN1020发过来的报文
    [SwitchA]interface Ethernet 0/3
    [SwitchA-Ethernet0/3]port link-type hybrid
    [SwitchA-Ethernet0/3]port hybrid vlan 10 20 untagged

    7.        配置端口G2/1Hybrid端口,能够接收并透传VLAN1020发过来的报文
    [SwitchA]interface GigabitEthernet 2/1
    [SwitchA-GigabitEthernet2/1]port link-type hybrid
    [SwitchA-GigabitEthernet2/1]port hybrid vlan 10 20 tagged

        G2/1设置为Hybrid端口,且其功能等效于Trunk,可以不把它加入到某个VLAN中,同时要带标签传输不同vlan标签的报文

    SwitchB相关配置】

    1.        创建(进入)VLAN10,将E0/1加入到VLAN10
    [SwitchA]vlan 10
    [SwitchA-vlan10]port Ethernet 0/1

    2.        创建(进入)VLAN20,将E0/2加入到VLAN20
    [SwitchA]vlan 20
    [SwitchA-vlan20]port Ethernet 0/2

    3.        配置端口G1/1Hybrid端口,能够接收并透传VLAN1020发过来的报文
    [SwitchA]interface GigabitEthernet 2/1
    [SwitchA-GigabitEthernet2/1]port link-type hybrid
    [SwitchA-GigabitEthernet2/1]port hybrid vlan 10 20 tagged

     

    功能需求及组网说明实例三:

    华为交换机的端口hybrid端口属性配置

    『配置环境参数』

    1.      交换机E0/1E0/2属于vlan10

    2.      交换机E0/3属于vlan20

    3.      交换机E0/4E0/5属于vlan30

    4.      交换机E0/23连接Server1

    5.      交换机E0/24连接Server2

    6.      Server1Server2分属于vlan40vlan50

    7.      PCServer都在同一网段

    8.      E0/10连接BAS设备,属于vlan60

    『组网需求』

    1.      利用二层交换机端口的hybrid属性灵活实现vlan之间的灵活互访;

    2.       Vlan10vlan20vlan30PC均可以访问Server 1;

    3.       vlan 10、20以及vlan30的4端口的PC可以访问Server 2;

    4.       vlan 10中的2端口的PC可以访问vlan 30的PC;

    5.       vlan 20的PC可以访问vlan 30的5端口的PC;

    6.       vlan10的PC访问外网需要将vlan信息送到BAS,而vlan2030则不需要。

    『端口hybrid属性配置流程』

    hybrid属性是一种混杂模式,实现了在一个untagged端口允许报文以tagged形式送出交换机。同时可以利用hybrid属性定义分属于不同的vlan的端口之间的互访,这是accesstrunk端口所不能实现的。在一台交换机上不允许trunk端口和hybrid端口同时存在。

    1.      先创建业务需要的vlan

    [SwitchA]vlan 10

    [SwitchA]vlan 20

    [SwitchA]vlan 30

    [SwitchA]vlan 40

    [SwitchA]vlan 50

    2.      每个端口,都配置为 hybrid状态

    [SwitchA]interface Ethernet 0/1

    [SwitchA-Ethernet0/1]port link-type hybrid 

    3.      设置端口的pvid等于该端口所属的vlan

    [Switch-Ethernet0/1]port hybrid pvid vlan 10 

    4.      将希望可以互通的端口的pvid vlan,设置为untagged vlan,这样从该端口发出的广播帧就可以到达本端口

    [Switch-Ethernet0/1]port hybrid vlan 10 40 50 60 untagged

     

    实际上,这种配置是通过 hybrid 端口的 pvid 来唯一的表示一个端口,接收端口通过是否将 vlan 设置为 untagged vlan,来控制是否与 pvid vlan   vlan 的端口互通。

    5.      以下各端口类似:

    [Switch-Ethernet0/1]int e0/2

    [Switch-Ethernet0/2]port link-type hybrid

    [Switch-Ethernet0/2]port hybrid pvid vlan 10

    [Switch-Ethernet0/2]port hybrid vlan 10 30 40 50 60 untagged

     

    [Switch-Ethernet0/2]int e0/3

    [Switch-Ethernet0/3]port link-type hybrid

    [Switch-Ethernet0/3]port hybrid pvid vlan 20

    [Switch-Ethernet0/3]port hybrid vlan 20 30 40 50 60 untagged

    [Switch-Ethernet0/3]int e0/4

    [Switch-Ethernet0/4]port link-type hybrid

    [Switch-Ethernet0/4]port hybrid pvid vlan 30

    [Switch-Ethernet0/4]port hybrid vlan 10 30 40 50 60 untagged

     

    [Switch-Ethernet0/4]int e0/5

    [Switch-Ethernet0/5]port link-type hybrid

    [Switch-Ethernet0/5]port hybrid pvid vlan 30

    [Switch-Ethernet0/5]port hybrid vlan 10 20 30 40 60 untagged

     

    [Switch-Ethernet0/5]int e0/23

    [Switch-Ethernet0/23]port link-type hybrid

    [Switch-Ethernet0/23]port hybrid pvid vlan 40

    [Switch-Ethernet0/23]port hybrid vlan 10 20 30 40 untagged

     

    [Switch-Ethernet0/24]int e0/24

    [Switch-Ethernet0/24]port link-type hybrid

    [Switch-Ethernet0/24]port hybrid pvid vlan 50

    [Switch-Ethernet0/24]port hybrid vlan 10 20 30 50 untagged

     

    6.      在上行口E0/10上允许vlan10tagged形式送出,其它为untagged

    [SwitchA]interface Ethernet 0/10

    [SwitchA-Ethernet0/10]port link-type hybrid

    [SwitchA-Ethernet0/10]port hybrid pvid vlan 60

    [SwitchA-Ethernet0/10]port hybrid vlan 10 tagged

    [SwitchA-Ethernet0/10]port hybrid vlan 20 30 untagged

    本例中需求比较复杂

    展开全文
  • 华为交换机端口的批量配置命令

    千次阅读 2021-02-11 20:38:21
    华为交换机端口的批量配置命令如何在华为交换机上进行批量管理端口呢,例如同时将多个端口加入到一个vlan中,下面yjbys为大家介绍华为交换机批量管理端口的方法!欢迎参考学习!首先在S5700交换机上创建一个端口组...
  • 求助,华为交换机肿么屏蔽445端口acl number 3000 rule 1 deny tcp destination-port eq 445 rule 5 deny udp destination-port eq 445华为交换机接口怎么建了接口组答:华为的一样,华为的配置做trunk的配置是...
  • 华为交换机基本配置命令

    千次阅读 2020-12-24 08:23:32
    [Huawei]intg0/0/1[Huawei]portlink-typeaccess(注:接口类型access,hybrid、trunk)[Huawei]portdefaultvlan10批量端口放入VLAN[Huawei]port-group1[Huawei-port-group-1]group-memberethernetG0/0/1...
  • 在IOS输入命令时只要缩写的程度不会引起混淆,使用配置命令的时候都可以使用缩写的形式。比如:Switch>enable,在用户模式下以en开头的命令就只有enable,所以可以缩写成Switch>en。也可以用TAB键把命令自动...
  • 华为交换机端口配置
  • 华为交换机批量配置端口

    千次阅读 2020-01-03 22:54:10
    acces类型 [Huawei]vlan 10 [Huawei]port-group group-member Ethernet 0/0/1 to Ethernet 0...[Huawei-port-group]port link-type access //端口类型 [Huawei-port-group]port default vlan 10 //将端口划分为vlan1...
  • 交换机端口有三种工作模式,分别是Access,Hybrid,Trunk。 Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口; Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机...
  • 华为交换机如何快速配置多个端口,多个VLAN故障描述:  思科交换机可以用int range命令来配置多个端口,华为产品有没有类似的命令 处理过程:  华为S23,S33,S53,S27,S37,S57,S77,S93系列交换机可以通过创建...
  • Access类型:端口只能属于1个VLAN,一般用于连接计算机;.. Trunk类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接;.. Hybrid类型:端口可以属于多个VLAN,可以接收和发送多个...
  • 华为交换机的基本配置1、创建vlan: //用户视图,也就是在Quidway模式下运行命令。system-view //进入配置视图[Quidway] vlan 10 //创建vlan 10,并进入vlan10配置视图,如果vlan10存在就直接进入vlan10配置视图...
  • 交换机端口链路类型介绍 交换机以太网端口共有三种链路类型:Access、Trunk和Hybrid。 l Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口; l Trunk类型的端口可以属于多个VLAN,可以接收和发送...
  • 华为交换机批量处理端口配置(端口配置)

    万次阅读 多人点赞 2019-11-14 21:48:29
    创建端口组名称 port-group 名称(命令用来创建Port Group名称) [Huawei]port-group 1-24 undo port-group 名称(命令用来删除Port Group名称) [Huawei]undo port-group 1-24 display port-group(令用来查看永久端口...
  • TRUNK是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于这几个端口的带宽合并,给端口提供一个几倍于独立端口的独享的高...
  • 华为交换机端口速率

    千次阅读 2020-12-20 14:19:56
    看懂用好华为交换机端口信息在遇见下面这样情况的时候一般大家会采取何种方法去判断? 1、交换机某一端口下的用户出现丢包 2、交换机下所有用户都在丢包 3、用户......来源: /sosofa/blog/item/7a595ccf270e503bf9dc...
  • 因为根据有些群朋友反映,华为交换机使用的比较多,所以本次以华为交换机为例,如果大家以前对vlan了解深,那么这篇文章却是可以很好入门与深入。一、什么样的网络才能互通通常情况下,两台电脑如何能...
  • 无论如何配置,就是能将端口有trunk改为access 后面发现这样配置,就可以将端口更改: 用下面两条命令就可以更改端口类型 [Huawei-GigabitEthernet0/0/1]undo port trunk allow-pass vlan all //取消trunk...
  • 创建端口组2,该组内端口配置access模式,且默认vlan为20,具体命令如下:[Huawei]port-group 2 [Huawei-port-group-2]group-member Ethernet 0/0/11 to Ethernet 0/0/22[Huawei-port-group-2]port link-type ...
  • 华为交换机配置常用命令

    千次阅读 2021-01-17 02:41:42
    华为交换机配置常用命令一、配置软件和硬件1、配置(Console)电缆连接配置电缆是一根8芯屏蔽电缆,一端是压接的RJ-45连接器,插入交换机的Console口里;另一端则同时带有一个DB-9(孔)和DB-25(孔)连接器2、配置软件及...
  • 只能属于一个vlan,且该端口不打tag; Trunk类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文;具有trunk性质的端口可以属于多个vlan,且该端口都是打tag的;一般用于交换机交换机相关的接口。 Hybrid...
  • 华为交换机基本配置命令详解

    千次阅读 2020-12-24 08:24:45
    1:配置登录用户,口令等 //用户直行模式提示符,用户视图system-view //进入配置视图[Quidway] //配置视图(配置密码后必须输入密码才可进入配置视图)[Quidway] sysname xxx //设置主机名成为xxx这里使用[Quidway] ...
  • 一、服务器环境和交换机环境 1、服务器 ubuntu18 4.15.0-159-generic 2、交换机 Huawei Versatile Routing Platform Software VRP (R) software, Version 5.170 (S5720 V200R010C00SPC600) Copyright (C) 2000-...
  • 满意答案lzz86226322013.10.05...(HUAWEI S3000)配置过程(// 后面为注释)1.改变中文模式language-mode chinese //习惯英语的可以不用此步骤2.进入系统试图system-view3.设置特权密码:super password cipher NIME...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,399
精华内容 1,759
关键字:

华为交换机端口不配置access