精华内容
下载资源
问答
  • 现要把连接在SwitchA上的User1和连接在SwitchB上的User2都划分VLAN 2中,而把连接在SwitchA上的User3和连接在SwitchB上的User4都划分VLAN 3中。方案一:用户端口采用Access类型,交换机间连接端口采用Tru...

    图所示为一个小型企业局域网示例,拓扑结构中的两台交换机(SwitchA 和SwitchB)上各连接了许多进行不同业务操作的用户。现要把连接在SwitchA上的User1和连接在SwitchB上的User2都划分到VLAN 2中,而把连接在SwitchA上的User3和连接在SwitchB上的User4都划分到VLAN 3中。

    593ce7ae5d321e2d8bce49a38cd5054a.png

    方案一:用户端口采用Access类型,交换机间连接端口采用Trunk类型(1)在SwitchA创建VLAN2和VLAN3,并将连接用户的端口类型都设置为Access类型,然后分别加入对应的VLAN中。SwitchB配置与SwitchA类似。

    system-view

    [HUAWEI]sysname SwitchA

    [SwitchA]vlan batch 2 3 !---批量创建VLAN 2和VLAN 3

    [SwitchA]interface gigabitethernet 1/0/1

    [SwitchA-GigabitEthernet1/0/1]port link-type access !---设置gigabitethernet1/0/1接口为Access类型

    [SwitchA-GigabitEthernet1/0/1]port default vlan 2 !---把gigabitethernet1/0/1接口加入到VLAN 2中

    [SwitchA-GigabitEthernet1/0/1]quit

    [SwitchA] interface gigabitethernet 1/0/2

    [SwitchA-GigabitEthernet1/0/2]port link-type access

    [SwitchA-GigabitEthernet1/0/2]port default vlan 3

    [SwitchA-GigabitEthernet1/0/2]quit

    (2)配置SwitchA与SwitchB连接的端口类型为Trunk,同时允许VLAN 2和VLAN 3通过。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA] interfacegigabitethernet 1/0/3

    [SwitchA-GigabitEthernet1/0/3]port link-type trunk

    [SwitchA-GigabitEthernet1/0/3]port trunk allow-pass vlan 2 to 3

    方案二:用户端口采用 Access 类型,交换机间连接端口采用带标签的 Hybrid类型。(1)把用户加入对应的VLAN中,配置方法同方案一中的第(1)步配置。(2)配置SwitchA与SwitchB连接的端口类型为Hybrid,并以Tagged(带标签)方式同时加入VLAN 2和VLAN 3中。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA]interfacegigabitethernet 1/0/3

    [SwitchA-GigabitEthernet1/0/3]port link-type hybrid

    [SwitchA-GigabitEthernet1/0/3]port hybrid Tagged vlan 2 to 3

    方案三:用户端口采用不带标签的 Hybrid 类型,交换机间连接端口采用 Trunk类型。(1)在SwitchA创建VLAN2和VLAN3,并将连接用户的端口类型都设置为Hybrid类型,然后分别以Untagged方式加入对应的VLAN中,并且把对应的VLAN ID设置这些Hybrid端口的PVID。SwitchB配置与SwitchA类似。

    system-view[HUAWEI]sysname SwitchA

    [SwitchA]vlan batch 2 3

    [SwitchA]interface gigabitethernet 1/0/1

    [SwitchA-GigabitEthernet1/0/1]port link-type hybrid !---设置gigabitethernet1/0/1接口为Hybrid类型

    [SwitchA-GigabitEthernet1/0/1]port hybrid Untagged vlan 2 !---把gigabitethernet 1/0/1接口以Untagged方式加入到VLAN 2中

    [SwitchA-GigabitEthernet1/0/1]port hybrid pvid vlan 2 !---设置gigabitethernet1/0/1接口的PVID为VLAN 2

    [SwitchA-GigabitEthernet1/0/1]quit

    [SwitchA]interface gigabitethernet 1/0/2

    配置方法同方案二中的第(2)步配置。验证配置结果如下。将User1和User2配置在一个网段,比如192.168.100.0/24;将User3和User4配置在一个网段,比如192.168.200.0/24。经测试,证明User1和User2能够互相ping通,但是均不能ping通User3和User4。User3和User4能够互相ping通,但是均不能ping通User1和User2。由此可确认配置是正确并成功的。

    展开全文
  • 华为交换机单独加入vlan太麻烦,思科交换机有批量加入vlan的方法,当然华为也有。要求 1~6口划分vlan2,6~12口划分vlan3,13~18口划分vlan4,19~24口划分vlan5.25,~26 加入trunk.1、创建vlan 2~vlan4,4个vlan...

    华为交换机单独加入vlan太麻烦,思科交换机有批量加入vlan的方法,当然华为也有。要求 1~6口划分到vlan2,6~12口划分到vlan3,13~18口划分到vlan4,19~24口划分到vlan5.25,~26 加入trunk.

    1、创建vlan 2~vlan4,4个vlan

    806bb073f53f9bf4cf4e449c646e0604.png

    创建vlan 2~vlan4,4个vlan

    也可以使用命令 batch 2 to 5

    2、端口port1~port6划分到vlan2

    [HW2700-2]port-group g2

    [HW2700-2-port-group-g2]group-member Ethernet 0/0/1 to Ethernet 0/0/6 选择1~6 端口

    [HW2700-2-port-group-g2]port link-type access 接口为access口,显示1~6口设置为access类型

    c834b3e118c7314a7cac3e4bd535ff3f.png

    端口port1~port6划分到vlan2

    [HW2700-2-port-group-g2]port default vlan 2 端口组所有端口加入vlan2.

    [HW2700-2]dis vlan 显示vlan信息

    204ba25c53da0bb32e300119715ba505.png

    显示vlan信息

    3、port7~port12加入vlan3.

    [HW2700-2]port-group g3

    [HW2700-2-port-group-g3]group-member Ethernet 0/0/6 to Ethernet 0/0/12

    [HW2700-2-port-group-g3]port link-type access 所有接口配置为access类型

    [HW2700-2-port-group-g3]port default vlan 3 显示如下

    369667f73aeae6402e08dd0ad3ddbe81.png

    显示vlan信息

    4、同理,端口1318,19~24分别划分到vlan4,vlan5方法相同。

    [HW2700-2]dis vlan 显示vlan信息如下:

    c0344e4fca96bf7ae727031bf910aade.png

    显示vlan信息

    5、端口25~26口为光口电口复用端口,配置trunk.

    [HW2700-2]dis interface brief 查看所有端口信息

    6adb84bcfbe035313d41c1d37ce8adce.png

    查看所有端口信息

    [HW2700-2]port-group g6

    [HW2700-2-port-group-g6]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/2 选择2端口

    [HW2700-2-GigabitEthernet0/0/1]port link-type trunk 端口G0 /0/1~G0/0/2 加入trunk.

    display current-configuration

    c6a8f093aad5bbac6115d04a78591e4b.png

    已经是trunk了。

    展开全文
  • 现要把连接在SwitchA上的User1和连接在SwitchB上的User2都划分VLAN 2中,而把连接在SwitchA上的User3和连接在SwitchB上的User4都划分VLAN 3中。方案一:用户端口采用Access类型,交换机间连接端口采用Tru...

    图所示为一个小型企业局域网示例,拓扑结构中的两台交换机(SwitchA 和SwitchB)上各连接了许多进行不同业务操作的用户。现要把连接在SwitchA上的User1和连接在SwitchB上的User2都划分到VLAN 2中,而把连接在SwitchA上的User3和连接在SwitchB上的User4都划分到VLAN 3中。

    08cf3f916ba68809b4f95baf369993b7.png

    方案一:用户端口采用Access类型,交换机间连接端口采用Trunk类型(1)在SwitchA创建VLAN2和VLAN3,并将连接用户的端口类型都设置为Access类型,然后分别加入对应的VLAN中。SwitchB配置与SwitchA类似。

    system-view

    [HUAWEI]sysname SwitchA

    [SwitchA]vlan batch 2 3 !---批量创建VLAN 2和VLAN 3

    [SwitchA]interface gigabitethernet 1/0/1

    [SwitchA-GigabitEthernet1/0/1]port link-type access !---设置gigabitethernet1/0/1接口为Access类型

    [SwitchA-GigabitEthernet1/0/1]port default vlan 2 !---把gigabitethernet1/0/1接口加入到VLAN 2中

    [SwitchA-GigabitEthernet1/0/1]quit

    [SwitchA] interface gigabitethernet 1/0/2

    [SwitchA-GigabitEthernet1/0/2]port link-type access

    [SwitchA-GigabitEthernet1/0/2]port default vlan 3

    [SwitchA-GigabitEthernet1/0/2]quit

    (2)配置SwitchA与SwitchB连接的端口类型为Trunk,同时允许VLAN 2和VLAN 3通过。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA] interfacegigabitethernet 1/0/3

    [SwitchA-GigabitEthernet1/0/3]port link-type trunk

    [SwitchA-GigabitEthernet1/0/3]port trunk allow-pass vlan 2 to 3

    方案二:用户端口采用 Access 类型,交换机间连接端口采用带标签的 Hybrid类型。(1)把用户加入对应的VLAN中,配置方法同方案一中的第(1)步配置。(2)配置SwitchA与SwitchB连接的端口类型为Hybrid,并以Tagged(带标签)方式同时加入VLAN 2和VLAN 3中。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA]interfacegigabitethernet 1/0/3

    [SwitchA-GigabitEthernet1/0/3]port link-type hybrid

    [SwitchA-GigabitEthernet1/0/3]port hybrid Tagged vlan 2 to 3

    方案三:用户端口采用不带标签的 Hybrid 类型,交换机间连接端口采用 Trunk类型。(1)在SwitchA创建VLAN2和VLAN3,并将连接用户的端口类型都设置为Hybrid类型,然后分别以Untagged方式加入对应的VLAN中,并且把对应的VLAN ID设置这些Hybrid端口的PVID。SwitchB配置与SwitchA类似。

    system-view[HUAWEI]sysname SwitchA

    [SwitchA]vlan batch 2 3

    [SwitchA]interface gigabitethernet 1/0/1

    [SwitchA-GigabitEthernet1/0/1]port link-type hybrid !---设置gigabitethernet1/0/1接口为Hybrid类型

    [SwitchA-GigabitEthernet1/0/1]port hybrid Untagged vlan 2 !---把gigabitethernet 1/0/1接口以Untagged方式加入到VLAN 2中

    [SwitchA-GigabitEthernet1/0/1]port hybrid pvid vlan 2 !---设置gigabitethernet1/0/1接口的PVID为VLAN 2

    [SwitchA-GigabitEthernet1/0/1]quit

    [SwitchA]interface gigabitethernet 1/0/2

    配置方法同方案二中的第(2)步配置。验证配置结果如下。将User1和User2配置在一个网段,比如192.168.100.0/24;将User3和User4配置在一个网段,比如192.168.200.0/24。经测试,证明User1和User2能够互相ping通,但是均不能ping通User3和User4。User3和User4能够互相ping通,但是均不能ping通User1和User2。由此可确认配置是正确并成功的。

    展开全文
  • 华为交换机和其他品牌的交换机在端口vlan划分上有一些区别,今天就和大家详细说说华为交换机端口vlan属性~按照IEEE802.1Q标准,vlan帧的格式如下:此处的Tag就是vlan tag,即我们常说的vlan标签。具体含义如下:...

    华为交换机和其他品牌的交换机在端口的vlan划分上有一些区别,今天就和大家详细说说华为交换机的端口vlan属性~

    3d2c9555dcf9430cc63634ae0a1932f1.gif

    按照IEEE802.1Q标准,vlan帧的格式如下:

    1a7e9317742722bc2c8013a2db192e19.png

    此处的Tag就是vlan tag,即我们常说的vlan标签。

    具体含义如下:

    ①TPID为固定值0x8100,表明加了一个vlan标签

    ②PRI为优先级,0~7

    ③CFI,取0表示为规范格式,取1表示非规范格式

    ④vlan ID为vlan号,取值范围1-4094

    首先提一个概念,即PVID(Port Vlan ID),这是端口的一个基本属性,可手动设置,默认值为1。其次,所有的以太网帧在交换机中进行处理得时候,都是按照上图格式来进行处理得,即帧都是带了vlan tag的。

    华为交换机的端口有三种模式,分别是access,trunk,hybrid。

    9b4eee2a62734171316fd176c654ce64.gif

    access

    1、access端口接收帧时:

    ①如果接收的帧有vlan tag时,该帧的vlan ID和access端口的PVID相同时,将改帧送入交换机;该帧的vlan ID和access端口的PVID不同时,丢弃帧。

    ②如果接收的帧没有vlan tag时,access端口会将该帧打上vlan tag,vlan ID即为本端口的PVID,送入交换机。

    2、access端口发送帧时:

    access端口只能发送vlan ID和端口PVID相同的帧,发送出去时会剥掉vlan tag。

    例子:

    [Huawei-GigabitEthernet0/0/3]port link-type access

    [Huawei-GigabitEthernet0/0/3]port default vlan 10

    此时该端口为access端口,PVID为10。

    该端口只能发送vlan ID为10的帧,发送出来的帧没有vlan tag。

    该端口可以接收vlan ID为10的帧(如交换机传出的帧);也可以接收没有vlan tag的帧(如PC传出的帧),此帧将打上vlan tag(vlan ID=10)传入交换机。

    28c922cdf7b05eda2855c44573a1aa81.gif

    trunk

    1、trunk端口接收帧时:

    ①接收没有vlan tag的帧,trunk端口将帧打上vlan tag,vlan ID和本端口的PVID相同,若该PVID在trunk端口的放行vlan中,送入交换机,若PVID不在trunk端口的放行vlan中,丢弃该帧。

    ②接收有vlan tag的帧,若帧的vlan ID在trunk端口的放行vlan中,送入交换机,若vlan ID不在trunk端口的放行vlan中,丢弃该帧。

    2、trunk端口发送帧时:

    trunk端口只能发送放行vlan中的帧,若该帧的vlan ID和trunk的PVID相同,则剥掉vlan tag发送;若该帧的vlan ID和trunk的PVID不同,则保留原有vlan tag发送。

    例子

    [Huawei-GigabitEthernet0/0/4]port link-type trunk

    [Huawei-GigabitEthernet0/0/4]port trunk pvid vlan 5

    [Huawei-GigabitEthernet0/0/4]port trunk allow-pass vlan 10 20 30

    此时该端口为trunk端口,PVID为5,放行vlan为10,20,30。

    该端口可以发送vlan ID为10,20,30的帧,发送出去的帧时有vlan tag的。

    该端口可以接收vlan ID为10,20,30的帧。

    [Huawei-GigabitEthernet0/0/5]port link-type trunk

    [Huawei-GigabitEthernet0/0/5]port trunk pvid vlan 5

    [Huawei-GigabitEthernet0/0/5]port trunk allow-pass vlan 5 10 20 30

    此时该端口为trunk端口,PVID为5,放行vlan为5,10,20,30。

    该端口可以发送vlan ID,5,10,20,30的帧,发送vlan ID为10、20、30的帧,帧是有vlan tag的;发送vlan ID为5的帧,帧时没有vlan tag的。

    该端口可以接收vlan ID为5,10,20,30的帧,也可以接收没有vlan tag的帧。

    28c922cdf7b05eda2855c44573a1aa81.gif

    hybrid

    1、hybrid端口接收帧时:

    ①接收没有vlan tag的帧,hybrid端口将帧打上vlan tag,vlan ID和本端口的PVID相同,若该PVID在hybrid端口的放行vlan中,送入交换机,若PVID不在hybrid端口的放行vlan中,丢弃该帧。

    ②接收有vlan tag的帧,若帧的vlan ID在hybrid端口的放行vlan中,送入交换机,若vlan ID不在hybrid端口的放行vlan中,丢弃该帧。

    2、hybrid端口发送帧时:

    hybrid端口只能发送放行vlan中的帧,可以通过命令来控制发送时是否携带vlan tag。

    例子:

    [Huawei-GigabitEthernet0/0/6]port hybrid pvid vlan 10

    [Huawei-GigabitEthernet0/0/6]port hybrid tagged vlan 10 20 30

    [Huawei-GigabitEthernet0/0/6]port hybrid untagged vlan 100 200 300

    此端口为hybrid端口,PVID为10,放行的vlan有10、20、30、100、200、300。

    端口接收帧时同trunk是一样。

    端口发送帧时,vlan ID为10、20、30的帧时有vlan tag的;vlan ID为100、200、300的帧时没有vlan tag的。

    展开全文
  • 创建vlan [S1]vlan 10 [S1-vlan10]quit 给vlan配置IP地址 [S1]interface Vlanif 10 [S1-Vlanif10]ip address 192.168.1.1 24 将单个端口加入到vlan中 [S1]interface GigabitEthernet...
  • 华为交换机基于端口划分vlan

    万次阅读 2016-01-19 15:32:16
    1. 像集线器一样,交换机提供了大量可供线缆连接的端口,这样可以采用星型拓扑布线。 2. 像中继器、集线器和网桥那样,当它转发帧时,交换机会重新产生一个不失真的方形电信号。 3. 像网桥那样,交换机在每...
  • 华为交换机和其他品牌的交换机在端口vlan划分上有一些区别,本文将介绍华为交换机端口vlan属性。 按照IEEE802.1Q标准,vlan帧的格式如下: 此处的Tag就是vlan tag,即我们常说的vlan标签,具体含义如下: ①TPID...
  • 关注我,你的眼睛会怀孕华为交换机和其他品牌的交换机在端口vlan划分上有一些区别,今天就和大家详细说说华为交换机端口vlan属性~按照IEEE802.1Q标准,vlan帧的格式如下:此处的Tag就是vlan tag,即我们常说的...
  • 关注「开源Linux」,选择“设为星标”回复「学习」,有我为您特别筛选的学习资料~华为交换机和其他品牌的交换机在端口vlan划分上有一些区别,今天就和大家详细说说华为交换机端口vlan...
  • 华为交换机三种划分vlan的方法在学习划分vlan前,必须要了解华为交换机端口类型:Access类型端口执行命令portdefaultvlanvlan-id,将端口加入到指定的VLAN中。如果需要批量将端口加入VLAN,可在VLAN视图下执行命令...
  • 华为交换机和其他品牌的交换机在端口vlan划分上有一些区别,今天就和大家详细说说华为交换机端口vlan属性~按照IEEE802.1Q标准,vlan帧的格式如下:此处的Tag就是vlan tag,即我们常说的vlan标签。具体含义如下:...
  • 华为交换机和其他品牌的交换机在端口vlan划分上有一些区别,今天就和大家详细说说华为交换机端口vlan属性~ 按照IEEE802.1Q标准,vlan帧的格式如下: 此处的Tag就是vlan tag,即我们常说的vlan标签。 ...
  • 华为交换机划分vlan

    千次阅读 2019-10-22 10:19:41
    端口划分vlan 1:先进入系统视图(system) 2:为交换机命名(sysname加交换机名字) 3:创建vlan(VLAN batch空格加要创建的vlan,如单创一个vlan2就vlan batch 2,如果要创建1到10个VLANvlan batch 1 to 10) 4:...
  • VLAN(Virtual Local Area Network,虚拟局域网)是将一个物理以太网结构在逻辑上划分成多个广播域的通信...在交换机上配置基于接口划分VLAN,把业务相同的用户的接口划分到同一VLAN。实现不同VLAN的不能进行二层通信
  • 1端口类型在学习划分vlan前,必须要了解华为交换机端口类型,以及他们的使用方法,因为端口的类型在实际配置中是必须会用到的,因为下面的vlan划分会用到。1、Access类型端口执行命令port default vlan vlan-id,...
  • 方案一:用户端口采用Access类型,而交换机连接的端口采用Trunk类型 方案二:用户端口采用Access类型,而交换机连接的端口采用带标签的Hybrid类型。 SwitchA配置 interface GigabitEthernet0/0/1 port hybrid ...
  • 华为交换机批量加入 Vlan 方法

    千次阅读 2018-06-21 13:30:00
    华为交换机单独加入vlan太麻烦,思科有批量加入vlan的方法,华为也有。要求 1~6口划分vlan2,6~12口划分vlan3,13~18口划分vlan4,19~24口划分vlan5.25,~26 加入trunk. 创建vlan 2~vlan4,4个vlan也可以使用...
  • 华为交换机VLAN划分

    2017-11-12 19:39:00
    1. 进入系统视图: 1 <Quidway>system-view ...2. 创建vlan: ...[Quidway]vlan10 ...[Quidway]portg0/0/1to0/0/10#把相应的端口加入到该vlan中 3. 回到系统视图: 1 [Quidway]qu...
  • 实验步骤要配置 VLAN,首先要先创建 VLAN,然后才把交换机端口划分到特定的端口上:(1) 步骤 1:在划分 VLAN 前,配置 R1 和 R2 路由器的 g0/0 接口,从 R1 ping 192.168.12.2。默认时,交换机的全部接口都在 ...
  • 前面我们发布了华为交换机的基本配置,这篇内容是华为交换机的基本配置,...端口类型在学习划分vlan前,必须要了解华为交换机端口类型,以及他们的使用方法,因为端口的类型在实际配置中是必须会用到的,因为下面...
  • 原标题:【技术】华为交换机常用的三种vlan划分方法前面我们发布了华为交换机的基本配置,这篇内容是华为交换机的基本配置,今天...端口类型在学习划分vlan前,必须要了解华为交换机端口类型,以及他们的使用方法...
  • 华为交换机基本配置命令交换机是按照通信两端传输信息的需要,用...一、单交换机VLAN划分命令 命令解释system 进入系统视图system-view 进入系统视图quit 退到系统视图undo vlan 20 删除vlan 20sysname 交换机命名d...
  • 原标题:什么是vlan?华为交换机常用的三种vlan划分方法前面我们发布了华为交换机的基本配置,这篇内容是华为交换机的基本配置,今天我们...端口类型在学习划分vlan前,必须要了解华为交换机端口类型,以及他们的...
  • 华为交换机vlan划分常用命令

    千次阅读 2017-02-09 14:24:54
    进入视图 system-view进入接口interface (Ethernet|GigabitEthernet) (0/0/1-0/0/48)配置端口为trunk模式 port link-type trunk配置trunk允许通过的V...
  • 进入视图 system-view进入接口interface (Ethernet|GigabitEthernet) (0/0/1-0/0/48)配置端口为trunk模式 port link-type trunk配置trunk允许通过的Vlan vla...
  • 案例1:划分VLAN 案例2:多交换机VLAN的划分 案例3:配置trunk中继链路 案例4:链路聚合配置 案例5:配置静态路由 案例6:三层交换机基本配置 1 案例1:划分VLAN 1.1 问题 在交换机上创建以下VLAN,按照...

空空如也

空空如也

1 2 3 4 5 ... 11
收藏数 202
精华内容 80
关键字:

华为交换机端口划分vlan