精华内容
下载资源
问答
  • 华为交换机端口聚合使用实例,华为交换机命令配置使用
  • 华为镜像端口基础配置命令.
  • 华为交换机基础配置命令参考

    万次阅读 多人点赞 2019-03-24 10:06:03
    华为交换机基础配置命令参考 基础配置 用户模式 登陆设备后,直接进入用户模式,只能执行少量查看配置的命令; 视图模式 用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令; 局部配置...

    华为交换机基础配置命令参考

    基础配置

    用户模式

    登陆设备后,直接进入用户模式,只能执行少量查看配置的命令;

     

    视图模式

    用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令;

     

    局部配置模式

    视图模式下,输入局部配置命令,如interface GE 1/0/0,进入GE1/0/0端口配置模式,

     

    此外局部配置模式有很多种,可根据不同需求进入vlan配置模式、端口聚合配置模式等,可输入?,查看当前模式下,能执行哪些命令;

     

    输入quit返回上一层配置模式,输入commit提交已有配置,用户模式下输入save保存配置;

     

     

    查看设备信息

    <HUAWEI>display version

     

    其中关键信息有:

    软件版本:Version 8.130 (S6800 V800R013C00SPC560B560)

    设备型号:HUAWEI S6800

    运行时间:0 day, 0 hour, 15 minutes

     

    查看和修改系统时间

    <HUAWEI>display clock

    <HUAWEI>clock datetime 12:00:00 2018-01-01

     

     

    修改设备名称

    <HUAWEI>system-view

    [~HUAWEI]sysname CE6800

    如果没有commit,需退出一次系统视图模式后保存;

     

     

     配置设备说明信息

    添加登录设备说明内容,举例:Only the administrator can configure the equipment

    [*CE6800]header shell information "Only the administrator can configure the equipment!"

     

    退出视图模式后可见

     

     

    配置console登录认证方式及超时时间

    Console登录:默认console登录无密码,任何人通过串口线直连设备console接口,可直接修改配置,管理员可配置console密码,登录不需要用户名,初次配置时使用console;

     

    超时时间:指连接设备后,一段时间内无操作,系统自动退出,需重新登录,默认超时时间为10min;

     

    进入console配置模式

    [*CE6800]user-interface console 0

     

    Console认证方式为password

    [*CE6800-ui-console0]authentication-mode password

     

    设置console密码为密文形式huawei@123

    [*CE6800-ui-console0]set authentication password cipher huawei@123

     

    设置超时时间为20min

    [*CE6800-ui-console0]idle-timeout 20 0

     

    使用quit返回视图模式,保存后使用display this检查配置结果,乱码是加密后的密码;

     

     

    Telnet 配置

    配置密文登录验证

    进入vty配置模式,0 4表示允许5个并发telnet连接

    [~CE6800]user-interface vty 0 4

     

    指定认证方式为password,出现要求使用aaa认证提示信息,暂时忽略

    [~CE6800-ui-vty0-4]authentication-mode password

     

     

    配置telnet使用密文认证,密码Gauss_234

    [*CE6800-ui-vty0-4]set authentication password cipher Gauss_234

     

    配置用户等级3,缺省为级别1

    [*CE6800-ui-vty0-4]user privilege level 3

     

    退出保存后,使用display this查看配置

     

     

    用户等级说明

    LEVEL 0(访问级):可以执行用于网络诊断等功能的命令。包括ping、tracert、telnet等命令,执行该级别命令的结果不能被保存到配置文件中。
    LEVEL 1(监控级):可以执行用于系统维护、业务故障诊断等功能的命令。包括debugging、terminal等命令,执行该级别命令的结果不能被保存到配置文件中。
    LEVEL 2(系统级):可以执行用于业务配置的命令,主要包括路由等网络层次的命令,用于向用户提供网络服务。
    LEVEL 3(管理级):最高级,可以运行所有命令:关系到系统的基本运行、系统支撑模块功能的命令,这些命令对业务提供支撑作用。包括文件系统、FTP、TFTP、XModem下载、用户管理命令、级别设置命令等。

     

    注:某些型号设备用户等级有0-15级,区分更细,其中15级与LEVEL 3权限一致,配置时需依据具体情况而定。

     

    配置aaa登录认证

    aaa认证

    authentication(认证)、authorization(授权)、accounting(计费)的简称,是网络安全的一种管理机制;Authentication是本地认证/授权,authorization和accounting是由远处radius(远程拨号认证系统)服务或hwtacacs(华为终端访问控制系统)服务器完成认证/授权;

     

    进入vty配置模式

    [~CE6800]user-interface vty 0 4

     

    退出vty配置模式后,进入aaa配置模式

    [*CE6800]aaa

     

    配置本地用户huawei密码为密文Gauss_234

    [*CE6800-aaa]local-user huawei password cipher Gauss_234

     

    配置huawei用户服务类型为telnet

    [*CE6800-aaa]local-user huawei service-type telnet

     

    配置huawei用户特权等级15(模拟器不支持此配置,只有用户等级0-3)

    [*CE6800-aaa]local-user huawei privilege level 15

     

    配置完成后查看结果,其中aaa认证模式无特殊要求,均采用默认模式

     

     

    telnet登录时会要求输入username和password

    配置设备超级密码

    超级密码

    在用户权限较低时(例如Telnet登陆时,可以定义权限级别为0戒1),此时

    可以使用super命令迚行权限提升。为避免非法权限提升带来的危害,应该配置

    超级密码迚行防护。

     

    为CE6800设置超级密码,密码以simple(明文)方式存储(模拟器不支持)

    [*CE6800]super password simple huawei

     

    保存及查看配置

    保存所有配置信息,先提交后保存

    [~CE6800]commit

    <CE6800>save

     

     

    查看已保存的所有配置

    [*CE6800]display saved-configuration

     

    查看当前所有配置

    [*CE6800]display current-configuration

     

     

    IP及路由配置

    配置接口IP

    拓扑图如下:

     

    CE6800配置

    [*CE6800]undo portswitch batch GE 1/0/0                                                  GE 1/0/0开启三层转发

    [*CE6800]interface GE 1/0/0                                                                       进入接口配置模式

    [*CE6800-GE1/0/0]ip address 10.0.12.1 24                                                配置IP及netmask

    [*CE6800-GE1/0/0]description this port connect to CE12800 GE 1/0/0      添加端口说明(可选)

    [*CE6800-GE1/0/0]undo shutdown                                                             激活接口

    [*CE6800-GE1/0/0]quit                                                                               退出接口配置模式

    [*CE6800]commit                                                                                        提交配置

     

    保存后查看配置:

     

     

    CE12800配置

    配置GE 1/0/0地址为10.0.12.1 24

    其余配置与CE6800相同,查看配置结果如下

     

     

    从CE6800 ping 对端CE12800,测试连通性

     

     

    配置静态路由

    接上一个案例,拓扑图如下:

     

    目标:让CE6800能ping通CE6850上的8.0.10.2

     

    在CE12800上,配置GE 1/0/1接口IP为8.0.10.1/24

     

     

    在CE6850上,配置GE 1/0/0 接口IP为8.0.10.2/24

     

     

    网络连通后,尝试从CE6800 ping CE6850上的8.0.10.2,结果ping不通;

    查看CE6800路由表,没有去往8.0.10.0/24的路由

     

     

    在CE6800上添加去往8.0.10.0/24的静态路由,下一跳地址应为CE12800上的10.0.12.2

    [*CE6800]ip route-static 8.0.10.0 24 10.0.12.2

     

    再尝试从CE6800 ping CE6850上的8.0.10.2,结果仍然ping不通,

    原因是CE6850没有去往10.0.12.0/24网段的路由,导致ping数据包“有去无回”;

    在CE6850上添加去往10.0.12.0/24的静态路由,下一跳地址应为CE12800上的8.0.10.1

    [~CE6850]ip route-static 10.0.12.0 24 8.0.10.1

     

    提交保存后,CE6800可以ping通CE6850上的8.0.10.2;

     

    查看CE6800、CE12800及CE6850路由表,分别如下图

     

     

    注意到Proto字段,有两种类型:Direct直连和Static静态,

    其中CE12800路由均为直连,Pre字段为0,

    而CE6800和CE6850有两条静态路由,Pre字段为60,

    Pre表示路由优先级,越小越优,路由会优先匹配;

     

    华为路由器默认协议优先级如下表

     

    其余协议均为动态路由协议,包括:

    OSPF(开放式最短路径优先协议)

    RIP(路由信息协议)

    IS-IS(中间系统到中间系统协议)

    BGP(边界网关协议)

     

    配置默认路由

     

    该拓扑图中,在CE6800和CE6850上配置默认路由,也可以互相ping通,配置示例如下:

     

    CE6800配置:

    [~CE6800]ip route-static 0.0.0.0 0.0.0.0 10.0.12.2

     

    CE6850配置:

    [~HUAWEI]ip route-static 0.0.0.0 0.0.0.0 8.0.10.1

     

    分别查看路由表:

     

     

    利用默认路由,拓扑图中两端设备也可以互相ping通;

     

    配置端口聚合

    LACP协议

    LACP,基于IEEE802.3ax标准的LACP(Link Aggregation Control Protocol,链路汇聚控制协议)是一种实现链路动态汇聚的协议。LACP协议通过LACPDU(Link Aggregation Control Protocol Data Unit,链路汇聚控制协议数据单元)与对端交互信息

     

    静态LACP汇聚由用户手工配置,不允许系统自动添加或删除汇聚组中的端口。汇聚组中必须至少包含一个端口。当汇聚组只有一个端口时,只能通过删除汇聚组的方式将该端口从汇聚组中删除。静态汇聚端口的LACP 协议为使能状态,当一个静态汇聚组被删除时,其成员端口将形成一个或多个动态LACP 汇聚,并保持LACP 使能。禁止用户关闭静态汇聚端口的LACP 协议。

    动态LACP汇聚是一种系统自动创建或删除的汇聚,动态汇聚组内端口的添加和删除是协议自动完成的。只有速率和双工属性相同、连接到同一个设备、有相同基本配置的端口才能被动态汇聚在一起。即使只有一个端口也可以创建动态汇聚,此时为单端口汇聚。动态汇聚中,端口的LACP 协议处于使能状态。

     

    端口聚合配置示例

    拓扑图如下:

     

    CE6850的GE1/0/1~GE1/0/3分别直连对端CE12808的GE1/0/1~GE1/0/3,将三条链路做链路聚合(channel);

     

    CE6850配置如下:

    [~CE6850]interface Eth-Trunk 1                                                进入Eth-Trunk子配置模式,

    [*CE6850-Eth-Trunk1]mode lacp-dynamic                                 选择lacp动态模式

    [*CE6850-Eth-Trunk1]lacp max active-linknumber 1                                          

    [*CE6850-Eth-Trunk1]least active-linknumber 1                                              

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/0

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/1

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/2                                 将三个端口加入Eth-Trunk 1

    [*CE6850-Eth-Trunk1]commit                                                   提交配置

     

    CE12808配置与CE6850相同;

     

    查看Eth-Trunk 1配置

     

     

     

    两端设备的三根连线形成链路聚合,逻辑接口为Eth-Trunk 1

     

    展开全文
  • 华为交换机 display命令 . 
  • 华为交换机端口镜像功能,想要配置端口镜像或者删除端口镜像,该怎么实现呢》下面我们就来看看详细的教程,很简单,需要的朋友可以参考下
  • 查看以太网端口的简要信息,物理端口是否连通,端口是否是全双工,带宽是多少,端口的流入流出的流量百分比。可以排查端口的基本信息,比如有的端口用户网速慢,可以查看该端口的接口速率,是否是全双工状态,是否是...

    一、查看接口状态

    1、显示接口的运行状态和相关信息

    display interface Ethernet brief

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    查看以太网端口的简要信息,物理端口是否连通,端口是否是全双工,带宽是多少,端口的流入流出的流量百分比。可以排查端口的基本信息,比如有的端口用户网速慢,可以查看该端口的接口速率,是否是全双工状态,是否是网卡速率,比如本来是1000M的网卡,但是速率显示的是10M,那么该条链路一定是有问题的。

    2、查看接口的描述信息

    display interface description

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    由上图知悉,直观地看到接口的物理状态和协议状态,以及描述信息,利于了解接口作用。

    3、查看接口状态和配置的简要信息

    display interface brief

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    由上图知悉,每个接口的物理状态,协议状态,流入和流出的流量,输入和输出错误等。

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    4、查看接口与IP相关的简要信息

    display ip interface brief

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    display ip interface description

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    由上图知悉,可以看到包括IP地址、子网掩码、物理链路和协议的Up/Down状态以及处于不同状态的接口数目。

    二、查看接口的统计信息

    1、查看接口的统计信息

    display interface

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    这是一个全面的端口信息,所有的端口都可以查看,涉及到端口的内容都会在这里查询到。

    2、查看接口的流量统计数

    display counters

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    由上图知悉,每个端口的流量,细分为单播,组播,广播流量。

    3、查看错误报文的统计信息

    display counters error

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    4、查看接口的入方向或出方向流量速率

    display counters rate

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    5、查看接口和IP配置的相关信息

    display ip interface

    华为交换机查看端口相关信息常用命令,排查故障法宝,转发收藏

     

    这些查看华为交换机接口的命令,帮助你快速查看交换机接口状态,处理日常故障,熟记最好。

    展开全文
  • 华为各种型号交换机端口镜像配置方法总结
  • 华为交换机基本配置命令大全

    千次阅读 2019-12-02 13:42:16
    查看万兆端口模块收发光:display transceiver interface XGigabitEthernet 1/0/0 verbose 一、单交换机VLAN划分 命令 命令解释 system 进入系统视图 system-view 进入系统视图 quit 退到系统视图 undo vlan ...

    查看万兆端口模块收发光:display transceiver interface XGigabitEthernet 1/0/0 verbose

    一、单交换机VLAN划分

    命令 命令解释

    system 进入系统视图

    system-view 进入系统视图

    quit 退到系统视图

    undo vlan 20 删除vlan 20

    sysname 交换机命名

    disp vlan 显示vlan

    vlan 20 创建vlan(也可进入vlan 20)

    port e1/0/1 to e1/0/5 把端口1-5放入VLAN 20 中

    disp vlan 20 显示vlan里的端口20

    int e1/0/24 进入端口24

    port access vlan 20 把当前端口放入vlan 20

    undo port e1/0/10 表示删除当前VLAN端口10

    disp curr 显示当前配置

    二、配置交换机支持TELNET

    system 进入系统视图

    sysname 交换机命名

    int vlan 1 进入VLAN 1

    ip address 192.168.3.100 255.255.255.0 配置IP地址

    user-int vty 0 4 进入虚拟终端

    authentication-mode password (aut password) 设置口令模式

    set authentication password simple 222 (set aut pass sim 222) 设置口令

    user privilege level 3(use priv lev 3) 配置用户级别

    disp current-configuration (disp cur) 查看当前配置

    disp ip int 查看交换机VLAN IP配置

    删除配置必须退到用户模式

    reset saved-configuration(reset saved) 删除配置

    reboot 重启交换机

    三、跨交换机VLAN的通讯

    在sw1上:

    vlan 10 建立VLAN 10

    int e1/0/5 进入端口5

    port access vlan 10 把端口5加入vlan 10

    vlan 20 建立VLAN 20

    int e1/0/15 进入端口15

    port access vlan 20 把端口15加入VLAN 20

    int e1/0/24 进入端口24

    port link-type trunk 把24端口设为TRUNK端口

    port trunk permit vlan all 同上

    在SW2上:

    vlan 10 建立VLAN 10

    int e1/0/20 进入端口20

    port access vlan 10 把端口20放入VLAN 10

    int e1/0/24 进入端口24

    port link-type trunk 把24端口设为TRUNK端口

    port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

    disp int e1/0/24 查看端口24是否为TRUNK

    undo port trunk permit vlan all 删除该句

    四、路由的配置命令

    system 进入系统模式

    sysname 命名

    int e1/0 进入端口

    ip address 192.168.3.100 255.255.255.0 设置IP

    undo shutdown 打开端口

    disp ip int e1/0 查看IP接口情况

    disp ip int brief 查看IP接口情况

    user-int vty 0 4 进入口令模式

    authentication-mode password(auth pass) 进入口令模式

    set authentication password simple 222 37 设置口令

    user privilege level 3 进入3级特权

    save 保存配置

    reset saved-configuration 删除配置(用户模式下运行)

    undo shutdown 配置远程登陆密码

    int e1/4

    ip route 192.168.3.0(目标网段) 255.255.255.0 192.168.12.1(下一跳:下一路由器的接口) 静态路由

    ip route 0.0.0.0 0.0.0.0 192.168.12.1 默认路由

    disp ip rout 显示路由列表

    华3C AR-18

    E1/0(lan1-lan4)

    E2/0(wan0)

    E3/0(WAN1)

    路由器连接使用直通线。wan0接wan0或wan1接wan1

    计算机的网关应设为路由器的接口地址。

    五、三层交换机配置VLAN-VLAN通讯

    sw1(三层交换机):

    system 进入视图

    sysname 命名

    vlan 10 建立VLAN 10

    vlan 20 建立VLAN 20

    int e1/0/20 进入端口20

    port access vlan 10 把端口20放入VLAN 10

    int e1/0/24 进入24端口

    port link-type trunk 把24端口设为TRUNK端口

    port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

    sw2:

    vlan 10

    int e1/0/5

    port access vlan 10

    int e1/0/24

    port link-type trunk 把24端口设为TRUNK端口

    port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

    sw1(三层交换机):

    int vlan 10 创建虚拟接口VLAN 10

    ip address 192.168.10.254 255.255.255.0 设置虚拟接口VLAN 10的地址

    int vlan 20 创建虚拟接口VLAN 20

    ip address 192.168.20.254 255.255.255.0 设置虚拟接口IP VLAN 20的地址

    注意:vlan 10里的计算机的网关设为 192.168.10.254

    vlan 20里的计算机的网关设为 192.168.20.254

    六、动态路由RIP

    R1:

    int e1/0 进入e1/0端口

    ip address 192.168.3.1 255.255.255.0 设置IP

    int e2/0 进入e2/0端口

    ip adress 192.168.5.1 255.255.255.0 设置IP

    rip 设置动态路由

    network 192.168.5.0 定义IP

    network 192.168.3.0 定义IP

    disp ip rout 查看路由接口

    R2:

    int e1/0 进入e1/0端口

    ip address 192.168.4.1 255.255.255.0 设置IP

    int e2/0 进入e2/0端口

    ip adress 192.168.5.2 255.255.255.0 设置IP

    rip 设置动态路由

    network 192.168.5.0 定义IP

    network 192.168.4.0 定义IP

    disp ip rout 查看路由接口

    (注意:两台PC机的网关设置PC1 IP:192.168.3.1 PC2 IP:192.168.4.1)

    七、IP访问列表

    int e1/0

    ip address 192.168.3.1 255.255.255.0

    int e2/0

    ip address 192.168.1.1 255.255.255.0

    int e3/0

    ip address 192.168.2.1 255.255.255.0

    acl number 2001 (2001-2999属于基本的访问列表)

    rule 1 deny source 192.168.1.0 0.0.0.255 (拒绝地址192.168.1.0网段的数据通过)

    rule 2 permit source 192.168.3.0 0.0.0.255(允许地址192.168.3.0网段的数据通过)

    以下是把访问控制列表在接口下应用:

    firewall enable

    firewall default permit

    int e3/0

    firewall packet-filter 2001 outbound

    disp acl 2001 显示信息

    undo acl number 2001 删除2001控制列表

    扩展访问控制列表

    acl number 3001

    rule deny tcp source 192.168.3.0 0.0.0.255 destination 192.168.2.0 0.0.0.255 destination-port eq ftp

    必须在r-acl-adv-3001下才能执行

    rule permit ip source an destination any (rule permit ip)

    int e3/0

    firewall enable 开启防火墙

    firewall packet-filter 3001 inbound

    必须在端口E3/0下才能执行

    八、命令的标准访问IP列表(三层交换机):

    允许A组机器访问服务器内资料,不允许访问B组机器(服务器没有限制)

    sys

    vlan 10

    name server

    vlan 20

    name teacher

    vlan 30

    name student

    int e1/0/5

    port access vlan 10

    int e1/0/10

    port access vlan 20

    int e1/0/15

    port access vlan 30

    int vlan 10

    ip address 192.168.10.1 255.255.255.0

    undo sh

    int vlan 20

    ip address 192.168.20.1 255.255.255.0

    int vlan 30

    ip address 192.168.30.1 255.255.255.0

    acl number 2001

    rule 1 deny source 192.168.30.0 0.0.0.255

    rule 2 permit source any

    disp acl 2001 查看2001列表

    int e1/0/10

    port access vlan 20

    packet-filter outbound ip-group 2001 rule 1

    出口

    九、允许A机器访问B机器的FTP但不允许访问WWW,C机器没有任何限制。

    vlan 10

    vlan 20

    vlan 30

    int e1/0/5

    port access vlan 10

    int e1/0/10

    port access vlan 20

    int e1/0/15

    port access vlan 30

    int vlan 10

    ip address 192.168.10.1 255.255.255.0

    undo sh

    int vlan 20

    ip address 192.168.20.1 255.255.255.0

    int vlan 30

    ip address 192.168.30.1 255.255.255.0

    acl number 3001

    rule 1 deny tcp source 192.168.30.0 0.0.0.255 destination 192.168.10.0 0.0.0.255 destination-port eq www

    int e1/0/15

    packet-filter inbound ip-group 3001 rule 1

    进口

    十、NAT地址转换(单一静态一对一地址转换)

    R1:

    sys

    sysname R1

    int e1/0

    ip address 192.168.3.1 255.255.255.0

    int e2/0

    ip address 192.1.1.1 255.255.255.0

    R2:

    sys

    sysname R2

    int e2/0

    ip address 192.1.1.2 255.255.255.0

    int e1/0

    ip address 10.80.1.1 255.255.255.0

    回到R1:

    nat static 192.168.3.1 192.1.1.1

    int e2/0

    nat outbound static

    ip route 0.0.0.0 0.0.0.0 192.1.1.2

    十一、NAT内部整网段地址转换

    R1:

    sys

    sysname R1

    int e1/0

    ip address 192.168.3.1 255.255.255.0

    int e2/0

    ip address 192.1.1.1 255.255.255.0

    acl number 2008

    rule 0 permit source 192.168.3.0 0.0.0.255

    rule 1 deny

    quit

    int e2/0

    nat outbound 2008

    quit

    ip route-static 0.0.0.0 0.0.0.0 192.1.1.2 preference 60

    下一个路由接口地址

    R2:

    sys

    sysname R2

    int e2/0

    ip address 192.1.1.2 255.255.255.0

    int e1/0

    ip address 10.80.1.1 255.255.255.0

    NAT地址池配置:

    R1:

    sys

    sysname R1

    int e1/0

    ip address 192.168.3.1 255.255.255.0

    int e2/0

    ip address 192.1.1.1 255.255.255.0

    nat address-group 1 192.1.1.1 192.1.1.5 配置地址池

    undo address-group 1 删除地址池

    acl number 2001 创建访问列表

    rule permit source 192.168.1.0 0.0.0.255

    允许192.168.1.0/24网段地址转换(ethernet2/0指路由器wan口):

    int e2/0

    nat outbound 2001 address-group 1 启用协议

    ip route 0.0.0.0 0.0.0.0 192.1.1.2 默认路由

    R2:

    sys

    sysname R2

    int e1/0

    ip address 10.80.1.1 255.255.255.0

    int e2/0

    ip address 192.1.1.2 255.255.255.0

    AR18-22-8配置命令

    一、vlan配置

    1、vlan划分方案

    -------------------------------------------------- ------------------

    | 部门 | vlan名 | ip地址 | 端口分配 |

    -------------------------------------------------- ------------------

    | J室 | vlan10 | 192.168.10.1/24 | ethernet 3/1 |

    | K室 | vlan20 | 192.168.20.1/24 | ethernet 3/2 |

    | C室 | vlan30 | 192.168.30.1/24 | ethernet 3/3 |

    | Server | vlan40 | 192.168.0.1/24 | ethernet 3/{4,5,6} |

    -------------------------------------------------- ------------------

    2、显示vlan信息的命令

    显示指定VLAN 的相关信息。display vlan vid

    显示指定VLAN 配置的最大处理报文数目。display vlan max-packet-process vid

    显式指定VLAN 的报文统计信息,包括接收和发送的报文数目。display vlan statistics vid vid

    显示某个接口的VLAN 配置信息。display vlan interface interface-type interface-num

    清除指定VLAN 的报文统计信息。reset vlan statistics vid vid

    3、配置物理端口

    配置路由器,进入Ethernet 端口视图,指定端口的链路类型,把端口加入到指定vlan中,注意access端口加入的vlan不能是vlan1。

    # 配置Ethernet3/1

    <H3C> system-view

    H3C interface ethernet 3/1 进入端口1

    H3C-Ethernet3/1 port link-type access 设置端口类型为access

    H3C-Ethernet3/1 port access vlan 10 把该端口加到vlan10中

    H3C-Ethernet3/1 quit

    # 配置Ethernet3/2

    H3C interface ethernet 3/2

    H3C-Ethernet3/2 port link-type access

    H3C-Ethernet3/2 port access vlan 20

    H3C-Ethernet3/2 quit

    # 配置Ethernet3/3

    H3C interface ethernet 3/3

    H3C-Ethernet3/3 port link-type access

    H3C-Ethernet3/3 port access vlan 30

    H3C-Ethernet3/3 quit

    # 配置Ethernet3/4

    H3C interface ethernet 3/4

    H3C-Ethernet3/4 port link-type access

    H3C-Ethernet3/4 port access vlan 40

    H3C-Ethernet3/4 quit

    # 配置Ethernet3/5

    H3C interface ethernet 3/5

    H3C-Ethernet3/5 port link-type access

    H3C-Ethernet3/5 port access vlan 40

    H3C-Ethernet3/5 quit

    # 配置Ethernet3/6

    H3C interface ethernet 3/6

    H3C-Ethernet3/6 port link-type access

    H3C-Ethernet3/6 port access vlan 40

    H3C-Ethernet3/6 quit

    4、配置虚拟端口

    VLAN之间要实现互通,需要配置相应的以太网子接口,即VLAN 对应的路由接口,创建并进入相应的子接口视图,为其配置相应的封装协议和关联的VLAN ID,及IP 地址和掩码,ethernet 3/0 是三层虚拟端口。

    # 配置Ethernet 3/0.1

    H3C interface ethernet 3/0.1 创建并进入子接口

    H3C-Ethernet3/0.1 vlan-type dot1q vid 10 设置以太网子接口的封装类型以及相关联的VLAN ID

    H3C-Ethernet3/0.1 ip address 192.168.10.1 255.255.255.0

    H3C-Ethernet3/0.1 quit

    # 配置Ethernet 3/0.2

    H3C interface ethernet 3/0.2

    H3C-Ethernet3/0.2 vlan-type dot1q vid 20

    H3C-Ethernet3/0.2 ip address 192.168.20.1 255.255.255.0

    H3C-Ethernet3/0.2 quit

    # 配置Ethernet 3/0.3

    H3C interface ethernet 3/0.3

    H3C-Ethernet3/0.3 vlan-type dot1q vid 30

    H3C-Ethernet3/0.3 ip address 192.168.30.1 255.255.255.0

    H3C-Ethernet3/0.3 quit

    # 配置Ethernet 3/0.4

    H3C interface ethernet 3/0.4

    H3C-Ethernet3/0.4 vlan-type dot1q vid 40

    H3C-Ethernet3/0.4 ip address 192.168.0.1 255.255.255.0

    H3C-Ethernet3/0.4 quit

    二、DHCP服务器配置

    1、检测DHCP服务器

    display dhcp server ip-in-use 查看地址池动态地址绑定信息

    display dhcp server conflict 查看DHCP地址冲突的统计信息

    display dhcp server statistics 查看DHCP服务器的统计信息

    display dhcp servertree 查看DHCP地址池结构

    2、具体配置

    #公共配置(server和relay都适用)

    <H3C> system-view 进入系统视图

    H3C dhcp enable 使能DHCP服务

    H3C dhcp server detect 使能伪DHCP服务器检测功能

    #全局地址池配置

    H3C dhcp select global interface ethernet 3/0.1 to ethernet 3/0.4 配置接口工作在DHCP Server模式,从全局地址池分配地址

    H3C dhcp server ip-pool vlan10 创建全局地址池vlan10(最多支持128个全局地址池/路由器)

    H3C-ip-pool network 192.168.10.0 mask 255.255.255.0 配置动态分配的IP地址范围(只可配置1个/地址池)

    H3C-ip-pool expired day 7 hour 23 minute 59 配置租约

    H3C-ip-pool domain-name pearl.cn 配置域名

    H3C-ip-pool dns-list ip-address 192.168.0.6 202.106.0.20 202.106.196.115 配置DNS(最多8个/地址池)

    H3C-ip-pool gateway-list ip-address 192.168.10.1 配置默认网关(最多8个/地址池)

    H3C dhcp server forbidden-ip 192.168.10.1 192.168.10.10 配置保留IP地址范围(可配置多个/地址池)

    H3C dhcp server relay information enable 使能DHCP Server支持option 82

    #接口地址池配置

    H3C dhcp select interface interface ethernet 3/0.1 to ethernet 3/0.4 (指虚拟接口还是指物理接口???)

    配置多个接口工作在DHCP Server模式,从接口地址池分配地址,同时自动创建“接口地址池”

    H3C dhcp server expired day 7 hour 23 minute 59 interface ethernet 3/0.1 to ethernet 3/0.4

    H3C dhcp server domain-name pearl.cn interface ethernet 3/0.1 to ethernet 3/0.4

    H3C dhcp server dns-list ip-address 192.168.0.6 202.106.0.20 202.106.196.115 interface ethernet 3/0.1 to ethernet 3/0.4

    H3C interface ethernet 3/0.1

    H3C-interface gateway-list ip-address 192.168.10.1

    H3C dhcp server forbidden-ip 192.168.10.1 192.168.10.10 (是否接口模式下配??)

    H3C dhcp server relay information enable

    三、NAT配置

    #配置地址池和访问控制列表:

    H3C nat address-group 1 222.128.28.172 222.128.28.174

    H3C acl number 2001

    H3C-acl-basic-2001rule permit source 192.168.0.0 0.0.0.255

    #允许192.168.0.0/24网段地址转换(ethernet3/0指路由器wan口):

    H3C interface ethernet3/0

    H3C-ethernet3/0 nat outbound 2001 address-group 1

    #设置内部FTP服务器:

    H3C-ethernet3/0 nat server protocol tcp global 222.128.28.171 inside 192.168.0.8 ftp

    #设置内部www服务器1:

    H3C-ethernet3/0 nat server protocol tcp global 222.128.28.171 inside 192.168.0.9 www

    #设置内部www服务器2:

    H3C-ethernet3/0 nat server protocol tcp global 222.128.28.171 8080 inside 192.168.0.10 www

    展开全文
  • 华为交换机常用配置命令 1.基本配置命令 <huawei>system-view 进入系统视图模式(即特权模式) [Switch A]sysname Switch A 交换机命名为Switch A [Switch A]vlan 2 创建vlan 2 [Switch A-Vlan2]...

                                    华为交换机常用配置命令

    1.基本配置命令

    首次登陆用户名:admin 密码:admin@huawei.com
    <huawei>system-view        进入系统视图模式(即特权模式)
    [Switch A]sysname Switch A  交换机命名为Switch A
    [Switch A]vlan 2             创建vlan 2

    [Switch A]undo vlan 2  删除vlan 2
    [Switch A-Vlan2]description Market 描述vlan 2
    [Switch A-Vlan2]port ehternet 0/1 to ethernet 0/4 将端口1至4加入vlan2
    [Switch A-Vlan2]ip address 192.168.67.41 255.255.0.0 配置vlan2的ip地址为192.168.67.41 掩码255.255.0.0
    [Switch A-Vlan2]quit         退出vlan2
    [Switch A]interface ethernet 0/5  进入交换机端口5
    [Switch A-Ethernet0/5]port link-type access 当前端口设置access
    [Switch A-Ethernet0/5]port default vlan 10  当前端口配置成vlan 10
    [Switch A-Ethernet0/5]quit    退出端口5



    2.access、trunk、PVID配置
    <Switch A>system-view     进入系统视图模式(即特权模式)
    [Switch A]lvlan 3     创建vlan 3
    [Switch A-vlan3]port ethernet 0/2 将端口2加入vlan 3
    [Switch A-Vlan3]quit         退出vlan2
    [Switch A]interface ethernet0/2  进入交换机端口2
    [Switch A-Ethernet0/2]port access vlan 3  设置vlan 3类型为access

    [Switch A-Ethernet0/2]port link-type trunk 设置端口模式为trunk

    [Switch A-Ethernet0/2]port trunk allow-pass vlan all设置端口允许所有vlan通过

    [Switch A-Ethernet0/2]port trunk pvid vlan 99在端口trunk模式下设置允许单一的vlan通过
    [Switch A-Ethernet0/2]port trunk allow-pass vlan 3 设置vlan 3类型为trunk允许通过端口2
    [Switch A-Ethernet0/2]port hybird pvid vlan 3  设置端口vlan的pvid为vlan 3
    [Switch A-Ethernet0/2]port trunk pvid vlan 3   设置trunk的pvid为vlan 3 
    [Switch A-Ethernet0/2]port trunk pvid vlan 3 list untagged 设置无标识的VLAN ID如果和pvid一致,则去掉vlan信息
    [Switch A-Ethernet0/2]undo shutdown   激活端口
    [Switch A-Ethernet0/2]shut down        关闭端口



    3.Telnet功能设置

    <Switch A>system-view                      进入系统视图(特权模式)

    [Switch A]telnet server enable            开启telnet服务

    [Switch A]user-interface vty 0 4

    [Switch A-ui-vty0-4]protocol inbound telnet    指定VTY用户界面支持的协议为Telnet

    [Switch A-ui-vty0-4]authentication-mode aaa  配置认证方式为aaa

    [Switch A-ui-vty0-4]quit

    [Switch A]aaa

    [Switch A-aaa]local-user admin password irreversible-cipher root@123创建本地用户admin,登录密码为root@123

    [Switch A-aaa]local-user admin service-type telnet  terminal配置本地用户admin的接入类型为telnet方式和串口登录

     



    4.端口模式及流控设置
    <Switch A>system-view   进入系统视图模式(即特权模式)
    [Switch A]interface ethernet 0/1  进入交换机端口1
    [Switch A-Ethernet0/1]duplex {half|full|auto} 交换机端口设置为半双工、双工、自动
    [Switch A-Ethernet0/1]speed {100|10|auto}   设置交换机端口1的传输速率为100M、10M、自动
    [Switch A-Ethernet0/1]flow-control          配置交换机端口流控
    [Switch A-Ethernet0/1]port link-type  {access|trunk|hybrid}     设置交换机端口工作模式
    [Switch A-Ethernet0/1]undo shut down  激活端口
    [Switch A-Ethernet0/1]quit  退出系统视图



    5.配置静态路由
    [Switch A]ip route -static 10.69.1.137 255.255.0.0 10.65.1.2 255.255.0.0 配置交换机路由10.69.1.137至10.65.1.2
    [Switch A]rip    开启三层交换功能
    [Switch A]local-user ftp   开启ftp上传功能



    6.配置生成树、端口聚合
    <Switch A>system-view            进入系统视图模式(即特权模式)
    [Switch A]stp {enable/disable}   开启交换机生成树功能
    [Switch A]stp priority 4096      设置交换机的优先级
    [Switch A]stp root {primary/secondary}    设置交换机为根或者备份根
    [Switch A]interface ethernet0/1            进入交换机端口1
    [Switch A-Ethernet0/1]stp cost 200         设置交换机端口的花费为200
    [Switch A-Ethernet0/1]quit                  退出端口1
    [Switch A]link -aggregation e0/1 to e0/4 ingress|both    将端口1-端口4聚合
    [Switch A]undo link-aggregatuin e/0/1|all      始端口为通道号



    7.配置保存、删除,查看,及交换机重启命令
    <Switch A>system-view    进入系统视图模式(即特权模式)
    [Switch A]display curent-configuration       查看当前配置
    [Switch A]display interfaces                 查看交换机端口信息
    [Switch A]display vlan all                   查看交换机所有vlan
    [Switch A]display version                    查看交换机版本信息
    [Switch A]quit                               退出系统视图模式
    <Switch A>save                               保存当前配置
    [Switch A]reboot                             重启交换机
    [Switch A]reset saved-configuration          清除交换机配置

     

     

     

     

    展开全文
  • 华为交换机限速配置命令2016

    万次阅读 2018-07-19 11:53:00
    1.华为s2300交换机如何配置端口限速 使用QOS命令来配置(网络带宽的10M、100M和1000M的单位是bps(即bit/s,位/秒),而我们通常所说的100M大小的文件,这里的单位是Byte,而1Byte=8bit,显然100M bit=(100/8)M Byte=12.5M ...
  • 华为交换机基本配置命令详解

    千次阅读 多人点赞 2020-12-01 14:00:12
    文章目录华为交换机基本配置命令详解1、配置文件相关命令2、基本配置3、telnet配置4、端口配置5、链路聚合配置6、端口镜像7、VLAN配置8、STP配置9、MAC地址表的操作10、GVRP配置11、DLDP配置12、端口隔离配置13、...
  • 华为交换机单独端口限速

    千次阅读 2019-05-14 15:48:47
    #其实这个速度限制的就是上传速度,通俗局域网内理解为发文件给别人,自身端口上传速度受到了限制。 #做了这个限速以后,在我实际环境中,无论是局域网内发文件给别人,还是上传文件到服务器,速度始终≤1Mb/s ...
  • 华为交换机5720常用命令

    万次阅读 多人点赞 2018-07-17 15:48:17
    (一)交换机的概念  交换机(Switch)意为“开关”是...以太网交换机的结构是每个端口都直接与主机相连,并且一般都工作在全双工方式。交换机能同时连通许多对端口,使每一对相互通信的主机都能像独占通信媒体那...
  • 华为交换机端口及业务的常用查询命令

    万次阅读 多人点赞 2019-11-14 21:29:33
    查看所有接口概要信息: ...[Huawei]dis interface brief PHY: Physical *down: administratively down (l): loopback (s): spoofing (b): BFD down (e): ETHOAM down (dl): DLDP down (d): Dampening Su...
  • 详解华为交换机中的批量处理端口的配置(思科中叫端口组配置),即快速配置具有相同配置的接口。 创建端口组名称 port-group name #命令用来创建Port Group名称。 undo port-group name #命令用来删除Port Group名称。...
  • 华为交换机批量配置端口

    千次阅读 2020-01-03 22:54:10
    [Huawei]port-group group-member Ethernet 0/0/1 to Ethernet 0/0/10 //端口组成员 [Huawei-port-group]port link-type access //端口类型 [Huawei-port-group]port default vlan 10 //将端口划分为vlan1...
  • 1、给交换机划分VLANVlan是虚拟局域网的意思,它相当于一个局域网工作组。“vlan几”可以理解成编号为几的vlan,...下面我将三层交换机的第20个端口添加到vlan 10里,步骤如下:A.在交换机里添加VLAN 10system-view ...
  • 华为交换机安全配置

    2018-12-11 17:56:44
    华为交换机安全配置包括华为交换机安全ACL,端口安全配置命令
  • 首先准备好连接线,网口转RS232线,USB转RS232线,有了这两根线,你可以从笔记本的USB口转到交换机console口 确保连接可靠,打开securecrt软件,进行和下图一模一样的设置 连接后,会显示一片空白,然后回车...
  • 华为交换机配置端口镜像

    万次阅读 2018-01-03 10:11:30
    配置任何一种镜像功能,都需要先将物理端口配置成观察端口。配置观察端口分单个配置和批量配置两种方式。批量配置的观察端口相当于加入了一个观察端口组,在配置镜像端口时,镜像端口会绑定整个观察端口组。因此批量...
  • 华为交换机的端口hybrid端口属性配置 1 交换机端口链路类型介绍 交换机以太网端口共有三种链路类型:Access、Trunk和Hybrid。 l         Access类型的端口...
  • 华为交换机常用查询命令

    千次阅读 2021-04-15 18:12:55
    华为交换机查询常用命令 1.undo info-center enable //华为取消消息提示 2.reset saved-configuration //华为交换机初始化 3.dispaly ip routing-table //查看路由表 4.reset ip pool name xxxx all //释放某个地址...
  • 交换机端口MAC地址绑定命令
  • 华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明
  • 华为交换机常用配置命令

    千次阅读 2020-03-02 22:25:54
    华为交换机常用配置命令
  • 华为交换机批量处理端口

    千次阅读 2020-08-27 16:08:17
    交换机端口在配置vlan过程中,每个端口都需要配置link-type、vlan-tag,如果不批量配置,会非常麻烦; 华为交换机可以通过端口组配置解决这个问题。 1、创建端口组名称: port-group name 命名用来创建Port ...
  • 华为交换机划分vlan

    千次阅读 多人点赞 2019-10-22 10:19:41
    端口划分给vlan 1:先进入系统视图(system) 2:为交换机命名(sysname加交换机名字) 3:创建vlan(VLAN batch空格加要创建的vlan,如单创一个vlan2就vlan batch 2,如果要创建1到10个...5:进入端口后,输入port ...
  • 华为交换机怎么打开端口? 登录进交换机,进入系统视图,命令为:system-view。2、进入以太网端口视图,命令格式: interface interface-type interface-number。 华为交换机查看端口状态的方法 1>将交换机开机,...
  • 华为交换机端口hybird端口属性配置

    万次阅读 2018-06-02 13:32:08
    华为交换机的端口hybrid端口属性配置1 交换机端口链路类型介绍交换机以太网端口共有三种链路类型:Access、Trunk和Hybrid。l Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;l Trunk类型的端口可以...
  • 设备 华为S5735S-S24T4S-A ...1.华为交换机根据已知一个IP查他对应的MAC地址 dis arp | include 192.168.1.11 显示 IP ADDRESS MAC ADDRESS E XPIRE(M) TYPE INTERFACE VPN-INSTANCE VLAN 192.168.1.11

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,396
精华内容 2,558
关键字:

华为交换机进入端口命令