精华内容
下载资源
问答
  • 当我们的配置好交换机之后一般都会配置vlan信息那么在配置玩vlan之后还需要配置vlanif接口IP地址;以便于telnet管理或者是用于作为vlan的网关地址;那么今天小编将指导大家完成华为交换机的vlan配置和vlanif接口的...

    当我们的配置好交换机之后一般都会配置vlan信息那么在配置玩vlan之后还需要配置vlanif接口IP地址;以便于telnet管理或者是用于作为vlan的网关地址;那么今天小编将指导大家完成华为交换机的vlan配置和vlanif接口的配置

    请自行准备好华为交换机和电脑并且让你的电脑和交换机连接上

    使用system-view命令进入[]模式

    创建一个vlan[Quidway]vlan 2

    添加端口[Quidway-vlan2]port Ethernet 0/0/13 to 0/0/15

    然后使用display current查看端口是否属于这个vlan

    当然我们也可以用display vlan来查看vlan信息

    配置vlan IP[Quidway]interface Vlanif 2

    配置vlanif ip地址[Quidway]interface Vlanif 2[Quidway-Vlanif2]ip address 10.10.100.1 255.255.255.0

    配置完成之后再次使用display current 来查看下配置信息如下图能看到vlanif 的ip地址

    完成之后吧你的电脑接入到vlan2的接口上并设置好你的IP地址然后ping 10.10.100.1是否正常如下图

    如果您觉得本经验有帮助,请点击正下方的或右上角的“大拇指”或“分享”或“关注TA”给我支持和鼓励为了方便下次寻找,您可以点击“收藏”收藏本经验

    展开全文
  • 华为交换机配置VLAN和VLANif

    万次阅读 2016-10-20 16:49:56
    那么在配置玩vlan之后还需要配置vlanif接口IP地址;以便于telnet管理或者是用于作为vlan的网关地址; 那么今天小编将指导大家完成华为交换机的vlan配置和vlanif接口的配置 工具/原料 ...

    转自:

    当我们的配置好交换机之后一般都会配置vlan信息

    那么在配置玩vlan之后还需要配置vlanif接口IP地址;以便于telnet管理或者是用于作为vlan的网关地址;

    那么今天小编将指导大家完成华为交换机的vlan配置和vlanif接口的配置

    华为交换机配置VLAN和VLANif

    工具/原料

    • 华为交换机一台
    • 电脑一台

    方法/步骤

    1. 1

      请自行准备好华为交换机和电脑

      并且让你的电脑和交换机连接上

    2. 使用system-view命令

      进入[]模式

      华为交换机配置VLAN和VLANif
    3. 创建一个vlan

      [Quidway]vlan 2

      华为交换机配置VLAN和VLANif
    4. 添加端口

      [Quidway-vlan2]portEthernet 0/0/13 to 0/0/15

      华为交换机配置VLAN和VLANif
    5. 然后使用display current查看端口是否属于这个vlan

      华为交换机配置VLAN和VLANif
    6. 当然我们也可以用display vlan来查看vlan信息

      华为交换机配置VLAN和VLANif
    7. 配置vlan IP

      [Quidway]interface Vlanif 2

      华为交换机配置VLAN和VLANif
    8. 配置vlanif ip地址

      [Quidway]interface Vlanif 2

      [Quidway-Vlanif2]ip address 10.10.100.1 255.255.255.0

      华为交换机配置VLAN和VLANif
    9. 配置完成之后再次使用display current 来查看下配置信息

      如下图能看到vlanif 的ip地址

      华为交换机配置VLAN和VLANif
    10. 完成之后吧你的电脑接入到vlan2的接口上

      并设置好你的IP地址

      然后ping 10.10.100.1是否正常

      如下图

      华为交换机配置VLAN和VLANif


    1、VLAN之间默认是不能够通讯的,除非你的交换机支持路由功能并启了路由功能(是否支持路由功能联系厂家工程师咨询下),或者有路由器设备。可以通过每个VLAN 电脑验证下看否通?如果vLAN之间有路由的话,这时才有必要写ACL;
    2、rule 1 ip permit ip soure any destination 10.1.1.0 0.0.0.255
    把这一条ACL应用到除默认VLAN 1之外的其他VLAN接口,或者物理接口,方向:Outbond
    3、只要交换机开启了路由功能后,就会在交换机上产生所有VLAN的直连路由。因此所有VLAN都可以通讯。要用ACL来限制VLAN间互访。



    展开全文
  • 华为交换机怎么配置VLAN和VLANif接口IP地址华为交换机想要配置VLAN和VLANif,该怎么配置呢?下面我们就来啊看看你详细的教程,需要的朋友可以参考下
  • 华为路由器交换机VLAN配置实例使用4台PC(pc多和少,原理是一样的,所以这里我只用了4台pc),华为路由器(R2621)、交换机(S3026e)各一台,组建一VLAN,实现虚拟网和物理网之间的连接。实现防火墙策略,和访问控制(ACL)...

    华为路由器交换机

    VLAN

    配置实例

    使用

    4

    PC

    (

    pc

    多和少,原理是一样的,所以这里我只用了

    4

    pc

    ),华为路由器(

    R2621

    )、交换机(

    S

    3026e

    )各一台,组建一

    VLAN

    ,实现虚拟网和物理网之间的连接。实现防火墙策略,和访问控制(

    ACL

    )。

    方案说明:

    四台

    PC

    IP

    地址、掩码如下列表:

    P1

    192.168.1.1

    255.255.255.0

    网关

    IP

    192.168.1.5

    P2

    192.168.1.2

    255.255.255.0

    网关

    IP

    192.168.1.5

    P3

    192.168.1.3

    255.255.255.0

    网关

    IP

    192.168.1.6

    P4

    192.168.1.4

    255.255.255.0

    网关

    IP

    192.168.1.6

    路由器上

    Ethernet0

    IP

    192.168.1.5

    Ethernet1

    IP

    192.168.1.6

    firewall

    设置默认为

    deny

    实施命令列表:

    交换机上设置,划分

    VLAN

    sys

    //

    切换到系统视图

    [Quidway]vlan

    enable

    [Quidway]vlan

    2

    [Quidway-vlan2]port

    e0/1

    to

    e0/8

    [Quidway-vlan2]quit

    //

    默认所有端口都属于

    VLAN1,

    指定交换机的

    e0/1

    e0/8

    八个端口属于

    VLAN2

    [Quidway]vlan

    3

    [Quidway-vlan3]port

    e0/9

    to

    e0/16

    [Quidway-vlan3]quit

    //

    指定交换机的

    e0/9

    e0/16

    八个端口属于

    VLAN3

    [Quidway]dis

    vlan

    all

    [Quidway]dis

    cu

    展开全文
  • 按端口划分vlanVlan是二层协议,仅可把二层以太网端口(物理以太网端口和eth-trunk链路口)划分到vlan中,划为交换机以太网端口虽然可以转换为三层模式(undo portswitch),但仍不能直接配置IP地址。二层以太网端口类型...

    阅读本文如有无法理解的地方,建议先阅读前面的vlan理论知识部分

    1、基于接口划分VLAN(静态配置链路类型)

    1.按端口划分vlan

    Vlan是二层协议,仅可把二层以太网端口(物理以太网端口和eth-trunk链路口)划分到vlan中,划为交换机以太网端口虽然可以转换为三层模式(undo portswitch),但仍不能直接配置IP地址。

    二层以太网端口类型

    1、Access端口:

    用来连接用户主机;仅允许一个vlan的帧通过(仅允许加入一个vlan);发送的以太网帧永远是不带标签(untagged)的。

    2、trunk端口:

    与其他交换机二层以太网口相连;允许多个vlan的帧通过;发送的帧都是带标签tagged的,除了发送vlanID与

    PVID(port default vlanID端口缺省vlanID)一致的vlan帧。

    3、Hybrid端口:

    access端口和trunk端口的混合体,具有access端口和trunk端口特性。

    4、QinQ端口:

    二层隧道协议,核心思想是将用户私网vlan封装在公网vlan标签中,这样报文带着两层vlan标签(一个公网vlan标签,一个私网vlan标签)穿越网络运营商的骨干网络,为用户提供一种较为简单的二层VPN隧道。

    交换机内部数据传输都是带vlan标签的(前提是交换机支持vlan);默认情况下二层以太网端口是hybrid类型,以不带vlan标签方式加入vlan1。

    为什么要配置缺省vlan:以太网帧在交换机内部都是以tagged形式处理转发的,因此交换机必须给端口收到的untagged帧加上vlan标签。

    具体配置:

    1、设置端口链路类型

    [Huawei-GigabitEthernet0/0/2]port link-type

    ?

    access        Access port

    dot1q-tunnel  QinQ port

    hybrid        Hybrid port

    trunk         Trunk port

    2、设置端口加入vlan

    2.1 access端口加入vlan

    [Huawei-GigabitEthernet0/0/2]port default

    vlan ?

    INTEGER<1-4094>  VLAN ID

    2.2

    trunk端口加入vlan

    [Huawei-GigabitEthernet0/0/2]port trunk

    pvid vlan ? #缺省vlan

    INTEGER<1-4094>  VLAN ID

    ------------------

    [Huawei-GigabitEthernet0/0/2]port trunk

    allow-pass vlan ? #允许通过的vlan

    INTEGER<1-4094>  VLAN ID

    all              All

    2.3hybrid端口加入vlan

    [Huawei-GigabitEthernet0/0/5]port hybrid

    pvid vlan ?#缺省vlan

    INTEGER<1-4094>  VLAN ID

    ----------

    [Huawei-GigabitEthernet0/0/7]port hybrid

    untagged vlan ?#不带标签端口允许通过的vlan

    INTEGER<1-4094>  VLAN ID

    all              All

    ---------------

    [Huawei-GigabitEthernet0/0/7]port hybrid

    untagged vlan ?#带标签端口允许通过的vlan

    INTEGER<1-4094>  VLAN ID

    all              All

    2.4dot1q-tunne的外层标签

    [Huawei-GigabitEthernet0/0/5]port default

    vlan

    2、基于接口划分VLAN(LNP动态协商链路类型)

    当前,交换机支持的以太网接口的链路类型有:Access、Hybrid、Trunk和Dot1q-tunnel。这四种链路类型分别用于不同的网络位置,均由手工配置指定。

    如果网络拓扑变更,以太网接口的链路类型也需要重新配置,配置较为繁琐。

    为了简化用户配置,可通过自动协商出接口的链路类型为access或者trunk,并加入相应VLAN。

    具体配置

    操作步骤

    1、system-view

    进入系统视图。

    2、undo lnp disable

    全局使能链路类型自协商功能。缺省情况下,全局LNP处于使能状态,此时所有接口的链路类型自协商功能处于使能状态。

    3、interface

    interface-type interface-number

    进入需要使能链路类型自协商功能的以太网接口视图。

    4、undo port

    negotiation disable

    基于二层以太网接口使能链路类型自协商功能。缺省情况下,设备上所有接口的链路类型自协商功能处于使能状态。

    执行该配置时需保证接口是二层接口,如果不是,可通过命令portswitch,设置接口为二层接口。

    当支持链路类型自协商功能的设备和不支持链路类型自协商功能的设备互通时,支持链路类型自协商功能的设备会不断发送自协商报文,导致带宽浪费。此时,可通过在对应的二层以太网接口视图下执行命令port negotiation disable去使能链路类型自协商功能。

    为了保证链路类型自协商功能生效,必须保证全局下和接口视图下的链路类型自协商功能都处于使能状态。

    5、port link-type {

    negotiation-desirable | negotiation-auto }

    设置二层以太网接口的链路类型的自协商方式。缺省情况下,二层以太网接口的链路类型的自协商方式是negotiation-desirable。

    配置为negotiation-desirable或negotiation-auto的接口有以下约束:

    不支持创建子接口

    不支持使能MUX VLAN

    不支持作为VLAN-Switch的源端口或目的端口

    不支持配置自动模式Voice

    VLAN

    6、port trunk

    allow-pass only-vlan { { vlan-id1 [ to vlan-id2 ] } &<1-10> | none }

    配置通过LNP协议自协商为trunk后只允许通过的VLAN。缺省情况下,协商为trunk类型的接口允许所有VLAN通过。

    由于协商为Trunk类型的接口缺省会加入所有VLAN,因此需要配置环网协议来破除环路。

    可通过执行命令port

    trunk pvid vlan vlan-id来配置接口的PVID。

    当接口允许通过大量VLAN时,不要频繁创建、删除VLAN,否则会导致CPU偏高。

    (当协商为Access类型时)执行命令port

    default vlan vlan-id,配置通过LNP协议自协商为access后加入的VLAN。

    缺省情况下,协商为access类型的接口加入VLAN1。

    3、基于MAC地址划分VLAN

    基于MAC地址划分的VLAN只处理untagged报文,对于tagged报文处理方式和基于接口的VLAN一样。当接口收到的报文为untagged报文时,接口会以报文的源MAC地址为根据去匹配MAC-VLAN表项。如果匹配成功,则按照匹配到的VLAN ID和优先级进行转发。如果匹配失败,则按其它匹配原则进行匹配。

    交换机整机支持1024个MAC-VLAN。MAC-VLAN总数=配置的MAC-VLAN数*下发接口数。

    具体配置

    1、创建vlan(与MAC关联的vlan)

    [Huawei]vlan 10

    2、配置vlan-MAC映射表

    [Huawei-vlan10]mac-vlan

    mac-address 5489-9841-0BA6

    3、配置端口以hybrid模式(只能是hybrid模式)不带标签的方式加入指定vlan中

    [Huawei-Ethernet0/0/1]port link-type hybrid

    [Huawei-Ethernet0/0/1]port hybrid untagged

    vlan 10

    4指定优先基于MAC地址划分vlan(可选-默认策略>MAC=子网>协议>端口)

    [Huawei-Ethernet0/0/1]vlan

    precedence mac-vlan

    5、使能MAC地址划分vlan功能(通常在网络设备之间连接的hybrid端口上配置)

    [Huawei-GigabitEthernet0/0/1]mac-vlan enable

    MAC-VLAN与MUX-VLAN冲突,不允许在同一接口配置。不能在同一接口上配置MAC-VLAN和MAC认证功能。带掩码的MAC-VLAN对接收到的VLAN ID为0的报文不生效。

    4、基于子网划分VLAN

    基于子网划分VLAN和基于协议划分VLAN统称为基于网络层划分VLAN,可减少手工配置VLAN的工作量,也可保证用户自由地增加、移动和修改。

    基于子网划分VLAN适用于对安全需求不高,对移动性和简易管理需求较高的场景中。

    基于IP子网的VLAN只处理untagged报文,对于tagged报文处理方式和基于接口的VLAN一样。

    当设备接口接收到untagged报文时,设备根据报文的源IP地址或指定网段来确定报文所属的VLAN,然后将报文自动划分到指定VLAN中传输。

    具体配置

    1、创建vlan(与IP关联的vlan)

    [Huawei]vlan 11

    2、配置vlan-IP映射表和vlan-IP对应vlan 802.1P优先级 。

    [Huawei-vlan11]ip-subnet-vlan ip

    192.168.1.1 28 priority 7

    3、配置端口以hybrid模式(只能是hybrid模式)不带标签的方式加入指定vlan中

    [Huawei-Ethernet0/0/3]port link-type hybrid

    [Huawei-Ethernet0/0/3]port hybrid untagged

    vlan 11

    4、指定优先基于IP地址划分vlan(可选-默认策略>MAC=子网>协议>端口)

    [Huawei-Ethernet0/0/11]vlan precedence

    ip-subnet-vlan

    5、使能IP地址划分vlan功能(通常在网络设备之间连接的hybrid端口上配置)

    [Huawei-GigabitEthernet0/0/2]ip-subnet-vlan

    enable

    5、基于策略划分VLAN

    基于策略划分VLAN也可称为Policy

    VLAN,可实现用户终端的即插即用功能,同时可为终端用户提供安全的数据隔离。

    基于策略划分VLAN分为:

    基于MAC地址+IP地址组合策略

    基于MAC地址+IP地址+接口组合策略。

    基于策略的VLAN只处理untagged报文,对于tagged报文处理方式和基于接口的VLAN一样。

    当设备接口接收到untagged报文时,设备根据用户报文中的MAC地址和IP地址与配置的MAC地址和IP地址组合策略来确定报文所属的VLAN,然后将报文自动划分到指定VLAN中传输。

    具体配置步骤

    1、创建vlan

    [Huawei]vlan 10

    2、创建策略与vlan映射

    [Huawei-vlan10]policy-vlan mac-address

    11-22-33 ip 192.168.1.1 priority 6

    [Huawei-vlan10]policy-vlan mac-address

    11-22-44 ip 192.168.10.1 interface Ethernet 0/0/5 priority 6

    #此命令需要先把要指定的端口加入相应的vlan中

    3、配置端口为混合端口并允许不带标签vlan通过

    [Huawei-GigabitEthernet0/0/1]port hybrid

    untagged vlan 10 to 20

    6、基于协议划分vlan

    划分思想是把用户计算机上运行的协议与vlan进行关联;基于协议划分的vlan只处理不带标签的数据帧,只能在混合端口上进行配置。

    配置步骤

    1、创建vlan

    [Huawei]vlan

    100

    2、关联vlan与协议

    [Huawei-vlan100]protocol-vlan

    ?

    INTEGER<0-15>  Protocol

    index

    at             AT(AppleTalk

    Protocol) configuration information

    ipv4           IPv4 configuration information

    ipv6           IPv6 configuration information

    ipx            IPX(Internetwork Packet eXchange)

    configuration information

    mode           Other protocol mode configuration

    information

    3设置端口类型并加入vlan(只能是hybrid类型不带标签)

    [Huawei-Ethernet0/0/5]port link-type hybrid

    [Huawei-Ethernet0/0/5]port hybrid untagged vlan

    100

    4、配置协议vlan与协议(号)关联(通常在网络设备之间连接的hybrid端口上配置)

    [Huawei-GigabitEthernet0/0/2]protocol-vlan

    vlan 100 0

    #协议号是根据协议与vlan关联的先后顺序自动产生的,如(同一接口下)先关联IPV4协议则产生协议0,再关联IPV6则产生协议号1.

    展开全文
  • 如图: 1.首先进入系统视图:system-view 进入后<>变成[ ],当然我这是在华为的ensp模拟器下,实操是需要输入账户和...3.配置vlanif接口的ip地址 int vlan * 进入vlanif接口视图 vlan10网段10,vlan20网段20,...
  • 华为交换机同一VLAN配置多个网段

    万次阅读 2017-10-31 13:50:16
    博客:http://blog.csdn.net/wylfengyujiancheng在VLANIF接口下配置主从IP地址,可以实现同一VLAN多个网段用户间的互通。 例如,如图1所示,某VLAN10内两个主机Host_1和Host_2分别属于网段10.1.1.1/24和10.1.2.1/24...
  • 2、在交换机(本实验中的交换机是具备路由功能的以太网三层交换机)上配置VLAN10及VLAN20的VLAN接口(Vlanif),作为VLAN10及VLAN20用户的网关,使得PC1及PC2能够相互ping通。二、实验步骤:1、创建vlan10 20,配置...
  • 某个公司的基本网络结构如图所示。为了提高部门内的信息安全,每个部门的员工划分到一... 图基于MAC地址VLAN划分配置示例拓扑结构 根据以上要求,可以针对工程部的以上三台PC 配置基于MAC 地址划分的VLAN 10,将它...
  • 华为交换机vlan配置

    2017-11-13 01:42:00
    今天算是丢人了,连华为交换机VLAN配置都搞错了,客户的网络结构很简单,就是路由加防火墙加三层交换机,客户防火墙宕机后,默认三层交换机的指向就出不去了,所以导致内部用户无法上网。 解决此问题方法很多,...
  • 案例1:划分VLAN 案例2:多交换机VLAN的划分 ...在交换机上创建以下VLAN,按照拓扑图-1将端口加入到指定的VLAN配置服务器IP地址,实现同VLAN主机的通信 图-1 1.2 步骤 实现此案例需要按照如下步骤进行...
  • VLANIF接口下配置主从IP地址,可以实现同一VLAN多个网段用户间的互通。例如,如图1所示,某VLAN10内两个主机Host_1和Host_2分别属于网段10.1.1.1/24和10.1.2.1/24,要求两主机互通。可以在Switch上进行如下配置:...
  • 我们前面发布了华为交换机的配置方式,那么今天就用一些小实例来增加对华为交换机配置的了解。一、给交换机划分VLANVlan是虚拟局域网的意思,它相当于一个局域网工作组。“vlan几”可以理解成编号为几的vlan,比如...
  • 之前讨论的都是思科的,今天咱们具体讨论内容包含VLAN级联的静态配置; 通过GVRP协议实现的VLAN级联的动态配置;...首先按照上图连接各实验设备,然后配置PCA IP地址为10.1.1.2/24,PCB IP地址为10....
  • 1.创建VLAN并将接口加入VLAN,实现基于IP子网的VLAN可以透传当前接口。...配置介绍:Switch的配置文件#sysname Switch //交换机命名#vlan batch 100 200 300 //创建VLAN 100、VLAN 200和VLAN 300#vla...
  • 华为交换机vlan配置教程

    万次阅读 多人点赞 2018-07-24 15:56:14
    Sys \\进入系统视图 Dhcp enable \\全局开启dhcp功能 Vlan bacth 2 3 4 \\批量创建vlan 2 3 ...Ip add 192.168.xxx.1 255.255.255.0 \\为vlan2分配IP地址及子网掩码 Dhcp select global \\dhcp选择全局开启 Q \...
  • 华为交换机配置远程管理地址

    千次阅读 2019-03-28 06:33:48
    华为交换机配置stelent过程。 交换机型号为:s5700,Software Version V200R010C00SPC600。笔记本通过consloe 口连入交换机,默认用户名admin,默认密码admin@huawei.com,首次登陆强制更改密码。输入默认密码后,...
  • 关于华为交换机vlanif

    千次阅读 2014-12-01 17:43:34
    华为vlanif相当于思科的svi接口,直接给vlan配置ip地址,也就是说相当于思科的int vlan 2 而虚拟子接口是在物理接口的进行划分,你可以看做是将物理接口一分为二,一分为三等。虚拟子接口是有路由交换功能的。 ...
  • 华为交换机同一vlan不同网段的通信

    千次阅读 2019-01-08 09:45:01
    VLANIF接口下配置主从IP地址,可以实现同一VLAN多个网段用户间的互通。 某VLAN10内两个主机Host_1和Host_2分别属于网段10.1.1.1/24和10.1.2.1/24,要求两主机互通。 可以在Switch上进行如下配置: [Switch] ...
  • 华为交换机配置DHCP, NAT, 互联vlan Ⅰ: 网络拓扑图 Ⅱ:配置部分 PC1-2-3-4: 地址获取选择DHCP SW2: sysname Huawei undo info-center enable vlan batch 10 20 interface Eth-Trunk0 port link-type trunk ...
  • 1. 配置VLANIF 接口 介绍配置VLANIF 接口的过程与step。...1.4.3 配置VLANIF 接口的IP 地址 1.4.4 检查配置结果 1.4.1 建立配置任务 应用环境 当S-switch 需要与网络层的设备通信时,可以在S-sw...
  • 3.假设S1交换机由于某种原因,无法配置,请在S3的E4端口进行相应配置,根据相应IP进行VLAN的划分。 4.测试同一网段的PC和服务器能否通信?(YES)。 三、配置命令与原因分析: 1.测试同一网段的PC和服务器能否...
  • 交换机连接的两个pc不用配置网关也能ping通有拓扑如下,pc1与pc2除了ip地址不同,其它都相同,网关都是默认的0.0.0.0但是只要这个拓扑启动后pc1照样能够ping通pc2查看mac地址表及当前交换机vlan可以发现是因为默认...
  • 配置方法 Switches1(S5700)配置 The device is running! <Huawei>system-view Enter system view, return user view with Ctrl+Z. [Huawei]undo info enable Info: Information center is disabled....

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 423
精华内容 169
关键字:

华为交换机配置vlan地址