精华内容
下载资源
问答
  • 华为配置telnet和ssh访问

    华为配置telnet和ssh访问

    一、Telnet登陆配置

    1、配置telnet功能及参数

    <Huawei>system-view # 进入系统视图
    [Huawei]telnet server enable # 配置开启telnet(默认开启)
    [Huawei]telnet server port 23 # 配置telnet端口(默认为23)
    

    2、配置telnet用户登陆界面

    [Huawei]user-interface vty 0 4 # 进入vty用户界面视图
    [Huawei-ui-vty0-4]protocol inbound telnet # 配置用户界面支持Telnet服务
    [Huawei-ui-vty0-4]user privilege level 3 # 配置用户级别,3为管理级,最高权限
    

    3、配置验证方式

    三种输入的验证方式:

    • none: 无需验证
    • password: 用户密码验证
    • aaa: AAA验证,即用户名和密码验证

    我们只需要在这三种验证方式中选择一种即可。一般选择C。

    A. 配置不验证密码

    [Huawei-ui-vty0-4]authentication-mode none
    

    B. 配置passwd验证方式

    [Huawei-ui-vty0-4]authentication-mode password #配置验证方式为password
    [Huawei-ui-vty0-4]set authentication password cipher Huawei123 #配置验证密码:Huawei12#$
    

    C. 配置AAA验证

    [Huawei-ui-vty0-4] authentication-mode aaa #配置验证模式为aaa
    [Huawei-ui-vty0-4] quit #退出用户界面视图
    [Huawei] aaa #进入aaa验证
    [Huawei-aaa] local-user admin password cipher Huawei12#$ #设置登陆用户名为admin,密码为Huawei12#$
    [Huawei-aaa] local-user admin privilege level 3    #配置用户级别
    [Huawei-aaa] local-user admin service-type telnet  #配置用户登录方式
    [Huawei-aaa] quit
    

    用户登陆级别说明

    • 0参观级:网络诊断工具命令(ping、tracert)、从本设备出发访问外部设备的命令(Telnet客户端)、部分display命令等。
    • 1监控级:用于系统维护,包括display等命令。并不是所有display命令都是监控级,比如display current-configuration命令和display saved-configuration命令是3级管理级。
    • 2配置级:业务配置命令,包括路由、各个网络层次的命令,向用户提供直接网络服务。
    • 3~15管理级:用于系统基本运行的命令,对业务提供支撑作用,包括文件系统、FTP、TFTP下载、命令级别设置命令以及用于业务故障诊断的debugging命令等。

    4、配置Telnet远程登陆管理端口

    远程管理端口可以是物理端口或者逻辑端口

    设置物理管理端口

    [Huawei] interface MEth 0/0/1
    [Huawei-MEth0/0/1] ip address 192.168.1.250 24
    [Huawei-MEth0/0/1] quit
    

    设置逻辑端口

    [Huawei] vlan 10
    ...
    [Huawei] interface vlanif 10
    [Huawei-vlanif10] ip address 192.168.10.1 24
    [Huawei-vlanif10] quit
    

    说明:必须保证控制终端能够连接上交换机的vlanif10端口,特别是控制端直接连接此设备时,还需要将与控制端相连的设备端口配上相应的vlan,如控制端连接GigabitEthernet0/0/1来对设备进行远程登陆,需要的配置如下:

    [Huawei] interface gigabitethernet0/0/1
    [Huawei-GigabitEthernet0/0/1] port link-type access
    [Huawei-GigabitEthernet0/0/1] port default vlan 10
    [Huawei-GigabitEthernet0/0/1] quit
    

    二、配置SSH远程登陆

    1.配置SSH远程登陆界面及其属性

    <Huawei> system-view
    [Huawei] user-interface vty 0 4
    [Huawei-ui-vty0-4] authentication-mode aaa    # 配置用户界面验证方式
    [Huawei-ui-vty0-4] protocal inbound ssh       # 配置用户界面支持SSH
    [Huawei-ui-vty0-4] user privilege level 5     # 配置用户界面优先级
    [Huawei-ui-vty0-4] quit
    

    2. 配置SSH服务

    [Huawei] stelnet server enable     #使能STelnet服务
    [Huawei] ssh user radmin service-type stelnet    #配置SSH用户radmin的服务方式为STelnet
    [Huawei] ssh user radmin authentication-type password    #配置用户名为radmin(新建)的SSH用户
    

    3. 配置AAA验证所需的用户名和密码

    [Huawei] aaa
    [Huawei-aaa] local-user radmin password cipher Huawei12#$ #配置用户'radmin'(新建)及其密码'Huawei12#$'
    [Huawei-aaa] local-user radmin privilege level 10   #配置用户优先级
    [Huawei-aaa] local-user radmin service-type ssh     #配置本地用户接入类型为SSH
    [Huawei-aaa] quit
    

    说明:当用户界面优先级和用户本身的优先级(AAA视图下的配置)相冲突,以用户优先级为准

    配置SSH远程登陆管理端口
    管理端口的配置根Telnet服务一致,不再重复。

    管理终端登陆

    ssh radmin@192.168.100.1
    

    三、web页面登陆配置步骤

    配置步骤:

    system-view
    [HUAWEI]http server enable    #开启http服务
    [HUAWEI]interface vlanif 1
    [HUAWEI-Vlanif1]ip add 192.168.1.1 255.255.255.0     #配置IP地址
    [HUAWEI-Vlanif1]quit
    [HUAWEI]aaa
    [HUAWEI-aaa]local-user huawei password cipher huawei@123     #配置用户名huawei和密码huawei@123
    [HUAWEI-aaa]local-user huawei privilege level 15       #配置用户名权限
    [HUAWEI-aaa]local-user huawei service-type http        #配置用户名服务类型
    [HUAWEI-aaa]quit
    [HUAWEI]quit
    save
    y
    

    重点华为设备出厂的时候,对web访问的接口做了限制,我们必须查出来哪个接口可以web访问

    display current-configuration filter http serve   #查询哪个接口允许web访问
    #
    post-system
     http server enable
     http server permit interface GigabitEthernet0/0/1  #这个接口可以访问
    #
    return
    

    解决办法有两种:

    undo http server permit interface    #删除限制
    http server permit interface e0/0/0  #允许你的接口访问web
    

    在这里我想说的是,华为的web界面真的是很差,我用的真机AR1220,不知道新版的怎么样。建议还是用命令把。

    展开全文
  • 因为tcp是基于字节流的协议,所以这两种远程管理配置方式对流量的延迟或者抖动非常敏感。(二者都是交互式数据流) telnet完全是明文交互,非常不安全。通过tcp字节流跟踪,得到以下截图: 从此图可以看出完全是明文...

    1、Telnet认证:

    2、SSH认证:

     3、两种方式的对比:

    首先都是tcp的应用,需要三次握手建立连接。因为tcp是基于字节流的协议,所以这两种远程管理配置方式对流量的延迟或者抖动非常敏感。(二者都是交互式数据流)

    telnet完全是明文交互,非常不安全。通过tcp字节流跟踪,得到以下截图:

    从此图可以看出完全是明文,密码和内容都存在不安全性。所以目前很少用此方式进行远程管理。

    而ssh相对而言是通过rsa加密算法加密后进行数据交互,相对于telnet来说安全性可以得到保障。

    因此目前比较常用的远程管理是ssh。

     

    展开全文
  • 华为交换机telnet配置方法

    千次阅读 2021-03-19 11:28:13
    华为交换机telnet配置方法前言Telnet的两种配置方式:1.仅密码登录验证2.配置AAA登录总结 前言 提示:此文章目的是记录自己学习的笔记,顺便分享给有需要的人,本人小萌新一个,如文章中有出错欢迎各位大佬指正! ...

    前言

    提示:此文章目的是记录自己学习的笔记,顺便分享给有需要的人,本人小萌新一个,如文章中有出错欢迎各位大佬指正!


    提示:以下是本篇文章正文内容,下面案例可供参考

    示例:以下内容是以华为交换机S2700作为实验设备,当然华为交换机的配置大同小异,其他型号的华为交换机亦可参照此文档进行配置。

    Telnet的两种配置方式:

    1.仅密码登录验证

    代码如下(示例):
    <Quidway>system-view -----进入配置模式
    [Quidway]interface vlan 1 -----进入管理vlan
    [Quidway-Vlanif1]ip address 192.168.28.49 255.255.255.0 -----配置管理ip地址
    [Quidway-Vlanif1]quit -----退出
    [Quidway]telnet server enable -----打开telnet服务 (一般默认开启)
    [Quidway]user-interface vty 0 4 -----用户指定虚拟用户终端接口
    [Quidway-ui-vty0-4]authentication-mode password -----配置用户终端接口认证方式 密码验证
    [Quidway-ui-vty0-4]set authentication password cipher huawei123 -----设置接口验证密码,密码为huawei123
    [Quidway-ui-vty0-4]user privilege level 15 -----设置用户优先级 (可选)
    [Quidway-ui-vty0-4]idle-timeout 1 -----设置登陆超时为一分钟 (可选)
    [Quidway-ui-vty0-4]return -----返回用户视图
    <Quidway>save -----保存

    2.配置AAA登录

    代码如下(示例):
    <Quidway>system-view -----进入配置模式
    [Quidway]interface vlan 1 -----进入管理vlan
    [Quidway-Vlanif1]ip address 192.168.28.49 255.255.255.0 -----配置管理ip地址
    [Quidway-Vlanif1]quit -----退出
    [Quidway]telnet server enable -----打开telnet服务 (一般默认开启)
    [Quidway]user-interface vty 0 4 -----用户指定虚拟用户终端接口
    [Quidway-ui-vty0-4]authentication-mode aaa -----配置用户终端接口认证方式 aaa验证
    [Quidway-ui-vty0-4]user privilege level 15 -----设置用户优先级
    [Quidway-ui-vty0-4]idle-timeout 1 -----设置登陆超时为一分钟
    [Quidway-ui-vty0-4]quit -----退出
    [Quidway]aaa -----进入aaa
    [Quidway-aaa]local-user huawei password cipher huawei123 -----创建用户名huawei 密码huawei123
    [Quidway-aaa]local-user huawei privilege level 15 -----设置用户优先级
    [Quidway-aaa]local-user huawei service-type telnet -----授权用户使用telnet
    [Quidway-ui-vty0-4]return -----返回用户视图
    <Quidway>save -----保存


    总结

    提示:这里对文章进行总结:文章中若有出差,请给位大佬指正。

    展开全文
  • 华为交换机配置telnet登陆

    千次阅读 2020-10-12 22:48:59
    网络拓扑 通过Console口首次登录...设置设备名称和管理IP地址。 u t m system-view [HUAWEI] sysname Server [Server] vlan 10 [Server-vlan10] quit [Server] interface vlanif 10 [Server-Vlanif10] ip address 19

    网络拓扑

    通过Console口首次登录设备后,对设备进行基本配置并配置通过Telnet远程登录的0~4号用户的级别为15级,认证方式为AAA认证,通过Console口登录设备,对设备进行基本配置。
    在这里插入图片描述

    设置设备名称和管理IP地址。

    u t m
    system-view
    [HUAWEI] sysname Server
    [Server] vlan 10
    [Server-vlan10] quit
    [Server] interface vlanif 10
    [Server-Vlanif10] ip address 192.168.10.1 24
    [Server-Vlanif10] quit
    [Server] interface gigabitethernet 0/0/1
    [Server-GigabitEthernet0/0/1] port link-type access
    [Server-GigabitEthernet0/0/1] port default vlan 10
    [Server-GigabitEthernet0/0/1] quit

    设置Telnet用户的级别和认证方式

    [Server] telnet server enable
    [Server] user-interface vty 0 4
    [Server-ui-vty0-4] protocol inbound telnet
    [Server-ui-vty0-4] authentication-mode aaa
    [Server-ui-vty0-4] user privilege level 15
    [Server-ui-vty0-4] quit
    [Server] aaa
    [Server-aaa] local-user admin1234 password cipher admin1234
    [Server-aaa] local-user admin1234 privilege level 15
    [Server-aaa] local-user admin1234 service-type telnet
    [Server-aaa] quit

    完成以上配置后,为验证配置结果,可以从PC1以Telnet方式远程登录设备。

    进入Windows的命令行提示符,并执行以下命令,通过Telnet方式登录设备。

    windows+R进入cmd命令界面,输入telnet 192.168.10.1,按Enter回车确定(确保主机已安装telnet客户端)
    在这里插入图片描述

    展开全文
  • 1.PC 通过telnet 登陆交换机并对其进行管理(本演示以Ethernet0/0/1作为管理端口); 2.仅密码认证方式; 3.只允许192.168.1.1的IP地址的PC TELNET 访问。 1.配置TELNET 登陆的ip 地址 <huawei>system-...
  • 华为交换机配置telnet服务

    千次阅读 2019-03-29 18:15:31
    我也是一名自学的初学者,希望对大家有帮助,如果有不对的地方,可以指出。 LW1 创建vlan 22 vlan 22 quit 接口22,划入VLAN22 ,并把链接模式设置成trunk,级联。...进入ifvlan22,配置ip地址子网掩码 int vlan 2...
  • 华为交换机配置console口和telnet密码实例 sys 进入到系统视图 Enter system view, return to user view with Ctrl+Z. [Quidway]user-interface aux 0 [Quidway-ui-aux0]authentication-mode scheme Notice: Telne.....
  • 华为交换机s2300的telnet配置 连接 console 口: <Quidway>sys [Quidway]interface vlanif 1 进入到vlan 1 [Quidway-Vlanif1]ip address 你的网段ip 你的掩码 设置ip:我的例子:ip address 192.168.0.200 255....
  • Huawei华为交换机远程Telnet配置

    万次阅读 多人点赞 2018-12-06 08:42:29
    <Huawei>system-view 从用户视图进入系统视图 [Huawei]interface Vlanif 1 进入管理Vlan [Huawei-Vlanif1]ip address 192.168.1.1 25...
  • 今天给大家带来的是如何在华为交换机配置Telnet和SSH的配置。实验拓扑如下 实验拓扑 实验需求 按照图示连接到真机,并配置IP地址(真机IP地址配置到VirtualBox Host-Only Ethernet Adapter网卡) 在SW1开启Telnet...
  • 华为交换机配置Telnet步骤

    千次阅读 2020-12-08 17:38:30
    通过Telnet方式登录交换机进行设备查询管理为各网络管理员提供了便利,不需要成天拎着console线夹着笔记本蹲在机房里,只要在能连接到相应网络的电脑上Telnet连接即可。 前提条件是该交换机已经配置ip地址并网络...
  • <Huawei>system-view Enter system view, return user view with Ctrl+Z. ...[S2]interface Vlanif 1 //配置IP地址 [S2-Vlanif1]ip address 192.168.1.254 24 [S2-Vlanif1]quit [S2]user-interface vty 0 4
  • 华为交换机配置流程

    万次阅读 多人点赞 2019-02-21 16:43:24
    华为交换机配置流程 一、准备工作 准备console线,连接交换机电脑。通过计算机设备管理器查看COM驱动。 登录putty,选择serial连接方式,输入正确的COM口参数,选择连接。 二、交换机初始化步骤 1.设置...
  • 华为交换机设置telnet

    2021-07-08 20:45:09
    配置远程登录不用用户名的telnet设置: sys 1、开启telnettelnet server enable 2、创建远程账户: aaa local-user adminpassword cipher admin #admin是账户,admin@huawei.com是密码,密码在登录的时候可以改...
  • “vlan几”可以理解成编号为几的vlan,比如vlan 2就是编号为2的vlan,只是一个编号而已,并不是说vlan 2的网段一定要是2网段,vlan2的IP地址是可以随便设置的。下面我将三层交换机的第20个端口添加到vlan 10里,步骤...
  • 电脑PC1经过S3700交换机telnet远程登录到S5700交换机。 连接拓扑图如下:(测试时用实物测试) 一、配置S5700交换机。 1.交换机开启Telnet服务 <Huawei>system-view Enter system view, return user view ...
  • 公司可能为了安全考虑,只允许IT管理员的IP地址登录到此交换机。那么该怎么实现呢? 实现步骤 1:设置ACL 2:在虚拟接口telnet下调用基本ACL。 ACL可以这样写。 #acl 2000//2000基本ACL,匹配源地址 #step 5 ...
  • 华为路由/交换机配置telnet登录 实验拓扑图 配置ip表 1、基础配置 测试R3跟R2 R1的联通性 配置telnet密码验证 在R1上配置telnet验证方式为密码验证,并设置密码为密文方式存储 在R2使用telnet连接R1验证 配置...
  • 华为交换机如何配置telnet AAA配置示例 system-view -----进入配置模式 [Huawei] sysname admin -----修改名称 [Huawei] interface vlan 1 -----进入管理vlan1 [Huawei–Vlanif1] ip address 192.168.10.1 255....
  • 华为交换机路由器常见开局配置指导 目 录 1 如何登陆管理设备 .......................................................... 5 1.1 通过Console登录设备 .................................................. 5 1.2 ...
  • 此工具可以再CRT的script里面运行脚本,list里面填写你的IP地址 账号密码 备份后保存的文件名,至于文件夹位置等参数可自行修改。
  • display this \\显示当前配置 display saved-configuration \\显示已保存配置 display current-configuration \\显示当前生效配置 2、配置登录标语 header shell information "welcome to certification lab" 3...
  • 通过Telnet方式登录交换机进行设备查询管理为各网络管理员提供了便利,不需要成天拎着console线夹着笔记本蹲在机房里,只要在能连接到相应网络的电脑上Telnet连接即可。 注意:这里是交换机不是路由器,路由器不一样...
  • 华为交换机配置远程连接

    千次阅读 2021-04-06 11:08:29
    注意:在华为模拟器中选用这个名为:“router”的路由,不然别的路由E口不支持配置ip(默认为二层设备端口) 实验思路: 1、路由器配置ip交换机配置ip实现互通。 2、由于模拟器中交换机是二层设备,所以端口不...
  • 交换机telnet ftp等配置白名单,限制非法登入。 启用Telnet服务 <HUAWEI> system-view [HUAWEI] sysname Telnet_Server [Nxera-YC] telnet server enable 配置VTY用户界面的最大个数。 [Nxera-YC]...
  • 一、华为S5700交换机初始化和配置SSH和TELNET远程登录方法: 配置登陆IP地址: system-view //进入系统配置模式 [Quidway]interface Vlanif 1 //进入三层 vlanif 接口 [Quidway-Vlanif1]ip ad...
  • 最简单(password形式)开启telnet 1.网络拓扑如下: 第一步:首先搭建网络 R1配置: <Huawei>system-view [Huawei]sysname R1 [R1]int G0/0/0 [R1-GigabitEthernet0/0/0]ip add 192.168.1.1 24 [R1...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,656
精华内容 1,062
关键字:

华为交换机配置管理ip和telnet