精华内容
下载资源
问答
  • 华为交换机配置详解

    千次阅读 2019-11-25 16:08:59
    最近一直想学习华为交换机配置,收集了一下命令,先进行一下整理,共大家学习参考! 希望给给位博友有所帮助!! 交换机命令 [Quidway]discur; 显示当前配置 [Quidway]displaycurrent-configuration; 显示当前...

    最近一直想学习华为交换机的配置,收集了一下命令,先进行一下整理,共大家学习参考!

    希望给给位博友有所帮助!!

    交换机命令

    [Quidway]discur;     显示当前配置
    
    [Quidway]displaycurrent-configuration;     显示当前配置
    
    [Quidway]displayinterfaces;     显示接口信息
    
    [Quidway]displayvlanall;     显示路由信息
    
    [Quidway]displayversion;     显示版本信息
    
    [Quidway]superpassword;修改特权用户密码
    
    [Quidway]sysname;交换机命名
    
    [Quidway]interfaceethernet0/1;进入接口视图
    
    [Quidway]interfacevlanx;进入接口视图
    
    [Quidway-Vlan-interfacex]ipaddress10.65.1.1255.255.0.0;配置VLAN的IP地址
    
    [Quidway]iproute-static0.0.0.00.0.0.010.65.1.2;静态路由=网关
    
    [Quidway]rip;三层交换支持
    
    [Quidway]local-userftp   
    
    [Quidway]user-interfacevty04;进入虚拟终端
    
    [S3026-ui-vty0-4]authentication-modepassword;设置口令模式
    
    [S3026-ui-vty0-4]setauthentication-modepasswordsimple222;设置口令
    
    [S3026-ui-vty0-4]userprivilegelevel3;用户级别
    
    [Quidway]interfaceethernet0/1;进入端口模式
    
    [Quidway]inte0/1;进入端口模式
    
    [Quidway-Ethernet0/1]duplex{half|full|auto};配置端口工作状态
    
    [Quidway-Ethernet0/1]speed{10|100|auto};配置端口工作速率
    
    [Quidway-Ethernet0/1]flow-control;配置端口流控
    
    [Quidway-Ethernet0/1]mdi{across|auto|normal};配置端口平接扭接
    
    [Quidway-Ethernet0/1]portlink-type{trunk|access|hybrid};设置端口工作模式
    
    [Quidway-Ethernet0/1]portaccessvlan3;当前端口加入到VLAN   
    
    [Quidway-Ethernet0/2]porttrunkpermitvlan{ID|All};设trunk允许的VLAN   
    
    [Quidway-Ethernet0/3]porttrunkpvidvlan3;设置trunk端口的PVID   
    
    [Quidway-Ethernet0/1]undoshutdown;激活端口
    
    Quidway-Ethernet0/1]shutdown;关闭端口
    
    [Quidway-Ethernet0/1]quit;返回
    
    [Quidway]vlan3;创建VLAN   
    
    [Quidway-vlan3]portethernet0/1;在VLAN中增加端口
    
    [Quidway-vlan3]porte0/1;简写方式
    
    [Quidway-vlan3]portethernet0/1toethernet0/4;在VLAN中增加端口
    
    [Quidway-vlan3]porte0/1toe0/4;简写方式
    
    [Quidway]monitor-port;指定镜像端口
    
    [Quidway]portmirror;指定被镜像端口
    
    [Quidway]portmirrorint_listobserving-portint_typeint_num;指定镜像和被镜像
    
    [Quidway]descriptionstring;指定VLAN描述字符
    
    [Quidway]description;删除VLAN描述字符
    
    [Quidway]displayvlan[vlan_id];查看VLAN设置
    
    [Quidway]stp{enable|disable};设置生成树,默认关闭
    
    [Quidway]stppriority4096;设置交换机的优先级
    
    [Quidway]stproot{primary|secondary};设置为根或根的备份
    
    [Quidway-Ethernet0/1]stpcost200;设置交换机端口的花费
    
    [Quidway]link-aggregatione0/1toe0/4ingress|both;端口的聚合
    
    [Quidway]undolink-aggregatione0/1|all;始端口为通道号
    
    [SwitchA-vlanx]isolate-user-vlanenable;设置主vlan   
    
    [SwitchA]isolate-user-vlansecondary;设置主vlan包括的子vlan   
    
    [Quidway-Ethernet0/2]porthybridpvidvlan;设置vlan的pvid   
    
    [Quidway-Ethernet0/2]porthybridpvid;删除vlan的pvid   
    
    [Quidway-Ethernet0/2]porthybridvlanvlan_id_listuntagged;设置无标识的vlan如果包的vlanid与PVId一致,则去掉vlan信息.默认PVID=1。所以设置PVID为所属vlanid,设置可以互通的vlan为untagged.   
    

    路由器命令

    [Quidway]displayversion;显示版本信息
    
    [Quidway]displaycurrent-configuration;显示当前配置
    
    [Quidway]displayinterfaces;显示接口信息
    
    [Quidway]displayiproute;显示路由信息
    
    [Quidway]sysnameaabbcc;更改主机名
    
    [Quidway]superpasswrod123456;设置口令
    
    [Quidway]interfaceserial0;进入接口
    
    [Quidway-serial0]ipaddress;配置端口IP地址
    
    [Quidway-serial0]undoshutdown;激活端口
    
    [Quidway]link-protocolhdlc;绑定hdlc协议
    
    [Quidway]user-interfacevty04
    
    [Quidway-ui-vty0-4]authentication-modepassword   
    
    [Quidway-ui-vty0-4]setauthentication-modepasswordsimple222   
    
    [Quidway-ui-vty0-4]userprivilegelevel3  [Quidway-ui-vty0-4]quit   
    
    [Quidway]debugginghdlcallserial0;显示所有信息
    
    [Quidway]debugginghdlceventserial0;调试事件信息
    
    [Quidway]debugginghdlcpacketserial0;显示包的信息
    

    静态路由:

    [Quidway]iproute-static{interfacenumber|nexthop}value   
    
    例如:
    
    [Quidway]iproute-static129.1.0.01610.0.0.2   
    
    [Quidway]iproute-static129.1.0.0255.255.0.010.0.0.2   
    
    [Quidway]iproute-static129.1.0.016Serial2   
    
    [Quidway]iproute-static0.0.0.00.0.0.010.0.0.2 
    

    动态路由:

    [Quidway]rip;设置动态路由
    
    [Quidway]ripwork;设置工作允许
    
    [Quidway]ripinput;设置入口允许
    
    [Quidway]ripoutput;设置出口允许
    
    [Quidway-rip]network1.0.0.0;设置交换路由网络
    
    [Quidway-rip]networkall;设置与所有网络交换
    
    [Quidway-rip]peerip-address;
    
    [Quidway-rip]summary;路由聚合
    
    [Quidway]ripversion1;设置工作在版本1   
    
    [Quidway]ripversion2multicast;设版本2,多播方式
    
    [Quidway-Ethernet0]ripsplit-horizon;水平分隔
    
    [Quidway]routeridA.B.C.D;配置路由器的ID   
    
    [Quidway]ospfenable;启动OSPF协议
    
    [Quidway-ospf]import-routedirect;引入直联路由
    
    [Quidway-Serial0]ospfenablearea;配置OSPF区域
    

    标准访问列表命令格式如下:

    acl[match-orderconfig|auto];默认前者顺序匹配。
    
    rule[normal|special]{permit|deny}[sourcesource-addrsource-wildcard|any]  
    
    例:
    
    [Quidway]acl10   
    
    [Quidway-acl-10]rulenormalpermitsource10.0.0.00.0.0.255   
    
    [Quidway-acl-10]rulenormaldenysourceany 
    

    扩展访问控制列表配置命令

    配置TCP/UDP协议的扩展访问列表:

    rule{normal|special}{permit|deny}{tcp|udp}source{|any}destination|any}  [operate]  
    

    配置ICMP协议的扩展访问列表:

    rule{normal|special}{permit|deny}icmpsource{|any]destination{|any]  icmp-code  
    

    扩展访问控制列表操作符的含义

    equalportnumber;等于
    
    greater-thanportnumber;大于
    
    less-thanportnumber;小于
    
    not-equalportnumber;不等
    
    rangeportnumber1portnumber2;区间
    

    扩展访问控制列表举例

    [Quidway]acl101   
    
    [Quidway-acl-101]ruledenysouceanydestinationany   
    
    [Quidway-acl-101]rulepermiticmpsourceanydestinationanyicmp-typeecho   
    
    [Quidway-acl-101]rulepermiticmpsourceanydestinationanyicmp-typeecho-reply   
    
    [Quidway]acl102
    
    
    展开全文
  • 华为交换机配置命令超详解华为交换机配置命令超详解
  • 主要介绍了华为交换机基本配置命令详解,需要的朋友可以参考下
  • 华为三层交换机的OSPF协议的配置教程,配置实例详细说明,手把手教会你,内容完整易懂,重点突出,重点详细
  • 本文档详细介绍华为H3C交换机的详细配置
  • 华为交换机命令配置的中文解释和说明,非常详细
  • 华为交换机常用配置.一.华为交换机周边 华为(Huawei)作为全球领先的电信解决方案供应商,其产品和业务的分布十分广泛,是众多通信行业的公司学习的典范。华为品牌系列交换机,是信息化系统中用经常遇到的网络设备...

    华为eNSP模拟器

    eNSP(Enterprise Network Simulation Platform)是一款由华为提供的免费的、可扩展的、图形化操作的网络仿真工具平台,主要对企业网络路由器、交换机进行软件仿真,完美呈现真实设备实景,支持大型网络模拟,让广大用户有机会在没有真实设备的情况下能够模拟演练,学习网络技术。

    链接:https://pan.baidu.com/s/15ZOccfvljxmkn3qOGmP3dw

    提取码:fl8j

    华为最新模拟器
    VM百度盘 https://pan.baidu.com/s/1eRRf1E6

    CRT百度盘链接:https://pan.baidu.com/s/1bo0hjJ5

    juniper:链接: https://pan.baidu.com/s/1i2MwiUlROEuRamgYV_LQnQ 提取码: ict3

    思科GNS3合集https://pan.baidu.com/s/12PbIaCTmNydFSZQX-nDfDw 提取码:73lk

    H3C模拟器https://pan.baidu.com/s/1F1wK5w6oZ3IVNynyGvToFA 提取码:rnfu

    思科入门模拟器https://pan.baidu.com/s/1i4N5USX

    华为最新模拟器https://pan.baidu.com/s/1w-RkVhnEXDqG1l4h5_ljBg

    ASA模拟器百度盘链接:https://pan.baidu.com/s/1C1wc_UO3D4-8OASRms-2SA 提取码:vne8

    #华为交换机常用配置.一.华为交换机周边

    华为(Huawei)作为全球领先的电信解决方案供应商,其产品和业务的分布十分广泛,是众多通信行业的公司学习的典范。华为品牌系列交换机,是信息化系统中用经常遇到的网络设备,特别是在国产化和安可的要求之后,其中24与48口比较多。现在将华为交换机的一些常用配置整理一下,记录备查。华为具有网络安全设备模拟器eNSP(以VirtualBox、WinPcap、Wireshark为底层),如果需要下载和安装eNSP,请自行爬网寻找下载。
    华为交换机
    在这里插入图片描述
    华为交换机的型号后缀分别代表什么含义呢?
    Z,表示没有上行接口;
    G,表示上行GBIC接口;
    P,表示上行SFP接口;
    T,表示上行RJ45接口;
    V,表示上行VDSL接口;
    W,表示上行可配置WAN接口;
    C,表示上行接口可选配;
    M,表示上行接口为多模光口;
    S,表示上行接口为单模光口;
    F,表示下行接口为模板板,可插光接口板或电接口板;
    LI表示设备为弱特性版本;
    SI表示设备为标准版本,包含基础特;
    EI表示设备为增强版本,包含某些高级特性;
    HI表示设备为高级版本,包含某些更高级特性;

    当同时存在时,表示上行接口为多种接口类型复合。

    知道这些不同型号交换机代表的含义非常关键,这关系到这一型号的交换机该使用什么类型的光模块,例如有些适合电口模块,有些适合单模光模块,有些适合多模光模块。

    华为交换机的正常工作温度范围:长期工作温度-5℃至50℃,短期工作温度-5℃至55℃,存储温度:-40℃至70℃。

    新设备初始化
    新交换机加电后,使用电脑的COM口连接交换机的Console口,连接成功后屏幕提示是否设置密码,建议设置,完成后进入系统配置本机地址:

    <HUAWEI>system-view
    Enter system view, return user view with Ctrl+Z.
    [HUAWEI]vlan 1
    [HUAWEI-vlan1]ip address 192.168.1.254 255.255.255.0
    

    然后就可以在浏览器地址栏中输入:http://192.168.1.254,使用Web方式配置交换机(对安全没有特殊要求的环境,如果使用在等保或分保等安全环境中,建议只使用Console口直连或者加上SSH方式)。

    华为交换机的几种模式:

    用户模式:登陆设备后,直接进入用户模式,只能执行少量查看配置的命令;

    <HUAWEI>
    

    视图模式:用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令;

    <HUAWEI>system-view
    Enter system view, return user view with Ctrl+Z.
    [HUAWEI]
    

    局部配置模式:视图模式下,输入局部配置命令,如interface GE 1/0/0,进入GE1/0/0端口配置模式,此外局部配置模式有很多种,可根据不同需求进入vlan配置模式、端口聚合配置模式等,可输入?,查看当前模式下,能执行哪些命令;

    [HUAWEI]interface GigabitEthernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1]
    

    输入quit返回上一层配置模式,输入commit提交已有配置,用户模式下输入save保存配置;

    [HUAWEI]quit
    <HUAWEI>save
    The current configuration will be written to the device.
    Are you sure to continue?[Y/N]y
    Now saving the current configuration to the slot 0.
    Save the configuration successfully.
    

    查看设备信息:

    <HUAWEI>display version
    Huawei Versatile Routing Platform Software
    VRP (R) software, Version 5.160 (S5720 V200R007C00SPC500)
    Copyright (C) 2000-2014 HUAWEI TECH CO., LTD
    HUAWEI S5720-56C-EI-AC Routing Switch uptime is 0 week, 0 day, 17 hours, 47 minutes
    ES5D2T52C002 0(Master) : uptime is 0 week, 0 day, 17 hours, 46 minutes
    2048M bytes DDR Memory
    344M bytes FLASH
    

    其中关键信息有:

    软件版本:Version 5.160 (S5720 V200R007C00SPC500)
    设备型号:HUAWEIS5720-56C-EI-AC
    运行时间:uptime is 0 week, 0 day, 17 hours, 46 minutes

    查看和修改系统时间:

    <HUAWEI>display clock
    2020-05-16 17:02:19+08:00
    Saturday
    Time Zone(Beijing,Chongqing,Hongkon,Urumqi) : UTC+08:00
    <HUAWEI>system-view
    Enter system view, return user view with Ctrl+Z.
    [HUAWEI]clock timezone BJ add 8
    [HUAWEI]display clock
    2020-05-16 09:13:27+08:00
    Saturday
    Time Zone(BJ) : UTC+08:00
    [HUAWEI]ntp-service unicast-server 203.107.6.88
    [HUAWEI] display clock
    2020-05-16 09:14:17+08:00
    Saturday
    Time Zone(BJ) : UTC+08:00
    

    修改设备名称:

    <HUAWEI>system-view
    [HUAWEI]sysname Sw-Core
    [Sw-Core]
    

    配置设备说明信息:

    添加登录设备说明内容,举例:Only the administrator can configure the equipment

    <Sw-Core>system-view
    Enter system view, return user view with Ctrl+Z.
    [Sw-Core]header shell information "Only the administrator can configure the equipment!"
    

    退出视图模式后可见:
    在这里插入图片描述

    华为交换机常用配置.二.配置SSH连接

    由于telnet缺少安全认证方式,而且传输过程中采用TCP明文传输,容易导致IP地址欺骗等恶意攻击, 所以存在较大的风险。现在众多IT运维人员已经抛弃单纯的telnet管理了。SSH(Secure Shell)是一个网络安全协议,通过对网络数据的加密,使其能在一个不安全的环境里,提供安全的远程登录和其他网络服务。SSH数据加密传输,认证机制更加安全,而且可以替代telnet,现在已经被广泛使用了,特别是近年来等保和分保都对设备远程登录有了比较严格的要求。

    由于SSH用户使用Password方式验证,需要在SSH服务器端生成本地RSA密钥,因此生成本地RSA密钥是完完成SSH登录配置的首要操作,如下:

    1、创建本地密钥对

    [Sw-Core]rsa local-key-pair create
    The key name will be: Core-SW_Host
    The range of public key size is (512 ~ 2048).
    NOTES: If the key modulus is greater than 512,
    it will take a few minutes.
    Input the bits in the modulus[default = 2048]:
    Generating keys...
    ..+++++
    ........................++
    ....++++
    ...........++
    

    2、检查是否存在SSH user(可跳过),系统提示没有SSH user 存在

    [Sw-Core]dis ssh user-information
    Info: No SSH user exists.
    

    3、创建SSH user

    [Sw-Core]ssh user test \可以直接敲第二行命令
    [Sw-Core]ssh user test authentication-type password \认证模式为密码认证
    [Sw-Core]ssh user test service-type stelnet \服务类型为stelnet,即SSH
    

    4、创建用户

    [Sw-Core]aaa
    [Sw-Core-aaa]local-user test password cipher xxx \xxx处为想要设置的密码
    Info: Add a new user.
    [Sw-Core-aaa]local-user test privilege level 15 \用户level最高到15
    [Sw-Core-aaa]local-user test service-type ?
    8021x 802.1x user
    bind Bind authentication user
    ftp FTP user
    http Http user
    ppp PPP user
    ssh SSH user
    telnet Telnet user
    terminal Terminal user
    web Web authentication user
    x25-pad X25-pad user
    [Sw-Core-aaa]local-user test service-type ssh \开启该用户允许使用SSH访问设备的权限
    

    5、启用SSH(stelnet)服务

    [Sw-Core]stelnet server enable
    Info: Succeeded in starting the Stelnet server.
    

    6、配置vty界面支持的登录协议

    [Sw-Core]user-interface vty 0 4
    [Sw-Core-ui-vty0-4]authentication-mode aaa
    [Sw-Core-ui-vty0-4]protocol inbound ssh
    

    华为交换机进入BOOTROM(修改console口密码)

    BootROM(Boot Read-Only Memory)菜单是设备BootROM程序提供的一系列功能选项。

    BootROM程序是一组固化在设备主板上ROM芯片中的程序,它保存着设备最重要的基本输入输出的程序、系统设置信息、开机后自检程序和系统自启动程序。

    此外BootROM菜单还可以备份配置文件、修改BootROM密码等。

    华为交换机的BOOTROM和系统文件是分开存放;而且是单独升级的

    比如你升级系统的时候可能就会提示你需要先升级BOOTROM

    但是怎么样升级华为交换机的BOOTROM;也是比较麻烦的;

    因为要升级bootrom必须要通过com口接入才能升级;

    通过http和telnet都没有办法升级华为交换机的BOOTROM的

    1、用电脑连上交换机com口,记得确认com口编号
    2、打开超级终端,新建连接,这里名称可以随便输入一个
    在这里插入图片描述
    3.选择电脑上的com接口
    在这里插入图片描述
    4.然后设置比特率和数据流
    华为交换机的比特率是9600;数据流是无
    在这里插入图片描述
    5.接入交换机之后输入reboot重启交换机

    如果你是接上com口再开启交换机的话就不用重启了
    在这里插入图片描述
    6.重启交换机之后一定要一直看到超级终端的输出

    7.当出现提示按Ctrl+B的时候 果断按Ctrl+B键

    否则就得再重启一次了
    在这里插入图片描述
    8.接着提示输入BOOTROM密码

    默认密码是Admin@huawei.com注意大小写
    在这里插入图片描述
    9.输入完密码之后就来到BOOTROM menu界面了

    这里有8个选项
    如果是升级的话 选择Enter serial submenu
    也就是输入数字编号2
    如果是要恢复console密码,就选择Clear password for console user
    也就是输入数字编号7
    在这里插入图片描述
    BootROM主菜单介绍:
    在这里插入图片描述
    在这里插入图片描述
    10.如果是输入数字编号2进入升级后

    在升级界面中我们可以看到有一个Update BOOTROM system的选项

    如果要升级BOOTROM就选择Update BOOTROM system这个就可以了,也就是 数字编号1
    在这里插入图片描述
    串口子菜单介绍:
    在这里插入图片描述
    以上就是华为交换机进入BOOTROM的步骤。

    华为交换机的基本配置

    1、创建vlan:

    <Quidway>  //用户视图,也就是在Quidway模式下运行命令。
    <Quidway>system-view   //进入配置视图 
    [Quidway] vlan 10    //创建vlan 10,并进入vlan10配置视图,如果vlan10存在就直接进入vlan10配置视图 
    [Quidway-vlan10] quit   //回到配置视图 
    [Quidway] vlan 100 //创建vlan 100,并进入vlan100配置视图,如果vlan10存在就直接进入vlan100配置视图
    [Quidway-vlan100] quit //回到配置视图
    

    2、将端口加入到vlan中:

    [Quidway] interface GigabitEthernet2/0/1    (10G光口) 
    [Quidway- GigabitEthernet2/0/1] port link-type access //定义端口传输模式 
    [Quidway- GigabitEthernet2/0/1] port default vlan 100 //将端口加入vlan100 
    [Quidway- GigabitEthernet2/0/1] quit  回到配置视图 
    [Quidway] interface GigabitEthernet1/0/0 //进入1号插槽上的第一个千兆网口配置视图中。0代表1号口 
    [Quidway- GigabitEthernet1/0/0] port link-type access //定义端口传输模式 
    [Quidway- GigabitEthernet2/0/1] port default vlan 10 //将这个端口加入到vlan10中 
    [Quidway- GigabitEthernet2/0/1] quit 
    

    3、将多个端口加入到VLAN中

    <Quidway>system-view 
    [Quidway]vlan 10 
    [Quidway-vlan10]port GigabitEthernet 1/0/0 to 1/0/29   //将0到29号口加入到vlan10中 
    [Quidway-vlan10]quit
    华为下的这个命令自己现在不知道,找了下答案也没有结果。
    

    4、交换机配置IP地址

    [Quidway] interface Vlanif100  // 进入vlan100接口视图与vlan 100命令进入的地方不同 
    [Quidway-Vlanif100] ip address 119.167.200.90 255.255.255.252 // 定义vlan100管理IP三层 交换网关路由 
    [Quidway-Vlanif100] quit   返回视图
    [Quidway] interface Vlanif10 // 进入vlan10接口视图与vlan 10命令进入的地方不同 
    [Quidway-Vlanif10] ip address 119.167.206.129 255.255.255.128 // 定义vlan10管理IP三层交换网关路由
    [Quidway-Vlanif10] quit
    配置默认网关:
    [Quidway]ip route-static 0.0.0.0 0.0.0.0 119.167.200.89 //配置默认网关。
    

    5、 交换机保存设置和重置命令

    <Quidway>save //保存配置信息 
    <Quidway>reset saved-configuration /重置交换机的配置 
    <Quidway>reboot //重新启动交换机
    

    6、交换机常用的显示命令

    用户视图模式下:

    <Quidway>display current-configuration //显示现在交换机正在运行的配置明细 
    <Quidway>display device //显示S9303各设备状态 
    <Quidway>display interface//显示个端口状态,用?可以查看后边跟的选项 
    <Quidway>display version //查看交换机固件版本信息 
    <Quidway>display vlan ? // 查看vlan的配置信息
    

    7、恢复交换机出厂设置

    <Quidway>reset saved-configuration /重置交换机的配置
    

    8、华为交换机的基本配置

    1、创建vlan:

    <Quidway>  //用户视图,也就是在Quidway模式下运行命令。
    <Quidway>system-view   //进入配置视图 
    [Quidway] vlan 10    //创建vlan 10,并进入vlan10配置视图,如果vlan10存在就直接进入vlan10配置视图 
    [Quidway-vlan10] quit   //回到配置视图 
    [Quidway] vlan 100 //创建vlan 100,并进入vlan100配置视图,如果vlan10存在就直接进入vlan100配置视图
    [Quidway-vlan100] quit //回到配置视图
    

    2、将端口加入到vlan中:

    [Quidway] interface GigabitEthernet2/0/1    (10G光口) 
    [Quidway- GigabitEthernet2/0/1] port link-type access //定义端口传输模式 
    [Quidway- GigabitEthernet2/0/1] port default vlan 100 //将端口加入vlan100 
    [Quidway- GigabitEthernet2/0/1] quit  回到配置视图 
    [Quidway] interface GigabitEthernet1/0/0 //进入1号插槽上的第一个千兆网口配置视图中。0代表1号口 
    [Quidway- GigabitEthernet1/0/0] port link-type access //定义端口传输模式 
    [Quidway- GigabitEthernet2/0/1] port default vlan 10 //将这个端口加入到vlan10中 
    [Quidway- GigabitEthernet2/0/1] quit 
    

    3、将多个端口加入到VLAN中

    <Quidway>system-view 
    [Quidway]vlan 10 
    [Quidway-vlan10]port GigabitEthernet 1/0/0 to 1/0/29   //将0到29号口加入到vlan10中 
    [Quidway-vlan10]quit
    

    华为下的这个命令自己现在不知道,找了下答案也没有结果。

    4、交换机配置IP地址

    [Quidway] interface Vlanif100  // 进入vlan100接口视图与vlan 100命令进入的地方不同 
    [Quidway-Vlanif100] ip address 119.167.200.90 255.255.255.252 // 定义vlan100管理IP三层 交换网关路由 
    [Quidway-Vlanif100] quit   返回视图
    [Quidway] interface Vlanif10 // 进入vlan10接口视图与vlan 10命令进入的地方不同 
    [Quidway-Vlanif10] ip address 119.167.206.129 255.255.255.128 // 定义vlan10管理IP三层交换网关路由
    [Quidway-Vlanif10] quit
    配置默认网关:
    [Quidway]ip route-static 0.0.0.0 0.0.0.0 119.167.200.89 //配置默认网关。
    

    5、 交换机保存设置和重置命令

    <Quidway>save //保存配置信息 
    <Quidway>reset saved-configuration /重置交换机的配置 
    <Quidway>reboot //重新启动交换机
    

    6、交换机常用的显示命
    用户视图模式下:

    <Quidway>display current-configuration //显示现在交换机正在运行的配置明细 
    <Quidway>display device //显示S9303各设备状态 
    <Quidway>display interface//显示个端口状态,用?可以查看后边跟的选项 
    <Quidway>display version //查看交换机固件版本信息 
    <Quidway>display vlan ?// 查看vlan的配置信息
    

    7、恢复交换机出厂设置

    <Quidway>reset saved-configuration /重置交换机的配置
    

    #华为交换机最常用的基础命令汇总大全

    01、交换机的基础命令汇总

    system-view     进入系统视图
    
    quit     退到系统视图
    
    sysname     交换机命名
    
    vlan 20     创建vlan(进入vlan20)
    
    display vlan    显示vlan
    
    undo vlan 20    删除vlan20
    
    display vlan 20 显示vlan里的端口20
    
    Interface e1/0/24 进入端口24
    
    portlink-type access     vlan 20 把当前端口放入vlan20
    
    undo porte1/0/10 删除当前VLAN端口10
    
    display current-configuration 显示当前配置
    

    02、配置交换机支持TELNET

    interfacevlan 1 进入VLAN1
    
    ip address192.168.3.100 255.255.255.0 配置IP地址
    
    user-interfacevty 0 4 进入虚拟终端
    
    authentication-modepassword (aut password) 设置口令模式
    
    setauthentication password simple 222 (set aut pass sim 222) 设置口令
    
    userprivilege level 3(use priv lev 3) 配置用户级别
    
    dispcurrent-configuration (disp cur) 查看当前配置
    
    display ipinterface 查看交换机VLANIP配置
    
    resetsaved-configuration(reset saved) 删除配置(必须退到用户模式)
    
    reboot重启交换机
    

    03、跨交换机VLAN的通讯

    在sw1上:
    
    vlan 10建立VLAN 10
    
    interfacee1/0/5 进入端口5
    
    Portdefault vlan 10 把端口5加入vlan10
    
    vlan 20建立VLAN 20
    
    interfacee1/0/15 进入端口15
    
    portdefault vlan 20 把端口15加入VLAN20
    
    interfacee1/0/24 进入端口24
    
    portlink-type trunk 把24端口设为TRUNK端口
    
    port trunkpermit vlan all 所有端口都能经过此路径
    
    
    在SW2上:
    
    vlan 10建立VLAN 10
    
    interfacee1/0/20 进入端口20
    
    portdefault vlan 10 把端口20放入VLAN10
    
    interfacee1/0/24 进入端口24
    
    portlink-type trunk 把24端口设为TRUNK端口
    
    port trunkpermit vlan all (port trunk permit vlan 10 只能为vlan10使用)24端口为所有VLAN使用
    
    displayinterface e1/0/24 查看端口24是否为TRUNK
    
    undo porttrunk permit vlan all 删除该句
    

    04、路由器的基础命令汇总

    dispaly version 显示系统软件版本及硬件信息
    
    system-view 切换到系统视图
    
    quit 返回
    
    interface +接口 进入接口视图
    
    ip address +IP +mask 配置IP和子网掩码
    
    return 返回用户视图
    
    <Ctrl+Z> 返回用户视图
    
    sysname R1 修改路由器名称为R1
    
    display current-configuration 查看路由器当前配置
    
    dispaly interface +接口查看路由器接口的状态信息
    
    save 保存当前配置
    
    display ip interface brief 查看接口与IP相关摘要信息
    
    display ip routing-table 查看路由表
    

    05、telnet远程登陆配置

    user-interface vty 0 4 进入0~4前五个的VTY用户界面进行整体配置
    
    authentication-mode password 设置验证方式为密码
    
    user privilege level 3 设置用户登陆级别
    
    aaa 进入aaa视图
    
    local-user admin password cipher hello privilege level 3在aaa视图下设置账号密码和用户级别
    
    local-user admin service-type telnet 配置该用户接入类型为aaa
    
    q 退回到用户视图
    
    user-interface vty 0 4 进入到VTY用户视图
    
    authentication-mode aaa 设置验证方式aaa
    

    06、配置Stelnet

    配置SSHserver:rsalocal-key-pair create 生成本地RSA主机密钥对
    
    display rsa local-key-pair public 查看本地密钥对中的公钥信息
    
    user-interface vty 0 4 进入VTY用户视图
    
    authentication-mode aaa 设置用户验证方式为aaa授权验证方式
    
    protocol inbound ssh 指定VTY用户只支持ssh
    
    q 返回到系统视图
    
    aaa 进入aaa视图
    
    local-user huawei1 password cipher huawei1 创建用户和设置用户密码
    
    local-user huawei1 service-type ssh 配置本地用户接入类型为ssh
    
    q 退回到用户视图
    
    ssh user huawei1 authentication-type password新建ssh用户指定ssh用户认证方式为password
    
    aaa 进入aaa视图
    
    local-user huawei1 privilege level 3 设置huawei1用户级别为3级别范围0~15
    
    stelnet server enable 开启ssh功能
    
    display ssh user-information huawei1 查看ssh用户配置信息不指定用户默认查看所有用户
    
    display ssh server status 查看ssh服务器全局配置信息
    

    07、STP配置和选路规则

    stp enable 在交换机上启用STP
    
    stp mode stp
    
    dis stp 查看stp配置
    
    dis stp brief 查看接口摘要信息
    
    stp priority 4096 修改交换机优先级为4096
    
    stp root primary 设置交换机为主根交换机
    
    stp root secondary 命令配置备份交换机
    
    display stp interface Ethernet 0/0/2 查看e0/0/2接口的开销值
    
    int e0/0/2
    
    stp cost 2000 配置接口e0/0/2的带价值为2000
    
    stp timer forward-delay 3000 修改STP的ForwardDelay时间为3000cs也就是30s
    
    stp bridge-diameter 3 命令设置网络的直径为3
    
    stp mode rstp 启用RSTP使用RSTP可以缩短收敛时间
    
    int e0/0/1
    
    stp edged-port enable 配置接口e0/0/1为边缘端口不参与生成树的计算
    

    08、配置MSTP多实例

    stp region-configuration 进入MST域视图
    
    region-name huawei 配置MST域名为huawei
    
    revision-level 1 配置MSTP的修订级别为1
    
    instance 1 vlan 10 指定VLAN10映射到MSTI1
    
    active region-configuration 激活MST域配置
    
    display stp region-configuration 查看交换机上当前生效的MST域配置信息
    
    dis stp instance 0 brief 查看实例0中的生成树状态和统计的摘要信息
    
    stp instance 2 priority 0 配置交换机成位实例2中的根交换机
    

    09、RIP路由协议配置

    rip 创建开启协议进程
    
    network + ip 对指定网段接口使能RIP功能IP地址是与路由器直连的网段
    
    debugging rip 1 查看RIP定期更新情况
    
    terminal debugging
    
    terminal monitor 在屏幕上显示debug信息
    
    undo debugging rip 1undo debug all 命令关闭debug调试功能
    
    在上面的配置基础上配置RIP2
    
    rip 进入子视图模式
    
    version 2 配置版本
    
    或者直接配置
    
    rip 1
    
    version 2
    
    network + ip
    

    10、OSPF单区域配置

    ospf 1 进入ospf视图1代表进程号
    
    area 0 创建区域并进入OSPF区域视图,输入要创建的区域ID,骨干区域即区域0
    
    network +IP +匹配码
    
    display ospf interface 命令查看OSPF接口通告是否正确、
    
    display ospf peer 查看OSPF邻居状态
    
    display ip routing-table protocol ospf 查看OSPF路由表
    

    11、配置OSPF区域明文认证

    ospf 1
    
    area 1
    
    authentication-mode simple plain huawei plain是口令以明文方式显示
    
    authentication-mode md5 1 huawei 配置区域密文认证
    

    12、配置链路认证

    int g0/0/1
    
    ospf authentication-mode md5 1 huawei 在一条链路中的两个接口配置要相同
    

    13、配置抑制接口

    ospf 1
    
    silent-interface GigabitEthernet 0/0/1 禁止接口g0/0/1接收和发送ospf报文
    

    14、技巧对多个接口配置接口抑制

    ospf 1
    
    silent-interface all 抑制所有接口
    
    un
    
    display ip routing-table 10.0.1.1 查看10.0.1.1所在网段的路由条目
    

    15、基于接口修改

    int g0/0/0
    
    ospf network-type p2mp 修改ospf的网络类型为多到多点
    
    ospf network-type broadcast 修改ospf的网络类型为广播
    
    ospf dr-priority 100 修改g0/0/0接口的DR优先级为100
    
    reset ospf process 重启ospf进程
    
    ospf cost 1000 修改ospf的开销值为1000
    
    ospf timer hello 20 修改HELLO计时器为20s
    
    ospf timer dead 80 修改dead计时器为80s
    
    ospf 1
    
    preference 110 修改ospf优先级为110值越大优先级越低
    

    16、路由引入

    ospf 1
    
    import-route rip 1 在ospf进程中引入rip
    
    default-route-advertise always 在ospf进程中引入默认路由
    
    rip
    
    import-route ospf 1 在rip进程中引入ospf
    
    import-route ospf cost 3 ospf 引入rip时配置开销值
    
    default-route originate 在RIP进程中发布默认路由
    

    17、vrrp(虚拟路由器冗余协议)基本配置

    int g0/0/0
    
    vrrp vrid 1 virtual-ip 172.16.1.254创建VRRP备份组,备份组号为1,配置虚拟IP为172.16.1.254
    
    vrrp vrid 1 priority 120 修改优先级为120
    
    display vrrp 查看vrrp信息
    
    display vrrp brief
    
    display vrrp interface g0/0/0 查看VRRP的工作状态
    

    18、配置VRRP多备份组

    int g0/0/0
    
    vrrp vrid 1 virtual-ip 172.16.1.254创建VRRP备份组,备份组号为1,配置虚拟IP为172.16.1.254
    
    vrrp vrid 1 priority 120 修改优先级为120
    
    vrrp vrid 2 virtual-ip 172.16.1.253创建VRRP备份组,备份组号为2,配置虚拟IP为172.16.1.253
    
    int g0/0/0
    
    vrrp vrid 1 virtual-ip 172.16.1.254创建VRRP备份组,备份组号为1,配置虚拟IP为172.16.1.254
    
    vrrp vrid 2 virtual-ip 172.16.1.253创建VRRP备份组,备份组号为2,配置虚拟IP为172.16.1.253
    
    vrrp vrid 2 priority 120 修改优先级为120
    
    vrrp vrid 2 preempt-mode disable 开启非抢占方式
    

    19、配置VRRP的跟踪接口及认证

    int g0/0/1
    
    vrrp vrid 1 track interface GigabitEthernet 0/0/0 reduced 50监视上行接口G0/0/0,当此接口断掉时,裁减优先级50,使优先级为70
    
    vrrp vrid 1 authentication-mode md5 huawei 认证配置
    

    20、配置基本的访问控制表

    acl 2000 创建一个编号型ACL,基本ACL的范围是2000~29999
    
    rule 5 permit source 1.1.1.1 0指定规则ID为5,允许数据源地址为1.1.1.1的报文通过,反掩码全为0,即精确匹配
    
    rule 10 deny source any 指定ID为10,拒绝任意源地址的数据包通过
    
    display acl all 查看设备上所有的访问控制列表。
    

    #华为交换机配置命令汇总

    01、交换机的基础命令汇总

    system-view     进入系统视图
    
    quit     退到系统视图
    
    sysname     交换机命名
    
    vlan 20     创建vlan(进入vlan20)
    
    display vlan    显示vlan
    
    undo vlan 20    删除vlan20
    
    display vlan 20 显示vlan里的端口20
    
    Interface e1/0/24 进入端口24
    
    portlink-type access     vlan 20 把当前端口放入vlan20
    
    undo porte1/0/10 删除当前VLAN端口10
    
    display current-configuration 显示当前配置
    

    在这里插入图片描述
    02、配置交换机支持TELNET

    interfacevlan 1 进入VLAN1
    
    ip address192.168.3.100 255.255.255.0 配置IP地址
    
    user-interfacevty 0 4 进入虚拟终端
    
    authentication-modepassword (aut password) 设置口令模式
    
    setauthentication password simple 222 (set aut pass sim 222) 设置口令
    
    userprivilege level 3(use priv lev 3) 配置用户级别
    
    dispcurrent-configuration (disp cur) 查看当前配置
    
    display ipinterface 查看交换机VLANIP配置
    
    resetsaved-configuration(reset saved) 删除配置(必须退到用户模式)
    
    reboot重启交换机
    

    03、跨交换机VLAN的通讯

    在sw1上:
    
    vlan 10建立VLAN 10
    
    interfacee1/0/5 进入端口5
    
    Portdefault vlan 10 把端口5加入vlan10
    
    vlan 20建立VLAN 20
    
    interfacee1/0/15 进入端口15
    
    portdefault vlan 20 把端口15加入VLAN20
    
    interfacee1/0/24 进入端口24
    
    portlink-type trunk 把24端口设为TRUNK端口
    
    port trunkpermit vlan all 所有端口都能经过此路径
    
    
    在SW2上:
    
    vlan 10建立VLAN 10
    
    interfacee1/0/20 进入端口20
    
    portdefault vlan 10 把端口20放入VLAN10
    
    interfacee1/0/24 进入端口24
    
    portlink-type trunk 把24端口设为TRUNK端口
    
    port trunkpermit vlan all (port trunk permit vlan 10 只能为vlan10使用)24端口为所有VLAN使用
    
    displayinterface e1/0/24 查看端口24是否为TRUNK
    
    undo porttrunk permit vlan all 删除该句
    

    04、路由器的基础命令汇总

    dispaly version 显示系统软件版本及硬件信息
    
    system-view 切换到系统视图
    
    quit 返回
    
    interface +接口 进入接口视图
    
    ip address +IP +mask 配置IP和子网掩码
    
    return 返回用户视图
    
    <Ctrl+Z> 返回用户视图
    
    sysname R1 修改路由器名称为R1
    
    display current-configuration 查看路由器当前配置
    
    dispaly interface +接口查看路由器接口的状态信息
    
    save 保存当前配置
    
    display ip interface brief 查看接口与IP相关摘要信息
    
    display ip routing-table 查看路由表
    

    05、telnet远程登陆配置

    user-interface vty 0 4 进入0~4前五个的VTY用户界面进行整体配置
    
    authentication-mode password 设置验证方式为密码
    
    user privilege level 3 设置用户登陆级别
    
    aaa 进入aaa视图
    
    local-user admin password cipher hello privilege level 3在aaa视图下设置账号密码和用户级别
    
    local-user admin service-type telnet 配置该用户接入类型为aaa
    
    q 退回到用户视图
    
    user-interface vty 0 4 进入到VTY用户视图
    
    authentication-mode aaa 设置验证方式aaa
    

    06、配置Stelnet

    配置SSHserver:rsalocal-key-pair create 生成本地RSA主机密钥对
    
    display rsa local-key-pair public 查看本地密钥对中的公钥信息
    
    user-interface vty 0 4 进入VTY用户视图
    
    authentication-mode aaa 设置用户验证方式为aaa授权验证方式
    
    protocol inbound ssh 指定VTY用户只支持ssh
    
    q 返回到系统视图
    
    aaa 进入aaa视图
    
    local-user huawei1 password cipher huawei1 创建用户和设置用户密码
    
    local-user huawei1 service-type ssh 配置本地用户接入类型为ssh
    
    q 退回到用户视图
    
    ssh user huawei1 authentication-type password新建ssh用户指定ssh用户认证方式为password
    
    aaa 进入aaa视图
    
    local-user huawei1 privilege level 3 设置huawei1用户级别为3级别范围0~15
    
    stelnet server enable 开启ssh功能
    
    display ssh user-information huawei1 查看ssh用户配置信息不指定用户默认查看所有用户
    
    display ssh server status 查看ssh服务器全局配置信息
    

    07、STP配置和选路规则

    stp enable 在交换机上启用STP
    
    stp mode stp
    
    dis stp 查看stp配置
    
    dis stp brief 查看接口摘要信息
    
    stp priority 4096 修改交换机优先级为4096
    
    stp root primary 设置交换机为主根交换机
    
    stp root secondary 命令配置备份交换机
    
    display stp interface Ethernet 0/0/2 查看e0/0/2接口的开销值
    
    int e0/0/2
    
    stp cost 2000 配置接口e0/0/2的带价值为2000
    
    stp timer forward-delay 3000 修改STP的ForwardDelay时间为3000cs也就是30s
    
    stp bridge-diameter 3 命令设置网络的直径为3
    
    stp mode rstp 启用RSTP使用RSTP可以缩短收敛时间
    
    int e0/0/1
    
    stp edged-port enable 配置接口e0/0/1为边缘端口不参与生成树的计算
    

    08、配置MSTP多实例

    stp region-configuration 进入MST域视图
    
    region-name huawei 配置MST域名为huawei
    
    revision-level 1 配置MSTP的修订级别为1
    
    instance 1 vlan 10 指定VLAN10映射到MSTI1
    
    active region-configuration 激活MST域配置
    
    display stp region-configuration 查看交换机上当前生效的MST域配置信息
    
    dis stp instance 0 brief 查看实例0中的生成树状态和统计的摘要信息
    
    stp instance 2 priority 0 配置交换机成位实例2中的根交换机
    

    09、RIP路由协议配置

    rip 创建开启协议进程
    
    network + ip 对指定网段接口使能RIP功能IP地址是与路由器直连的网段
    
    debugging rip 1 查看RIP定期更新情况
    
    terminal debugging
    
    terminal monitor 在屏幕上显示debug信息
    
    undo debugging rip 1undo debug all 命令关闭debug调试功能
    
    在上面的配置基础上配置RIP2
    
    rip 进入子视图模式
    
    version 2 配置版本
    
    或者直接配置
    
    rip 1
    
    version 2
    
    network + ip
    

    10、OSPF单区域配置

    ospf 1 进入ospf视图1代表进程号
    
    area 0 创建区域并进入OSPF区域视图,输入要创建的区域ID,骨干区域即区域0
    
    network +IP +匹配码
    
    display ospf interface 命令查看OSPF接口通告是否正确、
    
    display ospf peer 查看OSPF邻居状态
    
    display ip routing-table protocol ospf 查看OSPF路由表
    

    11、配置OSPF区域明文认证

    ospf 1
    
    area 1
    
    authentication-mode simple plain huawei plain是口令以明文方式显示
    
    authentication-mode md5 1 huawei 配置区域密文认证
    

    12、配置链路认证

    int g0/0/1
    
    ospf authentication-mode md5 1 huawei 在一条链路中的两个接口配置要相同
    

    13、配置抑制接口

    ospf 1
    
    silent-interface GigabitEthernet 0/0/1 禁止接口g0/0/1接收和发送ospf报文
    

    14、技巧对多个接口配置接口抑制

    ospf 1
    
    silent-interface all 抑制所有接口
    
    un
    
    display ip routing-table 10.0.1.1 查看10.0.1.1所在网段的路由条目
    

    15、基于接口修改

    int g0/0/0
    
    ospf network-type p2mp 修改ospf的网络类型为多到多点
    
    ospf network-type broadcast 修改ospf的网络类型为广播
    
    ospf dr-priority 100 修改g0/0/0接口的DR优先级为100
    
    reset ospf process 重启ospf进程
    
    ospf cost 1000 修改ospf的开销值为1000
    
    ospf timer hello 20 修改HELLO计时器为20s
    
    ospf timer dead 80 修改dead计时器为80s
    
    ospf 1
    
    preference 110 修改ospf优先级为110值越大优先级越低
    

    16、路由引入

    ospf 1
    
    import-route rip 1 在ospf进程中引入rip
    
    default-route-advertise always 在ospf进程中引入默认路由
    
    rip
    
    import-route ospf 1 在rip进程中引入ospf
    
    import-route ospf cost 3 ospf 引入rip时配置开销值
    
    default-route originate 在RIP进程中发布默认路由
    

    17、vrrp(虚拟路由器冗余协议)基本配置

    int g0/0/0
    
    vrrp vrid 1 virtual-ip 172.16.1.254创建VRRP备份组,备份组号为1,配置虚拟IP为172.16.1.254
    
    vrrp vrid 1 priority 120 修改优先级为120
    
    display vrrp 查看vrrp信息
    
    display vrrp brief
    
    display vrrp interface g0/0/0 查看VRRP的工作状态
    

    18、配置VRRP多备份组

    int g0/0/0
    
    vrrp vrid 1 virtual-ip 172.16.1.254创建VRRP备份组,备份组号为1,配置虚拟IP为172.16.1.254
    
    vrrp vrid 1 priority 120 修改优先级为120
    
    vrrp vrid 2 virtual-ip 172.16.1.253创建VRRP备份组,备份组号为2,配置虚拟IP为172.16.1.253
    
    int g0/0/0
    
    vrrp vrid 1 virtual-ip 172.16.1.254创建VRRP备份组,备份组号为1,配置虚拟IP为172.16.1.254
    
    vrrp vrid 2 virtual-ip 172.16.1.253创建VRRP备份组,备份组号为2,配置虚拟IP为172.16.1.253
    
    vrrp vrid 2 priority 120 修改优先级为120
    
    vrrp vrid 2 preempt-mode disable 开启非抢占方式
    

    19、配置VRRP的跟踪接口及认证

    int g0/0/1
    
    vrrp vrid 1 track interface GigabitEthernet 0/0/0 reduced 50监视上行接口G0/0/0,当此接口断掉时,裁减优先级50,使优先级为70
    
    vrrp vrid 1 authentication-mode md5 huawei 认证配置
    

    20、配置基本的访问控制表

    acl 2000 创建一个编号型ACL,基本ACL的范围是2000~29999
    
    rule 5 permit source 1.1.1.1 0指定规则ID为5,允许数据源地址为1.1.1.1的报文通过,反掩码全为0,即精确匹配
    
    rule 10 deny source any 指定ID为10,拒绝任意源地址的数据包通过
    
    display acl all 查看设备上所有的访问控制列表
    

    #华为交换机日常维护检查命令

    1、查看子卡的运行状态,可以用命令display device。此命令可以查看子卡在位信息及状态信息是否正常。
    在这里插入图片描述
    2、查看设备复位情况,可以用命令display reboot-info。
    在这里插入图片描述
    3、查看设备温度,可以用命令display temperature all。各模块当前的温度应该在上下限之间,即“Current”的值在“Lower”和“Upper”之间。
    在这里插入图片描述
    4、查看设备的告警信息,可以用命令display alarm urgent。如果没有告警就会显示无。
    在这里插入图片描述
    5、查看cpu状态,可以用命令display cpu-usage。各模块的CPU占用率正常。如果出现CPU占用率长时间超过80%或者频繁出现超过80%的情况,建议重点关注。
    图片
    6、查看内存占用情况,可以使用display memory-usage。
    在这里插入图片描述
    7、查看日志信息,可以用display logbuffer或者display trapbuffer。这两个命令为会经常用到
    在这里插入图片描述

    交换机查看命令

    一、查看交换机的端口使用情况

    dis interface brief查看交换机的哪个端口是万兆端口,以及端口状态,那个端口在使用。

    如下图,使用这个命令。
    在这里插入图片描述
    其中端口0/0/1与端口0/0/2处于使用中。其它接口没有使用;如果在实际项目配置了其它的端口,它的状态没有显示up,而是down,那么就要检查端口配置了。

    如果你需要查看端口更详细情况,可以直接输入:

    display interface ?
    在这里插入图片描述
    二、查看交换机虚拟接口对应ip地址使用情况

    二、dis ip int brief 显示虚拟接口对应的 ip地址与使用状态。
    在这里插入图片描述
    虚拟接口的配置在交换机上是极其常见的,一个网络配置有时需要创建3到5个虚拟接口,了解虚拟接口的配置情况也是十分有必要的。

    三、查看交换机创建的vlan

    三、显示已经创建的vlan情况 dis vlan
    在这里插入图片描述
    四、查看交换机正在运行的配置明细

    显示现在交换机正在运行的配置明细 ,可以详细的看到交换机的配置情况,这个命令非常重要,可以详细查看交换机的ip地址、vlan、端口的配置情况。

    display current configuration
    在这里插入图片描述

    五、查看交换机型号与固件版本

    查看交换机的型号与固件版本,在了解交换机参数时很重要,根据交换机性能情况使用交换机。

    display version
    在这里插入图片描述

    六、显示交换机的设备状态情况

    显示设备状态,对查看交换机的状态很有必要。

    display device
    在这里插入图片描述

    七、查看交换机cpu利用率

    当你觉得交换机很卡时,不如查看交换机的cpu利用率

    Display cpu-usage 查看交换机CPU利用率
    在这里插入图片描述
    八、查看交换机内存利用率

    查看交换机内存利用率。

    Display memory
    在这里插入图片描述
    如果发现cpu与内存两者利用率都非常高,再通过输入命令 #Display interface端口号,可以不断的检查各端口下的数据流,如果发现某端口数据流量特别大。
    在这里插入图片描述
    进入该端口配置界面下,输入Shutdown命令,强制关闭该端口使其断网,联系该终端使用人员,令其终止下载进程后,再恢复其网络。

    九、重置交换机,恢复出厂设置

    当你发现交换机的配置很多都有问题,这个时候可以恢复出厂设置。交换机要实现恢复出厂设置,可以通过两种方法来实现,一种是本地配置,另一种是远程配置。

    我们来看下直接用配置实现。

    输入命令reset saved-configuration会提示是否擦除配置文件,按;Y;。
    在这里插入图片描述
    然后再输入命令reboot重启,会提示是否重启设备,按Y。 交换机重启后,就恢复到出厂设置了!
    在这里插入图片描述

    这九大命令都是交换机在配置过程极其常用,对于配置能够起到事半功倍的作用。

    华为交换机DHCP配置基础攻略

    配置服务器
    ⛳. 开启交换机的DHCP服务。

    [huawei]dhcp enable
    

    ⛳ . 配置地址池。

    [huawei]ip pool vlan500
    [huawei-ip-pool-vlan500]network 192 . 168 . 200 . 10 mask 255 . 255 . 255 . 0
    [huawei-ip-pool-vlan500]dns-list 8 . 8 . 8 . 8 114 . 114 . 114 . 114
    [huawei-ip-pool-vlan500]gateway-list 192 . 168 . 200 . 1
    

    ⛳. 进入vlan接口开启该lan dhcp功能。

    [huawei]interface vlanif 10
    [huawei]dhcp select global
    

    ⛳. 将端口加入vlan500 使其成为一个组可以拥有自动获取IP的权力。

    [sw1]interface GigabitEthernet 0/0/2
    [sw1-GigabitEthernet0/0/2]port link-type access
    [sw1-GigabitEthernet0/0/2]port default vlan 500
    [sw1]interface GigabitEthernet 0/0/3
    [sw1-GigabitEthernet0/0/2]port link-type access
    [sw1-GigabitEthernet0/0/2]port default vlan 500
    

    ⛳. 查看配置信息。

    [huawei]display ip pool name 8
    

    配置DHCP
    配置两个地址池:192 . 168 . 1 . 0/24和192 . 168 . 2 . 0/24

    配置两个VLAN:10和20
    将四台主机分别加入VLAN
    自动获取IP地址,确保全网互通。
    步骤:

    [DHCP]DHCP enable
    

    打开DHCP功能

    [DHCP]vlan batch 10 20
    [DHCP]ip pool vlan10
    [DHCP]gateway-list 192 . 168 . 1 . 254
    [DHCP]network 192 . 168 . 1 . 0 mask 255 . 255 . 255 . 0
    [DHCP]lease day 3
    [DHCP]dns-list 8 . 8 . 8 . 8/
    [DHCP]ip pool VLAN 20
    [DHCP]gateway-list 192 . 168 . 2 . 254
    [DHCP]network 192 . 168 . 2 . 0 mask 255 . 255 . 255 . 0
    [DHCP]lease day 3
    [DHCP]dns-list 8 . 8 . 8 . 8/
    

    在服务器上创建VLAN10;20;IP地址池VLAN 10和IP地址池 VLAN 20 .

    [DHCP]interface vlanif10
    [DHCP]ip address 192 . 168 . 1 . 254 255 . 255 . 255 . 0
    [DHCP]dhcp select global
    [DHCP] interface vlanif20
    [DHCP]ip address 192 . 168 . 2 . 254 255 . 255 . 255 . 0
    [DHCP]dhcp select global
    

    给VLAN10,VLAN20配置IP/

    [DHCP]interface gi0/0/1
    [DHCP]port link-type trunk
    [DHCP]port trunk allow-pass all
    [DHCP]interface gi0/0/2
    [DHCP]port link-type trunk
    [DHCP]port trunk allow-pass all
    

    给DHCP服务器1口和2口配置trunk链路

    [SW1]vlan batch 10 20
    [SW1]interface gi0/1
    [SW1]port link-type access
    [SW1]port default vlan 10
    [SW1]interface gi0/2
    [SW1]port link-type access
    [SW1]port default vlan 10
    [SW1]interface gi0/3
    [SW1]port link-type trunk
    [SW1]port trunk allow-pass all
    

    在交换机一上把端口1;2加入VLAN 10;端口3设置成trunk链路

    [SW1]DHCP enable
    

    打开DHCP功能。///交换机二也做相同操作;验证测试保存

    「干货」华为交换机如何查看MAC地址?

    我们在交换机中输入命令“dis mac-address 448A-5BE2-5800”,我们就可以查到这个mac地址所对应的端口。

    我们可以轻松的看到结果是该电脑所对应的是交换机的第八个口。

    假如说你想要找到接口对应的是那台电脑,或者是那个IP地址。用这条命令“dis mac-address gig0/0/8”或者“dis ip interface gig 0/0/8”。

    这样我们就能很轻松的找到,端口和电脑的对应情况。
    在这里插入图片描述
    那么,华为交换机该如何通过MAC地址查找对应接口呢?

    一、查看所有MAC地址

    执行命令display mac-address,查看所有的MAC地址表项。

    二、查看某个接口学习到的MAC地址

    执行命令display mac-address dynamic

    gigabitethernet1/0/1,查看接口GE1/0/1学习到的MAC地址表项。

    三、查看某个VLAN学习到的MAC地址

    执行命令display mac-address dynamic vlan 10,查看VLAN 10学习到的MAC地址表项。

    四、查看系统的MAC地址

    对于二层接口,设备的MAC地址就是接口的MAC地址。可以通过下面两种方式,查看设备的MAC地址。

    执行命令display interface

    gigabitethernet1/0/1,显示信息中的00e0-f74b-6d00,即为设备的MAC地址。
    
    display interface gigabitethernet1/0/1
    
    GigabitEthernet1/0/1 current state : UP
    
    Line protocol current state : UP
    
    Description:
    
    Switch Port, Link-type : access(configured),
    
    PVID : 103, TPID : 8100(Hex), The Maximum Frame Length is 9216
    
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is
    
    00e0-f74b-6d00
    

    …在V200R002版本及之后版本,执行命令display bridge mac-address,查看设备的MAC地址。

    display bridge mac-address
    
    System bridge MAC address: 00e0-f74b-6d00
    

    五、查看接口的MAC地址

    执行命令display interface

    gigabitethernet1/0/1,显示信息中的00e0-f74b-6d00,即为接口的MAC地址。对于二层接口,接口的MAC地址和设备的MAC地址是相同的。

    六、查看VLANIF接口的MAC地址

    执行命令display interface vlanif10,显示信息中的00e0-0987-7891,即为VLANIF接口的MAC地址。

    华为交换机命令基础入门学习

    01、基础配置命令

    1、用户模式

    登陆设备后,直接进入用户模式,尖括号表示用户模式,在这个模式下只能执行少量查看配置的命令;
    在这里插入图片描述
    2、视图模式

    用户模式下,输入system-view或者sys进入视图模式,方括号表示视图模式,可执行设备全局配置的命令;
    在这里插入图片描述
    3、交换机改名
    在这里插入图片描述
    在这里插入图片描述
    这个提示信息,比较烦人。每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉
    在这里插入图片描述
    4、进入接口
    在这里插入图片描述
    5、退出此端口
    在这里插入图片描述
    02、创建vlan并将端口加入vlan

    1、创建vlan

    创建单个vlan
    在这里插入图片描述
    批量创建vlan
    在这里插入图片描述
    2、更改端口的链接类型

    由于华为交换机的端口出厂时默认都是hybrid类型或auto类型的,所以无法立即加入vlan,需要更改端口的link-type后,才可以加入vlan。单个端口更改方式如下:

    为何要选择access类型??

    因为我们是终端PC与交换机相连,要求PC只能只能和上级交换机通信,所以必须只属于1个vlan

    以太网端口的链路类型有三种:

    Access 类型:端口只能属于1 个VLAN,一般用于交换机与终端用户之间的连接;

    Trunk 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,一般用于交换机 之间的连接;

    Hybrid 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,可以用于交换 机之间连接,也可以用于连接用户的计算机。Hybrid 端口可以允许多个VLAN 的报文发送时不携带标签,而Trunk 端口只允许缺省VLAN 的报文,发送时不携带标签。

    • trunk端口用于交换机相连,pvid必须一致。
    • access 类型只能属于1 个vlan
    • 规模较大的企业局域网,不建议使用vlan1,所以trunk端口不允许vlan1通过

    3、端口加入vlan
    在这里插入图片描述
    以上的操作是单个操作,如果配置端口比较多就很麻烦,下面我们来批量操作。

    4、端口的批量操作——端口组

    原理就是创建一个端口组,把要更改的端口加入到端口组中,然后统一更改类型加入vlan。也可以理解为群组端口,统一配置类型加入vlan.

    批量更改,先更改端口类型,再统一加入某个vlan,如下:
    在这里插入图片描述
    5、vlan的查看

    全局查看vlan信息
    在这里插入图片描述
    查看端口与vlan对应关系
    在这里插入图片描述
    6、允许所有vlan通过
    在这里插入图片描述
    03、首次登入交换机或路由器

    第一次上电和恢复出厂是一样的,我们先说一下恢复出厂设置。

    1、恢复出厂设置

    注意Y和N的选项,不要输错。
    在这里插入图片描述
    2、设置新密码

    新交换机第一次上电,或恢复出厂设置后,要求设置新密码

    出厂自带的用户名是admin,密码是admin@huawei.com
    在这里插入图片描述
    3、首次保存配置

    第一次保存设置时,需输入文件名,只需按回车
    在这里插入图片描述
    4、设置日期和时间
    在这里插入图片描述
    设置console口的连接方式,可设置为无,仅密码,用户名密码等方式
    在这里插入图片描述
    5、开启必要的服务和功能

    开启telnet服务,stp功能,http服务
    在这里插入图片描述
    6、设置vty,telnet登录
    在这里插入图片描述
    7、设置一个用户用于网页登录
    在这里插入图片描述
    由于第一次登录时,console口要求用户名密码登录,所以无法删除本地用户admin,此时可退到<>视图,保存设置,退出交换机,再重新登录。由于我们已经将console口的认证方式改为仅需密码,所以可以再次进入aaa,删除用户admin。删除后,再建立admin,权限,服务类型等,均可由我们自己控制。
    在这里插入图片描述
    如遇更新版本的交换机软件,telnet服务要求必须是aaa认证(用户名密码认证),可按上面所述再建立一个用户,service-type设置为telnet。

    8、关闭交换机自动弹出配置改变告警

    输入配置命令后设备会提示如下类似信息:
    在这里插入图片描述
    这个是配置改变的告警提示信息,不是错误信息,可以配置如下命令屏蔽此信息:
    在这里插入图片描述
    04、设置链路聚合
    在这里插入图片描述
    以上命令建立一个聚合端口,并设置了端口的属性
    在这里插入图片描述
    以上命令将G 0/0/25端口加入聚合端口eth-trunk 1,无需更多设置。可将更多的端口加入聚合端口。

    05、交换机DHCP

    开启DHCP功能,设置地址池,并应用
    在这里插入图片描述
    06、开启流控制功能,限制某些网段互链

    主要是限制访客网与办公网、财务网互访
    在这里插入图片描述
    注意源地址和目的地址的反向掩码
    在这里插入图片描述

    华为交换机常用配置命令,一步一步跟着学

    Vlan是虚拟局域网的意思,它相当于一个局域网工作组。“vlan几”可以理解成编号为几的vlan,比如vlan 2就是编号为2的vlan,只是一个编号而已,并不是说vlan 2的网段一定要是2网段,vlan2的IP地址是可以随便设置的。

    下面我将三层交换机的第20个端口添加到vlan 10里,步骤如下:

    ①在交换机里添加VLAN 10

     system-view     (一般用缩写:sys)
    [Quidway] vlan 10           (添加编号为10的vlan)
    [Quidway-vlan10] quit       (一般缩写:q
    

    ②设置vlan 10的IP地址为192.168.66.66 网关为255.255.255.0

    [Quidway]interface vlanif 10 (interface一般可以缩写为:int  ;vlanif也可以只写vlan)
    
    [Quidway-vlanif10] ip address 192.168.66.66  255.255.255.0 (address缩写add)
    
    [Quidway-vlanif10]quit
    

    ③设定交换机上第20个端口模式为access (默认为trunk,需在将端口划入VLAN前转为ACCESS)

    [Quidway] int gigabitethernet 0/0/20     (gigabitethernet:千兆以太网口)
    [Quidway-GigabitEthernet0/0/20] port link-type access   (port:端口)
    [Quidway-GigabitEthernet0/0/20]quit
    

    ④将第20个端口加入到vlan 10里

    [Quidway] vlan 10
    [Quidway-vlan10] port gigabitethernet 0/0/20 (如果是多个连续端口,用XX to XX)
    [Quidway-Vlan10]quit
    

    这样就是成功的将交换机上的第20个端口添加到了编号为10的Vlan 里,划分VLAN就是这4个步骤,2个步骤设置vlan,2个步骤设置端口。现在可以用网线把交换机的第20个端口和电脑网卡连接起来,设置网卡地址为192.168.66.XX,网关为192.168.66.66,在CMD里ping192.168.66.66可以ping通。

    2、删除VLAN
    ①在系统视图下,用“undo int vlan 2”命令删除vlan 2的3层口,这样vlan 2就没有了,但是划分给vlan 2的那些端口依然还处于vlan 2里,这时可以将那些端口释放出来,让他们不再属于任何vlan

    ②在系统视图下,用“undo vlan 2”命令删除2层口,这个命令可以释放那些原先划分给了vlan 2的端口,现在它们不属于任何vlan了。

    当然,将交换机上的某个端口更换到某个vlan里,是可以直接在vlan视图里添加端口的。

    注意:交换机上的某个端口被设置成了access模式,且加入了一个vlan,要想将这个端口的模式更改为trunk,直接在端口视图里打上“port link-type trunk”是不行的,会出现Error: Please renew the defaultconfigurations.这时需要先从VLAN里删除这个端口,也就是前面说的让这个端口不属于任何vlan,才能将这个端口设置为trunk。

    3、通过端口进行限速

    现在要对交换机上的第2个端口进行限速操作,让通过这个端口的下载速度不超过128KB/S

    配置命令说明:

    Inbound:对入端口报文进行限速
    
    Outbound:对出端口报文进行限速
    
     sys
    [Quidway] intgigabitethernet 0/0/2
    
    [Quidway-GigabitEthernet0/0/2] qos lr outbound cir 1024 cbs204800  (1024代表1M的带宽,理论下载速度就是128KB/S,204800=1024*200,cbs代表突发信息速率 cir代表承诺信息速率 )
    

    这个命令执行后,端口2的下载速度就被限制在128KB/S以内,实际测速表明,这个限速数值是该端口数据流量稳定后的速度,它的短暂峰值高出128KB/S很多,这个应该是交换机从侦测端口流量到启动限速需要一个过程,下载速度稳定后是在128KB/S上下徘徊,效果还是不错的,比路由器限速和限速软件的效果都要好很多,最关键的交换机稳定。

    注:取消限速方法

    [Quidway-GigabitEthernet0/0/2] undo qos lr outbound

    4、配置基于地址池的DHCP服务器

    ①全局启动DHCP服务。

    sys
    
    [Quidway] dhcp enable
    

    ②配置IP地址池10的属性(地址池范围,dns地址,出口网关,地址池租期)

    [Quidway] ip pool 10
    
    Info:It's successful to create an IP address pool.
    
    [Quidway-ip-pool-10] network 192.168.10.0 mask 255.255.255.0
    
    [Quidway-ip-pool-10] dns-list 202.103.24.68
    
    [Quidway-ip-pool-10] gateway-list 192.168.10.1
    
    [Quidway-ip-pool-10] lease day 10
    
    [Quidway-ip-pool-10] q
    

    ③将接口GE0/0/1加入到VLAN 10

    [Quidway] vlan 10
    [Quidway-vlan10] port gigabitethernet 0/0/1 (如果是多个连续端口,用XX to XX)
    [Quidway-Vlan10]quit
    

    ④配置VLANIF10接口下的客户端从全局地址池中获取IP地址

    [Quidway]int vlan 10
    
    [Quidway-vlanif10] ip add 192.168.10.1 24
    
    [Quidway-vlanif10] dhcp select global
    
    [Quidway-vlanif10] q
    

    这时,可以用“dis ip pool”命令查看IP地址池配置情况

    最后可以在电脑上验证是否成功
    在这里插入图片描述
    5、telnet远程登录设置

    system-view
    
    [Quidway]aaa                          (进入aaa视图)
    [Quidway-aaa] local-user tcwq passwordcipher tcwq (cipher是暗号的意思,password cipher就是指密码显示出来的是乱码,在用dis cur命令时,看到的密码是乱码)
    
    [Quidway-aaa] local-user tcwq passwordsimple tcwq (simple是简单的意思,passwor simple:弱口令,可以理解为明文,和cipher是相对的,在用dis cur命令时,看到的密码是明文)
    
    [Quidway-aaa] local-user tcwq  service-type  telnet (设置用户tcwq的登录方式为telnet)
    
    [Quidway-aaa] local-user tcwqprivilege level 3 (privilege level:权限级别,3为最高级别,拥有最高权限)
    
    [Quidway-aaa] q
    [Quidway]user-interface vty 04  (vty:虚拟终端,0 4代表有0到4一共最多5个终端可以同时登录到交换机)
    
    [Quidway-vty0-4]authentication-modeaaa (authentication:认证,验证。验证模式设置为aaa模式)
    
    [Quidway -ui-vty0-4]q
    

    设置完毕,这时可以在cmd里telnet 网关,即可登录到交换机。

    下面是S5324和S5700成功配置telnet后的截图
    在这里插入图片描述
    在这里插入图片描述
    注意:当提示验证失败时,将网卡禁用再启用可以解决问题。

    6、配置FTP服务器

    建立一个FTP服务器,用户名为tcwq,密码为tcwq

    sys
    
    [Quidway] ftp server enable  (开启FTP服务)
    
    [Quidway] aaa
    
    [Quidway-aaa] local-user tcwq passwordsimple tcwq
    
    [Quidway-aaa] local-usertcwq  service-type ftp
    
    [Quidway-aaa] local-usertcwq  ftp-directory  flash:/  (配置FTP用户的访问路径,如果不配置这一项,登录时会提示“530 logged incorrect”)
    
    [Quidway-aaa] q
    

    这时用网线把电脑网卡和交换机的某个端口相连,电脑IP设置为和该端口所在Vlan的网关同一网段的地址(如IP:192.168.1.128,网关:192.168.1.1),在CMD命令行里输入FTP 192.168.1.1即可进入FTP的验证界面,输入账号tcwq,密码tcwq,即可登录
    在这里插入图片描述
    登录到ftp后,可以从交换机的Flash里下载文件到电脑里(下载的文件所在位置是登录到ftp服务器前的盘符,如上图中是从F盘根目录登录到FTP的,那么文件都会被下载到F盘的根目录里),也可以从电脑里选择文件上传到交换机的Flash里(速度很快,比串口烧录快多了),还可以删除flash里文件

    ftp>dir             (查看文件)
    
    ftp>getvrpcfg.zip     (下载文件名为“vrpcfg.zip”的文件)
    
    ftp>put f:\S5700\web.zip  (将电脑F盘里名字为S5700的文件夹里的web.zip文件上传的交换机的Flash里)
    
    ftp>deleteweb.zip          (删除文件名为“web.zip”的文件) 
    

    7、WEB网页管理

    三层交换机可以进行网页管理,前提是HTTP服务要开启,且交换机Flash里有web管理文件并被成功加载。

    上一步进行了FTP服务器配置,如果交换机里没有ZIP后缀名的WEB管理文件,就需要先用FTP把WEB管理文件上传到Flash里

    ftp> put f:\S5700\web.zip
    
    200 Port command okay.
    
    150 Opening ASCII mode data connection for web.zip.
    
    226 Transfer complete.
    

    显示到这里就说明web.zip文件被成功上传到Flash里了。

    下面就需要在终端或者telnet里将刚刚上传的web.zip进行加载

    sys
    
    [Quidway] http server loadweb.zip  (加载web.zip)
    

    接下来就可以开启HTTP服务了,在没有加载web.zip之前,HTTP服务是开启不了的

    [Quidway] http server enable
    

    现在建立一个网管账号,账户名xiaodong,密码xiaodong

    [Quidway] aaa
    
    [Quidway-aaa] local-user xiaodong passwordsimple xiaodong
    
    [Quidway-aaa] local-user xiaodong  service-typehttp
    
    [Quidway-aaa] q
    

    这时可以在电脑上打开浏览器,输入192.168.1.1,进入登录验证界面,输入账号xxx,密码xxx,验证码,即可登录。
    在这里插入图片描述

    参考链接 :

    华为交换机常用配置命令,一步一步跟着学

    https://mp.weixin.qq.com/s/UCfvMJNtC1HKY0dRTrmmoA

    华为交换机命令基础入门学习,菜鸟也能看得懂!
    https://mp.weixin.qq.com/s/ljZJ7Z4kwmOsLdQcEmPEJA

    「干货」华为交换机如何查看MAC地址?
    https://mp.weixin.qq.com/s/w5ZWt0GptCXML01PSBZFHw

    【每日干货】华为交换机DHCP配置基础攻略
    https://mp.weixin.qq.com/s/xU9NMPaU6pIEx64rgI3yGA

    学以致用,华为交换机配置命令汇总 https://mp.weixin.qq.com/s/Qo16tWXoQQda7jbVkkKKPw

    华为交换机日常维护检查有哪些常用的命令?
    https://mp.weixin.qq.com/s/OoyE4YpVFvd6nioOX4O1RQ

    华为交换机常用配置.二.配置SSH连接.2020年5月16日 :https://www.jianshu.com/p/935478a309e1

    华为交换机常用配置.一.华为交换机周边.2020年5月16日 :https://www.jianshu.com/p/b24623872bbc

    华为交换机进入BOOTROM(修改console口密码):https://mp.weixin.qq.com/s/hbsU93ogoSrbl6THrMHEHQ

    华为交换机的基本配置 : https://mp.weixin.qq.com/s/YCfwac3mdhXrZ38Ty4_G6Q

    华为交换机的基本配置 : https://mp.weixin.qq.com/s/HsJ5wo6waC2f0Rcb0zW5Wg

    华为交换机最常用的基础命令汇总大全,非常实用!
    https://mp.weixin.qq.com/s/JlsYsCQlLSD48MhUtAo7qw

    展开全文
  • 华为交换机ssh配置

    千次阅读 2019-12-26 00:30:20
    下文一共四个步骤。 一,生成本地服务端生成密钥 [Huawei]rsa local-key-pair create ...二,配置VTY [Huawei]user-interface vty 0 4 [Huawei-ui-vty0-4]authentication-mode aaa [Huawei-ui-vty0-4]protoco...

    telnet是明文,可以通过抓包查看到密码,ssh是密文比较安全。下文一共四个步骤。

    一,生成本地服务端生成密钥

    [Huawei]rsa local-key-pair create
    

    二,打开shh服务,认证方式,创建用户名,密码及权限

    [Huawei]stelnet server enable
    [Huawei]aaa
    [Huawei-aaa]local-user admin privilege level 3 password cipher 123
    [Huawei-aaa]local-user admin service-type ssh
    [Huawei-aaa]q
    

    三,配置VTY

    [Huawei]user-interface vty 0 4
    [Huawei-ui-vty0-4]authentication-mode aaa
    [Huawei-ui-vty0-4]protocol inbound ssh
    

    四,最后别忘记配置个IP,即可远程连接

    展开全文
  • 华为交换机堆叠配置详解

    万次阅读 多人点赞 2020-07-02 11:58:24
    配置sw1的业务口GigabitEthernet0/0/1、GigabitEthernet0/0/2为物理成员端口,并加入到相应的逻辑堆叠端口。 sw1: int stack-pork 0/1 port int g0/0/1 enable int stack-port 0/2 port int g0/0/2 enable 不配置堆...

    双机堆叠
    在这里插入图片描述
    sw1和sw2进行堆叠
    配置sw1的业务口GigabitEthernet0/0/1、GigabitEthernet0/0/2为物理成员端口,并加入到相应的逻辑堆叠端口。
    sw1:
    int stack-pork 0/1
    port int g0/0/1 enable
    int stack-port 0/2
    port int g0/0/2 enable
    不配置堆叠成员号和优先级,使用默认的成员号0和默认的优先级100

    sw2:
    stack slot 0 renumber 1 #修改堆叠成员号,默认为0,这里修改为1
    stack slot 0 priority 10 #修改优先级,默认为100,值越大优先级越高
    int stack-pork 0/1
    port int g0/0/1 enable
    int stack-port 0/2
    port int g0/0/2 enable

    三机及以上堆叠(推荐使用环形堆叠)
    在这里插入图片描述
    配置方法同双机堆叠相同
    需要注意的点为每台机器出两根线分别连接两台设备,两个设备间只有一条线,双机堆叠为两台机器间连接两根线

    sw1:
    stack slot 0 priority 200 #修改优先级,默认为100,值越大优先级越高
    int stack-pork 0/1
    port int g0/0/1 enable
    int stack-port 0/2
    port int g0/0/2 enable

    sw2:
    stack slot 0 renumber 1 #修改堆叠成员号,默认为0,这里修改为1
    int stack-pork 0/1
    port int g0/0/1 enable
    int stack-port 0/2
    port int g0/0/2 enable
    #使用默认优先级100,无需配置

    sw3:
    stack slot 0 renumber 2 #修改堆叠成员号,默认为0,这里修改为1
    int stack-pork 0/1
    port int g0/0/1 enable
    int stack-port 0/2
    port int g0/0/2 enable
    #使用默认优先级100,无需配置

    注:较老版本,在将业务口加到stark-port之前
    须配置:
    stack port interface g0/0/1 enable
    然后再添加进堆叠口
    int stack-port 0/1
    port member-group interface g0/0/1

    其他配置同上

    监测方式:
    1.直连检测
    stack:
    int g0/0/5
    mad detect mode direct

    int g1/0/5
    mad detect mode direct

    2.Relay代理检测

    relay代理检测配置:
    stack(堆叠后的交换机集群)配置跨设备eth-trunk
    int eth-trunk 10
    trunkport g0/0/10
    trunkport g1/0/10
    trunkport g2/0/10
    mad detect mode relay #配置跨设备eth-trunk的代理方式多主检测功能
    return

    代理检测设备sw4
    int eth-trunk 10
    mad relay
    return

    查看配置信息
    stack:
    dis mad verbose
    查看代理信息
    sw4:
    dis mad proxy

    展开全文
  • 华为交换机vlan配置教程

    万次阅读 多人点赞 2018-07-24 15:56:14
    Sys \\进入系统视图 Dhcp enable \\全局开启dhcp功能 Vlan bacth 2 3 4 ...\\将交换机端口1和2加入端口组1 Port link-type access  \\端口链路类型访问 Port default vlan 2 \\将端口组加入vlan2
  • 华为交换机VLAN配置

    2013-05-18 17:56:17
    华为交换机VLAN配置.doc
  • 华为交换机配置命令超详解.doc
  • 华为交换机基本配置命令大全

    千次阅读 2019-12-02 13:42:16
    查看万兆端口模块收发光:...一、单交换机VLAN划分 命令 命令解释 system 进入系统视图 system-view 进入系统视图 quit 退到系统视图 undo vlan 20 删除vlan 20 sysname 交换机命名 disp vlan 显示vlan...
  • 华为交换机基础配置命令参考

    万次阅读 多人点赞 2019-03-24 10:06:03
    华为交换机基础配置命令参考 基础配置 用户模式 登陆设备后,直接进入用户模式,只能执行少量查看配置的命令; 视图模式 用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令; 局部配置...
  • 华为交换机路由器ACL原理+最常用操作配置手册
  • 华为交换机配置DHCP服务器

    万次阅读 2018-04-28 19:42:01
    1.开启交换机的DHCP服务。[huawei]dhcp enable2.配置地址池。[huawei]ip pool 8 [huawei-ip-pool-8]network 192.168.8.0 mask 255.255.255.0 [huawei-ip-pool-8]dns-list 223.5.5.5 223.6.6.6 [huawei-ip-pool-8]...
  • 华为交换机SNMP配置

    万次阅读 2019-01-21 09:56:31
    snmp-agent sys-info contact ...这个值初始是HuaWei BeiJing China,用指令display current-configuration可以在当前执行的配置的靠末尾看到该项。 snmp-agent sys-info location [value]设置交换机的位置信息,这...
  • 华为交换机基本配置命令详解.docx
  • 华为三层交换机配置方法、命令及实例,华为三层交换机配置方法、命令及实例
  • 华为交换机基本配置,秒看秒懂~~~

    千次阅读 多人点赞 2020-02-28 19:28:51
    一、交换机基本配置 交换机连接方式 本地:计算机COM口/USB口 --> Console线 --> 交换机Console口 远程:Putty、SecureCRT、Xshell远程管理工具 华为VRP网络操作系统 1)华为有四种视图模式 <Huawei> ...
  • 自己做的实验,网上找了好久没找到详细的,所以自己就传了个~共同学习!
  • 华为交换机配置命令总结

    千次阅读 多人点赞 2019-03-04 12:20:07
    1、配置文件相关命令 [Quidway]display current-configuration 显示当前生效的配置 [Quidway]display saved-configuration 显示flash中配置文件,即下次上...reboot 交换机重启 display version 显示系统版本信息...
  • 华为入门级三层交换机S系列配置操作详解,用于控制台登陆或tel登陆配置交换机
  • 详细讲解多个华为交换机配置实例

    千次阅读 2017-09-15 17:15:01
    详细讲解多个华为交换机配置实例交换机的配置是网络管理员的基本技能,本文以华为S5700交换机为例,结合使用sNSP模拟器,详细阐述VLAN配置、VLAN之间通信、跨交换机VLAN配置、跨交换机VLAN之间通信等。(备注:以下...
  • 因为根据有些群朋友反映,华为交换机使用的比较多,所以本次以华为交换机为例,如果大家以前对vlan了解不深,那么这篇文章却是可以很好入门与深入。一、什么样的网络才能互通通常情况下,两台电脑如何能...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,233
精华内容 493
关键字:

华为交换机配置详解