精华内容
下载资源
问答
  • 前几天研究了下SSH2通信的加密与认证过程,针对publickey认证方式,服务器端将公钥放入authorized_keys文件就可以了,但是交换机方面如何配置呢?So,今天主要说一下交换机是如何配置的。 在介绍之前提前提及一下...

    前几天研究了下SSH2通信的加密与认证过程,针对publickey认证方式,服务器端将公钥放入authorized_keys文件就可以了,但是交换机方面如何配置呢?So,今天主要说一下交换机是如何配置的。

    在介绍之前提前提及一下后面会用到的几个工具:

    1、ssh-keygen:openssh中认证秘钥生成、管理和装换的一个工具。

    详情参见:http://man7.org/linux/man-pages/man1/ssh-keygen.1.html

    2、egrep:相当于grep -E

    grep详情参见:https://www.runoob.com/linux/linux-comm-grep.html


    好啦,进入正题,大致分为两方面进行:

    第一方面:客户端将公钥转换成16进制字符串

    1. 为客户端生成秘钥对,默认存放位置 ~/.ssh/

    ssh-keygen -t rsa -b 1024 -f yourkeyname -C "备注"

    2. 将公钥转换成为16进制字符串形式

    ssh-keygen -e -m pem -f 公钥存放的绝对路径 | egrep -v "BEGIN|END" | base64 -d | od -t x1 -An -w4 | tr 'a-f' 'A-F' | tr -d ' ' | fmt -w 48

    注意:我一开始使用的自己的开发虚拟机,系统本身就很老,里面的openssh版本太老,ssh-keygen好多参数用不了,后来使用OpenSSH_7.4版本则可以支持。

    第二方面:交换机配置rsa认证(使用的华为交换机:S5700-24TP-SI-AC)

    1. 公钥导入交换机,命名rsa

    rsa peer-public-key rsa

    public-key-code begin

    粘贴16进制公钥

    public-key-code end

    peer-public-key end

    2. 创建aaa用户sshtest,密码hf123456,设置认证类型为ssh

    aaa
    local-user sshtest password cipher hf123456 privilege level 15
    local-user sshtest service-type ssh
    quit

    3. 添加ssh用户及认证方式

    ssh user sshtest authentication-type rsa
    ssh user sshtest assign rsa-key rsa
    ssh user sshtest service-type all

    4. 配置vty界面支持的登录协议 并 开启服务

    user-interface vty 0 4
    authentication-mode aaa
    protocol inbound ssh  /* 这里 ssh或all都可以 */
    quit

    stelnet server enable
    sftp server enable

    5. ok,大功告成,下面给他家贴一个我测试的客户端连接成功图!


    结语:

    以上就是大致的配置过程,从配置中可以看出,除了单独的password和rsa方式外,还可以两种方式结合进行认证,等有时间了再试一下其他几种认证方式(#^.^#)!

    最后结尾处贴出了我的调试信息结果图,等整理下代码,下次会把相关代码发上来。

    ------ 谢谢您的阅读,若文章内容有什么问题,欢迎指出,大家共同进步!

    参考连接:

    1. https://blog.csdn.net/qq_27860819/article/details/81568121

    2. https://www.cnblogs.com/fatt/p/5822450.html

    展开全文
  • 华为交换机ssh配置

    千次阅读 2019-12-26 00:30:20
    下文一共四个步骤。 一,生成本地服务端生成密钥 [Huawei]rsa local-key-pair create 二,配置VTY [Huawei]user-interface vty 0 4 [Huawei-ui-vty0-4]authentication-mode aaa [Huawei-ui-vty0-4]protoco...

    telnet是明文,可以通过抓包查看到密码,ssh是密文比较安全。下文一共四个步骤。

    一,生成本地服务端生成密钥

    [Huawei]rsa local-key-pair create
    

    二,打开shh服务,认证方式,创建用户名,密码及权限

    [Huawei]stelnet server enable
    [Huawei]aaa
    [Huawei-aaa]local-user admin privilege level 3 password cipher 123
    [Huawei-aaa]local-user admin service-type ssh
    [Huawei-aaa]q
    

    三,配置VTY

    [Huawei]user-interface vty 0 4
    [Huawei-ui-vty0-4]authentication-mode aaa
    [Huawei-ui-vty0-4]protocol inbound ssh
    

    四,最后别忘记配置个IP,即可远程连接

    展开全文
  • 华为交换机开局配置

    千次阅读 2019-10-23 21:21:29
    rsa local-key-pair create ssh user admin ssh user admin authentication-type password ssh user admin service-type all vlan batch 10 100 interface Vlanif100 ip address 192.168.1.2 255.255.255.252 ip...
    sysname SWITCH
    
    aaa
    undo local-aaa-user password policy administrator
    local-user admin password irreversible-cipher admin
    local-user admin privilege level 1
    local-user admin service-type terminal ssh
    
    super password level 15 cipher admin
    
    stelnet server enable 
    rsa local-key-pair create
    ssh user admin
    ssh user admin authentication-type password
    ssh user admin service-type all
    
    vlan batch 10 100
    
    interface Vlanif100
     ip address 192.168.1.2 255.255.255.252
    
    ip route-static 0.0.0.0 0.0.0.0 192.168.1.1
    
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     stp root-protection
     
    interface XGigabitEthernet0/0/1
     eth-trunk 1
    interface XGigabitEthernet1/0/1
     eth-trunk 1	 
    
    interface XGigabitEthernet0/0/18
     port link-type access
     port default vlan 10
     stp bpdu-filter enable
     stp edged-port enable
     
    clock timezone beijing add 08:00:00
    ntp-service unicast-server xxx.xxx.xxx
    
    acl number 3000
     rule 5 permit tcp source 10.10.10.0 0.0.0.255 destination-port eq 22
    
    snmp-agent
    snmp-agent sys-info version v3
    snmp-agent group v3 group-admin privacy read-view group-admin
    snmp-agent usm-user v3 user-admin
    snmp-agent usm-user v3 user-admin group group-admin
    snmp-agent usm-user v3 user-admin authentication-mode sha cipher Authe@123
    snmp-agent usm-user v3 user-admin privacy-mode aes128 cipher Priva@123
    snmp-agent target-host trap address udp-domain 10.10.10.1 params securityname user-admin v3 privacy
     
    user-interface vty 0 4
    authentication-mode aaa
    protocol inbound all
    acl 3000 inbound
    
    展开全文
  • 华为交换机SSH配置

    千次阅读 2020-06-15 14:19:49
    [Huawei]rsa local-key-pair create 二、配置VTY## [Huawei]user-interface vty 0 4进入虚拟终端 [Huawei-ui-vty0-4]authentication-mode aaa认证模式AAA [Huawei-ui-vty0-4]protocol inbound ssh 配置允许登录接...

    设备:S5700

    一、在本地设备服务端生成秘钥对##

    [Huawei]rsa local-key-pair create

    二、配置VTY##

    [Huawei]user-interface vty 0 4进入虚拟终端

    [Huawei-ui-vty0-4]authentication-mode aaa认证模式AAA

    [Huawei-ui-vty0-4]protocol inbound ssh 配置允许登录接入用户类型的协议(all | ssh | telnet)

    三、创建用户以及密码##

    [Huawei]aaa 进入AAA
    [Huawei-aaa]local-user admin password cipher admin privilege level 3设置用户名密码、用户等级

    [Huawei-aaa] local-user adminssh service-type ssh 在三aaa服务中开启ssh服务,一定要开

    四、打开服务以及认证方式##

    [Huawei]stelnet server enable 打开SSH
    [Huawei]ssh user admin authentication-type password 认证模式为密码模式
    [Huawei]ssh user admin service-type stelnet 服务方式

    五、实现##



    展开全文
  • 华为交换机常用配置命令

    千次阅读 2020-03-02 22:25:54
    华为交换机常用配置命令
  • 华为交换机sftp 配置

    千次阅读 2020-09-01 11:21:19
    sftp server配置 sys [R2]aaa [R2-aaa]local-user huawei2 password cipher huawei2 Info: Add a new user. [R2-aaa]local-user huawei2 privilege level 3 [R2-aaa]local-user huawei2 ftp-directory flash: [R2]...
  • 华为交换机配置ssh rsa认证登录方式

    千次阅读 2016-11-16 10:27:00
    systemrsa local-key-pair createstelnet server enable输入公钥* * *New Key from Linux ssh-keygen```systemrsa peer-public-key newpublic-key-code beginpublic-key-code endpeer-public-key end```配置ssh...
  • 网络设备如何配置SSH远程登陆
  • 今天给大家带来的是如何在华为交换机配置Telnet和SSH的配置。实验拓扑如下 实验拓扑 实验需求 按照图示连接到真机,并配置IP地址(真机IP地址配置到VirtualBox Host-Only Ethernet Adapter网卡) 在SW1开启Telnet...
  • 华为交换机配置SSH登录

    千次阅读 2021-04-12 15:00:09
    [Huawei] rsa local-key-pair create //创建rsa本地密钥对 [Huawei]aaa //进入aaa模式 [Huawei-aaa]local-user admin password ciper mima //配置登录用户密码(admin是登录用户名,mima是登录密码) [Huawei-aaa]...
  • 华为交换机5700 SSH配置

    千次阅读 2020-04-20 19:44:39
    [Huawei]rsa local-key-pair create //在本地生成密匙 二、配置VTY [Huawei]user-interface vty 0 4 //进入虚拟终端 [Huawei-ui-vty0-4]authentication-mode aaa //认证模式为AAA [Huawei-ui-vty0-4]protocol ...
  • 一、华为S5700交换机初始化和配置SSH和TELNET远程登录方法: 配置登陆IP地址: system-view //进入系统配置模式 [Quidway]interface Vlanif 1 //进入三层 vlanif 接口 [Quidway-Vlanif1]ip ad...
  • 交换机的基础命令汇总 system-view 进入系统视图 quit 退到系统视图 sysname 交换机命名 vlan 20 创建vlan(进入vlan20) display vlan 显示vlan undo vlan 20 删除vlan20 display vlan 20 显示vlan里的...
  • 本次实施将三台思科的百兆交换机以及三台华为的百兆交换机换成六台华为的千兆交换机。实现设备以及带宽的一次升级。 基本的配置就是给交换机划分VLAN,修改接口模式,放行VLAN数据,写上生成树等等;写上这些配置...
  • 今天拿到一台华为S3500,已经比较久远了,没有aaa模式,查阅了一些文档,找到了配置SSH的方法,现分享如下。 sys rsa local-key-pair create 创建rsa密钥 user-interface vty 0 4 authentication-mode scheme 认证...
  • 配置思路】 1.在本地的SSH服务端生成本地需要...[SW1] rsa local-key-pair create #创建本地密钥对 The key name will be: SW1_Host The range of public key size is (512 ~ 2048). NOTES: If the key modulus is gr
  • 1、生成秘钥 需要在你自己电脑上生成 执行下面命令,默认生成位置是~/.ssh ...-b 采用长度1024bit的密钥对,b=bits,最长4096,不过没啥必要-t rsa 采用rsa加密方式,t=type-f 生成文件名,f=output_keyf...
  • SSh server配置 sys [Huawei]int gi0/0/0 [Huawei-GigabitEthernet0/0/0]ip add 10.0.0.2 24 [Huawei-GigabitEthernet0/0/0]q [Huawei]sysna [Huawei]sysname R2 [R2]rsa local-key-pair create The key name will ...
  • 因为tcp是基于字节流的协议,所以这两种远程管理配置方式对流量的延迟或者抖动非常敏感。(二者都是交互式数据流) telnet完全是明文交互,非常不安全。通过tcp字节流跟踪,得到以下截图: 从此图可以看出完全是明文...
  • 公司买了一套RSA Securid,于是乎就想想华为的路由器和交换机也加入RSA来进行密码登陆管理。可是网上却没有相关的资料,在与华为RSA厂家的配合下,一起...华为的路由器和交换机想通过RSA Securid来实现认证登陆,...
  • 如何利用华为交换机配置SSH登录

    千次阅读 2017-11-17 12:04:00
    SSH是在传统的Telnet协议之基础上发展起来的一种安全的远程登录协议。相比于Telnet,SSH无论是在认证方式或者数据传输...[Huawei]rsa local-key-pair create The key name will be: Huawei_Host The range of public...
  • 华为交换机 ssh和Telnet远程登录配置命令 ##定位合肥 ,有没有大的公司招人 ,正在考IE中 联系方式 QQ481715271 ** 简单拓扑 ** LSW4 vlan 20配置地址的原因是SSH Telnet 都可以登录 LSW3 配置 vlan batch 10 20 ...
  • user-interface vty 0 4 ...ssh user huawei authentication-type password # ssh user huawei service-type stelnet # aaa # local-user shouxin password cipher huawei # local-user shouxin privilege level...
  • [LSW1-aaa]local-user huawei password cipher huawei # 新建用户名密码 [LSW1-aaa]local-user huawei privilege level3 # 用户权限等级 [LSW1]ssh user huawei authentication-typepassword # 认证类型 [LSW1]ssh...
  • 华为交换机配置命令汇总

    千次阅读 2019-09-30 08:17:19
    配置对SSH用户进行dsa、rsa、password-dsa或password-rsa验证 S ystem-view Rsa peer-public-key  key-name  [ encoding-type { der | openssh | pen } ] or Dsa peer-public-key   key-name   ...
  • 华为交换机配置consol密码及vty密码

    千次阅读 2017-04-26 22:41:52
    # 以登录用户界面的认证方式为密码认证,密码为Huawei@123为例,配置如下。<HUAWEI>system-view [HUAWEI]user-interfaceconsole0 [HUAWEI-ui-console0]authentication-modepassword [HUAWEI-ui-console0]...
  • 默认22 [SW1]display ssh server status #查看ssh服务状态 [SW1]display ssh server session #查看ssh服务会话 SSH用户认证方式分六种: 1)rsa (需配置ssh用户) 2)dsa (需配置ssh用户) 3)password (需同时...
  • 用户通过串口登录新交换机,对交换机进行初始化配置。 操作步骤以一个交换机为例说明配置过程。 必备事项 请按照现网网设文档获取交换机的基础配置数据。 操作步骤 1、本地PC使用串口线连接到交换机的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 422
精华内容 168
关键字:

华为交换机rsa配置