精华内容
下载资源
问答
  • 华为交换机 ssh和Telnet远程登录配置命令 ##定位合肥 ,有没有大的公司招人 ,正在考IE中 联系方式 QQ481715271 ** 简单拓扑 ** LSW4 vlan 20配置地址的原因是SSH Telnet 都可以登录 LSW3 配置 vlan batch 10 20 ...

    华为交换机 ssh和Telnet远程登录配置命令

    ##定位合肥
    联系方式 QQ481715271

    **

    • 简单拓扑

    **

    在这里插入图片描述LSW4 vlan 20配置地址的原因是SSH Telnet 都可以登录

    LSW3 配置
    vlan batch 10 20

    interface Vlanif10
    ip address 192.168.10.1 255.255.255.0

    interface Vlanif20
    ip address 192.168.20.1 255.255.255.0

    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    q

    ##配置rsa密钥
    rsa local-key-pair creat
    512
    q

    ## 进入用户视图
    user-interface vty 0 4
    authentication-mode aaa
    protocol inbound all

    ##配置AAA认证

    aaa
    local-user admin password simple 123456
    local-user admin privilege level 15
    local-user admin service-type telnet ssh
    q
    ##开启stelnet服务
    stelnet server enable
    ssh user admin
    ssh user admin authentication-type password
    ssh user admin service-type stelnet

    LSW3配置完毕

    LSW4配置

    vlan batch 10 20
    interface Vlanif20
    ip address 192.168.20.2 255.255.255.0
    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    ip route-static 0.0.0.0 0.0.0.0 192.168.20.1##这里要配置一条指向性静态路由,否则Telnet找不到管理地址;

    ##配置rsa密钥
    rsa local-key-pair creat
    512
    q

    ## 进入用户视图
    user-interface vty 0 4
    authentication-mode aaa
    protocol inbound all

    ##配置AAA认证

    aaa
    local-user admin password simple 123456###这里密码可以改
    local-user admin privilege level 15
    local-user admin service-type telnet ssh
    q
    ##开启stelnet服务
    stelnet server enable
    ssh user admin
    ssh user admin authentication-type password
    ssh user admin service-type stelnet

    访问

    telnet 192.168.20.1
    在这里插入图片描述
    stelnet 192.168.20.1
    #这里ssh首次登陆的时候需要配置 ssh clinet first-time enable
    如果用CTR等一些远程软件 则不要输入这条命令
    在这里插入图片描述
    进来请点个赞吧!!!

    展开全文
  • 华为交换机配置远程登录和验证方式,第一次需要这么配置后才能远程登录,可以参考。
  • 华为S5700交换机初始化和配置TELNET远程登录方法:1.交换机开启Telnet服务system-view #进入系统视图[Huawei]telnet server ? #查看有enable还是disable选项,选择对应的开启方式。[Huawei]telnet server enable #...

    华为S5700交换机初始化和配置TELNET远程登录方法:

    1.交换机开启Telnet服务

    system-view       #进入系统视图

    [Huawei]telnet server ?                    #查看有enable还是disable选项,选择对应的开启方式。

    [Huawei]telnet server enable                #enable选项开启Telnet服务 (普通系列一般为这个)

    [Huawei]undo telnet server disable          #disable选项开启Telnet服务 (CE高端系列一般为这个)

    2.配置VTY用户界面的最大个数(同时可以登录的最大数)

    [Huawei]user-interface maximum-vty 15 #默认是5,这个可以不设置

    3.配置VTY用户界面的终端属性

    [Huawei]user-interface vty 0 14              #上面是15所有这里是0 14 如果选择默认这里是0 4

    [Huawei-ui-vty0-14]protocol inbound telnet   #配置vty支持telnet协议

    4.配置VTY用户界面的用户验证方式

    [Huawei-ui-vty0-14]authentication-mode aaa    #配置用户终端的身份验证模式为aaa认证为aaa认证

    [Huawei-ui-vty0-14]quit                       #退出vty配置界面

    5.配置登录验证方式

    [Huawei]aaa                                                          #进入aaa配置模式

    [Huawei-aaa]local-user admin1234 password ?  #查看可以选择的密码选择

    [Huawei-aaa]local-user admin1234 password simple Huawei12#$        #密码选项simple 账号admin1234 密码Huawei12#$ (普通系列一般为这个)

    [Huawei-aaa]local-user admin1234 password irreversible-cipher Huawei12#$           #密码选项irreversible-cipher 账号admin1234 密码Huawei12#$ (CE高端系列一般为这个)

    [Huawei-aaa]local-user admin1234 service-type telnet               #配置接入服务类型,如果还需要SSH登录请加上

    [Huawei-aaa]local-user admin1234 privilege level 3                     #配置账号的级别,默认3级是超级管理员的权限

    [Huawei-aaa]quit                             #退出

    telnet 127.0.0.1               #测试telnet配置是否OK

    save                                 #保存配置

    ===================================================================

    华为S5700交换机初始化和配置SSH和TELNET远程登录方法:

    AAA是指:authentication(认证)、authorization(授权)、accounting(计费)的简称,是网络安全的一种管理机制;Authentication是本地认证/授权,authorization和accounting是由远处radius(远程拨号认证系统)服务或hwtacacs(华为终端访问控制系统)服务器完成认证/授权;AAA是基于用户进行认证、授权、计费的,而NAC方案是基于接入设备接口进行认证的,在实际应用中,可以使用AAA的一种或两种服务。

    如果是一台刚初始化过的华为交换机,需要输入两次相同的密码作为登录交换机的登录密码

    交换机上有console 端口 MEth管理端口 usb端口

    通过串口线配置S5700 的管理IP地址,串口线接在交换机的console口,ip设置完成后网线接在ETH口:

    system-view

    [Quidway] interface MEth 0/0/1

    [Quidway] interface MEth 0/0/1

    [Quidway-MEth0/0/1]ip address x.x.x.x 255.255.255.0              ///设置MEth管理端口的ip地址

    [Quidway-MEth0/0/1]quit

    [Quidway]ip route-static 0.0.0.0 0.0.0.0 x.x.x.x(gateway)

    [Quidway-MEth0/0/1]display ip interface MEth 0/0/1               ///查看MEth管理端口的配置信息

    [Quidway]

    添加用户,设置ssh telent远程登录

    system-view                                        ///进入系统配置模式

    [Quidway]aaa                                                 ///进入AAA模式

    [Quidway-aaa]local-user chy password cipher qaz123456        ///设置本地用户名和密码  cipher加密

    [Quidway-aaa]local-user chy service-type ssh telnet terminal  ///设置用户设置登录ssh telnet terminal服务

    [Quidway-aaa]display ssh server status             ///查看ssh服务是否生效

    [Quidway-aaa]display telnet server status            ///查看telnet服务是否生效

    [Quidway-aaa]local-user chy privilege level 15               ///设置用户级别

    [Quidway-aaa]q                                               ///退出AAA模式

    设置vty 0 4远程登陆的虚拟端口

    VTY是路由器的远程登陆的虚拟端口,0 4表示可以同时打开5个会话,line vty 0 4是进入VTY端口,对VTY端口进行配置,比如说配置密码,或者ACL.

    [Quidway]user-interface vty 0 4                     ///进入vty 0 4远程虚拟端口

    [Quidway-ui-vty0-4]authentication-mode aaa          ///为虚拟用户终端配置AAA身份验证模式

    [Quidway-ui-vty0-4]user privilege level 15          ///为虚拟用户终端配置用户级别

    [Quidway-ui-vty0-4]protocol inbound all             ///为虚拟用户终端配置使用的协议,all即都支持

    [Quidway-ui-vty0-4]protocol inbound telnet          ///为虚拟用户终端配置telnet协议,即可以使用telnet远程登录

    [Quidway-ui-vty0-4]protocol inbound ssh             ///为虚拟用户终端配置ssh协议,即用户可以使用ssh远程登录

    [Quidway]ssh user chy authentication-type password  ///为chy用户设置ssh认证为password,此命令对设置单一用户设置来说比较实用

    [Quidway]ssh authentication-type default password   ///设置ssh默认的认证方式为密码认证,对设置多个用户来说很实用

    [Quidway]ssh user chy service-type stelnet          ///为chy用户设置ssh认证服务类型为stelnet

    [Quidway]display ssh user-information chy           ///查看ssh服务chy用户的配置信息

    [Quidway]q                        ///退出系统设置视图

    save                      ///保存设置

    配置登陆IP地址

    system-view                                                               //进入系统配置模式

    [Quidway]interface Vlanif 1                                                         //进入三层 vlanif 接口

    [Quidway-Vlanif1]ip address 192.168.0.1  255.255.255.0                              //配置管理 IP 地址

    创建web登录管理账号

    [Quidway]http server enable                                                         ///系统视图下开启http服务

    [Quidway]http secure-server enable                                                  ///系统视图下开启http安全服务 即https

    [Quidway]aaa                                                                        //系统视图下进入aaa模式

    [Quidway-aaa]local-user admin privilege level 15                                    ///配置 http 登录名权限

    [Quidway-aaa]local-user admin service-type http                                     /// 开启 http 登录服务

    [Quidway-aaa]quit                                                                   /// 退出aaa模式

    如果telnet能登录,但console反而不能登录的话,则需在aaa里 把要登录的 账户 赋予权限

    [Quidway-aaa]local-user admin service-type terminal ssh telnet ftp

    创建vlan

    system-view              ///进入系统配置模式

    [Quidway]vlan 10                ///创建vlan 10

    [Quidway-vlan10]quit              ///退出系统配置模式

    [Quidway]interface Vlanif 10        ///进入配置vlan 10的模式

    [Quidway-Vlanif10]ip address 192.168.0.1 255.255.255.0  ///为vlan 10配置IP地址和掩码

    [Quidway-vlan10]quit              ///退出系统配置模式

    [Quidway-GigabitEthernet0/0/2]       ///进入端口2

    [Quidway-GigabitEthernet0/0/2]port link-type access  ///端口类型设置为access

    [Quidway-GigabitEthernet0/0/2]port default vlan 10   ///将port加入到我们创建好的vlan 10

    [Quidway-GigabitEthernet0/0/2]display vlan     ///查看配置的vlan信息

    [Quidway]quit                                                         ///退出系统设置视图

    批量创建vlan

    system-view              ///进入系统配置模式

    [Quidway]vlan batch 2 to 19            ///批量创建vlan 2-19 ,系统都会有一个默认的vlan 1

    [Quidway]display vlan                ///查看vlan信息

    [Quidway]q                      ///退出系统设置视图

    批量删除vlan

    system-view              ///进入系统配置模式

    [Quidway]undo vlan batch 2 to 19      ///批量删除vlan 2-19 ,系统都会有一个默认的vlan 1

    [Quidway]display vlan            ///查看vlan信息

    [Quidway]q                  ///退出系统设置视图

    批量把端口加入到vlan 10

    system-view              ///进入系统配置模式

    [Quidway]interface range GigabitEthernet 0/0/1 to GigabitEthernet 0/0/6

    ///将1口到6口添加到port-group,此处系统默认的给1口到6口添加到1个组里了。

    [Quidway-port-group]port link-type access   ///将port-group组内的端口全部改为access口

    [Quidway-port-group]port default vlan 10    ///将port-group组内的端口全部加入到vlan 10

    [Quidway]q                     ///退出系统设置视图

    或者先创建一个端口组,再添加到vlan中

    system-view              ///进入系统配置模式

    [Quidway]port-group 1           ///创建端口组,组名为1

    [Quidway-port-group-1]group-member GigabitEthernet 0/0/7 to GigabitEthernet 0/0/17   ///把端口7到17添加到端口组1中

    [Quidway-port-group-1]port link-type access ///将port-group-1组内的端口全部改为access口

    [Quidway-port-group-1]port default vlan 20  ///将port-group-1组内的端口全部加入到vlan 20

    [Quidway-port-group-1]display vlan       ///查看配置的vlan信息

    [Quidway-port-group-1]q            ///退出端口组1的配置模式

    [Quidway]q                       ///退出系统设置视图

    删除vlan----需要先删除vlanif信息---再删vlan

    system-view              ///进入系统配置模式

    [Quidway]undo interface Vlanif 10     ///删除vlanif 10

    [Quidway]display vlan             ///查看vlan配置

    [Quidway]display current-configuration    ///发现vlan配置还在,vlanif配置已经不在

    [Quidway]undo vlan 10            ///删除vlan 10

    [Quidway]display vlan             ///查看vlan配置,发现vlan 10已经不在

    [Quidway]display current-configuration    ///发现vlan配置不在,vlanif配置也不在,但是port信息还有,单独删port信息太慢

    批量删除port信息

    对于上面我们已经把vlanif信息删除,vlan删除,但是display current-configuration发现

    之前创建的port信息还是在的,一个一个删太慢,这里我们还创建组去删

    system-view              ///进入系统配置模式

    [Quidway]port-group 2            ///创建port组2

    [Quidway-port-group-2]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/6   ///将1口到6口加入到port组2中

    [Quidway-port-group-2]undo port default vlan  ///将port组2内的端口vlan配置全部删除

    [Quidway-port-group-2]undo port link-type     ///将port组2内的端口类型全部恢复到默认

    [Quidway-port-group-2]display current-configuration   ///查看端口信息

    [Quidway-port-group-2]q            ///退出端口组1的配置模式

    [Quidway]q                       ///退出系统设置视图

    展开全文
  • 配置远程登录和不用用户名的telnet设置:sys 1、开启telnettelnet server enable 2、创建远程账户:aaalocal-user huawei password cipher hello #huawei是账户,hello是密码,密码在登录的时候可以改local-user ...

    配置远程登录和不用用户名的telnet设置:
    sys
    1、开启telnet:
    telnet server enable
    2、创建远程账户:
    aaa
    local-user huawei password cipher hello #huawei是账户,hello是密码,密码在登录的时候可以改
    local-user huawei service-type telnet #使账户huawei支持telnet协议
    local-user huawei level 3 #账户权限为3
    quit
    3、配置账户用户界面的权限
    user-interface vty 0 4 #配置用户界面,0是初始值,4是结束 值。表示可同时打开5个会话
    authentication-mode password #创建本地用户并启用密码验证
    set authentication password cipher hello #设置身份验证密码密码
    protocol inbound telnet #配置用户支持telnet协议
    quit
    4、设置远程ip
    vlanif100
    ip address 192.168.1.1 255.255.255.0 #配置ip
    quit
    quit
    5、在全局模式下测试
    telnet 192.168.1.1 #回车会让你直接输入密码

    转载于:https://blog.51cto.com/11696724/2338641

    展开全文
  • 电脑PC1经过S3700交换机telnet远程登录到S5700交换机。 连接拓扑图如下:(测试时用实物测试) 一、配置S5700交换机。 1.交换机开启Telnet服务 <Huawei>system-view Enter system view, return user view ...

    实验目标:
    电脑PC1经过S3700交换机,telnet远程登录到S5700交换机。

    连接拓扑图如下:(测试时用实物测试
    在这里插入图片描述
    一、配置S5700交换机。
    1.交换机开启Telnet服务

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname LSW1
    [LSW1]telnet server enable //使能telnet服务。
    

    2.配置登陆IP地址

    [LSW1]vlan 666	//新建管理VLAN
    [LSW1-vlan666]quit	
    [LSW1]interface Vlanif 666	//配置IP地址
    [LSW1-Vlanif666]ip address 192.168.1.254 24
    [LSW1-Vlanif666]quit 
    

    3.配置g0/0/1端口属性

    [LSW1]interface GigabitEthernet 0/0/1
    [LSW1-GigabitEthernet0/0/1]port link-type trunk
    [LSW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 to 4094
    

    4.配置VTY用户界面的终端属性

    [LSW1]user-interface vty 0 4 //配置Telnet,同时配置5个用户
    [LSW1-ui-vty0-4]authentication-mode aaa //认证模式是AAA
    [LSW1-ui-vty0-4]user privilege level 15	//用户等级
    [LSW1-ui-vty0-4]protocol inbound telnet 		
    [LSW1-ui-vty0-4]quit 
    

    5.配置登录验证方式

    [LSW1]aaa 	
    [LSW1-aaa]local-user admin123 password cipher admin123* //设置用户名和密码
    [LSW1-aaa]local-user admin123 privilege level 15//设置用户权利等级
    [LSW1-aaa]local-user admin123 service-type telnet  //设置这个admin123用户用来Telnet
    

    6.保存配置

    <LSW1>save
    

    二、配置S3700交换机
    1.新建VLAN(此VLAN在S5700有定义)

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname LSW2
    [LSW2]vlan 666	
    [LSW2-vlan666]quit	
    

    2.配置e0/0/1和e0/0/2端口属性

    [LSW2]interface Ethernet 0/0/1
    [LSW2-Ethernet0/0/1]port link-type trunk
    [LSW2-Ethernet0/0/1]port trunk allow-pass vlan 2 to 4094
    [LSW2-Ethernet0/0/1]quit
    
    [LSW2]interface Ethernet 0/0/2
    [LSW2-Ethernet0/0/2]port link-type access
    [LSW2-Ethernet0/0/2]port default vlan 666
    [LSW2-Ethernet0/0/2]quit
    

    3.保存配置

    <LSW2>save
    

    三、配置电脑
    1.查看是否开启Telnet服务,(控制面板->卸载程序->左侧的“打开或关闭window功能”)
    在这里插入图片描述
    2.设置电脑IP为同一网段、子网掩码。默认网关(必须为S5700交换机VLAN666的IP地址)在这里插入图片描述
    3.ping 192.168.1.254就是交换机S5700 VLAN666的IP,直到ping通
    在这里插入图片描述
    4.telnet 192.168.1.254,就可以远程登录到S5700
    在这里插入图片描述

    展开全文
  • 华为S5700交换机初始化和配置TELNET远程登录方法:1,交换机开启Telnet服务&lt;Huawei&gt;system-view #进入系统视图[Huawei]telnet server ? #查看有enable还是disable选项,选择对应的开启方式。[Huawei...
  • 1,交换机开启Telnet服务 <Huawei>system-view #进入系统视图 [Huawei]telnet server ? #查看有enable还是disable选项,选择对应的开启方式。 [Huawei]telnet server enable #enable选项开启Telnet服务 (普通...
  • 项目需求:交换机远程登录配置。 模拟场景:通过R2路由器来远程LSW2交换机; 注意:在华为模拟器中选用这个名为:“router”的路由,不然别的路由E口不支持配置ip(默认为二层设备端口) 实验思路: 1、路由器...
  • 如果这篇文章对您有帮助,请关注并点赞,感谢您的支持,如果还有其他问题,请私信给我我在前几期讲解了如何配置华为交换机console口登录,并使用账户和密码方式登录交换机,有没看过的小伙伴请点击以下链接查看如何配置...
  • 今天给大家带来的是如何在华为交换机配置Telnet和SSH的配置。实验拓扑如下 实验拓扑 实验需求 按照图示连接到真机,并配置IP地址(真机IP地址配置到VirtualBox Host-Only Ethernet Adapter网卡) 在SW1开启Telnet...
  • 华为交换机配置Telnet

    2020-07-24 15:53:43
    telnet 远程登陆设置 telnet server enable 开启 telnet 服务 ...配置登录用户的相关信息 配置登录验证方式。 aaa local-user 用户名 password irreversible-cipher ******密码 local-user 用户名 service-type tel
  • Telnet是Internet远程登陆服务的标准协议和主要方式。它为用户提供了在本地计算机上完成远程主机工作的能力。在终端使用者的电脑上使用telnet程序,用它连接到服务器。...Telnet是常用的远程控制W...
  • 下面是笔者视频课程中的一节PPT...同一时候以一真实的Telnet远程登录实验向大家验证了这些配置的正确性。本节课程的视频链接例如以下(可免费观看,我所有课程5折限时抢购中!):http://edu.51cto.com/lesson/id-2...
  • 通过Console口首次登录设备后,对设备进行基本配置配置通过Telnet远程登录的0~4号用户的级别为15级,认证方式为AAA认证,通过Console口登录设备,对设备进行基本配置。 设置设备名称和管理IP地址。 u t m ...
  • 华为Telnet远程登录

    2018-02-23 15:53:11
    telnet:远程登录,远程控制一些路由器和交换机等网络设备。四层使用TCP 23号端口。 R2:Telnet 服务端 aaa :公有的认证、授权、审计 的协议 telnet server enable aaa 进入aaa local-user zhangsan privilege ...

空空如也

空空如也

1 2 3 4 5 6
收藏数 105
精华内容 42
关键字:

华为交换机telnet远程登录配置