精华内容
下载资源
问答
  • 实验步骤:1、通过在网络中的交换机上开启STP(Spanning Tree Protocol,生成树协议),能在保证物理链路冗余的情况下,解决环路的问题,同时为网络实现冗余性:2、手工指定SW1成为交换网络的主根桥,SW2成为本交换...

    3cf8db71b39ad41ef26b4e063b3718f7.png

    实验要求:

    1、开启生成树协议STP,观察相关现象;

    2、 配置STP,使得SW1成为网络的STP主根,SW2成为次根,SW3的GE0/0/22被阻塞。

    实验步骤:

    1、通过在网络中的交换机上开启STP(Spanning Tree Protocol,生成树协议),能在保证物理链路冗余的情况下,解决环路的问题,同时为网络实现冗余性:

    26d1683938cc2fb51208cbb151579be0.png

    2、手工指定SW1成为交换网络的主根桥,SW2成为本交换网络的次根桥:

    34d08ad884c601a7e5094f7af98d2e34.png

    3、查看实验效果:

    32b38910fa0985c3b1a1a09ffa7c4e5b.png

    再看看SW1的接口STP状态:

    ec84ba1ba148c3047fe909fe4d27e2fb.png

    再去SW2上看看:

    59d7efa8c9586f80f22c5faa94a120b6.png

    再查看sw3的情况:

    695dcb29a78824867c125ca2d46e012d.png

    505baf2301f72585ae92aa452f1ad294.png

    如果此时,你希望SW3被阻塞的不是GE0/0/22口,而是GE0/0/21口呢?一种可选的办法是,将GE0/0/21的接口COST调大,使得从这个接口上收到的BPDU累加COST比GE0/0/22口的累加值要大,也就是使得这个接口距离根桥SW1的“开销”更大、“更远”。

    2e08a7233def76e6582e4ba1f541850f.png

    小结: 1、选择生成树协议为stp,并激活stp;

    2、手动指定根端口用命令“primary”主根桥,“secondary”次根桥;

    3、查询三台交换机上的状态;

    4、sw3上希望阻塞现在的接口,则进入该接口把“cost”值加大。

    展开全文
  • 链路聚合简介 链路聚合(Link Aggregation),是指将多个物理端口捆绑在一起,成为一个逻辑端口,...链路聚合在增加链路带宽、实现链路传输弹性和冗余等方面是一项很重要的技术。 如果聚合的每个链路都遵循不同的物

    一、链路聚合简介

    链路聚合(Link Aggregation),是指将多个物理端口捆绑在一起,成为一个逻辑端口,以实现出入流量在各成员端口中的负荷分担,交换机根据用户配置的端口负荷分担策略决定报文从哪一个成员端口发送到对端的交换机。

    当交换机检测到其中一个成员端口的链路发生故障时,就停止在此端口上发送报文,并根据负荷分担策略在剩下链路中重新计算报文发送的端口,故障端口恢复后再次重新计算报文发送端口。链路聚合在增加链路带宽、实现链路传输弹性和冗余等方面是一项很重要的技术。

    如果聚合的每个链路都遵循不同的物理路径,则聚合链路也提供冗余和容错。通过聚合调制解调器链路或者数字线路,链路聚合可用于改善对公共网络的访问。链路聚合也可用于企业网络,以便在吉比特以太网交换机之间构建多吉比特的主干链路。

    二、链路聚合原理

    • 逻辑链路的带宽增加了大约(n-1)倍,这里,n为聚合的路数。另外,聚合后,可靠性大大提高,因为,n条链路中只要有一条可以正常工作,则这个链路就可以工作。除此之外,链路聚合可以实现负载均衡。因为,通过链路聚合连接在一起的两个(或多个)交换机(或其他网络设备),通过内部控制,也可以合理地将数据分配在被聚合连接的设备上,实现负载分担。

    • 因为通信负载分布在多个链路上,所以链路聚合有时称为负载平衡。但是负载平衡作为一种数据中心技术,利用该技术可以将来自客户机的请求分布到两个或更多的服务器上。 聚合有时被称为反复用或IMUX。如果多路复用是将多个低速信道合成为一个单个的高速链路的聚合,那么反复用就是在多个链路上的数据“分散”。它允许以某种增量尺度配置分数带宽,以满足带宽要求。链路聚合也称为中继。

    • 按需带宽或结合是指按需要添加线路以增加带宽的能力。在该方案中,线路按带宽的需求自动连接起来。聚合通常伴随着ISDN连接。基本速率接口支持两个64kbit/s的链路。一个可用于电话呼叫,而另一个可同时用于数据链路。可以结合这两个链路以建立l28kbit/s的数据链路。

    三、链路聚合优点

    • 增加网络带宽:链路聚合可以将多个链路捆绑成为一个逻辑链路,捆绑后的链路带宽是每个独立链路的带宽总和。
    • 提高网络连接的可靠性:链路聚合中的多个链路互为备份,当有一条链路断开,流量会自动在剩下链路间重新分配。
    • 负载分担:在一个链路聚合组内,可以实现在各成员活动链路上的负载分担。

    四、链路聚合基本概念

    1、链路聚合组和链路聚合接口

    链路聚合组LAG(Link Aggregation Group)是指将若干条以太链路捆绑在一起所形成的逻辑链路。

    每个聚合组唯一对应着一个逻辑接口,这个逻辑接口称之为链路聚合接口或Eth-Trunk接口。链路聚合接口可以作为普通的以太网接口来使用,与普通以太网接口的差别在于:转发的时候链路聚合组需要从成员接口中选择一个或多个接口来进行数据转发。

    2、成员接口和成员链路

    组成Eth-Trunk接口的各个物理接口称为成员接口。成员接口对应的链路称为成员链路。

    活动接口和非活动接口、活动链路和非活动链路

    链路聚合组的成员接口存在活动接口和非活动接口两种。转发数据的接口称为活动接口,不转发数据的接口称为非活动接口。

    活动接口对应的链路称为活动链路,非活动接口对应的链路称为非活动链路。

    3、活动接口数上限阈值

    设置活动接口数上限阈值的目的是在保证带宽的情况下提高网络的可靠性。当前活动链路数目达到上限阈值时,再向Eth-Trunk中添加成员接口,不会增加Eth-Trunk活动接口的数目,超过上限阈值的链路状态将被置为Down,作为备份链路。

    例如,有8条无故障链路在一个Eth-Trunk内,每条链路都能提供1G的带宽,现在最多需要5G的带宽,那么上限阈值就可以设为5或者更大的值。其他的链路就自动进入备份状态以提高网络的可靠性。

    注:手工负载分担模式链路聚合不支持活动接口数上限阈值的配置。

    4、活动接口数下限阈值

    设置活动接口数下限阈值是为了保证最小带宽,当前活动链路数目小于下限阈值时,Eth-Trunk接口的状态转为Down。

    例如,每条物理链路能提供1G的带宽,现在最小需要2G的带宽,那么活动接口数下限阈值必须要大于等于2。

    5、链路聚合模式

    链路聚合模式分为手工模式和LACP模式两种

    五、链路聚合工作方式

    工作方式有两种:手工负载分担、LACP模式。两种方式的对比:

    维度 手工模式 LACP模式
    定义 Eth-Trunk的建立、成员接口的加入由手工配置,没有链路聚合控制协议的参与。 Eth-Trunk的建立是基于LACP协议的,LACP为交换数据的设备提供一种标准的协商方式,以供系统根据自身配置自动形成聚合链路并启动聚合链路收发数据。聚合链路形成以后,负责维护链路状态。在聚合条件发生变化时,自动调整或解散链路聚合。
    设备是否需要支持LACP协议 不需要 需要
    数据转发 一般情况下,所有链路都是活动链路。所有活动链路均参与数据转发。如果某条活动链路故障,链路聚合组自动在剩余的活动链路中分担流量。 一般情况下,部分链路是活动链路。所有活动链路均参与数据转发。如果某条活动链路故障,链路聚合组自动在非活动链路中选择一条链路作为活动链路,参与数据转发的链路数目不变。
    是否支持跨设备的链路聚合 不支持 支持
    检测故障 只能检测到同一聚合组内的成员链路有断路等有限故障,但是无法检测到链路故障、链路错连等故障。 不仅能够检测到同一聚合组内的成员链路有断路等有限故障,还可以检测到链路故障、链路错连等故障。

    1、手工负载分担及配置和实验

    手工模式下,Eth-Trunk的建立、成员接口的加入由手工配置,没有链路聚合控制协议LACP的参与。当需要在两个直连设备之间提供一个较大的链路带宽而设备又不支持LACP协议时,可以使用手工模式。手工模式可以实现增加带宽、提高可靠性和负载分担的目的。

    • 手工负载分担模式允许在聚合组中手工加入多个成员接口,所有接口均处于转发状态,分担负载流量。
    • Eth-Trunk的创建,成员接口的加入都需要手工配置完成,没有LACP协议报文参与。
    • 手工负载分担模式通常应用在对端设备不支持LACP协议的情况下。

    具体的配置方法:如下图,我们来做这个实验。sw1和sw2分别用两条网线链接而成,我们通过手动分担负载的方式来实现PC1和PC2的通信。

    在这里插入图片描述

    sw1配置

    [sw1]interface Eth-Trunk 1   #1为ID,范围1-63
    [sw1-Eth-Trunk1]mode ?
      lacp-static  Static working mode
      manual       Manual working mode
    
    [sw1-Eth-Trunk1]mode manual load-balance 
    [sw1-Eth-Trunk1]q
    [sw1]int g0/0/1
    [sw1-GigabitEthernet0/0/1]eth-trunk 1
    [sw1-GigabitEthernet0/0/1]q
    [sw1]int g0/0/2
    [sw1-GigabitEthernet0/0/2]eth-trunk 1
    [sw1-GigabitEthernet0/0/2]q
    
    
    [sw1]dis eth-trunk 1
    Eth-Trunk1's state information is:
    WorkingMode: NORMAL(模式)   Hash arithmetic: According to SIP-XOR-DIP(负载均衡类型)        
    Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 8(最大8条)
    Operate status: up          Number Of Up Port In Trunk: 2(已有2条)
    --------------------------------------------------------------------------------
    PortName                      Status      Weight 
    GigabitEthernet0/0/1          Up          1      
    GigabitEthernet0/0/2          Up          1  
    

    sw2配置

    sw2也是完全一样的,这里就不显示了。

    2、LACP模式

    作为链路聚合技术,手工负载分担模式Eth-Trunk可以完成多个物理接口聚合成一个Eth-Trunk口来提高带宽,同时能够检测到同一聚合组内的成员链路有断路等有限故障,但是无法检测到链路层故障、链路错连等故障。

    为了提高Eth-Trunk的容错性,并且能提供备份功能,保证成员链路的高可靠性,出现了链路聚合控制协议LACP(Link Aggregation Control Protocol),LACP模式就是采用LACP的一种链路聚合模式。

    LACP为交换数据的设备提供一种标准的协商方式,以供设备根据自身配置自动形成聚合链路并启动聚合链路收发数据。聚合链路形成以后,LACP负责维护链路状态,在聚合条件发生变化时,自动调整或解散链路聚合。

    基本概念:

    • 系统LACP优先级:系统LACP优先级是为了区分两端设备优先级的高低而配置的参数。LACP模式下,两端设备所选择的活动接口必须保持一致,否则链路聚合组就无法建立。此时可以使其中一端具有更高的优先级,另一端根据高优先级的一端来选择活动接口即可。系统LACP优先级值越小优先级越高。
    • 接口LACP优先级:接口LACP优先级是为了区别同一个Eth-Trunk中的不同接口被选为活动接口的优先程度,优先级高的接口将优先被选为活动接口。接口LACP优先级值越小,优先级越高。
    • 成员接口间M:N备份:LACP模式链路聚合由LACP确定聚合组中的活动和非活动链路,又称为M:N模式,即M条活动链路与N条备份链路的模式。这种模式提供了更高的链路可靠性,并且可以在M条链路中实现不同方式的负载均衡。

    LACP模式实验:
    sw1和sw2分别用4条网线连接在一起,接口如下图:
    在这里插入图片描述

    sw1配置

    [sw1]interface Eth-Trunk 1  #创建1个聚合接口,ID为1
    [sw1-Eth-Trunk1]mode lacp-static #模式设为lacp静态
    
    [sw1-Eth-Trunk1]trunkport e0/0/1   #把接口加进来
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1-Eth-Trunk1]trunkport e0/0/2
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1-Eth-Trunk1]trunkport e0/0/3
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1-Eth-Trunk1]trunkport e0/0/4
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1-Eth-Trunk1]dis port vlan
    
    [sw1-Eth-Trunk1]load-balance ?   #配置负载均衡,默认值为下面的src-dst-ip,也可以不配置。
      dst-ip       According to destination IP hash arithmetic
      dst-mac      According to destination MAC hash arithmetic
      src-dst-ip   According to source/destination IP hash arithmetic
      src-dst-mac  According to source/destination MAC hash arithmetic
      src-ip       According to source IP hash arithmetic
      src-mac      According to source MAC hash arithmetic
    [sw1-Eth-Trunk1]q
    [sw1]lacp priority 100   
    #优先级默认是32768,我们只在sw1上配置,SW2不配置默认为32768,也就是说我们让SW1为主
    
    [sw1]int Eth-Trunk 1
    [sw1-Eth-Trunk1]least  active-linknumber 1 
    #配置最小链路数量,其实这里默认就是1不需要配置
    
    [sw1-Eth-Trunk1]max active-linknumber 2  
    #配置最大链路数量为2,我们共4个物理线路,2条为一组,最大也就只能是2条了,这里配置2
    
    
    [sw1-Eth-Trunk1]int e0/0/1    
    [sw1-Ethernet0/0/1]lacp priority 10
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]lacp priority 20
    [sw1-Ethernet0/0/2]int e0/0/3
    [sw1-Ethernet0/0/3]lacp priority 30
    [sw1-Ethernet0/0/3]int e0/0/4
    [sw1-Ethernet0/0/4]lacp priority 40
    #配置接口的优先级,就是哪个down了,另外下一个补上,相当于替补队员的顺序
    
    [sw1]int eth-trunk 1
    [sw1-Eth-Trunk1]lacp preempt enable  #配置抢占
    
    [sw1-Eth-Trunk1]lacp preempt delay ?
      INTEGER<10-180>  Value of preemption delay time, the default value is 30 (in
                       second)   默认30秒,范围可以是10-180
    
    [sw1-Eth-Trunk1]lacp preempt delay 30   #这里就先配置30
    
    

    sw2配置

    [sw2]interface Eth-Trunk1
    [sw2-Eth-Trunk1] mode lacp-static
    [sw2-Eth-Trunk1] max bandwidth-affected-linknumber 2
    [sw2-Eth-Trunk1] lacp preempt enable
    [sw2-Eth-Trunk1]#
    [sw2-Eth-Trunk1]interface Ethernet0/0/1
    [sw2-Ethernet0/0/1] eth-trunk 1
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw2-Ethernet0/0/1] lacp priority 10
    [sw2-Ethernet0/0/1]#
    [sw2-Ethernet0/0/1]interface Ethernet0/0/2
    [sw2-Ethernet0/0/2] eth-trunk 1
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw2-Ethernet0/0/2] lacp priority 20
    [sw2-Ethernet0/0/2]#
    [sw2-Ethernet0/0/2]interface Ethernet0/0/3
    [sw2-Ethernet0/0/3] eth-trunk 1
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw2-Ethernet0/0/3] lacp priority 30
    [sw2-Ethernet0/0/3]#
    [sw2-Ethernet0/0/3]interface Ethernet0/0/4
    [sw2-Ethernet0/0/4] eth-trunk 1
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw2-Ethernet0/0/4] lacp priority 40
    [sw2-Ethernet0/0/4]
    [sw2-Ethernet0/0/4]q
    [sw2]lacp pr	
    [sw2]lacp priority 200    #也可以不配置,默认为32768,SW1为100
    [sw2]
    
    [sw2]dis Eth-Trunk 1
    Eth-Trunk1's state information is:
    Local:
    LAG ID: 1                                   WorkingMode: STATIC   #静态                             
    Preempt Delay Time: 30(抢占延迟)            Hash arithmetic: According to SIP-XOR-DIP   #负载均衡策略       
    System Priority: 200(系统优先级)            System ID: 4c1f-cc52-655b                         
    Least Active-linknumber: 1(最小激活链路数量) Max Active-linknumber: 2 (最大激活链路数量)                   
    Operate status: up(状态OK)                 Number Of Up Port In Trunk: 4                     
    --------------------------------------------------------------------------------
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight
    Ethernet0/0/1   (激活)Selected 100M     10      2      289     10111100  1     
    Ethernet0/0/2   (激活)Selected 100M     20      3      289     10111100  1     
    Ethernet0/0/3          Unselect 100M     30      4      289     10100000  1     
    Ethernet0/0/4          Unselect 100M     40      5      289     10100000  1    
    
    Partner:
    --------------------------------------------------------------------------------
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState
    Ethernet0/0/1          100      4c1f-cc6d-2b8c  10      2      289     10111100
    Ethernet0/0/2          100      4c1f-cc6d-2b8c  20      3      289     10111100
    Ethernet0/0/3          100      4c1f-cc6d-2b8c  30      4      289     10111100
    Ethernet0/0/4          100      4c1f-cc6d-2b8c  40      5      289     10111100
    

    负载分担的方式主要包括以下几种,用户可以根据具体应用选择不同的负载分担方式。

    • 根据报文的源MAC地址进行负载分担
    • 根据报文的目的MAC地址进行负载分担
    • 根据报文的源IP地址进行负载分担
    • 根据报文的目的IP地址进行负载分担
    • 根据报文的源MAC地址和目的MAC地址进行负载分担
    • 根据报文的源IP地址和目的IP地址进行负载分担

    六、配置负载分担方式时的注意事项

    • 负载分担方式只在流量的出接口上生效,如果发现各入接口的流量不均衡,请修改上行出接口的负载分担方式。
    • 尽量将数据流通过负载分担在所有活动链路上传输,避免数据流仅在一条链路上传输,造成流量拥堵,影响业务正常运行。
    展开全文
  • 华为交换机STP的配置

    万次阅读 2015-12-08 21:24:56
    冗余链路当前的交换机为了防止单点故障导致的整个业务中断,常采用冗余链路来实现备份。也就是说如果交换机之间用一条链路互连,那么一旦一条链路出了问题,将会导致整个网络的瘫痪,为了防止这种情况,交换机之间用...

    什么是STP

    STP(Spanning Tree Protocol)生成树协议。
    冗余链路

    当前的交换机为了防止单点故障导致的整个业务中断,常采用冗余链路来实现备份。也就是说如果交换机之间用一条链路互连,那么一旦一条链路出了问题,将会导致整个网络的瘫痪,为了防止这种情况,交换机之间用多条链路互连,当一条链路故障时,还可以通过其他链路发送数据帧(是不是和电路交换/分组交换类似之间的区别类似)。
    冗余链路虽然可靠,但会形成环路。环路会造成广播风暴,MAC地址表震荡等问题。为了解决环路问题,提出了STP。
    STP(Spanning Tree Protocol)生成树协议

    作用:
    消除环路:在逻辑上断开环路。
    链路备份:当活动链路发生故障时,激活备份链路,保证网络的连通性。
    STP通过构造一棵树来解决环路问题。
    生成树的实现过程:
    选举根桥:根桥在一个逻辑树的根部,非根桥是其下游设备。根桥的选举根据桥ID(Bridge ID),桥ID由16位桥优先级和48位mac地址组成,优先级最高(桥优先级最小)的设备被选举为根桥,如果桥优先级相同,则mac地址小的被选举为根桥。
    选举根端口、选举指定端口
    STP的配置

    我用的是华为的eNSP软件,感觉还挺好用的。
    华为X7系列交换机默认工作在MSTP模式,使用STP时,要将所有交换机重新配置为STP,至于为什么要全部,有兴趣可以自己做下实验。
    下图是本次配置的拓扑图
    这里写图片描述
    什么都没修改,可以使用dis stp来查看各个交换机当前的stp配置。可以看到4个交换机都是使用MSTP
    四台交换机都修改到stp模式
    [Huawei]stp mode stp
    Info: This operation may take a few seconds. Please wait for a moment…done.
    [Huawei]
    缺省情况下交换机的桥优先级是32768,会选择MAC地址最小的作为根桥,这里选择的是S3。而想要使S1作为根桥,可以配置它的桥优先级
    [Huawei]stp priority 4096
    [Huawei]
    修改好以后,查看当前的STP状态
    [Huawei]dis stp
    ——-[CIST Global Info][Mode STP]——-
    CIST Bridge :4096 .4c1f-cce6-ead8
    Config Times :Hello 2s MaxAge 20s FwDly 15s MaxHop 20
    Active Times :Hello 2s MaxAge 20s FwDly 15s MaxHop 20
    CIST Root/ERPC :4096 .4c1f-cce6-ead8 / 0
    CIST RegRoot/IRPC :4096 .4c1f-cce6-ead8 / 0
    CIST RootPortId :0.0
    BPDU-Protection :Disabled
    TC or TCN received :75
    TC count per hello :0
    STP Converge Mode :Normal
    Time since last TC :0 days 0h:0m:12s
    Number of TC :13
    Last TC occurred :Ethernet0/0/3
    可以看到当前的根桥变为了S1.
    查看端口的角色
    [Huawei]dis stp brief
    MSTID Port Role STP State Protection
    0 Ethernet0/0/1 DESI FORWARDING NONE
    0 Ethernet0/0/2 DESI FORWARDING NONE
    0 Ethernet0/0/3 DESI FORWARDING NONE
    三个端口都是指定端口
    同理,可以查看其他三个交换机的端口角色。

    展开全文
  • 楼层1和楼层2分别通过两条线路做冗余接入交换机(本示例只考虑vrrp,暂不考虑其他方面)。当其中一段链路故障时,能通过另外一条链路传输。 配置信息: <lsw9>dis cu # sysname lsw9 # ...
    组网需求:
    
    楼层1和楼层2分别通过两条线路做冗余接入交换机(本示例只考虑vrrp,暂不考虑其他方面)。当其中一段链路故障时,能通过另外一条链路传输。
    
     
    
    配置信息:
    
    <lsw9>dis cu
    
    #
    
    sysname lsw9
    
    #
    
    vlan batch 10 20
    
    #
    
    stp mode stp
    
    #
    
    interface Ethernet0/0/2
    
     port link-type access
    
     port default vlan 10
    
    #
    
    interface Ethernet0/0/3
    
     port link-type access
    
     port default vlan 20
    
    #
    
    interface GigabitEthernet0/0/1
    
     port link-type trunk
    
     port trunk allow-pass vlan 10 20
    
    #
    
    interface GigabitEthernet0/0/2
    
     port link-type trunk
    
     port trunk allow-pass vlan 10 20
    
     stp instance 0 cost 200000000
    
    #
    
    return
    
    <lsw9>
    
    --------------------------
    
    <lsw11>dis cu
    
    #
    
    sysname lsw11
    
    #
    
    vlan batch 30
    
    #
    
    stp mode stp
    
    #
    
    interface Ethernet0/0/2
    
     port link-type access
    
     port default vlan 30
    
    #
    
    interface Ethernet0/0/3
    
     port link-type access
    
     port default vlan 30
    
    #
    
    interface GigabitEthernet0/0/1
    
     port link-type trunk
    
     port trunk allow-pass vlan 30
    
     stp instance 0 cost 200000000
    
    #
    
    interface GigabitEthernet0/0/2
    
     port link-type trunk
    
     port trunk allow-pass vlan 30
    
    #
    
    return
    
    <lsw11>
    
    -------------------------
    
    
    <lsw7>dis cu
    
    #
    
    sysname lsw7
    
    #
    
    vlan batch 10 20 30 100
    
    #
    
    stp mode stp
    
    #
    
    interface Vlanif1
    
    #
    
    interface Vlanif10
    
     description to 1 L
    
     ip address 10.155.10.254 255.255.255.0
    
     vrrp vrid 1 virtual-ip 10.155.10.252
    
     vrrp vrid 1 priority 120
    
     vrrp vrid 1 preempt-mode timer delay 20
    
    #
    
    interface Vlanif20
    
     ip address 10.155.20.254 255.255.255.0
    
     vrrp vrid 1 virtual-ip 10.155.20.252
    
     vrrp vrid 1 priority 120
    
     vrrp vrid 1 preempt-mode timer delay 20
    
    #
    
    interface Vlanif30
    
     description to 5 L
    
     ip address 10.156.40.254 255.255.255.0
    
     ip address 10.156.30.254 255.255.255.0 sub
    
     vrrp vrid 1 virtual-ip 10.156.30.252
    
     vrrp vrid 2 virtual-ip 10.156.40.252
    
     vrrp vrid 2 priority 120
    
     vrrp vrid 2 preempt-mode timer delay 20
    
    #
    
    interface Vlanif100
    
     ip address 10.10.10.1 255.255.255.0
    
    #
    
    interface MEth0/0/1
    
    #
    
    interface GigabitEthernet0/0/1
    
     port link-type access
    
     port default vlan 100
    
    #
    
    interface GigabitEthernet0/0/11
    
     port link-type trunk
    
     port trunk pvid vlan 100
    
     port trunk allow-pass vlan 2 to 4094
    
    #
    
    interface GigabitEthernet0/0/21
    
     port link-type trunk
    
     port trunk allow-pass vlan 30
    
    #
    
    ospf 1
    
     area 0.0.0.0
    
      network 10.10.10.0 0.0.0.255
    
      network 10.155.0.0 0.0.255.255
    
      network 10.156.0.0 0.0.255.255
    
    #
    
    return
    
    
    --------------------------------------
    
    <lsw8>dis cu
    
    #
    
    sysname lsw8
    
    #
    
    vlan batch 10 20 30 200
    
    #
    
    stp mode stp
    
    #
    
    interface Vlanif1
    
    #
    
    interface Vlanif10
    
     description to 1 L
    
     ip address 10.155.10.253 255.255.255.0
    
     vrrp vrid 1 virtual-ip 10.155.10.252
    
    #
    
    interface Vlanif20
    
     description to 1 L
    
     ip address 10.155.20.253 255.255.255.0
    
     vrrp vrid 1 virtual-ip 10.155.20.252
    
    #
    
    interface Vlanif30
    
     description to 5 L
    
     ip address 10.156.30.253 255.255.255.0
    
     ip address 10.156.40.253 255.255.255.0 sub
    
     vrrp vrid 1 virtual-ip 10.156.30.252
    
     vrrp vrid 1 priority 120
    
     vrrp vrid 1 preempt-mode timer delay 20
    
     vrrp vrid 2 virtual-ip 10.156.40.252
    
    #
    
    interface Vlanif200
    
     ip address 10.10.20.1 255.255.255.0
    
    #
    
    interface MEth0/0/1
    
    #
    
    interface GigabitEthernet0/0/1
    
    #
    
    interface GigabitEthernet0/0/2
    
     port link-type trunk
    
     port trunk allow-pass vlan 10 20
    
    #
    
    interface GigabitEthernet0/0/12
    
     port hybrid pvid vlan 200
    
     port hybrid tagged vlan 1 to 4094
    
    #
    
    interface GigabitEthernet0/0/22
    
     port link-type trunk
    
     port trunk allow-pass vlan 30
    
    #
    
    ospf 1
    
     area 0.0.0.0
    
      network 10.155.0.0 0.0.255.255
    
      network 10.156.0.0 0.0.255.255
    
      network 10.10.20.0 0.0.0.255
    
    #
    
    return
    
    <lsw8>
    
    -----------------
    
    <Huawei>dis cu
    
    #
    
    sysname Huawei
    
    #
    
    stp instance 0 root primary
    
    stp enable
    
    #
    
    interface GigabitEthernet0/0/1
    
     ip address 10.10.10.254 255.255.255.0
    
     stp enable
    
    #
    
    interface GigabitEthernet0/0/2
    
     ip address 10.10.20.254 255.255.255.0
    
     stp enable
    
    #
    
    interface GigabitEthernet0/0/3
    
     ip address 61.128.128.6 255.255.255.0
    
    #
    
    return
    
    <Huawei>

     

    转载于:https://www.cnblogs.com/qzqdy/p/8962658.html

    展开全文
  • 配置手工负载分担模式链路聚合示例组网需求如图1所示,SwitchA和SwitchB通过以太链路分别...同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。图1 配置手工负载分担模式链路聚合组网图配置思路采用...
  • l 两设备间的链路具有N 条冗余备份链路,当活动链路出现故障链路时,备份链路替 代故障链路,保持数据传输的可靠性。 配置思路 采用如下的思路配置静态LACP 模式链路聚合: 1. 在S-switc...
  • H3C华为交换机配置MSTP

    2013-07-18 11:28:08
    华为5700交换机,H3C交换机配置多区域HSTP与STP。网络链路冗余备份
  • 配置STP功能示例STP简介以太网交换网络中为了进行链路备份,提高网络可靠性,通常会使用冗余链路。但是使用冗余链路会在交换网络上产生环路,引发广播风暴以及MAC地址表不稳定等故障现象,从而导致用户通信质量较差...
  • 楼层1和楼层2分别通过两条线路做冗余接入交换机(本示例只考虑vrrp,暂不考虑其他方面)。当其中一段链路故障时,能通过另外一条链路传输。 配置信息: <lsw9>dis cu # sysname lsw9 # vlan ...
  • 配置STP功能示例STP简介以太网交换网络中为了进行链路备份,提高网络可靠性,通常会使用冗余链路。但是使用冗余链路会在交换网络上产生环路,引发广播风暴以及MAC地址表不稳定等故障现象,从而导致用户通信质量较差...
  • 由于两个交换机之间有多条冗余链路的时候,如果存在STP,会将其中的几条链路关闭,只保留一条,这样可以避免二层的环路产生。但是,失去了路径冗余的优点,因为STP的链路切换会很慢,在50s左右。使用以太通道的话,...
  • 华为交换机详细实验报告

    千次阅读 2019-09-24 23:48:38
    3、交换机SW3提高冗余链路 拓扑图: 具体配置如下: 1、首先配置物理主机PC1 PC2的IP地址与网关 2、 交换机创建 Vlan 10 20 15 (所有交换机配置相同vlan) 为什么全部要创建同样的vlan? ----所有vlan...
  • 华为交换机stp

    2013-09-16 16:49:13
    以SwitchB为根网桥,阻断网络中的环路,并能达到链路冗余备份的效果『交换机STP配置流程』通过改变交换机或者端口的STP优先级,从而达到手工指定网络中的根网桥,以及端口的STP角色,完成阻断环路及链路冗余备份...
  • Esxi是否支持华为交换机端口聚合

    千次阅读 2014-10-20 09:36:38
    华为交换机配置中端口聚合称为eth-trunk,是将多个物理端口组合成一个逻辑端口。目地是为了增加带宽、线路冗余各流量负载。工作模式有手工负载分担与LACP两种。 LACP模式是一种利用LACP协议进行聚合参数协商、确定...
  • -------------------- 关注本公众号获取更多干货~TCNE01:网关冗余技术、链路冗余技术 ACL原理、ACL配置 02: NAT原理与配置 、 高级NAT实现03 :基本OSPF实现 、高级OSPF实现 04:...
  • 一、 背景 1、server端 企业中一台server2016利用两块1G网卡组成teaming生成一张2G的虚拟网卡,业务数据在这张带宽为2G的虚拟网卡上运行。...交换机端需要支持并配置LACP((Link Aggregation Control Prot...
  • 在以太网交换网中部署生成树...华为交换机默认是开启mstp,但是没有配置。一次在机房解决交换机问题的时候,发现业务不通。分析过后,主要是eth0/1接口学习不到mac地址,同时接口又是处于up状态。经过反复检查接口...
  • 在以太网交换网中部署生成树协议后...华为交换机默认是开启mstp,但是没有配置。 一次在机房解决交换机问题的时候,发现业务不通。分析过后,主要是eth0/1接口学习不到mac地址,同时接口又是处于up状态。经过反复检...
  • 我们知道端口聚合能够提高链路的带宽和增加冗余性,目前华为设备负载分担有三种模式,分别是手工负载分担链路聚合和LACP模式链路聚合以及动态LACP聚合。手工负载分担模式链路聚合手工负载分担模式下,Eth-Trunk的...
  • trunk+vtp+链路冗余 理解

    千次阅读 2016-10-21 21:03:25
    链路冗余(etherchannel)链路冗余相当与有一个备份服务器,在两个路由器或者两个交换机或者两个二层设备之间可以配置链路冗余,其基本思想是当其中一个设备无法正常工作时,作为冗余的另外一个设备可以接替工作,本...
  • 我们知道端口聚合能够提高链路的带宽和增加冗余性,目前华为设备负载分担有三种模式,分别是手工负载分担链路聚合和 LACP模式链路聚合以及动态LACP聚合。 手工负载分担模式链路聚合 手工负载分担模式下,Eth-Trunk...
  • 链路聚合实现冗余功能实验(2) 文章目录1.实验环境2.配置LSW1 LACP3. 配置LSW24.配置R15.配置R26.主机配置注意网关地址一定要填7.互通性测试 1.实验环境 2.配置LSW1 LACP 3 配置LSW2 4.配置R1 5配置R2 6.主机配置注意...
  • 当三层交换机之间采用多条链路连接时,接口又会被STP阻塞,所以需要利用以太网通道技术channel(Cisco设备)或以太网中继技术Eth-Trunk(华为设备),将交换机之间的多个接口逻辑地整合为一个接口,实现带宽叠加的...
  • 为了提高网络可靠性,交换网络中通常会使用冗余链路。然而,冗余链路会给交换网络带来环路的风险,并导致广播风暴以及MAC地址表不稳定等问题,进而影响到用户的通信质量。生成树协议STP(Spanning TreeProtocol)可以...
  • 随着设备的增加及链路冗余备份的需要,或主动或被动的网络中会出现二层环路,从而产生广播风暴。当产生环路时接口利用率和CPU利用率等会急剧升高,严重时可能还会造成网络...2、 业务需求a、 三台华为交换机分别创...
  • 华为-集群CSS

    2020-10-28 15:55:52
    (1)高可靠性:集群系统两台成员交换机之间冗余备份,同时利用链路聚合功能实现跨设备的链路冗余备份。 (2)强大的网络扩展能力:通过组建集群增加交换机,从而轻松的扩展端口数、带宽和处理能力。 (3)简化配置...
  • 采用华为的ensp模拟器,接入交换机采用双上联的方式接入核心交换机,两台核心交换机之间两条链路捆绑连接,提高可靠性。路由器负责internet接入。涉及的网络协议,STP:全局开启STP协议,防止网络环路同时提高网络...

空空如也

空空如也

1 2
收藏数 35
精华内容 14
关键字:

华为交换机冗余链路配置