精华内容
下载资源
问答
  • DHCP服务器简介通常用户希望网络中的每台终端能够动态获取IP地址、DNS服务器的IP地址、路由信息、网关信息等网络参数,不需要手动配置终端的IP地址等网络参数;另外,针对一些移动终端(手机、ipad、办公笔记本等)...

    DHCP服务器简介

    通常用户希望网络中的每台终端能够动态获取IP地址、DNS服务器的IP地址、路由信息、网关信息等网络参数,不需要手动配置终端的IP地址等网络参数;另外,针对一些移动终端(手机、ipad、办公笔记本等)希望能够即插即用,不需要每次修改终端的IP等网络参数。如果用户网络中有这些需求,就可以在汇聚层的用户网关设备或核心层设备上配置DHCP服务器功能,来给终端分配IP地址等网络参数。

    动态主机配置协议DHCP(Dynamic Host Configuration Protocol)采用客户端/服务器模式对用户的网络参数进行动态配置和集中管理。其中,DHCP服务器通过地址池为用户分配IP地址等网络参数。地址池分为接口地址池和全局地址池两种。

    接口地址池配置方式简单,只能用于用户与DHCP服务器在同一个网段的场景,并且只能给对应接口下的用户分配IP地址等网络参数;适用于设备数量有限、配置以及维护量可控的小型网络。在用户网关设备上配置基于接口地址池的DHCP服务器功能之后,对应接口下的固定主机、移动终端等都可以自动获取IP地址等网络参数,不需要用户手动配置修改。

    与接口地址池相比,全局地址池可应用于大型网络,推荐在核心层设备上配置基于全局地址池的DHCP服务器功能或在服务器区域搭建一台专门的DHCP服务器统一分配IP地址等网络参数,而用户网关设备上只需要启用简单的DHCP中继功能即可。

    组网需求

    如图1所示,某企业内的一台主机通过Switch双归属到SwitchA和SwitchB,SwitchA为主设备,作为DHCP服务器为客户端分配IP地址。现用户希望当主设备故障时,客户端能够通过备设备重新获取IP地址。

    图1 VRRP组网下同网段内配置基于全局地址池的DHCP服务器组网图

    8532e215918388c2cf40a63b142c76a1.png

    配置思路

    VRRP组网下同网段内配置基于全局地址池的DHCP服务器,配置思路如下:

    配置SwitchA和SwitchB设备上接口IP地址,使各设备间网络层连通;同时配置Switch上的二层透传功能。

    在SwitchA和SwitchB上配置VRRP备份组。其中,SwitchA上配置较高优先级,作为Master设备为客户端分配IP地址;SwitchB上配置较低优先级,作为备用交换机。

    在SwitchA和SwitchB上创建全局地址池,并配置地址池相关属性。

    在SwitchA、SwitchB和Switch上配置破环协议,防止环路的产生(此处以配置STP为例)。

    操作步骤

    配置设备间的网络互连

    # 配置设备各接口的IP地址,以SwitchA为例。SwitchB的配置与SwitchA类似,详见配置文件。

    system-view

    [HUAWEI] sysname SwitchA

    [SwitchA] vlan batch 100

    [SwitchA] interface gigabitethernet 1/0/2

    [SwitchA-GigabitEthernet1/0/2] port link-type hybrid

    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 100

    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 100

    [SwitchA-GigabitEthernet1/0/2] quit

    [SwitchA] interface gigabitethernet 1/0/5

    [SwitchA-GigabitEthernet1/0/5] port link-type hybrid

    [SwitchA-GigabitEthernet1/0/5] port hybrid pvid vlan 100

    [SwitchA-GigabitEthernet1/0/5] port hybrid untagged vlan 100

    [SwitchA-GigabitEthernet1/0/5] quit

    [SwitchA] interface vlanif 100

    [SwitchA-Vlanif100] ip address 10.1.1.1 24

    [SwitchA-Vlanif100] quit

    # 配置Switch的二层透传功能。

    system-view

    [HUAWEI] sysname Switch

    [Switch] vlan 100

    [Switch-vlan100] quit

    [Switch] interface gigabitethernet 1/0/1

    [Switch-GigabitEthernet1/0/1] port link-type hybrid

    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 100

    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 100

    [Switch-GigabitEthernet1/0/1] quit

    [Switch] interface gigabitethernet 1/0/2

    [Switch-GigabitEthernet1/0/2] port link-type hybrid

    [Switch-GigabitEthernet1/0/2] port hybrid pvid vlan 100

    [Switch-GigabitEthernet1/0/2] port hybrid untagged vlan 100

    [Switch-GigabitEthernet1/0/2] quit

    [Switch] interface gigabitethernet 1/0/3

    [Switch-GigabitEthernet1/0/3] port link-type access

    [Switch-GigabitEthernet1/0/3] port default vlan 100

    [Switch-GigabitEthernet1/0/3] quit

    创建地址池并配置相关属性

    # 在SwitchA上启动DHCP服务。

    [SwitchA] dhcp enable# 在SwitchA上创建地址池,配置地址池范围是10.1.1.2~10.1.1.128,和SwitchB上配置的地址池地址互相排除。

    说明:

    由于交换机主设备上的地址池信息不能实时备份到备设备上,为防止主备切换后出现IP地址分配冲突,主设备和备设备上配置的地址池必须要互相排除。

    [SwitchA] ip pool 1

    [SwitchA-ip-pool-1] network 10.1.1.0 mask 255.255.255.0

    [SwitchA-ip-pool-1] gateway-list 10.1.1.111

    [SwitchA-ip-pool-1] excluded-ip-address 10.1.1.1

    [SwitchA-ip-pool-1] excluded-ip-address 10.1.1.129 10.1.1.254

    [SwitchA-ip-pool-1] lease day 10

    [SwitchA-ip-pool-1] quit

    # 在SwitchB上创建地址池,配置地址池范围是10.1.1.130~10.1.1.254,和SwitchA上配置的地址池地址互相排除。

    [SwitchB] dhcp enable

    [SwitchB] ip pool 1

    [SwitchB-ip-pool-1] network 10.1.1.0 mask 255.255.255.0

    [SwitchB-ip-pool-1] gateway-list 10.1.1.111

    [SwitchB-ip-pool-1] excluded-ip-address 10.1.1.1 10.1.1.110

    [SwitchB-ip-pool-1] excluded-ip-address 10.1.1.112 10.1.1.129

    [SwitchB-ip-pool-1] lease day 10

    [SwitchB-ip-pool-1] quit

    配置VRRP备份组

    # 在SwitchA上创建VRRP备份组1,配置SwitchA在该备份组中的优先级为120,并配置客户端从全局地址池中获取IP地址。

    [SwitchA] interface vlanif 100

    [SwitchA-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111

    [SwitchA-Vlanif100] vrrp vrid 1 priority 120

    [SwitchA-Vlanif100] dhcp select global

    [SwitchA-Vlanif100] quit

    # 在SwitchB上创建VRRP备份组1,其在该备份组中的优先级为缺省值100,并配置客户端从全局地址池中获取IP地址。

    [SwitchB] interface vlanif 100

    [SwitchB-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111

    [SwitchB-Vlanif100] dhcp select global

    [SwitchB-Vlanif100] quit

    配置STP协议,实现破除环路

    # 在Switch上全局使能STP功能,SwitchA和SwitchB的配置与之类似,详见配置文件。

    [Switch] stp enable# 在Switch的GE1/0/3接口上去使能STP并将端口GE1/0/1的路径开销值配置为20000。

    [Switch] interface gigabitethernet 1/0/3

    [Switch-GigabitEthernet1/0/3] stp disable

    [Switch-GigabitEthernet1/0/3] quit

    [Switch] interface gigabitethernet 1/0/1

    [Switch-GigabitEthernet1/0/1] stp cost 20000

    [Switch-GigabitEthernet1/0/1] quit

    验证配置结果

    # 完成上述配置以后,在SwitchA和SwitchB上分别执行display vrrp命令,可以看到SwitchA在备份组中的状态为Master,SwitchB在备份组中的状态为Backup。

    [SwitchA] display vrrp

    Vlanif100 | Virtual Router 1

    State : Master

    Virtual IP : 10.1.1.111

    Master IP : 10.1.1.1

    PriorityRun : 120

    PriorityConfig : 120

    MasterPriority : 120

    Preempt : YES Delay Time : 0 s

    TimerRun : 1 s

    TimerConfig : 1 s

    Auth type : NONE

    Virtual MAC : 0000-5e00-0101

    Check TTL : YES

    Config type : normal-vrrp

    Backup-forward : disabled

    Create time : 2012-01-12 20:15:46

    Last change time : 2012-01-12 20:15:46

    [SwitchB] display vrrp

    Vlanif100 | Virtual Router 1

    State : Backup

    Virtual IP : 10.1.1.111

    Master IP : 10.1.1.1

    PriorityRun : 100

    PriorityConfig : 100

    MasterPriority : 120

    Preempt : YES Delay Time : 0 s

    TimerRun : 1 s

    TimerConfig : 1 s

    Auth type : NONE

    Virtual MAC : 0000-5e00-0101

    Check TTL : YES

    Config type : normal-vrrp

    Backup-forward : disabled

    Create time : 2012-01-12 20:15:46

    Last change time : 2012-01-12 20:15:46

    # 在SwitchA和SwitchB上使用display ip pool命令用来查看地址池中的IP地址分配情况,可以看到作为主设备的SwitchA成功为DHCP客户端分配了IP地址,而作为备设备的SwitchB则没有为DHCP客户端分配IP地址。

    [SwitchA] display ip pool

    -----------------------------------------------------------------------------

    Pool-name : 1

    Pool-No : 0

    Lease : 10 Days 0 Hours 0 Minutes

    Position : Local Status : Unlocked

    Gateway-0 : 10.1.1.111

    Network : 10.1.1.0

    Mask : 255.255.255.0

    VPN instance : --

    Address Statistic: Total :253 Used :1

    Idle :125 Expired :0

    Conflict :0 Disable :127

    IP address Statistic

    Total :253

    Used :1 Idle :125

    Expired :0 Conflict :0 Disable :127

    [SwitchB] display ip pool

    -----------------------------------------------------------------------------

    Pool-name : 1

    Pool-No : 0

    Lease : 10 Days 0 Hours 0 Minutes

    Position : Local Status : Unlocked

    Gateway-0 : 10.1.1.111

    Network : 10.1.1.0

    Mask : 255.255.255.0

    VPN instance : --

    Address Statistic: Total :253 Used :0

    Idle :125 Expired :0

    Conflict :0 Disable :128

    IP address Statistic

    Total :253

    Used :0 Idle :125

    Expired :0 Conflict :0 Disable :128

    # 在SwitchA的接口GE1/0/2和接口GE1/0/5上执行shutdown命令,模拟SwitchA出现故障。

    [SwitchA] interface gigabitethernet 1/0/2

    [SwitchA-GigabitEthernet1/0/2] shutdown

    [SwitchA-GigabitEthernet1/0/2] quit

    [SwitchA] interface gigabitethernet 1/0/5

    [SwitchA-GigabitEthernet1/0/5] shutdown

    [SwitchA-GigabitEthernet1/0/5] quit

    # 在SwitchB上执行display vrrp命令查看VRRP状态信息,可以看到SwitchB的状态是Master。

    [SwitchB] display vrrp

    Vlanif100 | Virtual Router 1

    State : Master

    Virtual IP : 10.1.1.111

    Master IP : 10.1.1.129

    PriorityRun : 100

    PriorityConfig : 100

    MasterPriority : 100

    Preempt : YES Delay Time : 0 s

    TimerRun : 1 s

    TimerConfig : 1 s

    Auth type : NONE

    Virtual MAC : 0000-5e00-0101

    Check TTL : YES

    Config type : normal-vrrp

    Backup-forward : disabled

    Create time : 2012-01-12 20:15:46

    Last change time : 2012-01-12 20:15:46

    # 在SwitchB上使用display ip pool命令用来查看IP地址池配置情况。

    [SwitchB] display ip pool

    -----------------------------------------------------------------------------

    Pool-name : 1

    Pool-No : 0

    Lease : 10 Days 0 Hours 0 Minutes

    Position : Local Status : Unlocked

    Gateway-0 : 10.1.1.111

    Network : 10.1.1.0

    Mask : 255.255.255.0

    VPN instance : --

    Address Statistic: Total :253 Used :1

    Idle :124 Expired :0

    Conflict :0 Disable :128

    IP address Statistic

    Total :253

    Used :1 Idle :124

    Expired :0 Conflict :0 Disable :128

    配置文件

    SwitchA的配置文件

    #

    sysname SwitchA

    #

    vlan batch 100

    #

    dhcp enable

    #

    ip pool 1

    gateway-list 10.1.1.111

    network 10.1.1.0 mask 255.255.255.0

    excluded-ip-address 10.1.1.1

    excluded-ip-address 10.1.1.129 10.1.1.254

    lease day 10 hour 0 minute 0

    #

    interface Vlanif100

    ip address 10.1.1.1 255.255.255.0

    vrrp vrid 1 virtual-ip 10.1.1.111

    vrrp vrid 1 priority 120

    dhcp select global

    #

    interface GigabitEthernet1/0/2

    port link-type hybrid

    port hybrid pvid vlan 100

    port hybrid untagged vlan 100

    #

    interface GigabitEthernet1/0/5

    port link-type hybrid

    port hybrid pvid vlan 100

    port hybrid untagged vlan 100

    #

    returnSwitchB的配置文件

    #

    sysname SwitchB

    #

    vlan batch 100

    #

    dhcp enable

    #

    ip pool 1

    gateway-list 10.1.1.111

    network 10.1.1.0 mask 255.255.255.0

    excluded-ip-address 10.1.1.1 10.1.1.110

    excluded-ip-address 10.1.1.112 10.1.1.129

    lease day 10 hour 0 minute 0

    #

    interface Vlanif100

    ip address 10.1.1.129 255.255.255.0

    vrrp vrid 1 virtual-ip 10.1.1.111

    dhcp select global

    #

    interface GigabitEthernet1/0/2

    port link-type hybrid

    port hybrid pvid vlan 100

    port hybrid untagged vlan 100

    #

    interface GigabitEthernet1/0/5

    port link-type hybrid

    port hybrid pvid vlan 100

    port hybrid untagged vlan 100

    #

    returnSwitch的配置文件

    #

    sysname Switch

    #

    vlan batch 100

    #

    interface GigabitEthernet1/0/1

    port link-type hybrid

    port hybrid pvid vlan 100

    port hybrid untagged vlan 100

    stp instance 0 cost 20000

    #

    interface GigabitEthernet1/0/2

    port link-type hybrid

    port hybrid pvid vlan 100

    port hybrid untagged vlan 100

    #

    interface GigabitEthernet1/0/3

    port link-type access

    port default vlan 100

    stp disable

    #

    return

    展开全文
  • 配置基于全局地址池的DHCP服务器,从所有接口上连接的用户都可以选择该地址池中的地址,也就是说全局地址池是一个公共地址池。在DHCP服务器上创建地址池并配置相关属性(IP等等),再配置接口工作在全局地

    原理概述

    基于接口地址池的DHCP服务器,连接这个接口网段的用户都从该接口地址池中获取IP地址等配置信息,由于地址池绑在特定的接口上,可以限制用户的使用条件,因此在保障了安全性的同时也存在一定的局限性。当用户从不同接口接入DHCP服务器且需要从同一个地址池里获取IP地址时,就需要配置基于全局地址池的DHCP。
    配置基于全局地址池的DHCP服务器,从所有接口上连接的用户都可以选择该地址池中的地址,也就是说全局地址池是一个公共地址池。在DHCP服务器上创建地址池并配置相关属性(IP等等),再配置接口工作在全局地址池模式。路由器支持工作在全局地址池模式的接口有三层接口及其子接口,三层Ethernet接口及其子接口,三层Eth-Trunk接口及其子接口和VLANIF接口。

    工作流程(巨丑无比)

    在这里插入图片描述
    我用自己的话来说,就是PC-1想和R1要个IP地址(广播发送,因为现在PC-1啥也没有现在),R1收到请求,给你找个能用的IP地址,然后给PC-1看看,PC-1看看觉得行,回答说就他了,R1说行,你用吧,结束。

    实验拓扑

    在这里插入图片描述

    IP配置

    在这里插入图片描述

    实验步骤

    1:配置IP,交换机二层设备,无需配置,PC自动获取也不需要手工配置。

    [R1]interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/0]ip add 192.168.1.254 24
    [R1]interface GigabitEthernet 0/0/1
    [R1-GigabitEthernet0/0/1]ip add 192.168.2.254 24
    [R1-GigabitEthernet0/0/1]quit
    

    2:在R1上开启DHCP服务

    [R1]dhcp enable 
    

    3:创建一个IP pool 顾名思义就是给你个范围(这里这个池子的名字叫huawei)

    [R1]ip pool huawei
    

    4:用network命令配置全局地址池,huawei可分配的网段范围为192.168.1.0,
    如果不指定子网掩码,默认使用自然掩码,即24位子网掩码。该网段必须与路由器接口GE0/0/0的IP地址为同一网段。

    [R1-ip-pool-huawei]network 192.168.1.0
    

    5:配置地址租期,默认为1天,这里配置为100天

    [R1-ip-pool-huawei]lease day 100
    

    6:配置DHCP客户端出口网关地址

    [R1-ip-pool-huawei]gateway-list 192.168.1.254
    

    7:地址池不能分配的地址这里我让192.168.1.1到192.168.1.100不能参与分配,留着过年用

    [R1-ip-pool-huawei]excluded-ip-address 192.168.1.1 192.168.1.100
    

    8:配置DNS服务器地址(这里我配置为8.8.8.8)

    [R1-ip-pool-huawei]dns-list 8.8.8.8
    

    9:开启DHCP功能,使用该命令配置设备指定接口采用全局地址池为客户端分配IP地址

    [R1]int GigabitEthernet 0/0/0	
    [R1-GigabitEthernet0/0/0]dhcp select global 
    

    10:咱们这里需要为两个部门配置IP,所以需要两个地址池。为另一个部门地址池起名为huawei2,配置192.168.2.0网段,网关192.168.2.254,DNS还是使用8.8.8.8,然后在0/0/1接口下启用全局地址池的DHCP服务器模式

    [R1]ip pool huawei2
    Info: It's successful to create an IP address pool.
    [R1-ip-pool-huawei2]network 192.168.2.0
    [R1-ip-pool-huawei2]lease day 100
    [R1-ip-pool-huawei2]gateway-list 192.168.2.254
    [R1-ip-pool-huawei2]dns-list 8.8.8.8
    [R1-ip-pool-huawei2]quit
    [R1]interface GigabitEthernet 0/0/1	
    [R1-GigabitEthernet0/0/1]dhcp select global 
    [R1-GigabitEthernet0/0/1]quit
    

    11:可以查看一下地址池的配置

    [R1]display ip pool  
      -----------------------------------------------------------------------
      Pool-name      : huawei
      Pool-No        : 0
      Position       : Local           Status           : Unlocked
      Gateway-0      : 192.168.1.254   
      Mask           : 255.255.255.0
      VPN instance   : --
    
      -----------------------------------------------------------------------
      Pool-name      : huawei2
      Pool-No        : 1
      Position       : Local           Status           : Unlocked
      Gateway-0      : 192.168.2.254   
      Mask           : 255.255.255.0
      VPN instance   : --
    
    
      IP address Statistic
        Total       :506   
        Used        :2          Idle        :404   
        Expired     :0          Conflict    :0          Disable   :100   
    

    验证结果

    PC>ipconfig
    
    Link local IPv6 address...........: fe80::5689:98ff:feb6:76b6
    IPv6 address......................: :: / 128
    IPv6 gateway......................: ::
    IPv4 address......................: 192.168.1.253
    Subnet mask.......................: 255.255.255.0
    Gateway...........................: 192.168.1.254
    Physical address..................: 54-89-98-B6-76-B6
    DNS server........................: 8.8.8.8
    
    PC>ipconfig
    
    Link local IPv6 address...........: fe80::5689:98ff:fe45:e21
    IPv6 address......................: :: / 128
    IPv6 gateway......................: ::
    IPv4 address......................: 192.168.2.253
    Subnet mask.......................: 255.255.255.0
    Gateway...........................: 192.168.2.254
    Physical address..................: 54-89-98-45-0E-21
    DNS server........................: 8.8.8.8
    

    没问题

    新人博主,资历有限,如果有哪些不足之处请不吝赐教。

    展开全文
  • 华为路由器作DHCP服务配置(接口地址池和全局地址池配置)发布时间:2020-07-17 10:15:06来源:51CTO阅读:9142作者:zhang书虫一、接口地址池方式配置1.配置DHCP服务为AR1[Huawei]interface g0/0/0[Huawei-...

    华为路由器作DHCP服务配置(接口地址池和全局地址池配置)

    发布时间:2020-07-17 10:15:06

    来源:51CTO

    阅读:9142

    作者:zhang书虫

    bc83b1f69ceea09029318885471647b1.png

    一、接口地址池方式配置

    1.配置DHCP服务为AR1

    [Huawei]interface g0/0/0

    [Huawei-GigabitEthernet0/0/0]ip add 192.168.1.1 255.255.255.0

    [Huawei-GigabitEthernet0/0/0]undo shutdown

    [Huawei-GigabitEthernet0/0/0]dhcp select interface

    [Huawei-GigabitEthernet0/0/0]dhcp server dns-list 192.168.20.50

    [Huawei-GigabitEthernet0/0/0]dhcp server excluded-ip-address 192.168.1.1

    [Huawei-GigabitEthernet0/0/0]dhcp server lease day 1

    [Huawei]display ip pool

    -----------------------------------------------------------------------

    Pool-name      : GigabitEthernet0/0/0

    Pool-No        : 0

    Position       : Interface       Status           : Unlocked

    Gateway-0      : 192.168.1.1

    Mask           : 255.255.255.0

    ××× instance   : --

    IP address Statistic

    Total       :253

    Used        :0          Idle        :253

    Expired     :0          Conflict    :0          Disable   :0

    二、全局地址池方式配置

    原理:全局方式下,设置多个全局地址池,并存在定义的地址池网段与端口IP是同一网段的对应关系,即多个不同网段地池对应各自的端口,最终实现不同网段客户端自动获取相应地址配置DHCP服务为AR1

    [Huawei]dhcp enable

    [Huawei]ip pool jszx

    [Huawei-ip-pool-jszx]network 192.168.1.0 mask 24

    [Huawei-ip-pool-jszx]gateway-list 192.168.1.1

    [Huawei-ip-pool-jszx]lease day 1

    [Huawei]interface g0/0/0

    [Huawei-GigabitEthernet0/0/0]dhcp select global

    [Huawei]display ip pool

    Pool-name      : jszx

    Pool-No        : 0

    Position       : Local           Status           : Unlocked

    Gateway-0      : 192.168.1.1

    Mask           : 255.255.255.0

    ××× instance   : --

    IP address Statistic

    Total       :253

    Used        :0          Idle        :253

    Expired     :0          Conflict    :0          Disable

    三、附加升级试验

    依照"二"的全局配置过程,需要几个网段就定义几个地址池

    1.在"二"的基础上再添中JYD地址池,拓扑如下:

    25a06f5ec39ca91b14b31d20796d5b41.png

    配置AR1添加JYD地址池

    [Huawei]interface GigabitEthernet 0/0/1

    [Huawei-GigabitEthernet0/0/1]ip address 192.168.100.1 255.255.255.0

    [Huawei]ip pool JYD

    [Huawei-ip-pool-jszx]network 192.168.100.0 mask 24

    [Huawei-ip-pool-jszx]gateway-list 192.168.100.1

    [Huawei-ip-pool-jszx]lease day 1

    [Huawei]interface g0/0/1

    [Huawei-GigabitEthernet0/0/0]dhcp select global

    [Huawei]display ip pool

    PC5获得地址

    80fb0550299cd650253283ca69ae50ff.png

    PC1获得地址

    d881b4b983c83bc010d72b27718f9237.png

    展开全文
  • 全局地址池的DHCP拓扑图: R1: 配置全局DHCP pool1 、 pool2 : ip pool pool1 network 192.168.100.0 24 gateway-list 192.168.100.254 excluded-ip-address 192.168.100.240 192.168.100.254 //排除240-254地址...

    全局地址池的DHCP拓扑图:

    在这里插入图片描述
    R1:

    配置全局DHCP pool1 、 pool2 :

    ip pool pool1
    network 192.168.100.0 24
    gateway-list 192.168.100.254
    excluded-ip-address 192.168.100.240 192.168.100.254 //排除240-254地址段
    dns-list 8.8.8.8
    lease day 2
    
    ip pool pool2
    network 192.168.200.0 24
    gateway-list 192.168.200.254
    dns-list 8.8.8.8
    lease day 2
    

    interface g0/0/0:

    system-view
    interface g0/0/0
    ip add 192.168.100.254 24
    
    interface g0/0/0
    dhcp select pool1
    

    interface g0/0/1:

    interface g0/0/1
    ip add 192.168.200.254 24
    
    interface g0/0/1
    dhcp select pool2
    
    dis ip pool  //查看地址池信息
    
    展开全文
  • 动态主机配置协议DHCP...地址池分为接口地址池和全局地址池两种。接口地址池配置方式简单,只能用于用户与DHCP服务器在同一个网段的场景,并且只能给对应接口下的用户分配IP地址等网络参数;适用于设备数量有限、...
  • 一、接口地址池方式配置1.配置DHCP服务为AR1[Huawei]interface g0/0/0[Huawei-GigabitEthernet0/0/0]ip add 192.168.1.1 255.255.255.0[Huawei-GigabitEthernet0/0/0]undo shutdown[Huawei-GigabitEthernet0/0/0]...
  • 华为eNSP实验2、全局配置DHCP地址池

    千次阅读 2019-11-12 20:29:44
    3、配置全局地址池 4、宣告地址池 5、配置网关、dns、域名等 6、接口下调用全局地址池 dhcp-server配置如下: dhcp enable ip pool cisco gateway-list 192.168.1.254 network 192.168.1.0 mask 25...
  • 在配置DHCP之前呢一定一定要在全局模式下先开启dhcp enable第一步配置DHCP信息[AR1-GigabitEthernet0/0/0] ip address 192.168.10.1 255.255.255.0 //配置接口ip[AR1-GigabitEthernet0/0/0]dhcp select interface //...
  • 华为路由器DHCP地址池的配置

    千次阅读 2020-04-11 23:47:08
    华为路由器DHCP全局地址池的配置 DHCP有两种配置,一种是接口地址池,一种是全局地址池,上一期我写过接口地址池了,这次来看看全局地址池。 第一步:dhcp的配置 在配置DHCP之前一定一定要在全局模式下开启dhcp:...
  • 华为设备DHCP地址池的配置

    千次阅读 2020-04-11 22:06:10
    DHCP地址池的配置有两种,一种是在接口地址池,一种是全局地址池。 首先先来看一下接口地址池 在配置DHCP之前呢一定一定要在全局模式下先开启dhcp enable 第一步配置DHCP信息 [AR1-GigabitEthernet0/0/0] ip address...
  • 在配置DHCP之前呢一定一定要在全局模式下先开启dhcp enable第一步配置DHCP信息[AR1-GigabitEthernet0/0/0] ip address 192.168.10.1 255.255.255.0 //配置接口ip[AR1-GigabitEthernet0/0/0]dhcp select interface //...
  • 现在我们利用华为S5700交换机配置一个DHCP服务器 拓扑图如下 操作步骤 ... 全局启动DHCP服务。...Huawei>... Enter system view, return user view with Ctrl+Z. ... [Huawei]dhcp enable ... 创建地址...
  • 今天分享一下如何在华为三层交换机上配置DHCP服务。拓扑图三台终端分别为三个不同的部门,分别加入到不同的VLAN中,为了后续扩展需求,现在,采用动态获取IP地址。配置思路在交换机上创建VALN10-30。把三台终端分别...
  • 华为交换机 DHCP中继全局不同网段配置

    万次阅读 多人点赞 2018-07-02 17:06:02
    1、DHCP作为公司汇聚交换机,在上面配置DHCP全局地址池,然后接入交换机根据不同vlan会获取到不同网段IP地址。 2、网络拓扑 二、操作步骤 1、客户端 1)创建DHCP服务器组,并为DHCP服务器组添加DHCP服务器对应...

空空如也

空空如也

1 2 3 4
收藏数 65
精华内容 26
关键字:

华为全局地址池