精华内容
下载资源
问答
  • 2.给PC地址子网掩码网关配置(另一个同理) 3.配置路由器1 sys Enter system view, return user view with Ctrl+Z. [Huawei]int g0/0/0 [Huawei-GigabitEthernet0/0/0]ip add 192.168.10.2 24 //给端口添加IP地址 ...

    1.网络规划拓扑

    在这里插入图片描述

    2.给PC地址子网掩码网关配置(另一个同理)

    在这里插入图片描述
    在这里插入图片描述

    3.配置路由器1

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]int g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add 192.168.10.2 24 //给端口添加IP地址
    [Huawei-GigabitEthernet0/0/0]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add 192.168.20.1 24 //给端口添加IP地址
    [Huawei-GigabitEthernet0/0/1]q
    [Huawei]un in en //关闭提示信息
    Info: Information center is disabled.
    [Huawei]rip 1 //配置rip协议
    [Huawei-rip-1]version 2
    [Huawei-rip-1]network 192.168.10.0
    [Huawei-rip-1]network 192.168.20.0
    下图分别是路由器2和3配置和1类似
    在这里插入图片描述
    在这里插入图片描述

    4.使用display ip routing-table 命令查看一下路由器2的路由表

    在这里插入图片描述

    5.检验网络连通192.168.10.1ping192.168.40.1

    在这里插入图片描述

    6.tracert命令查看路由路径

    1 192.168.10.2 31 ms 31 ms 16 ms 网关
    2 192.168.20.2 15 ms 32 ms 15 ms 下一跳
    3 192.168.30.2 47 ms 31 ms 32 ms 下一跳
    4 192.168.40.1 31 ms 15 ms 32 ms 目的地址

    展开全文
  • 0x0 RIP协议如何工作? 在路由器上开启RIP协议,并将路由器的直连网段宣告进RIP后,RIP会将这些直连网段信息封装成RIP协议报文,发送给...注:在动态路由中我们添加的网段都是直连网段 0x2 配置RIP 宣告 rip 100 ...

    0x0 RIP协议如何工作?

    在路由器上开启RIP协议,并将路由器的直连网段宣告进RIP后,RIP会将这些直连网段信息封装成RIP协议报文,发送给邻居路由器。这样邻居路由器间就可以相互学习对方的网段信息,实现网络互通。

    0x1 如何配置基本的RIP网络?

    ①开启RIP协议
    ②将路由器的直连网段宣告进RIP协议

    注:在动态路由中我们添加的网段都是直连网段

    0x2 配置RIP 宣告

     rip 100                 #创建RIP协议进程100
     network 12.0.0.0  #宣告网段
    

    在这里插入图片描述

    0x3 RIP 如何计算开销值

    RIP是基于跳数来计算开销值,跳数就是跨越网段的数量

    RIP路由的最大网络跳数为15,如果一条RIP路由的跳数到达16,路由器则认为该路由不可达。

    0x4 RIP定时器的分类

    1.RIP有哪些定时器?
    ①更新定时器
    ②老化定时器
    ③垃圾回收定时器

    2.RIP定时器作用
    ①更新定时器(30s):运行rip的路由器会以30s为周期,向邻居发送RIP路由
    ②老化定时器(180s):当路由器在180s内没有收到一条RIP路由的更新,那么路由器会认为这条RIP路由已经失效。
    ③垃圾定时器(120s):当路由被设置为失效后,不会立即删除,需要等待120s才会彻底删除

    0x5 为什么RIP需要周期性的发送路由

    因为RIP基于UDP发送协议报文,而UDP没有确认机制,所以路由将路由发送出去以后无法确认另据是否收到RIP路由,为了保障路由的可靠更新,所以需要周期发送RIP路由。

    0x4 如何修改RIP的定时器?

    进入RIP协议对定时器做修改,在修改定时器时候只需要将本地路由老化时间比邻居的路由更新时间长就可以了。

     rip 100   #进入RIP协议进程 timers rip 10 20 30  #修改rip的更新、老化、垃圾定时器时间为10 20 30
    

    0x5 RIP的静默接口

    1.什么是RIP静默接口
    当路由器的接口被设置为RIP的静默接口后,这个接口将不会再向外发送RIP组播或者广播报文

    2.什么时候使用RIP的静默接口
    当路由器对端设备没有开启RIP的时候,将本地连接对端设备的接口设置为RIP的静默接口。

    3.静默接口的配置

     rip 100                       #进入rip协议进程
     silent-interface g0/0/0      #把接口g0/0/0设置成静默接口
    

    0x6 RIP单播更新

    1.什么是RIP单播更新?
    单播更新是指邻居路由器之间通过单播交互RIP路由信息

    2.什么场景使用RIP单播更新?
    当网络内有路由器没有启动RIP的时候,我们就可以让启用了RIP的路由器使用单播更新,单独交互RIP路由信息,这样就不会影响没有开启RIP协议的路由器了

    3.开启RIP单播更新需要注意什么?
    开启了RIP的单播更新功能后,RIP的组播或广播更新功能并没有关闭,所以还需要使用静默接口设置,关闭接口的组播和广播更新功能,这样就只有单播更新功能留下来了。

    4.单播更新的配置

    rip 100                       #进入rip协议进程
    peer  12.1.1.1             #配置跟你单播的路由器的IP
    silent-interface g0/0/0      #把接口g0/0/0设置成静默接口
    

    0x7 RIP V2 配置

    rip 100                       #进入RIP协议进程
    version 2                   #进入RIP 版本2
    network 12.0.0.0      #宣告网段
    

    0x8 自动汇总

    当子网路由传递到主类网段边界的时候,路由器会将子网路由汇总为主类网段再发送出去。

    rip 1版本开启了自动汇总
    rip 2版本关闭了自动汇总

    一般建议使用RIP 2版本

    0x9 手工汇总路由

    1.为什么要配置手工汇总?
    ①可以减少网络中路由条目的数量;
    ②可以可以增强网络的稳定性,因为汇总路由中包含的

    部分明细路由失效是不会影响汇总路由的,只有汇总路由中包含的所有明细路由失效,汇总路由才会消失。

    2.RIPv2手工汇总如何配置?
    在这里插入图片描述
    系统模式下:

    **R1:**
     rip 100
     network 12.0.0.0
     #添加直连网段路由
     
    **R2:**
    int loop-back 0   
    ip address 10.1.0.2 24 
    int loop-back 1 
    ip address10.1.1.2 24 
    int loop-back2 
    ip address 10.1.2.2 24 
    int loop-back 3 
    ip address 10.1.3.2 24
    # 创建环回接口
    int g0/0/0
    rip summary-address 10.1.0.0 255.255.252.0
    #进入本地路由接口,创建手动汇总,把上面的IP段汇总成一个大段
    rip 100
    network 12.0.0.0
    network 10.0.0.0
    #添加直连网段路由
    

    在这里插入图片描述

    注:进入接口实现RIPv2手工汇总,RIPv1无法实现手工汇总。

    0x10 手动修改路由器运行的RIP版本

    int g0/0/0
    rip version 1 #选择版本1

    展开全文
  • 动态路由信息协议RIP配置RIP命令;测试路由器之间联通情况;Wireshark抓包分析e/0/0/0。

    一、动态路由信息协议RIP

    动态路由信息协议RIP(Routing Information Protocol):它是一种基于距离矢量
    (Distance-Vector)算法的协议,使用跳数作为度量来衡量达到目的网络的距离。RIP主要用于规模较小的网络中,收敛速度很慢。
    工作原理:路由器运行RIP 后,首先会发送路由更新请求,收到请求的路由会发送自己的RIP路由进行响应。网络稳定后,路由器会周期性(30秒)发送路由更新信息,目标地址是224.0.0.9的组播地址,报文存放的的是路由信息。RIP的默认优先级Pre是100,RIP只看路由远近,距离以跳数(经过路由器的个数)来衡量,最大跳数不能超过15跳,经过16跳的路由器不可达。
    抑制接口:又称静默接口,配置接口为抑制状态,发送但不接收RIP路由更新报文,抑制接口通常用于接PC端路由器,如R1的Ethernet0/0/1接口,其优先级大于RIP Input和RIP Output。
    [R1]rip
    [R1-rip-1]silent-interface e0/0/1
    华为路由器拓扑图

    二、配置RIP命令

    如上图所示,在配置好R1、R2和R3路由器各个接口IP地址后再配置RIP协议。

    (一)配置路由器RI的RIP路由

    [R1]rip 1 #RIP进程号
    [R1-rip-1]version 2 #使用RIP 2版本
    [R1-rip-1]network 192.168.1.0 # 宣告直连类网路
    [R1-rip-1]network 12.0.0.0 # 宣告直连类网路
    [R1-rip-1]undo summary #关闭路由自动汇总
    [R1-rip-1]display this

    rip 1
    undo summary
    version 2
    network 192.168.1.0
    network 12.0.0.0

    return

    (二)配置路由器R2的RIP路由

    [R2]rip 1
    [R2-rip-1]version 2
    [R2-rip-1]undo summary
    [R2-rip-1]network 12.0.0.0
    [R2-rip-1]network 23.0.0.0
    [R2-rip-1]network 172.16.0.0
    [R2-rip-1]display this

    rip 1
    undo summary
    version 2
    network 12.0.0.0
    network 23.0.0.0
    network 172.16.0.0

    (三)配置路由器R3的RIP路由

    [R3]rip 1
    [R3-rip-1]version 2
    [R3-rip-1]undo summary
    [R3-rip-1]network 23.0.0.0
    [R3-rip-1]network 10.0.0.0
    [R3-rip-1]display this

    rip 1
    undo summary
    version 2
    network 23.0.0.0
    network 10.0.0.0

    (四)抑制路由器R1接口E0/0/1

    RIP Input和RIP Output。
    [R1]rip
    [R1-rip-1]silent-interface e0/0/1

    三、测试路由器之间联通情况

    PC1终端ping路由器R3

    四、Wireshark抓包分析e/0/0/0

    抓包分析e/0/0/0
    Wireshark抓包路由器接口

    展开全文
  • 链路状态路由协议1.2 rip路由协议工作原理1.2.1 rip是距离——矢量路由选择协议1.2.2 rip的基本概念1.2.3 RIP度量值为跳数1.2.4 RIP更新时间1.2.5 RIP路由更新消息1.3 rip命令二:实验2.1 实验测试兼容模式————...

    一:前言:

    1.1 rip协议概述

    1.1.1 按照路由执行的算法分类

    1.距离矢量路由协议

    • 依据从源网络到目标网络所经过的路由器的个数选择路由
      ●RIP、 IGRP
    2.链路状态路由协议
    • 综合考虑从源网络到目标网络的各条路径的情况选择路由
      ●OSPF、IS-IS

    1.2 rip路由协议工作原理

    1.2.1 rip是距离——矢量路由选择协议

    1.2.2 rip的基本概念

    • 定期更新 (路由器每经过一-段时间周期-30S后, 向邻居发送更新信息)
    • 邻居(与其相连的路由器)
    • 广播更新(Ripv1 255.255.255.255)
    • 组播更新 (Ripv2 224.0.0.9)
    • 泛洪路由表(路由器将从邻居学习到的路由放进自己的路由表中,然后将路由表所有路由信息在通告给其他路由器,直到整个网络学习到)

    1.2.3 RIP度量值为跳数

    • 最大跳数为15跳,16跳为不可达

    1.2.4 RIP更新时间

    • 每隔30s发送路由更新消息,UDP520端口

    1.2.5 RIP路由更新消息

    • 发送整个路由表信息(除了从接收端接收到的路由条目外)

    1.3 rip命令

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    二:实验

    2.1 实验测试兼容模式————即不宣告rip版本

    在这里插入图片描述

    2.1.1 AR2配置

    The device is running!
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sysname AR2
    [AR2-GigabitEthernet0/0/0]int lo 0
    [AR2-LoopBack0]ip add 192.168.200.1 30
    [AR2-LoopBack0]int g 0/0/0
    [AR2-GigabitEthernet0/0/0]ip add 12.0.0.2 30
    [AR2-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [AR2-GigabitEthernet0/0/0]q
    [AR2]rip 1
    [AR2-rip-1]network 192.168.200.0
    [AR2-rip-1]network 12.0.0.0
    [AR2-rip-1]q
    [AR2]
    

    2.1.2 AR1 配置

    The device is running!
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sysname AR1
    [AR1]int g0/0/0
    [AR1-GigabitEthernet0/0/0]ip add 12.0.0.1 30
    [AR1-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [AR1-GigabitEthernet0/0/0]int lo 0
    [AR1-LoopBack0]ip add 192.168.100.1 24
    [AR1-LoopBack0]q
    [AR1]rip 1
    [AR1-rip-1]network 192.168.100.0
    [AR1-rip-1]network 12.0.0.0
    [AR1-rip-1]
    

    2.1.3 查看路由表

    [AR1]dis ip routing
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 11       Routes : 11       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
           12.0.0.0/30  Direct  0    0           D   12.0.0.1        GigabitEthernet
    0/0/0
           12.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           12.0.0.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
      192.168.100.0/24  Direct  0    0           D   192.168.100.1   LoopBack0
      192.168.100.1/32  Direct  0    0           D   127.0.0.1       LoopBack0
    192.168.100.255/32  Direct  0    0           D   127.0.0.1       LoopBack0
      192.168.200.0/24  RIP     100  1           D   12.0.0.2        GigabitEthernet
    0/0/0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    
    [AR2]dis ip routing
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 11       Routes : 11       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
           12.0.0.0/30  Direct  0    0           D   12.0.0.2        GigabitEthernet
    0/0/0
           12.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           12.0.0.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
      192.168.100.0/24  RIP     100  1           D   12.0.0.1        GigabitEthernet
    0/0/0
      192.168.200.0/30  Direct  0    0           D   192.168.200.1   LoopBack0
      192.168.200.1/32  Direct  0    0           D   127.0.0.1       LoopBack0
      192.168.200.3/32  Direct  0    0           D   127.0.0.1       LoopBack0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    
    

    抓包查看,不设置版本的兼容模式,默认发送的是rip v1 版本,以广播的形式接收

    在这里插入图片描述

    2.2 实验测试兼容模式中在接口配置命令去发送rip v2 信息,或者在rip v2 的路由中设置接收rip v1 数据

    在这里插入图片描述

    备注:rip协议中,通过UDP520端口发送的路由条目信息,最大支持25条路由条目

    2.2.1 设置接口IP

    AR1:

    The device is running!
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sysname AR1
    [AR1]int lo 0
    [AR1-LoopBack0]ip add 1.1.1.1 24
    [AR1-LoopBack0]int g 0/0/0
    [AR1-GigabitEthernet0/0/0]ip add 12.0.0.1 30
    [AR1-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [AR1-GigabitEthernet0/0/0]
    

    AR2:

    The device is running!
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sysname AR2
    [AR2]int lo 0
    [AR2-LoopBack0]ip add 2.2.2.2 24
    [AR2-LoopBack0]int g 0/0/0
    [AR2-GigabitEthernet0/0/0]ip add 12.0.0.2 30
    [AR2-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [AR2-GigabitEthernet0/0/0]int g 0/0/1
    [AR2-GigabitEthernet0/0/1]ip add 23.0.0.1 30
    [AR2-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [AR2-GigabitEthernet0/0/1]
    

    AR3:

    The device is running!
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sysname AR3
    [AR3]int lo 0
    [AR3-LoopBack0]ip add 3.3.3.3 24
    [AR3-LoopBack0]int g 0/0/1
    [AR3-GigabitEthernet0/0/1]ip add 23.0.0.2 30
    [AR3-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [AR3-GigabitEthernet0/0/1]
    

    2.2.2 开始设置RIP

    AR1:

    [AR1-GigabitEthernet0/0/0]q
    [AR1]rip 1	
    [AR1-rip-1]?
    rip-1 interface view commands:
      arp-ping          ARP-ping
      backup            Backup  information
      bfd               Bidirectional Forwarding Detection
      checkzero         Perform the checkzero operation in the zero fields of RIP   
                        packets
      clear             Clear
      default-cost      Specify default metric for imported routes
      default-route     Enable advertisement of default routes
      description       Specify the process description
      dialer            Dialer
      display           Display information
      filter-policy     Specify route filtering policy
      graceful-restart  Graceful restart information
      host-route        Enable sending and receiving host routes
      import-route      Import routes from other protocols into RIP
      maximum           Set the maximum number of equal-cost multipaths
      mtrace            Trace route to multicast source
      network           Enable the routing protocol on the related network or       
                        interface
      peer              Specify a peer router
      ping              <Group> ping command group
      preference        Specify RIP route preference
      quit              Exit from current mode and enter prior mode
      reset             <Group> reset command group
      return            Enter the privileged mode
      silent-interface  Suppress RIP packets from being sent on the specified       
                        interface
      summary           Enable route summarization
      test-aaa          Accounts test
      timers            Adjust the protocol timers
      tracert           <Group> tracert command group
      undo              Negate a command or set its defaults
      verify-source     Validate the source IP address of received RIP updates
      version           Specify RIP version
    [AR1-rip-1]version 1
    [AR1-rip-1]network 1.1.1.0
    Error: The network address is invalid, and the specified address must be major-n
    et address without any subnets.
    [AR1-rip-1]network 1.0.0.0
    [AR1-rip-1]network 12.0.0.0
    [AR1-rip-1]undo summary 
    

    AR2:

    [AR2-GigabitEthernet0/0/1]q
    [AR2]rip 1
    [AR2-rip-1]network 2.0.0.0
    [AR2-rip-1]network 12.0.0.0
    [AR2-rip-1]network 23.0.0.0
    [AR2-rip-1]
    [AR2-rip-1]un summary 
    

    AR3:

    [AR3-GigabitEthernet0/0/1]q
    [AR3]rip 1
    [AR3-rip-1]version 2
    [AR3-rip-1]network 23.0.0.0 30
                                ^
    Error:Too many parameters found at '^' position.
    [AR3-rip-1]network 23.0.0.0
    [AR3-rip-1]network 3.3.3.0
    Error: The network address is invalid, and the specified address must be major-n
    et address without any subnets.
    [AR3-rip-1]network 3.3.3.0 24
                               ^
    Error:Too many parameters found at '^' position.
    [AR3-rip-1]network 3.0.0.0
    [AR3-rip-1]undo summary 
    [AR3-rip-1]
    

    2.2.3 抓包AR1的g0/0/0瞅一眼

    在这里插入图片描述
    在这里插入图片描述

    2.2.4 再抓一个AR3的g0/0/1

    在这里插入图片描述
    在这里插入图片描述

    2.2.5 小结:可以发现rip v1 不支持子网划分,网段没有经过划分;rip v2 支持子网划分,宣告出来的网段经过子网划分

    2.2.6 这时候看一下各个路由的路由表

    AR1:

    [AR1]dis ip routing-table 
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.0/24  Direct  0    0           D   1.1.1.1         LoopBack0
            1.1.1.1/32  Direct  0    0           D   127.0.0.1       LoopBack0
          1.1.1.255/32  Direct  0    0           D   127.0.0.1       LoopBack0
            2.0.0.0/8   RIP     100  1           D   12.0.0.2        GigabitEthernet
    0/0/0
            3.0.0.0/8   RIP     100  2           D   12.0.0.2        GigabitEthernet
    0/0/0
           12.0.0.0/30  Direct  0    0           D   12.0.0.1        GigabitEthernet
    0/0/0
           12.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           12.0.0.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           23.0.0.0/8   RIP     100  1           D   12.0.0.2        GigabitEthernet
    0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    

    AR2:

    [AR2]dis ip routing
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 15       Routes : 15       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.0.0.0/8   RIP     100  1           D   12.0.0.1        GigabitEthernet
    0/0/0
            2.2.2.0/24  Direct  0    0           D   2.2.2.2         LoopBack0
            2.2.2.2/32  Direct  0    0           D   127.0.0.1       LoopBack0
          2.2.2.255/32  Direct  0    0           D   127.0.0.1       LoopBack0
            3.3.3.0/24  RIP     100  1           D   23.0.0.2        GigabitEthernet
    0/0/1
           12.0.0.0/30  Direct  0    0           D   12.0.0.2        GigabitEthernet
    0/0/0
           12.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           12.0.0.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           23.0.0.0/30  Direct  0    0           D   23.0.0.1        GigabitEthernet
    0/0/1
           23.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
           23.0.0.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    

    AR3:

    [AR3]dis ip routing
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 10       Routes : 10       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            3.3.3.0/24  Direct  0    0           D   3.3.3.3         LoopBack0
            3.3.3.3/32  Direct  0    0           D   127.0.0.1       LoopBack0
          3.3.3.255/32  Direct  0    0           D   127.0.0.1       LoopBack0
           23.0.0.0/30  Direct  0    0           D   23.0.0.2        GigabitEthernet
    0/0/1
           23.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
           23.0.0.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    

    2.2.7 在路由表中,兼容模式路由接收到的3.3.3.0路由条目转发给rip v1,路由条目变为3.0.0.0,证明rip v1不支持子网划分

    2.2.8 当前rip v2 中没有获得新的路由条目,,因为兼容模式可以收rip v1和rip v2路由信息,但发只能是rip v1路由信息

    2.2.9 需要解决这个问题

    两种方法:

    第一种、进入R3的接收接口
    int g0/0/1
    rip version 1
    第二种、进入R2的发送接口(发送给vip v2路由的接口)
    int g 0/0/1
    rip version 2 multicast

    这里实验第二种方法,然后查看抓包数据

    是不是发生改变,然后再看路由表

    [AR2]int g 0/0/1
    [AR2-GigabitEthernet0/0/1]rip version 2 multicast 
    

    rip版本发生改变
    在这里插入图片描述

    AR3路由表,路由信息同步

    [AR3]dis ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 13       Routes : 13       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.0.0.0/8   RIP     100  2           D   23.0.0.1        GigabitEthernet
    0/0/1
            2.2.2.0/24  RIP     100  1           D   23.0.0.1        GigabitEthernet
    0/0/1
            3.3.3.0/24  Direct  0    0           D   3.3.3.3         LoopBack0
            3.3.3.3/32  Direct  0    0           D   127.0.0.1       LoopBack0
          3.3.3.255/32  Direct  0    0           D   127.0.0.1       LoopBack0
           12.0.0.0/30  RIP     100  1           D   23.0.0.1        GigabitEthernet
    0/0/1
           23.0.0.0/30  Direct  0    0           D   23.0.0.2        GigabitEthernet
    0/0/1
           23.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
           23.0.0.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    

    32 Direct 0 0 D 127.0.0.1 GigabitEthernet
    0/0/1
    23.0.0.3/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
    0/0/1
    127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
    127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
    127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
    255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0

    
    
    
    
    展开全文
  • RIP协议 配置各个网段使其相邻的可以ping通 [AR1]rip #启用RIP协议 [AR1-rip-1]version 2 #使用RIP版本为2 [AR1-rip-1]network 10.0.0.0 #声明自己所在的网段 ...查看路由协议 查看路由表 ping测试成功 ...
  • 文章目录一、动态路由及RIP协议工作原理1.1 动态路由概述1.1.2 动态路由...RIP配置和验证1.2.6 ripv1和v2的区别1.2.7 rip兼容模式二、动态路由协议实验2.1 实验目的2.2 实验环境2.3 实验步骤2.3.1 配置R12.3.2 配置R...
  • 分别配置三台路由器:R1ripv1版本,R3ripv2版本,R2兼容模式,调整R2端口rip协议版本让三台路由器能互相学习路由表 二、实验环境 在华为ENSP中建立如图所示拓扑图 在R1中设置 [R1]interface g0/0/0 ##配置接口ip [R1...
  • 文章目录华为模拟器--动态路由器+RIP路由协议配置及验证前言一、动态路由1.1动态路由协议基础1.1.1动态路由1.1.2动态路由特点1.2动态路由协议概述1.2.1度量值1.2.2收敛1.2.3静态路由与动态路由的比较1.3动态路由协议...
  • 静态路由:安全、配置繁琐、网络工程师必须非常了解本网络结构动态路由:适用于中型及大型网络、相应网络拓扑结构改变、不安全IGPS内部网关路由工作在一个AS内部EGPS边界网关路由工作在AS之间AS自治系统:一组受相同...
  • R1配置 <Huawei>sys Enter system view, return user view with Ctrl+Z. [Huawei]sys R1 [R1]int g0/0/0 [R1-GigabitEthernet0/0/0]ip add [R1-GigabitEthernet0/0/0]ip address 192.168.1.254 24 Oct 18 ...
  • 华为HCNA实验学习--RIP配置HCNA 动态路由RIP配置实验1.动态路由的概念2.静态路由的配置思路 HCNA 动态路由RIP配置实验 本章内容意在学习静态路由协议相关知识。通过本章的学习,你将掌握以下内容: 1.动态路由的概念...
  • RIP(Routing Information Protocol,路由信息协议)是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数...
  • 最简单的拓扑图解释RIP配置,RIP协议特点,华为模拟器中详细的配置命令
  • 任务2 RIP路由协议配置■ 任务背景某大型企业已有12台路由器,需要组建内部网络实现资源共享,考虑公司规模较大不适合采用静态路由组网,工程师对公司的实际情况进行了分析:1、路由跳数较多,不适合使用静态路由...
  • 动态路由之RIP 一、动态路由概述 动态路由可以实现路由器之间动态得互相学习路由表,而不需要工程师手工写路由 二、动态路由协议 动态路由基于一种动态路由协议实现得!协议:就是一种设备之间得语言或规则!如http...
  • 文章目录一、动态路由rip原理1.1动态路由概述1.2动态路由协议分类1.3RIP路由协议1.3.1RIP基本概念1.3.2RIP协议的特性1.3.3RIP度量值与更新时间1.3.4水平分割1.3.5RIP v1和RIP v2的区别1.3.6RIP兼容模式二、RIP实验...
  • BGP动态路由协议 ####BGP概述#### 1、 自治系统(AS)是由-个技术管理机构管理,使用统一选路策略的- -组路由器集合, 自治系统编号范围: 1-65535,其中1-64511是互联网.上注册公有AS号,类似公网IP地址。 64512-65535是...
  • 今天我们一起来看下RIP动态协议,其实不管时静态路由协议还是动态路由协议,他们最终的目的都是生成路由,路由器根据各种协议产生的路由选择最优路由加入路由表,用于指导数据包转发。其实RIP基本上在现网中基本已经...
  • RIP动态路由协议一、动态路由1、什么是动态路由2、动态路由的特点3、动态路由协议概述4、动态路由的度量值5、收敛是什么意思6、动态路由协议的分类二、RIP协议RIP(距离矢量协议)RIP:邻居:周期更新:Metric:版本...
  • OSPF动态路由协议实验与RIP动态路由协议的路由重分发配置方法 一、OSPF与RIP的区别 二、OSPF路由器类型 区域内路由器(InternalRouter) 区域边界路由器ABR(Area Border Router) 骨干路由器(BackboneRouter) ...
  • 文章目录前言一、动态路由协议基础1.概述2.度量值3.分类二、RIP路由协议工作原理1.基本原理2.路由环路 前言 前面我们学习了静态路由,在进行实验配置时,通过手动一个一个进行配置,久了感到非常麻烦,尤其在规模较...
  • 路由协议RIP

    千次阅读 2018-11-22 08:07:44
    RIP协议是一种内部网关协议(IGP),底层是贝尔曼福特算法,是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量...
  • RIP是Routing Information Protocol(路由信息协议)的简称,它是一种较为简单的内部网关协议(Interior Gateway Protocol)。RIP是一种基于距离矢量(Distance-Vector)算法的协议,它使用跳数(Hop Count)作为...
  • 华为路由器配置RIP
  • RIP是一种内部网关协议(IGP),是动态路由选择协议,用于自治系统(AS)内的路由信息的传递。 RIP协议基于距离矢量算法,使用“跳数”来衡量到达目标地址的路由距离。通过共享路由来完成未知路由的获取,最大16条,...

空空如也

空空如也

1 2 3 4
收藏数 70
精华内容 28
关键字:

华为动态路由协议rip配置