精华内容
下载资源
问答
  • 不使用pip install torchvision=0.4.0 使用pip install --no-deps torchvision=0.4.0w 完美解决安装完torchvision之后继续更新torch到1.2.0版本(目前最新版)。

    不使用pip install torchvision==0.4.0
    使用pip install --no-deps torchvision==0.4.0
    完美解决安装完torchvision之后继续更新torch到1.2.0版本(目前最新版)。

    展开全文
  • 我写这篇文章的时候刚出3.8但还是3.7 3.6靠谱一点,版本太新可能没有配套的tensorflow或torch。 如果顺利,就成功创建了一个environment,名字叫py3.7-gpu。创建的过程中可以在命令行看到从哪下载的,如果是正常清华...

    0e79aeaff7b2a6c73eb6aa91f790b709.png

    最近在做一些深度学习的项目,需要配置gpu环境,这里把遇到的一些坑和解决方法记录下来,供大家借鉴,同时也是以后自己需要的时候可以回头看看。

    关于pip安装和conda安装。简单来说pip也只是一个库,相当于一个安装工具。pip安装需要在cmd命令行中进行,方法为pip install +名字。但是利用pip安装网速极慢,是用的国外的channel,大概只有几kb/s,经常容易出现read time out的error。因此强烈建议使用conda install +名字。首先要把channel改为清华的镜像源,这样可以达到几mb/s的速度(之前因为版权问题关掉了一阵了,现在版权谈妥又开放了,这种有时效性的事情,网上就有坑让你删除这个镜像源,但现在不要删)。方法是在anaconda promote中base(root)打开terminal(还没安装anaconda的看下面图2那里先安装),进入命令行,输入以下:

    conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free 
    conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/main
    conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/pro
    conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/msps2

    如果需要安装最新的torch,再加入这个channel:

    conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/cloud/pytorch

    windows系统最后需要加上这个来生成.condarc的文件:

    conda config --set show_channel_urls yes

    需要注意的是一定要把Navigator界面中channels的default删掉,如图1。删完记得点update channels!!!

    7808df2c780a343d624f0eae21a9b1d7.png
    图1 删掉channels中default

    安装anaconda的话直接下载安装包就行,如图2。下载地址很多,实在找不到私信我发你。

    0e1e4cfdfd3221627cd574b535476346.png
    图2 anaconda安装包

    安装完记得添加环境变量,就算安装的时候点了自动添加也再看一下。如果没有,就手动添加:环境变量->系统变量->Path,如图3。具体取决于你安装在哪个盘C,D,E...没框的那几个好像是当时试坑加的。

    0cd1113ee9582e448af3b7a403a34f1f.png
    图3 环境变量

    接着创建自己的环境,不要用base(root)这个,比如我创建的py3.7-gpu。创建方法为:打开base(root)的terminal进入命令行,运行conda clean -i清除索引缓存,保证用的是清华镜像站提供的索引。这里备注一下,你在anaconda navigator中看到的packages都是根据你设置的channel提供的,比如说如果没有添加

    conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/cloud/pytorch

    那么搜索torchvision可能就没有结果,如图4。之前说pip坑也是因为我用pip安装的,pip list和conda list都有,但是anaconda navigator中没有,所以等于零。

    a9b13c8c04a3c8bda3aca5c291355d92.png
    图4 搜索torchvision

    运行完

    conda clean -i

    之后再运行

    conda create -n py3.7-gpu python=3.7

    就行,当然你也可以用3.6的版本如

    conda create -n py3.6-gpu python=3.6

    -n是name的缩写。我写这篇文章的时候刚出3.8但还是3.7 3.6靠谱一点,版本太新可能没有配套的tensorflow或torch。

    如果顺利,就成功创建了一个environment,名字叫py3.7-gpu。创建的过程中可以在命令行看到从哪下载的,如果是正常清华的镜像源几秒钟就创建好了。接下来就是给这个environment装各种package了,方法都是在这个environment的terminal下输入conda install +名字。比如说spyder,tensorflow-gpu等等,因为用了清华镜像源,每次都很快就安装好了。不需要再输入-c +channel了,这也是个坑,统一用清华的就行。另外说一下清华的网站不是用来手动下载package的,我一开始下了很多zip或者whl的包,其实并不需要,只要把网址写到channel里面,用conda install就行。

    如果需要安装gpu版的pytorch或tensorflow需要显卡是NVIDIA的,先看下自己显卡支持的cuda版本。方法如图5和图6,打开NVIDIA设置->帮助->系统信息->组件->3D设置。我的是1060的显卡,cuda版本是10.2。

    6de69603ee615618340e30862b504103.png
    图5 NVIDIA设置

    3b48ea79f9663a70a7302e97a4cf1eec.png
    图6 cuda版本

    接下来在命令行输入

    conda install pytorch torchvision cudatoolkit=10.1

    注意命令行一定要是在py3.7-gpu环境下的,如图7。我的显卡是cuda10.2的,因此只要是10.x都行。具体命令可以去pytorch官网看

    PyTorchpytorch.org
    d3fed708932cee5e88a57e0c38db07ca.png

    如图8,注意把最后那个-c pytorch去掉。

    2ad489be163a99f87ca5656de0757750.png
    图7 命令行前缀

    527b3e8a13d5c9490a733cfa53c4cc4f.png
    图8 pytorch配置

    全都安装好了可以在命令行查看是否成功,方法为:在命令行先输入

    python

    然后输入

    import torch

    最后输入

    print(torch.cuda.is_available())

    返回True就大功告成了。如果装的是tensorflow-gpu,就输入

    import tensorflow as tf 

    以及

    tf.test.gpu_device_name()

    返回

    /device:GPU:0

    就成功了。

    最后看一下用cpu和gpu跑程序速度的区别,如图9和图10所示。

    713eef439dc3134921432433b6da3273.png
    图9 CPU的速度

    418614dc8619c4470e92eb9ad1b8a849.png
    图10 GPU的速度

    以后有想到的再补充,侵删~

    展开全文
  • 更新了torch1.7.1对应的版本torch torchvision python master/nightly master/nightly >=3.6 1.7.1 0.8.2 >=3.6 1.7.0 0.8.1 >=3.6 1.7.0 0.8.0 >=3.6 ...

    更新了torch1.7.1对应的版本:

    torch torchvision python
    master / nightly master / nightly >=3.6
    1.7.1 0.8.2 >=3.6
    1.7.0 0.8.1 >=3.6
    1.7.0 0.8.0 >=3.6
    1.6.0 0.7.0 >=3.6
    1.5.1 0.6.1 >=3.5
    1.5.0 0.6.0 >=3.5
    1.4.0 0.5.0 ==2.7>=3.5<=3.8
    1.3.1 0.4.2 ==2.7>=3.5<=3.7
    1.3.0 0.4.1 ==2.7>=3.5<=3.7
    1.2.0 0.4.0 ==2.7>=3.5<=3.7
    1.1.0 0.3.0 ==2.7>=3.5<=3.7
    <=1.0.1 0.2.2 ==2.7>=3.5<=3.7

    命令:

    pip install torchvision

    在anaconda下:

    conda install torchvision -c pytorch

    下载地址:

    https://download.pytorch.org/whl/torch_stable.html

     

    展开全文
  • 下载最新版本torch 登录 https://pytorch.org/,移动至如图处,根据需要,选择对应的版本,OS:你的操作系统,Package:你的安装方式,Language:编程语言,CUDA:你的显卡的版本,如何查看请根据:...

    问题描述:

    在复现Github上论文代码时需要,安装与之对应的版本包,但有时候包的版本不对应,会导致代码无法运行。


    解决方案:

    1. 下载最新版本的torch
      登录 https://pytorch.org/,移动至如图处,根据需要,选择对应的版本,OS:你的操作系统,Package:你的安装方式,Language:编程语言,CUDA:你的显卡的版本,如何查看请根据:https://blog.csdn.net/qq_38295511/article/details/89223169。复制相关命令在命令行运行就可。
      在这里插入图片描述
    2. 下载以前版本的torch

    -方法2.1:登录https://pytorch.org/get-started/previous-versions/网址,根据所需要的版本号寻找相关系统命令。
    在这里插入图片描述
    自己摸索了一种方法如下,只需要更新版本号,即可通用下载对应自己本机的版本:

    pip install torch==1.5.0 torchvision==0.6.0 -f https://download.pytorch.org/whl/torch_stable.html
    

    -方法2.2:
    登陆网址https://download.pytorch.org/whl/torch_stable.html下载对应版本的torch包,在下载文件夹中打开cmd命令输入:
    在这里插入图片描述

    展开全文
  • 尝试运行...torch官网上最新版本torch支持的cuda最低版本为92,服务器上cuda版本为9.0,如果安装最新版的torch运行时会报错 The NVIDIA driver on your system is too...
  • 我目前用的是py3.6 和torch1.51 ,版本不一定要最新的,满足自己功能就行。 笔者一般喜欢用pip安装和管理包,这个是python自带的,安装时候会自动添加到系统的环境变量,如果没有自己手动添加环境变量就可以了,添加...
  • 版本不匹配的问题。完美解决方案如下: 目前torchvision最新版本是0.5,torch最新版本是1.5,使用命令。 pip install --no-deps torchvision==0.5.0
  • 安装torchvision出现ERROR: No matching distribution ...目前torchvision最新版本是0.5,torch最新版本是1.5 完美解决方案如下: 输入命令 pip install --no-deps torchvision==0.5.0 出现如下图片即安装成功! ...
  • torch1.0.0安装

    2018-12-08 17:59:06
    最新torch安装版本1.0.0,适合windows,python3.6,pip,none cuda安装轮子
  • 网上很多Torch/Torchvision安装教程但是大部分都不实用,根据我的安装经验先介绍之前安装所出现的...1、进入PyTorch官网,在首页选择安装版本 这里根据自己电脑的配置要求,选择操作系统、cpu/gpu等。一步安装的方法
  • pytorch指定版本安装及查看版本

    万次阅读 2019-03-14 09:51:31
    pytorch官网: ... pytoch使用conda安装(推荐): conda install pytorch ...注:上述版本为 cuda8.0(如果使用9.0或者10.0 更改相应参数即可),python版本没有影响,torch最新版本。 pytorch使用pip安装: p...
  • 本来我单独安装了torch,是最新版本,1.8.0,去官网找了一圈,找不到对应版本的torchversion,所以没办法安装。 于是在cmd命令行里使用命令: pip uninstall torch 卸载torch。 再使用命令: pip install torch=...
  • 显卡驱动:440.59(装最新的驱动的原因是支持最新的cuda10.2,可支持多种cuda) 显卡驱动:cuda10.2 tf:tensorflow-gpu:1.14 ,cuda:10.1,cudnn:7.6.5 torch:pytorch:1,5,torch:0.6,cuda:10.2,cudnn:7.6.5
  • 安装 torch1.0.0

    2020-11-06 18:38:22
    参考:安装最新pytorch1.0.0 打开cmd 切换到python编程环境(比如:activate pytorch) 下载相对应的whl,我下的是wins,python3.6版本的 下载完成后,将该whl文件放在python相同的目录下即可 (比如cd D:\...
  • 最全的卷积神经网络实现手写数字识别,由于版本的更新,好多函数被替代或简化,本文是根据最新版本的GPU11.0的pytorch撰写的卷积神经网络实现手写数字识别。欢迎大家借鉴。 import torch import torch.nn as nn ...
  • 今日,由于电脑重装系统了,我也只能重新配置pytorch环境。 环境配置一如既往地顺利,但是在运行的时候出现了问题: ... File "D:\Anaconda\lib\site-packages\torch\__init__.py", line 190, in <module>
  • 神经网络学习小记录48——windows下的torch=1.2.0环境...最新版本的Anaconda没有VSCODE,如果大家为了安装VSCODE方便可以直接安装旧版的Anaconda,百度网盘连接如下。也可以装新版然后分开装VSCODE。 链接: https://pan
  • 确保已安装最新版本的.NET和.NET Framework。 如果您正在使用Torch.SpaceEngineers,则在加载解决方案之前,需要运行setup.bat并按照说明将游戏DLL链接到解决方案。 如果您不使用Torch.SpaceEnginers,则只需卸载...
  • 如何安装torch 1.5.0+cpu和torchvision 0.6.0+cpu

    千次阅读 多人点赞 2020-05-27 20:33:53
    可以看出,torch最新版本为1.5.0,torchvision的最新版本为0.6.0. 鉴于pip和conda安装较慢,我们选择下载.whl文件半自动安装方式。从.whl下载地址中下载两个压缩文件,其中cpxx为python的版本(我的python是3.7.4...
  • python -m pip install --upgrade torch torchvision -i https://pypi.tuna.tsinghua.edu.cn/simple
  • 解决方法:(我自己这么做的,仅参考) ...在cmd里面输入命令下载最新1.1.0版本的pytorch(注意,没有安装cuda就选None) 3.https://pytorch-geometric.readthedocs.io/en/latest/notes/installation...
  • 没有安装最新的CUDA版本 PyTorch升级版本的时候,请注意下是否CUDA版本也升级了。 比如1.2的时候用的是CUDA 10.0,但是1.3的时候已经要求是CUDA 10.1了。如果没有安装CDUA 10.1,就会出现上面的错误。 python script...
  • windows下的torch=1.2.0环境配置

    千次阅读 2020-08-20 11:39:30
    神经网络学习小记录48——windows下的torch=1.2.0环境配置 ...最新版本的Anaconda没有VSCODE,如果大家为了安装VSCODE方便可以直接安装旧版的Anaconda,百度网盘连接如下。也可以装新版然后分开装VSCO.
  • 我的torch版本是 >>> import torch >>> torch.__version__ ...这是因为torch1.8.1是最新版很多接口发生了变化下载旧版本可以解决这个问题。 pip install torch==1.1.0 torchvision==0.3.0 -f
  • 安装了pytorch最新版本1.6之后,在pycharm中编辑python代码时,输入torch.nn.看不到提示了,比如torch.nn.MSELoss()。而在1.4及以前的版本中,直接输入torch.nn.就会自动提示出很多torch.nn.modules中的API。 该问题...
  • 近年CVPR会议上大部分文章... 其中,常用框架包含Caffe 1,TensorFlow,Torch/PyTorch,详见Deep-Learning-in-OpenCV包含了经典的AlexNet,GoogleNet等常用网络的模型。具体查看Opencv新特性下载地址:包含了常用平台的安
  • 2、conda install pytorch=1.4 pytorch官网的指令安装的是最新版本,不适配!!!后面会安装不上torch-geometric库 3、两种方法:(我是使用方法二成功的) 使用官方文档里的方法无脑依次进行检查并安装torch-...
  • 使用最新版本的pytorch,(torch版本1.3.1,torchvision版本0.4.2。) conda install pytorch torchvision cudatoolkit=10.1 -c pytorch 从https://github.com/xingyizhou/CenterNet运行 demo.py, 出现 ...

空空如也

空空如也

1 2 3 4 5 ... 8
收藏数 155
精华内容 62
关键字:

torch最新版本