精华内容
下载资源
问答
  • Trunk口配置实验

    千次阅读 2020-04-12 20:32:57
    最近在初学网格配置,采用华为的ENSP平台来进行网络搭建仿真实验。第一个实验就是搭建一个简单的网络来进行实现同一局域网下不同VLAN间的通信,如图蓝色表示VLAN:5,绿色VLAN:9,他们旗下的主机是不能互相ping通的...

    最近在初学网格配置,采用华为的ENSP平台来进行网络搭建仿真实验。第一个实验就是搭建一个简单的网络来进行实现同一局域网下不同VLAN间的通信,如图蓝色表示VLAN:5,绿色VLAN:9,他们旗下的主机是不能互相ping通的。比如192.168.1.2可以ping通192.168.1.3但是不能ping通192.168.1.4,即使他们处于同一路由器下。

    以下知识点:

    vlan端口类型:
    Access链路类型端口:
    1.只允许缺省VLAN通过,仅接收和发送一个VLAN的数据帧
    2.一般用于连接用户设备
    Trunk链路类型端口:
    1.允许多个VLAN通过,可以接收和发送多个VLAN的数据帧
    2.缺省VLAN的以太网不带标签
    3.一般用于交换机之间连接
    Hybrid链路类型端口:
    1.允许多个VLAN通过,可以接收和发送多个VLAN的数据帧
    2.Hybrid端口和Trunk端口的不同之处:
            ①Hybrid端口允许多个VLAN的以太网帧不带标签
            ②Trunk端口只允许缺省VLAN的以太网帧不带标签

    心得:

    1.PC机和路由器之间的端口一般配置的VLAN类型为access,路由器之间相连的端口为trunk

    2.端口配置命令:port link-type xxx(access/trunk/hybrid)

    3.在端口配置之前要先新建VLAN号,命令:“VLAN batch xx”如果vlan是连续的可以写成“VLAN batch xxto xx”但是中间间隔单位不是很明白为多少。测试之后间隔单位应该为1

    4.华为ENSP命令不区分大小写

    5.端口配置VLAN且VLAN类型为acces时命令“port default VLAN xx(具体的VLAN号) ”

    6.端口配置为trunk口后,还要在端口写上命令“port trunk allow-pass xx xx xx xx ”来允许多个VLAN通过

    展开全文
  • 交换机access和trunk口配置及应用

    千次阅读 2019-09-27 08:56:39
    交换机access和trunk口的配置 以下拓扑模拟一家公司同部门之间通过不同交换机接入,...交换机Access口和Trunk口配置 S1sys (进入系统视图)sysname S1 (重命名交换机)vlan batch 10 20 (同时创建多vlan)int e...

    交换机access和trunk口的配置

    以下拓扑模拟一家公司同部门之间通过不同交换机接入,实现同部门可以互访不同部门之间隔离。

    通过加入不同vlan,配置交换机接口实现,三台交换机配置如下。

     

    交换机Access口和Trunk口配置

    S1
    sys  (进入系统视图)
    sysname S1  (重命名交换机)
    vlan batch 10 20   (同时创建多vlan)
    int e0/0/2     (进入接口视图)
    port link-type access  (更改接口类型为access,下联PC)
    port default vlan 10    (配置接口所属vlan)

    int e0/0/3    (进入接口视图)
    port link-type access  (更改接口类型为access下联PC)
    port default vlan 20    (配置接口所属vlan)

    int e0/0/1   (进入接口视图)
    port link-type trunk    (更改接口类型为trunk,上联交换机)
    port trunk allow-pass vlan 10 20   (配置trunk口允许通过vlan,允许所有vlan通过命令:port trunk allow-pass vlan all)

    S2
    sys  (进入系统视图)
    sysname S2  (重命名交换机)
    int e0/0/2   (进入接口视图)
    port link-type access  (更改接口类型access,下联PC)
    port default vlan 10    (配置接口所属vlan)

    int e0/0/3   (进入接口视图)
    port link-type access  (更改接口类型access,下联PC)
    port default vlan 20   (更改接口所属vlan)

    int e0/0/1  (进入接口视图)
    port link-type trunk  (更改接口类型为trunk,上联交换机)
    port trunk allow-pass vlan 10 20 (配置trunk口可通过vlan)

    S3
    sys   (进入系统视图)
    sysname S3    (重命名交换机)
    vlan batch 10 20    (同时创建多vlan)
    int g0/0/1    (进入接口视图)
    port link-type trunk   (更改接口类型为trunk,下联接入交换机)
    port trunk allow-pass vlan 10 20  (配置trunk口允许通过vlan)

    int g0/0/2   (进入接口视图)
    port link-type trunk    (更改接口类型为trunk,下联接入交换机)
    port trunk allow-pass vlan 10 20   (配置trunk口允许通过vlan)

    转载于:https://www.cnblogs.com/Ro-Sw/articles/10616484.html

    展开全文
  • 交换机Trunk端口配置,功能需求及组网说明,配置环境参数,数据配置步骤,配置命令代码,利用将端口配置Trunk端口来完成在不同交换机之间透传VLAN,达到属于相同VLAN的PC机,跨交换机进行二层访问;或者不同VLAN的...
  • Unifi Switch新发布了交换机,那么很多网友想知道Unifi Switch交换机怎么配置vlan及trunk口?下面就为大家介绍下Unifi Switch交换机配置vlan及trunk口的方法,仅供参考
  • Trunk端口的配置

    万次阅读 2019-03-27 09:37:51
    以太网通常由多台交换机组成,需要在交换机之间互连的链路上配置为干道链路(Trunk Link)。和接入的链路不同,干道链路是用来在不同的设备之间(例如:交换机与交换机之间、交换机与路由器之间)承载多个不同VLAN...

    原理简述:

    在以太网中,通过划分VLAN来隔离广播域和增强网络通信的安全性。以太网通常由多台交换机组成,需要在交换机之间互连的链路上配置为干道链路(Trunk Link)。和接入的链路不同,干道链路是用来在不同的设备之间(例如:交换机与交换机之间、交换机与路由器之间)承载多个不同VLAN数据的,它不属于任何一个具体的VLAN ,可以承载所有的VLAN数据,也可以配置为只能传输指定VLAN的数据。

    Trunk端口一般用于交换机之间连接的端口,可以接收和发送多个VLAN的报文。

    当Trunk端口收到数据帧时,如果该帧不包含802.1Q的VLAN标签,将打上Trunk端口的PVID;如包含,则不改变。

    当Trunk端口发送数据帧时,当发送的数据帧的VLAN ID与端口的PVID不同时,检查其是否允许该VLAN通过,若允许的情况下,将其直接透传;不允许的情况下,直接丢弃。当该帧的VLAN ID与端口的PVID相同时,则剥离VLAN标签再转发。

    实验内容:

    保证在不同交换机下相同的部门之间能互相通信,需要配置交换机之间的链路为干道模式,实现相同VLAN跨交换机通信。

    实验目的:

    1.理解干道模式的应用场景;

    2.掌握Trunk端口的配置;

    3.掌握Trunk端口允许所有VLAN通过的配置;

    4.掌握Trunk端口允许特定VLAN通过的配置。

    实验拓扑:

    配置过程:

    1.根据实验要求,完成基础配置,实现在VLAN未划分前,各PC间可以互相通信。

    2.创建VLAN,配置Access接口:

    在S2和S3上,需要通过VLAN的划分隔离不同的部门。

    [S2]vlan batch 10 20
    [S2]vlan 10
    [S2-vlan10]description yanfa
    [S2-vlan10]vlan 20
    [S2-vlan20]description shichang
    .....

    配置完成后,可使用display vlan命令查看VLAN的信息。

    [S2]dis vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/1(U)     Eth0/0/2(U)     Eth0/0/3(U)     Eth0/0/4(D)     
                    Eth0/0/5(D)     Eth0/0/6(D)     Eth0/0/7(D)     Eth0/0/8(D)     
                    Eth0/0/9(D)     Eth0/0/10(D)    Eth0/0/11(D)    Eth0/0/12(D)    
                    Eth0/0/13(D)    Eth0/0/14(D)    Eth0/0/15(D)    Eth0/0/16(D)    
                    Eth0/0/17(D)    Eth0/0/18(D)    Eth0/0/19(D)    Eth0/0/20(D)    
                    Eth0/0/21(D)    Eth0/0/22(D)    GE0/0/1(D)      GE0/0/2(D)      
    
    10   common  
    20   common  
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    10   enable  default       enable  disable    yanfa       //以配置好相关的VLAN                  
    20   enable  default       enable  disable    shichang    

    或使用display vlan summary命令查看所配置的VLAN的简要信息。

    [S2]dis vlan summary 
    static vlan:
    Total 3 static vlan.  //配置完好
      1 10 20      
    
    dynamic vlan:
    Total 0 dynamic vlan.
    
    reserved vlan:
    Total 0 reserved vlan.
    

    在交换机上划分接口到相应的VLAN内。

    [S2-Ethernet0/0/2]port link-type access 
    [S2-Ethernet0/0/2]port default vlan 10
    
    [S2-Ethernet0/0/3]port link-type access 
    [S2-Ethernet0/0/3]port default vlan 20
    。。。。。。
    S3交换机配置方法相同。
    

    划分后使用display port vlan命令检查VLAN和接口的配置情况。

    [S2]dis po v
    Port                    Link Type    PVID  Trunk VLAN List
    -------------------------------------------------------------------------------
    Ethernet0/0/1           hybrid       1     -                                   
    Ethernet0/0/2           access       10    -          //已划分到相应的VLAN 内                         
    Ethernet0/0/3           access       20    -                                   
    Ethernet0/0/4           hybrid       1     -                                   
    Ethernet0/0/5           hybrid       1     -                                   
    Ethernet0/0/6           hybrid       1     -                                   
    Ethernet0/0/7           hybrid       1     -                                   
    Ethernet0/0/8           hybrid       1     -  
    ......

    在成功划分到相应VLAN后,测试相同部门中的PC的通信状态。

    PC>ping 10.1.1.3      //不能互通
    Ping 10.1.1.3: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    
    --- 10.1.1.3 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    

    3.配置Trunk接口:

    以上的操作是该跨交换机实现相同VLAN通信的二层组网拓扑中,虽然与PC端相连的交换机接口都划分到了相应的VLAN,但是在交换机与交换机之间相连的接口上并没有相应的VLAN信息,不能识别和发送跨越交换机的VLAN报文。此时的VLAN在每台交换机上只具有本地意义,而无法实现相同VLAN的跨交换机通信。

    现需要在交换机之间相连的接口配置为Trunk接口,而且配置的时候需要明确的指出被允许通过的VLAN,实现对VLAN流量传输的控制。

    [S1]int g0/0/1
    [S1-GigabitEthernet0/0/1]port link-type trunk    //配置Trunk模式
    [S1-GigabitEthernet0/0/1]port trunk allow-pass  vlan all   //允许所有VLAN通过
    。。。。。。。
    
    
    [S2]int e0/0/1	
    [S2-Ethernet0/0/1]port link-type trunk 	
    [S2-Ethernet0/0/1]port trunk allow-pass vlan 10 20   //允许VLAN 10、VLAN 20通过

    在交换机之间其他的接口上配置相同。

    可使用display port vlan命令检查Trunk的配置情况。

    [S1]dis port vlan
    Port                    Link Type    PVID  Trunk VLAN List
    -------------------------------------------------------------------------------
    GigabitEthernet0/0/1    trunk        1     1-4094   //配置完善
    GigabitEthernet0/0/2    trunk        1     1-4094
    GigabitEthernet0/0/3    hybrid       1     -                                   
    GigabitEthernet0/0/4    hybrid       1     -                                   
    GigabitEthernet0/0/5    hybrid       1     -                                   
    GigabitEthernet0/0/6    hybrid       1     -                                   
    GigabitEthernet0/0/7    hybrid       1     -           
    ......

    完成所有的配置后再次测试PC间的连通性。

    PC>ping 10.1.1.3
    
    Ping 10.1.1.3: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.3: bytes=32 seq=1 ttl=128 time=94 ms
    From 10.1.1.3: bytes=32 seq=2 ttl=128 time=63 ms
    From 10.1.1.3: bytes=32 seq=3 ttl=128 time=109 ms
    From 10.1.1.3: bytes=32 seq=4 ttl=128 time=78 ms
    From 10.1.1.3: bytes=32 seq=5 ttl=128 time=63 ms
    
    --- 10.1.1.3 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 63/81/109 ms
    //可以实现相同部门之间的通信

    注:在华为S系列交换机上,当Trunk端口收到带有vlan Tag的数据帧,但本机没有创建与该vlan tag数据帧中所携带的vlan id一致的vlan时,会对数据帧做丢弃处理。

     

    展开全文
  • 配置Trunk接口

    千次阅读 2020-11-23 15:10:44
    首先先配置IP地址 S4 vlan 10 //创建vlan10 vlan 20 //创建vlan20 inte eth0/0/2 //进入接口 port link-type access //接口模式为接入 port default vlan 10 //加入vlan10 inte eth0/0/3 //进入接口 port link-...

    首先先配置IP地址
    在这里插入图片描述
    S4

    vlan 10 //创建vlan10
    vlan 20 //创建vlan20
    inte eth0/0/2 //进入接口
    port link-type access //接口模式为接入
    port default vlan 10 //加入vlan10
    inte eth0/0/3 //进入接口

    port link-type access //接口模式为接入
    port default vlan 20 //加入vlan20
    inte eth0/0/1 //进入接口
    port link-type trunk //接口模式为干道
    port trunk allow-pass vlan 10 20 //允许vlan通过
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    S5

    vlan 10 //创建vlan10
    vlan 20 //创建vlan20
    inte eth0/0/2 //进入接口
    port link-type access //接口模式为接入
    port default vlan 10 //加入vlan10
    inte eth0/0/3 //进入接口

    port link-type access //接口模式为接入
    port default vlan 20 //加入vlan20
    inte eth0/0/1 //进入接口
    port link-type trunk //接口模式为干道
    port trunk allow-pass vlan 10 20 //允许vlan通过
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    S3

    vlan 10 //创建vlan10
    vlan 20 //创建vlan20
    inte eth0/0/1 //进入接口
    port trunk allow-pass vlan all //允许vlan通过*
    inte eth0/0/2 //进入接口
    port link-type trunk //接口模式为干道
    port trunk allow-pass vlan 10 20 //允许vlan通过
    在这里插入图片描述
    在这里插入图片描述

    配置完成

    展开全文
  • Vlan中Trunk接口配置

    千次阅读 2018-12-31 16:35:03
    Vlan中Trunk接口配置 参考文献:HCNA网络技术实验指南 模拟器:eNSP 实验环境: 实验目的:掌握Trunk端口配置 掌握Trunk端口允许所有Vlan配置方法 掌握Trunk端口允许特定Vlan配置方法 实验拓扑: 实验IP地址 : ...
  • 1.SwitchA与SwitchB用trunk互连,相同VLAN的PC之间可以互访,不同VLAN的PC之间禁止互访; 2.PC1与PC2之间在不同VLAN,通过设置上层三层交换机SwitchB的VLAN接口10的IP地址为10.1.1.254/24,VLAN接口20的IP地址为...
  • centos 7 下双网卡bond 与 trunk口的交换机通信 做这个首先要明白什么是trunk口 trunk 是实现不同网络设备的不同Vlan之间的通信 注意: 网卡也属于网络设备,设置vlan后也可以通信 先说下我的环境 网络工程师在两台...
  • TRUNK 的介绍和配置

    万次阅读 多人点赞 2019-08-16 18:20:28
    一、 TRUNK 的背景 : 如果交换机与交换机之间存在多条链路,交换机每增加一个vlan,交换机与交换机就会增加一条链路。这样会存在链路浪费,就产生了 DTP ( dynamic trunk protocols) 采用trunk后,所有的vlan都...
  • trunk中删除某个vlan Switch1(config)#interface fa0/24 Switch1(config-if)#switchport trunk allowed vlan remove 10 Switch1#show running-config 查看fa0/24接口的trunk配置 测试同一vlan机器的连通性 5....
  • 华为 Eth-trunk 配置IP

    千次阅读 2021-10-23 00:02:15
    华为Eth-trunk可以用于三层 通过对Eth-trunk配置实现路由器的提高带宽,负载均衡。 三层Eth-trunk案例: R1配置: <Huawei>system-view ##进入系统视图 [Huawei]sysname R1 ##重命名 [R1]interface ...
  • vlan trunk

    2015-02-10 16:56:07
    在两台交换机上创建vlan10及20 将连接PC的接口划入如图所示的vlan 配置SW1-SW2之间的链路为trunk,使得两台交换机的vlan10内的用户能够互相通信、vlan20内的用户能够互相通信。
  • 华为交换机配置trunk接口

    万次阅读 2020-02-11 18:37:12
    配置Trunk接口 trunk端口一般用于交换机之间连接的端口,trunk端口可以属于多个vlan,可以接受发发送多个vlan的报文。 本次的实验如下图: 模拟两天办公区怎么互信通信,切互不影响,PC1与PC3是同网段,PC2与PC4是...
  • HUAWEI设备如何配置Trunk ①进入对应接口配置接口类型 [SW1]interface e0/0/1 [SW1-Ethernet0/0/1]port link-type trunk 注意:如果这一步错了,需要一层一层的来删除配置,直到恢复到默认的配置,参考代码如下 ...
  • 配置vlan与Trunk配置命令教程

    千次阅读 2020-02-12 09:00:38
    配置vlan与Trunk配置命令如下 条件:1)两台s3700交换机 2)pc机4台 3)创建vlan 10 20 =========================================================== SW1配置: int e0/0/1: <Huawei>system-view ...
  • 华为交换机VLAN与Trunk配置

    万次阅读 2019-04-30 12:50:19
    通过eNSP新建如下网络拓扑1、 配置第一台交换机sw1<Huawei>undo ter moniter //关闭信息干扰<Huawei>system-view //进入系统视图[Huawei]sysname sw1 //修改交换机名字为sw1[sw1]vlan batch 5 10 //创建...
  • 华为路由器Eth-Trunk接口配置实例

    千次阅读 2017-11-02 15:43:43
    路由器可以对多个以太网接口捆绑形成一个Eth-Trunk逻辑接口,Eth-Trunk接口的主要目的是增大带宽和提高设备之间链路的可靠性。Eth-Trunk接口可以工作在二层模式或三层模式。二层模式的Eth-Trunk接口类似交互机的接口...
  • 交换机VLAN与Trunk配置

    千次阅读 2019-04-30 23:13:59
    交换机VLAN与Trunk配置 1 首先配置交换机SW1先创建vlan5与10,把与PC1相连的1端口配置为access模式,并把端口加入到vlan5把与PC2相连的2端口配置为access模式,并把端口加入到vlan10把与SW2相连的3端口配置trunk...
  • 华为交换机怎么配置Trunk接口实现通信?交换机不配置Trunk接口VLAN之间的数据是不能互通的,Trunk接口能收到所有VLAN的广播包信息,但是怎么配置Trunk接口?请看下文详细介绍
  • 【CCNA】cisco交换机配置trunk

    万次阅读 2018-08-14 11:57:22
    1、需求 2、本实验说明: ...b、经过trunk口的数据包会封装新的包头,里面会记录对应的vlan信息,对方接收到了该包,即可解包查看对应vlan,然后丢给对应的vlan去。 c、封装和解包都需要有对应的协议,...
  • 第二种方法:全局配置配置VLAN: Switch(config)#vlan 3 Switch(config-vlan)#name xingzheng 查看已经创建的VLAN: Switch#show vlan b 或者查看某个VLAN时: Switch#sh vl id 2** 删除VLAN: Switch...
  • 网络配置 接口/区域 名称:eth2 类型:透明 所属区域:wan ...配置Vlan管理(管理AF) 网络配置 --> 接口区域 Vlan接口 --> 新建vlan接口 接口名称:veth10 所属区域:vlan 基本属性:允许p...
  • 在技术领域中把TRUNK翻译为中文是“主干、干线、中继线、长途线” ,不过一般不翻译,直接用原文。  在网络的分层结构和宽带的合理分配方面,TRUNK被解释为“端口汇聚”,是带宽扩展和链路备份的一个重要途径。...
  • 实验|trunk配置

    2019-10-20 14:46:34
    前言:在路由/交换领域,VLAN的中继端口叫做trunktrunk技术用在交换机之间互连,使不同VLAN通过共享链路与其它交换机中的相同VLAN通信。交换机之间互连的端口就称为trunk端口。trunk是基于OSI第二层数据链路层...
  • 华三模拟器--交换机配置TRUNK口

    千次阅读 2019-03-15 08:37:59
    打开HCL并搭建好拓扑图...华三模拟器--交换机配置TRUNK口华三模拟器--交换机配置TRUNK口回到HCL双击交换机,进入用户界面。试用system-view进入系统界面。创建VLAN 10(添加端口时一切信息以设备为基准),使用disp...
  • 华为ENSP VLAN Trunk接口配置实验

    千次阅读 多人点赞 2021-02-07 12:09:29
    所以无法通信** 7: 在S1连接S3的接口上配置Trunk接口类型,并允许VLAN 10 20的通过 在S2连接S3的接口上配置Trunk接口类型,并允许VLAN 10 20的通过 在S3连接S1和S2的接口上配置Trunk接口类型,并允许所有VLAN...
  • 3.2配置trunk接口

    2021-03-19 16:05:43
    配置trunk接口原理概述一、实验目的及编址二、实验拓扑二、实验内容配置双工模式1....对于接收: 当trunk口接收到不一个带tag的vlan帧会给该帧打上该接口pvid一致的tag。如果该tag在允许通过的vlan list中就接收
  • centos7 配置vlan trunk口

    千次阅读 2018-03-21 14:38:34
    centos7 配置vlancentos7在网上找到的方法都是使用vconfig去配置,但偏偏centos7没有vconfig这个包,用yum安装也搜不到这个包,如果用centos6的包又太过麻烦,现提供已下配置方法注:此方法通过安装centos7时,配置...
  • 交换机Access和Trunk配置与删除!

    千次阅读 多人点赞 2021-03-19 14:44:47
    配置Access链路 [Huawei]int g0/0/1 //进入接口 [Huawei-GigabitEthernet0/0/1]port link-type access //配置access链路 [Huawei-GigabitEthernet0/0/1]port default vlan 10 //允许VLAN10通过 [Huawei-...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 8,593
精华内容 3,437
关键字:

trunk口配置