精华内容
下载资源
问答
  • Access接口、Trunk接口工作原理分析
  • 华为交换机怎么配置Trunk接口实现通信?交换机不配置置Trunk接口VLAN之间的数据是不能互通的,Trunk接口能收到所有VLAN的广播包信息,但是怎么配置Trunk接口?请看下文详细介绍
  • 综合运用VLAN创建、Access和Trunk接口配置、VLAN间路由配置,以及动态路由配置
  • 用Eth-Trunk接口做心跳口别忘记配这条命令
  • 华为ENSP VLAN Trunk接口配置实验

    千次阅读 多人点赞 2021-02-07 12:09:29
    所以无法通信** 7: 在S1连接S3的接口上配置成Trunk接口类型,并允许VLAN 10 20的通过 在S2连接S3的接口上配置成Trunk接口类型,并允许VLAN 10 20的通过 在S3连接S1和S2的接口上配置成Trunk接口类型,并允许所有VLAN...

    原理概述

    早期的局域网是基于总线型拓扑的。总线型拓扑是由一根单电缆连接着所有主机,这种局域网技术存在冲突域问题,所有用户都在一个冲突域里,那么同一时间内只有一台主机能发送信息,从任意设备发出的消息都会被其他主机接收到,用户可能收到一大堆不需要的报文,无法控制信息的安全。
    为了避免冲突域,同时可以拓展更多的计算机,可以在局域网使用二层交换机。交换机可以有效隔离冲突域,但是所有计算机都在同一个广播域,都能接收到所有报文。广播域和信息安全问题仍然存在,这才诞生了VLAN,可以将物理的LAN划分为多个广播域。这样,广播报文就被限制在一个VLAN里,VLAN 因此得名虚拟局域网。

    三种接口

    本次实验用的是Trunk接口类型,该端口一般用于交换机之间连接的端口,可以接受和发送多个VLAN的报文。
    当Trunk端口接收到数据帧时,如果该帧不包含802.1Q的VLAN 标签,将打上该Trunk端口的PVID,如果该帧包含802.1Q的VLAN标签,则不改变。
    当Trunk端口发送数据帧时,当该所发送帧的VLAN ID与端口的PVID不同时,检查是否允许该VLAN通过,若允许的话就直接透传,不允许就直接丢弃,当该帧的VLAN ID 与端口的PVID 相同时,则剥离 VLAN 标签后转发。

    实验拓扑

    在这里插入图片描述

    实验步骤

    1:配置IP略
    2:检测各主机连通性略(命令ping)
    3:在S1,S2上分别创建VLAN 10 20

    [S1]vlan 10
    [S1-vlan10]vlan 20
    [S2]vlan 10
    [S2-vlan10]vlan 20
    

    4:检查一下VLAN的配置(这里只发出S1的配置,S2同上)

    [S1]display vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/1(U)     Eth0/0/2(U)     Eth0/0/3(U)     Eth0/0/4(D)     
                    Eth0/0/5(D)     Eth0/0/6(D)     Eth0/0/7(D)     Eth0/0/8(D)     
                    Eth0/0/9(D)     Eth0/0/10(D)    Eth0/0/11(D)    Eth0/0/12(D)    
                    Eth0/0/13(D)    Eth0/0/14(D)    Eth0/0/15(D)    Eth0/0/16(D)    
                    Eth0/0/17(D)    Eth0/0/18(D)    Eth0/0/19(D)    Eth0/0/20(D)    
                    Eth0/0/21(D)    Eth0/0/22(D)    GE0/0/1(D)      GE0/0/2(D)      
    
    10   common    ·可以看到创建成功·
    20   common    
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    10   enable  default       enable  disable    VLAN 0010  ·这里也没有问题·                       
    20   enable  default       enable  disable    VLAN 0020           
    

    在S1上配置连接主机的接口为Access接口,并划分相应VLAN
    在S2上配置连接主机的接口为Access接口,并划分相应VLAN

    [S1]interface Ethernet 0/0/2
    [S1-Ethernet0/0/2]port link-type access 
    [S1-Ethernet0/0/2]port default vlan 10
    [S1-Ethernet0/0/2]quit           
    [S1]interface Ethernet 0/0/3
    [S1-Ethernet0/0/3]port link-type access 
    [S1-Ethernet0/0/3]port default vlan 20
    [S1-Ethernet0/0/3]quit
    
    [S2]interface Ethernet 0/0/2
    [S2-Ethernet0/0/2]port link-type access 
    [S2-Ethernet0/0/2]port default vlan 10
    [S2-Ethernet0/0/2]quit
    [S2]interface Ethernet 0/0/3
    [S2-Ethernet0/0/3]port link-type access 
    [S2-Ethernet0/0/3]port default vlan 20
    

    5:再次查看VLAN的配置 (S2同上,这里不再展示)

    [S1]display vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/1(U)     Eth0/0/4(D)     Eth0/0/5(D)     Eth0/0/6(D)     
                    Eth0/0/7(D)     Eth0/0/8(D)     Eth0/0/9(D)     Eth0/0/10(D)    
                    Eth0/0/11(D)    Eth0/0/12(D)    Eth0/0/13(D)    Eth0/0/14(D)    
                    Eth0/0/15(D)    Eth0/0/16(D)    Eth0/0/17(D)    Eth0/0/18(D)    
                    Eth0/0/19(D)    Eth0/0/20(D)    Eth0/0/21(D)    Eth0/0/22(D)    
                    GE0/0/1(D)      GE0/0/2(D)                                      
    
    10   common  UT:Eth0/0/2(U)    ·配置没有问题·                                                   
    
    20   common  UT:Eth0/0/3(U)    ·配置没有问题·                                                 
    
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    10   enable  default       enable  disable    VLAN 0010                         
    20   enable  default       enable  disable    VLAN 0020       
    

    6:此时用PC-1 ping PC-3 无法连接

    PC>ping 10.1.1.3
    
    Ping 10.1.1.3: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    
    --- 10.1.1.3 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    **因为交换机之间的端口没有相应的VLAN信息,所以无法通信**
    

    7:
    在S1连接S3的接口上配置成Trunk接口类型,并允许VLAN 10 20的通过
    在S2连接S3的接口上配置成Trunk接口类型,并允许VLAN 10 20的通过
    在S3连接S1和S2的接口上配置成Trunk接口类型,并允许所有VLAN的通过

    [S1]interface Ethernet 0/0/1
    [S1-Ethernet0/0/1]port link-type trunk 
    [S1-Ethernet0/0/1]port trunk allow-pass vlan 10 20
    
    [S2]interface Ethernet 0/0/1
    [S2-Ethernet0/0/1]port link-type trunk 
    [S2-Ethernet0/0/1]port trunk allow-pass vlan 10 20
    
    [S3]vlan 10
    [S3-vlan10]vlan 20
    [S3-vlan20]quit
    [S3]interface GigabitEthernet 0/0/1
    [S3-GigabitEthernet0/0/1]port link-type trunk 
    [S3-GigabitEthernet0/0/1]port trunk allow-pass vlan all 
    [S3-GigabitEthernet0/0/1]quit
    [S3]interface GigabitEthernet 0/0/2
    [S3-GigabitEthernet0/0/2]port link-type trunk 
    [S3-GigabitEthernet0/0/2]port trunk allow-pass vlan all 
    

    8:查看Trunk配置情况,这里以S3为例

    [S3]display port vlan 
    Port                    Link Type    PVID  Trunk VLAN List
    -------------------------------------------------------------------------------
    GigabitEthernet0/0/1    trunk        1     1-4094   ·配置没问题·
    GigabitEthernet0/0/2    trunk        1     1-4094
    

    9:检测连通性
    PC-1 - PC-3 可以连通 同vlan
    PC-1 - PC-2 不能连通 不同vlan
    其他的不做演示

    PC>ping 10.1.1.3
    
    Ping 10.1.1.3: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.3: bytes=32 seq=1 ttl=128 time=140 ms
    From 10.1.1.3: bytes=32 seq=2 ttl=128 time=94 ms
    From 10.1.1.3: bytes=32 seq=3 ttl=128 time=93 ms
    From 10.1.1.3: bytes=32 seq=4 ttl=128 time=109 ms
    From 10.1.1.3: bytes=32 seq=5 ttl=128 time=94 ms
    
    --- 10.1.1.3 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 93/106/140 ms
    
    PC>ping 10.1.1.2
    
    Ping 10.1.1.2: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    
    --- 10.1.1.2 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    

    新人博主,资历有限,如果有哪些不足之处请不吝赐教。

    展开全文
  • 配置Trunk接口

    千次阅读 2020-11-23 15:10:44
    inte eth0/0/2 //进入接口 port link-type access //接口模式为接入 port default vlan 10 //加入vlan10 inte eth0/0/3 //进入接口 port link-type access //接口模式为接入 port default vlan 20 //加入vlan20 inte...

    首先先配置IP地址
    在这里插入图片描述
    S4

    vlan 10 //创建vlan10
    vlan 20 //创建vlan20
    inte eth0/0/2 //进入接口
    port link-type access //接口模式为接入
    port default vlan 10 //加入vlan10
    inte eth0/0/3 //进入接口

    port link-type access //接口模式为接入
    port default vlan 20 //加入vlan20
    inte eth0/0/1 //进入接口
    port link-type trunk //接口模式为干道
    port trunk allow-pass vlan 10 20 //允许vlan通过
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    S5

    vlan 10 //创建vlan10
    vlan 20 //创建vlan20
    inte eth0/0/2 //进入接口
    port link-type access //接口模式为接入
    port default vlan 10 //加入vlan10
    inte eth0/0/3 //进入接口

    port link-type access //接口模式为接入
    port default vlan 20 //加入vlan20
    inte eth0/0/1 //进入接口
    port link-type trunk //接口模式为干道
    port trunk allow-pass vlan 10 20 //允许vlan通过
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    S3

    vlan 10 //创建vlan10
    vlan 20 //创建vlan20
    inte eth0/0/1 //进入接口
    port trunk allow-pass vlan all //允许vlan通过*
    inte eth0/0/2 //进入接口
    port link-type trunk //接口模式为干道
    port trunk allow-pass vlan 10 20 //允许vlan通过
    在这里插入图片描述
    在这里插入图片描述

    配置完成

    展开全文
  • 我会出大约四篇文章介绍并且讲述这华为几个接口的使用以及原理 今天就通过一个简单的图为大家讲解trunk 首先trunk口是说如果链路上需要通过多条VLAN,所以我们选择了trunk 它一般用于干道链路(首先是交换机...

    我会出大约四篇文章介绍并且讲述这华为几个接口的使用以及原理

    今天就通过一个简单的图为大家讲解trunk

     

    首先trunk口是说如果链路上需要通过多条VLAN,所以我们选择了trunk

    它一般用于干道链路(首先是交换机与交换机(或路由器)连接的物理链路,这时候我们就需要给他打一个可以区分不同VLAN的标签(tag),这样就可以在一跳链路上承载较多的VLAN)

    trunk可以识别多个标签(可以识别多个vlan)但是并不脱标签就是放过带有这些标签的

    trunk传输的数据带有标签(在配置过程中你允许放过的所有数据都不做处理,带着标签放过)

    这边给大家展示下配置

     进入进口并且,配置为trunk并且进行放行

    注:这个时候必须要注意,此交换机上必须要有你所允许通过的VLAN,如果没有也是不放行的。

    vlan1 一般是允许通过的,你也可以使用如下命令提高你的网络安全性

     那么配置完后的样子就是

     今天就到这里了,拜拜~~~

    展开全文
  • 实验原理 以太网通常有多台交换机,为了使得vlan地数据帧跨越多台...trunk接到数据帧地时候:如果不包含802.1Q的标签,将打上该trunk端口的pvid,如果该接口包含802.1Q地标签,则不改变。 trunk端口发送数据地时候

    实验原理

    • 以太网通常有多台交换机,为了使得vlan地数据帧跨越多台交换机传递,交换机互联地链路需要配置为trunk链路,,干道链路是实现不同设备之间多个多个vlan数据地,他不属于任何一个vlan,可以承载所有地vlan数据,也可以配置之传输指定vlan数据。trunk通常用于交换机之间连接地端口,可以接受和发送多个vlan地报文

    • trunk接到数据帧地时候:如果不包含802.1Q的标签,将打上该trunk端口的pvid,如果该接口包含802.1Q地标签,则不改变。

    • trunk端口发送数据地时候,当该发送帧地vlanID和端口地pvid不同,检查是否允许vlan通过,允许的话直接透传,不允许地话直接丢弃。当该口的vlan id与端口的pvid相同的时候,则剥离vlan标签后转发。

    实验目的

    理解干道链路的应用场景
    掌握trunk端口的配置
    掌握trunk端口允许所有vlan通过的配置方法
    掌握trunk允许特定vlan通过的配置方法。

    实验拓扑

    在这里插入图片描述

    实验步骤

    • 1 基本配置,保证在没有话分vlan之前各pc是可以互通 的
      在这里插入图片描述
    • 2 创建vlan配置access接口 配置后,查看接口为
    • 在这里插入图片描述
    • 配置过程如下
    • 在这里插入图片描述
    • 给S1和S2的连接pc的接口配置access,并把他划分到相应的vlan内
    • 在这里插入图片描述
    • 使用 display port vlan查看vlan和接口配置情况
      在这里插入图片描述
      可以看出所有连接pc的接口都变成access模式.并且已经加入正确的vlan中在这里插入图片描述
      可以看出所有连接pc的接口都变成access模式.并且已经加入正确的vlan中
    • 3 配置trunk接口
      测试同一个vlan是否可以相互通信(不可以),虽然与pc相连的交换机端口巨有vlan信息,但是交换机与交换机之间的接口并没有相应的vlan信息.不能识别和发送跨越交换机的vlan报文.
      在这里插入图片描述
      在这里插入图片描述
    • 为了叫交换机间能够识别和发送跨域交换机的vlan报文,需要将交换机相连的接口配置为trunk接口,配置时需要明确可以被允许通过的vlan
    • 在s1的e0/0/1配置trunk接口,允许vlan10和vlan20通过
      在这里插入图片描述
      port link-type trunk port trunk allow-pass vlan 10 20
      在s2的e0/0/2接口配置trunk 允许vlan 10和20通过
      在s3的g0/0/1和g0/0/2接口配置trunk,允许所有的vlan通过port link-type trunk port trunk allow-pass vlan all
      在这里插入图片描述
      再次测试连通性,发现属于同一个vlan的pc可以通信
      在这里插入图片描述

    实验总结

    • 跨域交换的的属于同一个vlan的需要配置交换机之间的接口的类型为trunk,
    • 在这里插入图片描述
    展开全文
  • 交换机trunk接口

    千次阅读 2020-05-08 11:49:28
    以太网通常由多台交换机组成,为了使VLAN的数据帧跨越多台交换机传递,交换机之间互连的链路需要配置为干道链路(Trunk Link)。 干道链路是用在不同的设备之间(如交换机和路由器之间、交换机和交换机之间)承载多个...
  • 华为交换机配置trunk接口

    万次阅读 2020-02-11 18:37:12
    配置Trunk接口 trunk端口一般用于交换机之间连接的端口,trunk端口可以属于多个vlan,可以接受发发送多个vlan的报文。 本次的实验如下图: 模拟两天办公区怎么互信通信,切互不影响,PC1与PC3是同网段,PC2与PC4是...
  • Vlan中Trunk接口配置

    千次阅读 2018-12-31 16:35:03
    Vlan中Trunk接口配置 参考文献:HCNA网络技术实验指南 模拟器:eNSP 实验环境: 实验目的:掌握Trunk端口配置 掌握Trunk端口允许所有Vlan配置方法 掌握Trunk端口允许特定Vlan配置方法 实验拓扑: 实验IP地址 : ...
  • 试验拓扑 概述 通过划分vlan隔离广播域和增强网络安全性。以太网由多台交换机组成...Trunk端口一般用于交换机之间连接的接口,该帧包不包含802.1Q1的vlan标签,将打上该Trunk端口的PVID。 如果该帧包含802.1Q的标签,
  • (2)实现接入交换机和汇聚交换机的联通,配置trunk接口,允许vlan 10 20 通过. 各设备配置指令: s3700 [SW1]vlan batch 10 20 //创建vlan 10 20 port link-type access //接入交换机的下行端口口,配置acc..
  • 华为路由器Eth-Trunk接口配置实例

    千次阅读 2017-11-02 15:43:43
    路由器可以对多个以太网接口捆绑形成一个Eth-Trunk逻辑接口,Eth-Trunk接口的主要目的是增大带宽和提高设备之间链路的可靠性。Eth-Trunk接口可以工作在二层模式或三层模式。二层模式的Eth-Trunk接口类似交互机的接口...
  • 关于Eth-Trunk接口与IP-Trunk接口

    万次阅读 2015-09-11 19:23:55
    在以太网设备上,我们常用到诸如Eth-Trunk接口、IP-Trunk接口、POS接口等。 Eth-Trunk接口是一种可以动态创建的接口,该类型接口可以绑定若干物理的以太网接口作为一个逻辑接口使用。加入到Eth-Trunk接口的...
  • trunk接口中,如果vlanID和接口pvid相同,且在允许通过的vlanID列表中,则去掉tag,发送数据帧?直接发送不就行了,为什么还要先去掉tag呀?
  • 通过trunk接口类型实现不同vlan通信 通过以下拓扑图为例 PC配置 交换机SW1配置文件 # sysname SW1 # vlan batch 10 20 # cluster enable ntdp enable ndp enable # drop illegal-mac alarm # diffserv domain ...
  • 获取eth-trunk接口和物理成员接口对应关系,方法如下:节点名称节点含义节点OID节点类型所属MIB文件hwTrunkIfID该节点标识Trunk接口号。1.3.6.1.4.1.2011.5.25.41.1.3.3.1.2MIB表节点HUAWEI-IF-EXT-...
  • 1、应客户的反馈,需要搭建一个旁路IDS的环境。简单了解下,是在交换机上做Monitor接口,使被监控的流量到IDS设备上进行分析。从客户需求上看貌似应该不难。... 交换机A(trunk接口)(trunk接口)交换机B  
  • [HCNA]VLAN配置Trunk接口

    2018-04-13 22:58:27
    实验目的 1.掌握Trunk端口的配置 2.掌握Trunk端口允许所有VLAN通过的配置方法 3.掌握Trunk端口允许特定VLAN通过的配置方法 4.理解干道链路的应用场景 ...VLAN的划分配置Trunk接口 1拓扑图 ...
  • 3.2配置trunk接口

    2021-03-19 16:05:43
    配置trunk接口原理概述一、实验目的及编址二、实验拓扑二、实验内容配置双工模式1.配置ip地址做ping通测试总结与思考 原理概述 在以太网中通过划分vlan来隔离广播域和增强网络通信安全性。 为了使交换机的vlan帧能...
  • Vlan的trunk接口实验

    2014-10-22 13:57:14
    1:trunk接口在收到报文帧中携带vlan标记时,判断本端口是否允许该vlan标记的报文通过。如果允许则报文携带原有的vlan标记进行转发,否则丢弃该报文。2:如果收到的报文帧中不携带vlan标记,则为该报文打上vlan标记...
  • 下面分别介绍Access接口、Trunk接口、Hybrid接口对收发数据帧的处理过程。 说明: QinQ接口可以给帧加上双层Tag,即在原来Tag的基础上,给帧加上一个新的Tag,具体处理过程请参见“QinQ配置”,本节不再赘述。 ...
  • Trunk接口的使用

    2014-11-04 18:35:34
    配置Trunk端口,使vlan可以互通 转载于:https://blog.51cto.com/19940911/1571812
  • 主要介绍了交换机三种端口模式Access、Hybrid和Trunk的理解,需要的朋友可以参考下
  • Eth-trunk

    千次阅读 2021-10-29 09:40:52
    Eth-trunk(端口绑定技术)是将一组物理接口捆绑在一起,来增加带宽,又称为多接口负载均衡组或链路聚合组。 一、Eth-trunk的概念 1、Eth-trunk的作用 把两台设备之间建立链路聚合组,可以提供更高的通讯带宽和更...
  • 可以类似于vlan和trunk接口, 可以对数据帧不打vlan标签和不打标签。 ●实验目的 通过配置交换机SW1和SW2不同接口的access、trunk、hybrid属性,实现PC1能和PC2互通,PC2能和PC4互通,PC3能和PC4互通。 ●需求分析 1...
  • 链路聚合Eth-Trunk

    2021-08-12 08:43:16
    目录 一,链路聚合定义 二,链路聚合实现的条件 三,链路聚合划分 四,二层链路捆绑步骤 ...端口捆绑技术:链路聚合是将一组物理接口捆绑一起作为一个逻辑接口来增加带宽的一...1,每个eth-trunk接口下最多可包含8个.
  • Trunk端口一般用于交换机之间连接的端口。它可以承载多个不同VLAN数据,不属于任何一个具体的VLAN。 拓扑图: 步骤: 1.基本配置: 如拓扑图所示,配置各个物理设备和接口,并完成连通性测试。 2.创建VLAN,配置...
  • Eth-Trunk(链路聚合)

    千次阅读 2021-01-24 12:50:38
    Trunk接口连接的链路可以看成是一条点到点的直连链路 ,在一个Trunk内 ,可以实现流量负载分担,同时也提供了更高的连接可靠性和更大的带宽。用户通过对逻辑口进行配置,实现各种路由协议以及其它业务部署。 三个优势...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 28,391
精华内容 11,356
关键字:

trunk接口