精华内容
下载资源
问答
  • 在技术领域中把TRUNK翻译为中文是“主干、干线、中继线、长途线” ,不过一般不翻译,直接用原文。  在网络的分层结构和宽带的合理分配方面,TRUNK被解释为“端口汇聚”,是带宽扩展和链路备份的一个重要途径。...
  • 交换机access与trunk

    千次阅读 2019-02-22 11:45:12
    交换机access与trunk口 理论知识:    以太网端口二种链路类型:Access 和Trunk。    Access 类型的端口:只能属于1 个VLAN,一般用于连接计算机的端口;  Trunk 类型的端口:可以允许多个VLAN 通过,...

    交换机access与trunk口

    理论知识:

           

           以太网端口二种链路类型:Access 和Trunk。

     

          Access 类型的端口:只能属于1 个VLAN,一般用于连接计算机的端口;

          Trunk 类型的端口:可以允许多个VLAN 通过,可以接收和发送多个VLAN 的报文,一般用于交换机之间连接的端口;

     

          交换机接口出入数据处理过程如下:

          《一》

               1. Acess 端口收报文:

               收到一个报文,判断是否有VLAN 信息:如果没有则打上端口的PVID,并进行交换转发,如果有则直接丢弃(缺省)

               (Access接受并转发的数据包必须是无VLAN信息的数据包)

               2. Acess 端口发报文:

               将报文的VLAN 信息剥离,直接发送出去

               (Access发送的数据报必定是无VLAN信息的数据包)

               总结:

               Access 端口可接受并转发的数据来源:来自PC的无VLAN信息数据包;从一个Access口入打上VLAN标记在交换机内转交给相同VLAN的access口去掉标记的无VLAN信息数据包;

               Access 端口发送出去的数据包无VLAN信息,可被PC接受或Access口接受。

               

              

                PC2与PC3能够相互 ping通,PC1与PC2,PC3不能 ping通,与上述结论相符合。

     

          《二》

     

                1.trunk 端口收报文:

                收到一个报文,判断是否有VLAN 信息;

                 如果有,判断该trunk 端口是否允许该VLAN 的数据进入;

                         如果可以则转发,否则丢弃;

                如果没有VLAN 信息则打上端口的PVID,并进行交换转发。

                (可以将trunk口看做是access口功能上的扩充,对于有VLAN信息的数据包Access直接丢弃,而Trunk则会对有指定VLAN的数据包直接转发)

                2.Trunk 端口发报文:

                比较将要发送报文的VLAN 信息和端口的PVID;

                如果不相等则直接发送;

                如果两者相等则剥离VLAN 信息,再发送。

                (Access口发数据包时对所有数据包去除VLAN信息,而Trunk只对与自己端口PVID相等(Trunk默认PVID与VLAN1相等)的数据包去VLAN信息,其他则直接转发)

               

                 总结:

                 结合Trunk口接受与发送数据包特点,可以得出经双绞线相连的一对Trunk口或同一交换机上的两个Trunk口可以将数据包(有或无VLAN信息)原封不动的从一端传到另一端。

                 

                   图中PC1 - PC3; PC2 - PC6; PC4 - PC5 之间可以ping通,与上述总结相符合

    展开全文
  • Eth-Trunk

    2021-04-12 15:22:26
    以太网链路聚合Eth-Trunk简称 链路聚合,它通过将 多条 以太网物理链路捆绑在一起成为一条 逻辑链路,从而实现 增加链路带宽 的目的。 同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效地 提高链路的可靠...

    链路聚合

    以太网链路聚合Eth-Trunk简称 链路聚合,它通过将 多条 以太网物理链路捆绑在一起成为一条 逻辑链路,从而实现 增加链路带宽 的目的。
    同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效地 提高链路的可靠性。
    在这里插入图片描述

    Eth-Trunk的技术背景

    1.STP/MSTP:调节流量----STP太多造成难以维护----不推荐
    2.升级链路带宽 ,万兆光模块成本高----不推荐

    Eth-Trunk的实现

    将两条或多条物理链路,从逻辑上合并成一条链路来维护
    以太信道组的建立
    手动模式 和 LACP (802.3AD)
    手工模式下,Eth-Trunk的建立、成员接口的加入由手工配置,没有链路聚合控制协议LACP的参与。当需要在两个直连设备之间提供一个较大的链路带宽而设备又不支持LACP协议时,可以使用手工模式。
    手工模式可以实现增加 带宽、提高可靠性和负载分担的目的。
    在这里插入图片描述

    Eth-Trunk 技术原理

    手工负载分担模式:
    当两台设备中至少有一台不支持LACP协议时,可使用手工负载分担模式的Eth-Trunk来增加设备间的带宽及可靠性。
    手工强制指定,Eth-trunk内的所有接口都要进行流量转发,并且每条链路的流量负载均衡
    mode Manuel load-balance
    在这里插入图片描述

    lacp模式:

    在这里插入图片描述
    LACP模式也称为M:N模式,其中M条链路处于活动状态转发数据,N条链路处于非活动状态作为备份链路。
    图中设置的活跃链路数为2,即2条链路处于转发状态,1条链路处于备份状态,不转发数据,只有当活跃的链路出现故障时,备份链路才进行转发。
    mode lacp-static (相当于 lacp的on模式)

    端口的负载分担:

    逐流负载分担

    逐流的负载分担这种机制把数据帧中的地址通过 HASH算法生成HASH-KEY值,然后根据这个数值在Eth-Trunk转发表中寻找对应的出接口,不同的MAC或IP地址HASH得出的HASH-KEY值不同,从而出接口也就不同,这样既保证了同一数据流的帧在同一条物理链路转发,又实现了流量在聚合组内各物理链路上的负载分担。逐流负载分担能保证包的顺序,但不能保证带宽利用率。

    逐包负载分担(不推荐)

    逐包的负载分担在使用Eth-Trunk转发数据时,由于聚合组两端设备之间有多条物理链路,就会产生同一数据流的第一个数据帧在一条物理链路上传输,而第二个数据帧在另外一条物理链路上传输的情况。这样一来同一数据流的第二个数据帧就有可能比第一个数据帧先到达对端设备,从而产生 接收数据包乱序 的情况。

    为了 避免 数据包 乱序 情况的发生,Eth-Trunk采用 逐流负载分担 的机制,其中如何转发数据则由于选择不同的负载分担方式而有所差别。
    负载分担的方式主要包括以下几种,用户可以根据具体应用选择不同的负载分担方式。
    -根据报文的源MAC地址进行负载分担
    -根据报文的目的MAC地址进行负载分担
    -根据报文的源IP地址进行负载分担
    -根据报文的目的IP地址进行负载分担
    -根据报文的源MAC地址和目的MAC地址进行负载分担
    -根据报文的源IP地址和目的IP地址进行负载分担

    Eth-Trunk的配置

    配置手工负载分担模式

    在这里插入图片描述

    [SWA]interface Eth-Trunk 1 
    [SW1-Eth-Trunk1]mode manual load-balance     //指定手工配置的静态模式
    [SWA-Eth-Trunk1]interface GigabitEthernet0/0/1
    [SWA-GigabitEthernet0/0/1]eth-trunk 1
    [SWA-GigabitEthernet0/0/1]interface GigabitEthernet0/0/2
    [SWA-GigabitEthernet0/0/2]eth-trunk 1
    [SW2-Eth-Trunk1] trunkport GigabitEthernet 0/0/1 0/0/2  等价于上面的四行命令
    
    配置LACP模式
     interface Eth-Trunk2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     mode lacp-static        //指定动态LACP模式
     trunkport GigabitEthernet  0/0/1 0/0/2 //将物理接口加入逻辑接口
     max active-linknumber 2    //最大激活链路数量
     lacp preempt enable        //LACP抢占启用
     lacp timeout slow                //周期30秒
     lacp timeout fast              //周期1秒
     lacp priority 4096 
    

    查看链路聚合信息
    在这里插入图片描述

    LACP模式的抢占机制

    在这里插入图片描述

    Eth-trunk的优点

    增加带宽

    链路聚合接口的最大带宽可以达到各成员接口带宽之和。

    提高可靠性

    当某条活动链路出现故障时,流量可以切换到其他可用的成员链路上,从而提高链路聚合接口的可靠性。互为备份。

    负载分担

    在一个链路聚合组内,可以实现在各成员活动链路上的负载分担。

    展开全文
  • 三层交换和trunk-link

    2020-02-07 16:53:47
    s1: vlan batch 10 [s1-Ethernet0/0/1]dis this # interface Ethernet0/0/1 port link-type access port default vlan 10 # [s1-Eth-Trunk1]dis this # interface Eth-Trunk1 ... port trunk ...

    在这里插入图片描述
    s1:

    vlan batch 10
    [s1-Ethernet0/0/1]dis this
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 10
    #
    [s1-Eth-Trunk1]dis this
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 2 to 4094
    #
    

    s3:

    vlan batch 20
    [s3-Ethernet0/0/1]dis this
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 20
    #
    [s3-Eth-Trunk2]dis this
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk pvid vlan 20
     port trunk allow-pass vlan 2 to 4094
    #
    

    s2:

    vlan batch 10 20 50
    [s2-Eth-Trunk1]dis this
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 2 to 4094
    #
    [s2-Eth-Trunk2]dis this
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk pvid vlan 20
     port trunk allow-pass vlan 2 to 4094
    #
    [s2-Eth-Trunk3]dis this
    #
    interface Eth-Trunk3
     port link-type access
     port default vlan 50
     mode lacp-static
    #
    
    ip route-static 192.168.60.0 255.255.255.0 192.168.50.2
    

    r1:

    [r1-Eth-Trunk3]dis this
    [V200R003C00]
    #
    interface Eth-Trunk3
     undo portswitch
     ip address 192.168.50.2 255.255.255.0 
     mode lacp-static
    #
    ip route-static 0.0.0.0 0.0.0.0 192.168.50.1
    

    需要注意的是:
    (1)s1和s2 以及 s3和s2是trunk,且都要配置
    (2)s2和r1,s2配置为access, r1不用配置
    (3)r1要 undo portswitch,Eth-Trunk3是二层链路,需要切换到三层链路,以便进行ip地址配置等

    展开全文
  • VLAN与Trunk的原理及配置VLAN详解一、VLAN概述1、VLAN的概念及优势2、静态VLAN3、静态VLAN的配置二、VLAN Trunk1、Trunk概述2、Trunk的配置 VLAN详解 一、VLAN概述 VLAN(Virtual Local Area Network)的中文名为...

    VLAN详解

    一、VLAN概述

    VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。IEEE于1999年颁布了用于标准化VLAN实现方案的802.1Q协议标准草案。VLAN技术的出现,使得管理员根据实际应用需求,把同一物理局域网内的不同用户逻辑地划分成不同的广播域,每一个VLAN都包含一组有着相同需求的计算机工作站,与物理上形成的LAN有着相同的属性。由于它是从逻辑上划分,而不是从物理上划分,所以同一个VLAN内的各个工作站没有限制在同一个物理范围中,即这些工作站可以在不同物理VLAN网段。

    1、VLAN的概念及优势

    一个VLAN就是一条单独的广播域(局域网)
    分割广播域有两种方法:
    1、物理分割
    将网络从物理上划分为若干个小网络,然后使用能隔离广播的路由设备将不同的网络连接起来实现通信。
    2、逻辑分离
    将网络从逻辑上划分为若干个小的虚拟网络,即VLAN。VLAN工作在OSI参考模型的数据链路层,一个VLAN就是一个交换网络,其中的所有用户都在一个广播域中,各VLAN通过路由设备的连接实现通信。

    由VLAN的特点可知,一个VLAN内部的广播和单播流量都不会转发到其他VLAN中,VLAN具有灵活性和可扩展性等特点,使用VLAN技术有以下好处:

    1、控制广播
    2、提高网络的安全性
    3、简化网络管理

    2、静态VLAN

    VLAN分为静态VLAN和动态VLAN,基于端口划分静态VLAN,基于MAC地址划分动态VLAN。目前较常见的是静态VLAN实现方式。
    静态VLAN即明确指定交换机的端口属于哪一个VLAN,这需要网络管理员手动配置。当用户主机连接到交换机端口上时,就被分配到了对应的VLAN中。这种端口和VLAN的映射只在本地有效,交换机之间不能共享这一信息。
    在这里插入图片描述

    3、静态VLAN的配置

    VLAN有4096个,0和4095不可用,1为默认范围2~4094。

        <Huawei>system-view
        
        [Huawei] sysname sw1
        
        [sw1]dis vlan    ###显示当vlan信息
        [sw1]vlan 10    ###添加
        [Sw1-vlan10]q   ###退出
        [sw1]vlan batch 20 30 40    ###批量添加
        [sw1]undo vlan 10    ###删除
    
      #####将端口加入VLAN,Access口只能属于1个VLAN,一般用于连接计算机端口。
        [Huawei]int e0/0/0    ###(进入接口模式)
        [ Huawei-Etherneto/0/0]port link-type access  ###(定义二层揣口为access模式)
        [Huawei-Ethernet0/0/0]port default vlan 10   ###(将端口加入到vlan中)
        
        [Huawei-Ethernet0/0/0]undo shutdown   ###开启当前接口
        
        [Huawei-Ethernet0/0/0]undo port default vlan   ###将端口从vlan删除
        [ Huawei-Ethernet0/0/0]port link-type hybrid   ### (将端口类型恢复成默认的hybrid模式)
        [Huawei-Ethernet0/0/0]dis this   ###  查看当前端口模式、状态
        
        同时将多个端口加入VLAN
        [Huawei] port-group 1(新增组1)
        [Huawei-port-group-l]group-member Ethernet 0/o/l to Ethernet 0/0/20   ###(组1的成员是e0/0/1到e0/0/20)
        [Huawei-port-group-1]port link-type access
        [Huawei-port-group-l]port default vlan 30
        
        端口恢复默认配置,注意,执行完命令后,接口会被shutdown
        [Huawei]clear configuration interface e0/0/1
        [Huawei]dis vlan 10   ###查看指定VLAN信息
        
      

    二、VLAN Trunk

    1、Trunk概述

    VLAN Trunk(虚拟局域网中继技术)是指能让连接在不同交换机上的相同VLAN中的主机互通。
    VLAN Trunk只使用一条链路,且通过标识来区分不同的VLAN数据。如果交换机1的VLAN1中的机器要访问交换机2的VLAN1中的,我们可以把两台交换机的直连端口设置为Trunk端口,这样,当交换机把数据包从级联口发出去的时候,会在数据包中做一个标记(TAG),以使其它交换机识别该数据包属于哪一个VLAN,这样,其它交换机收到这样一个数据包后,只会将该数据包转发到标记中指定的VLAN,从而完成了跨越交换机的VLAN内部数据传输。
    在这里插入图片描述

    2、Trunk作用

    1.VLAN在实际环境中的应用。在实际的企业环境中,不只是使用一台交换机,而是多台交换机共同作用。每台交换机都划分VLAN,且这些VLAN可能在多个交换机上是重复的;
    2.连接不同交换机的VLAN。为几个VLAN都连接一条物理的链路,只需要用一条中继链路承载所有的VLAN通信;
    3.链路的类型
    (1)接入链路:接入链路是属于一个并且只属于一个VLAN的端口;
    (2)中继链路:中继链路可以承载多个VLAN。
    在这里插入图片描述

    3、IEEE 802.1q的帧标识

    IEEE 802.1q的帧标识(4字节):2字节标识协议标识符(TPID)包含一个0x8100的固定值,这个特定的TPID值指明了该帧带有EE 802.1q的标识信息。
    2字节标识控制信息(TCI)包含了下面的3个元素:
    ●3位的用户优先级(Priority):IEEE802.1q不使用该字段。
    ●1位的规范格式标识符(CFI):CFI常用于以太网和令牌环网。在以太网中,CFI的值通常设置为0。
    ●12位VLAN标识符(VLANID):该字段唯一标识了帧所属的VLAN。VLANID可以唯一地标识4096个VLAN,但VLANO和VLAN4095是被保留的。
    在这里插入图片描述

    4、Trunk的配置

    Access接口类型是用于交换机与主机相连;
    Trunk是用于交换机与交换机相连的接口类型。

      #####Trunk类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN报文,一般用于交换机与交换机相关的接口。
        [Huawei]int e0/0/0
        [Huawei-Etherneto/o/0]port link-type trunk   ###(定义二层端口为trunk模式)
        [Huawei-Etherneto/o/o]port trunk allow-pass vlan 10 2030   ###(配置Trunk端口允许通过的vlan)
        [Huawei-Etherneto/o/o]undo shutdown
        [Huawei-Etherneto/o/o]undo port trunk allow-pass vlan 10    ###禁止Trunk传送某个VLAN的数据,删除这个VLAN
        

    Hybrid port华为独有的接口类型
    Access portTrunk port 国际通用接口类型
    Access一般是用于交换机与主机或路由器相连的接口类型(打标签)
    Trunk一般是用于交换机与交换机相连的接口类型(识别标签)

    展开全文
  • 解释清楚Vlan和Trunk的作用

    千次阅读 2021-01-04 22:32:15
    vlan(Virtual LAN),翻译成中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成的企业网络。VLAN所指的LAN特指使用路由器分割的网络——也就是广播域。 在此之前让我们...
  • TRUNK的作用功能.什么是TRUNK

    万次阅读 2016-03-22 22:42:30
    在技术领域中把TRUNK翻译为中文是“主干、干线、中继线、长途线” ,不过一般不翻译,直接用原文。而且这个词在不同场合也有不同的解释:  1、 在网络的分层结构和宽带的合理分配方面,TRUNK被解释为
  • VLAN(Virtual LAN),翻译成中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成的企业网络。VLAN所指的LAN特指使用路由器分割的网络——也就是广播域。在此让我们先...
  • 这里转发一下这个标准:《Trunk Based Development 主干开发模型》。 Preface 在之前的博文中我们介绍了 Git Flow 分支模型,正如文中所说,Git Flow 偏向于控制管理,使用了较多的分支,流程颇为复杂。大量的团队...
  • 1、trunk是主分支,是日常开发进行的地方。 2、branches是分支。一些阶段性的release版本,这些版本是可以继续进行开发和维护的,则放在branches目录中。又比如为不同用户客制化的版本,也可以放在分支中进行开发。 ...
  • Trunk的精解,分析tagged和untagged

    千次阅读 2013-06-19 17:16:41
    在接触其他厂商设备的时候无疑都使用cisco...例如,cisco的干道端口叫做trunk,而其他的厂商并不是如此,他们叫tagged port,而cisco的访问端口叫做access port,而其他厂家叫做untagged port。所以当您遇到命令行或者菜单
  • VTP(VLAN Trunking Protocol):是VLAN中继协议,也被称为虚拟局域网干道...在技术领域中把TRUNK翻译为中文是“主干、干线、中继线、长途线” ,不过一般不翻译,直接用原文。而且这个词在不同场合也有不同的解释。
  •  输入 Switch(config-if)#swicthport mode trunk 想改变端口为trunk 模式时 报出错误  Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "...
  • 一个有态度的优质教程集聚地 帮助过上万位网友解决教程需求问题 教程仅用于学习交流,禁止用于商业交易©猜您喜欢往期精选▼ 华为题库(含vce和讲解视频) | 2019年最新华为HCNA-HNTD(H12-211)中文过人版题库 干货 | ...
  • 这里我以laravel框架为例子 git使用小...name tag_name //把标签做成分支 操作依旧是,右键主干目录,找到创建标签(小乌龟有中文语言包,自行安装),创建之后 打包之后,我们就把这个版本包导出,然后正式发布线上
  • TRUNK本身中文含义就是:干线, 树干, 躯干, 箱子, 主干, 象鼻之意?那么在换句话来说它就是可以承载一些东西的意思,同样在网络中它也起到了一个承载作用,它可以承载多个VLAN,使不同交换设备的同一VLAN进行通信。  ...
  • 首先我们可以在trunk目录下面的空白处,或是直接在trunk的icon下面按下鼠标右键。 在选择Branch/Tag…这个项目后,您将会看到如下的对话框出现。 请先确认From WC at URL: 中的目录是您要复制的来源目录。...
  • 1.trunk是主分支,是日常开发进行的地方。2.branches是分支。一些阶段性的release版本,这些版本是可以继续进行开发和维护的,则放在branches目录中。又比如为不同用户客制化的版本,也可以放在分支中进行开发。3....
  • 网络基本功(三):细说VLAN与Trunk 转载请在文首保留原文出处:EMC中文支持论坛https://community.emc.com/go/chinese 介绍 网络性能是影响业务效率的一个重要因素。将大型广播域分段是提高网络性能的方法之一。...
  • 交换机的端口工作模式一般可以分为三种:Access,Multi,Trunk(树干)。 trunk模式的端口用于交换机与交换机,交换机与路由器,大多用于级联网络设备。 Access多用于接入层也叫接入模式。主要是将端口静态接入。 ...
  • Trunk Based Development,缩写为TBD,中文就是基于主干的开发。 什么是TBD,无需太多文字,看下图即可(来源http://paulhammant.com/2013/04/05/what-is-trunk-based-development/): 有人反映看不大懂,...
  • TRUNK

    2010-12-09 15:51:53
    在技术领域中把TRUNK翻译为中文是“主干、干线、中继线、长途线” ,不过一般不翻译,直接用原文。而且这个词在不同场合也有不同的解释: 1、 在网络的分层结构和宽带的合理分配方面,TRUNK被解释为“端口汇聚”,...
  • 本次实验总共由三组小实验组成,由简到难分别为VLAN的设置、Trunk中继链路的设置以及最终的三层交换机设置。 二、一、VLAN的设置(需所有pc机在同一网段下) VLAN(Virtual Local Area Network)的中文名为"虚拟...
  • VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。VLAN是一种将局域网设备从逻辑上划分成一个个网段,从而实现虚拟工作组的新兴数据交换技术。这一新兴技术主要应用于交换机和路由器中,但主流应用还是...
  •  VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。VLAN是一种将局域网设备从逻辑上划分成一个个网段,从而实现虚拟工作组的新兴数据交换技术。这一新兴技术主要应用于交换机和路由器中,但主流应用还是...
  • 本次实验总共由三组小实验组成,由简到难分别为VLAN的设置、Trunk中继链路的设置以及最终的三层交换机设置。 一、VLAN的设置(需所有pc机在同一网段下) VLAN(Virtual Local Area Network)的中文名为"虚拟局域网...
  • Trunk中文翻译为“主干”的意思,在项目运作过程中,日常的开发和管理资料都在此目录中进行维护和更新。 2 Branches Branches的中文意思为“分支”,在项目运作过程中,存放阶段性成果(版本),这些阶段性...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 8,626
精华内容 3,450
关键字:

trunk的中文