精华内容
下载资源
问答
  • 目录一、RIP路由1.1 RIP路由基础1.2 根据距离向量确定路由1.3 RIP的优缺点1.4 RIP路由配置1.5 RIP配置实验干货分享精彩链接最后 一、RIP路由 1.1 RIP路由基础 路由信息协议(RIP)是内部网关协议中使用较为广泛的...

    有理想,有抱负,相信在不久的将来你会成功的!

    打开微信搜索【孩子上学后】,关注这个不一样的程序员。

    一、RIP路由

    1.1 RIP路由基础

    路由信息协议(RIP)是内部网关协议中使用较为广泛的协议,它是一种分布式、基于距离向量的路由选择协议。

    RIP将路由控制信息(30秒1次)向全网广播。如果没有收到路由控制信息,连接就会断开。不过,这可能是丢包导致的,因此规定RIP等待5次。如果等了6次(180秒)仍未收到路由信息,才会真正关闭连接。

    1.2 根据距离向量确定路由

    RIP基于距离向量算法决定路径。距离的单位为“跳数。跳数是指所经过路由的个数。RIP希望尽可能少的通过路由器将数据包转发到目标IP地址。

    1.3 RIP的优缺点

    在默认情况下,RIP不考虑不考虑带宽、时延等因素,只考虑距离,距离就是通往目的站点所经过的链路数,也称为跳数,跳数越小路径越佳。RIP最小路径称为最佳路径。RIP的跳数取值为1~15,数值16表示无穷大。

    • 优点

      简单,没有复杂的配置选项

    • 缺点

      有最大跳数限制,因此只适合小型互联网络,不适合大型网络;路由更新收敛速度慢,不适合变化剧烈的互联网络。

    1.4 RIP路由配置

    RIP动态东路协议的配置主要包括基本配置和高级配置,配置命令格式如下:

    (1)router rip

    启动RIP协议,并开启RIP进程。

    (2)version1或2

    RIP有两个版本:RIP1和RIP2,RIP1不支持可变长掩码,因此交换路由信息时,不在更新报文中携带子网掩码。RIP2支持可变长掩码、多点广播路由更新和路由更新认证功能。

    (3)network网络地址

    设置RIP协议的网络地址,在设置RIP路由时要注意,network后面的网络地址是指与本路由器直接连接的网络地址,与静态路由完全不同,在静态路由中,路由器的目标网络是与路由器不直接连接的网络,两者正好相反。

    1.5 RIP配置实验

    配置思路

    • 由于要在小型网络中实现设备的网络互联,所以推荐配置RIP路由协议
    • 配置各个连接口的IP地址,使网络可达。
    • 在各个路由器上使用RIP,基本实现网络互联。
    • 在各个路由器上配置RIP2版本,提升RIP路由拓展性能。

    拓扑

    搭建好了拓扑之后,可以配置每个路由端口和PC机的IP地址

    PC1配置

    pc1

    PC2配置

    PC2

    R1配置

    <Huawei>sys	
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info	
    [Huawei]undo info-center en	
    [Huawei]undo info-center enable 
    Info: Information center is disabled.
    [Huawei]inter	
    [Huawei]interface g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add	
    [Huawei-GigabitEthernet0/0/1]ip address 192.168.1.254 24
    [Huawei-GigabitEthernet0/0/1]inter g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add	
    [Huawei-GigabitEthernet0/0/0]ip address 192.168.2.1 24
    [Huawei-GigabitEthernet0/0/0]
    

    R2配置

    <Huawei>sys	
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo in	
    [Huawei]undo info-center en	
    [Huawei]undo info-center enable 
    Info: Information center is disabled.
    [Huawei]inter	
    [Huawei]interface g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add	
    [Huawei-GigabitEthernet0/0/0]ip address 192.168.2.2 24
    [Huawei-GigabitEthernet0/0/0]inter g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add	
    [Huawei-GigabitEthernet0/0/1]ip address 192.168.3.1 24
    [Huawei-GigabitEthernet0/0/1]
    

    R3配置

    <Huawei>sys	
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo in	
    [Huawei]undo info-center en	
    [Huawei]undo info-center enable 
    Info: Information center is disabled.
    [Huawei]inter	
    [Huawei]interface g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add	
    [Huawei-GigabitEthernet0/0/1]ip address 192.168.3.2 24
    [Huawei-GigabitEthernet0/0/1]inter g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add	
    [Huawei-GigabitEthernet0/0/0]ip address 192.168.4.254 24
    [Huawei-GigabitEthernet0/0/0]
    

    接下来就是在各个路由器上配置RIP

    R1配置RIP

    <Huawei>sys	
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]rip 1
    [Huawei-rip-1]version 2
    [Huawei-rip-1]netwo	
    [Huawei-rip-1]network 192.168.1.0
    [Huawei-rip-1]network 192.168.2.0
    

    R2配置RIP

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]rip 1
    [Huawei-rip-1]version 2
    [Huawei-rip-1]network 192.168.3.0
    [Huawei-rip-1]network 192.168.2.0
    

    R3配置RIP

    [Huawei]rip 1
    [Huawei-rip-1]version 2
    [Huawei-rip-1]networ	
    [Huawei-rip-1]network 192.168.3.0
    [Huawei-rip-1]network 192.168.4.0
    [Huawei-rip-1]
    

    测试

    测试

    从上图可以看到,由PC1到PC2可以ping通,说明本次的RIP协议配置成功!

    干货分享

    打开微信搜索【孩子上学后】

    回复【ensp命令参考手册】,即可获取华为模拟器ensp命令参考手册!

    回复【RIP路由协议】,即可获取配置文件!

    精彩链接

    教你使用华为Ensp模拟器配置静态路由

    最后

    从本次配置上来看,RIP协议相对于静态路由来说是简单很多的,只需要配置与路由相邻的网段即可。

    这次的笔记分享到这里就结束了,更多精彩内容我们下期再见!

    路漫漫其修远兮,吾将上下而求索!

    我是啃书君,一个专注于学习的人,你懂得越多,你不懂的越多。

    更多精彩内容,我们下期再见!

    展开全文
  • 华为模拟器eNSP动态路由协议RIP

    千次阅读 2021-01-12 18:41:43
    动态路由信息协议RIP配置RIP命令;测试路由器之间联通情况;Wireshark抓包分析e/0/0/0。

    一、动态路由信息协议RIP

    动态路由信息协议RIP(Routing Information Protocol):它是一种基于距离矢量
    (Distance-Vector)算法的协议,使用跳数作为度量来衡量达到目的网络的距离。RIP主要用于规模较小的网络中,收敛速度很慢。
    工作原理:路由器运行RIP 后,首先会发送路由更新请求,收到请求的路由会发送自己的RIP路由进行响应。网络稳定后,路由器会周期性(30秒)发送路由更新信息,目标地址是224.0.0.9的组播地址,报文存放的的是路由信息。RIP的默认优先级Pre是100,RIP只看路由远近,距离以跳数(经过路由器的个数)来衡量,最大跳数不能超过15跳,经过16跳的路由器不可达。
    抑制接口:又称静默接口,配置接口为抑制状态,发送但不接收RIP路由更新报文,抑制接口通常用于接PC端路由器,如R1的Ethernet0/0/1接口,其优先级大于RIP Input和RIP Output。
    [R1]rip
    [R1-rip-1]silent-interface e0/0/1
    华为路由器拓扑图

    二、配置RIP命令

    如上图所示,在配置好R1、R2和R3路由器各个接口IP地址后再配置RIP协议。

    (一)配置路由器RI的RIP路由

    [R1]rip 1 #RIP进程号
    [R1-rip-1]version 2 #使用RIP 2版本
    [R1-rip-1]network 192.168.1.0 # 宣告直连类网路
    [R1-rip-1]network 12.0.0.0 # 宣告直连类网路
    [R1-rip-1]undo summary #关闭路由自动汇总
    [R1-rip-1]display this

    rip 1
    undo summary
    version 2
    network 192.168.1.0
    network 12.0.0.0

    return

    (二)配置路由器R2的RIP路由

    [R2]rip 1
    [R2-rip-1]version 2
    [R2-rip-1]undo summary
    [R2-rip-1]network 12.0.0.0
    [R2-rip-1]network 23.0.0.0
    [R2-rip-1]network 172.16.0.0
    [R2-rip-1]display this

    rip 1
    undo summary
    version 2
    network 12.0.0.0
    network 23.0.0.0
    network 172.16.0.0

    (三)配置路由器R3的RIP路由

    [R3]rip 1
    [R3-rip-1]version 2
    [R3-rip-1]undo summary
    [R3-rip-1]network 23.0.0.0
    [R3-rip-1]network 10.0.0.0
    [R3-rip-1]display this

    rip 1
    undo summary
    version 2
    network 23.0.0.0
    network 10.0.0.0

    (四)抑制路由器R1接口E0/0/1

    RIP Input和RIP Output。
    [R1]rip
    [R1-rip-1]silent-interface e0/0/1

    三、测试路由器之间联通情况

    PC1终端ping路由器R3

    四、Wireshark抓包分析e/0/0/0

    抓包分析e/0/0/0
    Wireshark抓包路由器接口

    展开全文
  • 在eNSP模拟器上实现RIP基本配置

    千次阅读 2021-06-01 23:51:09
    在eNSP模拟器上实现RIP基本配置拓扑图设备选型配置思路操作步骤配置说明结果验证 拓扑图 设备选型 四台路由器均为AR2220型路由器,如果AR2220型号路由器启动失败,也可使用Router型号路由代替,不过需要注意端口...

    拓扑图

    在这里插入图片描述

    设备选型

    四台路由器均为AR2220型路由器,如果AR2220型号路由器启动失败,也可使用Router型号路由代替,不过需要注意端口类型的不同,AR2220型号路由器使用千兆口(GigabitEthernet)互联,Router型号路由一般使用百兆口(Ethernet)互联。

    配置思路

    1.完成各路由器的基本配置(命名+接口IP)

    2.在每个路由器上进行RIP协议相关配置(进入协议视图,修改协议版本,宣告网段)

    操作步骤

    1.路由器命名&接口IP地址配置,具体配置脚本如下:
    AR1:

     sysname R1
    #
    interface GigabitEthernet0/0/0
     ip address 10.0.12.1 255.255.255.0 
    

    AR2:

     sysname R2
    #
    interface GigabitEthernet0/0/0
     ip address 10.0.12.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 172.16.23.2 255.255.255.0 
    

    AR3:

     sysname R3
    #
    interface GigabitEthernet0/0/0
     ip address 172.16.23.3 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.34.3 255.255.255.0 
    

    AR4:

     sysname R4
    #
    interface GigabitEthernet0/0/0
     ip address 192.168.34.4 255.255.255.0 
    

    2.在每个路由器上进行RIP协议配置
    AR1:

    rip 1                               //进入协议视图
     version 2                          //修改协议版本
     network 10.0.0.0                   //宣告网段
    

    AR2:

    rip 1
     version 2
     network 10.0.0.0
     network 172.16.0.0
    

    AR3:

    rip 1
     version 2
     network 172.16.0.0
     network 192.168.34.0
    

    AR4:

    rip 1
     version 2
     network 192.168.34.0
    

    配置说明

    1.网段宣告方式
    RIP在宣告网段时会采取主类掩码宣告,简而言之就是根据不同类别的网段采取不同的宣告方式:

    如果是A类(看网段的第一段数字是否在1-126区间),则只需宣告第一段数字即可,后续用0补充;

    如果是B类(看网段的第一段数字是否在128-191区间),则只需宣告前两段数字即可,后续用0补充;

    如果是C类(看网段的第一段数字是否在192-223区间),则只需宣告前三段数字即可,后续用0补充

    2.协议版本区别
    与RIP-1相比,RIP-2具有以下优势:

    支持外部路由标记(Route Tag),可以在路由策略中根据Tag对路由进行灵活的控制。

    报文中携带掩码信息,支持路由聚合和CIDR(Classless Inter-Domain Routing)。

    支持指定下一跳,在广播网上可以选择到目的网段最优下一跳地址。

    支持以组播方式发送更新报文,只有支持RIP-2的设备才能接收协议报文,减少资源消耗。

    支持对协议报文进行验证,增强安全性。

    结果验证

    在这里插入图片描述

    展开全文
  • eNsp华为模拟器 ospf配置实验

    千次阅读 2020-05-02 00:10:33
    ②network宣布地网段是自己的直连网段(与rip相同),但是需要加上反掩码 一、实验拓扑图搭建 二、配置过程 1、配置pc1、pc2的IP地址和网关。 PC1: PC2: 2、配置各个端口的ip地址 [R1]int g0/0/2 [R1-Giga...

    基础ospf协议配置需要注意地点:
    ①在启用ospf时,需要声明area区域,在同一个区域内才能通信。(要实现不同区域的配置我后面扩展中有写)
    ②network宣布地网段是自己的直连网段(与rip相同),但是需要加上反掩码
    一、实验拓扑图搭建
    在这里插入图片描述
    二、配置过程
    1、配置pc1、pc2的IP地址和网关。
    PC1:
    在这里插入图片描述
    PC2:
    在这里插入图片描述
    2、配置各个端口的ip地址
    [R1]int g0/0/2
    [R1-GigabitEthernet0/0/2]ip address 212.102.11.2 24
    [R1]int Loopback 1
    [R1-LoopBack 1]ip Baddress 172.16.0.1 24

    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip address 10.0.0.1 8
    [R2]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip address 192.168.0.1 24
    [R2]int g0/0/2
    [R2-GigabitEthernet0/0/2]ip address 212.102.11.1 24

    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip address 10.0.0.2 8
    [R3]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip address 192.168.1.1 24
    3、启用ospf协议
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    三、测试结果
    在这里插入图片描述
    在这里插入图片描述

    扩展下:

    OSPF不同area之间通信

    拓扑图:
    在这里插入图片描述
    各个端口p地址配置这里就不写了。
    主要看看怎么实现不同area间通信的。

    首先我们先看看配置前的ospf路由表
    这里只截图R3配置上ospf配置
    在这里插入图片描述
    配置完后:
    在这里插入图片描述
    主要实现方法就是R3这个边界路由器需要增加一条配置:
    在这里插入图片描述

    这样就可以全网通了。

    展开全文
  • eNSP 华为模拟器 acl配置实验

    千次阅读 2020-05-08 16:42:58
    ACL基础配置实验 ACL:访问控制列表 ACL可分为基础ACL和扩展ACL 基础ACL是对源ip地址进行过滤 ...华为(eNSP) RIP实验实验配置过程 在全网可以ping通的情况下我们开始配置acl 基础ACL配置:(在A...
  • 大家好! 我叫风清云淡,有句话说“相识是缘”,我也希望多多认识一些志同道和的朋友。作为一名互联网行业的小萌新,写博客一方面是为了...文章目录实验十四 RIP实验内容实验步骤实验十五 配置RIPV2 认证实验内容实验步骤
  • 华为模拟器ipv6接口配置本实验所需命令:1.ipv62.ipv6 enable3.ipv6 address ??????4.display ipv6 interface g ?/?/?(用来查看ipv6配置是否正确全球单播地址为3001::1/64和3001::2/64实验需求:让路由器有ipv6转发...
  • 华为交换机RIP配置实验

    千次阅读 2018-01-22 16:46:24
    给上图四台路由器分别配置接口IP地址;分别用版本2,开启summary,配置...验证命令查看当前路由协议R1#show ip route 查看路由表R1#show ip route rip仅仅查看RIP路由条目 转载于:https://blog.51cto.com/13...
  • 要求 1.按照拓扑所示,搭建网络环境,进行设备重命名 2.根据pc机给定地址信息,完成各自ip地址、网关地址计算及配置 3.采用RIP协议+静态路由实现pc1、2、3互通
  • 华为网络配置RIP

    千次阅读 多人点赞 2021-11-03 09:21:37
    二、RIP配置 1、案例 2、配置过程 (1)AR1 (2)AR2 (3)AR3 3、测试 (1)PC1 (2)PC2 结语 前言 在动态路由协议中,由于RIP的实现较为简单,在配置和维护管理方面也远比OSPF和IS-IS容易,因此RIP...
  • 华为模拟器里使用RIP协议跨越主类网络边界的实验现象 实验1:使用RIPv1协议跨越主类网络边界 Step1:输入必打命令 <Huawei>undo terminal monitor(关闭自动弹窗) <Huawei>system-view (进入系统...
  • 、网关1.1、概述1.2、网关1.3、默认网关1.4、网关的值二、mac、ip、port三类地址2.1、端口号2.2、常见端口号介绍2.3、MAC地址2.4、IP地址2.5 、...路由3.2、路由表3.3、静态路由和动态路由四、静态路由的配置实例最后...
  • 华为路由器配置RIP协议

    千次阅读 2020-01-06 16:42:06
    1、路由器基本配置 R1: <Huawei>system-view [Huawei]sysname R1 [R1]interface g0/0/0 [R1-GigabitEthernet0/0/0]ip address 10.10.10.1 255.255.255.0 [R1-GigabitEthernet0/0/0]interface g0/0/1 [R1-...
  • RIP路由协议 概念:RIP(Routing Information Protocol,路由信息协议)是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法...
  • 目录一、OSPF的简单概述1.1 OSPF是链路状态型路由协议1.2 OSPF基础知识1.3 OSPF工作原理描述二、OSPF的特点三、ospf单区域配置实验3.1 网络拓扑图3.2 IP地址配置3.3 OSPF配置四、实验结果测试五、最后 一、OSPF的...
  • 华为ENSP下配置RIP协议实验

    万次阅读 多人点赞 2018-12-05 11:11:41
    华为ENSP下配置RIP协议实验 1.组网要求 要求实现4台路由器网络互联。 2.配置思路 ①由于要在小型网络中实现设备的网络互联,所以推荐配置RIP路由协议。 ②配置各接口IP地址,使网络可达。 ③在各路由器上使能RIP,...
  • 192.168.1.96/27 192.168.1.10 000000/26 --R2环回 192.168.1.10 0 00000/27 -192.168.1.128/27 192.168.1.10 1 00000/27 -192.168.1.160/27 192.168.1.11 000000/26 3、配置命令: RIP配置: [r1]rip 1 --- 启动...
  • 静态路由的原理与配置、动态路由 路由技术: 二层(数据链路层)——交换机:mac地址、mac地址表(转发数据的依据)。 三层(网络层)——路由器:IP地址、路由表(数据转发表)。 一、路由表的主要作用: ...
  • ospf与rip的重分发,在之前的基础上,添加了使用RIPv2协议的R6 Step1:如图所示,敲必打命令与设置IP地址。 R1: <Huawei>undo terminal monitor <Huawei>system-view [...
  • 华为模拟器命令

    2021-05-30 19:31:40
    interface 进入命令 如果有此设备或者配置表示进入此设备或者配置 没有则表示创建此设备或配置 display 查看(show) interface Eth-Trunk 1 创建链路聚合 ID为1(全局模式下) eth-trunk 1 加入链路聚合1(端口模式...
  • 【eNSP 华为模拟器】DHCP中继的配置与抓包分析 拓扑图 拓扑图 拓扑 DHCP服务器的配置 <Huawei>sys Enter system view, return user view with Ctrl+Z. [Huawei]undo info-center enable Info: Information ...
  • 使用华为ENSP模拟器验证OSPF导入RIP路由,附上幕布笔记链接 https://share.mubu.com/doc/5HCTFQztRen
  • 大家好! 我叫风清云淡,有句话说“相识是缘”,我也希望多多认识一些志同道和的朋友。作为一名互联网行业的小萌新,写博客一方面是为了记录自己的学习过程,另一方面是总结自己所犯的错误...实验十六 连接RIP 与OSPF网
  • 目录前言一、关闭泛洪信息二、静态路由命令例题三、动态路由(一)RIP协议RIP命令例题(二)OSPF协议OSPF命令例题(单区域)例题(多区域)四、查看全局路由表结语 前言 本章笔记将讲述如何配置静态路由、动态路由...
  • 华为ensp模拟器RIP

    2021-04-06 09:37:34
    RIP v2的配置 注:需要关闭自动汇总(undo summary),宣告的为主内网络 RIP v1的配置 3.在R6上做RIP2对RIP1的接收实现全网可达 先进接口G0/0/2,再将RIP1的导入RIP2中 最终即可实现用RIP实现全网可达 ...
  • 【eNSP 华为模拟器配置 NAT Easy - IP 与 RIPv2 一、拓扑图和实验结果 二、路由器配置 三、抓包分析 一、拓扑图和实验结果 从pc1 ping 到pc2 二、路由器配置 路由器AR1配置: [R1]int g0/0/0 [R1-...
  • 目录 一、常用的查看配置命令 二、提高敲命令速度的小技巧 2.1按tab键补齐命令 或者 直接键入简写 2.2如何快速给PC等终端设备手动配置ip地址、掩码和网关 2.3取消某些命令的配置 2.4给路由器配置serial口 2.5ensp...
  • 使用华为的HW-RouteSim路由模拟器配置RIP计算机网络实验,教会你配置RIP动态路由!
  • 文章目录前言一、 OSPF的基本原理1.1 OSPF区域化结构1.2 OSPF报文类型1.3 多区域OSPF网络二、 OSPF多区域配置示例三、精彩链接四、最后 前言 与RIP协议一样,OSPF也是一种IGP。通常,我们把一个以OSPF协议作为其IGP...
  • 华为模拟器eNSP基本命令

    万次阅读 多人点赞 2018-06-01 19:56:39
    华为模拟器eNSP常用命令 最近一段了解网络协议,使用了华为模拟器eNSP搭建了几个路由实验,分享一下在搭建过程中,经常使用的命令. 路由器命令行常用命令: 1. system-view 进入系统视图,默认我们打开命令行前面...

空空如也

空空如也

1 2 3 4 5 ... 18
收藏数 349
精华内容 139
关键字:

华为模拟器rip的配置